Учебник по MQL4
MetaQuotes Sofware Corp.
  • Предисловие
  • Содержание
  • Введение в MQL4
  • Основы языка
  • Редактор MetaEditor
  • Программа на MQL4
  • Операторы
  • Переменные
  • Программирование на MQL4
  • Торговые операции
  • Простые программы на MQL4
  • Стандартные функции
  • Создание обычной программы
  • О сложных программах
  • Приложения
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)
Сергей Ковалёв

Программирование на алгоритмическом языке

Вводный курс

В настоящее время персональный компьютер стал незаменимым помощником в жизни каждого человека. Благодаря развитию Интернета и увеличению мощности современных компьютеров открылись новые возможности во многих областях деятельности. Ещё десять лет назад торговля на финансовых рынках была доступна только банкам и узкому кругу специалистов.

Торговый терминал MetaTrader 4, созданный компанией MetaQuotes Software Corp, по достоинству оценили сотни тысяч трейдеров во всем мире. Использование встроенного языка программирования MQL4 выводит трейдеров на качественно новый уровень торговли - автотрейдинг. Теперь трейдер может реализовать свои идеи в виде прикладной программы - самостоятельно написать пользовательский индикатор, скрипт для выполнения разовых операций или создать советник - автоматическую торговую систему (торговый робот).

Многомесячная автономная работа советника без вмешательства человека на сегодняшний день – уже реальность. Это доказал проводимый ежегодно Чемпионат Automated Trading Championship, на котором в течение 3 месяцев соревнуются сотни автоматических торговых систем.

Составление прикладных программ для торгового терминала MetaTrader 4 требует знания языка MQL4. Язык программирования MetaQuotes Language 4 – это уже язык четвертого поколения, который был также разработан компанией MetaQuotes Software Corp. на основании собственного многолетнего опыта. MQL4 – это первый язык программирования, учитывающий все тонкости при совершении торговых операций на финансовых рынках.

Документация по языку доступна на сайте компании, кроме того - растет и развивается MQL4.community, где можно пообщаться с другими трейдерами, почитать статьи, написанные самими трейдерами, скачать программы MQL4 в исходных кодах.

Настоящее учебное пособие представляет собой вводный курс, освоив который, можно самостоятельно создавать эксперты, скрипты и индикаторы, воплощая в них свои идеи - алгоритмы прибыльной торговли. Учебник рассчитан на широкий круг читателей, не имеющих навыков программирования и желающих научиться самостоятельно создавать прикладные программы для автоматического трейдинга с использованием клиентского терминала MetaTrader 4.

Предисловие
© 2000-2008, MetaQuotes Software Corp. Все права защищены.


Предисловие - Учебник по MQL4

Учебник по MQL4 [image] Предисловие
  • Предисловие
  • Содержание
  • Введение в MQL4
  • Основы языка
  • Редактор MetaEditor
  • Программа на MQL4
  • Операторы
  • Переменные
  • Программирование на MQL4
  • Торговые операции
  • Простые программы на MQL4
  • Стандартные функции
  • Создание обычной программы
  • О сложных программах
  • Приложения
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Предисловие

Некоторая сложность в написании учебного пособия по программированию для начинающих состоит в том, что рассматриваемая область знания содержит новые понятия, ни на чём привычном не основанные.

Вообще говоря, подобная проблема возникает и в любой другой области знаний. Например, известно, что точка в математике определяется как бесконечно малая окружность, в то время как сама окружность - это совокупность расположенных определённым образом точек. Легко заметить, что эти термины определены через самих себя. Вместе с тем, эта нечаянность не стала в математике камнем преткновения. И окружности, и точки, и линии, а вместе с ними другие термины, принятые в математике, благополучно сосуществуют. Более того, каждому человеку интуитивно понятно, что такое точка, а что - окружность.

Нетрудно выяснить, что подавляющее большинство привычных нам понятий имеют неопределённые границы, причём некоторые из них настолько размыты, что ставят под сомнение существование самого явления или объекта, обозначенного этим понятием. Однако природа человека такова, что эти странные, с позиции обычной логики, обстоятельства не мешают его существованию и плодотворной деятельности. После того как очередное понятие используется в течение некоторого времени, оно обретает для нас законченный смысл. Трудно ответить на вопрос, каким образом и почему это происходит. Известно только, что немаловажную роль в замечательном процессе овладения понятиями играет многократное обращение к ним.

В данной работе были поставлены следующие задачи:

  • раскрыть содержание новых понятий, подобрав общеизвестные аналогии;
  • сделать значение каждого нового термина интуитивно понятным при первом чтении;
  • предоставить в распоряжение читателя необходимое количество информации для характеристики программ и самого процесса программирования.
С этой целью в учебник включено достаточное количество примеров и рисунков. В тексте имеются перекрёстные ссылки, обеспечивающие возможность получения информации по смежным вопросам.

Несколько слов о методе изложения материала. Некоторые учебники по программированию на первых страницах содержат призыв напечатать с помощью простой программы фразу "Здравствуй, мир". Их авторы предполагают, что читатель с самого начала процесса обучения должен обращаться к текстам программ, постепенно привыкая к их внешнему виду, и впоследствии легче воспринимать материал. Однако при таком подходе читателю приходится одновременно иметь дело с несколькими незнакомыми понятиями и лишь догадываться о содержании и свойствах некоторых строк программы. А это может привести к ошибочному их пониманию и, следовательно, к пробелам в знаниях.

На мой взгляд, более эффективным следует считать метод обучения, при котором читатель переходит к очередному разделу учебника лишь после того, как он прочно усвоил предшествующий материал. В рамках такого метода первая программа предлагается читателю к рассмотрению лишь тогда, когда он овладел необходимыми понятиями и получил представление об общих принципах построения программ. Именно на такой основе построен настоящий учебник.

Для изучения материала, представленного в учебнике, читателю достаточно владеть персональным компьютером на уровне пользователя, а также иметь некоторый опыт работы с программой MetaTrader 4 компании MetaQuotes Software Corp.

«Выражаю искреннюю благодарность генеральному директору компании MetaQuotes Software Corp. Ренату Фатхуллину за доверие, профессиональную поддержку и всемерное содействие, а также сотрудникам компании Станиславу Старикову и Рашиду Умарову за ценные консультации и помощь при подготовке учебника.»

Сергей Ковалёв
http://autograf.dp.ua

Учебник по MQL4Содержание


Содержание - Учебник по MQL4

Учебник по MQL4 [image] Содержание
  • Предисловие
  • Содержание
  • Введение в MQL4
  • Основы языка
  • Редактор MetaEditor
  • Программа на MQL4
  • Операторы
  • Переменные
  • Программирование на MQL4
  • Торговые операции
  • Простые программы на MQL4
  • Стандартные функции
  • Создание обычной программы
  • О сложных программах
  • Приложения
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Содержание

Предисловие

Введение в программирование на языке MQL4

Основы языка MQL 4

  • Некоторые основные понятия
  • Константы и Переменные
  • Типы данных
  • Операции и выражения
  • Операторы
  • Функции
  • Виды программ

Редактор MetaEditor

  • Файловая система
  • Создание и использование программ

Программа на MQL4

  • Структура программы
  • Специальные функции
  • Выполнение программы
  • Примеры реализации

Операторы

  • Оператор присваивания
  • Условный оператор if-else
  • Оператор цикла while
  • Оператор цикла for
  • Оператор break
  • Операторы continue
  • Оператор switch
  • Вызов функции
  • Описание функции и оператор return

Переменные

  • Предопределённые переменные и функция RefreshRates
  • Виды переменных
  • Переменные GlobalVariables
  • Массивы

Практическое программирование на языке MQL4

Программирование торговых операций

  • Общий порядок проведения торговых операций
  • Характеристики ордеров и правила проведения торговых операций
  • Открытие и установка ордеров
  • Закрытие и удаление ордеров. Функция OrderSelect
  • Модификация ордеров

Простые программы на MQL4

  • Использование технических индикаторов
  • Простой эксперт
  • Создание пользовательских индикаторов
  • Пользовательский индикатор скорости изменения цены
  • Совместное использование программ

Стандартные функции

  • Общие функции
  • Графические объекты
  • Операции с графиками
  • Строковые функции и преобразование данных
  • Дата и время
  • Файловые операции
  • Операции с массивами и доступ к таймсериям
  • Математические функции
  • Глобальные переменные GlobalVariables
  • Пользовательские индикаторы
  • Клиентский терминал, проверка состояния и информация о счёте
  • Торговые функции

Построение обычных программ

  • Структура обычной программы
  • Учёт ордеров
  • Информационная функция
  • Функция слежения за событиями
  • Функция определения количества лотов
  • Функция определения торговых критериев
  • Торговые функции
  • Функция обработки ошибок

Общая характеристика сложных программ

Приложения

  • Словарь терминов
  • Типы торговых операций
  • Требования и ограничения при проведении торговых операций
  • Коды ошибок
  • Стили отображения индикаторных линий
  • Типы и свойства графических объектов
  • Звуковые файлы
  • Коды возврата функции MessageBox
  • Идентификаторы запроса, используемые в функции MarketInfo()
  • Список программ
ПредисловиеВведение


Введение в MQL4 - Учебник по MQL4

Учебник по MQL4 [image] Введение в MQL4
  • Предисловие
  • Содержание
  • Введение в MQL4
  • Основы языка
  • Редактор MetaEditor
  • Программа на MQL4
  • Операторы
  • Переменные
  • Программирование на MQL4
  • Торговые операции
  • Простые программы на MQL4
  • Стандартные функции
  • Создание обычной программы
  • О сложных программах
  • Приложения
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Введение в программирование на языке MQL4

Приступая к изучению программирования на языке MQL4, необходимо обозначить общие границы наших интересов. Прежде всего отметим, что обсуждаемые в учебнике программы могут использоваться только как прикладные программы для работы в клиентском терминале MetaTrader 4. Чтобы понять, какую роль эти программы играют в практике управления торговлей, рассмотрим рис. 1.

Рис. 1. Программа на MQL4 в составе клиентского терминала MetaTrader 4.

Если вы интересуетесь программированием на MQL4, вы, вероятнее всего, уже знакомы с клиентским терминалом. Клиентский терминал - это часть информационно-торговой системы. В состав этой системы входит также сервер, устанавливаемый в дилинговом центре. Дилинговый центр, в свою очередь, имеет средства связи с другими участниками рынка - банками и финансовыми организациями.

В клиентском терминале имеется информационная среда - набор параметров, информирующих о состоянии рынка и отношениях между трейдером и дилинговым центром. Она содержит сведения о текущих ценах, ограничениях по минимальному и максимальному размеру ордера, минимальной дистанции стоп-приказов, разрешении/запрете осуществлять автоматическую торговлю и множество других полезных параметров, характеризующих текущую ситуацию. Информационная среда обновляется с поступлением в терминал новых тиков (зелёная стрелка на рис. 1).

Встроенные средства

В клиентском терминале имеются встроенные средства, позволяющие проводить технический анализ рынка и осуществлять ручное управление торговлей. Для анализа рынка могут применяться технические индикаторы и различные линейные инструменты - линии поддержки/сопротивления, трендовые каналы, уровни Фибоначчи и др.

Для ручного управления торговлей используется панель управления ордерами. С помощью этой панели трейдер может открывать, закрывать и модифицировать ордера. Кроме того, в клиентском терминале имеется возможность автоматически управлять положением стоп-приказов рыночных ордеров. В результате воздействия трейдера на встроенные средства управления торговлей в клиентском терминале формируются торговые приказы (ордера), которые отправляются на сервер.

Для получения подробной информации о работе клиентского терминала необходимо обратиться к "Руководству пользователя" (каталог_терминала\Terminal_russian.chm).

Программные средства

Технический анализ рынка и управление торговлей в клиентском терминале MetaTrader 4 могут также осуществляться с помощью программных средств. Язык MQL4 позволяет создавать такие программы. Различают три вида прикладных программ, создаваемых на языке MQL4 и предназначенных для работы в клиентском терминале:

  • пользовательский индикатор - программа для графического отображения каких-либо закономерностей на рынке, написанная в соответствии с авторским алгоритмом;
  • эксперт (советник, Expert Advisor) - программа, позволяющая механизировать значительную часть торговых операций или полностью автоматизировать торговлю;
  • скрипт - программа для выполнения одноразовых действий, в том числе — осуществления торговых операций.

На рис. 1 видно, что прикладная программа имеет те же средства доступа к информационной среде клиентского терминала, что и встроенные средства для ручной торговли (синие стрелки), а также может формировать управляющие воздействия (красные стрелки), сообщаемые в клиентский терминал. Программы разных видов могут использоваться одновременно и при этом обмениваться данными. С помощью этих приложений программист может механизировать значительную часть торговых операций или создать робот, способный осуществлять торговлю без вмешательства трейдера.

Прикладные программы и ручные средства управления могут использоваться в клиентском терминале одновременно, взаимно дополняя друг друга.

Основополагающая техническая особенность торговли c помощью информационно-торговой системы MetaTrader состоит в том, что все управляющие воздействия формируются в клиентском терминале и отправляются на сервер. Прикладные программы (эксперт, скрипт, индикатор) могут работать только в составе клиентского терминала при условии его подключения к серверу (дилинговому центру). На сервере никакие прикладные программы не устанавливаются.

Сервер позволяет лишь обрабатывать приказы, поступающие со стороны клиентского терминала. Если клиентский терминал отключён от Интернета или запущенная в нём прикладная программа (эксперт или скрипт) по каким-то причинам не генерирует управляющие воздействия, то на сервере ничего происходить не будет.

Круг наших интересов будут составлять программы (эксперты, скрипты и пользовательские индикаторы), позволяющие вести механизированную или полностью автоматизированную торговлю и значительно расширяющие информационное сопровождение торговли (см. рис. 1). В представленном учебнике будет рассказано, из чего состоит программа, каковы основные правила составления и использования программ. Мы также детально рассмотрим примеры программ и параметры информационной среды клиентского терминала, доступные программе во время её исполнения.

Программы для автоматического трейдинга имеют гораздо больше потенциальных возможностей, чем ручные средства управления торговлей.

В подавляющем большинстве случаев программа позволяет существенно облегчить труд трейдера, избавив его от необходимости непрерывно в течение длительного срока находиться возле монитора для наблюдения за развитием рынка. Она также может помочь снизить нервную нагрузку и уменьшить количество ошибок, возникающих в период сильного эмоционального напряжения. Но главное — применение программного способа управления торговлей позволяет разработать собственные идеи и проверить их на исторических данных, подобрать оптимальные параметры для применения этих идей, а в конечном итоге — реализовать на практике продуманную торговую стратегию.

ПредисловиеОсновы языка MQL4


Некоторые основные понятия - Основы языка - Учебник по MQL4

Учебник по MQL4 [image] Основы языка [image] Некоторые основные понятия
MetaQuotes Sofware Corp.
  • Некоторые основные понятия
  • Константы и переменные
  • Типы данных
  • Операции и выражения
  • Операторы
  • Функции
  • Виды программ
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Некоторые основные понятия

Итак, предметом нашего интереса является программа, написанная на языке MQL4. Перед тем как мы приступим к детальному изучению правил построения программ, необходимо обозначить основные понятия, характеризующие программу и её взаимоотношения с информационной средой. Известно, что клиентский терминал MetaTrader 4 работает в интерактивном режиме. Ситуация на финансовом рынке постоянно меняется, и это находит своё отражение на графиках финансовых инструментов в клиентском терминале. Информацию об изменениях цен на рынке в клиентский терминал приносят тики.

Понятие тика

Тик — это событие, характеризующееся новой ценой по финансовому инструменту в некоторый момент времени.

Поставщиком тиков для каждого клиентского терминала является сервер, установленный в дилинговом центре. В зависимости от ситуации на рынке тики могут поступать часто или редко, но каждый из них несёт новую котировку - стоимость единицы одной валюты, выраженную в единицах другой валюты.

Прикладная программа, работающая в составе клиентского терминала, может находиться в работе в течение длительного периода, например, несколько дней или недель. Каждая прикладная программа исполняется в соответствии с правилами, установленными для программ определённого вида. Эксперт, например, не работает всё время безостановочно. Обычно эксперт запускается в работу в момент, когда приходит новый тик. По этой причине мы охарактеризовали тик не просто как новую котировку, а как событие, которое обрабатывается клиентским терминалом.

Продолжительность работы эксперта зависит от того, какой программный код в него заложен. Обычные эксперты завершают один цикл обработки информации в течение десятых или сотых долей секунды. За это время эксперт может обработать какие-то параметры, принять торговое решение, сообщить полезную информацию трейдеру и т.д. Отработав, эксперт переходит в режим ожидания тика. Новый тик снова запускает эксперт на выполнение, программа снова выполняет заложенные в неё операции и снова переходит в режим ожидания тика. Как именно появление нового тика влияет на работу программ, будет более подробно описано далее.

Понятие управления

Говоря о последовательности выполнения кода в программе и её взаимодействии с клиентским терминалом, мы будем использовать термин "управление".

Управление — это процесс выполнения действий, предопределённых алгоритмом программы и свойствами клиентского терминала. Управление может передаваться внутри программы от одной программной строки к другой, а также между программой и клиентским терминалом.

Передача управления больше всего напоминает передачу права произносить речь на собрании от одного оратора к другому в нашей обычной жизни. Подобно тому, как ораторы выступают на собрании и передают друг другу слово, клиентский терминал и программа передают друг другу управление. Причём клиентский терминал играет главенствующую роль. Его статус выше, чем у программы, так же как полномочия председателя собрания выше, чем у рядового оратора.

Пока программа не запущена в работу, управление находится в ведении клиентского терминала. В момент, когда появляется новый тик, клиентский терминал передаёт управление программе. С этого момента начинается исполнение программного кода.

Клиентский терминал, передавший управление программе, не останавливает свою работу. Он продолжает полноценно работать в течение всего времени, пока он запущен на компьютере. Программа же может начать работать только в тот момент, когда клиентский терминал передал ей управление (подобно тому, как председатель собрания управляет собранием всё время, а текущий оратор держит слово только в течение ограниченного времени).

По окончании своей работы программа возвращает управление клиентскому терминалу и не может быть запущена по собственной инициативе. Однако с момента, когда управление передано программе, она сама возвращает управление клиентскому терминалу. Иными словами, клиентский терминал не может сам вернуть себе управление из программы. Исключение составляют активные действия пользователя (например, принудительное завершение программы).

При обсуждении вопросов, связанных с работоспособностью и внутренним устройством программ, нас главным образом будет интересовать та часть управления, которая передаётся внутри программы. Обратимся к рис. 2, на котором показан общий характер передачи управления в программу, из программы и внутри неё. Кружки на представленном рисунке характеризуют некоторые небольшие, логически завершённые фрагменты программы, а стрелки между ними - передачу управления от одного фрагмента к другому.

Рис. 2. Передача управления в программе

Программа, получившая управление от клиентского терминала (исполняющаяся программа), начинает выполнять некоторые действия в соответствии с заложенным в неё алгоритмом. Программа содержит программные строки; общий порядок исполнения программы состоит в последовательной передаче управления от одной строки к другой в направлении сверху вниз. Что и по каким правилам может быть написано в этих строках, будет подробно рассмотрено в последующем изложении.

Здесь же важно подчеркнуть, что каждый логически завершённый фрагмент исполняется - например, производятся какие-либо математические вычисления, выводится текст сообщения на экран, формируется торговый приказ и пр. До тех пор пока текущий фрагмент программы не выполнен, он удерживает управление. После того как он выполнен полностью, управление передаётся следующему фрагменту. Таким образом, управление внутри программы передаётся от одного логически завершённого фрагмента к другому по мере их исполнения. Когда будет исполнен последний фрагмент, программа передаст (вернёт) управление клиентскому терминалу.

Понятие комментария

Программа состоит из двух видов записей: тех, которые составляют собственно программу, и тех, которые являются лишь пояснительным текстом к ней.

Комментарий - это необязательная и неисполняемая часть программы.

Комментарий - это необязательная часть программы. Готовая программа будет работать в соответствии с заложенным в неё кодом независимо от того, есть в ней комментарии или нет. Однако комментарии очень облегчают понимание кода программы. Они могут быть однострочными и многострочными. Однострочный комментарий - это любая последовательность символов, перед которой стоят две косые черты (//). Признак однострочного комментария заканчивается вместе с переводом строки. Многострочный комментарий начинается символами /* и заканчивается символами */ (см. рис. 3).

Комментарии используются для пояснения кода программы. Хорошая программа всегда содержит комментарии.

Рис. 3. Примеры комментариев в программе.

Комментарии широко используются при написании программ. В коде они обычно отражаются серым цветом. Мы также будем использовать комментарии для пояснений в программах, чтобы сделать их содержание более понятным.

Основы языка MQL4Константы и переменные


Операции и выражения - Основы языка - Учебник по MQL4

Учебник по MQL4 [image] Основы языка [image] Операции и выражения
MetaQuotes Sofware Corp.
  • Некоторые основные понятия
  • Константы и переменные
  • Типы данных
  • Операции и выражения
  • Операторы
  • Функции
  • Виды программ
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Операции и выражения

Чтобы понять, какое значение имеют в языке MQL4 операции и выражения, не требуется никаких особых аналогий. Практически это - то же самое, что операции и выражения в простой арифметике. Каждому человеку понятно, что в записи f = n + m элементы f, n и m являются переменными, значки = и + являются знаками операций, а n + m - выражением.

В предыдущем параграфе мы познакомились с необходимостью представления разных типов данных. Теперь нам предстоит разобраться, в каких отношениях между собой эти данные могут находиться (квадратные метры по-прежнему нельзя складывать с яблоками). В MQL4 имеются естественные ограничения и правила использования операций в выражениях.

Понятия "операнд", "операция", "знак операции" и "выражение"

Операнд - это константа, переменная, элемент массива или значение, возвращаемое функцией (понятие "функция" рассматривается в разделе Функции, понятие "массив" - в разделе Массивы; на данном этапе обучения достаточно понимать под операндами уже известные нам константы и переменные).

Операция - это действие, производимое над операндами.

Знак операции - предопределённый символ или группа символов, предписывающие выполнить некоторую операцию.

Выражение - последовательность операндов и знаков операций - запись в программе, вычисленное значение которой характеризуется типом данных.

Виды операций

В языке MQL4 различают следующие виды операций:

  • арифметические операции;
  • операции присваивания;
  • операции отношения;
  • логические операции;
  • побитовые операции;
  • операция запятая;
  • вызов функции.

Операции применяются в операторах (см. Операторы), только при этом их использование имеет смысл и реализуется в программе. Возможность использования операций определяется свойствами операторов (если свойства оператора позволяют применять конкретную операцию, то её можно использовать, в противном случае использовать данную операцию нельзя). Использование операций за пределами операторов запрещено.

Арифметические операции

К символам арифметических операций относятся следующие:

Символ | Операция | Пример | Аналог
+ | Сумма величин | x + 2 |
- | Вычитание величин или изменение знака | x - 3, y = - y |
* | Умножение величин | 3 * x |
/ | Частное от деления | x / 5 |
% | Остаток от деления | minutes = time % 60 |
++ | Добавление 1 к значению переменной | y++ | y = y + 1
-- | Вычитание 1 из значения переменной | y-- | y = y - 1

Операции присваивания

К символам операций присваивания относятся следующие:

Символ | Операция | Пример | Аналог
= | Присваивание значения x переменной y | у = x |
+= | Увеличение значения переменной у на x | у += x | y = y + x
-= | Уменьшение значения переменной y на x | y -= x | y = y - x
*= | Умножение значения переменной y на x | y *= x | y = y * x
/= | Деление значения переменной y на x | y /= x | y = y / x
%= | Остаток от деления значения переменной y на x | y %= x | y = y % x

Операции отношения

К символам операций отношения относятся следующие:

Символ | Операция | Пример
== | Истина, если x равно y | x == y
!= | Истина, если x не равно y | x != y
< | Истина, если x меньше y | x < y
> | Истина, если x больше y | x > y
<= | Истина, если x меньше или равно y | x <= y
>= | Истина, если x больше или равно y | x >= y

Логические операции

К символам логических операций относятся следующие:

Символ | Операция | Пример | Пояснения
! | НЕ (логическое отрицание) | ! х | ИСТИНА(1), если значение операнда ЛОЖЬ(0), и ЛОЖЬ(0), если значение операнда не ЛОЖЬ(0).
|| | ИЛИ (логическое ИЛИ) | x < 5 || x > 7 | ИСТИНА(1), если истинно любое из значений
&& | И (логическое И) | x == 3 && y < 5 | ИСТИНА(1), если истинны все значения

Побитовые операции

Побитовые операции выполняются только с целыми числами. К побитовым операциям относятся следующие:

Дополнение значения переменной до единицы. Значение выражения содержит 1 во всех разрядах, в которых значения переменной содержат 0, и 0 во всех разрядах, в которых значения переменной содержат 1.

b = ~n;

Двоичное представление x сдвигается вправо на y разрядов. Сдвиг вправо логический, то есть освобождающиеся слева разряды будут заполняться нулями.

x = x >> y;

Двоичное представление x сдвигается влево на y разрядов; освобождающиеся справа разряды заполняются нулями.

x = x << y;

Побитовая операция И двоичных представлений x и y. Значение выражения содержит 1 (ИСТИНА) во всех разрядах, в которых и x, и y содержат не ноль; и 0 (ЛОЖЬ) во всех остальных разрядах.

b = ((x & y) != 0);

Побитовая операция ИЛИ двоичных представлений x и y. Значение выражения содержит 1 во всех разрядах, в которых x или y не содержат 0, и 0 - во всех остальных разрядах.

b = x | y;

Побитовая операция "исключающее ИЛИ" (eXclusive OR) двоичных представлений x и y. Значение выражения содержит 1 в тех разрядах, в которых x и y имеют разные двоичные значения, и 0 - во всех остальных разрядах.

b = x ^ y;

Операция запятая

Выражения, разделённые запятыми, вычисляются слева направо. Все побочные эффекты вычисления левого выражения могут возникать до вычисления правого выражения. Тип и значение результата совпадают с типом и значением правого выражения.

for(i=0,j=99; i<100; i++,j--) Print(array[i][j]); // Оператор цикла

В качестве примера можно рассматривать список передаваемых параметров (будет рассмотрено далее).

My_function (Alf, Bet, Gam, Del) // Вызов функции с аргументами

Операторы и функции рассматриваются в разделах Операторы, Функции и в главе Операторы.

Вызов функции

Вызов функции подробно рассматривается в разделе Вызов функции.

Вызов функции подробно рассматривается в соответствующем разделе.

Операции над однотипными операндами

Если бы ученику начальной школы сообщили, что, решая задачу о количестве карандашей, он должен строить свои рассуждения на таких понятиях, как операнды, операции и выражения, он, наверное, счёл бы, что от него хотят невозможного. Глядя на символы операций, кто-то может решить, что программирование - некий таинственный, сложный процесс, доступный только избранным. На самом деле в программировании нет ничего сложного, достаточно лишь разобраться в сущности нескольких понятий. Чтобы в этом убедиться, рассмотрим несколько примеров.

Задача 1. У Васи 2 карандаша, у Пети 3 карандаша. Сколько всего карандашей у мальчиков?:)

Решение. Обозначим количество карандашей у Васи как переменную А, количество карандашей у Пети – как переменную В, а результат – через переменную С.

Ответ будет таким: С = А + В

В разделе Типы данных мы рассматривали варианты объявления переменных. Карандаши - это предметы, т.е. нечто такое, что в принципе может существовать в виде части (половина карандаша, например). Поэтому карандаши будем учитывать как действительные переменные, т.е. переменные типа double.

Программный код можно записать, например, так:

   double A = 2.0;                       // Количество карандашей у Васи
   double B = 3.0;                       // Количество карандашей у Пети
   double C = A + B;                     // Общее количество

В данном случае показательным моментом является применение операции "+" для нахождения суммы значений однотипных переменных.

Типом значения выражения

   A + B

будет тип тех переменных, которые составляют выражение, в данном случае - тип double.

Аналогичным будет ответ для разности величин (на сколько больше карандашей у Пети, чем у Васи?):

   double A = 2.0;                       // Количество карандашей у Васи
   double B = 3.0;                       // Количество карандашей у Пети
   double C = B - A;                     // Разность действительных чисел

Подобным образом используются и другие арифметические операции:

   double C = B * A;                     // Умножение действ. чисел
   double C = B / A;                     // Деление действительных чисел

Аналогичные вычисления могут производиться и с целыми числами.

Задача 2. Ученики выходят к доске для ответа. Вася выходил 2 раза, Петя выходил 3 раза. Сколько всего раз мальчики выходили к доске?

Решение. Обозначим количество ответов Васи как переменную Х, количество ответов Пети как переменную Y, а результат - через Z.

В этом примере необходимо использовать тип целых переменных int, т.к. мы учитываем события, являющиеся целыми по своей сути (невозможно выйти для ответа полтора или полраза; сам ответ может быть плохим или хорошим, но в данном случае нас интересует только количество ответов).

Решение задачи можно записать так:

   int X = 2;                           // Количество ответов Васи
   int Y = 3;                           // Количество ответов Пети
   int Z = X + Y;                       // Общее количество

В случае вычисления разности, произведения и частного от деления целых чисел знак операции "-" используется так же просто:

   int X = 2;                           // Целое число
   int Y = 3;                           // Целое число
   int Z = Y - X;                       // Разность целых чисел
   int Z = Y * X;                       // Произведение целых чисел
   int Z = Y / X;                       // Частное от деления целых чисел

С переменными типа string возникает несколько иная ситуация:

Задача 3. На одном углу дома расположен гастроном с названием "Северный". На другом углу дома расположено заведение под названием "Парикмахерская". Требуется определить, что написано на доме.

Решение. В MQL4 разрешено складывать значения строковых констант и переменных. В случае сложения переменных типа string строки просто приплюсовываются друг к другу в той последовательности, в которой они упоминаются в выражении.

Нетрудно составить код программы, которая вычислила бы интересующий нас результат:

 string W1  = "Северный";                     // Строка 1
 string W2  = "Парикмахерская";               // Строка 2
 string Ans = W1 + W2;                        // Сумма строк

Значением переменной Ans будет строка следующего вида:

СеверныйПарикмахерская

Получилось несколько неказистое с виду, но в полной мере правильно образованное значение строкового типа. Разумеется, для практического использования в подобных случаях необходимо предусматривать пробелы и др. знаки пунктуации.

Любые другие арифметические операции с переменными строкового типа запрещены:

 string Ans= W1 - W2;                        // Не допускается
 string Ans= W1 * W2;                        // Не допускается
 string Ans= W1 / W2;                        // Не допускается

Приведение типов

Приведение типов - это изменение (преобразование) типа значения операнда или выражения. Перед выполнением операций (кроме операций присваивания) происходит преобразование в тип, имеющий наибольший приоритет, а перед операциями присваивания - в целевой тип.

Рассмотрим несколько задач, касающихся приведения типов.

Задача 4. У Васи 2 карандаша, Петя выходил для ответа 3 раза. Сколько всего?

Некорректность этого вопроса с точки зрения формальной логики очевидна. Здравый смысл нам подсказывает, что суммировать события с предметами нельзя, что это неправильно.

Задача 5. На одном углу дома расположен гастроном с названием "Северный", а у Васи 2 карандаша.:)

С одинаковой степенью безысходности (с точки зрения обычных рассуждений) мы можем задать любой из вопросов:

1. Сколько всего? 2. Что написано на доме?

Чтобы правильно решить две последние задачи в рамках языка MQL4, необходимо обратиться к правилам приведения типов значений. Для этого необходимо указать, как переменные разных типов представлены в памяти компьютера.

Типы данных int, bool, color, datetime и double относятся к числовому типу. Внутренним (машинным) представлением констант и переменных типов int, double, bool, color и datetime является число. При этом переменные типов int, bool, color и datetime представлены в памяти машины как целые числа, а переменные типа double - как числа двойной точности с плавающей точкой, т.е. действительные числа. Значением констант и переменных типа string является набор символов (рис. 16).

Значения типов int, bool, color и datetime представлены в памяти машины как целые числа. Значения типа double представлены в памяти машины как действительные числа. Значения типа string представлены в памяти машины как последовательность символов. Значения типов int, bool, color, datetime и double являются значениями числового типа. Значения типа string являются значениями символьного типа.

Рис. 16. Представление разных типов данных в памяти машины.

Выше указывалось, что значения переменных типов int, bool, color и datetime представлены в памяти машины как целые числа, а double - как действительные числа. Выясняя вопрос о типе выражения, в котором участвуют переменные разных типов, допустимо вести разговор только относительно трёх типов данных: int, double и string. Значения типов bool, color и datetime будут проявлять себя в выражении так же, как значения типа int.

Итак, каким будет значение выражения, если его составляют операнды разных типов? В языке MQL4 принято правило неявного приведения типов:

  • если в выражении содержатся операнды разных типов, то тип выражения преобразовывается в тип, имеющий более высокий приоритет; типы int, bool, color и datetime имеют одинаковый приоритет, тип double - более высокий приоритет, тип string - самый высокий приоритет;
  • если тип выражения справа от знака операции присвоения не совпадает с типом переменной слева от знака операции присвоения, то значение выражения приводится к типу переменной слева от знака операции присвоения; это называется приведением к целевому типу;
  • приведение значений типа string к любому другому целевому типу запрещено.

Вернёмся к Задаче 4. Возможны два варианта решения.

Вариант 4.1. Вычисляется результат целого типа:

   double A = 2.0;                      // Количество карандашей у Васи
   int    Y = 3;                        // Количество ответов Пети
   int    F = A + Y;                    // Общее количество

Прежде всего нам необходимо выяснить, каким будет значение выражения, если операнды имеют разный тип. В выражении:

   A + Y

участвуют операнды двух типов данных: А - действительного типа double и Y - целого типа int.

В соответствии с правилом неявного преобразования типов значением этого выражения будет число действительного типа double. Обратите внимание: мы говорим только о типе выражения A+Y, но не о типе переменной F, стоящей слева от знака операции присвоения. Значением этого выражения будет действительное число 5.0. Для определения типа выражения A+Y применена первая часть правила неявного приведения типов.

После вычисления выражения A+Y исполняется операция присвоения. В данном случае также имеется несовпадение типов: тип выражения A+Y - double, а тип переменной F - int. В процессе выполнения операции присвоения: сначала тип выражения A+Y будет приведен к типу int (в соответствии с правилом вычисления целых чисел) и равен целому числу 5, а затем этот результат станет значением целой переменной F. Вычисления выполнены в соответствии со второй частью правила неявного приведения типов - приведения к целевому типу. Конечный результат вычислений и преобразований таков: значением целой переменной F является целое число 5.

Вариант 4.2. Аналогичная ситуация возникает и в случае, если искать результат в виде значения действительного типа:

   double A = 2.0;                   // Количество карандашей у Васи
   int    Y = 3;                     // Количество ответов Пети
   double F = A + Y;                 // Общее количество

Представленный случай отличается от предыдущего тем, что целевой тип переменной F (слева от знака операции присвоения), в данном случае - тип double, совпадает с типом double выражения A+Y, поэтому целевого преобразования типов не происходит. Результатом вычислений (значением действительной переменной F) будет действительное число 5.0.

Теперь посмотрим, каким будет решение Задачи 5. При инициализации переменных вопросов не возникает:

   string W1 = "Северный";             // Строка 1
   double A  = 2;                      // Количество карандашей у Васи

Вариант 5.1. Допустимое решение задачи:

   string W1  = "Северный";           // Строка 1
   double A   = 2;                    // Количество карандашей у Васи
   string Sum = W1 + A;               // Неявное преобразование справа

Здесь в правой части складываются значения двух переменных, одна из которых имеет тип string, а другая - тип double. В соответствии с правилом неявного приведения типов значение переменной А сначала будет приведено к типу string (т.к. у этого типа более высокий приоритет), а после этого произойдёт сложение (конкатенация) однотипных значений. Типом вычисленного значения в правой части от знака операции присвоения будет тип string. На следующем этапе это значение будет присвоено строковой переменной Sum. В результате значением переменной Sum будет следующая строка:

Северный2.00000000

Вариант 5.2. Такое решение является ошибочным:

   string W1 = "Северный";             // Строка 1
   double A = 2;                       // Количество карандашей у Васи
   double Sum = W1 + A;                // Это недопустимо

В данном случае нарушен запрет приведения к целевому типу значения типа string. Типом значения выражения W1+A, как и в предыдущем примере, является тип string. При исполнении операции присвоения должно быть произведено целевое приведение типа. Однако, в соответствии с правилом, целевое понижение типа string запрещено. Это - ошибка, которая будет обнаружена редактором MetaEditor на этапе создания программы (при компиляции).

В целом, указанные правила понятны и просты: при вычислении любых значений происходит приведение к типу с более высоким приоритетом. Понижение приоритета при целевом приведении типа допустимо только для численных значений, а строки в числа не преобразовываются.

Особенности вычисления значений целых чисел

Как известно, целые числа - это числа, у которых нет дробной части. При их сложении и вычитании получается интуитивно понятный результат. Например, если:

   int X = 2;                        // Первая целая переменная
   int Y = 3;                        // Вторая целая переменная

и при этом:

   int Z = X + Y;                    // Операция сложения

то не возникает никаких проблем с вычислением значения переменной Z: 2 + 3 = 5

Аналогично, если выполняется операция умножения:

   int Z = X * Y;                    // Операция умножения

то результат также легко предсказуем: 2 * 3 = 6

Но каким будет результат в том случае, если в программе необходимо выполнить операцию деления?

   int Z = X / Y;                    // Операция деления

Нетрудно написать 2 / 3. Но это - не целое число. Каким же будет значение выражения X/Y и переменной Z?

Правило вычисления значений целых чисел состоит в том, что дробная часть отбрасывается.

В этом примере справа от знака равенства находится выражение, содержащее только целые числа, т.е. в данном случае приведение типов не происходит. Это значит, что типом выражения X/Y является тип int. Поэтому результатом вычисления целого значения выражения X/Y (= 2/3) будет 0 (ноль). В результате это значение (ноль) будет присвоено переменной Z.

Соответственно, при других значениях переменных X и Y результат будет другим. Например, если:

   int X = 7;                      // Значение переменной целого типа
   int Y = 3;                      // Значение переменной целого типа
   int Z = X / Y;                  // Операция деления

то значение 7 / 3 выражения X / Y и переменной Z будет равно 2 (двум).

Порядок вычисления выражений

Правило вычисления выражений состоит в следующем:

Вычисление значения выражения производится в соответствии с приоритетом арифметических операций и слева направо, причём каждый промежуточный результат вычисляется по правилам приведения типов.

Рассмотрим порядок вычисления выражения в следующем примере:

   Y = 2.0*( 3*X/Z - N) + D;                          // Пример выражения
Выражение в правой части от знака равенства состоит из двух слагаемых: 2.0*( 3*X/Z - N) и D. Слагаемое 2.0*( 3*X/Z - N) состоит из двух множителей, а именно, 2 и (3*X/Z - N). Выражение в скобках 3*X/Z - N, в свою очередь, состоит из двух слагаемых, причём слагаемое 3*X/Z состоит из трёх множителей, а именно, 3, X и Z.

Для вычисления значения выражения в правой части от знака равенства сначала будет вычислено значение выражения 3*X/Z. Это выражение содержит две операции (умножение и деление), имеющих одинаковый приоритет, поэтому вычисление выражения будет выполняться слева направо. Сначала будет вычислено значение выражения 3*X, причём тип этого значения будет таким, какой тип имеет переменная X. Затем будет вычислено значение выражения 3*X/Z, его тип также будет вычислен на основании правил приведения типов. После этого программа вычислит значение и тип выражения 3*X/Z - N, потом выражения 2.0*( 3*X/Z - N) и в последнюю очередь - значение и тип всего выражения 2.0*( 3*X/Z - N) + D.

Легко заметить, что порядок вычисления выражений в программе аналогичен порядку подобных вычислений в математике, но отличается вычислением типов значений промежуточных выражений, что существенно влияет на конечный результат вычислений. В частности (в отличие от правил, принятых в математике), немаловажное значение имеет порядок операндов в выражении. Чтобы продемонстрировать это, рассмотрим небольшой пример.
Задача 6. Вычислить значения выражений А/В*С и А*С/В для целых чисел А, В и С.

Интуитивно ожидается, что результат вычислений в обоих случаях будет одинаковым. Однако это утверждение справедливо только в отношении действительных чисел. При вычислении значений выражений, составленных из операндов целого типа, очень важен промежуточный результат. В таком случае последовательность операндов имеет принципиальное значение:

   int A = 3;                          // Значение целого типа
   int B = 5;                          // Значение целого типа
   int C = 6;                          // Значение целого типа
   int Res_1 = A/B*C;                  // Результат 0 (ноль)
   int Res_2 = A*C/B;                  // Результат 3 (три)

Проследим процесс вычисления выражения A/B*C:

1. Сначала (слева направо) будет вычислено значение выражения A/B. В соответствии с указанными выше правилами значением выражения (3/5) будет целое значение 0 (ноль).

2. Вычисление выражения 0*С (ноль умножить на С). Результат - целое значение 0 (ноль).

3. Общий результат (значение переменной Res_1) - целое значение 0 (ноль).

Теперь посмотрим, как будут развиваться события при вычислении выражения A*C/B.

1. Вычисление A*C. Значением этого выражения будет целое число 18 (3*6=18).

2. Вычисление выражения 18/B. Ответ очевиден: (18/5) после отбрасывания дробной части получится целое число 3(три).

3. Общий результат (значение переменной Res_2) - целое значение 3 (три).

В данном примере рассмотрен небольшой фрагмент программы, в котором вычисляются значения переменных целого типа. Если эти переменные заменить константами, но использовать при этом те же их значения, то конечный результат от этого не изменится. При вычислении выражений, в которых используются целые числа, необходимо проявлять повышенное внимание к содержанию программных строк. В противном случае в программе может возникнуть ошибка, которую впоследствии (особенно в больших программах) очень трудно обнаружить. При вычислениях, в которых участвуют только действительные числа, подобная проблема не возникает. Но если в сложном выражении употребляются операнды разных типов, то конечный результат может полностью зависеть от случайно составленного фрагмента, где происходит деление целых чисел.

В разделе Операторы рассматривается понятие и общие свойства операторов, в главе Операторы раскрываются собственные свойства каждого оператора.

Типы данныхОператоры


Функции - Основы языка - Учебник по MQL4

Учебник по MQL4 [image] Основы языка [image] Функции
  • Некоторые основные понятия
  • Константы и переменные
  • Типы данных
  • Операции и выражения
  • Операторы
  • Функции
  • Виды программ
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Функции

Понятие функции

Наиболее важным завоеванием компьютерных технологий является возможность создания и хранения обособленных фрагментов кода, описывающих правила обработки информации для решения некоторого вопроса или небольшой задачи. Такая возможность имеется и в языке MQL4.

Функция - это именованная, обособленная часть программы, описывающая порядок преобразования информации.

Говоря о функциях, мы будем иметь в виду два аспекта: описание функции и вызов функции.

Описание функции - именованная, обособленная часть программы, предназначенная для исполнения.

Вызов функции (обращение к функции) - это запись, исполнение которой приводит к исполнению функции.

В нашей обычной жизни можно найти множество аналогов функции. Возьмём для примера тормозную систему автомобиля. Исполнительный механизм, собственно осуществляющий торможение, как и идея, заложенная в этот механизм конструктором, являются аналогом функции, а педаль тормоза - аналогом вызова функции. Водитель давит на педаль, в результате чего исполнительные механизмы осуществляют некоторое действие - останавливают автомобиль.

Аналогично, если в программе встретится вызов функции, то будет вызвана и исполнена одноимённая функция, т.е. выполнена некоторая последовательность расчётов или других действий (например, вывод сообщения, открытие ордера и пр.). Общий смысл функции состоит в том, чтобы вынести логически завершённую часть кода за пределы основного текста программы, а в основном тексте программы оставить только обращение к ней. Такая организация программы имеет неоспоримые достоинства:

  • во-первых, составленный таким образом текст программы гораздо легче читается;
  • во-вторых, легко видеть и при необходимости изменять текст функции, не меняя при этом основной код;
  • в-третьих, функцию можно оформить в виде отдельного файла и использовать её для работы в других программах, что избавляет программиста от необходимости всякий раз вписывать одни и те же фрагменты кода во вновь создаваемые программы.

Можно сказать, что большая часть кода программ, составленных на MQL4, оформляется в виде функций. Такой подход получил широкое распространение и сейчас является стандартом.

Состав функции

Итак, функция может быть описана и вызвана. Рассмотрим пример. Пусть у нас имеется небольшая программа (рис. 18), вычисляющая гипотенузу по двум заданным катетам с помощью теоремы Пифагора.

В этой программе все вычисления собраны в одном месте, операторы исполняются подряд в том порядке, в котором они встречаются в программе (в направлении сверху вниз).

Рис. 18. Код цельной программы pifagor.mq4.

Задача 8. Оформить часть представленного кода программы в виде функции.

Имеет смысл оформить в виде функции две строки, в которых определяется искомое значение. Программа, производящая те же вычисления, но использующая функцию, представлена на рис. 19.

В этой программе часть вычислений оформлена в виде функции. В основном коде имеется обращение к пользовательской функции. Описание пользовательской функции расположено за пределами (после) основного кода.

Рис. 19. Код программы, содержащий описание и обращение к пользовательской функции gipo.mq4.

Оба варианта представления программы дадут одинаковый результат. Однако, если в первом варианте (рис. 18) код оформлен в виде одного модуля, то во втором варианте (рис. 19) часть вычислений выполняется в функции, к которой имеется обращение из основного текста. По окончании вычислений, выделенных в функцию, продолжатся вычисления в основном коде.

Для того чтобы функция была исполнена, необходимо её вызвать (обратиться к ней). Поэтому функция практически представляется в двух частях: собственно набор кода, составляющий функцию (описание функции), и вызов функции, использующийся для её запуска в работу (обращение к функции). Невызванная функция исполняться не будет, в то же время обращение к несуществующей функции ни к чему не приведёт (в период создания такой программы редактор MetaEditior сообщит об ошибке).

Описание функции

Описание функции состоит из двух основных частей - заголовка функции и тела функции.

Заголовок функции состоит из указания типа возвращаемого значения, названия функции и списка формальных параметров. Список формальных параметров заключается в круглые скобки и располагается после названия. Тип возвращаемого значения может быть одним из известных нам типов: int, double, bool, color, datetime и string. Если функция не возвращает никакого значения, то её тип можно обозначить void ("без типа") или любым другим типом.

Тело функции заключается в фигурные скобки. Тело функции может содержать простые и/или составные операторы, а также обращения к другим функциям. Возвращаемое функцией значение указывается в скобках оператора return(). Тип значения, возвращаемого с помощью оператора return(), должен совпадать с типом функции, указанным в заголовке. Описание функции заканчивается закрывающей фигурной скобкой.

Рис. 20. Описание функции.

Описание функции должно находиться в программе обособленно, за пределами любых других функций (т.е. не внутри какой-либо другой функции, а снаружи).

Вызов функции

Вызов функции состоит из названия функции и списка передаваемых параметров. Список передаваемых параметров заключается в круглые скобки. Вызов функции может быть оформлен в виде отдельного оператора или являться составной частью оператора.

Рис. 21. Вызов функции (обращение к функции).

Вызов любой функции всегда указывается в коде другой функции (т.е. не за пределами всех функций, а внутри одной из них).

Типы функций

Различают три типа функций - специальные, стандартные (встроенные, предопределённые) и пользовательские.

Специальные функции

В языке MQL4 имеется всего 3 специальные функции. Они имеют предопределённые имена: init(), start() и deinit(), которые запрещено использовать для названия других функций. Специальные функции подробно рассматриваются в разделе Специальные функции. Здесь укажем лишь, что основной код программы размещается внутри этих функций (рис. 18, 19).

Особенностью применения специальных функций является то обстоятельство, что они вызываются для исполнения клиентским терминалом. Хотя специальные функции и обладают всеми свойствами функций вообще, тем не менее, в обычной корректно составленной программе специальные функции из программы обычно не вызываются.

Стандартные функции

Язык MQL4 имеет ряд полезных функций, описание которых не требуется при написании программ. Например, вычисление квадратного корня, печать сообщений в системный журнал или на экран - эти и многие другие стандартные функции выполняются по заранее разработанному и заданному алгоритму. Пользователю нет никакой необходимости интересоваться содержимым этих функций. Он может быть уверен, что все стандартные функции составлены разработчиками правильно и при этом был использован лучший из имеющихся алгоритмов.

Особенность использования стандартных функций состоит в том, что в тексте программы их описание не указывается. Вызов стандартных функций применяется в программе так же, как и при использовании любых других функций (это - обычная практика).

В нашем примере (рис. 18, 19) используется две стандартные функции: MathSqrt() и Alert(). Первая предназначена для вычисления квадратного корня, вторая - для сообщения на экран некоторого текста, заключённого в круглые скобки. Более подробно свойства функций рассматриваются в разделе Стандартные функции, а пока нам важно отметить, что эти записи представляют собой вызов стандартных функций, в то время как описания этих функций в программе отсутствуют. Стандартные функции ещё называют встроенными или предопределёнными. Можно использовать любой из указанных терминов.

Пользовательские функции

В ряде случаев программисты создают и используют в работе свои собственные функции. Эти функции называются пользовательскими и применяются в программах с использованием и описания, и вызова функции.

Таблица 1. Использование в программе описания и вызова для функций разных типов.

Тип функции | Описание функции | Вызов функции
Специальная | Используется | Не используется (*)
Стандартная | Не используется | Используется
Пользовательская | Используется | Используется

(*) Хотя техническая возможность вызова специальных функций из программы существует, делать это не рекомендуется.

Свойства функций

Главное свойство всех функций состоит в том, что вызванные функции исполняются. Исполнение функций происходит в соответствии с их кодом.

Передаваемые параметры и возвращаемое значение

В части получаемой и возвращаемой информации функция подобна обычному калькулятору. На его клавиатуре можно набрать некоторое выражение, состоящее из нескольких последовательно вводимых значений, и в качестве ответа получить одно значение. Функция может получить для обработки один или несколько параметров от программы, вызвавшей функцию для исполнения, и по окончании своей работы в качестве ответа возвратить (сообщить, передать) один параметр программе.

Передаваемые параметры указываются в круглых скобках после названия вызываемой функции и перечисляются через запятую. Количество передаваемых в функцию параметров не должно превышать 64. Функция может также не использовать передаваемые параметры. В этом случае указывается пустой список параметров, т.е. сразу после названия функции располагаются открывающая и закрывающая круглые скобки.

Количество, тип и порядок упоминания передаваемых параметров в вызове функции должны совпадать с количеством, типом и порядком упоминания формальных параметров, указанных в описании функции (исключение составляет вызов функции, имеющей умолчательные параметры - см. Вызов функции и Описание функции и оператор return). Если такого совпадения нет, то редактор MetaEditor выдаст сообщение об ошибке. В качестве передаваемых параметров могут использоваться константы, переменные, выражения и массивы.

Возвращаемое значение указывается в скобках оператора return() (см. Описание функции и оператор return). Тип значения, возвращаемого с помощью оператора return(), должен совпадать с типом функции, указанным в её заголовке. Функция может не возвращать никакого значения. В этом случае в скобках оператора return() ничего не указывается.

В нашем примере передаваемые параметры - это переменные A и В (рис. 21), а возвращаемое значение - переменная с (рис. 20). Требование совпадения типов передаваемых и формальных параметров показано на рис. 22.

Количество, тип и порядок упоминания передаваемых параметров в вызове функции должны совпадать с количеством, типом и порядком упоминания формальных параметров, указанных в описании функции. В качестве формальных параметров в заголовке описания функции могут использоваться только переменные.

Рис. 22. Совпадение количества, типов и порядка следования передаваемых и формальных параметров. В качестве передаваемых параметров используются только переменные.

В качестве передаваемых параметров могут использоваться переменные, выражения и константы.

Рис. 23. Совпадение количества, типов и порядка следования передаваемых и формальных параметров. В качестве передаваемых параметров используются константа, выражение и переменные соответствующего типа.

Формальные параметры

Замечательным свойством функции является использование формальных параметров.

Формальные параметры - это список переменных, указанных в заголовке описания функции.

Ранее уже упоминалось, что одна и та же функция может быть использована в нескольких программах. Однако в разных программах используются разные имена переменных. Если бы требованием функций было обязательное строгое совпадение имён переменных (и, соответственно, их значений), то это было бы очень неудобно. В самом деле, каждую вновь создаваемую программу пришлось бы составлять в тех именах переменных, которые использовались в функциях. Но, к счастью, переменные, используемые внутри функции, никак не связаны с переменными, используемыми в программе.

Обратимся ещё раз к рис. 20 и 21. Обратите внимание: имена передаваемых параметров (в скобках вызова функции указано A и В) не совпадают с именами параметров, указанных в описании функции (a и b). В разделе Константы и переменные указывалось, что язык MQL4 чувствителен к строчным и прописным буквам. Таким образом, рассматриваемые здесь A и a, В и b - разные имена переменных. Однако в этом коде нет ошибки.

Используемые в описании функции переменные - формальные параметры - никак не связаны с переменными, используемыми в основном коде программы. Это просто другие переменные. В качестве формальных параметров в заголовке функции могут быть указаны только переменные, но не константы.

Как это работает

  • В программе встречается вызов функции, в скобках которого указаны переменные А и В.
  • Вызывается одноимённая функция, в заголовке у которой указаны формальные параметры а и b.
  • Значение переменной А присваивается переменной а.
  • Значение переменной B присваивается переменной b.
  • Исполняемая функция производит вычисления, используя значения переменных а и b.

Допустимо использование любых названий формальных параметров (не совпадающих с названиями переменных, используемых в программе). В данном примере мы использовали идентификаторы формальных параметров а и b, но могли бы использовать любые другие, например, m и n или Kat_1 и Kat_2. Разумеется, при составлении программы в теле функции следует указывать вычисления, использующие те имена переменных, которые указаны в заголовке. Мы указали в заголовке а и b, значит, в функции необходимо использовать а и b, а не m и n.

В функции производятся вычисления, в которых принимают участие формальные параметры а и b, но не участвуют переменные А и В. В функции над формальными параметрами а и b могут производиться любые разрешённые действия (в том числе изменение значений этих переменных). Это не оказывает никакого воздействия на переменные А и В.

Возвращаемое значение, вычисленное в функции, указывается в скобках оператора return(). В качестве возвращаемого значения могут быть использованы значение переменной, результат выражения или константа. В нашем случае это - значение локальной переменной c (локальная переменная - это переменная, объявленная на уровне функции; при выходе из функции значения всех локальных переменных теряются; более подробно с локальными переменными мы познакомимся в разделе Виды переменных). Функция возвращает в программу значение локальной переменной с (рис. 19). Это значит, что теперь это значение будет присвоено переменной С.

Дальнейшие вычисления в программе (если они есть) могут производиться с переменными, объявленными на уровне вызывающей функции. В нашем случае вызывающая функция - это специальная функция start() (в ней находится строка вызова пользовательской функции), а переменные, объявленные на уровне вызывающей функции, - это А, В и С. Таким образом, в функции производятся вычисления с использованием формальных параметров, что позволяет создавать функции с использованием произвольных имён переменных, независимо от имён переменных, фактически используемых в программе.

Пример использования стандартных функций в программе

Для начала поинтересуемся, как ведёт себя программа, представленная на рис. 18. Прежде всего заметим, что весь код программы расположен внутри специальной функции start(). На данном этапе обучения мы не станем уделять этому внимание (специальные функции и их свойства подробно рассматриваются в разделе Специальные функции).

Рассмотрим, как будет исполняться программа, начиная с оператора присваивания:

   int A = 3;                               // Первый катет

1. В правой части оператора присваивания указана константа, значение которой равно 3.

2. Присвоение переменной А (находящейся в левой части от знака равенства в операторе присваивания) значения 3 (значения правой части).

Управление передаётся в следующую строку:

   int B = 4;                               // Второй катет

3. В правой части оператора присваивания указана константа, значение которой равно 4.

4. Присвоение переменной В значения 4.

Программа переходит к выполнению следующей строки:

  int C_2 = A*A + B*B;                      // Сумма квадратов катетов

5. Вычисление правой части оператора присваивания. Результатом вычислений является значение 25 (подробности обращения программы к переменным для получения их значений рассмотрены в разделе Константы и переменные, поэтому останавливаться на этом вопросе здесь мы не будем).

6. Присвоение переменной С_2 значения 25.

Следующая строка представляет собой оператор присваивания, в правой части которого содержится вызов стандартной функции:

   int C = MathSqrt( C_2);                  // Вычисление гипотенузы

Программа стремится выполнить оператор присваивания. Для этого она сначала выполняет вычисления справа от знака равенства.

7. Программа вызывает для исполнения стандартную функцию вычисления квадратного корня MathSqrt(). В качестве передаваемого параметра используется значение переменной С_2 (в нашем случае это значение равно 25). Обратите внимание на то, что нигде в программе нет описания этой стандартной функции. Описания стандартных функций не должны быть содержанием программ. В тексте программы вызов стандартной функции легко отличить по внешнему виду: в редакторе MetaEditor они выделяются фиолетовым цветом (программист может настроить цвет по своему выбору).

8. Производятся вычисления в стандартной функции MathSqrt().

9. Стандартная функция MathSqrt() закончила вычисления и возвращает полученное значение. В нашем случае это - значение 5 (квадратный корень из 25).

Возвращаемое функцией значение является теперь содержанием записи:

           MathSqrt( C_2)

Эта запись может рассматриваться как особенная, сложная переменная, - некая сущность, внутри которой производятся вычисления, а после того как вычисления закончены, эта сущность обретает своё значение. Определяющим здесь является то обстоятельство, что возвращаемое функцией значение может быть присвоено какой-либо другой переменной или как-то иначе учтено в других расчётах.

10. В данном случае возвращаемое значение является значением правой части оператора присваивания. Продолжая выполнять оператор присваивания, программа присвоит значение 5 переменной С.

11. В следующей строке находится оператор обращения к стандартной функции Alert() (вызов функции).

   Alert("Гипотенуза = ", C);                // Сообщение на экран

Стандартная функция Alert() открывает диалоговое окно, в котором отображаются значения передаваемых параметров. В данном случае в качестве передаваемых параметров функция получила два значения:

- значение строковой константы: Гипотенуза =

- значение целой переменной С: 5

Выше было указано, что не все функции обязательно должны возвращать значение (являющееся результатом исполнения функции). Стандартная функция Alert() не возвращает никакого значения, т.к. у неё другая задача - отображать текст на экране в специально предназначенном для этого окне.

В результате исполнения стандартной функции Alert() в окне этой функции появится следующая строка:

Гипотенуза = 5

12. Последний в этой программе оператор завершает работу специальной функции start().

 return;                                     // Оператор выхода из функции

На этом работа программы заканчивается.

Может возникнуть вопрос: как узнать, какая функция возвращает значение, а какая - нет? Ответ на этот вопрос очевиден: для получения подробного описания стандартных функций необходимо обратиться к справочной документации на MQL4.community, сайте MetaQuotes Software Corp., или к разделу "Справка" в редакторе MetaEditor. Свойства пользовательской функции задаются при её описании. Будет пользовательская функция возвращать значение или нет - зависит от заложенного в неё алгоритма (решение принимается программистом на этапе составления программного кода функции).

Пример применения в программе пользовательской функции

Теперь посмотрим, как те же вычисления выполняются в программе, содержащей пользовательскую функцию (рис. 19). Некоторая часть кода, ранее присутствовавшая в специальной функции start(), теперь отсутствует. Вместо неё там присутствует вызов пользовательской функции. Но вслед за специальной функцией start() появилось описание пользовательской функции.

Первые две строки, в которых целые переменные А и В получают численные значения, остались без изменения. Соответственно, ничего не изменится в части их выполнения:

   int A = 3;                            // Первый катет
   int B = 4;                            // Второй катет

В третьей строке написан оператор присваивания, в правой части которого указан вызов пользовательской функции:

   int C = Gipo(A,B);                    // Вычисление гипотенузы

6. Выполняя этот оператор, программа прежде всего обратится к пользовательской функции.

Обратите внимание: описание пользовательской функции должно обязательно присутствовать в программе и располагаться сразу после закрывающей фигурной скобки специальной функции start() (т.е. за её пределами).

В процессе обращения к пользовательской функции программа выполнит следующие действия:

6.1. Обращение к переменной А с целью получить её значение (в нашем случае - 3)

6.2. Обращение к переменной В с целью получить её значение (в нашем случае - 4)

Обратите внимание: с самого начала обращения к пользовательской функции (пользовательской - в данном случае, но это правило распространяется на все функции) программа получает в своё распоряжение лишь копию значений переменных, выступающих в роли передаваемых параметров, а изменение значений самих этих переменных (в данном случае - А и В) в связи с применением пользовательской функции не предполагается и не происходит.

7. Управление передаётся в пользовательскую функцию.

В течение всего времени исполнения пользовательской функции (как бы долго оно не происходило) значения переменных в вызывающей программе не пропадают, а сохраняются.

Первой строкой в описании пользовательской функции является её заголовок:

   int Gipo(int a, int b)                 // Пользовательская функция

Исполняя вызванную пользовательскую функцию, программа сделает следующее:

7.1. Переменной а (первой по порядку в списке формальных параметров) будет присвоено значение 3 (первое по порядку в списке передаваемых параметров).

7.2. Переменной b (второй по порядку в списке формальных параметров) будет присвоено значение 4 (второе по порядку в списке передаваемых параметров).

Далее управление будет передано в тело функции для исполнения заложенного в неё алгоритма.

Первым оператором в теле функции стоит такой:

   int c2 = a*a + b*b;                   // Сумма квадратов катетов

7.3. Исполняя этот оператор, программа вычислит значение в правой части оператора присваивания, а после этого присвоит полученное значение (в нашем случае: 3*3 + 4*4 = 25) переменной с2.

Следующий оператор:

   int c = MathSqrt(c2);                 // Гипотенуза

7.4. Здесь вычисляется квадратный корень из значения переменной с2. Порядок вычислений такой же, как и в предыдущем примере. Описание стандартной функции также не используется. В результате выполнения оператора присваивания переменной с будет присвоено значение 5.

7.5. В следующей строке стоит оператор:

   return(c);                           // Оператор выхода из функции

Исполняя этот оператор, программа вернёт (в точку вызова пользовательской функции) значение, заключённое в скобки этого оператора. В нашем случае - это значение переменной с, то есть 5.

На этом исполнение пользовательской функции заканчивается, а управление передаётся в точку вызова.

8. Напомним, что вызов пользовательской функции произошёл из оператора

   int C = Gipo(A,B);                   // Вычисление гипотенузы

Запись (вызов пользовательской функции)

          Gipo(A,B)

на этапе возврата значения получает значение, вычисленное в функции (в нашем случае - это значение 5).

Заканчивая выполнение оператора присваивания, программа присвоит переменной С значение 5.

9. Следующий оператор

   Alert("Гипотенуза = ", C);           // Сообщение на экран

будет исполнен так же, как и в предыдущем примере, а именно - в специальном окне появится сообщение:

Гипотенуза = 5

10. Последний в этой программе оператор

 return;                                // Оператор выхода из функции

завершает работу специальной функции start(), а вместе с ней - и работу всей программы (более подробно свойства специальных функций рассматриваются в разделе Специальные функции).

Рассмотрим несколько вариантов реализации представленной выше пользовательской функции. Легко убедиться, что программирование с применением пользовательских функций имеет неоспоримые преимущества.

Ранее рассмотренный вариант пользовательской функции Gipo()

В этой функции формальные параметры "напоминают" переменные, используемые в основной программе. Однако это - только внешнее сходство, в действительности А и а - разные имена переменных.

//--------------------------------------------------------------------
int Gipo(int a, int b)                  // Пользовательская функция
  {
   int c2 = a*a + b*b;                  // Сумма квадратов катетов
   int c = MathSqrt(c2);                // Гипотенуза
   return(c);                           // Оператор выхода из функции
  }
//--------------------------------------------------------------------

2-й вариант реализации пользовательской функции

В данном случае имена формальных параметров не "напоминают" имена переменных, использующихся в основной программе, но это не мешает использовать данную функцию в программе.

//--------------------------------------------------------------------
int Gipo(int alpha, int betta)           // Пользовательская функция
  {
   int SQRT = alpha*alpha + betta*betta; // Сумма квадратов катетов
   int GIP = MathSqrt(SQRT);             // Гипотенуза
   return(GIP);                          // Оператор выхода из функции
  }
//--------------------------------------------------------------------

3-й вариант реализации пользовательской функции Gipo()

В этом примере переменная alpha многократно используется в программе, дважды меняя своё значение. Это обстоятельство никак не отразится на фактических переменных, указанных в вызове функции в основной части программы.

//--------------------------------------------------------------------
int Gipo(int alpha, int betta)           // Пользовательская функция
  {
   alpha= alpha*alpha + betta*betta;     // Сумма квадратов катетов
   alpha= MathSqrt(alpha);               // Гипотенуза
   return(alpha);                        // Оператор выхода из функции
  }
//--------------------------------------------------------------------

4-й вариант реализации пользовательской функции Gipo()

В этой пользовательской функции все вычисления собраны в одном операторе. Возвращаемое значение вычисляется прямо в скобках оператора return(). Подкоренное выражение вычисляется прямо там, где должен быть указан передаваемый параметр в стандартной функции MathSqrt().Такое решение поначалу может показаться непонятным или неправильным, но в этой реализации пользовательской функции ошибки нет. Количество используемых в функции операторов меньше, чем в других примерах, код получается более компактным.

//--------------------------------------------------------------------
int Gipo(int a, int b)                   // Пользовательская функция
  {
   return(MathSqrt(a*a + b*b));          // Оператор выхода из функции
  }
//--------------------------------------------------------------------

Таким образом, применение пользовательских функций в практике программирования имеет неоспоримые достоинства:

  • имена переменных в основном тексте программы никак не связаны с именами формальных параметров в пользовательской функции;
  • пользовательские функции могут многократно применяться в различных программах, для этого нет необходимости изменять код пользовательской функции;
  • возможно создание библиотек.

Эти очень полезные свойства функций позволяют вести корпоративную работу по созданию больших программ. В этом процессе возможно участие одновременно нескольких программистов, при этом они могут не заботиться о согласовании используемых имён переменных. Достаточно согласовать порядок следования переменных в заголовке и вызове функции.

ОператорыВиды программ


Основы языка - Учебник по MQL4

Учебник по MQL4 [image] Основы языка
  • Некоторые основные понятия
  • Константы и переменные
  • Типы данных
  • Операции и выражения
  • Операторы
  • Функции
  • Виды программ
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Основы языка MQL4

В этом разделе представлены основные понятия, на которых построен язык программирования MQL4:
  • Некоторые основные понятия

    Описываются такие понятия, как "тик" (изменение цены), "управление" в алгоритме, "комментарий" в программе. Главное событие при торговле на финансовых рынках - изменение цены. Поэтому тик является важным событием, которое запускает основные механизмы работы MQL4-программ. Что делать по приходу каждого нового тика, какие действия предпринимать - здесь уже на первый план выходит управление. Но не забывайте комментировать свой код.

  • Константы и переменные

    Вводятся понятия константы и переменной, объясняется разница между ними. Как следует из названия, константа - это нечто неизменное, раз и навсегда заданное. В отличие от константы, переменная - это некоторый объект программного кода, который может изменять свое содержимое. Невозможно написать программу, не используя неизменные объекты (константы) и/или изменяемые в процессе работы программы объекты (переменные).

  • Типы данных

    В любом языке программирования используются определенные типы данных. Тип переменной выбирается исходя из ее назначения. Как объявить переменную, как инициализировать (задать начальное значение)? Неправильный выбор типа для переменной может впоследствии затруднить работу программы или даже привести к ошибочным действиям.

  • Операции и выражения

    Операции производят действия над операндами. Какие существуют виды операций, для чего требуется приведение типов, каковы особенности операций с целыми числами? Почему нужно помнить о приоритете одного типа данных над другим? Не зная особенностей некоторых операций, можно сделать неочевидные ошибки.

  • Операторы

    Операторы, простые и составные. Не всегда необходимое действие можно выполнить одним простым оператором. Если требуется, чтобы группа операторов выполнялась как один большой оператор, то эту группу заключают в один составной оператор. Требования и примеры использования.

  • Функции

    Необходимость получения понятного и простого кода приводит нас к понятию Функция. Для того чтобы функцию можно было использовать из разных мест программы, требуется передать ей Параметры функции. Рассмотрим процесс создания пользовательской функции. Приводятся примеры использования стандартных функций.

  • Виды программ

    Скрипты, индикаторы и эксперты - разные варианты MQL4 программ, которые позволяют охватить практически весь класс задач для торговли на финансовых рынках. Необходимо понимать назначение каждого типа программы, чтобы лучше пользоваться терминалом MetaTrader 4.
ВведениеНекоторые основные понятия


Операторы - Основы языка - Учебник по MQL4

Учебник по MQL4 [image] Основы языка [image] Операторы
  • Некоторые основные понятия
  • Константы и переменные
  • Типы данных
  • Операции и выражения
  • Операторы
  • Функции
  • Виды программ
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Операторы

Понятие оператора

Одним из ключевых понятий любого языка программирования является понятие "оператор". Без овладения этим понятием в полной мере написание программ не представляется возможным. От того, насколько быстро и правильно программист усвоит, что такое операторы и как они применяются в программе, зависит, как скоро он начнёт писать программы.

Оператор - это составная часть программы, фраза алгоритмического языка, предписывающая определённый порядок преобразования информации.

Любая программа содержит операторы. Наиболее близкой аналогией оператору является предложение. Операторы образуют программу так же, как обычные предложения образуют текст рассказа или повести.

Свойства операторов

Различаются два вида свойств операторов - общeе и собственные.

Общее свойство операторов

Все операторы имеют одно общее свойство - они исполняются.

Можно сказать, что оператор - это инструкция, содержащая руководство к действию (описание приказа). Для компьютера выполнять запущенную на нём программу означает (последовательно переходя от одного оператора к другому) выполнять предписания (инструкции, приказы), содержащиеся в операторах.

Собственно оператор - это только запись, некоторая последовательность символов. В операторе нет рычажков, проводов или ячеек памяти. Поэтому, когда компьютер выполняет программу, в самих операторах ничего не происходит, они продолжают оставаться в программе в том виде, в котором их составил программист. Но преобразования происходят в компьютере, имеющем ячейки памяти и каналы связи между ними. Если компьютер исполнил некоторое преобразование информации в соответствии с содержащимся в операторе предписанием, то говорят, что оператор исполнился.

Собственные свойства операторов

Существует несколько различных видов операторов. Каждый вид оператора обладает собственным свойством. Например, свойством оператора присваивания является способность присвоения указанной переменной некоторого значения, свойством оператора цикла является его многократное исполнение. Собственные свойства операторов подробно рассматриваются в соответствующих разделах главы Операторы. Здесь укажем только, что все виды операторов имеют собственные свойства, присущие только их виду и не повторяющиеся в других видах.

Типы операторов

Различают два типа операторов - простые и составные.

Простые операторы

Простые операторы в языке MQL4 заканчиваются знаком ";" (точка с запятой). С помощью этого разделителя компьютер может определить, где заканчивается один и начинается другой оператор. Знак ";" (точка с запятой) так же необходим в программе, как "." (обычная точка) необходима в обычном тексте для разделения предложений. Один оператор может располагаться в нескольких строках, несколько операторов можно располагать в одной строке.

Каждый простой оператор заканчивается знаком ";" (точка с запятой).

Примеры простых операторов:

   Day_Next= TimeDayOfWeek(Mas_Big[n][0]+60);   // Простой оператор

   Go_My_Function_ind();                        // Простой оператор

   a=3;  b=a*x+n;  i++;                         // Несколько операторов в строке

   Print("   Day= ",TimeDay(Mas_Big[s][0]),     // Один оператор..
         "   Hour=",TimeHour(Mas_Big[s][0]),    // расположен..
         "   Minute=",TimeMinute(Mas_Big[s][0]),// в нескольких ..
         "   Mas_Big[s][0]= ",Mas_Big[s][0],    // строках
         "   Mas_Big[s][1]= ",Mas_Big[s][1]);

Составные операторы

Составной оператор состоит из нескольких простых, разделенных знаком ";", и оформляется фигурными скобками. Чтобы можно было использовать несколько операторов там, где ожидается присутствие только одного, предусматривается составной оператор (который также называют "блоком"). Список операторов в составном операторе выделяется фигурными скобками, а свидетельством окончания составного оператора является наличие закрывающей фигурной скобки.

Пример использования составного оператора в условном операторе. Сначала идет условный оператор if(выражение), за ним следует составной оператор. Составной оператор содержит список исполняемых операторов.

Рис. 17. Составной оператор.

Тело составного оператора заключено в фигурные скобки. Каждый составной оператор заканчивается закрывающей фигурной скобкой.

Примеры составных операторов:

                                            // Пример  оператора switch
switch(ii)                                  // Оператор switch(выражение)
   {                                        // Открывающая фигурная скобка
   case 1: Buf_1[Pok-f+i]= Prognoz;  break; // Вложенные операторы (тело операт.)
   case 2: Buf_2[Pok-f+i]= Prognoz;  break; // Вложенные операторы (тело операт.)
   case 3: Buf_3[Pok-f+i]= Prognoz;  break; // Вложенные операторы (тело операт.)
   }                                        // Закрывающая фигурная скобка,..
                                            // .. означает окончание оператора
//----------------------------------------------------------------------------------
                                            // Пример использования цикла
for (tt=1; tt<=Kol_Point[7]; tt++)          // Оператор for(выражения)
   {                                        // Открывающая фигурная скобка
   Numb = Numb + Y_raz[tt]*X_raz[ii][tt];   // Вложенный оператор (тело операт.)
   }                                        // Закрывающая фигурная скобка..
                                            // .. означает окончание оператора
//----------------------------------------------------------------------------------
                                            // Пример условного оператора if
if (TimeDay(Mas_Big[f][0])!= 6)             // if (выражение)
   {                                        // Открывающая фигурная скобка
   Sred =(Nabor_Koef[ii][vv][2]+ NBh)*Point;// Вложенные операторы (тело операт.)
   Ind = Nabor_Koef[ii][vv][0] + f;         // Вложенные операторы (тело операт.)
   Print(" Ind= ",Ind);                     // Вложенные операторы (тело операт.)
   }                                        // Закрывающая фигурная скобка..
                                            // .. означает окончание оператора

Тело составного оператора всегда заключено в фигурные скобки и может состоять из нуля, одного или нескольких операторов.

Примеры использования простых операторов:

//----------------------------------------------------------------------------------
                                    // Пример оператора for
   for (n=1; n<=Numb; n++)          // for(выражения)
      Mas[n]= Const_1+ n*Pi;        // Вложенный оператор (тело операт.)
//----------------------------------------------------------------------------------
                                    // Пример условного оператора if
   if (Table > Chair)               // if (выражение)
      Norma = true;                 // первый оператор (подоператор 1)
   else                             // Альтернативное условие
      Norma = false;                // второй оператор (подоператор 2)
//----------------------------------------------------------------------------------

Несколько простых операторов могут быть объединены в составной оператор без строгой необходимости.

Это - редко встречающаяся, но вполне допустимая конструкция. В этом случае операторы, заключённые в фигурные скобки, называют блоком операторов. Такое использование допустимо. Обрамление фигурными скобками делается по воле программиста для удобства представления кода. Пример блока операторов:

   {                                            // Открывающая фигурная скобка
   Day_Next= TimeDayOfWeek(Mas_Big[n][0]+60);   // Простой оператор
   b=a*x+n;                                     // Простой оператор
   }                                            // Закрывающая фигурная скобка..

Требования к операторам

Операторы должны быть записаны в текст программы в соответствии с правилами форматирования (представления в программе). Ни один оператор не может быть составлен вне этих правил. Если же программа содержит оператор, составленный вопреки правилам форматирования, то при компиляции программы редактор MetaEditor выдаст сообщение об ошибке. Это значит, что в таком виде программа (содержащая ошибочный оператор) не может использоваться.

Выражение "Формат оператора" следует понимать как набор правил форматирования, присущих виду оператора. Каждый вид оператора имеет свой формат. Форматы операторов подробно рассматриваются в соответствующих разделах главы Операторы.

Порядок исполнения операторов

Важной характеристикой любой программы является порядок исполнения операторов. Операторы не могут исполняться просто так, без всякой системы. В языке MQL4 принято следующее правило исполнения операторов:

Операторы исполняются в том порядке, в котором они встречаются в программе. Направлением последовательности исполнения операторов принято направление слева направо и сверху вниз.

Это значит, что и простые и составные операторы исполняются просто подряд, один за другим (подобно тому, как мы читаем строки стихов - сначала верхнюю строку, потом следующую ниже, следующую и т.д.). Если в одной строке находится несколько операторов, то они исполняются последовательно один за другим слева направо, после чего исполняются операторы в следующей строке, расположенной ниже.

Операторы, входящие в составной оператор, исполняются точно так же: любой оператор блока начинает исполняться после того, как исполнится предыдущий.

Пример написания и исполнения операторов

По внешнему виду текст программы (содержащий операторы) напоминает обычный текст или записи математических уравнений. Однако это сходство - только внешнее. В обычном тексте допускается произвольная последовательность записей, в то время как в программе необходимо соблюдение строго определённого порядка.

В качестве примера рассмотрим, как работает оператор присваивания. Для этого возьмём решение простой системы линейных уравнений и сравним, как некоторые математические вычисления отражаются в обычном тексте и как - в тексте программы, в операторах.

Задача 7. Дана система уравнений:
Y = 5
Y - X = 2
Требуется найти численное значение переменной Х.

Вариант 1. Текст составлен обычным способом на листе бумаги.

1. 5 - Х = 2

2. Х = 5 - 2

3. Х = 3

Вариант 2. Текст программы.

Y = 5;                      // Строка 1
X = Y - 2;                  // Строка 2

И в первом, и во втором варианте записи (строки) содержат законченный смысл. Тем не менее, строки из первого варианта не могут в таком виде использоваться в программе, потому что их вид не соответствует формату оператора присваивания.

Записи в первом варианте представляют отображение на бумаге некоторых зависимостей. Они могут использоваться лишь для того, чтобы сообщить программисту, в каком отношении находятся между собой переменные. Программные операторы имеют другое назначение - они сообщают компьютеру, какие операции и в какой последовательности необходимо исполнить. Все без исключения операторы представляют собой точную, не допускающую неоднозначности инструкцию.

Оба оператора в Варианте 2 являются операторами присваивания. Любой оператор присваивания отдаёт компьютеру буквально следующий приказ:

Вычислить значение выражения справа от знака равенства и присвоить полученное значение переменной слева от знака равенства.

По этой причине в операторе присваивания слева от знака равенства не может находиться ничего, кроме переменной. Например, запись 5 - Х = 2, используемая в первом варианте, содержит ошибку, потому что набор символов 5 - Х не является переменной. Поэтому не существует и ячейки памяти, в которую должно быть помещено численное значение выражения, вычисленного справа от знака равенства.

Проследим, что будет делать компьютер, выполняя операторы второго варианта.

1. Переход к оператору (строка 1).

Y = 5;                      // Строка 1

2. Обращение к правой части оператора (правая часть находится между знаком равенства и точкой с запятой).

3. Компьютер обнаружил, что правая часть оператора содержит численное значение.

4. Запись численного значения (5) в ячейку памяти переменной Y.

5. Переход к следующему оператору (строка 2).

X = Y - 2;                  // Строка 2

6. Обращение к правой части оператора.

7. Компьютер обнаружил, что правая часть оператора содержит выражение.

8. Вычисление численного значения правой части оператора (5 - 2).

9. Запись численного значения (3) в ячейку памяти этой переменной Х.

Выполнение компьютером действий 1 - 4 есть исполнение первого оператора (строка 1). Выполнение компьютером действий 5 - 9 есть исполнение второго оператора (строка 2).

Для того чтобы составить работающую программу, программист должен хорошо представлять себе, что и в какой последовательности в этой программе будет выполняться. В частности, в программу заносятся не все математические вычисления, нередко возникает необходимость предварительной подготовки операторов.

Например, при решении математических задач производится немало промежуточных вычислений. Они могут помочь математику найти правильное решение, но оказываются бесполезными с точки зрения программирования. В качестве операторов в программу необходимо вносить только содержательные вычисления: например, исходные значения одних переменных или формулы для вычислений других. В предыдущем примере первый оператор несёт информацию о численном значении переменной Y, а второй оператор - формулу для вычисления интересующей нас переменной X.

В любой работающей программе есть выражения, имеющие привычный вид, но найдутся и такие, которые можно понять, только оценивая их в качестве программных операторов. Например, запись

X = X + 1;                  // Пример счётчика

с точки зрения математической логики и здравого смысла кажется ошибочной. Но она вполне приемлема, если воспринимать её как оператор (кстати, именно этот оператор имеет широкое применение).

В этом операторе вычисляется новое значение переменной Х: выполняя оператор присваивания (то есть вычисляя значение правой части оператора), компьютер обратится к ячейке памяти, несущей численное значение переменной Х (например, в момент обращения оно окажется равным 3), вычислит выражение в правой части оператора присваивания (3 + 1) и полученное значение (4) запишет в ячейку памяти переменной Х. В результате исполнения этого оператора присваивания переменная Х получит новое значение - (4). Компьютер будет удерживать это значение переменной Х до тех пор, пока переменная Х не встретится в левой части от знака равенства в каком-нибудь другом операторе присваивания. В этом случае будет вычислено новое значение этой переменной, которое она будет удерживать до следующего возможного изменения.

Операции и выраженияФункции


Виды программ - Основы языка - Учебник по MQL4

Учебник по MQL4 [image] Основы языка [image] Виды программ
  • Некоторые основные понятия
  • Константы и переменные
  • Типы данных
  • Операции и выражения
  • Операторы
  • Функции
  • Виды программ
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Виды программ

Приступая к созданию программы на MQL4, программист должен, прежде всего, ответить на вопрос о том, к какому виду программ она будет относиться. От этого зависят её содержание и функциональные возможности. В языке MQL4 различают 3 вида прикладных программ: эксперты, скрипты и пользовательские индикаторы. Любая программа, созданная программистом, будет относиться к одному из этих видов. Все они имеют своё назначение и особенности. Рассмотрим эти характеристики.

Эксперт (Expert Advisor) - программа, составленная на языке MQL4 и вызываемая клиентским терминалом для исполнения на каждом тике. Основным назначением экспертов является программное управление торговыми операциями. Эксперты создаются пользователями. В клиентском терминале отсутствуют встроенные эксперты.

Скрипт - программа, составленная на языке MQL4 и исполняемая клиентским терминалом однократно. Назначением скриптов является выполнение любых разрешённых операций, которые требуется выполнить только один раз. Скрипты создаются пользователями, клиентский терминал встроенными скриптами не укомплектован.

Пользовательский индикатор - программа, составленная на языке MQL4 и вызываемая клиентским терминалом для исполнения на каждом тике. Основным назначением индикаторов является отображение на экране линий заданных зависимостей. У индикаторов отсутствует возможность осуществления торговых операций. Различают два вида индикаторов - технические (встроенные) и пользовательские. Подробно индикаторы рассматриваются в разделах Использование технических индикаторов и Создание пользовательских индикаторов.

Выбор программистом вида вновь создаваемой программы зависит от того, что именно будет делать программа, а также от свойств и ограничений, имеющихся у программ разного вида.

Свойства программ

Запуск программы на исполнение

Существует критерий, отличающий эксперты и пользовательские индикаторы от скриптов. Это - длительность работы программы. В разделе Некоторые основные понятия уже упоминалось, что программы запускаются на исполнение кратно тикам. Это утверждение справедливо в отношении экспертов и пользовательских индикаторов, но несправедливо в отношении скриптов.

Эксперт и пользовательский индикатор. После присоединения к окну финансового инструмента программа (эксперт или пользовательский индикатор) выполняет подготовительные операции и переходит в режим ожидания тика. При поступлении тика программа запускается клиентским терминалом на выполнение, исполняет все действия, заложенные в её алгоритме, и по окончании исполнения передаёт управление клиентскому терминалу - переходит в режим ожидания тика.

Если новый тик приходится на время исполнения программы, то это не оказывает никакого влияния на исполнение программы - программа продолжает исполняться в соответствии с алгоритмом и лишь по окончании исполнения передаёт управление клиентскому терминалу. Поэтому не все тики приводят к запуску эксперта и пользовательского индикатора на исполнение, а только те, которые поступают в период, когда управление передано клиентскому терминалу и программа находится в режиме ожидания нового тика.

Новый тик снова запускает программу на выполнение. Таким образом, эксперт и пользовательский индикатор могут находиться в работе в течение длительного времени, оставаясь присоединёнными к окну финансового инструмента и периодически (кратно тикам) включаясь в практическую работу.

Существует также разница между порядком исполнения эксперта и индикатора при первом запуске программы. Эта разница определяется свойствами специальных функций программы определённого вида (см. Специальные функции). После присоединения к окну финансового инструмента эксперт выполняет подготовительные операции (функция init()) и переходит в режим ожидания тика для запуска функции start(). В отличие от экперта, индикатор не только выполняет функцию init(), но и однократно производит вызов функции start() для первого предварительного расчета значения индикатора. В дальнейшем при поступлении тика программа запускается вызовом только функции start(), то есть исполняются операторы в соответствии с алгоритмом функции start().

Скрипт. В отличие от эксперта и пользовательского индикатора, скрипт запускается на исполнение сразу же после присоединения к окну финансового инструмента, не дожидаясь поступления тика. Весь код скрипта выполняется один раз, а после того как все программные строки исполнены, скрипт заканчивает свою работу и выгружается из окна финансового инструмента. Скрипт удобно использовать для выполнения разовых операций, например, для открытия или закрытия ордеров, для отображения на экране текстовой информации, установки графических объектов и пр.

Разница в исполнении экспертов, скриптов и пользовательских индикаторов, определяется свойствами их специальных функций, которые мы рассмотрим более подробно в разделе Специальные функции.

Осуществление торговых операций

Одним из главных критериев, отличающих программы, является возможность формирования торговых приказов. Торговый приказ - это управляющее воздействие, передаваемое программой на сервер, с целью открытия, закрытия или модификации ордеров. Торговые приказы формируются в программах с помощью встроенных функций, называющихся торговыми.

Правом использования торговых функций обладают только эксперты и скрипты (и только в том случае, если включена соответствующая опция в настройках эксперта или скрипта). Использование торговых функций в пользовательских индикаторах запрещено.

Одновременное использование

Существует также отличие в количестве программ разного вида, одновременно присоединённых в окно финансового инструмента.

Эксперт. В окне финансового инструмента одновременно можно присоединить только один эксперт; одновременное использование нескольких экспертов запрещено.

Скрипт. В окне финансового инструмента одновременно можно присоединить только один скрипт; одновременное использование нескольких скриптов запрещено.

Пользовательский индикатор. В окне финансового инструмента одновременно могут быть присоединены несколько индикаторов, не мешая работе друг друга.

Все виды программ могут быть одновременно запущены в одном окне финансового инструмента при условии соблюдения ограничений, имеющихся у каждого вида. Например, можно одновременно запустить на выполнение один эксперт, один скрипт и несколько индикаторов или один эксперт и один индикатор; но в одном окне нельзя запустить на выполнение несколько экспертов или несколько скриптов, независимо от наличия программ других видов.

В то же время разрешено одновременное использование программ одного вида в разных окнах одного финансового инструмента. Например, если есть необходимость запустить на выполнение два эксперта по одному финансовому инструменту, то можно один из них запустить в одном окне, а другой - в другом. В этом случае эксперты будут работать одновременно. Однако при этом необходимо учитывать, что эксперты, запущенные на исполнение таким способом, могут формировать противоречивые торговые приказы. Например, один из экспертов может отдавать приказы на открытие, а другой - на закрытие ордеров, в результате чего может возникнуть длинная последовательность бесполезных торговых операций, результатом которой будет общий убыток.

Все виды программ могут создавать глобальные переменные клиентского терминала, доступные всем другим программам, запущенным в клиентском терминале, в том числе в окнах разных финансовых инструментов. Это позволяет скоординировать одновременную работу всех программ. Порядок использования глобальных переменных будет рассматриваться в разделе Переменные GlobalVariable.

Вызов программ на исполнение

Программы всех видов запускаются на выполнение только по инициативе пользователя. В языке MQL4 не существует возможности вызвать на исполнение эксперт, скрипт или индикатор программным способом.

Исключение составляет использование встроенной функции iCustom(), позволяющей обратиться к пользовательскому индикатору для получения некоторых данных, а также функций технических индикаторов. При этом факт обращения к функции iCustom() или к функциям технических индикаторов не приводит к отображению индикаторных линий в окне финансового инструмента (см. Простые программы на MQL4).

Таблица 2. Основные свойства экспертов, скриптов и пользовательских индикаторов.

Свойство программы | Эксперт | Скрипт | Индикатор
Продолжительность работы | В течение длительного срока | Однократно | В течение длительного срока
Осуществление торговых операций | Разрешено | Разрешено | Запрещено
Возможность отображения линий | Нет | Нет | Есть
Одновременное использование нескольких программ одного вида | Запрещено | Запрещено | Разрешено
Вызов на исполнение программным способом | Запрещено | Запрещено | Запрещено

Таким образом, если нам понадобится программа, управляющая торговлей по некоторому алгоритму, то следует создать эксперт или скрипт, а если требуется графически отобразить некоторую зависимость, то необходимо использовать индикатор.

ФункцииРедактор MetaEditor


Типы данных - Основы языка - Учебник по MQL4

Учебник по MQL4 [image] Основы языка [image] Типы данных
  • Некоторые основные понятия
  • Константы и переменные
  • Типы данных
  • Операции и выражения
  • Операторы
  • Функции
  • Виды программ
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Типы данных

Всем хорошо известно, что складывать и вычитать можно только однотипные величины. Например, яблоки можно суммировать с яблоками, но яблоки нельзя суммировать с квадратными метрами или с температурой. Аналогичные ограничения есть и в большинстве современных алгоритмических языков.

Подобно тому, как обычные объекты имеют типы характеристик цвета (красный, синий, жёлтый, зелёный), вкуса (горький, кислый, сладкий), количества (полтора, два, семь), в языке программирования MQL4 данные различаются по типу. Говоря о типе данных, мы будем иметь в виду тип значения константы, переменной и значения, возвращаемого функцией (понятие функции рассматривается в разделе Функции).

В языке MQL4 различают следующие типы (констант, переменных и значений, возвращаемых функциями):

  • int - целые числа.
  • double - действительные числа.
  • bool - значения логического типа.
  • string - значения строкового типа.
  • color - значения цветового типа.
  • datetime - значение даты и времени.

Тип int

Значения типа int - это целые числа. К этому типу относятся значения, которые являются целыми по своей сути. Примерами целых чисел могут служить: количество баров в окне финансового инструмента (16000 баров), количество открытых и отложенных ордеров (3 ордера), дистанция в пунктах от текущего курса финансового инструмента до цены открытия ордера (15 пунктов). Количество таких объектов, как события, также бывают только целыми. Например, количество попыток открыть ордер не может быть равным полутора, а только одной, двум, трём и т.д.

Различают 2 вида целых значений:

  • Десятичные значения могут состоять из цифр 0 - 9 и быть положительными или отрицательными: 10, 11, 12, 1, 5, -379, 25, -12345, -1, 2.
  • Шестнадцатеричные значения могут состоять из букв латинского алфавита от A до F или от a до f, цифр от 0 до 9, обязательно должны начинаться с 0x или 0X и принимать положительные и отрицательные значения: 0x1a7b, 0xff340, 0xAC3 0X2DF23, 0X13AAB, 0X1.

Значения типа int должны находиться в диапазоне чисел от -2 147 483 648 до 2 147 483 647. Если значение константы или переменной находится за пределами указанного диапазона, то результат работы программы будет не определён. В памяти компьютера значения констант и переменных типа int занимают 4 байта.

Пример использования в программе переменной типа int:

   int Art  = 10;                         // Пример целой переменной
   int B_27 = -1;                         // Пример целой переменной
   int Num  = 21;                         // Пример целой переменной
   int Max  = 2147483647;                 // Пример целой переменной
   int Min  = -2147483648;                // Пример целой переменной

Тип double

Значения типа double - это действительные числа, содержащие дробную часть.

Примером значений этого типа являются любые величины, значение которых может иметь дробную часть: угол наклона линии поддержки, цена финансового инструмента, среднее количество ордеров, открываемых в течение дня.

Иногда при составлении программ могут возникнуть трудности с определением типа переменной, т.е программисту бывает не сразу понятно, к какому типу (int или double) относится переменная. Рассмотрим небольшой пример:

Программа открыла в течение недели 12 ордеров. Какого типа должна быть переменная А, учитывающая среднее количество ордеров, открываемых этой программой в день? Очевидно, что ответ: A = 12 ордеров / 5 дней. То есть, переменная А = 2.4 должна учитываться в программе, как double, т.к. у этого значения есть дробная часть. А какого типа должна быть эта же переменная А в случае, если общее количество открытых за неделю ордеров составляет 10? Казалось бы, что если 2 (10 ордеров / 5 дней = 2) не имеет дробной части, то переменная А может учитываться как int. Однако это рассуждение ошибочно. Текущее значение некоторой переменной может иметь дробную часть, состоящую из одних нулей. Но важно то, что значение этой переменной является действительным по своей сути. В этом случае переменная А также должна иметь тип double, и при записи константы в программе обязательно отображается разделяющая точка: А = 2.0

Значения действительных констант и переменных состоят из целой части, десятичной точки (.) и дробной части. Они могут принимать положительные и отрицательные значения. Целая и дробная части составляются из цифр 0 - 9. Количество значащих цифр после десятичной точки может достигать 15. Например:

27.12 -1.0 2.5001 -765456.0 198732.07 0.123456789012345

Интервал значений типа double находится в пределах от -1.7 * e-308 до 1.7 * e308. В памяти компьютера значения констант и переменных типа double занимают 8 байт.

Пример использования в программе переменной типа double:

   double Art     = 10.123;                 // Пример действительной переменной
   double B_27    = -1.0;                   // Пример действительной переменной
   double Num     = 0.5;                    // Пример действительной переменной
   double MMM     = -12.07;                 // Пример действительной переменной
   double Price_1 = 1.2756;                 // Пример действительной переменной

Тип bool

Значения типа bool - это значения логического типа, содержанием которых являются ложь и истина.

Для того чтобы лучше усвоить смысл понятия логический тип, рассмотрим небольшой пример из обыденной жизни. Предположим, что у учителя возникла необходимость вести учёт наличия учебников у учеников. В этом случае учитель составит на листе бумаги список учеников и справа в строке будет делать пометки о том, есть у ученика учебник или нет. Например, он может ставить галочку и прочерк:

Список учеников |  | Учебник физики | Учебник биологии | Учебник химии
1 | Иванов | V | - | -
2 | Петров | V | - | V
3 | Сидоров | - | V | V
... | ... | ... | ... | ...
25 | Миронов | V | V | V

Значения в правых столбцах будут принимать только 2 возможных значения: верно или неверно. Эти значения нельзя отнести к ранее рассмотренным типам данных, поскольку они не являются числами. Они также не являются значениями цвета, вкуса, количества и т.д. Тем не менее, они несут важную смысловую нагрузку. В языке MQL4 подобные значения называют логическими. Характеристикой констант и переменных типа bool является то, что они могут принимать лишь 2 возможных значения - истина (true, True, TRUE, 1) или ложь (false, False, FALSE, 0). В памяти компьютера значения констант и переменных типа bool занимают 4 байта.

Пример использования в программе переменной типа bool:

   bool aa    = True;           // Логическая переменная аа    имеет значение истина
   bool B17   = TRUE;           // Логическая переменная B17   имеет значение истина
   bool Hamma = 1;              // Логическая переменная Hamma имеет значение истина

   bool Asd   = False;          // Логическая переменная Asd   имеет значение ложь
   bool Nol   = FALSE;          // Логическая переменная Nol   имеет значение ложь
   bool Prim  = 0;              // Логическая переменная Prim  имеет значение ложь

Тип string

Значение типа string - это значение строкового типа, представляющее собой набор символов кода ASCII.

В обычной жизни аналогичное содержание имеют названия, например, магазинов, марок автомобилей и пр. Значение строкового типа записывается в виде набора символов, заключённого в двойные кавычки (не путать двойные кавычки с двумя одинарными!). Кавычки используются только для того, чтобы обозначить начало и окончание значения строковой константы, а собственно значением является совокупность символов, обрамлённая кавычками.

Если необходимо ввести в строку двойную кавычку ", то перед ней надо поставить символ обратной косой черты: \. В строку могут быть введены любые специальные символьные константы, перед которыми стоит символ обратной косой черты \. Длина строковой константы - от 0 до 255 символов. Если длина строковой константы превосходит максимальную, лишние символы справа отбрасываются, и компилятор выдаёт соответствующее предупреждение. Сочетание из двух символов, первый из которых – обратная косая черта \, обычно является общепринятым и воспринимается большинством программ как указание на выполнение определённого форматирования текста. В тексте это сочетание не отображается. Например, сочетание \n указывает на необходимость переноса строки, \t указывает на табуляцию и т.д.

Значение строкового типа записывается в виде набора символов, заключённого в двойные кавычки: "MetaTrader 4", " Stop Loss", "Ssssstop_Loss", "stoploss", "10 pips". Собственно строковым значением является набор символов, находящийся внутри кавычек. Кавычки используются лишь для обозначения границ значения. Внутреннее представление - структура размером в 8 байт.

Пример использования в программе переменной типа string:

   string Prefix    = "MetaTrader 4";                 // Пример строковой переменной
   string Postfix   = "_of_my_progr. OK";             // Пример строковой переменной
   string Name_Mass = "History";                      // Пример строковой переменной
   string text      ="Верхняя строка\nНижняя строка"; // текст содержит символы перевода строки

Тип color

Значение типа color - это значение цветового типа.

Всем хорошо известно, что значит цвет: синий, красный, белый, желтый, зелёный. Нетрудно представить, что означает переменная или константа цветового типа. Это такая константа или переменная, значением которой является цвет. Это может показаться несколько непривычным, но в сущности – очень просто. Подобно тому, как значением целой константы является число, значением цветовой константы является цвет.

Значения цветовых констант и переменных могут быть представлены одним из трёх видов:

  • Литералы

    Значение цветового типа в виде литерала состоит из трёх частей, представляющих собой числовые значения интенсивности трех основных компонент цвета: красного, зеленого и синего. Значение такого вида начинается с символа C и обрамляется одинарными кавычками.

    Числовые значения интенсивности компоненты цвета лежат в диапазоне от 0 до 255 и могут записываться как в десятичном, так и в шестнадцатеричном виде.

    Примеры: C'128,128,128' (серый), C'0x00,0x00,0xFF' (синий), C'0xFF,0x33,0x00' (красный).

  • Целочисленное представление

    Целочисленное представление записывается в виде шестнадцатеричного или десятичного числа. Шестнадцатеричное число имеет вид 0xRRGGBB, где RR - значение интенсивности красной компоненты цвета, GG - зелёной, а BB - синей. Десятичные константы не имеют прямого отражения в RGB. Они представляют собой десятичное значение шестнадцатеричного целочисленного представления.

    Представление значений цветового типа в целочисленном виде и в виде шестнадцатеричных литералов очень удобно. Большинство современных текстовых и графических редакторов представляют информацию о содержании красной, синей и зелёной составляющих в выбранном значении цвета. Достаточно подобрать в редакторе нужный цвет и переписать выявленные таким образом числа в соответствующее представление значения цвета.

    Примеры: 0xFFFFFF (белый), 0x008000 (зеленый), 16777215 (белый), 32768 (зеленый).

    Рис. 11. В современных редакторах можно взять параметры цвета для литерального и целочисленного представления цветового значения константы.

  • Названия цветов

    Самым простым способом задания цвета является указание его названия в соответствии с таблицей Web-цветов. В этом случае значение цвета представляется словом, поставленным в соответствие цвету, например, Red - красный.

    Black | DarkGreen | DarkSlateGray | Olive | Green | Teal | Navy | Purple
    Maroon | Indigo | MidnightBlue | DarkBlue | DarkOliveGreen | SaddleBrown | ForestGreen | OliveDrab
    SeaGreen | DarkGoldenrod | DarkSlateBlue | Sienna | MediumBlue | Brown | DarkTurquoise | DimGray
    LightSeaGreen | DarkViolet | FireBrick | MediumVioletRed | MediumSeaGreen | Chocolate | Crimson | SteelBlue
    Goldenrod | MediumSpringGreen | LawnGreen | CadetBlue | DarkOrchid | YellowGreen | LimeGreen | OrangeRed
    DarkOrange | Orange | Gold | Yellow | Chartreuse | Lime | SpringGreen | Aqua
    DeepSkyBlue | Blue | Magenta | Red | Gray | SlateGray | Peru | BlueViolet
    LightSlateGray | DeepPink | MediumTurquoise | DodgerBlue | Turquoise | RoyalBlue | SlateBlue | DarkKhaki
    IndianRed | MediumOrchid | GreenYellow | MediumAquamarine | DarkSeaGreen | Tomato | RosyBrown | Orchid
    MediumPurple | PaleVioletRed | Coral | CornflowerBlue | DarkGray | SandyBrown | MediumSlateBlue | Tan
    DarkSalmon | BurlyWood | HotPink | Salmon | Violet | LightCoral | SkyBlue | LightSalmon
    Plum | Khaki | LightGreen | Aquamarine | Silver | LightSkyBlue | LightSteelBlue | LightBlue
    PaleGreen | Thistle | PowderBlue | PaleGoldenrod | PaleTurquoise | LightGray | Wheat | NavajoWhite
    Moccasin | LightPink | Gainsboro | PeachPuff | Pink | Bisque | LightGoldenrod | BlanchedAlmond
    LemonChiffon | Beige | AntiqueWhite | PapayaWhip | Cornsilk | LightYellow | LightCyan | Linen
    Lavender | MistyRose | OldLace | WhiteSmoke | Seashell | Ivory | Honeydew | AliceBlue
    LavenderBlush MintCream Snow White

В памяти компьютера значения констант и переменных типа color занимают 4 байта. Пример использования такой переменной в программе:

color Paint_1 = C'128,128,128';       // Переменной присвоено значение серого   цвета
color Colo    = C'0x00,0x00,0xFF';    // Переменной присвоено значение синего   цвета
color BMP_4   = C'0xFF,0x33,0x00'     // Переменной присвоено значение красного цвета

color K_12  = 0xFF3300;               // Переменной присвоено значение красного цвета
color N_3   = 0x008000;               // Переменной присвоено значение зелёного цвета
color Color = 16777215;               // Переменной присвоено значение белого   цвета
color Alfa  = 32768;                  // Переменной присвоено значение зелёного цвета

color A       = Red;                  // Переменной присвоено значение красного цвета
color B       = Yellow;               // Переменной присвоено значение желтого  цвета
color Colorit = Black;                // Переменной присвоено значение черного  цвета
color B_21    = White;                // Переменной присвоено значение белого   цвета

Тип datetime

Значение типа datetime - это значение даты и времени.

Значения этого типа могут использоваться в программах для анализа момента начала или окончания каких-либо событий, в том числе выхода важных новостей, начала/конца рабочего дня и пр. Константы даты и времени могут быть представлены в виде литеральной строки, которая состоит из 6 частей, представляющих числовое значение года, месяца, даты (либо даты, месяца, года), часа, минуты и секунды.

Константа обрамляется одинарными кавычками и начинается с символа D. Допускается использование усечённого значения: либо без даты, либо без времени, либо пустое значение. Диапазон изменения значений: от 1 января 1970 года до 31 декабря 2037 года. В памяти компьютера значения констант и переменных типа datetime занимают 4 байта. Значение представляет собой количество секунд, прошедших с 00:00 1 января 1970 года.

Пример использования в программе переменной типа datetime:

datetime Alfa    = D'2004.01.01 00:00';       // Новый Год
datetime Tim     = D'01.01.2004';             // Новый Год
datetime Tims    = D'2005.05.12 16:30:45';    // 12 мая 2005г. 16 час.30 мин.45 сек.
datetime N_3     = D'12.05.2005 16:30:45';    // 12 мая 2005г. 16 час.30 мин.45 сек.
datetime Compile = D'';                       // равнозначно D'[дата компиляции] 00:00:00'

Объявление и инициализация переменных

Для того чтобы в ходе вычислений у программы не возникало вопросов, к какому типу данных принадлежит та или иная переменная, в MQL4 принято обязательное правило явно обозначать тип переменных в самом начале программы. Прежде чем переменная начнёт участвовать в каких-либо вычислениях, её необходимо объявить.

Объявление переменной - это первое упоминание переменной в программе. При объявлении переменной указывается её тип.

Инициализация переменной - это присвоение ей при её объявлении значения, соответствующего её типу. Любая переменная может быть инициализирована. Если явно не задано никакое начальное значение, то численная переменная инициализируется нулем (0), а переменная строкового типа инициализируется пустой строкой.

В MQL4 принято обязательное явное обозначение типа переменных при их объявлении. Объявление типа переменной выполняется при первом упоминании названия этой переменной. При втором и последующих упоминаниях переменной её тип не указывается. В ходе выполнения программы может меняться значение переменной, однако её тип и название не изменяются. Объявление типа переменной может выполняться в отдельных строках или в операторах.

Объявление переменной может осуществляться в отдельной строке:

   int Var_1;                 // Объявление переменной в отдельной строке

Эта запись означает, что будет использоваться переменная Var_1 (собственно объявление переменной) и тип этой переменной - int.

Допускается объявление в одной строке нескольких переменных одного типа:

   int Var_1, Box, Comm;      // Объявление нескольких переменных в одной строке

Эта запись означает, что будут использоваться переменные Var_1, Box и Comm и тип этих переменных - int, то есть перечисленные переменные будут учтены программой как переменные целого типа.

Допускается инициализация переменных в рамках операторов:

   double Var_5 = 3.7;        // Инициализация переменной в операторе присваивания

Эта запись означает, что будет использоваться переменная Var_5 вещественного типа с начальным значением 3.7.

Нигде в последующих строках программы тип переменных не указывается. Однако всякий раз, обращаясь к переменной, программа будет помнить, что эта переменная того типа, который указан при её объявлении. По ходу вычислений в программе значения переменных могут меняться, но тип переменных не изменяется.

Название переменной никак не связано с типом переменной, т.е. по названию переменной невозможно судить о её типе. Одно и то же название переменной в разных программах может быть использовано для переменных любого типа. Но в пределах одной программы тип любой переменной может быть объявлен только один раз. В ходе выполнения программы тип объявленной переменной не изменяется.

Примеры объявления и инициализации переменных

Объявление переменных может осуществляться в нескольких строках или в одной строке.

Допускается объявление нескольких переменных одного типа одновременно. В этом случае переменные перечисляются через запятую, а в конце строки ставится точка с запятой.

Рис. 12. Примеры объявления переменных в отдельной строке.

Объявление типа переменных производится один раз при первом упоминании переменной. При втором и последующих упоминаниях переменной её тип не указывается.

Рис. 13. Примеры объявления переменных в отдельной строке.

Допускаются объявление и инициализация переменных в операторах.

Рис. 14. Примеры инициализации переменных.

Рис. 15. Инициализация переменной в заголовке составного оператора.

Константы и переменныеОперации и выражения


Константы и переменные - Основы языка - Учебник по MQL4

Учебник по MQL4 [image] Основы языка [image] Константы и переменные
MetaQuotes Sofware Corp.
  • Некоторые основные понятия
  • Константы и переменные
  • Типы данных
  • Операции и выражения
  • Операторы
  • Функции
  • Виды программ
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Константы и переменные

Понятия "константа" и "переменная" рассматриваются в одном разделе, потому что эти понятия очень близки по своей сущности.

Понятие константы

Константа — это составная часть программы; объект, имеющий значение.

Понятие "константа" в программе аналогично тому же понятию, используемому в математических уравнениях. Это — неизменная величина. Для более полного описания сущности константы, используемой в алгоритмическом языке, обратимся к известным физическим и математическим константам.

Человечеством открыты такие константы, значение которых от нас не зависит. К ним в физике относится, например, ускорение свободного падения, равное 9,8 м/с/с, а в математике - число пи = 3,14. Константы такого рода не могут быть признаны аналогией константы в алгоритмическом языке.

В математических уравнениях также используется понятие константы. Например, в уравнении Y = 3 * X + 7 числа 3 и 7 являются константами. Значение таких констант в полной мере зависит от воли человека, составившего уравнение. Это - ближайшая аналогия констант, используемых в программах на MQL4.

Константа (в виде значения) заносится программистом в код на этапе его создания. Константа характеризуется только своим значением, поэтому термины "константа" и "значение константы" являются полными синонимами.

Примеры констант:
37, 3.14, true, "Kazan"

Рис. 4. Константа в памяти компьютера.

Свойства констант

Свойством константы является её способность удерживать значение, заданное программистом, в течение времени работы программы и сообщать это значение программе при запросах программы (рис. 5). Для каждой константы, содержащейся в программе, компьютер отводит часть памяти необходимого размера. Значение константы не может быть изменено во время исполнения программы ни программистом, ни компьютером (рис. 6).

Значение константы всегда остаётся неизменным.

Рис. 5. Состояние ячейки памяти константы при сообщении значения программе.

Значение константы не может быть изменено в процессе работы программы.

Рис. 6. Изменение значения константы во время работы программы невозможно.

Понятие переменной

Переменная - это составная часть программы, имеющая значение и название.

Понятие переменной в языке MQL4 аналогично понятию переменной, принятому в математике. Разница между ними состоит лишь в том, что значение переменной в математике подразумевается, а значение переменной в исполняющейся программе хранится в специально отведенной для этого ячейке памяти компьютера.

Термин "идентификатор переменной" является полным синонимом терминов "имя переменной" и "название переменной". Переменная заносится создателем кода в его текст на этапе программирования в виде имени переменной. Имя переменной (идентификатор) может состоять из букв, цифр, знака подчёркивания. Однако начинаться оно должно с буквы. Язык MQL4 чувствителен к регистру букв, т.е. S и s - не одно и то же.

Примеры идентификаторов переменных: Alpha, alFa, beta, NuMbEr, Num, A_37, A37, qwerty_123
Следующие идентификаторы представляют названия разных переменных: a_22 и А_22; Massa и MASSA.
Примеры значений переменных: 37, 3.14, true, "Kazan".

Свойства переменной

Свойством переменной является её способность получать некоторое значение от программы, удерживать его в течение времени работы программы и сообщать это значение программе при запросах программы. Для каждой переменной в программе компьютер отводит часть памяти необходимого размера. Обратимся к рис. 7 и проследим, как устроены переменные.

Рис. 7. Переменная в памяти компьютера.

В ячейке памяти компьютера содержится значение переменной. Это значение может быть затребовано для обработки и изменено программой. Имя переменной никогда не изменяется. При создании кода программист может назначить переменной любое имя, но с момента, когда готовая программа запущена в работу, ни у программиста, ни у компьютера, ни у программы нет технической возможности изменить название переменной.

Если на пути выполнения программы встречается имя переменной, то программа обращается к этой переменной, чтобы получить для обработки её значение. Если программа обратилась к переменной, последняя сообщает программе своё значение. При этом значение переменной остаётся неизменным. Программа же получает в своё распоряжение копию значения, содержащегося в ячейке памяти, выделенной для этой переменной (рис. 8).

При сообщении значения переменной программе оно остаётся неизменным. Название (имя) переменной никогда не изменяется.

Рис. 8. Состояние ячейки памяти переменной при сообщении значения программе.

В течение некоторого времени переменная не имеет отношений с исполняемой программой. В это время программа может обращаться к другим переменным или производить необходимые вычисления. В период между случаями общения с программой переменная удерживает своё значение, т.е. сохраняет его неизменным.

В соответствии с выполняющимся алгоритмом, заложенным в программу, может потребоваться изменение значения переменной. В этом случае программа сообщает переменной её новое значение, а переменная получает это значение от программы. При этом в ячейке памяти производятся необходимые преобразования, в результате которых предыдущее значение переменной удаляется, а на его месте образуется новое значение переменной, сообщённое программой (рис. 9).

Значение переменной может быть изменено в результате воздействия программы. Название (имя) переменной остаётся неизменным всегда.

Рис. 9. Состояние ячейки памяти переменной при получении значения от программы.

Примеры констант и переменных в программе

В программе константы и переменные встречаются в операторах. В данном тексте программы А и В являются переменными, а 7 и 3 - константами:

A = 7;             // Строка 1
B = A + 3;         // Строка 2

Проследим, как программа работает с константами и переменными. Исполняя эти строки, программа выполнит следующие шаги:

Первая строка:

  1. Константа 7 сообщает своё значение программе.
  2. Переменная А получает значение 7 от программы.

Вторая строка:

  1. Программа обнаружила выражение справа от знака равенства и стремится его вычислить.
  2. Константа 3 сообщает своё значение программе.
  3. Программа обращается к переменной А по имени.
  4. Переменная А сообщает своё значение (7) программе.
  5. Программа производит вычисления (7 + 3).
  6. Переменная В получает значение 10 от программы.

В процессе работы программы значение переменной может быть изменено. Например, в программе может встретиться строка, в которой написано следующее:

В = 33;            // Строка 3

В этом случае при исполнении программы будет выполнено следующее:

  1. Константа 33 сообщает своё значение программе.
  2. Переменная В получает (новое) значение 33 от программы.

Легко заметить, что на некотором этапе выполнения программы переменная В получает значение 10, а в ходе дальнейших вычислений - значение 33. В результате этих событий название переменной В остаётся неизменным, а значение переменной изменяется.

На рис. 10 показаны константы и переменные в тексте программы:

Рис. 10. Константа и переменная в программе.

Некоторые основные понятияТипы данных


Создание и использование программ - Редактор MetaEditor - Учебник по MQL4

Учебник по MQL4 [image] Редактор MetaEditor [image] Создание и использование программ
MetaQuotes Sofware Corp.
  • Файловая система
  • Создание и использование программ
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Создание и использование программ

Прикладные программы на языке MQL4 - эксперты, скрипты и индикаторы - создаются с помощью редактора MetaEditor.

Исполняемый файл редактора MetaEditor (MetaEditor.exe) поставляется в составе клиентского терминала и находится в корневом каталоге терминала. Руководство по работе в редакторе MetaEditor открывается при нажатии клавиши F1. Здесь рассматриваются общие сведения, которые необходимы для создания новых программ. Открыть редактор для использования можно, например, кликнув по имени файла MetaEditor.exe или по ярлыку, предварительно расположенному на рабочем столе.

Структура клиентского терминала

Для удобства работы в редактор MetaEditor встроены панели "Навигатор" (Ctrl+D) и "Инструментарий" (Ctrl+T).

Рис. 25. Расположение окон в редакторе MetaEditor.

Текст программы располагается в окне редактирования, а окна инструментария и навигатора имеют вспомогательное значение. Окна навигатора и инструментария имеют подвижные границы и могут быть отображены/скрыты в редакторе с помощью кнопок [image] и [image].

Создание новой программы

Обычно при создании новой программы окна инструментария и навигатора остаются скрытыми, и внимание программиста сосредоточено на создаваемой программе. Для создания новой программы необходимо воспользоваться пунктом меню редактора Файл >> Создать или кнопкой создания новых файлов [image].

В результате этого действия "Мастер создания Советника" предложит выбрать вид создаваемой программы:

Рис. 26. Выбор вида программы при её создании.

Если требуется создать эксперт, то необходимо сделать отметку в графе Советник и нажать кнопку Далее. В следующем окне необходимо вписать название создаваемого эксперта. Пусть этот эксперт называется create.mq4.

Имя создаваемого файла указывается без расширения (указания типа).

Мастер создания советника выведет окно, в котором необходимо заполнить несколько полей ввода:

Рис. 27. Окно для указания общих параметров советника.

После клика по кнопке Готово в основном окне отобразится некоторый набор текста, и одновременно с этим в файловой системе и в окне навигатора появится полноценное название созданного нами эксперта create.mq4.

Рис. 28. Отображение созданного файла эксперта в файловой системе и в окне навигатора.

Посмотрим, какой текст программы был сгенерирован редактором MetaEditor:

//+------------------------------------------------------------------+
//|                                                       create.mq4 |
//|                                                       John Smith |
//|                                                  www.company.com |
//+------------------------------------------------------------------+
#property copyright "John Smith"
#property link      "www.company.com"

//+------------------------------------------------------------------+
//| expert initialization function                                   |
//+------------------------------------------------------------------+
int init()
  {
//----

//----
   return(0);
  }
//+------------------------------------------------------------------+
//| expert deinitialization function                                 |
//+------------------------------------------------------------------+
int deinit()
  {
//----

//----
   return(0);
  }
//+------------------------------------------------------------------+
//| expert start function                                            |
//+------------------------------------------------------------------+
int start()
  {
//----

//----
   return(0);
  }
//+------------------------------------------------------------------+

Легко увидеть, что в этом коде содержатся в основном комментарии. Мы уже знаем, что комментарии являются необязательной частью программы и текст, содержащийся в комментариях, программой не обрабатывается.

В программе имеются три специальные функции (init(), start() и deinit() ), содержанием каждой из которых является всего один оператор return(0) выхода из функции. Таким образом, код программы, сгенерированный мастером создания советников, являет собой лишь шаблон, используя который программист может создать новую программу. Конечный код программы не обязательно должен содержать все указанные специальные функции. Они представлены в программе мастером создания программ лишь потому, что обычная программа средней сложности, как правило, содержит все эти функции. Если же использование какой-либо из функций не предполагается, то её описание можно удалить.

Следующие строки в коде программы также можно опустить:

#property copyright "John Smith"
#property link      "www.company.com"

Несмотря на то, что эта программа не несёт никакой полезной нагрузки, она составлена корректно с точки зрения соблюдения синтаксиса. Поэтому, вообще говоря, эту программу можно было бы скомпилировать и запустить на выполнение. И она исполнялась бы как любая полноценная программа (при этом не выполнялись бы никакие вычисления ввиду их отсутствия в исходном коде).

Внешний вид программы

Использование подробных комментариев в программе крайне желательно, а в некоторых случаях и жизненно необходимо. Следует особо подчеркнуть, что программисту приходится не только составлять программы, но и читать их. В ряде случаев при чтении программы могут возникнуть значительные затруднения. Опыт многих программистов свидетельствует о том, что логика собственных рассуждений, на основе которых была построена программа, забывается (в случае чужой программы - неизвестна) и без построчных комментариев понять смысл иных фрагментов кода довольно сложно, а в некоторых случаях - просто невозможно.

Корректно составленная программа обязательно содержит комментарии.

Основные достоинства комментариев состоят в следующем:

  • Во-первых, комментарии позволяют отделить одну логически обособленную часть программы от другой. Гораздо легче читать удобно форматированный текст, нежели текст, составленный сплошным потоком.
  • Во-вторых, построчные комментарии позволяют пояснить обычными словами, что имел ввиду программист в каждой отдельно взятой строке кода.
  • В-третьих, в верхней части программы можно указать некоторый набор сведений, касающихся программы в целом: фамилию и реквизиты автора (в том числе, авторский сайт, адрес электронной почты и пр.), назначение программы (является она законченной торгующей программой или библиотечной функцией), основные её характеристики и ограничения, а также другую полезную информацию на усмотрение автора.

Каждый программист по своему вкусу может выбрать любой удобный ему стиль комментариев. Стиль, предлагаемый разработчиками языка MQL4, представлен в эксперте create.mq4. Рассмотрим основные особенности любого приемлемого стиля оформления программы.

1. Длина строки кода не должна превышать размер основного окна. Это ограничение не является формальным требованием синтаксиса языка, однако чтение программы, содержащей длинные строки, очень неудобно. Любую длинную строку всегда можно расположить в несколько программных строк, так, чтобы все они были полностью видны на экране. Для монитора с разрешением 1024 х 768 пикселей максимальная длина строки составляет 118 символов.

2. Объявление переменных осуществляется в начале программы. К каждой переменной желательно дать описание в комментарии: кратко отметить сущность и (если необходимо) особенности использования переменной.

3. Каждый оператор желательно располагать в отдельной строке.

4. Построчный комментарий, если он присутствует в строке, должен начинаться с 76 позиции (рекомендуется для мониторов 17" с разрешением 1024 х 768 пикс.). Это требование также не является обязательным. Например, если строка кода занимает 80 позиций, то её не обязательно разбивать на две строки, можно написать комментарий, начиная с 81 позиции. Обычно содержательная часть программы (код) составляют строки длиной около 50 символов, поэтому построчный комментарий выглядит как столбец текста в правой части экрана.

5. Для разделения логически обособленных фрагментов используются строки комментария на всю ширину (118 символов).

6. При использовании фигурных скобок обязательно используется отступ на величину табуляции (обычно 3 символа).

Посмотрим? как может выглядеть эксперт после того, как в него вписан программный код. В данном случае логика программного алгоритма не обсуждается. Здесь важно отметить только подробности оформления программы. Комментированная программа (эксперт create.mq4) может выглядеть, например, так:

//--------------------------------------------------------------------
// create.mq4
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------------
int Count=0;                                    // Глобальная перемен.
//--------------------------------------------------------------------
int init()                                      // Спец. ф-ия init()
   {
   Alert ("Сработала ф-ия init() при запуске"); // Сообщение
   return;                                      // Выход из init()
   }
//--------------------------------------------------------------------
int start()                                     // Спец. ф-ия start()
   {
   double Price = Bid;                          // Локальная перемен.
   Count++;                                     // Счётчик тиков
   Alert("Новый тик ",Count,"   Цена = ",Price);// Сообщение
   return;                                      // Выход из start()
   }
//--------------------------------------------------------------------
int deinit()                                    // Спец. ф-ия deinit()
   {
   Alert ("Сработала ф-ия deinit() при выгрузке");   // Сообщение
   return;                                      // Выход из deinit()
   }
//--------------------------------------------------------------------

Легко увидеть, что законченные смысловые блоки программы отделены друг от друга комментарием - сплошной строкой. Таким способом выделяются специальные, пользовательские функции и головная часть программы:

//--------------------------------------------------------------------

Объявление переменных выполняется в отдельном блоке, причём каждая переменная описана. Иногда в программе используются переменные, для объяснения смысла которых приходится использовать комментарий в несколько строк. Такое случается редко, но при необходимости делать это нужно обязательно, иначе не только другой программист, но и автор программы не сможет в ней разобраться по прошествии некоторого срока.

В правой части каждой строки кода дан поясняющий комментарий. Ценность комментариев становится понятной только в том случае, если их нет, и при чтении программы возникают проблемы с пониманием алгоритма. Например, если этот же код представить без комментариев и без выделения блоков с помощью табуляции, то, даже несмотря на то, что программа достаточно простая и короткая, воспринимать её станет значительно сложнее:

int Count=0;
int init() {
Alert ("Сработала ф-ия init() при запуске");
return; }
int start() {
double Price = Bid;
Count++;
Alert("Новый тик ",Count,"   Цена = ",Price);
return; }
int deinit(){
Alert ("Сработала ф-ия deinit() при выгрузке");
return;}

Компиляция программы

Чтобы программу можно было использовать на практике, её необходимо скомпилировать. Для этого нужно воспользоваться кнопкой [image] (F5) в редакторе MetaEditor. Если в программе нет ошибок, то программа будет скомпилирована, а в окне инструментария появится сообщение:

Рис. 29. Сообщение редактора об успешной компиляции программы.

При этом в соответствующем каталоге (в данном случае в Каталог_терминала\experts) появится новый файл create.ex4. Это - программа, готовая к работе в клиентском терминале MetaTrader 4. В момент компиляции в том же каталоге сохранится также последняя редакция исходного текста программы с тем же названием, в нашем случае - это файл create.mq4.

Одновременно с этим в окне навигатора клиентского терминала, в разделе Советники появится строка с названием созданного эксперта:

Рис. 30. Отображение названия эксперта в окне навигатора клиентского терминала.

Если при компиляции в программе будут обнаружены ошибки, то редактор MetaEditor выдаст соответствующее сообщение об ошибке. В таком случае необходимо вернуться к редактированию исходного текста программы, исправить ошибки и попытаться снова скомпилировать программу. Успешная компиляция программы возможна только в случае, если в ней нет ошибок.

Использование программы в практической работе

Если прикладная программа (эксперт, скрипт, индикатор) успешно скомпилирована и её название появилось в окне навигатора клиентского терминала, то её можно использовать в практической работе. Для этого достаточно мышкой перетащить соответствующий значок из окна навигатора в окно финансового инструмента. Это будет означать, что программа присоединена к окну графика финансового инструмента и будет запущена на исполнение.

Эксперт и индикатор будут оставаться в работе до тех пор, пока пользователь вручную не прекратит работу программы. Обычный скрипт, после выполнения заложенного в него алгоритма, самостоятельно прекратит свою работу.

Здесь необходимо ещё раз подчеркнуть, что:

Любые прикладные программы (эксперт, скрипт, индикатор) могут быть использованы для торговли только в составе клиентского терминала MetaTrader 4 при условии его подключения к серверу (дилинговому центру) с помощью сети Интернет; никакие программы не могут быть установлены пользователем на сервере или использоваться в терминалах других производителей.

Иными словами, если трейдер хочет использовать в своей работе какую-либо прикладную программу, он должен включить свой компьютер, открыть клиентский терминал MetaTrader 4 и запустить в окне финансового инструмента исполняемый файл *.ex4. При исполнении программы (в зависимости от её алгоритма) могут быть сформированы торговые приказы, которые будут отправлены на сервер, в результате чего и будет осуществляться управление торговлей.

Файловая системаПрограмма на MQL4


Файловая система - Редактор MetaEditor - Учебник по MQL4

Учебник по MQL4 [image] Редактор MetaEditor [image] Файловая система
MetaQuotes Sofware Corp.
  • Файловая система
  • Создание и использование программ
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Файловая система

Клиентский терминал различает виды программ по месту их расположения в подчинённых директориях.

Все прикладные программы сосредоточены в директории Каталог_терминала\experts. Эксперты, скрипты и пользовательские индикаторы, которые трейдер предполагает использовать в практической работе, должны находиться в своих директориях (см. рис. 24). Эксперты находятся непосредственно в каталоге Каталог_терминала\experts, а скрипты и индикаторы - в поддиректориях Каталог_терминала\experts\scripts и Каталог_терминала\experts\indicators.

Рис. 24. Директории для хранения файлов, созданных пользователем.

Пользователь может по своему усмотрению создавать и другие директории и хранить в них некоторые свои файлы, однако использование готовых программ, находящихся в таких директориях, в клиентском терминале не предусмотрено.

Типы файлов

В языке MQL4 различают 3 типа файлов, несущих программный код: mq4, ex4 и mqh.

Файлы типа mq4 - это исходный код программы. В файлах этого типа содержатся исходные тексты программ всех видов (экспертов, скриптов и индикаторов). Для создания кодов программ используется редактор MetaEditor. После того как код программы составлен полностью или частично, его можно сохранить, а впоследствии - снова открыть в редакторе для доработки. Файлы типа mq4 не могут быть использованы для исполнения в клиентском терминале. Для того чтобы запустить программу на выполнение, её необходимо предварительно скомпилировать. В результате компиляции исходного кода программы создаётся одноимённый файл с расширением ех4.

Файлы типа ех4 - это скомпилированная программа, готовая для практического использования в клиентском терминале. Для файлов этого типа возможность редактирования не предусмотрена. Если требуется внести изменения в программу, то необходимо обратиться к её исходному коду (файлу типа mq4), отредактировать его, а затем снова скомпилировать. По названию файла ех4 нельзя судить о том, к какому виду программ он относится - является ли он скриптом, экспертом или индикатором. Файлы ex4 могут использоваться как библиотечные.

Файлы типа mqh - включаемые файлы. Это - исходный текст часто используемых блоков пользовательских программ. Такие файлы могут включаться в исходные тексты экспертов, скриптов и пользовательских индикаторов на этапе компиляции. Обычно включаемые файлы содержат описания импортируемых функций (смотрите в качестве примера файлы stdlib. mqh или WinUser32.mqh), либо описания общих констант и переменных (stderror.mqh и WinUser32.mqh). Файлы типа mqh, как правило, хранятся в директории Каталог_терминала\experts\include.

Включаемые файлы называются так потому, что обычно их "подключают" на этапе компиляции к основному исходному файлу при помощи директивы #include. Несмотря на то что файлы типа mqh могут содержать исходный код программы и MetaEditor их компилирует, они не являются самостоятельными и самодостаточными, т.е. не требуют компиляции с целью получения исполняемых файлов типа ех4. В качестве включаемых файлов могут также использоваться файлы mq4, которые также должны храниться в каталоге Каталог_терминала\experts\include .

В навигаторе клиентского терминала в разделах "Советники", "Пользовательские индикаторы" и "Скрипты" высвечиваются только те имена файлов, которые имеют расширения ex4 и при этом находятся в соответствующем каталоге. Файлы, скомпилированные в более старой версии MetaEditor, не запускаются и отображаются серым цветом.

Существуют и другие виды файлов, не образующие законченную программу, но используемые при создании прикладных программ. Например, программу можно составить из нескольких отдельных файлов или использовать для этой цели ранее созданную библиотеку. Пользователь может создавать библиотеки пользовательских функций, предназначенных для хранения часто используемых блоков пользовательских программ. Библиотеки рекомендуется хранить в директории Каталог_терминала\experts\libraries. В качестве библиотечных могут быть использованы файлы mq4 и ex4. Библиотеки не могут самостоятельно запускаться на выполнение. Использование включаемых файлов более предпочтительно, чем использование библиотек, из-за дополнительных расходов компьютерных ресурсов при вызове библиотечных функций.

В первой части учебника "Введение в программирование на языке MQL4" нас будут интересовать файлы исходных текстов программ mq4 и скомпилированные файлы программ ех4.

Редактор MetaEditorСоздание и использование программ


Редактор MetaEditor - Учебник по MQL4

Учебник по MQL4 [image] Редактор MetaEditor
  • Файловая система
  • Создание и использование программ
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Редактор MetaEditor

В этом разделе рассматривается общий порядок создания прикладных программ с помощью редактора MetaEditor.

MetaEditor - это многофункциональный специализированный редактор, предназначенный для создания, редактирования и компиляции прикладных программ, написанных на языке MQL4. Редактор имеет дружественный интерфейс, позволяющий пользователю легко ориентироваться при написании и отладке программ.

  • Файловая система
    MetaEditor хранит все исходные коды программ на MQL4 в своем собственном структурированном каталоге на жестком диске. Местонахождение программы на MQL4 определяется ее назначением: скрипт, советник, индикатор, включаемый файл (include) или библиотека (library).

  • Создание и использование программ
    Создать первую программу на MQL4 очень просто, в этом Вам помогут встроенные помощники. Вы можете изменить шаблоны для создания скрипта, индикатора или советника. Созданный код будет автоматически сохранен в нужной папке файловой системы MetaEditor.
Виды программФайловая система


Выполнение программы - Программа на MQL4 - Учебник по MQL4

Учебник по MQL4 [image] Программа на MQL4 [image] Выполнение программы
MetaQuotes Sofware Corp.
  • Структура программы
  • Специальные функции
  • Выполнение программы
  • Примеры реализации
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Выполнение программы

Развитие навыков программирования происходит лучше всего, если в распоряжении программиста есть небольшая работающая программа. Для того, чтобы она стала в полной мере понятной, необходимо внимательно рассмотреть все её составляющие и по шагам проследить как она работает. Обратите внимание, свойства специальных функций прикладных программ разных видов (эксперт, скрипт, индикатор) имеют отличия. Здесь мы рассмотрим, как работает простой эксперт.

Пример простого эксперта ( simple.mq4 )
//--------------------------------------------------------------------
// simple.mq4
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------------
int Count=0;                                    // Глобальная перемен.
//--------------------------------------------------------------------
int init()                                      // Спец. ф-ия init()
   {
   Alert ("Сработала ф-ия init() при запуске"); // Сообщение
   return;                                      // Выход из init()
   }
//--------------------------------------------------------------------
int start()                                     // Спец. ф-ия start()
   {
   double Price = Bid;                          // Локальная перемен.
   Count++;                                     // Счётчик тиков
   Alert("Новый тик ",Count,"   Цена = ",Price);// Сообщение
   return;                                      // Выход из start()
   }
//--------------------------------------------------------------------
int deinit()                                    // Спец. ф-ия deinit()
   {
   Alert ("Сработала ф-ия deinit() при выгрузке");   // Сообщение
   return;                                      // Выход из deinit()
   }
//--------------------------------------------------------------------

В соответствии с правилами исполнения программ (см. Структура программы и Специальные функции) этот эксперт будет работать так:

1. В момент присоединения программы к окну финансового инструмента клиентский терминал передаст управление программе, в результате чего программа начнёт исполняться. Исполнение программы начнётся с головной части. В головной части программы указана всего одна строка:

int Count=0;                                    // Глобальная перемен.

В этой строке объявлена глобальная переменная Count, инициализированная нулевым значением. (Локальные и глобальные переменные подробно рассматриваются в Виды переменных. Здесь только нужно отметить, что алгоритм, используемый в этой конкретной программе, предполагает обязательное объявление переменной Count как глобальной, поэтому она не может быть объявлена внутри какой-либо функции, а должна быть объявлена за пределами описаний функций, т.е. в головной части; в результате этого значение глобальной переменной Count будет доступно из любого места программы.)

2. После исполнения головной части программы будет запущена на исполнение специальная функция init(). Обратите внимание, вызов этой функции на исполнение нигде в коде программы не содержится. Запуск на исполнение специальной функции init() эксперта в момент присоединения программы к окну финансового инструмента является собственным свойством этой функции. Клиентский терминал вызовет на исполнение специальную функцию init() просто потому, что в коде программы имеется её описание. В рассматриваемой программе описание специальной функции init() такое:

int init()                                      // Спец. ф-ия init()
   {
   Alert ("Сработала ф-ия init() при запуске"); // Сообщение
   return;                                      // Выход из init()
   }

В теле функции содержится всего два оператора.

2.1 Функция Alert() выводит окно сообщения:

Сработала ф-ия init() при запуске

2.2 Оператор return заканчивает работу специальной функции init()

В результате исполнения функции init() будет напечатано сообщение. В реально используемых программах такой алгоритм встречается редко, потому что от такого применения init() мало пользы. В самом деле, нет никакого смысла использовать функцию, которая просто уведомляет трейдера о том, что она исполняется. Здесь этот алгоритм применён лишь для того, чтобы проиллюстрировать факт исполнения специальной функции init(). Обратите внимание: специальная функция init() будет исполнена в программе всего один раз. Исполнение указанной функции произойдёт в начале работы программы, сразу после обработки головной части. В момент, когда в специальной функции init() исполнится оператор return, программа передаст управление клиентскому терминалу.

3. Клиентский терминал обнаружил в программе описание специальной функции start():

int start()                                     // Спец. ф-ия start()
   {
   double Price = Bid;                          // Локальная перемен.
   Count++;
   Alert("Новый тик ",Count,"   Цена = ",Price);// Сообщение
   return;                                      // Выход из start()
   }

31. Управление удерживается клиентским терминалом. Клиентский терминал ждёт новый тик и до прихода нового тика не запускает на исполнение ни одну из функций программы. Это значит, что некоторое время программа не работает, т.е. в программе не производится никаких действий. Возникает пауза, хотя нигде в программе нет прямого или косвенного указания на выполнение этой паузы. Необходимость ожидания тика является собственным свойством специальной функции strart() эксперта, и не существует возможности программно повлиять на это свойство (например, отключить). Программа будет находиться в ожидании управления до тех пор, пока не придёт новый тик. В момент прихода тика клиентский терминал передаст управление программе, а именно специальной функции start() (в данном случае в соответствии со свойством функции start() эксперта), в результате чего начнётся её исполнение.

32 (1). В строке

   double Price = Bid;                          // Локальная переменная

производятся следующие действия:

32.1(1). Объявление локальной переменной Price (см. Виды переменных). Значение этой локальной переменной будет доступно из любого места специальной функции start().

32.2(1). Выполнение оператора присваивания. Переменной Price будет присвоено значение текущей цены Bid. Новое значение цены появляется всякий раз с приходом очередного тика (например, на первом тике цена финансового инструмента может оказаться равной 1.2744).

33(1). Далее будет выполняться строка:

   Count++;

Эта, несколько непривычная, запись является полным аналогом записи Count=Count+1;

На момент, когда управление передаётся в эту строку, значение переменной Count равно нулю. В результате выполнения оператора Count++ значение Count будет увеличено на единицу. Таким образом, к моменту передачи управления в следующую строку, значение Count будет равно 1.

34(1). В следующей строке содержится вызов функции Alert():

   Alert ("Новый тик ",Count,"   Цена = ",Price);// Сообщение

Функция напечатает все константы и переменные, перечисленные в круглых скобках.

При первом выполнении функции start() программа напечатает Новый тик, затем обратится к переменной Count, чтобы получить её значение, (при первом выполнении это значение равно 1), напечатает это значение, вслед за этим напечатает Цена =, и, наконец, обратится к переменной Price, получит её значение (в нашем примере это значение 1.2744) и напечатает его.

В результате будет напечатана строка:

Новый тик 1 Цена = 1.2744

35(1). Оператор

   return;                                      // Выход из start()

заканчивает работу специальной функции start().

36. Управление возвращается клиентскому терминалу (на период до прихода очередного тика).

Так исполняется специальная функция start() эксперта. По окончании исполнения функция start() возвращает управление клиентскому терминалу, а с приходом нового тика клиентский терминал вновь запускает её в работу. Этот процесс (запуск start() на исполнение и возврат управления клиентскому терминалу) может поддерживаться долго - несколько дней или недель. В течение всего этого времени специальная функция start() будет периодически исполняться. В общем случае, в зависимости от параметров окружения (новых значений цены, времени, условий торговли и пр.), в специальной функции start() могут быть выполнены те или иные действия, например, открыт или модифицирован ордер.

37. С момента прихода нового тика последовательность действий по пп 32 - 36 повторяется. Однако повторяется лишь последовательность выполняемых операторов, но переменные всякий раз получают новые значения. Рассмотрим отличия между первым и вторым исполнением специальной функции start().

32 (2). В строке

   double Price = Bid;                         // Локальная переменная

производятся следующие действия:

32.1(2). Объявление локальной переменной Price (без изменений).

32.2(2). Выполнение оператора присваивания. Переменной Price будет присвоено значение текущей цены Bid (новое значение цены появляется всякий раз с приходом очередного тика, например, на втором тике цена финансового инструмента окажется равной 1.2745). (есть изменения).

33(2). Далее будет выполняться строка:

   Count++;

В момент, предшествующий передаче управления в эту строку, значение переменной Count (после первого выполнения функции start()) равно 1. В результате выполнения оператора Count++ значение Count будет увеличено на единицу. Таким образом, при втором выполнении значение Count будет равно 2 (есть изменения).

34(2). Функция Alert():

   Alert ("Новый тик ",Count,"   Цена = ",Price);// Сообщение

напечатает все константы и переменные (их новые значения), перечисленные в круглых скобках.

При втором выполнении функции start() программа напечатает Новый тик, затем обратится к переменной Count, чтобы получить её значение, (при втором выполнении это значение равно 2), напечатает это значение, вслед за этим напечатает Цена =, и, наконец, обратится к переменной Price, получит её значение (в нашем примере значение цены при втором выполнении равно 1.2745) и напечатает его (есть изменения).

В результате будет напечатана строка:

Новый тик 2 Цена = 1.2745

35(2). Оператор

      return;                                      // Выход из start()

заканчивает работу специальной функции start() (без изменений).

36(2). Управление возвращается клиентскому терминалу на ожидание нового тика.

37(2). В дальнейшем всё повторяется снова. При третьем выполнении специальной функции start() переменные получат новые значения и неминуемо будут снова напечатаны с помощью функции Alert(), т.е. программа снова выполнится по п.п. 32 - 36(3). И далее снова и снова.. 32 - 36(4), 32 - 36(5),..(6)..(7)..(8)... Если пользователь не предпримет никаких действий, то этот процесс будет повторяться бесконечно. В результате работы специальной функции start() рассматриваемой программы на экране можно наблюдать тиковую историю изменения цены.

Следующие события наступят только в тот момент, когда пользователь примет решение о прекращении работы программы и принудительно, вручную выгрузит программу из окна финансового инструмента:

4. Клиентский терминал передаст управление специальной функции deinit() (в соответствии с её свойствами).

int deinit()                                    // Спец. ф-ия deinit()
   {
   Alert ("Сработала ф-ия deinit() при выгрузке");   // Сообщение
   return;                                      // Выход из deinit()
   }

В теле функции содержится всего два оператора.

41. Функция Alert() напечатает сообщение:

Сработала ф-ия deinit() при выгрузке

42. Оператор return заканчивает работу специальной функции deinit().

Функция deinit() запускается на исполнение клиентским терминалом один раз, в результате чего в окне функции Alert() появится указанное сообщение, после чего программа будет выгружена из окна финансового инструмента.

5. На этом история исполнения эксперта заканчивается.

Присоедините эту показательную программу в окно любого финансового инструмента и запустите её на выполнение. Выполняющаяся программа отобразит на экране окно, в котором будут отображены сообщения функции Alert(). Ориентируясь по содержанию сообщений, легко понять, какая специальная функция причастна к той или иной записи.

Рис. 35. Результат работы программы simple.mq4.

На данном примере легко убедиться, что программа исполняется в соответствии со свойствами специальных функций, указанными в разделе Специальные функции. Выгрузите и загрузите программу снова. Сделав это несколько раз, Вы получите небольшой опыт использования своей первой программы. Она будет работать и сейчас и в следующий раз. В дальнейшем, программы, которые Вы напишете самостоятельно, также будут построены в соответствии с описанной структурой, и для запуска на исполнение их также нужно будет присоединять к окну финансового инструмента.

Старайтесь, чтобы ни одно понятие или правило не ускользнуло от Вашего внимания, тогда процесс составления программ на языке MQL4 окажется лёгким и приятным занятием.

Специальные функцииПримеры реализации


Программа на MQL4 - Учебник по MQL4

Учебник по MQL4 [image] Программа на MQL4
  • Структура программы
  • Специальные функции
  • Выполнение программы
  • Примеры реализации
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Программа на MQL4

С самого начала следует заметить, что программирование на языке MQL4 вполне по силам обычному человеку, хотя и требует внимания и определённых знаний.

Некоторые трейдеры, возможно, мысленно готовятся к затруднениям при обучении программированию, имея в виду, что они лишь с большим трудом могут представить сложные процессы, происходящие в недрах их компьютеров. К счастью, разработчики языка MQL4 постарались сделать его доступным широкому кругу пользователей. Приятная особенность составления программ на MQL4 состоит в том, что от программиста не требуется специальных знаний, касающихся взаимодействия клиентского терминала с операционной средой, особенностей сетевых протоколов или устройства компилятора.

Процесс составления программ на MQL4 - это выполнение простой и понятной работы. Например, водителю автомобиля необязательно уметь разбираться в устройстве двигателя, чтобы ездить на автомобиле, - достаточно научиться давить на педали и крутить руль. Вместе с тем, каждый водитель, прежде чем выехать на дорогу с оживлённым движением, проходит обучение. Приблизительно то же необходимо сделать и начинающему программисту - освоить некоторые простые принципы построения программ, и - можно начинать потихоньку "ездить".

  • Структура программы
    Несмотря на многообразие программ на MQL4, все они имеют общие черты. Можно сказать, что в основе правильно написанного кода лежит правильная структура. Поэтому необходимо понимать из чего складывается программа.
  • Специальные функции
    Есть множество функций, встроенных в язык MQL4. Такие функции называются стандартными функциями языка. Но среди них есть несколько наиболее важных, которые называют специальными. Без них невозможна работа программы, и каждая из этих функций имеет свое предназначение.
  • Выполнение программы
    Необходимо правильно понимать, как работает MQL4-программа. Не все части кода используются одинаково часто. Какие функции выполняются в первую очередь, где лучше разместить основную часть программы, какой тип программы использовать для тех или иных целей?
  • Примеры реализации
    Осваивать новый язык лучше всего на примерах. Как написать правильно простую программу? Какие ошибки можно совершить при этом?
Создание и использование программСтруктура программы


Примеры реализации - Программа на MQL4 - Учебник по MQL4

Учебник по MQL4 [image] Программа на MQL4 [image] Примеры реализации
MetaQuotes Sofware Corp.
  • Структура программы
  • Специальные функции
  • Выполнение программы
  • Примеры реализации
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Примеры реализации

В предыдущем параграфе рассматривался пример исполнения специальных функций в простом эксперте simple.mq4. Для того, чтобы закрепить материал, необходимо рассмотреть ещё несколько модификаций этой программы.

Пример правильной структуры программы

Как правило, описания функций в программе указываются в той последовательности, в которой они вызываются для исполнения клиентским терминалом, а именно, сначала приводится описание специальной функции init(), затем специальной функции start(), и последним указывается описание специальной функции deinit(). Однако специальные функции вызываются для исполнения клиентским терминалом в соответствии с их собственными свойствами, поэтому не имеет значения, в каком месте программы указано описание той или иной функции. Давайте переставим местами специальные функции и посмотрим, что из этого получится (эксперт possible.mq4).

//--------------------------------------------------------------------
// possible.mq4
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------------
int Count=0;                                    // Глобальная перемен.
//--------------------------------------------------------------------
int start()                                     // Спец. ф-ия start()
   {
   double Price = Bid;                          // Локальная перемен.
   Count++;
   Alert("Новый тик ",Count,"   Цена = ",Price);// Сообщение
   return;                                      // Выход из start()
   }
//--------------------------------------------------------------------
int init()                                      // Спец. ф-ия init()
   {
   Alert ("Сработала ф-ия init() при запуске"); // Сообщение
   return;                                      // Выход из init()
   }
//--------------------------------------------------------------------
int deinit()                                    // Спец. ф-ия deinit()
   {
   Alert ("Сработала ф-ия deinit() при выгрузке");// Сообщение
   return;                                      // Выход из deinit()
   }
//--------------------------------------------------------------------

Запустив этот эксперт на выполнение, легко убедиться, что порядок исполнения специальных функций в программе не зависит от порядка следования в программе описаний специальных функций. Вы можете самостоятельно по своему выбору поменять местами специальные функции в исходном коде и убедиться, что для любого варианта результат будет таким же, как и в случае исполнения эксперта simple.mq4.

Пример неправильной структуры программы

Совсем иные события произойдут, если в программе изменить положение головной части. В данном примере специальная функция start() указана раньше (выше по тексту), чем головная часть программы (эксперт incorrect.mq4):

//--------------------------------------------------------------------
// incorrect.mq4
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------------
int start()                                     // Спец. ф-ия start()
   {
   double Price = Bid;                          // Локальная перемен.
   Count++;
   Alert ("Новый тик ",Count,"   Цена = ",Price);// Сообщение
   return;                                      // Выход из start()
   }
//--------------------------------------------------------------------
int Count=0;                                    // Глобальная перемен.
//--------------------------------------------------------------------
int init()                                      // Спец. ф-ия init()
   {
   Alert ("Сработала ф-ия init() при запуске"); // Сообщение
   return;                                      // Выход из init()
   }
//--------------------------------------------------------------------
int deinit()                                    // Спец. ф-ия deinit()
   {
   Alert ("Сработала ф-ия deinit() при выгрузке");// Сообщение
   return;                                      // Выход из deinit()
   }
//--------------------------------------------------------------------

При попытке компиляции этого эксперта редактор MetaEditor выдаст сообщение об ошибке:

Рис. 36. Сообщение об ошибках при компиляции программы incorrect.mq4.

В данном случае строка

int Count=0;                                    // Глобальная перемен.

написана за пределами всех функций, но находится не в первых строках программы, а где-то в середине.

Определяющим моментом в структуре этой программы является то, что объявление глобальной переменной Count происходит после объявления функции (в данном случае - специальной функции start()). На данном этапе изложения мы не можем обсуждать подробности применения глобальных переменных; виды переменных и правила их использования приведены в разделе Переменные. Здесь достаточно сказать, что любая глобальная переменная должна быть объявлена раньше (выше по тексту программы), чем первое обращение к этой переменной (в данном случае из функции start()). В рассматриваемой программе это правило нарушено, поэтому компилятор сообщил об ошибке.

Пример применения пользовательской функции

Теперь посмотрим, как программа проявляется в отношении пользовательских функций. Для этого несколько модернизируем код, представленный в примере простого эксперта simple.mq4, и подробно его разберём. Программа, содержащая пользовательскую функцию, будет выглядеть так (эксперт userfunction.mq4):

//--------------------------------------------------------------------
// userfunction.mq4
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------------
int Count=0;                                    // Глобальная перемен.
//--------------------------------------------------------------------
int init()                                      // Спец. ф-ия init()
   {
   Alert ("Сработала ф-ия init() при запуске"); // Сообщение
   return;                                      // Выход из init()
   }
//--------------------------------------------------------------------
int start()                                     // Спец. ф-ия start()
   {
   double Price = Bid;                          // Локальная перемен.
   My_Function();                               // Вызов польз. ф-ии
   Alert("Новый тик ",Count,"   Цена = ",Price);// Сообщение
   return;                                      // Выход из start()
   }
//--------------------------------------------------------------------
int deinit()                                    // Спец. ф-ия deinit()
   {
   Alert ("Сработала ф-ия deinit() при выгрузке");// Сообщение
   return;                                      // Выход из deinit()
   }
//--------------------------------------------------------------------
int My_Function()                               // Описание польз.ф-ии
   {
   Count++;                                     // Счётчик обращений
   }
//--------------------------------------------------------------------

Прежде всего, посмотрим, какие внесены изменения и какая часть кода осталась нетронутой.

Остались без изменений:

1. Головная часть осталась без изменений.

// userfunction.mq4
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------------
int Count=0;                                    // Глобальная перемен.

2. Специальная функция init() осталась без изменений.

int init()                                      // Спец. ф-ия init()
  {
   Alert ("Сработала ф-ия init() при запуске"); // Сообщение
   return;                                      // Выход из init()
  }

3. Специальная функция deinit() осталась без изменений.

int deinit()                                    // Спец. ф-ия deinit()
  {
  Alert("Сработала ф-ия deinit() при выгрузке");// Сообщение
  return;                                       // Выход из deinit()
  }

Изменения:

1. Добавилась пользовательская функция My_Function().

int My_Function()                               // Описание польз.ф-ии
  {
   Count++;                                     // Счётчик обращений
  }

2. Претерпел изменение код специальной функции start(): в нём появилось обращение к пользовательской функции, а также отсутствует строка вычисления переменной Count.

int start()                                     // Спец. ф-ия start()
  {
   double Price = Bid;                          // Локальная перемен.
   My_Function();                               // Вызов польз. ф-ии
   Alert("Новый тик ",Count,"   Цена = ",Price);// Сообщение
   return;                                      // Выход из start()
  }

В разделе Выполнение программы рассматривался порядок исполнения специальных функций init() и deinit(). В данном примере исполнение этих функций будет происходить так же, поэтому здесь нет необходимости останавливаться на их работе. Рассмотрим исполнение специальной функции start() и пользовательской функции My_Function(). Описание пользовательской функции расположено за пределами всех специальных функций, как и должно быть. Вызов пользовательской функции указан в коде специальной функции start(), что тоже верно.

После того, как исполнится специальная функция init(), программа будет исполняться так:

31. Специальная функция start() находится в ожидании запуска клиентским терминалом. С приходом нового тика терминал запустит функцию start() на исполнение, в результате чего произойдут следующие события:

32 (1). В строке

      double Price = Bid;                        // Локальная перемен.

производятся те же действия:

32.1(1). Инициализация локальной переменной Price (см. Виды переменных). Значение этой локальной переменной будет доступно из любого места специальной функции start().

32.2(1). Выполнение оператора присваивания. Переменной Price будет присвоено последнее известное значение текущей цены Bid (например, на первом тике цена финансового инструмента окажется равной 1.2744).

33(1). Следующей записью в коде является обращение к пользовательской функции My_Function():

   My_Function();                                // Вызов польз. ф-ии

Эта строка будет исполнена в рамках продолжающейся работы специальной функции start(). Результатом выполнения этой части кода (обращение к пользовательской функции) будет передача управления в тело (описание) пользовательской функции с последующим возвратом управления в место вызова.

34(1). В описании пользовательской функции имеется всего один оператор:

   Count++;

При первом вызове пользовательской функции значение переменной Count равно нулю. В результате выполнения оператора Count++ значение переменной Count будет увеличено на единицу. Исполнив этот оператор (единственный и последний) пользовательская функция заканчивает свою работу и передаёт управление в то место, откуда она была вызвана.

Необходимо подчеркнуть, что пользовательские функции могут быть вызваны для работы только из специальных функций ( или из других пользовательских, которые в конечном счёте всё равно вызваны из специальных). Поэтому справедливым является утверждение, что в любой текущий момент работает одна из специальных функций (или специальная функция start() может находиться в состоянии ожидания нового тика - запуска её на исполнение клиентским терминалом), а пользовательские функции исполняются лишь в рамках исполнения специальных функций.

В данном случае управление возвращается в (исполняющуюся) специальную функцию start(), а именно в строку, следующую за оператором вызова функции:

35(1). В этой строке содержится вызов функции Alert():

   Alert ("Новый тик ",Count,"   Цена = ",Price);// Сообщение

Функция Alert() выведет в окно сообщения все константы и переменные, перечисленные в круглых скобках:

Новый тик 1 Цена = 1.2744

36(1). Оператор

   return;                                       // Выход из start()

заканчивает работу специальной функции start().

37. Управление передаётся клиентскому терминалу на ожидание нового тика.

При следующих исполнениях специальной функции start() переменные получат новые значения и снова будут выведены в окно сообщения функции Alert(), т.е. программа снова выполнится по пп 32 - 36. В том числе, при каждом исполнении функции start() (на каждом тике) будет срабатывать обращение к пользовательской функции My_Function(), и эта функция будет выполняться. Исполнение специальной функции start() будет продолжаться до тех пор, пока пользователь не примет решение о прекращении работы программы. В этом случае отработает специальная функция deinit() и программа прекратит свою работу.

Запущенная на исполнение программа userfunction.ех4 отобразит на экране окно, в котором будут выводиться сообщения функции Alert(). Обратите внимание, результат работы программы будет таким же, как и результат работы простого эксперта simple.mq4. Легко увидеть, что структура программы userfunction.mq4 составлена в соответствии с обычным порядком расположения функциональных блоков. Если же этот порядок изменить на другой допустимый порядок, то результат работы программы не изменится.

Выполнение программыОператоры


Специальные функции - Программа на MQL4 - Учебник по MQL4

Учебник по MQL4 [image] Программа на MQL4 [image] Специальные функции
MetaQuotes Sofware Corp.
  • Структура программы
  • Специальные функции
  • Выполнение программы
  • Примеры реализации
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Специальные функции

Отличительной особенностью программ, предназначенных для работы в клиентском терминале MetaTrader 4, является их работа с постоянно обновляющейся информацией в режиме реального времени. В языке MQL4 эта особенность нашла своё отражение в виде трёх специальных функций: init(), start() и deinit().

Специальные функции - это функции с предопределёнными именами init(), start() и deinit(), обладающие специальными собственными свойствами.

Свойства специальных функций

Общее свойство специальных функций

Главным свойством всех специальных функций является их исполнение в программе при определённых условиях без использования вызова специальной функции из программы. Специальные функции вызываются для исполнения клиентским терминалом. Если в программе есть описание специальной функции, то она будет вызвана (и исполнена) в соответствии с условиями вызова (собственными свойствами).

Специальные функции вызываются для исполнения клиентским терминалом.

Собственные свойства специальных функций

Специальная функция init().

Собственным свойством специальной функции init() является её исполнение при запуске (инициализации) программы. Если в программе есть описание специальной функции init(), то она будет вызвана (и исполнена) в момент запуска программы. Если в программе нет специальной функции init(), то при запуске программы не выполняется никаких действий.

В экспертах специальная функция init() вызывается (и исполняется) также сразу после старта клиентского терминала и подгрузки исторических данных, после смены финансового инструмента и/или периода графика, после перекомпиляции программы в редакторе MetaEditor, после смены входных параметров из окна настройки эксперта и после смены счёта.

В скриптах специальная функция init() вызывается (и исполняется) сразу после прикрепления к графику финансового инструмента.

В пользовательских индикаторах специальная функция init() вызывается (и исполняется) сразу после старта клиентского терминала, после смены финансового инструмента и/или периода графика, после перекомпиляции программы в редакторе MetaEditor и после смены входных параметров из окна настройки пользовательского индикатора.

Специальная функция start().

Собственные свойства специальной функции start() отличаются в зависимости от вида исполняемой программы.

В экспертах специальная функция start() вызывается (и исполняется) сразу после прихода очередного тика. Если новый тик поступил в период выполнения специальной функции start(), то этот тик будет проигнорирован, т.е. вызов на исполнение специальной функции start() в момент прихода такого тика осуществляться не будет. Все котировки, пришедшие в период выполнения специальной функции start(), будут проигнорированы. Запуск специальной функции start() на исполнение производится клиентским терминалом только при условии, что предыдущий сеанс работы полностью завершён, управление передано клиентскому терминалу и специальная функция start() находится в ожидании нового тика.

На возможность вызова и исполнения специальной функции start() влияет состояние кнопки "Разрешить/запретить советников". Если указанная кнопка находится в состоянии запрета, то клиентский терминал не будет вызывать для исполнения специальную функцию start() вне зависимости от поступления новых котировок. Вместе с тем, перевод этой кнопки из разрешающего состояния в состояние запрета не прерывает текущий сеанс работы специальной функции start().

Специальная функция start() не вызывается клиентским терминалом на выполнение при открытом окне свойств эксперта. Окно свойств эксперта может быть открыто для внесения изменений только в период, когда специальная функция start() находится в состоянии ожидания нового тика. Это окно не может быть открыто в момент текущего сеанса выполнения специальной функции start() эксперта.

В скриптах специальная функция start() вызывается (и исполняется) один раз сразу после выполнения инициализации программы в специальной функции init().

В пользовательских индикаторах специальная функция start() вызывается (и исполняется) сразу после прихода очередного тика, сразу после прикрепления индикатора к графику, при изменении размеров окна финансового инструмента, при переходе пользователем от одного окна финансового инструмента к другому, при открытии клиентского терминала (если в предыдущем сеансе работы индикатор был прикреплен к графику) а также после смены символа или периода текущего графика вне зависимости от поступления новых котировок.

Прекращение текущего сеанса выполнения специальной функции start() для программ всех видов может осуществляться по причине отсоединения программы от графика, смены финансового инструмента и/или периода графика, смены счета, закрытия графика, а также в результате завершения работы клиентского терминала. Если специальная функция start() выполнялась в момент команды на завершение работы, то время, отпущенное терминалом для завершения исполнения функции, составляет 2,5 секунды. Если после поступления команды на завершение работы специальная функция start() продолжит работу более указанного лимита времени, то она будет принудительно остановлена клиентским терминалом.

Специальная функция deinit().

Собственным свойством специальной функции deinit() является её исполнение при закрытии (деинициализации) программы. Если в программе есть описание специальной функции deinit(), то она будет вызвана (и исполнена) в момент закрытия программы. Если в программе нет специальной функции deinit(), то при закрытии программы не выполняется никаких действий.

Специальная функция deinit() вызывается для исполнения клиентским терминалом также при завершении работы клиентского терминала, при закрытии окна финансового инструмента, непосредственно перед сменой финансового инструмента и/или периода графика, при удачной перекомпиляции программы в редакторе MetaEditor, при смене входных параметров, а также при смене счета.

В экспертах и скриптах закрытие программы с необходимостью вызова специальной функции deinit() происходит и по причине присоединения к окну финансового инструмента новой программы того же вида, замещающей предыдущую.

В пользовательских индикаторах исполнение специальной функции deinit() в результате присоединения к графику нового индикатора не происходит. В окне финансового инструмента может работать одновременно несколько различных индикаторов, поэтому присоединение к окну финансового инструмента нового индикатора не приводит к закрытию других индикаторов с необходимостью вызова на исполнение функции deinit().

Время исполнения специальной функции deinit() ограничено периодом 2,5 секунды. В случае, если код, заложенный в специальную функцию deinit(), выполняется дольше указанного времени, то клиентский терминал принудительно завершит работу специальной функции deinit() и программы в целом.

Требования к специальным функциям

Допускается отсутствие в программе специальных функций init() и deinit(). Порядок следования в программе описаний специальных функций не имеет значения. Специальные функции могут быть вызваны из любого места программы в соответствии с общим порядком вызова функции.

Специальные функции могут иметь параметры. Однако при вызове этих функций клиентским терминалом никакие параметры переданы извне не будут, а будут использованы умолчательные значения.

Специальные функции init() и deinit() должны по возможности максимально быстро завершать свою работу и ни в коем случае не зацикливаться в попытке начать полноценную работу раньше вызова функции start().

Порядок использования специальных функций

Разработчики предоставили в распоряжение программистов очень удобный механизм: при включении программы в работу прежде всего исполняется init(), после этого вся основная работа (так долго по времени, сколько нужно пользователю) осуществляется с помощью функции start(), а когда пользователь завершил работу программы, то ненадолго перед выгрузкой программы будет запущена функция deinit().

Весь основной код программы должен быть сосредоточен в функции start(). Внутри неё должны располагаться операторы, обращения к встроенным и пользовательским функциям, производиться необходимые вычисления. В то же время следует правильно понимать роль, отведенную пользовательским функциям. Описание пользовательских функций располагается в коде программы за пределами описаний специальных функций, но если пользовательская функция вызвана для исполнения, то при этом специальная функцию свою работу не прекращает. Это значит, что управление на некоторое время передаётся в пользовательскую функцию, но сама пользовательская функция работает в рамках исполнения вызвавшей её специальной функции. Поэтому справедливо будет сказать, что в процессе выполнения программы специальные функции работают всегда (согласно их собственным свойствам), а пользовательские включаются в работу по мере их вызова из специальных.

В случае если программист не предполагает использовать какую-то из специальных функций, то он может отказаться от её применения в программе. В этом случае клиентский терминал её вызывать не будет. Абсолютно нормальной следует считать программу, содержащую все три специальные функции. Нормальной также можно считать программу, в которой отсутствуют функции init() или deinit() или одновременно обе эти функции.

Если в программе не используется ни одна специальная функция, то такая программа не будет работать. Клиентским терминалом запускаются на исполнение только специальные функции в соответствии с их свойствами. Пользовательские функции клиентским терминалом не вызываются. Поэтому, если программа не содержит ни одной специальной функции (а содержит только пользовательские), то она никогда не будет вызвана для исполнения.

Нежелательно из специальной функции init() вызывать специальную функцию start() или совершать торговые операции, так как в момент инициализации модуля могут быть не готовы значения параметров информационного окружения (данные графиков, рыночные цены и пр.).

В разделах Выполнение программы и Примеры реализации представлено несколько практических примеров, на которых можно проследить некоторые свойства специальных функций.

Структура программыВыполнение программы


Структура программы - Программа на MQL4 - Учебник по MQL4

Учебник по MQL4 [image] Программа на MQL4 [image] Структура программы
MetaQuotes Sofware Corp.
  • Структура программы
  • Специальные функции
  • Выполнение программы
  • Примеры реализации
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Структура программы

Ранее мы ознакомились с основными понятиями, на которых базируется язык программирования MQL4. Теперь необходимо рассмотреть, как устроена программа в целом. Изучая этот вопрос, мы рассмотрим её структурную схему.

Как уже упоминалось, основной код программы, составленный программистом, располагается внутри пользовательских и специальных функций. В разделе Функции мы рассматривали понятие и свойства встроенных и пользовательских функций. Кратко напомним, что пользовательская функция имеет описание, а для запуска её на исполнение в программе используется вызов функции. Любая встроенная или пользовательская функция может быть исполнена только в результате обращения к ней; в этом случае говорят, что функция вызвана для исполнения программой.

Свойства специальных функций подробно изложены в разделе Специальные функции, а здесь мы рассмотрим только общие сведения о них. Специальная функция - это такая функция, которая вызывается для исполнения клиентским терминалом. В отличие от обычных функций, специальные функции имеют только описание, а вызов специальных функций в программе не указывается. Специальные функции вызываются для исполнения клиентским терминалом (имеется техническая возможность вызова специальных функций и из программы, но мы будем считать такой способ некорректным и здесь рассматривать не будем). Когда программа запущена на исполнение в окне финансового инструмента, клиентский терминал передаёт управление одной из специальных функций, в результате чего эта функция исполняется.

Правило программирования на языке MQL4 состоит в следующем:

Код программы должен быть расположен внутри функций.

Это значит, что программные строки (операторы и обращения к функциям), находящиеся за пределами функций, не могут быть исполнены. При попытке компиляции такой программы редактор MetaEditor выдаст соответствующее сообщение об ошибке, и исполняемый файл *.ехе в результате компиляции получен не будет.

Рассмотрим функциональную схему обычной прикладной программы-эксперта:

Рис. 31. Функциональная схема программы (эксперта).

Наиболее крупными функциональными блоками составленной на MQL4 программы являются:

1. Головная часть программы.

2. Специальная функция init().

3. Специальная функция start().

4. Специальная функция deinit().

5. Пользовательские функции.

В дальнейшем мы будем рассматривать только внутреннее содержание этих функциональных блоков (составных частей) программы, а все внешние объекты, будь то информационная среда клиентского терминала или оборудование, не будут входить в круг наших интересов.

Информационная среда клиентского терминала МТ4

Информационная среда клиентского терминала МТ4 не является составной частью программы. Информационная среда - это набор параметров, доступных для обработки программой. Например, это - пришедшая с новым тиком цена финансового инструмента, накапливающийся с каждым новым тиком объём, сведения о максимальных и минимальных ценах исторических баров, параметры, характеризующие предлагаемые дилинговым центром условия торговли и т.д. Информационная среда постоянно сохраняется и с каждым новым тиком обновляется клиентским терминалом, поддерживающим постоянную связь с сервером.

Структура программы

Головная часть

Головная часть - это несколько строк программы, расположенных в её начале (буквально - в первой, второй строке и т.д.), содержащих некоторые записи. В этих строках размещается информация общего характера, касающаяся программы в целом. Например, в головной части располагаются строки объявления и инициализации глобальных переменных (необходимость расположения той или иной информации в головной части программы будет рассмотрена ниже). Признаком окончания головной части может служить встретившееся в следующей строке описание функции (пользовательской или специальной).

Специальные функции

Обычно после головной части следует описание специальных функций. Внешне описание специальной функции выглядят так же, как и описание обычной пользовательской функции, с той разницей, что специальные функции имеют предопределённые имена - init(), start() и deinit(). Специальные функции представляют собой собственно блок вычислений и находятся во взаимоотношениях с информационной средой клиентского терминала и пользовательскими функциями. Специальные функции подробно рассматриваются в разделе Специальные функции.

Пользовательские функции

Описания пользовательских функций обычно располагаются непосредственно после описания специальных функций. Количество пользовательских функций в программе не ограничено. На схеме представлены всего две пользовательские функции, в то время как в программе их может быть 10 или 500, или ни одной. Если в программе не применяются пользовательские функции, значит, программа будет иметь упрощённый вид: головную часть и описания специальных функций.

Стандартные функции

Ранее упоминалось, что стандартные функции могут быть представлены только в виде вызова функции. Вообще говоря, стандартная функция, как и специальные и пользовательские функции, имеет описание. Однако это описание не указывается в программе (поэтому и не показано на схеме). Описание стандартной функции скрыто от глаз программиста, его невозможно изменить, но оно доступно редактору MetaEditor. В период компиляции программы редактор MetaEditor сформирует такой исполняемый файл, в котором в полной мере правильно будут исполняться все вызываемые стандартные функции.

Порядок расположения в программе

Головная часть программы должна находиться в первых строках. Порядок расположения в программе описаний специальных и пользовательских функций не имеет значения. На рис. 32 представлена обычная последовательность функциональных блоков, а именно - головная часть, специальные функции, пользовательские функции. На рис. 33 представлены другие варианты структуры программы. Во всех примерах головная часть находится вверху, в то время как в отношении описаний функций допускается произвольный порядок.

Рис. 32. Обычный порядок расположения функциональных блоков в программе (рекомендуется).

Рис. 33. Возможные варианты расположения функциональных блоков в программе (произвольный порядок).

Особо нужно отметить:

Ни одна функция не может быть описана внутри другой функции. Использование в программе описания функции, расположенного внутри другой функции, запрещено.

Ниже представлены примеры неправильно расположенного описания функции.

Рис. 34. Примеры неправильного расположения описаний функций в программе.

Если программист ошибочно составит программу, в которой описание какой-либо функции расположено в пределах описания другой функции, на этапе компиляции редактор MetaEditor выдаст сообщение об ошибке, и исполняемый файл для такой программы создан не будет.

Последовательность исполнения кода в программе

Головная часть и специальные функции

С момента, когда программа запущена на исполнение в окне финансового инструмента, исполняются строки головной части программы.

После того как приготовления, описанные в головной части, выполнены, клиентский терминал передаёт управление специальной функции init(), в результате чего эта функция исполняется (передача управления показана на структурной схеме крупными жёлтыми стрелками). Специальная функция init() вызывается для исполнения один раз в начале работы программы. В этой функции обычно указывается код, который необходимо выполнить один раз перед началом основной работы программы. Например, при исполнении функции init() выполняется инициализация некоторых глобальных переменных, в окне финансового инструмента отображаются графические объекты, выводятся те или иные сообщения. Когда все программные строки в функции init() исполнены, функция заканчивает исполнение, в результате чего управление возвращается клиентскому терминалу.

Основное время работы программы - это период работы функции start(). При некоторых условиях (см. свойства специальных функций в разделе Специальные функции), в том числе - при поступлении в клиентский терминал нового тика с сервера, клиентский терминал вызовет для исполнения специальную функцию start(). Эта функция (как и другие функции) может обращаться к информационному окружению клиентского терминала, производить необходимые вычисления, открывать и закрывать ордера, словом производить любые действия, позволенные правилами языка MQL4. Обычно в ходе исполнения специальной функции start() вырабатывается решение, которое реализуется в виде управляющего воздействия (красная стрелка). Таким управляющим воздействием может быть сформированный программой торговый приказ на открытие, закрытие или модификацию ордера.

После того как весь код специальной функции start() эксперта будет исполнен, функция start() закончит свою работу и вернёт управление клиентскому терминалу. Некоторое время клиентский терминал будет удерживать управление, не запуская на исполнение ни одну из специальных функций. Возникает пауза, в течение которой программа не работает. В дальнейшем, при поступлении нового тика, клиентский терминал снова передаст управление специальной функции start(), в результате чего она снова начнёт исполняться, а по окончании исполнения вернёт управление клиентскому терминалу. На следующем тике функция start() снова будет запущена на исполнение клиентским терминалом.

Процесс многократного вызова на исполнение специальной функции start() клиентским терминалом будет продолжаться до тех пор, пока программа прикреплена к окну финансового инструмента, и может продолжаться недели и месяцы. В течение всего этого периода эксперт может осуществлять автоматическую торговлю, т.е. выполнять своё основное назначение. На схеме процесс многократного исполнения функции start() показан несколькими крупными жёлтыми стрелками, огибающими специальную функцию start().

В момент, когда трейдер отсоединит эксперт от окна финансового инструмента, клиентский терминал один раз запустит на исполнение специальную функцию deinit(). Исполнение этой функции вызвано необходимостью корректного завершения работы эксперта. В процессе работы программа может, например, создавать графические объекты и глобальные переменные клиентского терминала. Поэтому в коде функции deinit() обычно указываются программные строки, исполнение которых приводит к удалению теперь уже ненужных объектов и переменных. После завершения исполнения специальной функции deinit() управление возвращается клиентскому терминалу.

Исполняющиеся специальные функции могут обращаться к информационному окружению (тонкие синие стрелки на схеме) и вызывать для исполнения пользовательские функции (тонкие жёлтые стрелки). Обратите внимание на то, что специальные функции выполняются в результате их вызова клиентским терминалом в порядке, предопределённом в свойствах этих функций: сначала init(), потом (многократно) start() и потом deinit(). Условия, при которых клиентский терминал вызывает специальные функции, описаны в разделе Специальные функции.

Пользовательские функции

Пользовательские функции исполняются тогда, когда в какой-нибудь функции встретился вызов этой пользовательской функции. В этом случае управление передаётся на время в пользовательскую функцию, а по её завершении возвращается в место вызова (тонкие оранжевые стрелки на схеме). Вызов на исполнение пользовательской функции может содержаться не только в описании специальной функции, но и в описании вызываемых из неё других пользовательских функций. Одни пользовательские функции могут вызывать для исполнения другие пользовательские функции - такой порядок вызова пользовательских функций является позволительным и широко используется в практике программирования.

Пользовательские функции не вызываются для исполнения клиентским терминалом. Любые пользовательские функции всегда выполняются в рамках исполнения какой-то из специальных функций, возвращающих управление клиентскому терминалу. Пользовательские функции также могут запрашивать (использовать) для обработки значения переменных окружения - информационной среды клиентского терминала (тонкие синие стрелки на схеме).

Если в программе имеется описание пользовательской функции, но нигде не встречается вызов её на исполнение, то такая пользовательская функция будет исключена из готовой программы на этапе компиляции и в процессе работы программы использоваться не будет.

Обратите внимание: специальные функции вызываются для исполнения клиентским терминалом. Пользовательские функции исполняются в результате их вызова из специальных или других пользовательских функций, но никогда не вызываются клиентским терминалом. Управляющее воздействие (торговые приказы) может быть сформировано как в специальных, так и в пользовательских функциях.

Программа на MQL4Специальные функции


Оператор присваивания - Операторы - Учебник по MQL4

Учебник по MQL4 [image] Операторы [image] Оператор присваивания
MetaQuotes Sofware Corp.
  • Оператор присваивания
  • Условный оператор if - else
  • Оператор цикла while
  • Оператор циклa for
  • Оператор break
  • Оператор continue
  • Оператор switch
  • Вызов функции
  • Описание функции и оператор return
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Оператор присваивания

Оператор присваивания - самый простой и наиболее распространённый оператор.

Формат оператора присваивания

Оператор присваивания представляет собой запись, содержащую символ = (знак равенства), слева от которого указано имя переменной, а справа - выражение. Оператор присваивания заканчивается знаком ; (точка с запятой).

  Переменная = Выражение;                          // Оператор присваивания

Оператор присваивания можно отличить в тексте программы по наличию знака равенства. В качестве выражения может быть указана константа, переменная, вызов функции или собственно выражение.

Правило исполнения оператора присваивания

Вычислить значение выражения справа от знака равенства и полученное значение присвоить переменной, указанной слева от знака равенства.

Оператор присваивания, как и любой другой оператор, является исполняемым. Это значит, что запись, составляющая оператор присваивания, исполняется в соответствии с правилом. При исполнении оператора присваивания вычисляется значение в правой части, а затем это значение присваивается переменной слева от знака равенства. В результате исполнения оператора присваивания переменная в левой части всегда получает новое значение; это значение может отличаться или совпадать с предыдущим значением этой переменной. Вычисление выражения в правой части оператора присваивания осуществляется в соответствии с порядком вычисления выражений (см. Операции и выражения).

Примеры операторов присваивания

В операторе присваивания допускается объявление типа переменной слева от знака равенства:

   int In = 3;                // Переменной In присвоено значение константы
   double Do = 2.0;           // Переменной Do присвоено значение константы
   bool Bo = true;            // Переменной Bo присвоено значение константы
   color Co = 0x008000;       // Переменной Co присвоено значение константы
   string St = "sss";         // Переменной St присвоено значение константы
   datetime Da= D'01.01.2004';// Переменной Da присвоено значение константы

Ранее объявленные переменные используются в операторе присваивания без указания типа.

   In = 7;                   // Переменной In присвоено значение константы
   Do = 23.5;                // Переменной Do присвоено значение константы
   Bo = 0;                   // Переменной Bo присвоено значение константы

В операторе присваивания не допускается объявление типа переменной в правой части от знака равенства:

   In = int In_2;            // Объявление типа переменных в правой части запрещено
   Do = double Do_2;         // Объявление типа переменных в правой части запрещено

В операторе присваивания не допускается повторное объявление типа переменных.

   int In;                   // Объявление типа переменной In
   int In = In_2;            // Не допускается повторное объявление переменной (In)

Примеры использования в правой части пользовательских и стандартных функций:

   In = My_Function();      // In присвоено значение пользоват. функции
   Do = Gipo(Do1,Do1);      // Do присвоено значение пользоват. функции
   Bo = IsConnected();      // Bo присвоено значение стандартн. функции
   St = ObjectName(0);      // St присвоено значение стандартн. функции
   Da = TimeCurrent();      // Da присвоено значение стандартн. функции

Примеры использования в правой части выражений:

   In = (My_Function()+In2)/2;        // Переменной In присвоено
                                      // ..значение выражения
   Do = MathAbs(Do1+Gipo(Do2,5)+2.5); // Переменной Do присвоено
                                      // ..значение выражения

При вычислениях в операторе присваивания применяются правила приведения типов данных (см. Приведение типов).

Примеры операторов присваивания краткой формы

В MQL4 используется также краткая форма записи операторов присваивания. Это - форма операторов присваивания, в которой используются операции присвоения, отличные от операции присвоения = (знак равенства) (см. Операции и выражения). На операторы краткой формы распространяются те же правила и ограничения. Краткая форма операторов присваивания используется в коде для наглядности. Программист по своему усмотрению может использовать ту или иную форму оператора присваивания. Любой оператор присваивания краткой формы может быть легко переписан в полноформатный, при этом результат исполнения оператора не изменится.

   In /= 33;              // Краткая форма записи оператора присваивания
   In = In/33;            // Полная  форма записи оператора присваивания

   St += "_exp7";         // Краткая форма записи оператора присваивания
   St = St + "_exp7";     // Полная  форма записи оператора присваивания

ОператорыУсловный оператор if - else


Оператор break - Операторы - Учебник по MQL4

Учебник по MQL4 [image] Операторы [image] Оператор break
  • Оператор присваивания
  • Условный оператор if - else
  • Оператор цикла while
  • Оператор циклa for
  • Оператор break
  • Оператор continue
  • Оператор switch
  • Вызов функции
  • Описание функции и оператор return
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Оператор break

В ряде случаев, например, при программировании циклических операций, возникает необходимость прервать выполнение цикла ещё до того, когда условие оператора цикла станет ложным. Для решения подобных задач необходимо использовать оператор break.

Формат оператора break

Оператор break состоит из одного слова, заканчивается знаком ; (точка с запятой).

   break;                                         // Оператор break

Правило исполнения оператора break

Оператор break прекращает исполнение ближайшего внешнего оператора while, for или switch. Исполнением оператора break является передача управления за пределы составного оператора while, for или switch, ближайшему следующему оператору. Оператор break может использоваться только для прерывания выполнения указанных операторов.

Исполнение оператора break можно проиллюстрировать на следующем примере.

Задача 14. Дана нить длиной 1 метр. Требуется сложить нить в форме прямоугольника, имеющего максимально возможную площадь. Путём последовательного перебора вариантов найти площадь этого прямоугольника и длины сторон с точностью до 1 мм.

Из цельного отрезка нити можно сложить бесконечное количество прямоугольников различных размеров. Учитывая, что по условиям задачи точность вычислений составляет 1 мм, мы можем рассмотреть всего 499 вариантов. Первый, самый "тонкий", прямоугольник будет иметь размеры 1 х 499 мм, второй - 2 х 498 мм и так далее, а размеры последнего будут составлять 499 х 1 мм. Нам необходимо перебрать все эти прямоугольники и выбрать из них один, имеющий максимальную площадь.

Легко заметить, что в рассматриваемом наборе прямоугольников встречаются повторяющиеся размеры. Например, первый и последний прямоугольники имеют одинаковый размер: 1 х 499 (то же, что 499 х 1). Аналогично этому, размер второго прямоугольника совпадает с размером предпоследнего и т.д. Нам необходимо составить алгоритм перебора всех оригинальных вариантов, но перебирать повторяющиеся нет необходимости.

Для начала проведём предварительную оценку: определим, как площадь прямоугольника будет зависеть от его размеров. Легко понять, что у первого прямоугольника, с размерами сторон 1 х 499, будет самая маленькая площадь. Далее, по мере увеличения малой стороны, площадь прямоугольников будет увеличиваться. По достижении некоторого значения площади прямоугольников начнут снижаться. Эта зависимость отражена на рис. 44:

Рис. 44. Зависимость размера площади прямоугольника от размера одной стороны.

Глядя на рис. 44, несложно прийти к выводу, что искать максимальную площадь, перебирая варианты, начиная с первого, необходимо лишь до тех пор, пока площадь в процессе вычислений увеличивается. Как только она начнёт снижаться, необходимо закончить перебор и выйти из цикла перебора вариантов. Ниже представлен скрипт rectangle.mq4, в котором реализован такой алгоритм.

//--------------------------------------------------------------------
// rectangle.mq4
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------------
int start()                         // Специальная функция start()
  {
//--------------------------------------------------------------------
   int
   L=1000,                          // Заданная длина нити
   A,                               // Первая сторона прямоугольн.
   B,                               // Вторая сторона прямоугольн.
   S,                               // Площадь прямоугольника
   a,b,s;                           // Текущие значения
//--------------------------------------------------------------------
   for(a=1; a<L/2; a++)             // Заголовок оператора цикла
     {                              // Скобка начала тела цикла
      b=(L/2) - a;                  // Текущее значение сторон
      s=a * b;                      // Текущее значение площади
      if (s<=S)                     // Выбираем большее значение
         break;                     // Выходим за пределы цикла
      A=a;                          // Запоминаем лучшее значение
      B=b;                          // Запоминаем лучшее значение
      S=s;                          // Запоминаем лучшее значение
     }                              // Скобка конца тела цикла
//--------------------------------------------------------------------
   Alert("Максимальная площадь = ",S,"  A=",A,"  B=",B);// Сообщение
   return;                             // Оператор выхода из функции
  }
//--------------------------------------------------------------------

Проследим, как эта программа работает. В начале программы объявлены и прокомментированы переменные. В пределах цикла for реализуется собственно алгоритм решения задачи. В Выражении_1 задано начальное значение размера стороны а прямоугольника, равное 1. В соответствии с Условием, перебор ведётся до тех пор, пока размер стороны прямоугольника а остаётся меньше половины длины нити. Выражение_2 предписывает увеличивать размер стороны прямоугольника а на каждом шаге итерации.

Переменные a, b и s - текущие переменные, значения которых перебираются. Переменные A, B и S - искомые значения. В начале цикла вычисляется вторая сторона b и площадь s текущего прямоугольника.

      b = (L/2) - a;                   // Текущее значение сторон
      s = a * b;                       // Текущее значение площади

В операторе if проверяется условие выхода из цикла:

      if (s <= S )                     // Выбираем большее значение
         break;                        // Выходим за пределы цикла

Если только что вычисленная площадь текущего прямоугольника s оказывается больше площади S, вычисленной на предыдущей итерации, то это новое значение s и становится лучшим достигнутым результатом. В этом случае Условие оператора if не выполняется, а управление передаётся ближайшему оператору, следующему за оператором if. В этих строках запоминаются лучшие достигнутые результаты:

      A = a;                           // Запоминаем лучшее значение
      B = b;                           // Запоминаем лучшее значение
      S = s;                           // Запоминаем лучшее значение

При достижении ближайшей закрывающей фигурной скобки итерация заканчивается, и управление передаётся в заголовок оператора for для выполнения Выражения_2 и проверки Условия. Если на момент проверки размер стороны а ещё не вырос до указанных пределов, то выполнение цикла продолжится.

Повторяющиеся циклические вычисления будут продолжаться до тех пор, пока не произойдёт одно из событий: либо размер стороны а превысит допустимые пределы (в соответствии с Условием оператора for), либо размер вычисленной площади s окажется меньше ранее достигнутого значения, хранящегося в переменной S. У нас есть все основания считать, что раньше произойдёт выход из цикла по условию оператора if:

     if (s <= S )                     // Выбираем большее значение
        break;                        // Выходим за пределы цикла

Действительно, оператор цикла for составлен так, что перебирает все возможные варианты без исключения (половина длины нити L/2 - это сумма двух сторон). В то же время максимальная площадь прямоугольника будет достигнута где-то в середине перебираемого набора вариантов. И как только это событие произойдёт (площадь текущего прямоугольника s окажется меньше или равной ранее достигнутого значения S), в рамках исполнения оператора if управление будет передано оператору break, который, в свою очередь, передаст управление за пределы оператора for в строку:

     Alert("Максимальная площадь = ",S,"  A=",A,"  B=",B);// Сообщение

В результате исполнения встроенной функции Alert() будет напечатана следующая строка:

Максимальная площадь = 62500 А=250 В=250

После этого управление будет передано оператору return, в результате чего специальная функция start() завершит свою работу. Это, в свою очередь, приведёт к окончанию работы скрипта и выгрузке его клиентским терминалом из окна финансового инструмента.

В данном примере оператор break прекращает работу (передаёт управление за пределы) оператора цикла for, а именно того оператора цикла, внутри которого он находится. Ниже приведена функциональная схема цикла for, в котором используется специальный выход:

Рис. 45. Функциональная схема цикла for с использованием оператора break (rectangle.mq4).

На схеме видно, что из цикла имеется два выхода: нормальный выход (выход из цикла в результате срабатывания условия, заключённого в заголовке оператора цикла) и специальный выход из цикла (выход из тела цикла по дополнительному условию с помощью оператора break).

Возможность специального выхода из цикла в языке MQL4 трудно переоценить. В нашем примере использование оператора break позволило составить алгоритм, при котором выполняются только необходимые вычисления. Алгоритм, составленный без специального выхода из цикла, был бы неэффективным - в этом случае производились бы повторяющиеся вычисления, что привело бы к необоснованной трате вычислительных ресурсов и времени. Заштрихованная область на рис. 44 наглядно показывает область параметров, которые не обрабатывались в рассматриваемой программе (почти половина всех вычислений!), что не помешало получить правильный результат.

Необходимость использования эффективных алгоритмов становится особенно очевидна, когда время работы программы растягивается на секунды и даже минуты, что может оказаться больше, чем промежуток времени между тиками. В этом случае сохраняется риск пропустить обработку некоторых содержательных тиков и как результат - потерять инициативу в управлении торговлей. Кроме этого, снижение времени вычислений особенно остро ощущается при выполнении тестирования программ на тестере стратегий. Тестирование сложных программ на большом промежутке исторических данных может занимать часы и дни. Снижение времени тестирования наполовину в этой ситуации оказывается очень важной возможностью.

В правиле указано, что оператор break прекращает действие ближайшего внешнего оператора. Посмотрим, как работает программа, в которой используются вложенные циклы.

Задача 15. Используя алгоритм Задачи 14, подобрать наименьшую нить, кратную 1 метру, достаточную, чтобы образовать прямоугольник площадью 1.5 м ².

В этой задаче необходимо последовательно перебирать имеющиеся длины нитей, для каждой из которых нужно вычислить максимально достижимую площадь. Решение задачи 15 реализовано в скрипте area.mq4. Варианты решения перебираются в двух циклах - во внешнем и во внутреннем. Внешний цикл перебирает длину нити с шагом 1000 мм, а внутренний находит максимальную площадь для текущей длины нити. В данном случае оператор break используется для выхода из внешнего и внутреннего циклов.

//--------------------------------------------------------------------
// area.mq4
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------------
int start()                             // Специальная функция start()
  {
//--------------------------------------------------------------------
   int
   L,                                  // Длина нити
   S_etalon=1500000,                   // Заданная площадь (мм2)
   S,                                  // Площадь прямоугольника
   a,b,s;                              // Текущие стороны и площадь
//--------------------------------------------------------------------
   while(true)                         // Внешний цикл по длинам нити
     {                                 // Начало внешнего цикла
      L=L+1000;                        // Текущее значение нити в мм
      //--------------------------------------------------------------------
      S=0;                             // Начальное значение..
      // ..для каждого размера
      for(a=1; a<L/2; a++)             // Заголовок оператора цикла
        {                              // Начало внутреннего цикла
         b=(L/2) - a;                  // Текущие значения сторон
         s=a * b;                      // Текущее значение площади
         if (s<=S)                     // Выбираем большее значение
            break;                     // Выход из внутреннего цикла
         S=s;                          // Запоминаем лучшее значение
        }                              // Конец внутреннего цикла
      //--------------------------------------------------------------------
      if (S>=S_etalon)                 // Выбираем большее значение
        {
         Alert("Подходит нить длиной ",L1000," м.");// Сообщение
         break;                         // Выход из внешнего цикла
        }
     }                                 // Конец внешнего цикла
//--------------------------------------------------------------------
   return;                              // Оператор выхода из функции
  }
//--------------------------------------------------------------------

Здесь внутренний цикл работает подобно тому, как и в решении предыдущей задачи. Оператор break используется для выхода из цикла for, когда достигнуто максимальное значение площади для нити заданной длины. Необходимо особо подчеркнуть, что оператор break, указанный во внутреннем цикле for, передаёт управление оператору, следующему за закрывающей фигурной скобкой цикла for, прекращая таким образом работу цикла. Это явление не оказывает никакого влияния на исполнение внешнего оператора цикла while.

В момент, когда срабатывает оператор break во внутреннем цикле for, управление передаётся оператору if:

   if (S >= S_etalon)                              // Выбираем большее значение
      {
       Alert("Подходит нить длиной ",L1000," м.");// Сообщение
       break;                                      // Выход из внешнего цикла
      }

В операторе if производится проверка: является ли найденная площадь больше или равной заданному по условию задачи минимально допустимому значению 1.5 м 2? Если это так, то решение найдено, и продолжать вычисления нет смысла; управление передаётся в тело оператора if. Исполняемую часть оператора if составляют всего два оператора, первый из которых выводит на экран сообщение о найденном решении:

Подходит нить длиной 5 м.

С помощью второго оператора - break - осуществляется выход из внешнего цикла while и последующий выход из программы. Ниже представлена функциональная схема алгоритма, реализованного в программе area.mq4.

Рис. 46. Функциональная схема программы, в которой реализуется возможность специального выхода из внутреннего и внешнего цикла (area.mq4).

На схеме видно, что из каждого цикла имеется нормальный и специальный выход. Каждый из операторов break прекращает работу своего цикла и никак не отражается на работе другого; каждому специальному выходу соответствует свой оператор break. Один и тот же оператор break не может использоваться для специального выхода из обоих циклов. В данном случае каждый из циклов имеет только один специальный выход, но в общем случае допускается использование нескольких операторов break, образующих несколько специальных выходов из одного цикла.

Обратите внимание, Условием в заголовке внешнего цикла while является (true), т. е. запись, не содержащая переменной, значение которой в процессе выполнения программы могло бы измениться. Это значит, что выход из цикла while по Условию, указанному в заголовке, никогда не произойдёт. В этом случае использование оператора break является единственной возможностью для выхода из цикла.

В этом примере алгоритм построен так, что фактически используется только специальный выход как из внутреннего, так и из внешнего цикла. Однако не следует полагать, что использование оператора break обязательно приводит к построению алгоритмов, предполагающих только специальный выход. В алгоритмах других программ вполне возможно достижение условий, при которых происходит нормальный выход из цикла.

Использование оператора break для передачи управления за пределы оператора switch рассматривается в разделе Переключатель switch.

Оператор циклa forОператор continue


Вызов функции - Операторы - Учебник по MQL4

Учебник по MQL4 [image] Операторы [image] Вызов функции
  • Оператор присваивания
  • Условный оператор if - else
  • Оператор цикла while
  • Оператор циклa for
  • Оператор break
  • Оператор continue
  • Оператор switch
  • Вызов функции
  • Описание функции и оператор return
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Вызов функции

Вызов функции может быть оформлен в виде отдельного оператора, а также содержаться в любом месте программы, где по смыслу предполагается некоторое значение (за исключением оговоренных случаев). Формат и правила исполнения вызова функции в равной мере распространяются на стандартные (встроенные) и пользовательские функции.

Формат вызова функции

Вызов функции состоит из названия функции и списка передаваемых параметров, обрамлённого круглыми скобками:

   Название_функции  (Список_параметров )      // Собственно вызов функции

Название, указанное в вызове функции, должно совпадать с названием функции, вызываемой для исполнения. Список параметров указывается через запятую. Количество параметров, передаваемых в функцию, ограничено и не может превышать 64. В качестве параметров в вызове функции могут использоваться константы, переменные и вызовы других функций. Количество, тип и порядок упоминания передаваемых параметров в вызове функции должны совпадать с количеством, типом и порядком упоминания формальных параметров, указанных в описании функции (исключение составляет вызов функции, имеющей умолчательные параметры).

My_function (Alf, Bet)                       // Пример вызова функции
                                             // Здесь:
My_function                                  // Название вызываемой функции
Alf                                          // Первый передаваемый параметр
Bet                                          // Второй передаваемый параметр

Если вызываемая функция не предусматривает передаваемых параметров, то список параметров указывается пустым, наличие круглых скобок при этом обязательно.

My_function ()                               // Пример вызова функции
                                             // Здесь:
My_function                                  // Название вызываемой функции
                                             // Передаваемые параметры отсутствуют

При вызове функции, имеющей умолчательные параметры, список передаваемых параметров может быть ограничен (указан не полностью). Список параметров можно ограничить, начиная с первого умолчательного параметра. В данном примере локальные переменные b, c и d имеют умолчательные значения.

                                             // Для функции с описанием:
int My_function (int a, bool b=true, int c=1, double d=0.5)
   {
   Операторы
   }
                                             // .. допустимы следующие вызовы:
My_function (Alf, Bet, Ham, Del)             // Допустимый вызов функции
My_function (Alf )                           // Допустимый вызов функции
My_function (3)                              // Допустимый вызов функции
My_function (Alf, 0)                         // Допустимый вызов функции
My_function (3, Tet)                         // Допустимый вызов функции
My_function (17, Bet, 3)                     // Допустимый вызов функции
My_function (17, Bet, 3, 0.5)                // Допустимый вызов функции

Параметры, не имеющие значения по умолчанию, опускать нельзя. Если какой-либо из умолчательных параметров опущен, то все последующие умолчательные параметры также не указываются.

                                             // Для функции с описанием:
int My_function (int a, bool b=true, int c=1, double d=0.5)
   {
   Операторы
   }
                                             // ..следующие вызовы являются ошибочными:
My_function ()                               // Недопустимый вызов функции: неумолчательные..
                                             // ..параметры опускать нельзя (первый)
My_function (17, Bet, , 0.5)                 // Недопустимый вызов функции: пропущен..
                                             // ..умолчательный параметр (третий)

Вызываемые функции делятся на две группы: возвращающие некоторое значение заранее определённого типа и не возвращающие никакого значения.

Формат вызова функции, не возвращающей значение

Вызов функции, не возвращающей значение, может быть оформлен только в виде отдельного оператора. Оператор вызова функции заканчивается знаком ; (точка с запятой):

Название_функции  (Список_параметров );       // Оператор вызова функции,не возвращающей знач
Func_no_ret (Alfa, Betta, Gamma);            // Пример оператора вызова функции,..
                                             //.. не возвращающей значение

Иного формата (способа) для вызова функций, не возвращающих значение, не предусмотрено.

Формат вызова функции, возвращающей значение

Вызов функции, возвращающей значение, может быть оформлен в виде отдельного оператора, а также использоваться в коде программы - в том месте, где по смыслу предполагается значение известного типа.

В случае оформления в виде отдельного оператора вызов функции заканчивается знаком ; (точка с запятой):

Название_функции  (Список_параметров );       // Оператор вызова функции, возвращающей знач
Func_yes_ret (Alfa, Betta, Delta);           // Пример оператора вызова функции,..
                                             //.. возвращающей значение

Правила исполнения вызова функции

Вызов функции вызывает для исполнения одноимённую функцию. Если вызов функции оформлен в виде отдельного оператора, то после исполнения функции управление передаётся оператору, следующему за вызовом функции. Если вызов функции используется в выражении, то после исполнения функции управление передаётся в то место выражения, где указан вызов функции, и дальнейшие вычисления в выражении производятся со значением, возвращённым функцией.

Использование вызова функции в составе других операторов определяется форматом этих операторов.

Задача 20. Составить программу, в которой реализуются следующие условия: - если текущее время больше 15:00, то выполнить 10 итераций в цикле for;- в остальных случаях выполнить 6 итераций.

Ниже приведен пример скрипта callfunction.mq4, в котором используются: вызов функции в заголовке оператора for (в составе Выражения_1, согласно формату оператора for, см. Оператор цикла for), вызов стандартной функции в виде отдельного оператора, в правой части оператора присваивания (см. Оператор присваивания) и в заголовке оператора if-else (в Условии, согласно формату оператора if-else, см. Условный оператор if-else).

///--------------------------------------------------------------------
// callfunction.mq4
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------------
int start()                               // Описание функции start()
  {                                       // Начало тела ф-ии start()
   int n;                                 // Объявление переменной
   int T=15;                              // Заданное время
   for(int i=Func_yes_ret(T);i<=10;i++)   // Использование функции в..
                                          //.заголовке оператора цикла
     {                                    // Начало тела цикла for
      n=n+1;                              // Счётчик итераций
      Alert ("Итерация n=",n," i=",i);    // Оператор вызова функции
     }                                    // Конец тела цикла for
   return;                                // Выход из функции start()
  }                                       // Конец тела ф-ии start()
//--------------------------------------------------------------------
int Func_yes_ret (int Times_in)           // Описание пользоват. ф-ии
  {                                       // Начало тела польз. ф-ии
   datetime T_cur=TimeCurrent();          // Использование функции в..
                                          // ..операторе присваивания
   if(TimeHour(T_cur) > Times_in)         // Использование функции в..
                                          //..заголовке операт.if-else
      return(1);                          // Возврат значения 1
   return(5);                             // Возврат значения 5
  }                                       // Конец тела пользов. ф-ии
//--------------------------------------------------------------------

В приведенном примере использованы вызовы следующих функций с такими передаваемыми параметрами:

  • в вызове функции Func_yes_ret(T) - переменная T;
  • в вызове функции Alert () - строковые константы "Итерация n=" и " i=", переменные n и i;
  • вызов функции TimeCurrent() не предусматривает передаваемых параметров;
  • в вызове функции TimeHour(T_cur) - переменная T_cur.

В программе реализован очень простой алгоритм. В переменной Т задаётся время в часах, относительно которого производятся вычисления. В заголовке оператора for указан вызов пользовательской функции Func_yes_ret(), которая может возвращать одно из двух значений: 1 или 5. В зависимости от этого значения изменяется количество итераций в цикле: либо их будет 10 (i изменяется от 1 до 10), либо 6 (i изменяется от 5 до 10). Для наглядности в теле цикла используется счётчик итераций, каждое значение которого выводится на экран с помощью функции Alert().

В описании пользовательской функции сначала вычисляется время в секундах, прошедших после 00:00 1 января 1970 года (обращение к функции TimeCurrent()), а затем текущее время в часах (обращение к функции TimeHour()). Разветвление алгоритма осуществляется с помощью оператора if (вызов функции TimeHour() указан в его условии). Если текущее время оказывается больше, чем переданное в пользовательскую функцию (локальная переменная Times_in), то пользовательская функция возвращает 1, иначе - возвращает 5.

Обратите внимание:

В программе нет описаний стандартных функций и вызова специальной функции start().

Ниже показана функциональная схема скрипта callfunction.mq4:

Рис. 51. Функциональная схема программы, использующей обращение к функциям.

На функциональной схеме кружками обозначены вызовы функций (пользовательской и стандартной). Красными стрелками показана передача управления в функцию и обратно. Наглядно видно, что функция возвращает управление в то место, где указан вызов функции, причём на пути между вызовом функции и самой функцией не совершается каких-либо иных вычислений. В общем случае, если функция возвращает значение, это значение передаётся в вызывающий модуль (по красной стрелке в направлении вызова функции).

Специальные функции могут быть вызваны из любого места программы по общим правилам, наравне с другими функциями. Специальные функции также могут иметь параметры. Однако при вызове этих функций клиентским терминалом никакие параметры извне переданы не будут, а будут использованы умолчательные значения. Использование параметров в специальных функциях будет иметь смысл только при вызове их из программы. Несмотря на то, что в языке MQL4 имеется техническая возможность вызова специальных функций из программы, делать это не рекомендуется. Программу, использующую обращение к специальным функциям, следует считать некорректной.

Оператор switchОписание функции и оператор return


Оператор continue - Операторы - Учебник по MQL4

Учебник по MQL4 [image] Операторы [image] Оператор continue
  • Оператор присваивания
  • Условный оператор if - else
  • Оператор цикла while
  • Оператор циклa for
  • Оператор break
  • Оператор continue
  • Оператор switch
  • Вызов функции
  • Описание функции и оператор return
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Оператор continue

Иногда при использовании цикла возникает необходимость досрочно закончить обработку текущей итерации и перейти к следующей, не выполняя при этом все оставшиеся операторы, составляющие тело цикла. В таких случаях используется оператор continue.

Формат оператора continue

Оператор continue состоит из одного слова, заканчивается знаком ";" (точка с запятой).

   continue;                                         // Оператор continue

Правило исполнения оператора continue

Оператор continue прекращает исполнение текущей итерации ближайшего оператора цикла while или for. Результатом выполнения оператора continue является переход к следующей итерации ближайшего оператора цикла while или for. Оператор continue может использоваться только в составе тела указанных операторов цикла.

Рассмотрим вариант практического использования оператора continue.

Задача 16. На первой ферме имеется 1000 овец. Ежедневно количество овец на первой ферме увеличивается на 1%. Если в конце месяца на первой ферме количество овец превышает 50 000, то 10% овец переводят на вторую ферму. Через какое время количество овец на второй ферме достигнет численности 35 000? (Считать, что в месяце 30 рабочих дней.)

Алгоритм решения задачи очевиден: необходимо организовать цикл, в котором рассчитывалась бы сумма общего количества овец на первой ферме. По условию задачи перевод части овец на вторую ферму происходит в конце месяца, значит необходимо создать ещё один (внутренний) цикл, в котором вычислялось бы накопление в текущем месяце. По окончании месяца необходимо выяснить: превышен ли пороговый уровень в 50 000? И если это так, то нужно рассчитать количество овец, переводимых на вторую ферму в конце месяца, и общее количество овец на второй ферме.

Рассматриваемый алгоритм реализован в скрипте sheep.mq4. Здесь оператор continue используется для расчётов во внешнем цикле.

//--------------------------------------------------------------------
// sheep.mq4
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------------
int start()                               // Специальная ф-ия start()
  {
//--------------------------------------------------------------------
   int
   day,                                   // Текущий день месяца
   Mons;                                  // Искомое количест. месяцев
   double
   One_Farm    =1000.0,                   // Количество на 1 ферме
   Perc_day    =1,                        // Ежедневный подъём, %
   One_Farm_max=50000.0,                  // Пороговое значение
   Perc_exit   =10,                       // Ежемесячный вывод, %
   Purpose     =35000.0,                  // Необх. колич. на 2 ферме
   Two_Farm;                              // Количество на 2 ферме
//--------------------------------------------------------------------
   while(Two_Farm < Purpose)              // Внешний цикл по истории
     {                                    // Начало тела внешн. цикла
      //--------------------------------------------------------------
      for(day=1; day<=30; day++)          // Цикл по дням месяца
         One_Farm=One_Farm*(1+Perc_day/100);//Накопление на 1й ферме
      //--------------------------------------------------------------
      Mons++;                             // Считаем месяцы
      if (One_Farm < One_Farm_max)        // Если меньше допустимого,.
         continue;                        // .. то овец не переводим
      Two_Farm=Two_Farm+One_Farm*Perc_exit/100;//Количес. на 2 ферме
      One_Farm=One_Farm*(1-Perc_exit/100);// Остаток на 1 ферме
     }                                    // Конец тела внешнего цикла
//--------------------------------------------------------------------
   Alert("Цель будет достигнута через ",Mons," мес.");//Вывод на экран
   return;                                // Выход из функции start()
  }
//--------------------------------------------------------------------

В начале программы, как обычно, описаны и прокомментированы переменные. Собственно расчёт выполняется в цикле while, а после его окончания выводится соответствующее сообщение. Расчёты во внешнем цикле while будут происходить до тех пор, пока не будет достигнута цель, а именно, пока общее количество овец на второй ферме не достигнет ожидаемого значения 35 000.

Внутренний цикл for очень прост: значение баланса увеличивается ежедневно на 1%. Никакого анализа суммы в этом цикле не выполняется, потому что по условию задачи перевод овец может происходить только в конце месяца. Таким образом, после выхода из цикла for переменная One_Farm имеет значение, равное количеству овец на первой ферме. Сразу после этого вычисляется значение переменной Mons, увеличивающееся на единицу при выполнении каждой итерации внешнего цикла while.

В зависимости от текущего количества овец на первой ферме выполняется одно из двух вычислений:

  • если количество овец на первой ферме превышает пороговое значение 50 000, то необходимо 10% овец с первой фермы перевести на вторую ферму;
  • в противном случае - овец с первой фермы на вторую не переводить и продолжать разведение овец на первой ферме.

Разветвление алгоритма осуществляется с помощью оператора if:

      if (One_Farm < One_Farm_max)        // Если меньше допустимого,.
         continue;                        // .. то овец не переводим

Эти строки кода можно охарактеризовать так: если количество овец на первой ферме меньше порогового значения 50 000, то исполнить оператор, составляющий тело оператора if. При первой итерации количество овец на первой ферме оказывается меньше порогового значения, поэтому управление будет передано в тело оператора if, т.е. оператору continue. Исполнение оператора continue означает следующее: закончить текущую итерацию ближайшего выполняемого цикла (в данном случае это цикл в операторе while ) и передать управление в заголовок оператора цикла. При этом следующие программные строки, также являющиеся составной частью тела оператора цикла while, выполняться не будут:

      Two_Farm = Two_Farm+One_Farm*Perc_exit/100;//Количес. на 2 ферме
      One_Farm = One_Farm*(1-Perc_exit/100);     // Остаток на 1 ферме

В этих строках осуществляется расчёт достигнутого количества овец на второй ферме и остаточное количество овец на первой ферме. На первой итерации выполнять эти расчёты нельзя, т.к. ещё не достигнуто пороговое количество овец 50 000 на первой ферме. Сущность оператора continue как раз и состоит в том, чтобы "переступить" через эти строки, не исполнять их в текущей итерации.

В результате исполнения оператора continue управление передаётся в заголовок оператора цикла while. Далее происходит проверка условия в операторе цикла и начинается следующая итерация. Выполнение цикла будет продолжаться по тому же алгоритму до тех пор, пока количество овец на первой ферме не достигнет порогового значения. При этом на каждой итерации накапливается значение Mons.

На некотором этапе расчётов количество овец на первой ферме достигнет или превысит пороговое значение 50 000 голов. В этом случае, при исполнении оператора if условие (One_Farm < One_Farm_max) окажется ложным, поэтому управление в тело оператора if передано не будет. Это значит, что оператор continue не исполнится, а управление будет передано на первую из двух последних строк тела цикла while: сначала будет вычислено количество овец на второй ферме, а затем остаточное количество овец на первой ферме. После этих вычислений очередная итерация цикла while закончится, и управление снова будет передано в заголовок цикла. Ниже представлена функциональная схема алгоритма, реализованного в скрипте sheep.mq4.

Рис. 47. Функциональная схема программы, в которой оператор continue прерывает итерации внешнего цикла (sheep.mq4).

На схеме наглядно видно, что в зависимости от исполнения условия в операторе if, управление либо сразу передаётся в заголовок цикла while (в результате исполнения continue ), либо сначала выполняются некоторые операторы, а потом управление всё равно передаётся в заголовок цикла while. В обоих случаях выполнение цикла при этом не заканчивается.

Обратите внимание, наличие оператора continue в теле цикла не обязательно приводит к окончанию текущей итерации. Это происходит только в том случае, если он исполняется, т.е. если ему передано управление.

На каждой очередной итерации в операторе цикла while, будет рассчитываться новое достигнутое значение переменой Two_Farm. Как только это значение превысит заданную величину (35 000), условие в операторе цикла while окажется ложным, поэтому вычисления в теле цикла while больше выполняться не будут, а управление будет передано ближайшему оператору, следующему за оператором цикла:

    Alert("Цель будет достигнута через ",Mons," мес.");//Вывод на экран

Результатом исполнения функции Alert() будет строка следующего вида:

Цель будет достигнута через 17 мес.

Оператор return заканчивает исполнение специальной функции start(), в результате чего управление будет передано клиентскому терминалу, а исполнение скрипта заканчивается - он будет выгружен из окна финансового инструмента.

Представленный алгоритм предусматривает нормальный выход из цикла while. В более общем случае выход из цикла может происходить и в результате исполнения оператора break (специальный выход). Однако ни тот, ни другой способ завершения цикла никак не связаны с прерыванием текущей итерации с помощью оператора continue.

В правиле исполнения оператора continue используется выражение "ближайшего оператора". Ошибочно полагать, что это означает близость программных строк. Посмотрим на код скрипта sheep.mq4. Оператор for находится "ближе" к оператору continue, чем заголовок цикла while. Однако это не имеет никакого значения: оператор continue никак не связан с циклом for, потому что находится за его пределами, вне его тела. В общем случае программа может содержать множество вложенных операторов цикла. Оператор continue всегда находится в теле какого-то из них. Но одновременно с этим оператор continue, являясь составной частью внутреннего оператора цикла, естественно, находится и внутри внешнего оператора цикла. Выражение "прекращает исполнение текущей итерации ближайшего оператора цикла" следует понимать так, что его действие распространяется на ближайший оператор цикла, внутри тела которого он находится. Чтобы проиллюстрировать это, несколько изменим условия задачи.

Задача 17. На первой ферме имеется 1000 овец. Ежедневно количество овец на первой ферме увеличивается на 1%. В тот день, когда количество овец на первой ферме достигает 50 000, 10% овец переводят на вторую ферму. Через какое время количество овец на второй ферме достигнет численности 35 000? (Считать, что в месяце 30 рабочих дней.)

Решение задачи 17 реализовано в скрипте othersheep.mq4. В данном случае оператор continue используется для расчётов во внешнем и внутреннем циклах.

//--------------------------------------------------------------------
// othersheep.mq4
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------------
int start()                               // Специальная ф-ия start()
  {
//--------------------------------------------------------------------
   int
   day,                                   // Текущий день месяца
   Mons;                                  // Искомое количест. месяцев
   double
   One_Farm    =1000.0,                   // Количество на 1 ферме
   Perc_day    =1,                        // Ежедневный подъём, %
   One_Farm_max=50000.0,                  // Пороговое значение
   Perc_exit   =10,                       // Разовый вывод, %
   Purpose     =35000.0,                  // Необх. колич. на 2 ферме
   Two_Farm;                              // Количество на 2 ферме
//--------------------------------------------------------------------
   while(Two_Farm < Purpose)              // До достижения цели
     {                                    // Начало тела внешн. цикла
      //--------------------------------------------------------------
      for(day=1; day<=30 && Two_Farm < Purpose; day++)// Цикл по дням
        {
         One_Farm=One_Farm*(1+Perc_day/100);//Накопл. на 1 ферме
         if (One_Farm < One_Farm_max)     // Если меньше допустимого,.
            continue;                     // .. то овец не переводим
         Two_Farm=Two_Farm+One_Farm*Perc_exit/100;//Накопл. на 2 ферме
         One_Farm=One_Farm*(1-Perc_exit/100);     //Остаток на 1 ферме
        }
      //--------------------------------------------------------------
      if (Two_Farm>=Purpose)              // Если цель достигнута,..
         continue;                        // .. то месяцы не считаем
      Mons++;                             // Считаем месяцы
     }                                    // Конец тела внешнего цикла
//--------------------------------------------------------------------
   Alert("Цель будет достигнута через ",Mons," мес. и ",day," дн.");
   return;                                // Выход из функции start()
  }
//--------------------------------------------------------------------

Для решения задачи необходимо анализировать количество овец для каждого дня. С этой целью строки:

   if (One_Farm < One_Farm_max)             // Если меньше допустимого,.
      continue;                             // .. то овец не переводим
   Two_Farm=Two_Farm+One_Farm*Perc_exit/100;//Накопл. на 2 ферме
   One_Farm=One_Farm*(1-Perc_exit/100);     //Остаток на 1 ферме

перенесены во внутренний цикл, организованный по дням месяца. Очевидно, что перевод некоторого количества овец на вторую ферму в данном случае происходит не в конце месяца, а в тот день, когда количество овец на первой ферме достигает заданного значения. Смысл использования здесь оператора continue тот же: "переступить" через строки, в которых выполняются вычисления, связанные с переводом овец с одной фермы на другую, т.е. не выполнять эти строки. Обратите внимание, цикл while, построенный по дням месяца, не прерывается независимо от факта перевода овец, потому что действие оператора continue распространяется на ближайший оператор цикла, в данном случае - на оператор цикла for.

В качестве Условия в операторе цикла for используется сложное выражение:

   for(day=1; day<=30 && Two_Farm<Purpose; day++)// Цикл по дням

Использование операции && ("и") означает, что цикл будет выполняться до тех пор, пока будут справедливы оба условия:

  • месяц ещё не закончился, т.е. переменная day остаётся в пределах от 1 до 30 включительно;
  • количество овец на второй ферме не достигло заданного, т.е. переменная Two_Farm меньше Purpose (35 000).

Если же хотя бы одно из условий не выполняется (становится ложным), цикл прекращается. Когда выполнение цикла for закончено (по любой из причин), управление передаётся оператору if:

   if (Two_Farm >= Purpose)            // Если цель достигнута,..
      continue;                        // .. то месяцы не считаем
   Mons++;                             // Считаем месяцы

Использование в этом месте кода оператора continue имеет простой смысл: продолжать считать месяцы только в том случае, если количество овец на второй ферме меньше ожидаемого. Если же цель уже достигнута, то значение переменной Mons не изменяется, а управление (в результате исполнения continue) передаётся в заголовок ближайшего оператора цикла, в этом случае - оператора цикла while.

Использование операторов continue во вложенных циклах отражено на рис. 48.

Рис. 48. Функциональная схема алгоритма, построенного на вложенных циклах. В теле каждого из циклов имеется свой оператор continue (othersheep.mq4).

В данном примере каждый из циклов (внешний и внутренний) содержит один оператор continue, действие которого распространяется только на "свой" ближайший цикл, а на события в другом цикле не влияет. В общем случае в теле цикла могут использоваться несколько операторов continue, каждый из которых может прерывать текущую итерацию в результате выполнения какого-либо условия. Количество операторов continue в теле цикла не ограничено.

Оператор breakОператор switch


Оператор циклa for - Операторы - Учебник по MQL4

Учебник по MQL4 [image] Операторы [image] Оператор циклa for
  • Оператор присваивания
  • Условный оператор if - else
  • Оператор цикла while
  • Оператор циклa for
  • Оператор break
  • Оператор continue
  • Оператор switch
  • Вызов функции
  • Описание функции и оператор return
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Оператор циклa for

Вторым оператором цикла является оператор for.

Формат оператора for

Полноформатный оператор цикла for состоит из заголовка, содержащего Выражение_1, Условие и Выражение_2, и исполняемого тела цикла, обрамлённого фигурными скобками.

  for (Выражение_1; Условие; Выражение_2)            // Заголовок оператора цикла
      {                                            // Открывающая фигурная скобка
      Блок операторов,                             // Тело цикла может состоять ..
      составляющих тело цикла                      //.. из нескольких операторов
      }                                            // Закрывающая фигурная скобка

Если в операторе for тело цикла составляет один оператор, то фигурные скобки можно опустить.

  for (Выражение_1; Условие; Выражение_2)            // Заголовок оператора цикла
      Один оператор, тело цикла                    // Тело цикла - один оператор

Допускается отсутствие Выражения_1, Условия и Выражения_2. При этом наличие разделяющего знака ; (точка с запятой) обязательно.

  for ( ; Условие; Выражение_2)                       // Отсутствует Выражение_1
      {                                            // Открывающая фигурная скобка
      Блок операторов,                             // Тело цикла может состоять ..
      составляющих тело цикла                      //.. из нескольких операторов
      }                                            // Закрывающая фигурная скобка
// - ---------------------------------------------------------------------------------
  for (Выражение_1; ; Выражение_2)                    // Отсутствует Условие
      {                                            // Открывающая фигурная скобка
      Блок операторов,                             // Тело цикла может состоять ..
      составляющих тело цикла                      //.. из нескольких операторов
      }                                            // Закрывающая фигурная скобка
// - ---------------------------------------------------------------------------------
  for ( ; ; )                                          // Отсутств. Выражения и Условие
      {                                            // Открывающая фигурная скобка
      Блок операторов,                             // Тело цикла может состоять ..
      составляющих тело цикла                      //.. из нескольких операторов
      }                                            // Закрывающая фигурная скобка

Правило исполнения оператора for

При передаче управления оператору for исполнить Выражение_1. Пока Условие оператора for является истинным: передать управление первому оператору тела цикла, а после выполнения всех операторов тела цикла исполнить Выражение_2 и передать управление в заголовок для проверки истинности Условия. Если Условие оператора for является ложным, то: передать управление оператору, следующему за оператором for.

Посмотрим, как работает оператор цикла for. Для этого решим задачу.

Задача 13. Дана последовательность целых чисел: 1 2 3 4 5 6 7 8 9 10 11 ...Составить программу, вычисляющую сумму элементов этой последовательности, начиная с номера N1, заканчивая номером N2.

С точки зрения математики эта задача решается просто. Предположим, необходимо высчитать сумму элементов с третьего по седьмой. Решением будет сумма: 3 + 4 + 5 + 6 + 7 = 25. Такое решение годится только для частного случая, когда номера первого и последнего элементов, составляющих сумму, равны соответственно 3 и 7. Программа должна быть составлена так, чтобы при необходимости вычисления суммы в другом интервале последовательности (например, от 15-го до 23-го элемента) можно было легко заменить численные значения номеров элементов в одном месте, не меняя программные строки в других местах. Вот один из вариантов такой программы (скрипт sumtotal.mq4):

//--------------------------------------------------------------------
// sumtotal.mq4
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------------
int start()                          // Специальная функция start()
  {
//--------------------------------------------------------------------
   int
   Nom_1,                               // Номер первого элемента
   Nom_2,                               // Номер второго элемента
   Sum,                                 // Сумма чисел
   i;                                   // Формальн параметр (счётчик)
//--------------------------------------------------------------------
   Nom_1=3;                              // Задаём численное значение
   Nom_2=7;                              // Задаём численное значение
   for(i=Nom_1; i<=Nom_2; i++)           // Заголовок оператора цикла
     {                                   // Скобка начала тела цикла
      Sum=Sum + i;                       // Сумма накапливается
      Alert("i=",i,"  Sum=",Sum);        // Сообщение на экран
     }                                   // Скобка конца тела цикла
//--------------------------------------------------------------------
   Alert("После выхода из цикла i=",i,"  Sum=",Sum);// Вывод на экран
   return;                               // Выход из start()
  }
//--------------------------------------------------------------------

В первых строках программы объявлены переменные (с комментариями, поясняющими смысл каждой переменной). В строках

   Nom_1 = 3;                           // Задаём численное значение
   Nom_2 = 7;                           // Задаём численное значение

численно определены значения первого и последнего элементов интервала. Обратите внимание, нигде в других местах программы эти значения не указываются. При необходимости эти значения можно легко изменить (в одном месте), не меняя код в других строках, и задача будет решена для другого интервала. После выполнения последнего из этих операторов управление передаётся оператору цикла for:

   for(i=Nom_1; i<=Nom_2; i++)          // Заголовок оператора цикла
     {                                  // Скобка начала тела цикла
      Sum = Sum + i;                    // Сумма накапливается
      Alert("i=",i,"  Sum=",Sum);       // Сообщение на экран
     }                                  // Скобка конца тела цикла

Ключевая фраза - правило исполнения оператора for такая: "Начиная с .., до тех пор пока.., с шагом.. выполнять следующее: ..". Употребление слов "с шагом" уместно в том случае, если в качестве Выражения_2 используется накопительный счётчик, например, i++ или i=i+2. В данном примере ключевая фраза звучит так: начиная с i, равного Nom_1, до тех пор, пока i меньше или равно Nom_2, с шагом 1 выполнять следующее: (и далее - анализ тела цикла).

В соответствии с правилом исполнения оператора for в этом блоке программы будет выполнено следующее:

1. Исполнение Выражения_1:

   i=Nom_1

Переменная i получит численное значение переменной Nom_1, т.е. целое число 3. Выражение_1 выполняется один раз, - в тот момент, когда управление передаётся оператору for и ни в каких последующих событиях Выражение_1 не участвует.

2. Выполняется проверка Условия:

   i<=Nom_2

Значение переменной Nom_2 на первой итерации - целое число 7, а значение переменной i равно 3. Это значит, что Условие является истинным (т.к. 3 меньше 7), а значит, управление будет передано в тело цикла для его исполнения.

3. В данном примере тело цикла составляют два оператора, которые будут последовательно исполнены:

   Sum = Sum + i;                    // Сумма накапливается
   Alert("i=",i,"  Sum=",Sum);       // Сообщение на экран

Переменная Sum не получила при инициализации какое-либо начальное значение, поэтому до начала первой итерации её значение равно нулю. В процессе вычислений значение переменной Sum увеличивается на величину i и по окончании первой итерации равно 3. Это значение можно увидеть в окне функции Alert() :

i=3 Sum=3

4. Последним событием, которое происходит при выполнении оператора цикла, является исполнение Выражения_2:

   i++

Значение переменной i увеличивается на единицу. На этом заканчивается первая итерация, и управление передаётся на проверку Условия.

Далее начинается вторая итерация, пункты 2 - 4. В процессе вычислений переменные получают новые значения. В частности, на второй итерации значение переменной i будет равно 4, а Sum будет равно 7, о чём появится соответствующее сообщение. В целом, события в этой программе будут развиваться в соответствии со схемой:

Рис. 43. Функциональная схема исполнения оператора цикла for в программе sumtotal.mq4.

Программа будет циклически повторять исполнение оператора цикла, до тех пор, пока Условие не окажется ложным. Это произойдёт, когда значение переменной i будет равно 8, т.е. больше заданного значения переменной Nom_2, равного 7. В этом случае управление будет передано за пределы оператора for, а именно в строку:

   Alert("После выхода из цикла i=",i,"  Sum=",Sum);// Вывод на экран

и дальше, на исполнение оператора return, завершающего работу специальной функции start().

Можно использовать эту программу для вычислений суммы любого другого интервала значений. Например, если заменить константы 3 и 7 на 10 и 15, то в результате исполнения этой же программы будет вычислена сумма значений для указанного интервала.

В некоторых языках программирования переменные, указанные в заголовке оператора цикла, после выхода из цикла теряют свои значения. В MQL4 это не так. Все переменные, участвующие в любых вычислениях, являются полноценными и сохраняют свои значения после завершения цикла. Вместе с тем, есть особенности, а скорее подробности, касающиеся значений переменных, участвующих в вычислениях.

Обратите внимание на 2 последние строки сообщений, оставшиеся после завершения всех вычислений и выгрузки скрипта:

i=7 Sum=25
После выхода из цикла i=8 Sum=25

Первое из этих сообщений появилось на стадии последней итерации, ещё до завершения цикла, а последнее сообщение выдано последней функцией Alert() перед завершением программы. Примечательно, что в этих строках отображаются разные значения переменной i. Ещё при выполнении цикла это значение равно 7, а после завершения цикла равно 8. Чтобы понять, почему это произошло, обратимся ещё раз к рис. 43.

Последняя (в данном случае - пятая) итерация начинается с проверки Условия. Значение i в этот момент равно 7. Поскольку 7 не больше, чем значение переменной Nom_2, то Условие истинно, а значит, будет выполняться тело цикла. По окончании выполнения операторов, составляющих тело цикла, осуществляется последняя операция: исполняется Выражение_2. Это необходимо ещё раз подчеркнуть особо:

Последним событием, происходящим на каждой итерации при исполнении цикла for, является вычисление Выражения 2.

В результате этого значение переменной i увеличивается на 1 и становится равным 8. Очередная проверка Условия (в начале следующей итерации) подтверждает, что теперь условие ложно, поэтому после проверки управление передаётся за пределы оператора цикла. При этом переменная i выходит из оператора цикла со значением 8, а значение переменной Sum остаётся равным 25, потому что исполнение тела цикла на этом этапе уже не происходит. Это замечание необходимо учитывать в случаях, когда количество итераций заранее неизвестно, и судить об этом программист предполагает, ориентируясь на значение переменной, вычисленной в Выражении_2.

Исключительным случаем можно считать ситуацию, при которой возникает зацикливание. Это становится возможным при различных ошибках. Например, если в качестве Выражения_2 ошибочно использовать оператор:

   i--

то значение счётчика на каждой итерации будет уменьшаться, поэтому Условие никогда не станет ложным.

Другим ошибочным случаем может быть неправильно составленное Условие:

for(i=Nom_1; i>=Nom_1; i++)              // Заголовок оператора цикла

В данном случае значение переменной i всегда будет больше или равным значению переменной Nom_1, поэтому Условие всегда будет оставаться истинным.

Взаимозаменяемость операторов циклов while и for

Использование того или иного оператора цикла полностью зависит от решения программиста. Здесь только нужно отметить, что эти операторы взаимозаменяемы; зачастую необходимо лишь немного доработать код программы.

Например, при решении Задачи 13, был использован оператор цикла for:

   for (i=Nom_1; i<=Nom_2; i++)         // Заголовок оператора цикла
     {                                  // Скобка начала тела цикла
      Sum = Sum + i;                    // Сумма накапливается
      Alert("i=",i,"  Sum=",Sum);       // Сообщение на экран
     }                                  // Скобка конца тела цикла

А так может выглядеть тот же фрагмент программы, но с использованием оператора цикла while:

   i=Nom_1;                             // Оператор присваивания
   while (i<=Nom_2)                     // Заголовок оператора цикла
     {                                  // Скобка начала тела цикла
      Sum = Sum + i;                    // Сумма накапливается
      Alert("i=",i,"  Sum=",Sum);       // Сообщение на экран
      i++;                              // Увеличение номера элемента
     }                                  // Скобка конца тела цикла

Легко увидеть, что для подобной замены достаточно вынести Выражение_1 в строку, предшествующую оператору цикла, а Выражение_2 указать последним в теле цикла. Вы можете самостоятельно внести изменения в программу и запустить её на выполнение, чтобы убедиться, что результат при исполнении обоих вариантов окажется одинаковым.

Оператор цикла whileОператор break


Описание функции и оператор return - Операторы - Учебник по MQL4

Учебник по MQL4 [image] Операторы [image] Описание функции и оператор return
MetaQuotes Sofware Corp.
  • Оператор присваивания
  • Условный оператор if - else
  • Оператор цикла while
  • Оператор циклa for
  • Оператор break
  • Оператор continue
  • Оператор switch
  • Вызов функции
  • Описание функции и оператор return
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Описание функции и оператор return

По необходимости указания в программе можно выделить 2 группы функций: функции, описания которых в программе не указываются, и функции, описания которых должны быть указаны в программе. Описания стандартных функций в программе не указываются. Описания пользовательских функций должны присутствовать в программе обязательно. Описания специальных функций, если они используются, также указываются в программе.

Формат описания функции

Описание функции состоит из двух основных частей - заголовка функции и тела функции.

Заголовок функции содержит указание типа возвращаемого значения, название функции и список формальных параметров, обрамлённый круглыми скобками. Если функция не должна возвращать никакого значения, то её тип обозначают void.

Тело функции может состоять из простых и/или составных операторов, обращений к другим функциям и заключается в фигурные скобки.

Тип_возвращаемого_значения Название_функции (Список формальных параметров)//Заголовок
   {                                    // Открывающая фигурная скобка
   Программный код,                     // Тело функции может состоять ..
   составляющий тело                    //.. из операторов и ..
   функции                              //.. обращений к другим функциям
   }                                    // Закрывающая фигурная скобка

Список параметров указывается через запятую. Количество параметров, передаваемых в функцию, ограничено и не может превышать 64. В качестве формальных параметров в заголовке функции могут быть указаны только переменные (но не константы, вызовы других функций или выражения). Количество, тип и порядок упоминания передаваемых параметров в вызове функции должны совпадать с количеством, типом и порядком упоминания формальных параметров, указанных в описании функции (исключение составляет вызов функции, имеющей параметры со значением по умолчанию):

int My_function (int a, double b)      // Пример описания функции
  {
   int c = a * b + 3;                  // Оператор тела функции
   return (c);                         // Оператор выхода из функции
  }
                                       // Здесь (слева направо в заголовке):
   int                                 // Тип возвращаемого значения
   My_function                         // Название функции
   int a                               // Первый формальный параметр а целого типа
   double b                            // Второй формальный параметр b дествит. типа

Параметры, передаваемые в функцию, могут иметь значения по умолчанию, которые задаются константами соответствующего типа:

int My_function (int a, bool b=true, int c=1, double d=0.5)//Пример описания функции
  {
   a = a + b*c + d2;                   // Оператор тела функции
   int k = a * 3;                      // Оператор тела функции
   return (k);                         // Оператор выхода из функции
  }
                                       // Здесь (слева направо в заголовке):
   int                                 // Тип возвращаемого значения
   My_function                         // Название функции
   int a                               // Первый формальный параметр а целого типа
   bool b                              // Второй формальный параметр b логическ.типа
   true                                // Константа - умолчательное значение для b
   int c                               // Третий формальный параметр c целого типа
   1                                   // Константа - умолчательное значение для c
   double d                            // Четвёрт. формальный параметр d действ.типа
   0.5                                 // Константа - умолчательное значение для d

   a,b,c,d,k                           // Локальные переменные

Если в вызове функции, имеющей умолчательные значения, указаны фактические параметры, то к расчёту в функции будут приняты значения фактических параметров. Если в вызове функции, имеющей умолчательные значения, не указаны какие-то фактические параметры, то к расчёту в функции принимаются соответствующие значения по умолчанию.

Специальные функции также могут иметь параметры. Однако при вызове этих функций клиентским терминалом никакие параметры извне переданы не будут, а будут использованы умолчательные значения. Специальные функции могут быть вызваны из любого места модуля по общим правилам, наравне с другими функциями.

Правила исполнения функции

Место в программе для описания функции:

Описание функции должно находиться в программе обособленно, за пределами любых других функций (т.е. не внутри какой-либо другой функции, а снаружи).

Исполнение функции:

Вызванная для исполнения функция исполняется в соответствии с кодом, составляющим тело функции.

Формат оператора return

Возвращаемое функцией значение - это значение параметра, указанного в скобках оператора return. Оператор return состоит из ключевого слова return, Выражения, обрамлённого круглыми скобками, и заканчивается знаком ; (точка с запятой). Полноформатный оператор return:

   return (Выражение );                        // Оператор return

В качестве выражения в круглых скобках может быть указана константа, переменная или вызов функции. Тип значения, возвращаемого с помощью оператора return, должен совпадать с типом возвращаемого значения функции, указанным в заголовке. В случае если этого совпадения нет, значение выражения, указанного в операторе return, приводится к типу возвращаемого значения, указанному в заголовке описания функции. В случае если такое преобразование невозможно, на этапе компиляции программы редактор MetaEditor выдаст сообщение об ошибке.

Правило исполнения оператора return

Оператор return прекращает исполнение ближайшей внешней функции и передаёт управление в вызывающую программу в соответствии с правилами, определёнными для вызова функции. Значением, возвращаемым функцией, является значение выражения, указанного в операторе return. Если тип значения параметра, указанного в операторе return, не совпадает с типом возвращаемого значения, указанным в заголовке функции, то значение приводится к типу возвращаемого значения, указанному в заголовке.

Пример использования оператора return, возвращающего значение:

bool My_function (int Alpha)                 // Описание пользовательской функции
  {                                          // Начало тела функции
   if(Alpha>0)                               // Оператор if
     {                                       // Начало тела оператора if
      Alert("Значение положительно");        // Вызов стандартной функции
      return (true);                         // Первый выход из функции
     }                                       // Конец тела оператора if
   return (false);                           // Второй выход из функции
  }                                          // Конец тела функции

В функциях с типом возвращаемого значения void необходимо использовать оператор return без выражения:

   return;                                   // Оператор return без выражения в круглых скобках

Пример использования оператора return без возврата значения:

void My_function (double Price_Sell)         // Описание пользовательской функции
  {                                          // Начало тела функции
   if(Price_Sell-Ask >100)                   // Оператор if
      Alert("Прибыль по ордеру более 100 п");// Вызов стандартной функции
   return;                                   // Выход из функции
  }                                          // Конец тела функции

В описании функции допускается отсутствие оператора return. В этом случае функция автоматически завершает работу, если (в соответствии с исполняемым алгоритмом) в теле функции исполнился последний оператор. Пример описания функции, в которой не указан оператор return:

void My_function (int Alpha)                 // Описание пользовательской функции
  {                                          // Начало тела функции
   for (int i=1; i<=Alpha; i++)              // Оператор цикла
     {                                       // Начало тела цикла
      int a = 2*i + 3;                       // Оператор присваивания
      Alert ("a=", a);                       // Оператор вызова станд. функции
     }                                       // Конец тела цикла
  }                                          // Конец тела функции

В данном случае функция завершит работу в момент окончания исполнения оператора цикла for. Последним движением при исполнении функции будет проверка условия в операторе цикла. Как только Условие в заголовке оператора цикла for станет ложным, управление будет передано за пределы оператора цикла. Но в связи с тем, что оператор цикла является последним исполняемым оператором в теле функции My_function (), пользовательская функция завершит работу, а управление будет передано за пределы функции, именно в то место, откуда функция была вызвана на исполнение.

Вызов функцииПеременные


Условный оператор if - else - Операторы - Учебник по MQL4

Учебник по MQL4 [image] Операторы [image] Условный оператор if - else
MetaQuotes Sofware Corp.
  • Оператор присваивания
  • Условный оператор if - else
  • Оператор цикла while
  • Оператор циклa for
  • Оператор break
  • Оператор continue
  • Оператор switch
  • Вызов функции
  • Описание функции и оператор return
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Условный оператор if - else

Как правило, при программировании прикладных программ возникает необходимость закодировать в одной программе несколько вариантов решений. Для решения подобных задач в программе может быть использован условный оператор if-else.

Формат оператора if-else

Полный формат

Полноформатный оператор if-else содержит заголовок, включающий условие, тело 1, ключевое слово else и тело 2. Тела оператора могут состоять из одного или нескольких операторов и обрамляются фигурными скобками.

   if ( Условие )                                       // Заголовок оператора и условие
      {
      Блок операторов 1,                           // Если условие истинно, то..
      составляющих тело1                           //..выполняются операторы тела 1
      }else                                         // А если условие ложно..
      {
      Блок операторов 2,                           // ..то выполняются..
      составляющих тело 2                          // ..операторы тела 2
      }

Формат с отсутствующей частью else

Допускается использование оператора if-else с отсутствующей частью else. В этом случае оператор if-else содержит заголовок, включающий условие, и тело 1, состоящее из одного или нескольких операторов и обрамлённое фигурными скобками.

   if ( Условие )                                    // Заголовок оператора и условие
      {
      Блок операторов 1,                           // Если условие истинно, то..
      составляющих тело1                           //..выполняются операторы тела 1
      }

Формат с отсутствующими фигурными скобками

В случае, если тело оператора if-else состоит из одного оператора, то обрамляющие фигурные скобки можно опустить.

   if ( Условие )                                           // Заголовок оператора и условие
      Оператор;                                     // Если условие истинно, то..
                                                    // ..выполняется этот оператор

Правило исполнения оператора if-else

Если условие оператора if-else является истинным, то передать управление первому оператору тела 1, а после выполнения всех операторов тела 1 передать управление оператору, следующему за оператором if-else. Если условие оператора if-else является ложным, то:
- если в операторе if-else имеется ключевое слово else, то передать управление первому оператору тела 2, а после выполнения всех операторов тела 2 передать управление оператору, следующему за оператором if-else;
- если в операторе if-else нет ключевого слова else, то передать управление оператору, следующему за оператором if-else.

Примеры применения оператора if-else

Рассмотрим несколько примеров, демонстрирующих использование оператора if-else.

Задача 9. Составить программу, в которой реализуются следующие условия: если цена по финансовому инструменту поднялась выше некоторого значения, сообщить об этом трейдеру, а если нет, то не осуществлять никаких действий.

Один из вариантов решения этой задачи может выглядеть, например, так (onelevel.mq4):

//--------------------------------------------------------------------
// onelevel.mq4
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------------
int start()                                   // Спец. функция start
  {
   double
   Level,                                     // Сигнальный уровень
   Price;                                     // Текущая цена
   Level=1.2753;                              // Задаём уровень
   Price=Bid;                                 // Запрашиваем цену
//--------------------------------------------------------------------
   if (Price>Level)                           // Оператор if с условием
     {
      Alert("Курс превысил заданный уровень");// Сообщение трейдеру
     }
//--------------------------------------------------------------------
   return;                                    // Выход из start()
  }
//--------------------------------------------------------------------

Прежде всего необходимо отметить, что программа создана как эксперт. Этим полагается, что программа будет находиться в работе достаточно долго, с тем чтобы, когда текущая цена превысит заданный уровень, на экране появилось интересующее нас сообщение. В программе имеется всего одна специальная функция start(). В начале функции объявлены и прокомментированы переменные. Далее численно задаётся уровень цены и запрашивается текущая цена.

Oператор if-else используется в следующих строках программы:

//----------------------------------------------------------------------------------
   if (Price>Level)                           // Оператор if с условием
     {
      Alert("Курс превысил заданный уровень");// Сообщение трейдеру
     }
//----------------------------------------------------------------------------------

С момента, когда в выполняющейся программе управление передано в оператор if-else, начинается проверка его условия. Обратите внимание, проверка условия в операторе if-else является его собственным свойством. Эта проверка во время исполнения оператора if-else не может быть проигнорирована, она являет суть и смысл самого оператора и будет выполнена обязательно. В дальнейшем, в зависимости от результата этой проверки, управление будет передано либо в тело оператора, либо за его пределы - в оператор, следующий за закрывающей фигурной скобкой.

На рис. 37 представлена функциональная схема, в соответствии с которой могут развиваться события при исполнении оператора if-else.

Рис. 37. Функциональная схема исполнения оператора if-else в программе onelevel.mq4.

В этой и последующих схемах ромб символизирует проверку условия. Стрелки показывают, куда будет передано управление после исполнения текущего блока операторов (термин "блок операторов" означает некоторый произвольный набор операторов, находящихся в непосредственной близости друг к другу). Рассмотрим схему более подробно.

К блоку 'Предыдущие вычисления' (серый прямоугольник на схеме) в программе onelevel.mq4 относятся следующие:

   double
   Level,                                     // Сигнальный уровень
   Price;                                     // Текущая цена
   Level=1.2753;                              // Задаём уровень
   Price=Bid;                                 // Запрашиваем цену

После исполнения последнего оператора в этом блоке управление передаётся на заголовок оператора if-else, в котором проверяется условие Цена выше заданной? (ромб на схеме, рис. 37):

   if (Price>Level)                           //Оператор if с условием

Иными словами, можно сказать, что на этом этапе программа ищет ответ на вопрос, является ли заключённое в круглые скобки утверждение истинным. Само утверждение звучит буквально так, как оно написано: значение переменной Price больше значения переменной Level (цена больше заданного уровня). К моменту, когда программа определяет истинность этого утверждения, у неё уже имеются численные значения переменных Price и Level. И ответ зависит от соотношения этих значений. Если курс ниже заданного уровня (значение Price меньше или равно значению Level), то утверждение ложно, а если выше, то утверждение истинно.

Таким образом, куда будет передано управление после проверки условия, зависит от текущей ситуации на рынке (!). Если цена по финансовому инструменту остаётся ниже заданного уровня (ответ - Нет, т.е. утверждение ложно), то, в соответствии с правилом исполнения оператора if-else, управление будет передано за пределы оператора, в данном случае - в блок Последующие вычисления, а именно в строку:

   return;                                    // Выход из start()

При этом легко увидеть, что сообщение трейдеру не выдаётся.

Если же цена по финансовому инструменту превышает заданный в программе уровень (ответ - Да, т.е. утверждение истинно), то управление передаётся в тело оператора if-else, а именно в строки:

      {
      Alert("Курс превысил заданный уровень");// Сообщение трейдеру
      }

Результатом исполнения функции Alert() будет появление на экране небольшого окна с надписью:

Курс превысил заданный уровень

Функция Alert() является единственным оператором тела оператора if-else, поэтому после её исполнения оператор if-else является полностью выполненным, а значит, управление должно быть передано оператору, следующему за ним, т.е. в строку:

   return;                                    // Выход из start()

В результате исполнения оператора return функция start() закончит свою работу, и программа перейдёт в режим ожидания тика. На новом тике (несущем и новую цену по финансовому инструменту) функция start() будет снова исполнена. И в зависимости от того, превысил или не превысил текущий курс заданный уровень, будет или не будет выдано заложенное в программу сообщение.

Операторы if-else могут быть вложенными. Для того чтобы продемонстрировать использование вложенных операторов, обратимся к следующему примеру. Здесь задача уже несколько усложнена.

Задача 10. Составить программу, в которой реализуются следующие условия: если цена поднялась выше некоторого значения 1, то сообщить об этом трейдеру, если цена опустилась ниже некоторого значения 2, то сообщить об этом трейдеру, в остальных случаях не осуществлять никаких действий.

Понятно, что для решения этой задачи в программе необходимо дважды проверять текущую цену:

- находится ли цена выше-ниже уровня 1;

- находится ли цена выше-ниже уровня 2.

Решение задачи 10. Вариант 1

Действуя формально, можно составить следующий алгоритм решения:

Рис. 38. Функциональная схема исполнения операторов if-else в программе twolevel.mq4.

Программа, реализующая этот алгоритм, может выглядеть так (twolevel.mq4):

//--------------------------------------------------------------------
// twolevel.mq4
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------------
int start()                                 // Спец. функция start
  {
   double
   Level_1,                                 // Сигнальный уровень 1
   Level_2,                                 // Сигнальный уровень 2
   Price;                                   // Текущая цена
   Level_1=1.2850;                          // Задаём уровень 1
   Level_2=1.2800;                          // Задаём уровень 2
   Price=Bid;                               // Запрашиваем цену
//--------------------------------------------------------------------
   if (Price > Level_1)                     // Проверка верхн уровня
     {
      Alert("Цена находится выше уровня 1");// Сообщение трейдеру
     }
//--------------------------------------------------------------------
   if (Price < Level_2)                     // Проверка нижнего уровня
     {
      Alert("Цена находится ниже уровня 2");// Сообщение трейдеру
     }
//--------------------------------------------------------------------
   return;                                  // Выход из start()
  }
//--------------------------------------------------------------------

Нетрудно заметить, что код в программе twolevel.mq4 является расширенным вариантом программы onelevel.mq4. Если раньше у нас был только один уровень, относительно которого проводились вычисления, то теперь таких уровней стало два. Каждый из уровней задан численно, и для решения поставленной задачи в программе имеются два блока, отслеживающие поведение цены - находится ли она в коридоре значений, ограниченном заданными уровнями, или за его пределами.

Кратко охарактеризуем исполнение программы.

После выполнения предварительных вычислений управление поступает в первый оператор проверки if-else:

//----------------------------------------------------------------------------------
   if (Price > Level_1)                     // Проверка верхн уровня
     {
      Alert("Цена находится выше уровня 1");// Сообщение трейдеру
     }
//----------------------------------------------------------------------------------

Независимо от того, какие события произойдут при исполнении этого оператора (будет ли выдано сообщение трейдеру), по окончании его исполнения управление будет передано в следующий оператор if-else:

//----------------------------------------------------------------------------------
   if (Price < Level_2)                     // Проверка нижнего уровня
     {
      Alert("Цена находится ниже уровня 2");// Сообщение трейдеру
     }
//----------------------------------------------------------------------------------

В результате последовательного исполнения обоих операторов становится возможным осуществить обе проверки и, в конечном счёте, решить поставленную задачу. Несмотря на то, что программа полностью выполняет задачу, представленный вариант решения нельзя считать абсолютно корректным. Обратите внимание на одну немаловажную деталь: второй проверочный блок выполняется независимо от результатов, полученных при проверке в первом блоке. Выполнение второго программного блока осуществляется даже в том случае, если цена превысила первый уровень.

Здесь необходимо заметить, что одной из важных целей, преследуемых программистом при составлении программ, является оптимизация алгоритма. Рассматриваемые примеры - лишь демонстрация, поэтому являют собой короткую, а значит и быстро исполняемую программу. Программа, которую предполагается использовать в практической работе, обычно значительно больше. Она может обрабатывать значения сотен переменных, использовать множество проверок, каждая из которых выполняется в течение некоторого времени. В результате этого появляется опасность, что длительность работы специальной функции start() превысит временной промежуток между тиками. Это будет означать, что некоторые тики могут остаться необработанными. Разумеется, это - крайне нежелательная ситуация, и программисту следует прилагать усилия для того, чтобы не допустить этого. Одним из методов уменьшения времени исполнения программы является оптимизация алгоритма.

Посмотрим на последний пример ещё раз, теперь уже с точки зрения экономии ресурсов. Например, какой смысл проводить во втором блоке проверку "Цена ниже заданной?", если при проверке в первом блоке уже выяснилось, что цена выше верхнего уровня? Понятно, что в этом случае цена не может оказаться ниже нижнего уровня, значит, при этих условиях выполнять проверку во втором блоке (а также исполнять набор операторов в этом блоке) нет необходимости.

Решение задачи 10. Вариант 2

Учитывая эти рассуждения, рассмотрим следующий, оптимизированный алгоритм:

Рис. 39. Функциональная схема исполнения операторов if-else в программе twoleveloptim.mq4.

В соответствии с алгоритмом, представленным на этой схеме, лишние операции выполняться уже не будут. После подготовительных вычислений проводится проверка Цена выше заданной? В случае если цена выше, то выдаётся сообщение трейдеру и управление передаётся на Последующие вычисления, при этом анализ ситуации по второму критерию (Цена ниже заданной?) не производится. И только в том случае, если цена не оказалась выше верхнего уровня (ответ - Нет), управление передаётся на второй проверочный блок, в котором и проводится необходимая при этих условиях проверка. Если цена оказывается ниже нижнего уровня, то выдаётся соответствующее сообщение, а если нет, то управление передаётся на дальнейшие вычисления. Очевидно, что при работе программы по этому алгоритму никаких лишних действий не производится, в результате чего вычислительные ресурсы расходуются лишь по мере необходимости.

Программная реализация этого алгоритма предполагает использование вложенного оператора if-else (twoleveloptim.mq4):

//--------------------------------------------------------------------
// twoleveloptim.mq4
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------------
int start()                                  // Спец. функция start()
  {
   double
   Level_1,                                  // Сигнальный уровень 1
   Level_2,                                  // Сигнальный уровень 2
   Price;                                    // Текущая цена
   Level_1=1.2850;                           // Задаём уровень 1
   Level_2=1.2800;                           // Задаём уровень 2
   Price=Bid;                                // Запрашиваем цену
//--------------------------------------------------------------------
   if (Price > Level_1)                      // Проверка верхн. уровня
     {
      Alert("Цена находится выше уровня 1"); // Сообщение трейдеру
     }
   else
     {
      if (Price < Level_2)                   // Проверка нижнего уровня
        {
         Alert("Цена находится ниже уровня 2");// Сообщение трейдеру
        }
     }
//--------------------------------------------------------------------
   return;                                   // Выход из start()
  }
//--------------------------------------------------------------------

Обратите внимание на этот блок вычислений:

//--------------------------------------------------------------------
   if (Price > Level_1)                      // Проверка верхн. уровня
     {
      Alert("Цена находится выше уровня 1"); // Сообщение трейдеру
     }
   else
     {
      if (Price < Level_2)                   // Проверка нижнего уровня
        {
         Alert("Цена находится ниже уровня 2");// Сообщение трейдеру
        }
     }
//--------------------------------------------------------------------

Оператор if-else, в котором проверяется второе условие, является составной частью первого оператора if-else, проверяющего первое условие. Применение вложенных операторов очень распространено в практике программирования, зачастую является оправданным, а в некоторых случаях - единственным возможным решением. Разумеется, в реальных программах вместо функции Alert() могут быть использованы другие функции или операторы, выполняющие полезные действия.

В качестве условия в операторе if-else может быть использовано сложное выражение.

Задача 11. Составить программу, в которой реализуются следующие условия: если цена находится в заданном диапазоне значений, то не осуществлять никаких действий; если цена вышла за пределы заданного диапазона, то сообщить об этом трейдеру.

Условие этой задачи похоже на условие Задачи 10. Разница состоит в том, что в данном случае нас не интересует, в какую именно сторону ушла цена - выше или ниже заданного диапазона. По условию задачи нам достаточно знать только сам факт - находится цена внутри коридора или за его пределами. При этом может использоваться один и тот же текст сообщения.

Здесь, как и в предыдущих решениях, необходимо проверять положение цены относительно двух уровней - верхнего и нижнего. Алгоритм решения, представленный на рис. 38, нами уже был отвергнут ранее как неэффективный. Поэтому в соответствии с последними рассуждениями можно предложить такой вариант решения:

Рис. 40. Функциональная схема одного из вариантов алгоритма решения Задачи 11.

Однако в использовании такого алгоритма нет необходимости. На схеме наглядно показано, что данный алгоритм предполагает использование в разных местах программы одного и того же блока сообщений. Программные строки будут повторяться, несмотря на то, что результатом их исполнения будут одинаковые сообщения. Гораздо эффективнее в данном случае использовать один оператор if-else со сложным условием:

Рис. 41. Функциональная схема исполнения оператора if-else в программе compoundcondition.mq4.

Код программы, реализующий этот алгоритм, выглядит так (compoundcondition.mq4):

//--------------------------------------------------------------------
// compoundcondition.mq4
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------------
int start()                                    // Спец. функция start
  {
   double
   Level_1,                                    // Сигнальный уровень 1
   Level_2,                                    // Сигнальный уровень 2
   Price;                                      // Текущая цена
   Level_1=1.2850;                             // Задаём уровень 1
   Level_2=1.2800;                             // Задаём уровень 2
   Price=Bid;                                  // Запрашиваем цену
//--------------------------------------------------------------------
   if (Price>Level_1 || Price<Level_2)         // Проверка сложн услов
     {
      Alert("Цена находится за пределами диапазона");// Сообщение
     }
//--------------------------------------------------------------------
   return;                                     // Выход из start()
  }
//--------------------------------------------------------------------

Ключевым моментом в этом программном решении является использование сложного условия в операторе if-else:

if (Price>Level_1 || Price<Level_2)         // Проверка сложн услов
  {
   Alert("Цена находится за пределами диапазона");// Сообщение
  }

Написанное простыми словами, это условие выглядит так: если значение переменной Price больше значения переменной Level_1 или значение переменной Price меньше значения переменной Level_2, то исполнять тело оператора if-else. Использование логических операций (&&,|| и !) при составлении условий операторов if-else разрешено и широко применяется в практике программирования (см. Логические операции).

При решении других задач может возникнуть необходимость составления ещё более сложных условий, что вполне допустимо. При этом часть выражений может быть заключено в круглые скобки, в том числе вложенные. Например, в качестве условия в операторе if-else возможно использование такого выражения:

   if ( A>B && (B<=C || (N!=K && F>B+3)) )      // Пример сложного условия

Таким образом, язык программирования MQL4 предоставляет широкие возможности для использования операторов if-else: они могут быть вложенными, сами могут заключать вложенные структуры, использовать простые и сложные проверочные условия, в результате чего становится возможным составление простых и сложных программ с разветвлённым алгоритмом.

Оператор присваиванияОператор цикла while


Операторы - Учебник по MQL4

Учебник по MQL4 [image] Операторы
  • Оператор присваивания
  • Условный оператор if - else
  • Оператор цикла while
  • Оператор циклa for
  • Оператор break
  • Оператор continue
  • Оператор switch
  • Вызов функции
  • Описание функции и оператор return
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Операторы

В разделе представлены правила форматирования и исполнения операторов, используемых в языке MQL4. В каждом параграфе приводятся простые примеры, демонстрирующие исполнение операторов. С целью полного усвоения материала все представленные программы рекомендуется скомпилировать и запустить на исполнение. Это позволит также закрепить навыки работы с редактором MetaEditor.

  • Оператор присваивания.
    Самый простой и интуитивно понятный оператор. Операцию присваивания мы все знаем из школьного курса математики: слева от знака равенства стоит имя переменной, справа - назначаемое ей значение.
  • Условный оператор if-else.
    Часто необходимо направлять работу программы в ту или иную сторону в зависимости от некоторых условий. В таких случаях будет полезен оператор управления if-else.
  • Оператор цикла while.
    Обработка больших однотипных массивов данных обычно требует многочисленного повторения одних и тех же операций. Можно организовать цикл таких операций в операторе цикла while. Каждое однократное выполнение операций в цикле называется итерацией.
  • Оператор цикла for.
    Оператор for также является оператором цикла. Но в отличие от оператора while, в нем обычно указывается начальное и конечное значение некоего условия для выполнения итераций.
  • Оператор break.
    Если вам необходимо прервать работу оператора цикла и не выполнять оставшиеся итерации, то вам необходим оператор прерывания break. Он применяется в операторах while, for, switch и более нигде.
  • Оператор continue.
    Еще один полезный оператор - оператор перехода к следующей итерации в цикле. Позволяет пропустить все оставшиеся операторы в текущей итерации и перейти к следующей.
  • Переключатель switch.
    Этот оператор является "переключателем", который позволяет выбрать один из множества возможных вариантов. Для каждого варианта описывается своя заданная константа, которая является ключом (case) к этому варианту.
  • Вызов функции.
    Под вызовом функции подразумевается, что вызываемая функция выполняет некие возложенные на нее операции. При этом функция может возвращать некое значение заранее оговоренного типа. Количество параметров, передаваемых в функцию, не может превышать 64.
  • Описание функции и оператор return.
    Прежде чем вызвать пользовательскую функцию, ее необходимо описать. Описание функции - это указание ее типа, имени и списка параметров. Кроме того, в теле функции помещаются выполняемые операторы, завершается работа функции оператором return.
Примеры реализацииОператор присваивания


Оператор switch - Операторы - Учебник по MQL4

Учебник по MQL4 [image] Операторы [image] Оператор switch
  • Оператор присваивания
  • Условный оператор if - else
  • Оператор цикла while
  • Оператор циклa for
  • Оператор break
  • Оператор continue
  • Оператор switch
  • Вызов функции
  • Описание функции и оператор return
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Оператор switch

Некоторые программы предусматривают разветвление алгоритма по нескольким вариантам. В подобных случаях очень удобно использовать оператор switch, особенно, когда количество вариантов достигает десятков или сотен, а при использовании множества вложенных операторов if код получается очень громоздким.

Формат оператора switch

Оператор switch состоит из заголовка и исполняемого тела. Заголовок содержит название оператора и Выражение, обрамлённое круглыми скобками. Тело оператора содержит один или несколько вариантов case и один вариант default.

Каждый из вариантов case состоит из ключевого слова case, Константы, ":" (знака "двоеточие') и операторов. Количество вариантов case не ограничено.

Вариант default состоит из ключевого слова default, : (знака двоеточие) и операторов. Обычно вариант default указывается в теле оператора switch последним, но он может находиться и в любом другом месте тела или вообще отсутствовать.

   switch ( Выражение )                            // Заголовок оператора
      {                                          // Открывающая фигурная скобка
      case Константа: Операторы                   // Один из вариантов case
      case Константа: Операторы                   // Один из вариантов case
      ...
      [default: Операторы]                        // Вариант без параметра
      }                                         // Закрывающая фигурная скобка

Значениями Выражения и Параметров могут быть только значения целого типа. В качестве Выражения может использоваться константа, переменная, вызов функции или выражение. Каждый вариант case может быть помечен целой константой, символьной константой или константным выражением. Константное выражение не может включать переменные или вызовы функций.

Правило исполнения оператора switch

Передать управление первому из операторов, следующих за ":" (знаком двоеточия) того варианта case, значение Константы которого совпадет со значением Выражения, и далее последовательно исполнить все операторы, составляющие тело оператора switch. Проверка условия равенства Выражения и Константы производится в направлении сверху вниз и слева направо. Совпадение значений Констант разных вариантов case не допускается. Оператор break прекращает исполнение оператора switch и передаёт управление оператору, следующему за оператором switch.

Легко понять, что запись case Константа: представляет просто метку, на которую передаётся управление; и, начиная с этой метки, исполняются все операторы, составляющие тело оператора switch. Если же алгоритм программы предполагает исполнение группы операторов, соответствующих только одному из вариантов case, то последним в списке операторов, соответствующих одному варианту case, следует указать оператор break. Проследим работу оператора switch на примере.

Примеры применения оператора switch

Задача 18. Составить программу, в которой реализуются следующие условия: если курс поднялся выше заданного уровня, то выдать сообщение, в котором словами обозначено превышение над уровнем (до 10 пунктов); в остальных случаях сообщить, что курс не превышает заданный уровень.

Решение задачи с использованием оператора switch (эксперт pricealert.mq4):

//--------------------------------------------------------------------
// pricealert.mq4
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------------
int start()                                     // Спец. функция start
  {
   double Level=1.3200;                           // Задан. уровень цены
   int Delta=NormalizeDouble((Bid-Level)Point,0); // Превышение
   if (Delta<=0)                                  // Цена не выше уровня
     {
      Alert("Цена ниже уровня");                  // Сообщение
      return;                                     // Выход из start()
     }
//--------------------------------------------------------------------
   switch(Delta)                                  // Заголовок switch
     {                                            // Начало тела switch
      case 1 : Alert("Плюс один пункт");    break;// Варианты..
      case 2 : Alert("Плюс два пункта");    break;
      case 3 : Alert("Плюс три пункта");    break;
      case 4 : Alert("Плюс четыре пункта"); break;//Здесь представлено
      case 5 : Alert("Плюс пять пунктов");  break;//10 вариантов case,
      case 6 : Alert("Плюс шесть пунктов"); break;//но в общем случае
      case 7 : Alert("Плюс семь пунктов");  break;//количество case
      case 8 : Alert("Плюс восемь пунктов");break;//не ограничено
      case 9 : Alert("Плюс девять пунктов");break;
      case 10: Alert("Плюс десять пунктов");break;
      default: Alert("Более десяти пунктов");     // С case не совпало
     }                                            // Конец тела switch
//--------------------------------------------------------------------
   return;                                        // Выход из start()
  }
//--------------------------------------------------------------------

В данном варианте решения задачи используется оператор switch, в каждом варианте case которого используется оператор break. В зависимости от значения переменной Delta управление передаётся на один из вариантов case, в результате чего исполняются операторы, соответствующие этому варианту: функция Alert() и оператор break. Оператор break прекращает исполнение оператора switch, т.е. передаёт управление за его пределы, а именно - оператору return, завершающему работу специальной функции start(). Таким образом, в зависимости от значения переменной Delta, срабатывает один из вариантов case, а остальные варианты оказываются не затронутыми.

Эта программа - эксперт, значит она будет запускаться в работу на каждом тике, всякий раз отображая сообщения, соответствующие текущей ситуации. Разумеется, для демонстрации работы программы в окне финансового инструмента необходимо подобрать значение Level, близкое к текущему курсу.

Рис. 49. Функциональная схема оператора switch в эксперте pricealert.mq4.

На функциональной схеме хорошо видно, что благодаря наличию в каждом варианте case оператора break, после исполнения операторов любого из вариантов управление передаётся за пределы оператора switch. Подобный принцип построения алгоритма с применением оператора switch использован и в файле stdlib.mq4, поставляемом в составе клиентского терминала (..\experts\libraries\stdlib.mq4).

Рассмотрим другой случай, не предусматривающий использование break в каждом варианте case.

Задача 19. Дано 10 баров. Сообщить номера всех баров, начиная с n-го.

Закодировать решение этой задачи достаточно просто (скрипт barnumber.mq4):

//--------------------------------------------------------------------
// barnumber.mq4
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------------
int start()                             // Специальная функция start()
  {
   int n = 3;                           // Заданный номер
   Alert("Номера баров, начиная с ", n,":");// Не зависит от n
//--------------------------------------------------------------------
   switch (n)                           // Заголовок оператора switch
     {                                  // Начало тела switch
      case 1 : Alert("Бар 1");          // Варианты..
      case 2 : Alert("Бар 2");
      case 3 : Alert("Бар 3");
      case 4 : Alert("Бар 4");          // Здесь представлено 10 ..
      case 5 : Alert("Бар 5");          // ..вариантов case, но в ..
      case 6 : Alert("Бар 6");          // ..общем случае количество..
      case 7 : Alert("Бар 7");          // ..case не ограничено
      case 8 : Alert("Бар 8");
      case 9 : Alert("Бар 9");
      case 10: Alert("Бар 10");break;
      default: Alert("Задан неправильный номер");// С case не совпало
     }                                  // Конец тела switch
//--------------------------------------------------------------------
   return;                              // Оператор выхода из start()
  }
//--------------------------------------------------------------------

В операторе switch будет производиться перебор вариантов case до тех пор, пока не обнаружится равенство Выражения и Константы. Когда значение Выражения (здесь - это целое число 3) совпадает с одной из Констант (в данном случае - case 3), то исполнятся все операторы, которые следуют за двоеточием (case 3:), а именно: оператор вызова функции Alert("Бар 3"), следующие за ним Alert("Бар 4"), Alert("Бар 5") и т.д., пока не встретится оператор break, завершающий работу оператора switch.

В случае если значение Выражения не совпадает ни с одной из Констант, управление передаётся оператору, соответствующую варианту default:

Рис. 50. Функциональная схема оператора switch в скрипте barnumber.mq4.

В отличие от алгоритма, реализованного в предыдущей программе, в данном случае (рис. 50) в каждом варианте case не используется оператор break. Поэтому при совпадении значения Выражения со значением одной из Констант будут исполнены все операторы, начиная с операторов соответствующего варианта case. Использование оператора break в последнем варианте case имеет другую цель - не допустить исполнение операторов, соответствующих варианту default. Если же среди значений Констант не найдётся ни одной, равной Выражению, то управление будет передано оператору, соответствующему метке default.

Таким образом, если значение заданной переменной n находится в интервале значений от 1 до 10, то будут напечатаны номера всех баров, начиная с n, а если значение n находится за пределами указанного диапазона, то будет выдано сообщение о несоответствии.

Обратите внимание, Константы вариантов case не обязательно должны быть указаны в программе в порядке возрастания. Порядок следования вариантов case с соответствующими Константами определяется необходимостью программного алгоритма.

Оператор continueВызов функции


Оператор цикла while - Операторы - Учебник по MQL4

Учебник по MQL4 [image] Операторы [image] Оператор цикла while
MetaQuotes Sofware Corp.
  • Оператор присваивания
  • Условный оператор if - else
  • Оператор цикла while
  • Оператор циклa for
  • Оператор break
  • Оператор continue
  • Оператор switch
  • Вызов функции
  • Описание функции и оператор return
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Оператор цикла while

Наиболее мощным средством языка MQL4 является возможность организации циклов.

Довольно часто при создании прикладных программ приходится использовать повторяющиеся вычисления, чаще это бывают одни и те же программные строки. Для того чтобы программирование было удобным, а сама программа - понятной, используются операторы циклов. В составе MQL4 имеется два оператора цикла - while и for. Здесь мы рассмотрим первый из них.

Формат оператора while

Полноформатный оператор цикла while состоит из заголовка, содержащего условие, и исполняемого тела цикла, обрамлённого фигурными скобками.

   while ( Условие )                                   // Заголовок оператора цикла
      {                                            // Открывающая фигурная скобка
      Блок операторов,                             // Тело цикла может состоять ..
      составляющих тело цикла                      //.. из нескольких операторов
      }                                            // Закрывающая фигурная скобка

Если в операторе while тело цикла составляет один оператор, то фигурные скобки можно опустить.

   while ( Условие )                                   // Заголовок оператора цикла
      Один оператор, тело цикла                    // Тело цикла - один оператор

Правило исполнения оператора while

Пока Условие оператора while является истинным: передать управление первому оператору тела цикла, а после выполнения всех операторов тела цикла передать управление в заголовок для проверки истинности Условия.
Если условие оператора while является ложным, передать управление оператору, следующему за оператором while.

Рассмотрим пример.

Задача 12. Вычислить коэффициент Фибоначчи с точностью до 10-го знака.

Кратко охарактеризуем коэффициент Фибоначчи. Итальянский математик Леонардо Фибоначчи обнаружил уникальную последовательность чисел:

1 1 2 3 5 8 13 21 34 55 89 144 233 ...

Каждое число в этой последовательности является суммой двух предыдущих чисел. Представленная последовательность чисел обладает уникальными свойствами: отношение любого числа к предыдущему равно 1.618, а к следующему - 0,618. Коэффициент 1.618 получил название коэффициента Фибоначчи, а указанная последовательность называется последовательностью Фибоначчи (отметим также, что 0,3819 - сопряжённая величина для коэффициента Фибоначчи, получена в результате его умножения на самого себя: 0.3819 = 0.618 х 0.618).

Задача состоит в том, чтобы вычислить коэффициент Фибоначчи более точно. Если проанализировать коэффициент Фибоначчи для нескольких десятков элементов последовательности, то становится очевидным, что полученные коэффициенты колеблются вокруг иррационального числа 1.61803398875..., принимая поочерёдно то большие, то меньшие значения. Чем большие числа из последовательности участвуют в вычислениях, тем меньше отклонение от указанного значения.

Заранее неизвестно, какие именно числа необходимо взять, чтобы их коэффициенты отличались между собой не более, чем в десятом знаке. Поэтому необходимо составить программу, которая будет последовательно перебирать коэффициенты до тех пор, пока разница между ними не окажется меньше 0.0000000001.

В данном случае для решения Задачи 12 создан скрипт (fibonacci.mq4), потому программа не будет использоваться в длительной работе на каждом тике. После присоединения к окну финансового инструмента скрипт должен один раз выполнить необходимые вычисления (в том числе показать результат), после этого он будет выгружен из окна клиентским терминалом.

//--------------------------------------------------------------------
// fibonacci.mq4
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------------
int start()                               // Спец. ф-ия start()
  {
//--------------------------------------------------------------------
   int i;                                 // Формальн параметр,счётчик
   double
   A,B,C,                                 // Числа последовательности
   Delta,                                 // Фактич. разница между Кф
   D;                                     // Заданная точность
//--------------------------------------------------------------------
   A=1;                                   // Начальное значение
   B=1;                                   // Начальное значение
   C=2;                                   // Начальное значение
   D=0.0000000001;                        // Задаём точность
   Delta=1000.0;                          // Начальное значение
//--------------------------------------------------------------------
   while(Delta > D)                       // Заголовок оператора цикла
     {                                    // Скобка начала тела цикла
      i++;                                // Счётчик
      A=B;                                // Следующее значение
      B=C;                                // Следующее значение
      C=A + B;                            // Следующее значение
      Delta=MathAbs(C/B - B/A);           // Искомая разница между Кф
     }                                    // Скобка конца тела цикла
//--------------------------------------------------------------------
   Alert("C=",C," Число Фибоначчи=",C/B," i=",i);//Сообщение на экран
   return;                                // Выход из start()
  }
//--------------------------------------------------------------------

В начале программы производится объявление переменных (и даётся их описание). В последующих строках переменным присваиваются численные значения. А, В и С получают значения первых чисел последовательности Фибоначчи. Здесь необходимо отметить, что, хотя в самой последовательности идёт речь о целых числах, частное от их деления должно быть учтено в программе как действительное число. Если бы в данном случае был использован тип int для этих чисел, то не было бы возможности вычислить коэффициент Фибоначчи, например, 8/5 = 1 (целое число 1, то есть без дробной части). Поэтому в данном случае использован тип переменных double. Собственно оператор цикла выглядит так:

   while(Delta > D)                       // Заголовок оператора цикла
     {                                    // Скобка начала тела цикла
      i++;                                // Счётчик
      A=B;                                // Следующее значение
      B=C;                                // Следующее значение
      C=A + B;                            // Следующее значение
      Delta=MathAbs(C/B - B/A);           // Искомая разница между Кф
     }                                    // Скобка конца тела цикла

Рассмотрим функциональную схему оператора цикла while:

Рис. 42. Функциональная схема исполнения оператора while в программе fibonacci.mq4.

Оператор цикла начинает свою работу с проверки условия. Многократное выполнение цикла будет повторяться до тех пор, пока условие (Delta>D) является истинным. Понимание кода программы существенно упрощается, если при чтении операторов произносить ключевую фразу - правило исполнения. Например, при чтении оператора while это фраза: "До тех пор пока .., выполнять следующее: ..". В данном случае заголовок оператора while звучит так: до тех пор, пока Delta больше D, выполнять следующее.. И далее можно перейти к анализу программных строк, составляющих тело цикла и исполняемых в случае истинности этого Условия.

Перед тем как управление в приведенном примере fibonacci.mq4 передано оператору цикла while, значения этих переменных соответственно равны 1000.0 и 0.0000000001, поэтому при первом обращении к оператору цикла условие является истинным. Это значит, что после проверки условия управление будет передано первому оператору, составляющему тело оператора цикла.

В данном примере - это оператор:

      i++;                                // Счётчик

В трёх последующих строках вычисляются значения очередного набора элементов последовательности:

      A = B;                              // Следующее значение
      B = C;                              // Следующее значение
      C = A + B;                          // Следующее значение

Легко увидеть, что переменные принимают значения следующих (ближайших больших) элементов. Если до исполнения оператора цикла значения А, В и С были равны соответственно 1.0, 1.0 и 2.0, то в процессе первой итерации эти переменные принимают значения 1.0, 2.0 и 3.0.

Итерация - повторное выполнение некоторых вычислений; используется для обозначения факта исполнения программных строк, составляющих тело оператора цикла.

В следующей строке вычисляется интересующая нас разница между коэффициентами Фибоначчи, полученным на основе последующих (C/B) и предыдущих (B/A) элементов последовательности:

      Delta = MathAbs(C/B - B/A);         // Искомая разница между Кф

В этом операторе используется стандартная функция MathAbs(), вычисляющая абсолютное значение выражения. Ранее указывалось, что по мере увеличения значений элементов последовательности, коэффициенты Фибоначчи принимают поочерёдно то большие, то меньшие значения, в сравнении с "эталоном". Поэтому разница между соседними коэффициентами будет принимать то отрицательное, то положительное значение. В то же время, нас интересует собственно величина этого отклонения, т.е. её абсолютное значение. Таким образом, независимо от того, в какую сторону отклонилось текущее значение коэффициента Фибоначчи, значением выражения MathAbs(C/B - B/A), а также значением переменной Delta, всегда будет положительное число.

Этот оператор является последним в списке операторов, составляющих тело цикла, о чём свидетельствует наличие в следующей строке закрывающей фигурной скобки. После исполнения последнего оператора тела цикла управление передаётся в заголовок оператора цикла для проверки условия. В этом состоит ключевой момент, определяющий сущность оператора цикла. В зависимости от того, является ли теперь истинным условие оператора цикла, управление будет передано либо на очередную итерацию в тело цикла, либо за пределы оператора цикла.

На первых итерациях значение переменной Delta оказывается больше значения, заданного в переменной D. Это означает, что условие (Delta > D) является истинным, поэтому управление будет передано в тело цикла на следующую итерацию. Все переменные, участвующие в вычислениях, получат новые значения, и после достижения конца тела цикла управление снова будет передано в заголовок для проверки истинности условия.

Этот процесс будет продолжаться до тех пор, пока условие оператора цикла не станет ложным. В момент, когда значение переменной Delta окажется меньше или равным значению D, условие (Delta > D) перестанет соответствовать истине, а значит управление будет передано за пределы оператора цикла, в строку:

   Alert("C=",C," Число Фибоначчи=",C/B," i=",i);//Сообщение на экран

В результате на экране появится окно оператора Alert(), в котором будет напечатано следующее:

С=317811 Число Фибоначчи=1.618 i=25

Это означает, что на 25-й итерации заданная точность достигнута, при этом максимальное значение элемента последовательности Фибоначчи, которое было обработано, равно 317811, а сам коэффициент Фибоначчи, как и ожидалось, равен 1.618. Это сообщение является решением поставленной задачи.

Здесь нужно заметить, что действительные числа в MQL4 вычисляются с точностью до 15-го знака. В то же время, коэффициент Фибоначчи отражён с точностью до 3-го знака. Это произошло потому, что свойством функции Alert() является отображение чисел с точностью до 4-го знака, но все последние ноли при этом не отображаются. Если бы у нас возникла необходимость отобразить на экране число Фибоначчи с некоторой наперёд заданной точностью, то нам пришлось бы несколько изменить код, например, так:

   Alert("C=",C," Число Фибоначчи=",C/B*10000000," i=",i);// Сообщение

Особо нужно отметить следующее:

Возможна ситуация, при которой условие, указанное в заголовке оператора цикла, всегда будет оставаться истинным, в результате чего происходит зацикливание.

Зацикливание - бесконечное повторяющееся выполнение операторов, составляющих тело цикла; критическая ситуация, возникающая в результате реализации ошибочного алгоритма.

При зацикливании программа бесконечно исполняет блок операторов, составляющих тело цикла. Вот простой пример оператора цикла while с зацикливанием:

   int i=1;                               // Формальн параметр (счётчик)
   while (i > 0)                          // Заголовок оператора цикла
      i++;                                // Увеличение значения i

В данном примере происходит накапливание (увеличение значения) переменной i на каждой итерации. В результате условие никогда не станет ложным. Аналогичная ситуация возникает в случае, когда в теле цикла вообще ничего не вычисляется. Например, в этом коде:

   int i=1;                               // Формальн параметр (счётчик)
   while (i > 0)                          // Заголовок оператора цикла
      Alert("i= ",i);                     // Сообщение на экран

значение переменной i в цикле не изменяется. На каждой итерации на экран будет выводиться сообщение:

i= 1

Этот процесс будет повторяться бесконечно. Однажды попав в ловушку зацикленного кода, управление уже не может выйти из него. Особенно опасна эта ситуация в торгующих экспертах и скриптах. В таких случаях обычно не обновляются переменные окружения, т.к. специальная функция не заканчивает свою работу, а о факте зацикливания пользователю может быть ничего не известно. В результате управление в выполняемой программе не может быть передано в соответствующие программные строки, где принимается решение о закрытии или открытии ордеров.

Задача программиста состоит в том, чтобы не допустить возникновение условий, при которых неконтролируемое зацикливание становится возможным. Не существует метода, с помощью которого можно было бы обнаружить эту ситуацию программным способом ни на этапе компиляции программы, ни при её выполнении. Единственным возможным средством для выявления подобных алгоритмических ошибок является внимательный анализ кода - логические рассуждения и здравый смысл.

Условный оператор if - elseОператор циклa for


Массивы - Переменные - Учебник по MQL4

Учебник по MQL4 [image] Переменные [image] Массивы
  • Предопределённые переменные и функция RefreshRates
  • Виды переменных
  • Переменные GlobalVariables
  • Массивы
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Массивы

Значительная часть информации, обрабатываемой прикладными программами, заключена в массивах.

Понятие массив

Массив - это сгруппированный по месту распределения набор значений однотипных переменных, имеющих общее название. Различают одномерный и многомерный массивы. Максимально допустимое количество измерений в массиве - четыре. Допускаются массивы любых типов данных.

Элемент массива - это составная часть массива; индексированная переменная с одноимённым названием, имеющая некоторое значение.

Рис. 59. Графическое представление массивов целого типа: а) одномерный; b) двумерный; с) трёхмерный.

Индексирование

Индекс элемента массива - одно или несколько целых значений, указанных в виде константы, переменной или выражения, перечисленных через запятую и заключённых в квадратные скобки. Индекс элемента массива однозначно определяет место элемента в массиве. Индекс элемента массива указывается непосредственно после идентификатора переменной (названия массива) и является неотъемлемой частью элемента массива. В MQL4 принято индексирование, начинающееся с нуля.

Допускается также способ указания индексов, при котором каждый из индексов обрамляется квадратными скобками:

Наиболее близким бытовым аналогом двумерного массива является зрительный зал кинотеатра. Номер ряда в кинотеатре символизирует значение первого индекса, номер места в ряду - значение второй индекса, зрители - элементы массива, фамилия зрителя - значение элемента массива, а билет для входа в кинотеатр (с указанием ряда и места) - метод доступа к значению элемента массива.

Объявление массива и доступ к элементам массива

Перед тем, как массив будет использоваться в программе, его необходимо объявить. Массив может быть объявлен так же, как и переменная, - на глобальном и локальном уровне. Соответственно, значения элементов глобального массива доступны всей программе, а локального массива - только той функции, в которой этот массив объявлен. Массив не может быть объявлен на уровне клиентского терминала, поэтому глобальные переменные клиентского терминала не могут быть объединены в массив. Тип значений элементов массива может быть любым. Значения всех элементов массива имеют одинаковый тип, а именно тот, который указан при объявлении массива. При объявлении массива указывается тип данных, название массива и количество элементов в каждом измерении массива:

Доступ к значениям элементов массива осуществляется поэлементно, т.е. одновременно можно получить доступ только к одному из элементов. Тип значения элемента массива в программе не указывается. Получение или изменение значения элемента массива может осуществляться с помощью операторов присваивания:

Значения элементов массивов, показанных на Рис. 59, следующие:

- для одномерного массива значением элемента Mas[4] является целое число 34;

- для двумерного массива значением элемента Mas[3,7] является целое число 28;

- для трёхмерного массива значением элемента Mas[5,4,1] является целое число 77.

Обратите внимание, минимальное значение индекса элемента массива - 0 (ноль), а максимальное значение - на единицу меньше, чем количество элементов в соответствующем измерении, указанное при объявлении массива.

Например, для массива Mas[10][15] элементом с минимальными значениями индексов является элемент Mas[0,0], а с максимальными значениями индексов - элемент Mas[9,14] .

Осуществлять операции с массивами можно также с помощью стандартных функций. Для получения подробной информации о работе этих функций обратитесь к справочной документации на сайте производителя (http://docs.MQL4.com/ru) или к разделу "Справка" в редакторе MetaEditor. Некоторые из этих функций рассматриваются в дальнейшем изложении.

Инициализация массива

Массив может быть инициализирован только константами соответствующего типа. Одномерные и многомерные массивы инициализируются одномерной последовательностью констант, перечисленных через запятую. Последовательность обрамляется фигурными скобками:

int Mas_i[3][4] = { 0, 1, 2, 3,   10, 11, 12, 13,   20, 21, 22, 23 };

double Mas_d[2][3] = { 0.1, 0.2, -0.3,    -10.2, 1.5, 7.0 };

bool Mas_b[5] = { false, true, false, true, true }

В инициализирующей последовательности допускается пропуск одной или нескольких констант. В этом случае соответствующие элементы массивов числовых типов инициализируются нолём, а элементы массивов типа string инициализируются строковым значением "" (открывающая и закрывающая двойная кавычка без промежутка), т.е. пустой строкой (не путать с пробелом). Следующая программа выводит на экран значений массивов, инициализированных последовательностью с пропусками некоторых значений (скрипт arrayalert.mq4):

//--------------------------------------------------------------------
// arrayalert.mq4
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------------
int start()                                     // Спец. функция start
  {
   string Mas_s[4] = {"a","b", ,"d"};           // Строковый массив
   int Mas_i[6] = { 0,1,2, ,4,5 };              // Массив целого типа
   Alert(Mas_s[0],Mas_s[1],Mas_s[2],Mas_s[3]);  // Вывод на экран
   Alert(Mas_i[0],Mas_i[1],Mas_i[2],Mas_i[3],Mas_i[4],Mas_i[5]);
   return;                                      // Выход из start()
  }
//--------------------------------------------------------------------

Если размер одномерного инициализируемого массива не указан, то он определяется компилятором, исходя из размера инициализирующей последовательности. Инициализация массива может быть выполнена также с помощью стандартной функции ArrayInitialize(). Все массивы являются статическими, т.е. имеют вид static, даже если при инициализации это явно не указано. Это значит, что все элементы массива сохраняют свои значения в промежутке между вызовами на исполнение функции, в которой объявлен массив (см. Виды переменных).

Все используемые в MQL4 массивы можно разделить на две группы: пользовательские массивы (создаваемые по инициативе программиста) и массивы - таймсерии (массивы с предопределёнными именами и типами данных). Определение размеров пользовательских массивов и значений их элементов зависит от того, как составлена программа и, в конечном счёте, от воли программиста. Значения элементов пользовательских массивов сохраняется в программе в течение всего времени исполнения программы и может быть изменено в результате вычислений. В то же время изменение значений элементов в массивах-таймсериях не допускается, а их размеры могут увеличиваться при подкачке истории.

Пользовательские массивы

В разделе Оператор switch рассматривалась Задача 18. Несколько усложним условие (увеличим количество выводимых словами пунктов до 100) и решим эту задачу, используя массивы.

Задача 25. Составить программу, в которой реализуются следующие условия: если курс поднялся выше заданного уровня, то выдать сообщение, в котором словами обозначено превышение над уровнем (до 100 пунктов); в остальных случаях сообщить, что курс не превышает заданный уровень.

Решение Задачи 25 с использованием строкового массива может быть таким (эксперт stringarray.mq4):

//--------------------------------------------------------------------
// stringarray.mq4
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------------
extern double Level=1.3200;                     // Заданный уровень
string Text[101];                               // Объявление массива
//--------------------------------------------------------------------
int init()                                      // Спец. ф-ия init()
  {                                             // Присвоение значений
   Text[1]="один ";            Text[15]="пятнадцать ";
   Text[2]="два ";             Text[16]="шестнадцать ";
   Text[3]="три ";             Text[17]="семнадцать ";
   Text[4]="четыре ";          Text[18]="восемнадцать ";
   Text[5]="пять ";            Text[19]="девятнадцать ";
   Text[6]="шесть ";           Text[20]="двадцать ";
   Text[7]="семь ";            Text[30]="тридцать ";
   Text[8]="восемь ";          Text[40]="сорок ";
   Text[9]="девять ";          Text[50]="пятьдесят ";
   Text[10]="десять ";         Text[60]="шестьдесят";
   Text[11]="одиннадцать ";    Text[70]="семьдесят ";
   Text[12]="двенадцать ";     Text[80]="восемьдесят ";
   Text[13]="тринадцать ";     Text[90]="девяносто";
   Text[14]="четырнадцать ";   Text[100]= "сто";
   // Вычисление значений
   for(int i=20; i>=90; i=i+10)                // Цикл по десяткам
     {
      for(int j=1; j>=9; j++)                  // Цикл по единицам
         Text[i+j]=Text[i] + Text[j];          // Вычисление значения
     }
   return;                                     // Выход из init()
  }
//--------------------------------------------------------------------
int start()                                     // Спец. ф-ия start()
  {
   int Delta=NormalizeDouble((Bid-Level)/Point,0);// Превышение
//--------------------------------------------------------------------
   if (Delta>=0)                                // Цена не выше уровня
     {
      Alert("Цена ниже уровня");                // Сообщение
      return;                                   // Выход из start()
     }
//--------------------------------------------------------------------
   if (Delta<100)                               // Цена более 100
     {
      Alert("Более ста пунктов");               // Сообщение
      return;                                   // Выход из start()
     }
//--------------------------------------------------------------------
   Alert("Плюс ",Text[Delta],"pt.");            // Вывод на экран
   return;                                      // Выход из start()
  }
//--------------------------------------------------------------------

Для решения Задачи 25 используется строковый массив Text[]. Во время исполнения программы значения элементов этого массива не изменяются. Массив объявлен на глобальном уровне (за пределами специальных функций), а первоначальное заполнение массива осуществляется в специальной функции init(). Таким образом, в специальной функции start() выполняются только те вычисления, которые необходимо исполнить на каждом тике.

Некоторой части элементов массива Text[] присваиваются значения строковых констант. Другой части элементов массива присваиваются значения, вычисленные во вложенных циклах путём суммирования строк.

   for (int i = 20; i<=90; i=i+10)              // Цикл по десяткам
     {
      for (int j=1; j<=9; j++)                  // Цикл по единицам
         Text[i+j] = Text[i] + Text[j];         // Вычисление значения
     }

Смысл этих вычислений понять легко: для каждого элемента массива с индексом, начиная с 21 и заканчивая 99 (исключая значения индексов, кратных 10), вычисляются соответствующие строковые значения. Обратите внимание на значения индексов, указанные в строке:

         Text[i+j] = Text[i] + Text[j];         // Вычисление значения

В качестве значений индексов используются переменные (значения которых в цикле изменяются) и выражение. В зависимости значений переменных i и j программа будет обращаться к соответствующим элементам массива Text[], суммировать их значения и присваивать результат элементу массива с индексом, значение которого также вычисляется ( i+j ) Например, если на некотором этапе вычислений значение переменной i равно 30, а переменной j равно 7, то название элементов, значения которых суммируются, соответственно, Text[30] и Text[7], а элемента, которому присваивается результат, - Text[37]. В качестве значения индекса элемента массива может использоваться и любая другая переменная целого типа. В данном примере в функции start() используется название элемента того же массива с индексом Delta, а именно - Text[Delta].

Специальная функция start() имеет простой код. Вычисления ведутся в зависимости от значения переменной Delta. Если оно оказывается меньше одного или больше ста пунктов, то после вывода необходимого сообщения исполнение специальной функции start() завершается. Если же это значение находится в пределах заданного диапазона, то на экран выводится сообщение, требуемое по условию задачи.

Рис. 60. Вывод на экран искомых значений экспертом stringarray.mq4.

Обратите внимание на решение Задачи 18. Если бы и Задача 25 была решена тем же способом, то тело оператора switch содержало бы около 100 строк, - по одной строке для каждого варианта решения. Такой подход к составлению программ нельзя считать удовлетворительным. Тем более подобные способы решения оказываются непригодными, если приходится обрабатывать десятки, а иногда и сотни тысяч значений переменных. В таких случаях использование массивов оправдано и очень удобно.

Массивы-таймсерии

Массив-таймсерия - это массив с предопределённым названием (Open, Close, High, Low, Volume или Time), элементы которого содержат значения соответствующих характеристик исторических баров.

Данные, содержащиеся в массивах-таймсериях, несут очень важную информацию и широко используются в практике программирования на MQL4. Каждый массив-таймсерия является одномерным массивом и содержит исторические сведения о какой-то одной характеристике бара. Каждый бар характеризуется ценой открытия Open[], ценой закрытия Close[], максимальной ценой High[], минимальной ценой Low[], объёмом Volume[] и временем открытия Time[]. Например, массив-таймсерия Open[] несёт информацию о цене открытия всех баров, имеющихся в окне финансового инструмента: значением элемента массива Open[1] является цена открытия первого бара, Open[2] - цена открытия второго бара и т.д. То же справедливо и для всех других таймсерий.

Нулевой бар - это текущий бар, который ещё полностью не сформировался. В окне финансового инструмента нулевой бар отражается в крайней правой позиции.

Отсчёт баров (и поставленных им в соответствие индексов массивов-таймсерий) начинается с нулевого бара. Значениями элементов всех массивов-таймсерий, имеющих индекс [0], являются значения, характеризующие нулевой бар. Например, значением элемента Open[0] является цена открытия нулевого бара. На Рис. 61 показан порядок нумерации баров и характеристики бара (отражаемые в окне финансового инструмента при наведении на изображение бара курсора мыши).

Рис. 61. Каждый бар характеризуется набором значений, содержащихся в массивах-таймсериях.
Отсчёт баров начинается с нулевого бара.

Нулевой бар на Рис. 61 имеет следующие характеристики:

Индекс | Open[] | Close[] | High[], | Low[], | Time[]
[0] | 1.2755 | 1.2752 | 1.2755 | 1.2752 | 2006.11.01 14:34

По истечении некоторого времени текущий бар сформируется, а в окне финансового инструмента появится новый бар. Теперь нулевым будет этот новый бар, а тот, который только что сформировался, станет первым (с индексом 1):

Рис. 62. Бары смещаются с течением времени, но нумерация баров не смещается.

Теперь значения элементов массивов-таймсерий станут следующими:

Индекс | Open[] | Close[] | High[], | Low[], | Time[]
[0] | 1.2751 | 1.2748 | 1.2752 | 1.2748 | 2006.11.01 14:35
[1] | 1.2755 | 1.2752 | 1.2755 | 1.2752 | 2006.11.01 14:34

В дальнейшем в окне финансового инструмента будут появляться новые бары. При этом текущий, не сформировавшийся, самый правый бар всегда будет нулевым, ближайший слева от него будет первым, ближайший следующий - вторым и т.д. Вместе с тем, собственно бар не изменяет свои характеристики: тот бар, который в представленном примере был открыт в 14:34 по-прежнему будет характеризоваться временем открытия 14:34, и все другие его параметры также не изменятся. Однако, индекс этого бара будет всё время увеличиваться по мере появления новых баров.

Таким образом, важнейшая особенность, касающаяся массивов-таймсерий, состоит в следующем:

Значения элементов массивов-таймсерий являются собственными характеристиками бара и никогда не изменяются (за исключением следующих характеристик нулевого бара: Close[0], High[0], Low[0], Volume [0]), а индекс бара отражает его углубление в историю на текущий момент и меняется с течением времени.

Отдельно нужно заметить, что время открытия бара исчисляется кратно календарным минутам, секунды при этом не учитываются. Иными словами, если в период между 14:34 и 14:35 первый тик пришёл в 14 час. 34 мин. 07 сек, то в минутном таймфрейме образуется новый бар со временем открытия 14:34. Соответственно, время открытия бара в 15-минутном таймфрейме кратно 15 минутам, при этом первый бар в течение часового интервала открывается в n час.00 мин, второй в n:15, третий в n:30 и четвёртый - в n:45.

Чтобы правильно понять роль индексов в массивах-таймсериях, решим следующую простую задачу:

Задача 26.Найти минимальное и максимальное значения цены среди последних n баров.

Обратите внимание, решение подобных задач невозможно без обращения к значениям массивов-таймсерий. Эксперт, определяющий минимальную и максимальную цену среди заданного количества последних баров, может иметь следующее решение (extremumprice.mq4):

//--------------------------------------------------------------------
// extremumprice.mq4
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------------
extern int Quant_Bars=30;                       // Количество баров
//--------------------------------------------------------------------
int start()                                     // Спец. функция start
  {
   int i;                                       // Номер бара
   double Minimum=Bid,                          // Минимальная цена
          Maximum=Bid;                          // Максимальная цена

   for(i=0;i<=Quant_Bars-1;i++)                 // От нуля (!) до..
     {                                          // ..Quant_Bars-1 (!)
      if (Low[i]< Minimum)                      // Если < известного
         Minimum=Low[i];                        // то оно и будет мин
      if (High[i]> Maximum)                     // Если > известного
         Maximum=High[i];                       // то оно и будет макс
     }
   Alert("За последние ",Quant_Bars,            // Вывод на экран
         " баров Min= ",Minimum," Max= ",Maximum);
   return;                                      // Выход из start()
  }
//--------------------------------------------------------------------

В программе extremumprice.mq4 используется простой алгоритм. Количество баров, предназначенных для анализа, задано во внешней переменной Quant_Bars. В начале программы искомым значениям Minimum и Maximum присваиваются значения текущей цены. Поиск минимального и максимального значений выполняется в операторе цикла:

   for(i=0;i<=Quant_Bars-1;i++)                 // От нуля (!) до..
     {                                         // ..Quant_Bars-1 (!)
      if (Low[i]< Minimum)                      // Если < известного
         Minimum = Low[i];                      // то оно и будет мин
      if (High[i]> Maximum)                     // Если > известного
         Maximum = High[i];                     // то оно и будет макс
     }

Здесь показательным является интервал значений индексов (целая переменная i) обрабатываемых элементов массивов-таймсерий Low[i] и High[i]. Обратите внимание на Выражение_1 и Условие в заголовке оператора цикла:

   for(i=0;i<=Quant_Bars-1;i++)                 // От нуля (!) до..

На первой итерации вычисления производятся с нулевыми значениями индексов. Это значит, что в расчётах на первой итерации анализируются значения нулевого бара. Таким образом гарантируется, что самые последние значения цены, появившиеся в окне финансового инструмента, тоже принимаются во внимание. В разделе Предопределённые переменные указано правило, в соответствии с которым значения всех предопределённых переменных, в том числе и массивов-таймсерий, обновляются в момент запуска на исполнение специальных функций. Таким образом, ни одно значение цены не может быть пропущено или не учтено.

Последним индексом элементов таймсерий, обрабатываемых в цикле, является индекс, на 1 меньший, чем количество обрабатываемых баров. В нашем примере указано количество баров, равное 30. Это значит, что максимальное значение индекса должно быть равно 29. Таким образом, в цикле будут обработаны значения элементов таймсерий с индексами от 0 до 29, т.е. всего для 30 баров.

Легко понять и смысл вычислений в теле оператора цикла:

      if (Low[i]< Minimum)                      // Если < известного
         Minimum = Low[i];                      // то оно и будет мин
      if (High[i]> Maximum)                     // Если > известного
         Maximum = High[i];                     // то оно и будет макс

Если текущее значение Low[i] (т.е. в период текущей итерации с текущим значением индекса) оказывается меньше известного минимального значения, то оно и становится минимальным значением. Аналогично вычисляется и максимальное значение. К моменту окончания цикла переменные Minimum и Maximum получат искомые значения. В последующих строках эти значения выводятся на экран.

Запустив эту программу на выполнение можно получить результат, аналогичный следующему:

Рис. 63. Результаты работы эксперта extremumprice.mq4.

Обратите внимание, эксперт может работать бесконечно долго, показывая правильный результат, причём в программе всё время используются одни и те же значения индексов (в данном случае от 0 до 29). При этом значения элементов массивов-таймсерий с ненулевыми индексами будут изменяться в момент появления нового бара, а значения элементов массивов-таймсерий, характеризующих нулевой бар, могут поменяться на любом следующем тике (за исключением значений Open[0] и Time[0], которые на нулевом баре не изменяются).

В некоторых случаях требуется выполнить какие-то действия, начиная с момента, когда очередной бар только что полностью сформировался. Это бывает важно, например, для реализации алгоритмов, основанных на свечном анализе. При этом обычно во внимание принимаются только полностью сформировавшиеся бары.

Задача 27.В начале каждого бара 1 раз вывести на экран минимальное и максимальное значения цены среди последних сформировавшихся n баров.

Чтобы решить задачу, прежде всего необходимо определить факт начала нового бара, т.е. выявить первый тик на нулевом баре. Для этой цели существует очень простой и надёжный способ - анализировать время открытия нулевого бара. Время открытия нулевого бара - это такая характеристика бара, которая не изменяется в течение времени его формирования. Новые тики, поступающие в процессе развития нулевого бара, могут изменить его максимальную цену High[0], минимальную цену Low[0], цену закрытия Close[0] и объём Volume0]. Но такие характеристики нулевого бара, как цена открытия Open[0] и время открытия Time[0], не изменяются.

Поэтому достаточно запомнить время открытия нулевого бара и на каждом тике сравнивать это значение с последним известным временем открытия нулевого бара. Как только обнаружится несовпадение, это будет означать факт образования нового бара (и завершение предыдущего). В эксперте newbar.mq4 алгоритм обнаружения нового бара реализован в виде пользовательской функции:

//--------------------------------------------------------------------
// newbar.mq4
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------------
extern int Quant_Bars=15;                       // Количество баров
bool New_Bar=false;                             // Флаг нового бара
//--------------------------------------------------------------------
int start()                                     // Спец. функция start
  {
   double Minimum,                              // Минимальная цена
          Maximum;                              // Максимальная цена
//--------------------------------------------------------------------
   Fun_New_Bar();                               // Обращение к ф-ии
   if (New_Bar==false)                          // Если бар не новый..
      return;                                   // ..то уходим
//--------------------------------------------------------------------
   int Ind_max =ArrayMaximum(High,Quant_Bars,1);// Индекс бара макс.ц.
   int Ind_min =ArrayMinimum(Low, Quant_Bars,1);// Индекс бара мин. ц.
   Maximum=High[Ind_max];                       // Искомая макс цена
   Minimum=Low[Ind_min];                        // Искомая мин. цена
   Alert("За последние ",Quant_Bars,            // Вывод на экран
   " баров Min= ",Minimum," Max= ",Maximum);
   return;                                      // Выход из start()
  }
//--------------------------------------------------------------------
void Fun_New_Bar()                              // Ф-ия обнаружения ..
  {                                             // .. нового бара
   static datetime New_Time=0;                  // Время текущего бара
   New_Bar=false;                               // Нового бара нет
   if(New_Time!=Time[0])                        // Сравниваем время
     {
      New_Time=Time[0];                         // Теперь время такое
      New_Bar=true;                             // Поймался новый бар
     }
  }
//--------------------------------------------------------------------

В программе используется глобальная переменная New_Bar. Полагается, что если её значение равно true, то это означает, что последний известный тик - это первый тик нового бара. Если же значение New_Bar равно false, то последний известный тик появился в период развития текущего нулевого бара.

Флаг - это переменная, значение которой ставится в соответствие каким-либо событиям или фактам.

Использование флагов в программе очень удобно. Значение флага может быть определено в одном месте, а использоваться в разных местах. Иногда в программе используется алгоритм, в котором принимается решение в зависимости от сочетания значений различных флагов. В эксперте newbar.mq4 в качестве флага используется переменная New_Bar, значение которой находится в прямой зависимости от факта образования нового бара.

Вычисления, касающиеся выявления факта образования нового бара, сосредоточены в пользовательской функции Fun_New_Bar(). В первых строках этой функции определена статическая переменная New_Time (напомним, что статические переменные не теряют своё значение после окончания исполнения функции). При каждом обращении к функции значение глобальной переменной New_Bar устанавливается равным false. Собственно обнаружение нового бара осуществляется в операторе if:

   if(New_Time != Time[0])                      // Сравниваем время
     {
      New_Time = Time[0];                       // Теперь время такое
      New_Bar = true;                           // Поймался новый бар
     }

Если значение переменной New_Time (вычисленное в предыдущей истории), не равно времени открытия нулевого бара Time[0], то это означает факт образования нового бара. В этом случае управление передаётся в тело оператора if, где запоминается новое значение времени открытия нового нулевого бара и переменной New_Bar присваивается значение true (условно можно сказать, что флаг устанавливается в положение вверх).

При решениях подобных задач важно учитывать специфику использования различных флагов. В данном случае особенность состоит в том, что значение переменной New_Bar (положение флага) должно быть обновлено раньше, чем оно будет использоваться в вычислениях (в данном случае - в специальной функции start()). Поскольку значение переменной New_Bar определяется в пользовательской функции, значит обращение к ней должно быть выполнено как можно раньше в программе, а именно, до первых вычислений, в которых используется переменная New_Bar. Специальная функция start() так и составлена: обращение к пользовательской функции осуществляется сразу после объявления переменных.

Вычисление искомых значений имеет смысл только в том случае, если специальная функция start() запущена тиком, на котором и образовался новый бар. Поэтому в функции start(), сразу после определения факта образования нового бара, производится анализ положения флага (значения переменной New_Bar):

   if (New_Bar == false)                        // Если бар не новый..
      return;                                   // ..то уходим

Если последний тик, запустивший на исполнение специальную функцию start(), не образовал новый бар, то управление передаётся оператору, завершающему исполнение функции start(). И только в том случае, если новый бар образовался, управление передаётся в последующие строки для вычисления искомых значений (что и требуется по условию задачи).

Вычисление максимального и минимального значений осуществляется с помощью стандартных функций ArrayMaximum() и ArrayMinimum(). Каждая из этих функций возвращает индекс элемента массива (соответственно максимального и минимального значения) для заданного интервала индексов. По условию задачи необходимо исследовать только полностью сформировавшиеся бары, поэтому в качестве граничных значений индексов выбраны значения 1 и Quant_Bars - заданное количество баров (нулевой бар не сформировался, т.е. в решении данной задачи не учитывается). Для получения подробной информации о работе этих и других функций доступа к таймсериям обратитесь к справочной документации на сайте производителя (http://docs.MQL4.com/ru) или к разделу "Справка" в редакторе MetaEditor.

На Рис. 64 можно проследить, как менялись минимальное и максимальное значения цены на заданном интервале в период исполнения программы:

Рис. 64. Результаты работы эксперта newbar.mq4.

Переменные GlobalVariablesПрактическое программирование на языке MQL4


Переменные GlobalVariables - Переменные - Учебник по MQL4

Учебник по MQL4 [image] Переменные [image] Переменные GlobalVariables
MetaQuotes Sofware Corp.
  • Предопределённые переменные и функция RefreshRates
  • Виды переменных
  • Переменные GlobalVariables
  • Массивы
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Переменные GlobalVariables

В клиентском терминале может работать несколько прикладных программ одновременно. В ряде случаев возникает необходимость передать какие-то сведения из одной программы в другую. Специально для этого в языке MQL4 созданы глобальные переменные клиентского терминала.

Глобальная переменная клиентского терминала - переменная, значение которой доступно из всех прикладных программ, запущенных на клиентском терминале (сокращённо - GV-переменная).

Обратите внимание, глобальная переменная клиентского терминала и глобальная переменная - это разные переменные с похожими названиями. Областью видимости глобальных переменных является одна программа, в которой эта переменная объявлена, а областью видимости глобальных переменных клиентского терминала - все программы, одновременно запущенные в клиентском терминале.

Свойства GV-переменных

В отличие от других переменных, GV-переменная может быть не только создана из любой программы, но и удалена. Значение GV-переменной сохраняется на жёстком диске компьютера и после закрытия клиентского терминала. Однажды объявленная GV-переменная существует в клиентском терминале в течение 4 недель с момента последнего обращения. Если в течение указанного срока ни одна из программ не обращалась к GV-переменной, то она удаляется клиентским терминалом. GV-переменная может иметь только тип double.

Функции для работы с GV-переменными

Для работы с GV-переменными в MQL4 имеются ряд функций (см. также Глобальные переменные GlobalVariables). Рассмотрим те из них, которые понадобятся нам в последующих примерах.

Функция GlobalVariableSet()

datetime GlobalVariableSet( string name, double value)

Функция устанавливает новое значение глобальной переменной. Если переменная не существует, то система создает новую глобальную переменную. При успешном выполнении функция возвращает время последнего доступа, иначе 0. Чтобы получить информацию об ошибке, необходимо вызвать функцию GetLastError().

Параметры:

name - Имя глобальной переменной.

value - Новое числовое значение.

Функция GlobalVariableGet()

double GlobalVariableGet( string name)

Функция возвращает значение существующей глобальной переменной или 0 в случае ошибки. Чтобы получить информацию об ошибке, необходимо вызвать функцию GetLastError().

Параметры:

name - Имя глобальной переменной.

Функция GlobalVariableDel()

bool GlobalVariableDel( string name)

Функция удаляет глобальную переменную. При успешном удалении функция возвращает TRUE, иначе FALSE. Чтобы получить информацию об ошибке, необходимо вызвать функцию GetLastError().

Параметры:

name - Имя глобальной переменной.

Чтобы продемонстрировать насколько удобным и полезным может быть использование GV-переменных, решим следующую задачу:

Задача 24. В терминале одновременно работают несколько экспертов. Сумма депозита составляет $10 000. Общая стоимость всех открытых ордеров не должна превышать 30% от суммы депозита. Каждому эксперту должно быть выделено равное количество денежных средств. Составить программу эксперта, содержащую расчёт суммы, выделенной для торговли.

Собственно расчёт суммы, которая выделяется эксперту для торговли, не представляет никакой сложности. Однако, для того, чтобы такой расчёт выполнить, необходимо знать, какое количество экспертов одновременно запущено в клиентском терминале. В MQL4 не существует функции, которая помогла бы ответить на этот вопрос. Единственная возможность для подсчёта количества одновременно запущенных программ состоит в том, чтобы каждая из программ заявила о себе путём изменения значения некоторой GV-переменной. В дальнейшем, все программы, заинтересованные в такой информации, могут обратиться к этой переменной и по её значению судить о текущем положении дел.

Здесь нужно заметить, что в общем случае не каждая программа предназначена для решения подобной задачи. Если в клиентском терминале появится эксперт, не заявляющий о своём присутствии, то, естественно, он никак не будет учтён. Поэтому в данном случае сама постановка задачи предполагает использование только тех экспертов, которые содержат необходимый код - и для изменения значения GV-переменной, и для последующего считывания значения этой переменной.

Ниже представлен эксперт, демонстрирующий использование GV-переменных (globalvar.mq4), который может быть использован для решения Задачи 24:

//--------------------------------------------------------------------
// globalvar.mq4
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------------
int    Experts;                                 // Колич. экспертов
double Depo=10000.0,                            // Заданный депозит
       Persent=30,                              // Заданный процент
       Money;                                   // Искомые средства
string Quantity="GV_Quantity";                  // Имя GV-переменной
//--------------------------------------------------------------------
int init()                                      // Спец. функция init
  {
   Experts=GlobalVariableGet(Quantity);         // Получим тек. знач.
   Experts=Experts+1;                           // Колич. экспертов
   GlobalVariableSet(Quantity, Experts);        // Новое значение
   Money=Depo*Persent/100/Experts;                // Средства для эксп.
   Alert("Для эксперта в окне ", Symbol()," выделено ",Money);
   return;                                      // Выход из init()
  }
//--------------------------------------------------------------------
int start()                                     // Спец. функция start
  {
   int New_Experts= GlobalVariableGet(Quantity);// Новое колич. эксп.
   if (Experts!=New_Experts)                    // Если изменилось
     {
      Experts=New_Experts;                      // Теперь текущ. такое
      Money=Depo*Persent/100/Experts;             // Новое знач. средств
      Alert("Новое значение для эксперта ",Symbol(),": ",Money);
     }
   /*
   ...
   Здесь долен быть указан основной код эксперта,
   в котором используется значение переменной Money
   ...
   */
   return;                                      // Выход из start()
  }
//--------------------------------------------------------------------
int deinit()                                    // Спец. ф-ия deinit
  {
   if (Experts ==1)                             // Если эксперт один..
      GlobalVariableDel(Quantity);              //..удаляем GV-перемен
   else                                         // А иначе..
      GlobalVariableSet(Quantity, Experts-1);   //..уменьшаем на 1
   Alert("Эксперт выгружен из окна ",Symbol()); // Сообщ. о выгрузке
   return;                                      // Выход из deinit()
  }
//--------------------------------------------------------------------

Этот эксперт содержит три специальные функции. Кратко напомним, что все специальные функции запускаются на исполнение клиентским терминалом: функция init() - при присоединении эксперта к окну финансового инструмента, функция deinit() - при выгрузке эксперта из окна, а функция start() - потиково. В головной части программы объявлены глобальные переменные (областью видимости этих переменных является программа).

Распределение средств между экспертами зависит от одного изменяемого параметра - количества одновременно запущенных экспертов. Поэтому и GV-переменная, отражающая количество экспертов, должна быть одна. Название этой переменной задано в строке:

string Quantity = "GV_Quantity";                // Имя GV-переменной
Обратите внимание, имя глобальной переменной клиентского терминала может быть вычислено в исполняющейся программе (имена всех других видов переменных задаются программистом на этапе создания кода).

Разберём подробно, как изменяется и обрабатывается значение переменной Quantity в процессе выполнения программы. Прежде всего, эксперт, присоединяемый к окну финансового инструмента, должен заявить о своём присутствии, чтобы другие эксперты, работающие в терминале, могли об этом событии узнать. Это необходимо сделать как можно раньше (как можно ближе к тому моменту, когда эксперт присоединён). Наиболее подходящее для этого место в программе - специальная функция init(). В первой строке этой функции эксперт запрашивает текущее значение переменной Quantity, для этого используется функция GlobalVariableGet():

   Experts = GlobalVariableGet(Quantity);       // Получим тек. знач.

Теперь значение GV-переменной Quantity, каким бы оно ни было на момент присоединения эксперта, должно быть увеличено на 1. Это означает, что только что присоединяемый эксперт увеличил общее количество экспертов, одновременно работающих в терминале, на один:

   Experts = Experts+1;                         // Колич. экспертов

Глобальная переменная Experts используется в программе для удобства. Её значение недоступно другим экспертам. Чтобы изменить значение GV-переменной Quantity, необходимо воспользоваться функцией GlobalVariableSet(), устанавливающей новое значение GV-переменной:

   GlobalVariableSet(Quantity, Experts);        // Новое значение

Это означает, что GV-переменной Quantity присвоено новое значение Experts. Теперь это новое значение GV-переменной доступно всем работающим в терминале программам. Вслед за этим рассчитывается и искомая сумма, выделенная для торговли только что присоединённому эксперту, и делается сообщение (здесь сообщения необходимы только для того, чтобы проиллюстрировать в какой момент времени в каком эксперте осуществляются те или иные события; в реально работающей программе сообщения используются по необходимости).

   Money = Depo*Persent/100/Experts;              // Средства для эксп.
   Alert("Для эксперта в окне ", Symbol()," выделено ",Money);

Обратите внимание, наш эксперт рассчитал искомую сумму исходя из общего количества присоединённых экспертов (в том числе, посчитал и себя). По окончании исполнения специальной функции init() управление передаётся клиентскому терминалу, и эксперт переходит в режим ожидания нового тика. В момент прихода нового тика клиентский терминал запустит на исполнение специальную функцию start().

Теперь, в рамках решения поставленной задачи, целью эксперта является отслеживание текущего количества присоединённых экспертов - ведь могут быть присоединены или выгружены другие эксперты, а значит, общее количество одновременно работающих экспертов может измениться. В зависимости от этого наш эксперт должен пересчитать сумму средств, выделяемых ему по условию задачи. Поэтому, первое, что делает эксперт на каждом новом тике, - это запрашивает новое значение GV-переменной Quantity:

   int New_Experts= GlobalVariableGet(Quantity);// Новое колич. эксп.

и если это новое значение New_Experts не совпадает с последним известным значением Experts, то новое известное значение теперь учитывается как текущее, выполняется пересчёт средств, выделяемых эксперту для торговли (Money), а также делается соответствующее сообщение:

   if (Experts != New_Experts)                  // Если изменилось
     {
      Experts = New_Experts;                    // Теперь текущ. такое
      Money = Depo*Persent/100/Experts;           // Новое знач. средств
      Alert("Новое значение для эксперта ",Symbol(),": ",Money);
     }

Если же переменные New_Experts и Experts совпадают, то этот расчёт не производится, а в дальнейшем коде эксперта (в функции start()) используется ранее вычисленное значение переменной Money. Так, в зависимости от ситуации, на каждом тике высчитывается новое или сохраняется имеющееся значение Money.

На этапе выгрузки каждый эксперт, принимающий участие в вычислениях в рамках Задачи 24, должен сообщить другим экспертам, что он выгружен, т.е. количество одновременно работающих экспертов уменьшилось. Более того, если этот эксперт последний, то необходимо удалить и саму GV-переменную. О выгрузке эксперта однозначно свидетельствует факт исполнения специальной функции deinit(), поэтому соответствующий код должен быть расположен именно в этой функции:

int deinit()                                    // Спец. ф-ия deinit
  {
   if (Experts ==1)                             // Если эксперт один..
      GlobalVariableDel(Quantity);              //..удаляем GV-перемен
   else                                         // А иначе..
      GlobalVariableSet(Quantity, Experts-1);   //..уменьшаем на 1
   Alert("Эксперт выгружен из окна ",Symbol()); // Сообщ. о выгрузке
   return;                                      // Выход из deinit()
  }

Все вычисления в специальной функции deinit() производятся в рамках одного оператора if. Если количество экспертов равно 1, т.е. этот эксперт последний, то исполняется удаление GV-переменной с помощью функции GlobalVariableDel(), а во всех остальных случаях (т.е. когда количество экспертов больше 1) с помощью функции GlobalVariableSet() для переменной Quantity устанавливается новое значение, которое на 1 меньше текущего. Эксперты, оставшиеся загруженными, в начале исполнения специальной функции start(), отследят новое значение переменной Quantity и пересчитают искомое значение переменной Money.

Легко заметить, что значения GV-переменных могут быть считаны или изменены из любого исполняющегося эксперта с помощью предназначенных для этого функций. Прямые вычисления со значениями GV-переменных недопустимы. Для того, чтобы использовать значение GV-переменной в обычном выражении, необходимо это значение присвоить какой-нибудь другой переменной, и в вычислениях использовать эту переменную. В нашем случае такую роль играют две переменные - Experts и New_Experts в таких строках:

   Experts = GlobalVariableGet(Quantity);       // Получим тек. знач.
   int New_Experts= GlobalVariableGet(Quantity);// Новое колич. эксп.

Рекомендуется скомпилировать и запустить на исполнение globalvar.mq4 в нескольких окнах различных валютных инструментов. В зависимости от последовательности событий, в окне функции Alert можно наблюдать соответствующие сообщения, например, такие:

Рис. 55. Сообщения в окне функции Alert в результате последовательной загрузки и выгрузки
эксперта globalvar.mq4 в окна трёх различных финансовых инструментов.

В клиентском терминале имеется возможность открыть панель "Глобальные переменные", на которой в режиме реального времени можно увидеть все открытые на текущий момент GV-переменные и их значения. Эта панель доступна через меню клиентского терминала Сервис >> Глобальные переменные (клавиша F3):

Рис. 56. Состояние панели глобальных переменных клиентского терминала в момент, когда
в клиентском терминале было одновременно запущено три эксперта globalvar.mq4.

После того, как все эксперты были выгружены, на этой панели не осталось записей, свидетельствующих о наличии открытой глобальной переменной клиентского терминала.

Ошибки при использовании GV-переменных

Если запустить эксперт globalvar.mq4 в окнах нескольких финансовых инструментов и не торопясь последовательно отслеживать все события, то легко убедиться, что представленный код успешно работает. Однако это происходит только в том случае, если паузы между событиями достаточно большие. Обратите внимание на условие оператора if в функции deinit():

   if (Experts ==1)                             // Если эксперт один..

В данном случае анализируется значение глобальной переменной Experts, которая, вообще говоря, хотя и отражает значение глобальной переменной клиентского терминала, но имеет свойство устаревать (не будем забывать, что все программы в клиентском терминале работают в режиме реального времени). Чтобы разобраться, почему это происходит, рассмотрим следующую диаграмму:

Рис. 57. Выгрузка советника из окна EUR/USD до третьего тика.

На Рис. 57 представлено развитие событий, касающихся значения глобальной переменной клиентского терминала Quantity. Проследим, как будет изменяться это значение в зависимости от происходящих событий. Пусть запуск на исполнение эксперта в окне EUR/USD произошел в момент t 0. В этот момент GV-переменной Quantity ещё не существует. В период t 0 - t 1 исполняется специальная функция init() эксперта, в результате чего создаётся GV-переменная Quantity, значение которой в момент t 1 равно 1. Последующие тики по валютному инструменту EUR/USD запускают на исполнение специальную функцию start(). Однако в период t 0 - t 6 в клиентском остаётся всего один эксперт, поэтому значение значение GV-переменной Quantity не изменяется.

В момент t 6 в окно финансового инструмента GBP/USD присоединяется второй эксперт. В результате исполнения его функции init() значение GV-переменной Quantity изменяется и в момент t 7 становится равным 2. После этого в момент t 8 в окно USD/CHF присоединяется третий эксперт, в результате чего в момент t 9 значение GV-переменной Quantity становится равным 3.

В момент t 10 трейдер принимает решение о выгрузке советника из окна EUR/USD. Обратите внимание, последний раз переменная Experts в эксперте, работающем в этом окне, была изменена в период исполнения функции start(), запущенной на втором тике, т.е. в период t 4 - t 5. В момент t 10 значение переменной Experts в эксперте, работающем в окне EUR/USD, остаётся равным 1. Поэтому при исполнении специальной функции deinit() этого эксперта GV-переменная Quantity будет удалена в результате исполнения строк:

   if (Experts ==1)                             // Если эксперт один..
      GlobalVariableDel(Quantity);              //..удаляем GV-перемен

Таким образом, несмотря на то, что в клиентском терминале остаются подключёнными два эксперта, GV-переменная удалена! Нетрудно понять, какие последствия это событие будет иметь для расчётов в работающих экспертах. При исполнении функции start() в этих экспертах будет установлено, что текущее значение переменной New_Experts равно нулю, поэтому и новое текущее значение переменной Experts также обнулится. В результате окажется, что значение переменной Money вычислить не представляется возможным, т.к. в формуле, используемой для расчёта, переменная Experts стоит в знаменателе. Таким образом, дальнейшие расчёты в экспертах пойдут по ложному пути со всеми вытекающими последствиями.

Кроме того, при исполнении функции deinit() экспертов (при выгрузке из окон GBP/USD и USD/CHF) GV-переменная будет снова открыта, но получит значение -1 (минус единица) после выгрузки одного из них, и -2 при выгрузке последнего. Это приведёт к получению отрицательного значения переменной Money. Важным также является то, что после выгрузки всех экспертов GV-переменная Quantity останется открытой в клиентском терминале и в будущем окажет влияние на работу всех экспертов, интересующихся её значением.

Возможен и другой сценарий развития событий. На Рис. 58 показано как изменится значение GV-переменной в случае, если перед выгрузкой первого эксперта успеет случиться ещё один тик.

Рис. 58. Выгрузка советника из окна EUR/USD после третьего тика.

События, отраженные на Рис. 58, в период t 0 - t 9 полностью совпадают с событиями, отражёнными на Рис. 57. Согласно представленной диаграмме, в момент t 12 по финансовому инструменту EUR/USD поступает третий тик, в результате чего при исполнении специальной функции start() значение переменной Experts изменится и станет равным 3. Это значит, что при выгрузке эксперта из окна EUR/USD, в результате исполнения функции deinit() значение GV-переменной Quantity будет установлено равным 2, т.е. правильно отражающим количество экспертов, оставшихся в работе.

На основании этих рассуждений можно сделать вывод, что эксперт globalvar.mq4 составлен некорректно. Алгоритмическая ошибка в данном случае состоит в том, что для анализа ситуации в функции deinit() используется значение переменной Experts, не отражающей действительное количество одновременно работающих экспертов во всех без исключения случаях. Для случая, показанного на Рис. 58, значение переменной Experts оказывается справедливым, а для случая, представленного на Рис. 57, - нет. Таким образом, общий результат работы эксперта находится в зависимости от случайных событий, а именно, от последовательности прихода тиков по финансовым инструментам, с которыми работает эксперт.

В данном случае исправить ошибку просто. Достаточно обновить значение переменной Experts перед анализом (перед исполнением оператора if):

int deinit()                                    // Спец. ф-ия deinit
  {
   Experts = GlobalVariableGet(Quantity);       // Получим тек. знач.
   if (Experts ==1)                             // Если эксперт один..
      GlobalVariableDel(Quantity);              //..удаляем GV-перемен
   else                                         // А иначе..
      GlobalVariableSet(Quantity, Experts-1);   //..уменьшаем на 1
   Alert("Эксперт выгружен из окна ",Symbol()); // Сообщ. о выгрузке
   return;                                      // Выход из deinit()
  }

Подобные алгоритмические ошибки опасны тем, что они не всегда очевидны, и их бывает трудно обнаружить. Из этого вовсе не следует, что программисту нужно отказаться от использования GV-переменных. Однако, это значит, что код любой программы должен быть составлен корректно, с учётом всех событий, которые могут повлиять на работоспособность программы.

Использование глобальных переменных в практической работе оказывается очень полезным: например, можно передать информацию о критических событиях на другом финансовом инструменте (достижение ценой некоторого уровня, пробитие его и пр.), сообщить о факте подключения к клиентскому терминалу другого эксперта (с целью распределения полномочий), вести скоординированную торговлю одновременно по нескольким финансовым инструментам. Создать глобальную переменную клиентского терминала можно также из индикатора, вычисляющего некоторые важные события, а принимать во внимание значение такой переменной может любой работающий эксперт или скрипт.

Виды переменныхМассивы


Переменные - Учебник по MQL4

Учебник по MQL4 [image] Переменные
  • Предопределённые переменные и функция RefreshRates
  • Виды переменных
  • Переменные GlobalVariables
  • Массивы
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Переменные

Для составления программ на любом алгоритмическом языке очень важно знать свойства переменных различных типов и видов. В данном разделе рассматриваются все виды переменных, используемых в MQL4.

  • Предопределённые переменные и функция RefreshRates.
    В первую очередь необходимо познакомиться с предопределенными переменными. Имена предопределенных переменных зарезервированы и не могут использоваться пользователем для создания своих переменных. Именно предопределенные переменные несут основную информацию, необходимую для анализа текущей рыночной ситуации. Для обновления этой информации используется функция RefreshRates().
  • Виды переменных.
    Переменные играют значительную роль при написании программы. Они делятся на локальные и глобальные, внешние и внутренние. Статические переменные сохраняют свои значения между вызовами функций, это полезно для запоминания некоторых значений в локальных переменных, не прибегая к созданию глобальных переменных.
  • Переменные GlobalVariable.
    Кроме глобальных переменных на уровне отдельно взятой программы, значения которых доступны из любого места этой программы, существуют глобальные переменные на уровне терминала. Эти глобальные переменные называются GlobalVariables и позволяют наладить взаимодействия между независимыми программами на языке MQL4. С их помощью можно передавать значения между скриптами, индикаторами и советниками. При выключении терминала значения GlobalVariables также сохраняются, чтобы быть доступными при новом запуске MetaTrader 4. Необходимо помнить, что если к глобальной переменной не было обращения в течение 4 недель, то она уничтожается.
  • Массивы.
    Если Вам необходимо хранить или обрабатывать большие объемы значений одного типа, то тут без массивов не обойтись. Прежде чем использовать массив, его, как и переменную, необходимо объявить. Обращения к элементам массива происходит через указание индекса(ов) элемента, при этом индексация массивов начинается с нуля. Количество измерений массива называется его размерностью. Допускаются не более чем четрырехмерные массивы. Всегда явно инициализируйте значения массивов, чтобы не делать ошибок, которые потом очень трудно обнаружить.

Описание функции и оператор returnПредопределённые переменные и функция RefreshRates


Предопределённые переменные и функция RefreshRates - Переменные - Учебник по MQL4

Учебник по MQL4 [image] Переменные [image] Предопределённые переменные и функция RefreshRates
MetaQuotes Sofware Corp.
  • Предопределённые переменные и функция RefreshRates
  • Виды переменных
  • Переменные GlobalVariables
  • Массивы
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Предопределённые переменные и функция RefreshRates

В языке MQL4 существуют переменные с предопределёнными именами.

Предопределённая переменная - это переменная с предопределённым названием, значение которой определяется клиентским терминалом и не может быть изменено программным способом. Предопределённые переменные отражают состояние текущего ценового графика на момент запуска программы (эксперта, скрипта или пользовательского индикатора) или в результате исполнения функции RefreshRates().

Перечень простых предопределённых имён переменных

Ask- последняя известная цена продажи по текущему финансовому инструменту;

Bid- последняя известная цена покупки по текущему финансовому инструменту;

Bars - количество баров на текущем графике;

Point - размер пункта текущего финансового инструмента в валюте котировки;

Digits - количество цифр после десятичной точки в цене текущего финансового инструмента.

Перечень предопределённых имён массивов-таймсерий

Time - время открытия каждого бара текущего графика;

Open - цена открытия каждого бара текущего графика;

Close - цена закрытия каждого бара текущего графика;

High - максимальная цена каждого бара текущего графика;

Low - минимальная цена каждого бара текущего графика;

Volume - тиковый объем каждого бара текущего графика.

(понятия "массив" и "массив-таймсерия" рассматриваются в разделе Массивы).

Свойства предопределённых переменных

Название предопределённой переменной не может быть использовано для идентификации пользовательской переменной. Предопределённые переменные могут использоваться в выражениях наравне с другими переменными по тем же правилам, но изменить значение предопределённой переменной нельзя. При попытке компилировать программу, содержащую оператор присваивания, в котором слева от знака равенства указана предопределённая переменная, редактор MetaEditor выдаст сообщение об ошибке. По области видимости предопределённые переменные относятся к глобальным, т.е. доступны из любой части программы (см. Виды переменных).

Наиболее важное свойство предопределённых переменных заключается в следующем:

Значения всех предопределённых переменных автоматически обновляются клиентским терминалом в момент запуска на исполнение специальных функций.

Предыдущее и текущее значения предопределённых переменных могут совпадать, но само значение будет обновлённым. В момент запуска специальной функции значения этих переменных уже обновлены и доступны с первых строк программы. Проиллюстрируем обновление значений предопределённых переменных на следующем примере (эксперт predefined.mq4 ):

//--------------------------------------------------------------------
// predefined.mq4
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------------
int start()                                     // Спец. функция start
  {
   Alert("Bid = ", Bid);                        // Текущий курс
   return;                                      // Выход из start()
  }
//--------------------------------------------------------------------

Запустив эту простую программу на выполнение легко убедиться, что значения переменной Bid, отражаемые в сообщениях, всякий раз будут соответствовать значениям текущего курса. Аналогичным способом можно проверить и значения других переменных, зависящих от сложившихся условий. Например, переменная Ask также прямо зависит от текущего курса. Значение переменной Bars тоже изменится, если изменится количество баров. Это может произойти на том тике, на котором в окне текущего финансового инструмента образуется новый бар. Значение Point зависит от спецификации финансового инструмента. Например, для валютной пары EUR/USD это значение равно 0.0001, а для валютной пары USD/JPY - равно 0.01. Значение Digits для тех же валютных инструментов равно соответственно целым числам 4 и 2.

Другим важным свойством предопределённых переменных является следующее:

Клиентский терминал создаёт набор локальных копий предопределённых переменных отдельно для каждой запущенной программы. Каждая запущенная программа работают с собственным набором копий исторических данных.

В одном клиентском терминале может быть одновременно запущено несколько прикладных программ(экспертов, скриптов или индикаторов), и для каждой из них клиентский терминал создаст свой набор копий значений всех предопределённых переменных - исторических данных. Рассмотрим более подробно, чем вызвана такая необходимость. На Рис. 52 показано, как будут работать эксперты, характеризующиеся разной длительностью исполнения специальной функции start(). Для простоты положим, что в рассматриваемых экспертах других специальных функций нет, и оба эксперта работают в одинаковых таймфреймах одного и того же финансового инструмента.

Рис. 52. Время работы функции start() может быть больше или меньше интервала времени между тиками.

Эксперты отличаются друг от друга временем исполнения специальной функции start(). Для обычных экспертов средней сложности это время составляет приблизительно от 1 до 100 миллисекунд. Другие эксперты могут исполняться значительно дольше, например, несколько секунд или даже десятков секунд. Промежуток времени между тиками также колеблется от миллисекунд до минут, а в редких случаях - нескольких десятков минут. Проследим на представленном примере, как повлияет частота поступления тиков на работу экспертов Эксперт 1 и Эксперт 2, имеющих различное время исполнения специальной функции start().

В момент времени t 0 Эксперт 1 присоединяется к клиентскому терминалу и переходит в режим ожидания тика. В момент t 1 поступает тик, в результате чего клиентский терминал запускает на исполнение специальную функцию start(). Одновременно с этим событием программа получает доступ к обновлённому набору копий значений предопределённых переменных. В период исполнения программа может обращаться к этим значениям, они будут оставаться неизменными в течение всего времени работы специальной функции start(). По окончании исполнения специальной функции start() программа перейдёт в режим ожидания нового тика.

Ближайшим событием, при котором предопределённые переменные могут получить новые значения, является новый тик. Время исполнения Т1 специальной функции start() Эксперта 1 значительно меньше, чем ожидаемое время между тиками, например, промежуток времени t 1 - t 2 или t 2 - t 3 и т.д. В связи с этим в рассматриваемом периоде исполнении Эксперта 1 не возникает ситуация, при которой значения предопределённых переменных могли бы устареть, т.е. не соответствовать истинным (последним известным) значениям на текущий момент.

В работе Эксперта 2 наблюдается иная ситуация, потому что период исполнения Т2 его специальной функции start() в некоторых случаях превышает период времени между тиками. Функция start() Эксперта 2 также запускается в момент t 1. На Рис. 52 показано, что интервал времени меду тиками t 1 - t 2 больше, чем время Т2 исполнения функции start(), поэтому в этот период работы программы обновление предопределённых переменных не происходит (т.е. в этот период новые значения переменных с сервера не поступают, поэтому их истинными значениями следует считать те, которые появились в момент t 1).

В следующий раз функция start() Эксперта 2 запускается на исполнение в момент t 2, в результате прихода второго тика. Одновременно с этим обновляются и значения набора копий предопределённых переменных. На Рис. 52 показано, что момент прихода третьего тика t 3 приходится на тот период, когда специальная функция start() ещё не закончила свою работу (т.е. исполняется). Возникает естественный вопрос: каковыми будут значения предопределённых переменных, доступные Эксперту 2, в период с момента t 3 прихода третьего тика до момента t 32 окончания работы специальной функции start()? Ответ на этот вопрос можно получить согласно следующему правилу:

Значения копий предопределённых переменных сохраняются в течение всего периода работы специальных функций. Эти значения могут быть принудительно обновлены с помощью стандартной функции RefreshRates().

Таким образом (если не была исполнена функция RefreshRates()), в течение всего периода исполнения специальной функции start() Эксперту 2 будут доступны значения того локального набора копий предопределённых переменных, который был сформирован в момент поступления второго тика. Несмотря на то, что эксперты работают в одинаковых окнах, начиная с момента прихода третьего тика t 3, каждый из экспертов будет работать с разными значениями предопределённых переменных. Эксперт 1 будет работать со своей локальной копией набора исторических данных, значения которых определены в момент t 3, а Эксперт 2 будет работать со своей копией данных, значения которых соответствуют моменту t 2.

Чем больше время исполнения прикладной программы и меньше промежуток между тиками, тем больше вероятность того, что очередной тик придётся на период, когда программа исполняется. С помощью набора локальных копий исторических данных для каждой программы создаются условия, гарантирующие неизменность предопределённых переменных в течение всего времени исполнения специальных функций.

Начиная с момента t 4, когда придёт очередной тик, оба эксперта снова будут запущены в работу, при этом каждый из них будет иметь доступ к своей копии предопределённых переменных, значения которых сформированы в момент t 4 прихода четвёртого тика.

Функция RefreshRates()

bool RefreshRates()

Стандартная функция RefreshRates() позволяет обновить значения локальной копии исторических данных. Другими словами, эта функция принудительно обновляет данные о текущем рыночном окружении (объем Volume, серверное время последней котировки Time[0], цены Bid, Ask и т.д.). Эта функция может использоваться, когда программа производит вычисления в течение длительного времени и нуждается в обновленных данных.

Функция RefreshRates() возвращает TRUE, если на момент её исполнения в клиентском терминале имеются сведения о новых значениях исторических данных (т.е. если в период исполнения специальной функции приходил новый тик). В этом случае значения набора локальных копий предопределённых переменных будут обновлены.

Функция RefreshRates() возвращает FALSE, если с момента начала исполнения специальной функции исторические данные в клиентском терминале не обновлялись. В этом случае текущие значения набора локальных копий предопределённых переменных не изменяются.

Обратите внимание, действие функции RefreshRates() распространяется только на ту программу, в которой она запущена (а не на все программы, одновременно работающие в клиентском терминале).

Проиллюстрируем исполнение функции RefreshRates() на примере.

Задача 21. Посчитать сколько итераций может выполнить оператор цикла в период между тиками (для ближайших пяти тиков).

Решить эту задачу возможно только с использованием функции RefreshRates() (скрипт countiter.mq4 ):

//--------------------------------------------------------------------
// countiter.mq4
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------------
int start()                                  // Спец. функция start()
  {
   int i, Count;                             // Объявление переменных
   for (i=1; i<=5; i++)                      // Покажем для 5 тиков
     {
      Count=0;                               // Сброс счётчика
      while(RefreshRates()==false)           // До тех пор, пока..
        {                                   //..придёт новый тик
         Count = Count+1;                    // Счётчик итераций
        }
      Alert("Тик ",i,", циклов ",Count);     // После каждого тика
     }
   return;                                   // Выход из start()
  }
//--------------------------------------------------------------------

По условию задачи необходимо сделать вычисления только для ближайших пяти тиков, поэтому для решения можно использовать скрипт. В программе используются две переменные: i - для подсчёта количества тиков и Count - для подсчёта итераций. Внешний цикл for организован по количеству обрабатываемых тиков (от 1 до 5). В начале каждого цикла for обнуляется счётчик количества итераций (выполняемых в цикле while), а в конце - выдаётся сообщение с номером тика и соответствующим ему количеством итераций.

Внутренний цикл while будет работать до тех пор, пока значение, возвращаемое функцией RefreshRates(), равно false, т.е. до тех пор, пока нового тика нет. В течение времени работы цикла while (т.е. в период между тиками) значение переменной Count будет постоянно увеличиваться, таким образом, будет производиться подсчёт искомого количества итераций в цикле while. Если в момент проверки условия в операторе цикла while значение, возвращаемое функцией RefreshRates(), окажется равным true, то это будет означать, что в клиентском терминале имеются новые значения предопределённых переменных, т.е. пришёл новый тик. В результате этого управление передаётся за пределы цикла while и подсчёт итераций, таким образом, прекращается.

В результате исполнения скрипта countiter.mq4 в окне финансового инструмента может быть получен ряд сообщений, характеризующих быстродействие языка MQL4:

Рис. 53. Результат работы скрипта countiter.mq4 в окне EUR/USD.

Легко увидеть, что за 1 секунду (продолжительность между третьим и четвёртым тиками) скрипт совершил более 400 тысяч итераций. Аналогичный результат можно получить путём простого расчёта и для других тиков.

Вернёмся к предыдущему примеру (эксперт predefined.mq4). Ранее было показано, что если в Эксперте 2 не исполняется функция RefreshRates(), то значения локальных копий предопределённых переменных будут оставаться неизменными в течение всего времени исполнения специальной функции start(), т.е., например, в течение периода t 2 - t 32. Если же после третьего тика (приходящегося на период исполнения специальной функции start()) в Эксперте 2 исполнить функцию RefreshRates(), например, в момент t 31, то значения локальных копий предопределённых переменных будут обновлены. Поэтому оставшееся время, начиная с момента t 31 исполнения функции RefreshRates() до момента t 32 окончания исполнения специальной функции start(), Эксперту 2 будут доступны новые значения локальных копий предопределённых переменных, соответствующие тем значениям, которые определены клиентским терминалом в момент t 3 прихода третьего тика.

Если же в Эксперте 2 функцию RefreshRates() исполнить в момент t 11 или t 21 (т.е. в период, когда последний известный тик - это тот, который запустил на исполнение специальную функцию start()), то это не приведёт к изменению значений локальных копий предопределённых переменных. В этих случаях текущие значения локальных копий предопределённых переменных будут соответствовать последним известным, а именно тем, которые были определены клиентским терминалом на момент последнего запуска специальной функции start().

ПеременныеВиды переменных


Виды переменных - Переменные - Учебник по MQL4

Учебник по MQL4 [image] Переменные [image] Виды переменных
  • Предопределённые переменные и функция RefreshRates
  • Виды переменных
  • Переменные GlobalVariables
  • Массивы
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Виды переменных

Прикладная программа на языке MQL4 может содержать десятки и сотни переменных. Очень важным свойством любой переменной является возможность использовать в программе её значение. Ограничение такой возможности непосредственно связано с областью видимости переменных.

Область видимости переменной - место в программе, в котором доступно значение переменной. Каждая переменная имеет свою область видимости. По области видимости в языке MQL4 различают два вида переменных: локальные и глобальные.

Локальные и глобальные переменные

Локальная переменная - переменная, объявленная внутри какой-либо функции. Областью видимости локальных переменных является тело функции, в которой эта переменная объявлена. Локальная переменная может быть проинициализирована константой или выражением, соответствующими ее типу.

Глобальная переменная - переменная, объявленная за пределами всех функций. Областью видимости глобальных переменных является вся программа. Глобальная переменная не локализована ни на каком уровне. Глобальная переменная может быть проинициализирована только соответствующей ее типу константой (но не выражением). Инициализация глобальных переменных производится однократно перед началом исполнения специальных функций.

Если управление в программе находится внутри какой-либо функции, то значения локальных переменных, объявленных в другой функции не доступны. Значение любой глобальной переменной доступно из любой специальной и пользовательской функции. Рассмотрим простой пример.

Задача 22. Составить программу, считающую тики.

Алгоритм решения Задачи 22, использующий глобальную переменную (countticks.mq4):

//--------------------------------------------------------------------
// countticks.mq4
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------------
int Tick;                              // Глобальная переменная
//--------------------------------------------------------------------
int start()                            // Специальная функция start()
  {
   Tick++;                             // Счётчик тиков
   Comment("Поступил тик № ",Tick);    // Сообщение, содержащее номер
   return;                             // Оператор выхода из start()
  }
//--------------------------------------------------------------------

В этой программе используется всего одна глобальная переменная Tick. Она является глобальной, т.к. объявлена за пределами описания функции start(). Это значит, что от тика к тику значение этой переменной будет сохраняться. Рассмотрим подробности исполнения программы.

В разделе Специальные функции мы рассматривали критерии, при которых запускаются на исполнение специальные функции. Кратко напомним, что специальная функция start() в экспертах запускается на выполнение клиентским терминалом в момент поступления очередного тика. В момент присоединения эксперта к окну финансового инструмента произойдут следующие события:

1. Объявление глобальной переменной Tick. Эта переменная не проинициализирована константой, поэтому её значение на этом этапе равно нулю.

2. Управление удерживается в клиентском терминале до поступления тика.

3. Поступил тик. Управление передаётся специальной функции start().

3.1. В рамках исполнения специальной функции start() управление передаётся оператору:

   Tick++;                             // Счётчик тиков

В результате исполнения этого оператора значение переменной Tick увеличится на 1 (целую единицу).

3.2. Управление передаётся оператору:

   Comment("Поступил тик № ",Tick);    // Сообщение, содержащее номер

Исполнение стандартной функции Comment() приведёт к появлению сообщения:

Поступил тик № 1

3.3. Управление передаётся оператору:

   return;                             // Оператор выхода из start()

В результате его исполнения специальная функция start() заканчивает свою работу, управление передаётся клиентскому терминалу. При этом глобальная переменная продолжает своё существование, её значение сохраняется равным 1.

Далее события будут повторяться, начиная с пункта 2. Переменная Tick снова будет участвовать в вычислениях, однако на втором тике, в момент запуска на исполнение функции start(), её значение равно 1, поэтому результатом исполнения оператора:

   Tick++;                             // Счётчик тиков

будет новое значение переменной Tick - оно увеличится на 1 и теперь будет равно 2, поэтому исполнение функции Comment() приведёт к появлению сообщения:

Поступил тик № 2

Таким образом, значение переменной Tick будет увеличиваться на 1 при каждом запуске специальной функции start(), т.е. на каждом тике. Решение подобных задач становится возможным только в случае использования переменных, сохраняющих своё значение после выхода из функции (в данном случае использована глобальная переменная). Использовать для той же цели локальные переменные бессмысленно: локальная переменная теряет своё значение по окончании исполнения функции, в которой она объявлена.

В этом очень легко убедиться, запустив на выполнение эксперт, в котором переменная Tick открыта как локальная переменная (т.е. программа содержит алгоритмическую ошибку):

int start()                           // Специальная функция start()
  {
   int Tick;                          // Локальная переменная
   Tick++;                            // Счётчик тиков
   Comment("Поступил тик № ",Tick);   // Сообщение, содержащее номер
   return;                            // Оператор выхода из start()
  }

С точки зрения синтаксиса в представленном коде ошибок нет. Эта программа может быть успешно скомпилирована и запущена на исполнение. И она будет работать, однако всё время будет сообщать один и тот же результат:

Поступил тик № 1

И это вполне естественно, потому что переменная Tick будет инициализирована нолём в начале исполнения специальной функции start() при каждом её запуске. Последующее увеличение этого значения на единицу будет приводить лишь к тому, что к моменту сообщения значение Tick всякий раз будет равно 1.

Статические переменные

На физическом уровне локальные переменные представлены во временной области памяти соответствующей функции. Существует способ расположить переменную, объявленную внутри функции, в постоянной памяти программы. Для этого при объявлении переменной перед типом переменной необходимо указать модификатор static:

   static int Number;           // Статическая переменная целого типа

Ниже представлено решение задачи 22 с использованием статической переменной (эксперт staticvar.mq4):

//--------------------------------------------------------------------
// staticvar.mq4
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------------
int start()                            // Специальная функция start()
  {
   static int Tick;                    // Статическая локальная перем
   Tick++;                             // Счётчик тиков
   Comment("Поступил тик № ",Tick);    // Сообщение, содержащее номер
   return;                             // Оператор выхода из start()
  }
//--------------------------------------------------------------------

Статические переменные инициализируются однократно. Каждая статическая переменная может быть проинициализирована соответствующей ее типу константой (в отличие от простой локальной переменной, которая может быть проинициализирована любым выражением). Если явной инициализации нет, то статическая переменная инициализируется нулем. Статические переменные хранятся в постоянной области памяти программы, их значения не теряются при выходе из функции. Вместе с тем, статические переменные имеют ограничение, свойственное локальным переменным - областью видимости статической переменной остаётся функция, внутри которой эта переменная объявлена, в отличие от глобальных переменных, значение которых доступно из любого места программы. Легко увидеть, что программы countticks.mq4 и staticvar.mq4 дают одинаковый результат.

Все массивы являются статическими изначально, т.е. имеют вид static, даже если при инициализации это явно не указано (см. Массивы).

Внешние переменные

Внешняя переменная - это переменная, значение которой доступно из окна свойств программы. Внешняя переменная объявляется за пределами всех функций и является глобальной, область её видимости - вся программа. При объявлении внешней переменной перед типом её значения необходимо указать модификатор extern:

   extern int Number;                          // Внешняя переменная целого типа

Внешние переменные указываются в головной части программы, а именно перед любой функцией, в которой имеется обращение к внешней переменной. Использование внешних переменных очень удобно, если время от времени возникает необходимость запустить программу на выполнение с иными значениями переменных.

Задача 23. Составить программу, в которой реализуются следующие условия: если цена достигла некоторого уровня Level и опустилась ниже этого уровня на n пунктов, то один раз сообщить об этом факте трейдеру.

Понятно, что поставленная задача предполагает необходимость изменения настроек, ведь сегодня цены уже не такие, как вчера, а завтра будут не такими, как сегодня. Чтобы обеспечить возможность изменения настроек в эксперте externvar.mq4 использованы внешние переменные:

//--------------------------------------------------------------------
// externvar.mq4
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------------
extern double Level = 1.2500;                   // Внешняя переменная
extern int        n = 5;                        // Внешняя переменная
       bool  Fact_1 = false;                    // Глобальная перемен.
       bool  Fact_2 = false;                    // Глобальная перемен.
//--------------------------------------------------------------------
int start()                                     // Спец. функция start
  {
   double Price = Bid;                          // Локальная перемен.
   if (Fact_2==true)                            //Если сообщение уже..
      return;                                   //..было, то выходим

   if (NormalizeDouble(Price,Digits) >= NormalizeDouble(Level,Digits))
      Fact_1 = true;                            // Произошло событие 1

   if (Fact_1 == true && NormalizeDouble(Price,Digits)<=
                         NormalizeDouble(Level-n*Point,Digits))
      My_Alert();                               // Вызов польз. ф-ии

   return;                                      // Выход из start()
  }
//--------------------------------------------------------------------
void My_Alert()                                 // Пользовательс. ф-ия
  {
   Alert("Условия достигнуты");                 // Сообщение
   Fact_2 = true;                               // Произошло событие 2
   return;                                      // Выход из польз.ф-ии
  }
//--------------------------------------------------------------------

В этой программе внешние переменные заданы в строках:

extern double Level = 1.2500;                   // Внешняя переменная
extern int        n = 1;                        // Внешняя переменная

Значения внешних переменных доступны из окна свойств программы. Ценность этих переменных состоит в том, что их можно изменить в любой момент - и на этапе присоединения программы в окно финансового инструмента и в процессе работы программы.

Рис. 54. Окно свойств программы; здесь можно изменить значения переменных.

В момент присоединения программы к окну финансового инструмента в окне настроек будут указаны те значения переменных, которые указаны в коде программы. Пользователь может по своему усмотрению изменить эти значения. С момента, когда пользователь нажал кнопку ОК на панели настроек, программа будет запущена клиентским терминалом на исполнение. При этом начальные значения внешних переменных будут такими, какими они были указаны пользователем. В процессе работы программы значения этих переменных могут быть изменены выполняющейся программой.

Если у пользователя возникла необходимость поменять значения внешних переменных в процессе работы программы, то необходимо открыть окно настроек и внести изменения. Очень важно помнить, что панель свойств программы может быть вызвана на экран только в период, когда программа (эксперт или индикатор) находится в состоянии ожидания нового тика, т.е. ни одна из специальных функций не исполняется. В течение времени исполнения программы панель её свойств вызвана быть не может. Поэтому, если программа составлена таким образом, что выполняется долго (несколько секунд или десятков секунд), то у пользователя могут возникнуть затруднения с доступом к окну свойств программы. Значения внешних переменных скрипта доступны только в момент его присоединения к окну финансового инструмента, но в процессе работы не могут быть изменены. Если окно свойств программы открыто, то эксперт не работает - управление удерживается клиентским терминалом и не передаётся программе для запуска специальных функций.

Обратите внимание, в период, когда открыто окно свойств эксперта и пользователь принимает решение о значениях внешних переменных, эксперт (или индикатор) не работает. Установив значения внешних переменных и нажав ОК на панели настроек программы, пользователь заново запускает её в работу.

При этом клиентский терминал последовательно запускает на исполнение специальную функцию deinit(), потом специальную функцию init(), а после этого, в момент поступления нового тика, запускает на исполнение специальную функцию start(). При исполнении функции deinit(), завершающей программу, внешние переменные будут иметь значения, полученные в предыдущем сеансе, т.е. те, которые были у них до открытия панели настроек эксперта. Перед исполнением специальной функции init() внешние переменные получат значения, установленные пользователем на панели настроек эксперта, и при исполнении функции init() внешние переменные будут иметь уже новые, установленные пользователем значения. Таким образом, новые значения внешних переменных вступают в силу с момента нового сеанса (init - start - deinit) работы эксперта, начинающегося с исполнения init().

Факт открытия окна настроек эксперта на значения глобальных переменных не влияет. В течение всего времени, пока открыто окно настроек, и после его закрытия, глобальные переменные сохраняют свои значения, имеющиеся на момент, предшествующий открытию панели настроек эксперта.

В программе externvar.mq4 используются также две глобальные и одна локальная переменные.

       bool  Fact_1 = false;                    // Глобальная перемен.
       bool  Fact_2 = false;                    // Глобальная перемен.
   double Price = Bid;                          // Локальная перемен.

Алгоритмически решение задачи выглядит так. Идентифицируются два события: первое - факт достижения ценой уровня Level, второе - факт того, что сообщение (о снижении ниже уровня Level на n пунктов) уже выдано. Эти события находят своё отражение в значениях переменных Fact_1 и Fact_2: если событие ещё не свершилось, то значение соответствующей переменной равно false, а если свершилось - true. В строках:

   if (NormalizeDouble(Price,Digits) >= NormalizeDouble(Level,Digits))
      Fact_1 = true;                            // Произошло событие 1

определяется факт свершения первого события. Стандартная функция NormalizeDouble() позволяет производить вычисления со значениями действительных переменных с заданной точностью (соответствующей точности цены финансового инструмента). Если цена оказалась равной или выше заданного уровня, то факт первого события считается свершившимся, поэтому глобальной переменной Fact_1 присваивается значение истина. Программа составлена так, что переменная Fact_1, получив однажды значение истина, никогда не изменит его на ложь - для этого в программе нет соответствующего кода.

В строках:

   if (Fact_1 == true && NormalizeDouble(Price,Digits)<=
                         NormalizeDouble(Level-n*Point,Digits))
      My_Alert();                               // Вызов польз. ф-ии

определяется необходимость выдачи сообщения. Если уже свершилось первое событие и цена опустилась на n пунктов ниже (меньше или равно) заданного уровня, то необходимо выдать сообщение - осуществляется вызов на исполнение пользовательской функции My_Alert(). В пользовательской функции, после собственно сообщения, отмечается факт того, что сообщение уже выдано, путём присвоения глобальной переменной Fact_2 значения true. После этого заканчивает работу пользовательская функция и вслед за ней и специальная функция start().

После того, как переменная Fact_2 получает значение истина, программа всякий раз будет завешать свою работу, поэтому сообщение, однажды сделанное, больше никогда в течение этого сеанса работы программы не повторится:

   if (Fact_2==true)                            //Если сообщение уже..
      return;                                   //..было, то выходим

Показательным в этой программе является то, что значения глобальных переменных могут быть изменены в любом месте (и в специальной функции и в пользовательской) и сохраняются в течение всего периода работы программы - в период между тиками, после изменения значений внешних переменных или в результате переключения таймфрейма.

В общем случае значения глобальных переменных могут быть изменены в любой специальной функции. Поэтому нужно быть особенно внимательным, указывая операторы, изменяющие значения глобальных переменных в функциях init() и deinit(). Например, если в функции init() обнулить значение глобальной переменной, то при первом исполнении функции start() значение этой переменной будет нулевым, т.е. значение этой переменной, достигнутое в период предыдущего исполнения start(), будет потеряно (т.е. после изменения внешних настроек программы).

Предопределённые переменные и функция RefreshRatesПеременные GlobalVariables


Программирование на MQL4 - Учебник по MQL4

Учебник по MQL4 [image] Программирование на MQL4
  • Предисловие
  • Содержание
  • Введение в MQL4
  • Основы языка
  • Редактор MetaEditor
  • Программа на MQL4
  • Операторы
  • Переменные
  • Программирование на MQL4
  • Торговые операции
  • Простые программы на MQL4
  • Стандартные функции
  • Создание обычной программы
  • О сложных программах
  • Приложения
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Практическое программирование на языке MQL4

Во второй части рассматриваются: порядок проведения торговых операций, принципы построения и использования простых скриптов, экспертов и индикаторов, а также стандартные функции, часто используемые при составлении программ. Все разделы содержат примеры программ, готовых к использованию, но имеющих ограниченную область применения.

В разделе "Построение обычных программ" представлен пример программы, который может быть принят за основу при проектировании собственного обычного эксперта для использования в реальной торговле.

Все приведенные торговые критерии используются в учебных целях и не должны рассматриваться как руководство к действию при торговле на реальном счёте.

  • Программирование торговых операций

При программировании торговых операций необходимо учитывать требования и ограничения, связанные с характеристиками ордеров и правилами, принятыми в дилинговом центре, а также особенности технологии исполнения торговых приказов. В разделе подробно рассматривается порядок проведения торговых операций и приводится достаточно примеров, поясняющих назначение всех торговых функций, с помощью которых формируются различные торговые приказы. Представлено несколько готовых к использованию скриптов, ориентированных на узкую область применения.

  • Простые программы на MQL4

После того как программист овладеет навыками программирования торговых операций, он может приступать к созданию простых программ. В разделе рассматриваются общие принципы построения простого эксперта и простого пользовательского индикатора, а также порядок совместного использования эксперта и различных индикаторов. В частности, описывается порядок передачи данных из пользовательского индикатора в эксперт. Приводятся несколько примеров простых программ, готовых для практического использования.

  • Стандартные функции

Всего в языке MQL4 насчитывается более 220 стандартных функций, кроме функций технических индикаторов. Представить в учебнике описание и пример использования для каждой из них затруднительно ввиду их большого количества. Некоторые функции, требующие подробных пояснений, рассмотрены в предыдущих разделах. В данном разделе рассматриваются наиболее употребляемые стандартные функции, приводятся примеры их использования. В конце каждого параграфа указан полный список функций определённой категории и их краткое описание.

  • Построение обычных программ

Как правило, после самостоятельного программирования нескольких простых прикладных программ на MQL4, программист переходит к более сложному проекту - созданию удобной программы для практического использования. Простые программы в ряде случаев не удовлетворяют потребностям трейдера-программиста по крайней мере по двум причинам:

1. Функциональная ограниченность простых программ не позволяет в полной мере обеспечить трейдера необходимой информацией и средствами управления торговлей, что делает их применение недостаточно эффективным.

2. Несовершенство кода простых программ затрудняет возможность дальнейшего их наращивания с целью получения большего сервиса.

В данном разделе представлен один из возможных вариантов реализации торгующего эксперта, который может рассматриваться как основа для создания собственного проекта.

МассивыТорговые операции


Общий порядок проведения торговых операций - Торговые операции - Учебник по MQL4

Учебник по MQL4 [image] Торговые операции [image] Общий порядок проведения торговых операций
MetaQuotes Sofware Corp.
  • Общий порядок проведения торговых операций
  • Характеристики ордеров и правила проведения торговых операций
  • Открытие и установка ордеров
  • Закрытие и удаление ордеров
  • Модификация ордеров
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Общий порядок проведения торговых операций

Все вычисления и различные действия, осуществляемые в связи с выполнением прикладной программы, по месту их исполнения можно разделить на две группы: исполняемые внутри компьютера пользователя и исполняемые на сервере. Значительная часть вычислений производится на компьютере пользователя. К этой группе относится исполнение прикладных программ. Торговые операции относятся ко второй группе. Осуществление торговых операций предполагает обязательное преобразование информации на сервере.

Рассматривая торговые операции, мы будем различать следующие понятия:

Рыночный ордер - исполненный торговый приказ на покупку или продажу активов по финансовому инструменту. Рыночный ордер отображается в окне финансового инструмента до тех пор, пока не выполнен приказ на закрытие ордера.

Отложенный ордер - торговый приказ на покупку или продажу активов по финансовому инструменту при достижении заданного значения цены. Отложенный ордер отражается в окне финансового инструмента до тех пор, пока он не преобразуется в рыночный ордер либо будет удалён.

Торговый приказ - приказ, сформированный программой или трейдером с целью осуществления торговой операции.

Торговая операция - открытие, закрытие или модификации рыночных и отложенных ордеров.

Схема проведения торговых операций

В проведении торговых операций принимают участие три составляющих - прикладная программа, клиентский терминал и сервер (см. рис. 65). В программе формируется торговый приказ (ранее уже было указано, что любые прикладные программы могут исполняться только в компьютере трейдера; никакие прикладные программы не устанавливаются на сервере). Торговый приказ, сформированный программой, передаётся клиентскому терминалу, который, в свою очередь, отправляет приказ на сервер. На сервере принимается решение об исполнении или отклонении торгового приказа. Информация о фактически полученных результатах сообщается сервером в клиентский терминал и далее в программу.

Рис. 65. Схема передачи торговых приказов при проведении торговых операций.

Формирование торговых приказов

Торговый приказ может быть сформирован трейдером или программой. Для создания торговых приказов по инициативе трейдера в составе клиентского терминала имеется панель управления ордерами (см. описание клиентского терминала). Формирование торговых приказов в программе происходит в соответствии с алгоритмом в результате исполнения торговых функций. Нигде в других местах (ни в клиентском терминале, ни на сервере) торговые приказы самопроизвольно не формируются.

Свойства программы

В зависимости от исполняемого алгоритма программа может формировать различные торговые приказы - приказы на открытие, закрытие или модификацию рыночных и отложенных ордеров. Для формирования торговых приказов в программе используются следующие торговые функции:

  • OrderSend() - для открытия рыночных и отложенных ордеров;
  • OrderClose() и OrderCloseBy() - для закрытия рыночных ордеров;
  • OrderDelete() - для удаления отложенных ордеров;
  • OrderModify()- для модификации рыночных и отложенных ордеров.

Указанные торговые функции могут использоваться только в экспертах и скриптах; использование этих функций в индикаторах запрещено (см. также Таблицу 2). Существуют и другие функции, относящиеся к торговым (см. справку в редакторе MetaEditor и раздел Торговые функции), однако их исполнение связано с обращением к информационной среде клиентского терминала с целью получения справочной информации и не приводит к формированию торговых приказов и обращению к серверу.

Свойства клиентского терминала

Торговый приказ, сформированный программой в результате исполнения торговой функции, передаётся для обработки в клиентский терминал. Клиентский терминал анализирует содержание торгового приказа и выполняет одно из двух действий: либо отправляет приказ на сервер с целью его исполнения на сервере, либо отклоняет приказ и ничего не отправляет на сервер.

Клиентский терминал позволяет отправлять на сервер только корректные торговые приказы. Если программа составлена таким образом, что формирует, например, приказ на открытие ордера по несуществующей цене, то клиентский терминал не отправит этот торговый приказ на сервер. Если же программа формирует корректный торговый приказ (открытие и закрытие ордеров по последней известной цене, стоимость ордеров находится в пределах ограничений дилингового центра и т.д.), то такой приказ будет отправлен на сервер.

Для осуществления торговых операций в клиентском терминале предусмотрен всего один поток. Это значит, что клиентский терминал может работать одновременно только с одним торговым приказом. Если в клиентском терминале запущено несколько торгующих экспертов или скриптов и при этом один из них передал клиентскому терминалу торговый приказ, то торговые приказы остальных экспертов и скриптов будут отклоняться до тех пор, пока клиентский терминал не закончит работу с текущим торговым приказом, то есть пока не освободится торговый поток.

Свойства сервера

Информация об истории торговли по каждому счёту (открытие, закрытие и модификация ордеров) в обязательном порядке строго учитывается на сервере и имеет более высокий приоритет в сравнении с торговой историей, хранящейся в клиентском терминале. Правом исполнения торговых приказов обладает только сотрудник дилингового центра или сервер, работающий в автоматическом режиме (если сотрудник дилингового центра на некоторое время передаст серверу соответствующие полномочия). Торговый приказ, поступивший на сервер, может быть исполнен либо отклонён. В случае, если торговый приказ исполнен (т.е. фактически проведена торговая операция), то на сервере выполняется необходимое преобразование информации. Если же торговый приказ отклонён, то преобразование информации на сервере не происходит. Независимо от того, какое именно решение (исполнить или отклонить приказ) принято на сервере, информация об этом будет передана клиентскому терминалу для синхронизации торговой истории.

Торговый приказ, сформированный в результате работы программы, и торговый приказ, сформированный трейдером вручную, с точки зрения сервера выглядят одинаковыми, поэтому на сервере не делается никаких различий при обработке торговых приказов.

На сервере также имеется возможность запретить торговать советникам в клиентском терминале. Это бывает необходимо, если в результате работы программы создаётся конфликтная ситуация. Например, если в результате реализации ошибочного алгоритма программа непрерывно формирует торговые приказы поочерёдно на открытие и закрытие ордеров через очень маленькие промежутки времени (например, на каждом тике), или в случае чрезмерно частых приказов на создание, модификацию и удаление отложенных ордеров. Во всех случаях, когда создается повышенная нагрузка на брокера, возможен запрет на торговлю с помощью советников.

Порядок проведения торговых операций

Процесс исполнения торговых операций является интерактивным и осуществляется в режиме реального времени. На диаграмме (рис. 66) отражены все события, связанные с осуществлением торговой операции.

Рис. 66. Последовательность событий при осуществлении торговой операции.

Событие 0. Программа запущена на выполнение в момент времени t 0.

Событие 1. В момент t 1 в результате исполнения одной из торговых функций программой сформирован торговый приказ. Торговый приказ передаётся клиентскому терминалу. В этот момент программа передаёт клиентскому терминалу управление, и выполнение программы приостанавливается (красная точка на диаграмме).

Событие 2. Клиентский терминал получил управление и информацию о содержании торгового приказа. В период времени t 2 - t 3 клиентский терминал анализирует содержание торгового приказа и принимает решение о дальнейших событиях.

Событие 3. Клиентский терминал осуществляет принятое решение (один из двух вариантов).

Вариант 1. В случае, если торговый приказ, сформированный в результате исполнения одной из торговых функций, оказался некорректным, управление передаётся программе. В этом случае следующим является Событие 4 (это возможно, например, в случае, если программа создала торговый приказ открыть ордер, стоимость которого превышает количество свободных средств на счёте).

Событие 4. Программа получила управление (момент времени t 4, зелёная точка) и может продолжить исполнение с того места, где ранее был сформирован торговый приказ. В этот же момент программа получила информацию о том, что торговый приказ не исполнен. Какова причина отказа исполнения торгового приказа, можно выяснить, анализируя код возвращаемой ошибки. Как это сделать, мы рассмотрим позднее. Здесь же важно отметить, что не все торговые приказы приводят к осуществлению торговых операций. В данном случае программа сформировала некорректный приказ, в результате чего клиентский терминал отклонил этот приказ и вернул управление программе. Обращение к серверу в этом случае не происходит. Интервалы времени t 1 - t 2 - t 3 - t 4 пренебрежительно малы и в общей сложности не превышают нескольких мс.

Вариант 2. В случае, если программа сформировала корректный торговый приказ, клиентский терминал отправляет этот приказ на сервер, и тогда следующим событием будет Событие 5 (момент t 5) - получение торгового приказа сервером. Связь между клиентским терминалом и сервером осуществляется по сети Internet, поэтому время, затраченное на пересылку торгового приказа на сервер (интервал времени t 3 - t 5), полностью зависит от качества связи. При хорошей связи этот промежуток времени может составлять приблизительно 5 - 10 мс, а при плохой связи может измеряться секундами.

Событие 5. В момент времени t 5 сервер получил торговый приказ. Сервер может исполнить полученный приказ или отклонить его. Решение об исполнении или отклонении приказа может быть принято на сервере через некоторое время (в момент t 6). Интервал времени t 5 - t 6 может колебаться в зависимости от обстоятельств от нескольких микросекунд до десятков секунд. В одних случаях, если сервер работает в автоматическом режиме, на рынке нет резких движений цены и нет большой активности других трейдеров, торговый приказ может быть исполнен или отклонён в считанные микросекунды. В других случаях, если сервер перегружен в результате большой активности трейдеров, а решение об исполнении/отклонении приказа принимает человек, время, затраченное на решение, может составлять десятки секунд.

Событие 6. Если в течение промежутка времени с момента формирования торгового приказа программой (t 1) до момента принятия решения сервером (t 6) на рынке не произошло каких-либо существенных изменений, торговый приказ, как правило, будет исполнен. Если за это же время изменилась цена по финансовому инструменту, либо стоимость открываемого ордера на момент решения превышает количество свободных средств, либо возникли другие препятствия, то сервер принимает решение отклонить торговый приказ.

Отклонение торговых приказов сервером (несмотря на их предварительную проверку клиентским терминалом) - нормальное явление. В целом, подавляющее число торговых приказов, попадающих на сервер, принимаются сервером к исполнению. Однако в ряде случаев торговый приказ может быть отклонён, поэтому прикладная программа должна быть составлена таким образом, чтобы учесть возможность подобного развития событий и принять необходимые меры.

Вне зависимости от того, какое именно решение (исполнить/отклонить торговый приказ, Событие 6) было принято сервером, информация об этом будет направлена сервером клиентскому терминалу, приславшему приказ.

Событие 7. Клиентский терминал получил ответ сервера. Ответ сервера проходит тот же путь по сети Internet, что и при отправке приказа на сервер; и время, затраченное на получение ответа сервера, полностью зависит от качества связи. В зависимости от того, какие преобразования были выполнены на сервере, клиентский терминал покажет соответствующие изменения. Например, если в результате исполнения торгового приказа был закрыт или открыт ордер, то клиентский терминал отразит это событие: графически - в окне финансового инструмента, текстом - в окне Терминала (закладки Торговля и История счёта). Если же торговый приказ был отклонён сервером, то никаких изменений в окнах клиентского терминала не произойдёт.

Событие 8. Клиентский терминал закончил отображение изменений и передаёт управление программе.

Событие 9. Программа получила управление и может продолжать работу.

Обратите внимание:

С момента, когда программа отдаёт торговый приказ (и одновременно с этим передаёт управление) клиентскому терминалу, до момента, кода управление возвращается в программу, программа находится в режиме ожидания ответа. В этот период в программе не осуществляется никаких действий. Управление возвращается в программу в соответствии с правилом исполнения вызова функции (сформировавшей торговый приказ).

Если торговый приказ был некорректным, то программа находится в режиме ожидания ответа непродолжительное время (период t 1 - t 4). Если же торговый приказ был одобрен клиентским терминалом и отправлен на сервер, то программа может находиться в режиме ожидания ответа в течение различного по продолжительности времени (t 1 - t 9), в зависимости от качества связи и времени принятия решения на сервере - от нескольких миллисекунд до минут.

Одновременно с управлением программа получает возможность работать. Работающая программа может анализировать код последней ошибки, возвращённой клиентским терминалом, и таким образом судить о факте исполнения или отклонения торгового приказа.

Конфликты при проведении торговых операций. Ошибка 146

При рассмотрении свойств клиентского терминала указывалось, что клиентский терминал может работать одновременно только с одним торговым приказом. Рассмотрим, какие события будут происходить, если клиентскому терминалу будет адресовано несколько торговых приказов, сформированных разными программами.

Рис. 67. Конфликты при передаче торговых приказов клиентскому терминалу от нескольких программ.

На рис. 67 представлена ситуация, когда в клиентском терминале запущено на исполнение одновременно два торгующих эксперта. Эксперт 1 сформировал торговый приказ в момент t 1 и передал его клиентскому терминалу в момент t 2.

Эксперт 2 также создал торговый приказ и обращается к клиентскому терминалу в период, когда клиентский терминал занят обработкой первого торгового приказа (период t 2 - t 3). В этой ситуации клиентский терминал не может принять к рассмотрению торговый приказ, созданный Экспертом 2, и поэтому отклонит этот приказ и вернёт управление Эксперту 2. Обратите внимание, в данном случае торговый приказ отклоняется клиентским терминалом не потому, что приказ оказался некорректным, а потому, что терминал занят обработкой другого приказа. Эксперт 2 продолжит работу и может проанализировать код ошибки, свидетельствующий о причине отклонения торгового приказа (в данном случае - ошибка 146).

Если в период t 1 - t 4 клиентскому терминалу передаёт свой торговый приказ Эксперт 2 (а в общем случае одна или несколько торгующих программ), то этот приказ отклоняется (группа событий в розовой области). Клиентский терминал освобождается в момент t 4 (зелёная точка). Начиная с этого момента, Эксперт 2 может успешно передать клиентскому терминалу свой торговый приказ (группа событий в зелёной области). Этот приказ будет принят и рассмотрен клиентским терминалом, в результате чего также может быть отклонён (но уже по причине некорректности) или отправлен на сервер.

Если торговый приказ, созданный Экспертом 1, будет принят клиентским терминалом как корректный, то в момент t 3 этот приказ отправляется терминалом на сервер. В этом случае клиентский терминал переходит в режим ожидания ответа сервера и считается недоступным для рассмотрения других торговых приказов. Клиентский терминал освободится для рассмотрения других торговых приказов только в момент t 9. Таким образом, согласно второму варианту развития событий клиентский терминал является недоступным для анализа торговых приказов в течение периода t 1 - t 9. Если в этот период к клиентскому терминалу обратится любая программа с целью передать на рассмотрение торговый приказ, то клиентский терминал откажет в этом событии и вернёт управление программе (группа событий в розовой области в период t 6 - t 7). Программа, получившая управление, продолжит свою работу и, проанализировав код ошибки, может выяснить причину отклонения торгового приказа (в данном случае - ошибка 146).

Начиная с момента t 9, клиентский терминал полностью освобождается для анализа любых других торговых приказов. Эксперт 2 может успешно передать торговый приказ клиентскому терминалу в период, следующий за моментом t 9. В зависимости от того, сочтёт ли клиентский терминал этот приказ корректным, приказ будет передан клиентским терминалом на сервер или отклонён.

Анализ ошибок, возникающих при проведении торговых операций, более подробно рассматривается в последующем изложении.

Торговые операцииХарактеристики ордеров и правила проведения торговых операций


Торговые операции - Учебник по MQL4

Учебник по MQL4 [image] Торговые операции
  • Общий порядок проведения торговых операций
  • Характеристики ордеров и правила проведения торговых операций
  • Открытие и установка ордеров
  • Закрытие и удаление ордеров
  • Модификация ордеров
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Программирование торговых операций

При программировании торговых операций необходимо учитывать требования и ограничения, связанные с характеристиками ордеров и правилами, принятыми в дилинговом центре, а также особенности технологии исполнения торговых приказов. В разделе подробно рассматривается порядок проведения торговых операций и приводится достаточно примеров, поясняющих назначение всех торговых функций, с помощью которых формируются различные торговые приказы. Представлено несколько готовых к использованию скриптов, ориентированных на узкую область применения.

  • Общий порядок проведения торговых операций.
    Трейдер или программа на MQL4 могут только отдавать приказы на совершение торговых операций. Сами же торговые операции регистрируются на торговом сервере. Посредником между торговым сервером и программой является клиентский терминал. Некорректно составленные торговые приказы отклоняются прямо в терминале, поэтому необходимо понимать общий порядок проведения торговых операций.
  • Характеристики ордеров и правила проведения торговых операций.
    Торговые приказы оформляются с помощью ордеров. В ордере необходимо указать множество параметров, одна часть которых определяется текущими ценами и направлением операции, другая часть зависит от инструмента, по которому будет производиться торговая операция. Торговые приказы, поступившие на сервер, проверяются в режиме реального времени на соответствие текущей ситуации и состоянию торгового счета. Поэтому, знание правил проведения торговых операций просто необходимо.
  • Открытие и установка ордеров.
    Наиболее важная торговая функция - OrderSend(). Именно с ее помощью торговому серверу отсылаются приказы на открытие рыночного ордера или постановку отложенного. При этом можно сразу указать требуемые значения StopLoss и TakeProfit. Некоректное значение этих параметров, а также цены открытия и объема ордера, может приводить к получению ошибок. Важно правильно обрабатывать эти ошибки. Функция MarketInfo() позволяет свести количество таких ошибок к минимуму.
  • Закрытие и удаление ордеров. Функция OrderSelect.
    Закрытие рыночных ордеров производится с помощью функции OrderClose(), для удаления отложенных ордеров существует функция OrderDelete(). При отсылке приказа на закрытие или удаление ордера необходимо указать тикет этого ордера. Нужный ордер мы выберем с помощью функции OrderSelect(). Кроме того, если по некоторому финансовому инструменту имеется два встречных ордера, то их можно закрыть одновременно, один за счёт другого, с помощью функции OrderCloseBy(). При исполнении такой торговой операции экономится один спред.
  • Модификация ордеров.
    Уровни TakeProfit и StopLoss можно изменять с помощью торговой функции OrderModify(). Для отложенных ордеров можно также менять уровень открытия ордера. Изменять объем для отложенных ордеров нельзя. Модификация рыночных и отложенных ордеров также налагает определенные требования на корректность этой торговой операции. При любой торговой операции крайне желательна обработка результатов этих операций, обработка ошибок.
Практическое программирование на языке MQL4Общий порядок проведения торговых операций


Закрытие и удаление ордеров - Торговые операции - Учебник по MQL4

Учебник по MQL4 [image] Торговые операции [image] Закрытие и удаление ордеров
MetaQuotes Sofware Corp.
  • Общий порядок проведения торговых операций
  • Характеристики ордеров и правила проведения торговых операций
  • Открытие и установка ордеров
  • Закрытие и удаление ордеров
  • Модификация ордеров
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Закрытие и удаление ордеров

Закрытие рыночных ордеров

Торговые приказы для закрытия рыночных ордеров формируются с помощью функции OrderClose().

Функция OrderClose()

bool OrderClose (int ticket, double lots, double price, int slippage, color Color=CLR_NONE)

Функция закрытия рыночного ордера. Функция возвращает TRUE при успешном исполнении торговой операции. Возвращает FALSE при неудачном завершении торговой операции.

Параметры:

ticket - уникальный порядковый номер ордера.

lots - количество лотов для закрытия. Допускается указать значение меньшее, чем имеющееся количество лотов ордера. В этом случае (при успешном исполнении торгового приказа) ордер будет закрыт частично.

price - цена закрытия. Устанавливается в соответствии с требованиями и ограничениями, принятыми для проведения торговых операций (см. Характеристики ордеров и Приложение 3). Если заявленной цены для закрытия рыночного ордера не было в ценовом потоке или она сильно устарела, то такой торговый приказ отклоняется; если же цена устарела, но присутствует в ценовом потоке и при этом отклонение от текущей цены находится в пределах значения slippage, то такой торговый приказ будет принят клиентским терминалом и отправлен на торговый сервер.

slippage - максимально допустимое отклонение заявленной цены закрытия ордера от рыночной цены (пунктов).

Color - цвет стрелки закрытия на графике. Если параметр отсутствует или его значение равно CLR_NONE, то стрелка на графике не отображается.

Если в программе имеются сведения о типе ордера, который необходимо закрыть, о его уникальном номере, а также известно количество лотов, предназначенных для закрытия, то закрыть рыночный ордер очень просто. Для этого в коде программы необходимо использовать обращение к функции OrderClose() с заданными параметрами. Например, если уникальный номер ордера Buy 12345 и необходимо закрыть 0.5 лотов, то обращение к функции закрытия ордера может выглядеть так:

OrderClose( 12345, 0.5, Bid, 2 );

Чтобы принять решение о том, какие ордера и в какой последовательности необходимо закрывать, требуется иметь сведения обо всех ордерах, открытых на текущий момент. В MQL4 имеется ряд функций, с помощью которых можно получить различные сведения, характеризующие любой ордер. Например, функция OrderOpenPrice() возвращает значение цены открытия ордера (или заявленной цены для отложенных ордеров), функция OrderLots() возвращает количество лотов, функция OrderType() возвращает тип ордера и т.д. Все функции, возвращающие значение какой-либо характеристики ордера, при исполнении обращаются к тому ордеру, который был выбран с помощью функции OrderSelect().

Функция OrderSelect()

Чтобы получить параметры любого из ордеров (рыночных или отложенных, закрытых или удалённых) его необходимо предварительно выбрать с помощью функции OrderSelect().

bool OrderSelect(int index, int select, int pool=MODE_TRADES)

OrderSelect - функция выбирает ордер для дальнейшей работы с ним. Возвращает TRUE при успешном завершении функции. Возвращает FALSE при неудачном завершении функции.

Параметры:

index - позиция ордера или номер ордера в зависимости от второго параметра.

select - флаг способа выбора. Параметр select может принимать одно из двух значений:

SELECT_BY_POS - в параметре index передается порядковый номер ордера в списке (нумерация начинается с 0),

SELECT_BY_TICKET - в параметре index передается номер тикета (уникальный номер ордера).

pool - источник данных для выбора. Параметр pool используется, когда параметр select равен SELECT_BY_POS. Параметр pool игнорируется, если ордер выбирается по номеру тикета (SELECT_BY_TICKET). Параметр pool может принимать одно из двух значений:

MODE_TRADES (по умолчанию) - ордер выбирается среди открытых и отложенных ордеров, т.е. среди ордеров, отображаемых в Терминале на закладке Торговля;

MODE_HISTORY - ордер выбирается среди закрытых и удаленных ордеров, т.е. среди тех, которые указаны в Терминале на закладке История счёта. При этом имеет значение глубина истории, заданная пользователем в терминале для показа закрытых и удаленных ордеров.

Для того чтобы продемонстрировать порядок использования торговых функций при закрытии рыночных ордеров, решим задачу:

Задача 28. Составить скрипт, закрывающий один из имеющихся рыночных ордеров. В результате исполнения скрипта должен быть закрыт тот ордер, который находится ближе других к месту прикрепления скрипта мышью в окно финансового инструмента.

Предположим, что в терминале имеется три рыночных ордера, открытых по финансовому инструменту Eur/Usd и один отложенный ордер, открытый по Usd/Chf:

Рис. 90. Отражение в окне Терминала нескольких ордеров, открытых по разным финансовым инструментам.

Нам необходимо написать такой скрипт, чтобы можно было перетянуть его мышкой из Навигатора в окно финансового инструмента, в результате чего был бы закрыт один из рыночных ордеров, а именно тот, к которому оказался ближе курсор (в момент, когда пользователь отпустил кнопку мыши). На рис. 91 показан вариант, при котором курсор находится ближе всего к ордеру Sell 4372889, - он и должен быть закрыт в результате исполнения скрипта.

Рис. 91. Использование скрипта closeorder.mq4 для закрытия выбранного ордера.

Для решения задачи из всех ордеров необходимо выбрать ордера, открытые по финансовому инструменту (используя функцию OrderSymbol()), в окно которого брошен скрипт. Затем нужно определить цены открытия всех выбранных рыночных ордеров (т.е. необходимо исполнить функцию OrderOpenPrice() последовательно для каждого ордера). Зная цены открытия ордеров, легко выбрать из них один, соответствующий условию задачи. Чтобы указать правильные значения параметров в функции OrderClose(), понадобятся ещё и другие сведения о выбранном ордере: количество лотов (определяется функцией OrderLots()) и уникальный номер ордера (определяется функцией OrderTicket()). Кроме того, чтобы правильно определить ту или иную цену двухсторонней котировки, понадобится знать тип ордера (определяется с помощью функции OrderType()).

Рассмотрим, какие параметры требуется указать в функции OrderSelect() для того, чтобы получить указанные выше характеристики рыночных ордеров.

Прежде всего, необходимо определиться со способом выбора ордеров. В данной задаче выбор способа диктуется самой постановкой задачи: полагается, что в момент запуска скрипта на исполнение в программе нет сведений о номерах ордеров, т.е. программа должна содержать блок, в котором номера ордеров определяются. Это значит, что необходимо последовательно по порядку опросить все ордера, отражённые в Терминале (рис. 64.1), поэтому требуется использование параметра SELECT_BY_POS.

Источник для выбора ордеров также очевиден. Для решения задачи нет необходимости анализировать закрытые и удалённые ордера. В данном случае нас интересуют только рыночные ордера, поэтому будем искать их, используя в функции OrderSelect() параметр MODE_TRADES. Для параметра pool в заголовке функции указано умолчательное значение MODE_TRADES, поэтому его можно опустить.

Вот так может быть построен блок, в котором анализируются рыночные и отложенные ордера:

   for (int i=1; i<=OrdersTotal(); i++)       //Цикл по всем ордерам,..
     {                                        //отражённым в терминале
      if(OrderSelect(i-1,SELECT_BY_POS)==true)//Если есть следующий
        {
         // Здесь должен выполняться ..
         // ..анализ характеристик ордеров
        }
     }                                        //Конец тела цикла

В заголовке оператора цикла указано начальное значение i=1, а условием окончания цикла - выражение i<=OrdersTotal(). Функция OrdersTotal() возвращает общее количество рыночных и отложенных ордеров, т.е. тех ордеров, которые отражаются в Терминале на закладке Торговля. Поэтому в цикле будет столько итераций, сколько ордеров присутствует в торговле.

На каждой итерации, при вычислении условия в операторе if, будет исполнена функция OrderSelect(i-1,SELECT_BY_POS). Здесь необходимо обратить внимание на следующий важный момент:

Исчисление позиций ордеров в списке рыночных и отложенных ордеров начинается с нуля.

Это значит, что первый по порядку ордер (рис. 90) располагается в нулевой позиции, позиция второго ордера имеет значение 1, третьего ордера - значение 2 и т.д. Поэтому в вызове функции OrderSelect() указано значение индекса i-1. Таким образом, для всех выбираемых ордеров этот индекс будет на 1 меньше, чем значение переменной i (совпадающее с номером очередной итерации).

Функция OrderSelect() возвращает true в случае, если выбор ордера выполнен удачно. Под этим понимается, что возможен вариант, при котором выбор ордера может закончиться неудачей. Это может произойти в случае, если за время обработки ордеров количество ордеров изменилось. При программировании на MQL4 нужно хорошо помнить, что прикладная программа будет работать в режиме реального времени, и пока в ней выполняется обработка каких-то параметров, значение этих параметров может измениться. Например, может измениться количество рыночных ордеров, причём это может произойти как в результате открытия/закрытия ордеров, так и в результате преобразования отложенных ордеров в рыночные. Поэтому при программировании обработки ордеров необходимо придерживаться правила: обработка ордеров должна быть выполнена как можно быстрее, а программный блок, ответственный за эту обработку, по возможности не должен содержать лишних программных строк.

Согласно коду, представленному на рис. 64.3, в заголовке оператора if анализируется факт наличия следующего ордера в списке ордеров на момент его выбора. Если следующий ордер есть, то управление передаётся внутрь тела оператора if для обработки параметров ордера. Нужно заметить, что такая конструкция тоже не спасает от возможного конфликта, т.к. ордер может пропасть (быть закрытым) в процессе обработки его параметров. Однако такое решение оказывается наиболее эффективным в случае, если на момент выбора ордера его уже нет. В теле оператора if выполняется анализ параметров выбранного ордера. При исполнении, например, функций OrderOpenPrice(), OrderTicket(), OrderType() и других подобных каждая из них будет возвращать значение некоторой характеристики ордера, выбранного в результате исполнения функции OrderSelect().

Все предыдущие рассуждения использовались при составлении программы для решения Задачи 28.

Пример простого скрипта, предназначенного для закрытия рыночного ордера, цена открытия которого находится ближе к месту прикрепления скрипта, чем цены открытия других ордеров (closeorder.mq4).

//--------------------------------------------------------------------
// closeorder.mq4
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------- 1 --
int start()                                     // Спец.функция start
  {
   string Symb=Symbol();                        // Финанс. инструмент
   double Dist=1000000.0;                       // Предустановка
   int Real_Order=-1;                           // Пока рыночных нет
   double Win_Price=WindowPriceOnDropped();     // Здесь брошен скрипт
//--------------------------------------------------------------- 2 --
   for(int i=1; i<=OrdersTotal(); i++)          // Цикл перебора ордер
     {
      if (OrderSelect(i-1,SELECT_BY_POS)==true) // Если есть следующий
        {                                       // Анализ ордеров:
         //------------------------------------------------------ 3 --
         if (OrderSymbol()!= Symb) continue;    // Не наш фин.инструм.
         int Tip=OrderType();                   // Тип ордера
         if (Tip>1) continue;                   // Отложенный ордер
         //------------------------------------------------------ 4 --
         double Price=OrderOpenPrice();         // Цена ордера
         if (NormalizeDouble(MathAbs(Price-Win_Price),Digits)< //Выбор
            NormalizeDouble(Dist,Digits))       // самого близкого орд
           {
            Dist=MathAbs(Price-Win_Price);      // Новое значение
            Real_Order=Tip;                     // Есть рыночный ордер
            int Ticket=OrderTicket();           // Номер ордера
            double Lot=OrderLots();             // Количество лотов
           }
         //------------------------------------------------------ 5 --
        }                                       //Конец анализа ордера
     }                                          //Конец перебора орд.
//--------------------------------------------------------------- 6 --
   while(true)                                  // Цикл закрытия орд.
     {
      if (Real_Order==-1)                       // Если рыночных нет
        {
         Alert("По ",Symb," рыночных ордеров нет");
         break;                                 // Выход из цикла закр
        }
      //--------------------------------------------------------- 7 --
      switch(Real_Order)                        // По типу ордера
        {
         case 0: double Price_Cls=Bid;          // Ордер Buy
            string Text="Buy ";                 // Текст для Buy
            break;                              // Из switch
         case 1: Price_Cls=Ask;                 // Ордер Sell
            Text="Sell ";                       // Текст для Sell
        }
      Alert("Попытка закрыть ",Text," ",Ticket,". Ожидание ответа..");
      bool Ans=OrderClose(Ticket,Lot,Price_Cls,2);// Закрытие ордера
      //--------------------------------------------------------- 8 --
      if (Ans==true)                            // Получилось :)
        {
         Alert ("Закрыт ордер ",Text," ",Ticket);
         break;                                 // Выход из цикла закр
        }
      //--------------------------------------------------------- 9 --
      int Error=GetLastError();                 // Не получилось :(
      switch(Error)                             // Преодолимые ошибки
        {
         case 135:Alert("Цена изменилась. Пробуем ещё раз..");
            RefreshRates();                     // Обновим данные
            continue;                           // На след. итерацию
         case 136:Alert("Нет цен. Ждём новый тик..");
            while(RefreshRates()==false)        // До нового тика
               Sleep(1);                        // Задержка в цикле
            continue;                           // На след. итерацию
         case 146:Alert("Подсистема торговли занята. Пробуем ещё..");
            Sleep(500);                         // Простое решение
            RefreshRates();                     // Обновим данные
            continue;                           // На след. итерацию
        }
      switch(Error)                             // Критические ошибки
        {
         case 2 : Alert("Общая ошибка.");
            break;                              // Выход из switch
         case 5 : Alert("Старая версия клиентского терминала.");
            break;                              // Выход из switch
         case 64: Alert("Счет заблокирован.");
            break;                              // Выход из switch
         case 133:Alert("Торговля запрещена");
            break;                              // Выход из switch
         default: Alert("Возникла ошибка ",Error);//Другие варианты
        }
      break;                                    // Выход из цикла закр
     }
//-------------------------------------------------------------- 10 --
   Alert ("Скрипт закончил работу -----------------------------");
   return;                                      // Выход из start()
  }
//-------------------------------------------------------------- 11 --

Весь код программы closeorder.mq4 сосредоточен в специальной функции start(). В блоке 1-2 инициализируются некоторые переменные. Переменная Dist - дистанция от места, где был брошен скрипт, до ближайшего ордера. Переменная Real_Order - флаг, отражающий факт наличия в терминале хотя бы одного рыночного ордера (неотрицательное значение). Переменная Win_Price - цена, на которой пользователь прикрепил скрипт в окно финансового инструмента. В блоке 2-6 выполняется анализ ордеров: один из имеющихся ордеров назначается к закрытию. Блок 6-10 представляет блок закрытия ордера и обработку ошибок, которые могут возникнуть при исполнении торговой операции.

С момента, когда пользователь присоединил скрипт в окно финансового инструмента, вычисляются значения переменных в блоке 1-2, в том числе переменная Win_Price получает значение цены, на уровне которой пользователь прикрепил скрипт. Теперь необходимо найти ордер (и определить его характеристики), который расположен ближе других к этому месту.

В цикле for (блок 2-6) выполняется перебор ордеров. В блоке 2-3 программа определяет, есть ли в очередной строке Терминала ордер, и если он есть, то управление передаётся в тело оператора if для получения и анализа характеристик этого ордера. В блоке 3-4 отсортировываются ордера, открытые не по тому финансовому инструменту, где исполняется программа. В нашем случае - это ордер 4372930, открытый по Usd/Chf. Функция OrderSymbol() возвращает название финансового инструмента выбранного ордера. Если это название не совпадает с названием финансового инструмента, в котором исполняется программа, то текущая итерация прерывается, тем самым предотвращая обработку ордера, открытого по другому финансовому инструменту. Если же исследуемый ордер оказался открытым по "нашему" финансовому инструменту, то выполняется ещё одна проверка. С помощью функции OrderType() определяется тип ордера (см. Типы торговых операций). Если тип ордера оказывается больше 1, это означает, что исследуемый ордер является отложенным. В этом случае также прерывается текущая итерация - отложенные ордера в данном случае нас не интересуют. В нашем примере такой ордер есть, но он к тому же открыт по другому финансовому инструменту, поэтому ранее уже отсортирован. Все ордера, которые благополучно проходят проверку в блоке 3-4, являются рыночными.

Блок 4-5 предназначен для того, чтобы из всех (ранее прошедших проверку) рыночных ордеров выбрать один, а именно тот, который находится ближе всего к ранее определённой цене (значению переменной Win_Price). От пользователя не требуется точного попадания курсором мыши в линию ордера. Выбор производится в пользу того ордера, который оказался ближе других к курсору в момент запуска скрипта на исполнение. С помощью функции OrderOpenPrice() определяется цена открытия обрабатываемого ордера. Если абсолютное значение дистанции между ценой ордера и ценой курсора меньше, чем эта же дистанция для предыдущего ордера, то выбор производится в пользу текущего (абсолютная величина дистанции нужна для того, чтобы исключить влияние положения курсора - выше или ниже линии ордера). В этом случае на текущей итерации цикла for этот ордер запоминается как первый претендент на закрытие. Для такого ордера в конце блока 4-5 вычисляется номер тикета (индивидуальный номер ордера) и количество лотов. В данном примере (рис. 90) общее количество ордеров - четыре (три рыночных и один отложенный), поэтому в цикле for будет выполнено четыре итерации, в результате чего будет определена вся необходимая информация для закрытия одного выбранного ордера.

Далее управление в исполняемой программе будет передано оператору цикла while (блок 6-10). В блоке 6-7 выполняется проверка наличия найденных рыночных ордеров. Если в блоке 2-4 не было обнаружено ни одного рыночного ордера (а это в общем случае вполне возможно), то значение флага Real_Order остаётся равным -1, что означает отсутствие рыночных ордеров. Если при проверке в блоке 6-7 выявлено отсутствие рыночных ордеров, то выполнение цикла while прерывается и программа заканчивает работу. Если же значение переменной Real_Order оказывается равным 0 или 1, то это значит, что рыночный ордер к закрытию ранее определён и его надо закрыть.

В блоке 7-8, в зависимости от типа ордера вычисляется цена закрытия - для ордеров Buy это значение Bid, а для ордеров Sell - Ask (см. Требования и ограничения торговых операций).

В блоке 7-8 также вычисляется значения вспомогательной переменной Text. Собственно торговый приказ на закрытие ордера формируется в функции OrderClose () в следующей строке:

      bool Ans=OrderClose(Ticket,Lot,Price_Cls,2);// Закрытие ордера

Торговая функция OrderClose() возвращает true при успешном исполнении торговой операции и false при неудачном. Если торговый приказ успешно исполнен на сервере, то переменной Ans (ответ) будет присвоено значение true. В этом случае, исполняя блок 8-9, программа сообщит пользователю об успешном закрытии ордера, после чего исполнение оператора цикла while будет прекращено, и программа закончит работу. В противном случае управление будет передано в блок 9-10 для анализа ошибки, возвращённой в программу клиентским терминалом.

В начале блока 9-10 вычисляется код ошибки. В дальнейшем, в зависимости от кода ошибки, выполняется либо выход из программы либо повторное исполнение торговой операции. В первом операторе switch обрабатываются ошибки, которые по смыслу являются преодолимыми, т.е, если можно считать, что при выполнении торговой операции возникли временные затруднения. Для каждой из таких ошибок выполняются необходимые действия, после чего текущая итерация прерывается, и исполнение цикла while начинается снова. (Обратите внимание, в данном примере при обработке преодолимых ошибок используется оператор switch, выход из которого осуществляется в результате исполнения оператора continue, который сам по себе не предназначен для передачи управления за пределы switch. Такая конструкция оказывается рабочей только благодаря тому, что оператор switch является содержимым внешнего оператора цикла while, а оператор continue прерывает текущую итерацию, передавая управление в заголовок while).

Если код ошибки не обрабатывается в первом операторе switch, то эта ошибка считается непреодолимой. В этом случае управление передаётся второму оператору switch, смысл исполнения которого сводится к информированию пользователя о возникновении той или иной критической ошибки. В дальнейшем исполняется оператор break, прерывающий исполнение цикла while. Выход из цикла while по любой причине приводит к передаче управления в блок 9-10, в котором выдаётся сообщение о завершении работы программы. Оператор return прекращает исполнение специальной функции start() и программа завершает работу.

Практический результат, полученный после запуска скрипта в заданных условиях (см. рис. 90 и 91), представлен ниже. Торговая операция была успешно выполнена на сервере.

Рис. 92. Сообщения, полученные в результате успешного исполнения скрипта closeorder.mq4.

В результате закрытия одного из ордеров в окне финансового инструмента Eur/Usd осталось два ордера.

Рис. 93. Исполнение скрипта closeorder.mq4 привело к закрытию одного из ордеров

Закрытие ордера также нашло своё отражение и в окне Терминала:

Рис. 94. После исполнение скрипта closeorder.mq4 в Терминале отражаются два рыночных ордера.

В последующих событиях с помощью представленного скрипта были закрыты и два других рыночных ордера.

Удаление отложенных ордеров

Торговые приказы для удаления отложенных ордеров формируются с помощью функции OrderDelete( ).

Функция OrderDelete()

bool OrderDelete(int ticket, color arrow_color=CLR_NONE)

Функция удаляет ранее установленный отложенный ордер. Возвращает TRUE при успешном завершении функции. Возвращает FALSE при неудачном завершении функции.

Параметры:

ticket - уникальный порядковый номер ордера.

arrow_color - цвет стрелки на графике. Если параметр отсутствует или его значение равно CLR_NONE, то стрелка на графике не отображаются.

Легко заметить, что в функции OrderDelete( ) нет указания на количество лотов в удаляемом ордере и цену закрытия.

Удаление ордера происходит независимо от рыночных цен. Невозможно также частичное удаление ордера. Уменьшение количества лотов отложенного ордера можно осуществить в два этапа - сначала удалить имеющийся ордер, а потом выставить новый отложенный ордер на уменьшенное (любое) количество лотов.

Алгоритм построения программы для удаления отложенного ордера может быть полностью аналогичен алгоритму программы закрытия рыночного ордера. Небольшая разница состоит лишь в том, что для удаления отложенного ордера не требуется цена закрытия, поэтому в следующей программе отсутствует блок, в котором обновляются рыночные цены.

Пример простого скрипта, предназначенного для удаления одного отложенного ордера, заявленная цена которого находится ближе к месту прикрепления скрипта, чем цены других отложенных ордеров (deleteorder.mq4).

//--------------------------------------------------------------------
// deleteorder.mq4
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------- 1 --
int start()                                     // Спец.функция start
  {
   string Symb=Symbol();                        // Финанс. инструмент
   double Dist=1000000.0;                       // Предустановка
   int Limit_Stop=-1;                           // Пока отложенных нет
   double Win_Price=WindowPriceOnDropped();     // Здесь брошен скрипт
//--------------------------------------------------------------- 2 --
   for(int i=1; i<=OrdersTotal(); i++)          // Цикл перебора ордер
     {
      if (OrderSelect(i-1,SELECT_BY_POS)==true) // Если есть следующий
        {                                       // Анализ ордеров:
         //------------------------------------------------------ 3 --
         if (OrderSymbol()!= Symb) continue;    // Не наш фин.инструм.
         int Tip=OrderType();                   // Тип ордера
         if (Tip<2) continue;                   // Рыночный ордер
         //------------------------------------------------------ 4 --
         double Price=OrderOpenPrice();         // Цена ордера
         if (NormalizeDouble(MathAbs(Price-Win_Price),Digits)< //Выбор
            NormalizeDouble(Dist,Digits))       // самого близкого орд
           {
            Dist=MathAbs(Price-Win_Price);      // Новое значение
            Limit_Stop=Tip;                     // Есть отложен. ордер
            int Ticket=OrderTicket();           // Номер ордера
           }                                    // Конец if
        }                                       //Конец анализа ордера
     }                                          // Конец перебора орд.
//--------------------------------------------------------------- 5 --
   switch(Limit_Stop)                           // По типу ордера
     {
      case 2: string Text= "BuyLimit ";         // Текст для BuyLimit
         break;                                 // Выход из switch
      case 3: Text= "SellLimit ";               // Текст для SellLimit
         break;                                 // Выход из switch
      case 4: Text= "BuyStopt ";                // Текст для BuyStopt
         break;                                 // Выход из switch
      case 5: Text= "SellStop ";                // Текст для SellStop
         break;                                 // Выход из switch
     }
//--------------------------------------------------------------- 6 --
   while(true)                                  // Цикл закрытия орд.
     {
      if (Limit_Stop==-1)                       // Если отложенных нет
        {
         Alert("По ",Symb," отложенных ордеров нет");
         break;                                 // Выход из цикла закр
        }
      //--------------------------------------------------------- 7 --
      Alert("Попытка удалить ",Text," ",Ticket,". Ожидание ответа..");
      bool Ans=OrderDelete(Ticket);             // Удаление ордера
      //--------------------------------------------------------- 8 --
      if (Ans==true)                            // Получилось :)
        {
         Alert ("Удалён ордер ",Text," ",Ticket);
         break;                                 // Выход из цикла закр
        }
      //--------------------------------------------------------- 9 --
      int Error=GetLastError();                 // Не получилось :(
      switch(Error)                             // Преодолимые ошибки
        {
         case  4: Alert("Торговый сервер занят. Пробуем ещё раз..");
            Sleep(3000);                        // Простое решение
            continue;                           // На след. итерацию
         case 137:Alert("Брокер занят. Пробуем ещё раз..");
            Sleep(3000);                        // Простое решение
            continue;                           // На след. итерацию
         case 146:Alert("Подсистема торговли занята. Пробуем ещё..");
            Sleep(500);                         // Простое решение
            continue;                           // На след. итерацию
        }
      switch(Error)                             // Критические ошибки
        {
         case 2 : Alert("Общая ошибка.");
            break;                              // Выход из switch
         case 64: Alert("Счет заблокирован.");
            break;                              // Выход из switch
         case 133:Alert("Торговля запрещена");
            break;                              // Выход из switch
         case 139:Alert("Ордер заблокирован и уже обрабатывается");
            break;                              // Выход из switch
         case 145:Alert("Модификация запрещена. ",
                              "Ордер слишком близок к рынку");
            break;                              // Выход из switch
         default: Alert("Возникла ошибка ",Error);//Другие варианты
        }
      break;                                    // Выход из цикла закр
     }
//-------------------------------------------------------------- 10 --
   Alert ("Скрипт закончил работу -----------------------------");
   return;                                      // Выход из start()
  }
//-------------------------------------------------------------- 11 --

Блок обработки ошибок также претерпел некоторые изменения. Если при закрытии рыночных ордеров необходимо учитывать возможность возникновения ошибок, связанных с изменением цен (ошибки 135 и 136), то при удалении отложенных ордеров подобные ошибки не возникают. По этой же причине нигде в программе не используется функция RefreshRates() с целью обновления текущих цен.

Некоторую сложность вызывает обработка таких ошибок, как 4 и 137 (см. Коды ошибок). Например, при получении ошибки 137 программа может принять к сведению информацию о том, что "брокер занят". Но возникает естественный вопрос: когда он освободится, чтобы пользователь мог продолжить торговлю? Ошибка 137 не содержит такой информации. Поэтому вопрос о том, как правильно составить программу обработки подобных ошибок, программист должен решить сам. В простом случае можно повторить торговый приказ после некоторой паузы (в данном примере - 3 секунды). С другой стороны, в результате серии неудачных попыток удаления (или в общем случае закрытия, открытия или модификации) ордера сервер может вернуть ошибку 141 - слишком много запросов. В результате этой ошибки скрипт deleteorder.mq4 прекратит работу. В целом, подобные конфликты не являются вопросами программирования. В подобных случаях следует связаться со службой поддержки дилингового центра и выяснить причины отказа в исполнении торгового приказа.

Ошибка 145 может возникнуть в том случае, если отложенный ордер (в общем случае и стоп-приказ рыночного ордера) находится слишком близко к рыночной цене. Эта ошибка не возникает, если торговля ведётся на спокойном рынке в размеренном темпе. Если же на рынке происходят резкие изменения цены, брокер может решить, что некоторый ордер в ближайшее время будет открыт, и не позволит его удалить (или модифицировать). Эта ошибка учитывается в скрипте как непреодолимая и приводит завершению программы (нет смысла лишний раз тревожить брокера торговыми приказами). Если через некоторое время цена изменится, можно повторить попытку удаления ордера, снова запустив скрипт на исполнение.

В общем случае, для предотвращения ошибки 145 необходимо учитывать уровень заморозки, установленный дилинговым центром. Уровень заморозки - это значение, определяющее коридор цен, внутри которого ордер считается замороженным, т.е. его удаление может быть запрещено. Например, если отложенный ордер установлен по цене 1.2500, а уровень заморозки равен 10 пунктов, то это значит, что если цена находится в коридоре цен от 1.2490 до 1.2510 включительно, то удаление отложенного ордера запрещено. Уровень заморозки можно получить, исполнив функцию MarketInfo() с идентификатором запроса MODE_FREEZELEVEL.

Встречное закрытие рыночных ордеров

Встречный ордер - это рыночный ордер, открытый в противоположном направлении по отношению к другому рыночному ордеру по тому же финансовому инструменту.

Если по некоторому финансовому инструменту имеется два встречных ордера, то их можно закрыть одновременно, один за счёт другого, с помощью функции OrderCloseBy(). При исполнении такой торговой операции экономится один спред.

Функция OrderCloseBy()

bool OrderCloseBy(int ticket, int opposite, color Color=CLR_NONE)

Функция закрывает один рыночный ордер другим рыночным ордером, открытым по тому же финансовому инструменту, но в противоположном направлении. Функция возвращает TRUE при успешном завершении функции и FALSE при неудачном завершении функции.

Параметры:

ticket - Уникальный порядковый номер закрываемого ордера.

opposite - Уникальный порядковый номер противоположного ордера.

Color - Цвет стрелки закрытия на графике. Если параметр отсутствует или его значение равно CLR_NONE, то стрелка на графике не отображается.

Размеры встречных ордеров не обязательно должны совпадать. В случае несовпадения размеров ордеров торговая операция выполняется в размере меньшего объема одного из ордеров.

Рассмотрим пример. Пусть в терминале имеются два рыночных ордера одинакового объема, один из которых открыт на покупку, а другой - на продажу. Если каждый из этих ордеров закрыть по отдельности, используя для этого функцию OrderClose (), то экономический результат будет складываться из суммы прибыли, имеющейся по каждому из ордеров:

Рис. 95. Результат отдельного закрытия ордеров с помощью функции OrderClose().

Если же в этой ситуации использовать функцию встречного закрытия ордеров OrderCloseBy(), то экономический результат окажется лучше (в сравнении с предыдущим вариантом) на сумму, пропорциональную стоимости спреда одного из ордеров:

Рис. 96. Результат встречного закрытия ордеров с помощью функции OrderCloseBy().

Очевидно, что если в терминале есть встречные ордера, которые необходимо закрыть, то, имея ввиду экономическую выгоду, следует использовать функцию OrderCloseBy(), а не OrderClose().

В связи с экономией одного спреда при встречном закрытии ордеров необходимо дать замечания более общего характера. В сущности, торговая операция открытия ордера (например, на покупку) по смыслу является противоположной торговой операцией по отношению к операции открытия ордера в противоположном направлении (на продажу) в той же мере, как и операция закрытия ордера (на покупку). Иначе говоря, с экономической точки зрения безразлично какой из двух вариантов использовать: то ли просто закрыть рыночный ордер, то ли открыть встречный на такое же количество лотов (а впоследствии оба ордера закрыть встречно). Разница между этими вариантами может состоять лишь в различных методах расчёта денежных средств, отвлекаемых на поддержание рыночных ордеров в различных дилинговых центрах (см. рис. 85 и рис. 88).

Легко заметить также, что в функции OrderCloseBy() для встречного закрытия ордеров не предусмотрено указание цены закрытия. В этом нет необходимости, потому что прибыль и убыток от двух встречных ордеров взаимно гасят друг друга, и общий экономический результат от рыночной цены не зависит. Это правило справедливо, конечно же, только в отношении ордеров одинакового количества лотов. Например, если по одному финансовому инструменту имеются два ордера - Buy размером 1 лот и Sell размером 0.7 лота, то зависимость от цены этой торговой ситуации касается только ордера Buy в размере 0.3 лота. Совпадающая же часть ордеров 0.7 лота от цены финансового инструмента не зависит.

Встречные ордера не оказывают влияния на общий итог торгов, поэтому торговые тактики, основанные на открытии встречных ордеров, не имеют содержательного основания (по этой причине некоторые дилинговые центры принудительно закрывают любые встречные ордера в пределах совпадающего количества лотов). Единственное - негативное - влияние подобных тактик может состоять только в отвлечении средств в соответствии с правилами, принятыми в некоторых дилинговых центрах. Кроме того, наличие нескольких встречных ордеров представляет большую сложность с точки зрения программного управления торговлей, чем один ордер. Если также принять во внимание наличие комиссионных и свопов (для каждого из рыночных ордеров), то необходимость закрывать встречные ордера становится очевидной.

Пример простого скрипта, закрывающего все встречные ордера по финансовому инструменту (closeby.mq4).

//--------------------------------------------------------------------
// closeby.mq4
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------- 1 --
int start()                                     // Спец.функция start
  {
   string Symb=Symbol();                        // Финанс. инструмент
   double Dist=1000000.0;                       // Предустановка
//--------------------------------------------------------------- 2 --
   while(true)                                  // Цикл обработки..
     {                                          // ..встречных ордеров
      double Hedg_Buy = -1.0;                   // Макс. стоимость Buy
      double Hedg_Sell= -1.0;                   // Макс.стоимость Sell
      for(int i=1; i<=OrdersTotal(); i++)       // Цикл перебора ордер
        {
         if(OrderSelect(i-1,SELECT_BY_POS)==true)// Если есть следующий
           {                                    // Анализ ордеров:
            //--------------------------------------------------- 3 --
            if (OrderSymbol()!= Symb) continue; // Не наш фин.инструм.
            int Tip=OrderType();                // Тип ордера
            if (Tip>1) continue;                // Отложенный ордер
            //--------------------------------------------------- 4 --
            switch(Tip)                         // По типу ордера
              {
               case 0:                          // Ордер Buy
                  if (OrderLots()>Hedg_Buy)
                    {
                     Hedg_Buy=OrderLots();      // Выбираем макс.стоим
                     int Ticket_Buy=OrderTicket();//Номер ордера
                    }
                  break;                        // Из switch
               case 1:                          // Ордер Sell
                  if (OrderLots()>Hedg_Sell)
                    {
                     Hedg_Sell=OrderLots();     // Выбираем макс.стоим
                     int Ticket_Sell=OrderTicket();//Номер ордера
                    }
              }                                 //Конец switch
           }                                    //Конец анализа ордера
        }                                       //Конец перебора орд.
      //--------------------------------------------------------- 5 --
      if (Hedg_Buy<0 || Hedg_Sell<0)            // Если нет ордера..
        {                                       // ..какого-то типа
         Alert("Все встречные ордера закрыты :)");// Сообщение
         return;                                // Выход из start()
        }
      //--------------------------------------------------------- 6 --
      while(true)                               // Цикл закрытия
        {
         //------------------------------------------------------ 7 --
         Alert("Попытка встречного закрытия. Ожидание ответа..");
         bool Ans=OrderCloseBy(Ticket_Buy,Ticket_Sell);// Закрытие
         //------------------------------------------------------ 8 --
         if (Ans==true)                         // Получилось :)
           {
            Alert ("Выполнено встречное закрытие.");
            break;                              // Выход из цикла закр
           }
         //------------------------------------------------------ 9 --
         int Error=GetLastError();              // Не получилось :(
         switch(Error)                          // Преодолимые ошибки
           {
            case  4: Alert("Торговый сервер занят. Пробуем ещё раз..");
               Sleep(3000);                     // Простое решение
               continue;                        // На след. итерацию
            case 137:Alert("Брокер занят. Пробуем ещё раз..");
               Sleep(3000);                     // Простое решение
               continue;                        // На след. итерацию
            case 146:Alert("Подсистема торговли занята. Пробуем ещё..");
               Sleep(500);                      // Простое решение
               continue;                        // На след. итерацию
           }
         switch(Error)                          // Критические ошибки
           {
            case 2 : Alert("Общая ошибка.");
               break;                           // Выход из switch
            case 64: Alert("Счет заблокирован.");
               break;                           // Выход из switch
            case 133:Alert("Торговля запрещена");
               break;                           // Выход из switch
            case 139:Alert("Ордер заблокирован и уже обрабатывается");
               break;                           // Выход из switch
            case 145:Alert("Модификация запрещена. ",
                                 "Ордер слишком близок к рынку");
               break;                           // Выход из switch
            default: Alert("Возникла ошибка ",Error);//Другие варианты
           }
         Alert ("Скрипт закончил работу --------------------------");
         return;                                // Выход из start()
        }
     }                                          // Конец цикла обработ
//-------------------------------------------------------------- 10 --
  }                                             // Конец start()
//--------------------------------------------------------------------

Алгоритм представленного скрипта несколько отличается от последних рассмотренных. Это отличие состоит в том, что для успешного закрытия нескольких ордеров (количество закрываемых ордеров не ограничено) необходимо многократно исполнить один и тот же код. Скрипт опробовался на случайном наборе рыночных ордеров. На рис. 97 представлено 5 ордеров различной стоимости.

Рис. 97. Рыночные ордера, открытые по одному финансовому инструменту.

Для того чтобы встречно закрыть имеющиеся ордера, необходимо для начала задаться критериями отбора ордеров. Таким критерием в данном алгоритме является размер ордера - сначала закрываются ордера большего объема, а затем меньшего. После встречного закрытия ордеров различного объема остаются ордера на разницу разутых ордеров. Например, в результате встречного закрытия ордера Buy в размере 1 лот и ордера Sell в размере 0.8 лотов останется ордер Buy объемом 0.2 лота. Поэтому после каждого успешного закрытия необходимо снова обратиться к (теперь уже обновлённому) набору ордеров, с тем, чтобы в этом наборе ордеров выявить два встречных ордера максимального объема.

Указанные вычисления реализованы в (условно) бесконечном цикле while в блоках 2-10. В начале этого цикла на каждой итерации делается предположение, что ордеров какого-либо типа уже не осталось. Для этого переменным Hedg_Buy и Hedg_Sell присваивается значение -1. Алгоритм блока обработки ордеров в целом сохранён (см. код closeby.mq4). В цикле перебора ордеров for, а именно в блоке 3-4, так же, как и в предыдущих программах, производится отсев "не наших" ордеров, в данном случае - открытых по другому финансовому инструменту, а также отложенных ордеров.

В блоке 4-5 для каждого из ордеров, прошедших проверку в блоке 3-4, вычисляется его объем. Если в процессе вычислений оказывается, что текущий обрабатываемый ордер имеет больший размер из всех обрабатываемых, то запоминается его тикет. Это значит, что на данной стадии вычислений ордер с этим номером является претендентом на участие в операции встречного закрытия. К моменту окончания последней итерации цикла for известны номера ордеров с максимальным количеством лотов, открытых в разных направлениях. Эти ордера и являются выбранными. Если же к этому моменту ордеров какого-либо типа уже нет, то в блоке 5-6 осуществляется выход из программы.

Блок 6-10 представляет обработку ошибок, он полностью аналогичен рассмотренным ранее (в этом и предыдущем параграфах). Формирование торгового приказа для встречного закрытия ордеров осуществляется в блоке 7-8 с помощью функции OrderCloseBy(). В случае неудачи, в зависимости от кода ошибки, управление передаётся либо на повторение попытки исполнения торговой операции (для тех же тикетов) либо оператору return, в результате чего скрипт заканчивает работу.

Если торговая операция прошла успешно, то выполняется выход из блока обработки ошибок, и заканчивается текущая итерация самого внешнего цикла обработки while. На очередной итерации этого цикла все вычисления повторяются: выполняется опрос имеющихся ордеров, отбор рыночных ордеров, выбор по одному тикету для каждого из типов ордеров, формирование торгового приказа на встречное закрытие и последующий анализ ошибок. Указанный цикл выполняется до тех пор, пока в терминале не закончатся ордера какого-либо типа (или - в частном случае - обоих типов). Это событие будет вычислено в блоке 5-6, в результате чего программа закончит работу.

При исполнении скрипта closeby.mq4 для закрытия рыночных ордеров, показанных на рис. 97, были получены такие сообщения:

Рис. 98. Сообщения, полученные при исполнении скрипта closeby.mq4.

На закладке История Счёта в Терминале видно, что некоторые ордера закрыты с нулевой прибылью. Это и есть экономия, получаемая при встречном закрытии ордеров. Сравните экономические показатели на рис. 97 и рис. 99:

Рис. 99. История Счёта после исполнения скрипта closeby.mq4.

На закладке Журнал в Терминале можно проследить историю закрытия ордеров (последние события сверху):

Рис. 100. События, произошедшие при исполнении скрипта closeby.mq4.

При исполнении скрипта в соответствии с алгоритмом закрываются ордера максимального размера, имеющиеся на текущий момент. Несмотря на то, что ордера были открыты в случайной последовательности (рис. 97), первыми в закрытии участвовали ордера Buy 778594 и Sell 778595, соответственно размером 1 лот и 0.8 лота (нижние строки на рис. 100). Объемы этих ордеров разные, поэтому в результате встречного закрытия образовался новый ордер Buy 778597 остаточного размера 0.2 лота. В дальнейшем программа выбрала для закрытия ордера Buy 778592 и Sell 778593, по 0.5 лотов каждый. Эти ордера были закрыты без остатка.

К моменту начала третьей итерации во внешнем цикле обработки в окне финансового инструмента остались два ордера: исходный ордер Sell 778596 стоимостью 0.3 лота и тот, который образовался в процессе исполнения скрипта - Buy 778597 стоимостью 0.2 лота. В верхних строках рис. 100 видно, что эти ордера тоже были закрыты встречно. Объемы этих ордеров разные, поэтому в результате исполнения последней торговой операции в окне финансового инструмента остался один рыночный ордер размером 0.1 лота (обратите внимание на экономические показатели):

Рис. 101. Ордер Sell остаточной стоимостью 0.1 лота.

Скрипт closeby.mq4 удобно использовать при ручной торговле, особенно в случаях, когда в окне финансового инструмента имеется множество разнонаправленных рыночных ордеров.

Открытие и установка ордеровМодификация ордеров


Модификация ордеров - Торговые операции - Учебник по MQL4

Учебник по MQL4 [image] Торговые операции [image] Модификация ордеров
MetaQuotes Sofware Corp.
  • Общий порядок проведения торговых операций
  • Характеристики ордеров и правила проведения торговых операций
  • Открытие и установка ордеров
  • Закрытие и удаление ордеров
  • Модификация ордеров
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Модификация ордеров

Язык MQL4 предоставляет возможность модификации рыночных и отложенных ордеров. Модификация ордеров производится в соответствии с правилами, описанными в разделе Характеристики ордеров и Приложении 3.

Функция OrderModify()

Торговые приказы для модификации рыночных и отложенных ордеров формируются с помощью функции OrderModify().

bool OrderModify(int ticket, double price, double stoploss, double takeprofit, datetime expiration, color arrow_color=CLR_NONE)

Функция изменяет параметры рыночных и отложенных ордеров. Функция возвращает TRUE при успешном исполнении торговой операции и FALSE при неудачном.

Параметры:

ticket - уникальный порядковый номер ордера.

price - новая заявленная цена для отложенного ордера или цена открытия рыночного ордера.

stoploss - новое значение StopLoss.

takeprofit - новое значение TakeProfit.

expiration - время истечения отложенного ордера.

arrow_color - цвет стрелок модификации StopLoss и/или TakeProfit на графике. Если параметр отсутствует или его значение равно CLR_NONE, то стрелки на графике не отображаются.

Замечания: цену открытия и время истечения можно изменять только для отложенных ордеров.

Если в качестве параметров функции передать неизмененные значения, то в этом случае будет сгенерирована ошибка 1 (ERR_NO_RESULT). На некоторых торговых серверах может быть установлен запрет на применение срока истечения отложенных ордеров. В этом случае при попытке задать ненулевое значение в параметре expiration будет сгенерирована ошибка 147 (ERR_TRADE_EXPIRATION_DENIED).

Модификация рыночных ордеров

Обычный рыночный ордер содержит два стоп-приказа - StopLoss и TakeProfit, - предписывающих закрытие ордера по заявленным ценам с целью ограничения убытков и фиксации прибыли. Модификация рыночных ордеров бывает полезна для изменения заявленных цен стоп-приказов либо в результате получения в программе новых расчётных значений, либо по инициативе трейдера. Клиентский терминал имеет собственное средство для модификации ордера StopLoss - Трейлинг-стоп. Этот инструмент позволяет модифицировать StopLoss, продвигая его вслед за курсом на определённом фиксированном расстоянии (см. Руководство клиентского терминала).

Функция модификации ордеров OrderModify() значительно расширяет возможности модификации: допускается изменение заявленных цен обоих стоп-приказов как в сторону приближения их к рыночной цене, так и удаление. Ограничением при модификации рыночного ордера является минимально допустимая дистанция между стоп-приказом и рыночной ценой, устанавливаемая дилинговым центром (см. Характеристики ордеров и Требования и ограничения торговых операций). В случае, если программа пытается изменить положение стоп-приказа так, что он оказывается ближе к рынку, чем на минимально допустимую дистанцию, то такой торговый приказ будет отклонён клиентским терминалом, и исполнение функции OrderModify() закончится неудачей (ошибка 130). Поэтому в программе обязательно должен быть предусмотрен блок вычислений, учитывающий это ограничение.

Пример простого эксперта, модифицирующего StopLoss всех рыночных ордеров, для которых дистанция между заявленной ценой StopLoss и рыночной котировкой оказывается больше заданной (modifystoploss.mq4)

//--------------------------------------------------------------------
// modifystoploss.mq4
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------------
extern int Tral_Stop=10;                        // Дист. преследования
//--------------------------------------------------------------- 1 --
int start()                                     // Спец. функция start
  {
   string Symb=Symbol();                        // Финанс. инструмент
//--------------------------------------------------------------- 2 --
   for(int i=1; i<=OrdersTotal(); i++)          // Цикл перебора ордер
     {
      if (OrderSelect(i-1,SELECT_BY_POS)==true) // Если есть следующий
        {                                       // Анализ ордеров:
         int Tip=OrderType();                   // Тип ордера
         if(OrderSymbol()!=Symb||Tip>1)continue;// Не наш ордер
         double SL=OrderStopLoss();             // SL выбранного орд.
         //------------------------------------------------------ 3 --
         while(true)                            // Цикл модификации
           {
            double TS=Tral_Stop;                // Исходное значение
            int Min_Dist=MarketInfo(Symb,MODE_STOPLEVEL);//Миним. дист
            if (TS < Min_Dist)                  // Если меньше допуст.
               TS=Min_Dist;                     // Новое значение TS
            //--------------------------------------------------- 4 --
            bool Modify=false;                  // Не назначен к модифи
            switch(Tip)                         // По типу ордера
              {
               case 0 :                         // Ордер Buy
                  if (NormalizeDouble(SL,Digits)< // Если ниже желаем.
                     NormalizeDouble(Bid-TS*Point,Digits))
                    {
                     SL=Bid-TS*Point;           // то модифицируем его
                     string Text="Buy ";        // Текст для Buy
                     Modify=true;               // Назначен к модифи.
                    }
                  break;                        // Выход из switch
               case 1 :                         // Ордер Sell
                  if (NormalizeDouble(SL,Digits)> // Если выше желаем.
                     NormalizeDouble(Ask+TS*Point,Digits)
                     || NormalizeDouble(SL,Digits)==0)//или равно нулю
                    {
                     SL=Ask+TS*Point;           // то модифицируем его
                     Text="Sell ";              // Текст для Sell
                     Modify=true;               // Назначен к модифи.
                    }
              }                                 // Конец switch
            if (Modify==false)                  // Если его не модифи
               break;                           // Выход из while
            //--------------------------------------------------- 5 --
            double TP    =OrderTakeProfit();    // TP выбранного орд.
            double Price =OrderOpenPrice();     // Цена выбранн. орд.
            int    Ticket=OrderTicket();        // Номер выбранн. орд.

            Alert ("Модификация ",Text,Ticket,". Ждём ответ..");
            bool Ans=OrderModify(Ticket,Price,SL,TP,0);//Модифи его!
            //--------------------------------------------------- 6 --
            if (Ans==true)                      // Получилось :)
              {
               Alert ("Ордер ",Text,Ticket," модифицирован:)");
               break;                           // Из цикла модифи.
              }
            //--------------------------------------------------- 7 --
            int Error=GetLastError();           // Не получилось :(
            switch(Error)                       // Преодолимые ошибки
              {
               case 130:Alert("Неправильные стопы. Пробуем ещё раз.");
                  RefreshRates();               // Обновим данные
                  continue;                     // На след. итерацию
               case 136:Alert("Нет цен. Ждём новый тик..");
                  while(RefreshRates()==false)  // До нового тика
                     Sleep(1);                  // Задержка в цикле
                  continue;                     // На след. итерацию
               case 146:Alert("Подсистема торгов занята.Пробуем ещё");
                  Sleep(500);                   // Простое решение
                  RefreshRates();               // Обновим данные
                  continue;                     // На след. итерацию
                  // Критические ошибки
               case 2 : Alert("Общая ошибка.");
                  break;                        // Выход из switch
               case 5 : Alert("Старая версия клиентского терминала.");
                  break;                        // Выход из switch
               case 64: Alert("Счет заблокирован.");
                  break;                        // Выход из switch
               case 133:Alert("Торговля запрещена");
                  break;                        // Выход из switch
               default: Alert("Возникла ошибка ",Error);//Др. ошибки
              }
            break;                              // Из цикла модифи.
           }                                    // Конец цикла модифи.
         //------------------------------------------------------ 8 --
        }                                       // Конец анализа орд.
     }                                          // Конец перебора орд.
//--------------------------------------------------------------- 9 --
   return;                                      // Выход из start()
  }
//-------------------------------------------------------------- 10 --

Представленная для примера программа - эксперт. В случае необходимости ничего не мешает реализовать функцию модификации ордеров и в скрипте. Однако использование обычного скрипта в данном случае не удобно - после выполнения торговых операций скрипт закончит работу. Использование скрипта может быть оправданно в том случае, если в программе реализуется выполнение разовой операции - например, открытие или закрытие ордеров. В данном случае решается задача, требующая постоянного контроля ситуации - изменить положение стоп-приказа, если выполняется некоторое условие, а именно, дистанция между рыночным курсом и заявленным значением стоп-приказа превышает некоторую заданную величину (в нашем случае 10 пунктов). Для длительного использования гораздо удобнее использовать эксперт, который запускается на исполнение на каждом тике, а прекращает работу только в результате прямого указания пользователя.

Алгоритм представленного эксперта modifystoploss.mq4 очень прост. Основные вычисления выполняются в цикле перебора ордеров (блок 2-9). Выбор ордера ведётся среди рыночных и отложенных ордеров (параметр pool в вызове функции OrderSelect() не указан явно). В блоке 2-3 отсортировываются отложенные ордера, а также ордера, открытые по другому финансовому инструменту; для ордеров, прошедших отбор, определяется значение StopLoss.

Блок 3-9 представляет цикл модификации выбранного ордера. В блоке 3-4 определяется новое текущее значение ограничивающей дистанции (брокер может изменить это значение в любой момент). В блоке 4-5 вычисляется необходимость модификации отобранного ордера (текущего обрабатываемого в цикле for), а также новое значение StopLoss. Если текущий ордер не требует модификации, то в конце блока 4-5 осуществляется выход из цикла while, и модификация этого ордера (в блоке 5-6) не осуществляется. Если же ордер требует модификации, то управление передаётся в блок 5-6, в котором вычисляются необходимые параметры и выполняется обращение к функции OrderModify(), которая и формирует торговый приказ.

Если торговая операция завершилась успешно, то оператор break в блоке 6-7 заканчивает исполнение цикла while, что приводит к окончанию текущей итерации цикла перебора ордеров for (и на следующей итерации начинается обработка очередного ордера). Если же торговая операция закончилась неудачей, то производится обработка ошибок. В случае, когда ошибка оказывается не критической, попытка повторить торговую операцию повторяется. Если же ошибка оценивается как критическая, то управление передаётся за пределы цикла модификации для обработки следующего ордера (в цикле for).

Здесь необходимо обратить внимание на небольшую особенность, касающуюся модификации рыночных ордеров. Функция OrderModify() устанавливает новые значения цен одновременно для обоих стоп-приказов. При этом требование соблюдения минимальной дистанции касается только того стоп-приказа, новое значение которого отличается от текущего. Если же новое значение остаётся таким же, как текущее, то такой стоп-приказ может находиться на любом расстоянии от рыночной цены, а соответствующий торговый приказ является корректным.

Например, имеется рыночный ордер Buy, открытый по цене 1.295467, со стоп-приказами StopLoss = 1.2958 и TakeProfit = 1.2960. Минимальная дистанция, установленная брокером, равна 5 пунктов. При рыночной цене Bid = 1.2959 возникают условия для модификации ордера, а именно для установки StopLoss = 1.2949 (Bid - 10 пунктов). Для исполнения функции OrderModify() требуется указать и новое значение TakeProfit. Наш советник не изменяет положение TakeProfit, поэтому в функции задаётся текущее значение TakeProfit = 1.2960.

Несмотря на то, что новое заявленное значение TakeProfit = 1.2960 находится близко к рыночной цене Bid (всего 1 пункт, т.е меньше допустимой дистанции 5 пунктов), это значение не отличается от текущего значения TakeProfit = 1.2960, поэтому торговый приказ будет признан корректным и исполнен на сервере (в общем случае торговый приказ может быть отклонён, но по другим причинам). На рис. 102 и 103 представлены результаты успешной модификации ордера в этой ситуации.

Рис. 102. Вид окна сообщений и окна финансового инструмента при модификации ордера экспертом modifystoploss.mq4 в момент, когда рыночный курс находится вблизи от заявленного значения TakeProfit.

Рис. 103. Модифицированный ордер в окне Терминала.

На Рис. 103 видно, что в результате модификации новое значение StopLoss = 1.2949, а текущая цена Bid = 1.2959 находится на расстоянии 1 пункта от значения TakeProfit.

Отдельно нужно заметить, что сама по себе модификация (и рыночных и отложенных) ордеров в отрыве от анализа рыночной ситуации производиться не должна. Подобная модификация может быть полезна только в случае резкого и однонаправленного движения рыночного курса, которое случается в результате выхода важных новостей. Если же торговля ведётся на "обычном" рынке, то решение о необходимости модификации ордеров должно приниматься на основе рыночных критериев. В эксперте modifystoploss.mq4 тоже используется критерий (StopLoss от рыночной цены дальше желаемого), по которому принимается решение о модификации, однако он слишком простой и жёсткий, поэтому не может рассматриваться как критерий, характеризующий рыночную ситуацию.

Модификация отложенных ордеров

Модификация отложенных ордеров несколько отличается от модификации рыночных. Существенное отличие состоит в том, что возможно изменить заявленную цену самого ордера. Обязательно соблюдение правил, ограничивающих положение отложенного ордера относительно рыночной цены и стоп-приказов ордера относительно заявленной цены ордера (см. Характеристики ордеров и Требования и ограничения торговых операций). При этом все характеристики отложенного ордера оцениваются как вновь заявленные, независимо от предыдущей истории событий, связанных с этим ордером.

Например, имеется отложенный ордер BuyStop = 1.2030, имеющий StopLoss = 1.2025 и TakeProfit = 1.2035. Минимально допустимая дистанция установлена брокером в размере 5 пунктов. Нетрудно заметить, что стоп-приказы ордера стоят на допустимой границе, поэтому любая модификация заявленной цены открытия ордера повлечёт обязательную модификацию по крайней мере одного из стоп-приказов. Если же будет сформирован торговый приказ, в соответствии с которым предполагается изменить заявленную цену ордера, а значения стоп-приказов оставить без изменения, то такой торговый приказ будет признан клиентским терминалом как ошибочный и не будет отправлен на сервер для исполнения. Например, если в торговом приказе указаны значения BuyStop = 1. 2028, StopLoss = 1.2025 и TakeProfit = 1.2035, то этот торговый приказ является ошибочным, несмотря на то, что значения стоп-приказов не изменились - в данном случае нарушено правило соблюдения минимальной дистанции между заявленной ценой открытия ордера и ценой одного из стоп-приказов (см. Требования и ограничения торговых операций).

Посмотрим, как может выглядеть скрипт, модифицирующий отложенный ордер для приближения заявленной цены ордера к рыночной цене на некоторое заданное расстояние. Зададим расстояние 10 пунктов. Для указания программе ордера, назначенного к модификации (в окне может находиться несколько отложенных ордеров), используем цену прикрепления скрипта в окно финансового инструмента.

Пример простого скрипта, модифицирующего отложенный ордер, заявленная цена которого находится ближе к месту прикрепления скрипта, чем цены других отложенных ордеров (modifyorderprice.mq4).

//--------------------------------------------------------------------
// modifyorderprice.mq4
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------- 1 --
int start()                                     // Спец.функция start
  {
   int Tral=10;                                 // Дист. приближения
   string Symb=Symbol();                        // Финанс. инструмент
   double Dist=1000000.0;                       // Предустановка
   double Win_Price=WindowPriceOnDropped();     // Здесь брошен скрипт
//--------------------------------------------------------------- 2 --
   for(int i=1; i<=OrdersTotal(); i++)          // Цикл перебора ордер
     {
      if (OrderSelect(i-1,SELECT_BY_POS)==true) // Если есть следующий
        {                                       // Анализ ордеров:
         //------------------------------------------------------ 3 --
         if (OrderSymbol()!= Symb) continue;    // Не наш фин.инструм.
         if (OrderType()<2) continue;           // Рыночный ордер
         //------------------------------------------------------ 4 --
         if(NormalizeDouble(MathAbs(OrderOpenPrice()-Win_Price),Digits)
            < NormalizeDouble(Dist,Digits))     // Выбираем ближайший
           {
            Dist=MathAbs(OrderOpenPrice()-Win_Price);// Новое значение
            int    Tip   =OrderType();          // Тип выбранного орд.
            int    Ticket=OrderTicket();        // Номер выбранн. орд.
            double Price =OrderOpenPrice();     // Цена выбранн. орд.
            double SL    =OrderStopLoss();      // SL выбранного орд.
            double TP    =OrderTakeProfit();    // TP выбранного орд.
           }                                    // Конец if
        }                                       // Конец анализа ордера
     }                                          // Конец перебора орд.
//--------------------------------------------------------------- 5 --
   if (Tip==0)                                  // Если отложенных нет
     {
      Alert("По ",Symb," отложенных ордеров нет");
      return;                                   // Выход из программы
     }
//--------------------------------------------------------------- 6 --
   while(true)                                  // Цикл закрытия орд.
     {
      RefreshRates();                           // Обновим данные
      //--------------------------------------------------------- 7 --
      double TS=Tral;                           // Исходное значение
      int Min_Dist=MarketInfo(Symb,MODE_STOPLEVEL);//Миним. дистанция
      if (TS < Min_Dist)                        // Если меньше допуст.
         TS=Min_Dist;                           // Новое значение TS
      //--------------------------------------------------------- 8 --
      string Text="";                           // Не назначен к модифи
      double New_SL=0;
      double New_TP=0;
      switch(Tip)                               // По типу ордера
        {
         case 2:                                // BuyLimit
            if (NormalizeDouble(Price,Digits) < // Если дальше, чем на
                NormalizeDouble(Ask-TS*Point,Digits))//..заданное знач
              {
               double New_Price=Ask-TS*Point;   // Новая его цена
               if (NormalizeDouble(SL,Digits)>0)
                  New_SL=New_Price-(Price-SL);  // Новый StopLoss
               if (NormalizeDouble(TP,Digits)>0)
                  New_TP=New_Price+(TP-Price);  // Новый TakeProfit
               Text= "BuyLimit ";               // Будем его модифи.
              }
            break;                              // Выход из switch
         case 3:                                // SellLimit
            if (NormalizeDouble(Price,Digits) > // Если дальше, чем на
                NormalizeDouble(Bid+TS*Point,Digits))//..заданное знач
              {
               New_Price=Bid+TS*Point;          // Новая его цена
               if (NormalizeDouble(SL,Digits)>0)
                  New_SL=New_Price+(SL-Price);  // Новый StopLoss
               if (NormalizeDouble(TP,Digits)>0)
                  New_TP=New_Price-(Price-TP);  // Новый TakeProfit
               Text= "SellLimit ";              // Будем его модифи.
              }
            break;                              // Выход из switch
         case 4:                                // BuyStopt
            if (NormalizeDouble(Price,Digits) > // Если дальше, чем на
                NormalizeDouble(Ask+TS*Point,Digits))//..заданное знач
              {
               New_Price=Ask+TS*Point;          // Новая его цена
               if (NormalizeDouble(SL,Digits)>0)
                  New_SL=New_Price-(Price-SL);  // Новый StopLoss
               if (NormalizeDouble(TP,Digits)>0)
                  New_TP=New_Price+(TP-Price);  // Новый TakeProfit
               Text= "BuyStopt ";               // Будем его модифи.
              }
            break;                              // Выход из switch
         case 5:                                // SellStop
            if (NormalizeDouble(Price,Digits) < // Если дальше, чем на
                NormalizeDouble(Bid-TS*Point,Digits))//..заданное знач
              {
               New_Price=Bid-TS*Point;          // Новая его цена
               if (NormalizeDouble(SL,Digits)>0)
                  New_SL=New_Price+(SL-Price);  // Новый StopLoss
               if (NormalizeDouble(TP,Digits)>0)
                  New_TP=New_Price-(Price-TP);  // Новый TakeProfit
               Text= "SellStop ";               // Будем его модифи.
              }
        }
      if (NormalizeDouble(New_SL,Digits)<0)     // Проверка SL
         New_SL=0;
      if (NormalizeDouble(New_TP,Digits)<0)     // Проверка TP
         New_TP=0;
      //--------------------------------------------------------- 9 --
      if (Text=="")                             // Если его не модифи
        {
         Alert("Нет условий для модификации.");
         break;                                 // Выход из while
        }
      //-------------------------------------------------------- 10 --
      Alert ("Модификация ",Text,Ticket,". Ждём ответ..");
      bool Ans=OrderModify(Ticket,New_Price,New_SL,New_TP,0);//Модифи!
      //-------------------------------------------------------- 11 --
      if (Ans==true)                            // Получилось :)
        {
         Alert ("Модифицирован ордер ",Text," ",Ticket," :)");
         break;                                 // Выход из цикла закр
        }
      //-------------------------------------------------------- 12 --
      int Error=GetLastError();                 // Не получилось :(
      switch(Error)                             // Преодолимые ошибки
        {
         case  4: Alert("Торговый сервер занят. Пробуем ещё раз..");
            Sleep(3000);                        // Простое решение
            continue;                           // На след. итерацию
         case 137:Alert("Брокер занят. Пробуем ещё раз..");
            Sleep(3000);                        // Простое решение
            continue;                           // На след. итерацию
         case 146:Alert("Подсистема торговли занята. Пробуем ещё..");
            Sleep(500);                         // Простое решение
            continue;                           // На след. итерацию
        }
      switch(Error)                             // Критические ошибки
        {
         case 2 : Alert("Общая ошибка.");
            break;                              // Выход из switch
         case 64: Alert("Счет заблокирован.");
            break;                              // Выход из switch
         case 133:Alert("Торговля запрещена");
            break;                              // Выход из switch
         case 139:Alert("Ордер заблокирован и уже обрабатывается");
            break;                              // Выход из switch
         case 145:Alert("Модификация запрещена. ",
                              "Ордер слишком близок к рынку");
            break;                              // Выход из switch
         default: Alert("Возникла ошибка ",Error);//Другие варианты
        }
      break;                                    // Выход из цикла закр
     }                                          // Конец цикла закр.
//-------------------------------------------------------------- 13 --
   Alert ("Скрипт закончил работу -----------------------");
   return;                                      // Выход из start()
  }
//-------------------------------------------------------------- 14 --

Расстояние между рыночной ценой и заявленной ценой отложенного ордера задано в переменной Tral. Переменная Win_Price содержит значение цены, на которой в окно финансового инструмента прикреплён скрипт. В цикле перебора ордеров (блок 2-5) вычисляются характеристики отложенного ордера, находящегося ближе других к месту прикрепления скрипта. Блок 6-13 представляет цикл закрытия ордеров. В блоке 8-9 определяется, нужно ли модифицировать выбранный ордер, и, если необходимо, вычисляются новые значения заявленной цены и стоп-приказов. Приказ на модификацию отдаётся с помощью функции OrderModify() в блоке 10-11. В блоке 11-13 реализована обработка ошибок.

Блок 8-9 состоит из четырёх однотипных блоков, в которых вычисляются новые значения отложенного ордера, используемые в торговом приказе. Рассмотрим один из них, для ордера SellLimit:

         case 3:                                // SellLimit
            if (NormalizeDouble(Price,Digits) > // Если дальше, чем на
                NormalizeDouble(Bid+TS*Point,Digits))//..заданное знач
               {
                New_Price=Bid+TS*Point;         // Новая его цена
                if (NormalizeDouble(SL,Digits)>0)
                  New_SL = New_Price+(SL-Price);// Новый StopLoss
                if (NormalizeDouble(TP,Digits)>0)
                  New_TP = New_Price-(Price-TP);// Новый TakeProfit
                Text= "SellLimit ";             // Будем его модифи.
               }
            break;                              // Выход из switch

Новые параметры ордера вычисляются только в том случае, если текущая цена Price находится дальше от текущей рыночной цены Bid, чем на желаемую дистанцию TS. Если это так, то управление передаётся в тело оператора if, где вычисляется новая цена открытия ордера New_Price. Новые значения StopLoss и TakeProfit вычисляются только для ненулевых значений. При этом дистанции между заявленной ценой ордера и каждой ценой стоп-приказа сохраняется неизменной.

Например, ордер SellLimit установлен по цене 1.2050, его StopLoss = 1.2073, а TakeProfit = 1. 2030. Допустим, в результате вычислений новая цена открытия ордера равна 1.2040. В этом случае новые значения стоп-приказов будут такими: StopLoss = 1.2063, а TakeProfit = 1. 2020. Таким образом, в результате работы программы ордер модифицируется "целиком" - все три основных параметра (цена открытия, StopLoss и TakeProfit) одновременно смещаются вниз, сохраняя при этом дистанцию между собой.

В конце блока 8-9 выполняется проверка новых значений стоп-приказов на отрицательные значения. Эта проверка полезна для того случая, если ранее установленный (другой программой или вручную) стоп-приказ находился близко к нулевой цене, например, на 1 пункт выше нуля. В этом случае при смещении ордера вниз на расстояние более одного пункта новая цена одного из стоп-приказов получит отрицательное значение. Если это значение было бы заявлено в торговом приказе, то он был бы отклонён клиентским терминалом.

Здесь необходимо отметить недостаток подобных небольших программ - как скриптов, так и экспертов. Представленная программа modifyorderprice.mq4 очень ограничена в выборе действий. Модифицируемый ордер может быть смещён только в одном направлении - в сторону рыночного курса, при этом его стоп-приказы жёстко "привязаны" к ордеру. Эта программа не приспособлена для модификации заявленной цены ордера в противоположную сторону от рыночной цены, в ней также не реализована возможность изменения положения отдельно взятого какого-либо из стоп-приказов.

Указанная ограниченность диктуется прежде всего количеством используемых управляющих средств. В данной программе такое средство всего одно - место прикрепления скрипта в окно финансового инструмента. Используя этот параметр, пользователь может по своему выбору назначить к модификации любой из ордеров. Но этим инициатива пользователя и ограничена. Для более эффективной работы пользователю необходимы дополнительные средства, чтобы иметь возможность воздействовать на другие параметры ордеров.

Решение подобных задач вполне реализуемо средствами языка MQL4, однако для этой цели необходимо использовать другой - более "интеллектуальный" - алгоритм. Возможно создать программу механизации торговли, которая позволила бы модифицировать ордера в соответствии с пожеланиями пользователя. В качестве дополнительных средств управления для ручной торговли в такой программе можно применить, например, графические объекты.

Закрытие и удаление ордеровПростые программы на MQL4


Характеристики ордеров и правила проведения торговых операций - Торговые операции - Учебник по MQL4

Учебник по MQL4 [image] Торговые операции [image] Характеристики ордеров и правила проведения торговых операций
MetaQuotes Sofware Corp.
  • Общий порядок проведения торговых операций
  • Характеристики ордеров и правила проведения торговых операций
  • Открытие и установка ордеров
  • Закрытие и удаление ордеров
  • Модификация ордеров
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Характеристики ордеров и правила проведения торговых операций

Перед тем как приступить к использованию торговых функций, необходимо рассмотреть параметры, характеризующие рыночные цены, типы ордеров и их характеристики, а также правила проведения торговых операций.

Характеристики финансовых инструментов

Прежде всего, необходимо указать на принцип, используемый брокерскими компаниями для формирования цен по финансовым инструментам. Этот принцип состоит в том, что для проведения торговых операций брокер предлагает трейдеру двухстороннюю котировку.

Двухсторонняя котировка - связанная пара рыночных цен, предлагаемых брокером для осуществления покупки и продажи активов по финансовому инструменту в текущий момент.

Bid - меньшая из цен в двухсторонней котировке по финансовому инструменту, предлагаемая брокером.

Ask - большая из цен в двухсторонней котировке по финансовому инструменту, предлагаемая брокером.

Пункт - единица измерения цены по финансовому инструменту (минимально возможное изменение цены, последняя значащая цифра в значении цены).

Спред - разница между большей и меньшей ценой в двухсторонней котировке по финансовому инструменту, выраженная в пунктах.

Спред обычно является фиксированной величиной. В MetaTrader 4 принято правило, в соответствии с которым в окне финансового инструмента изображается график цены, отражающий динамику изменения цены Bid:

Рис. 68. Обычный график цены по финансовому инструменту.

На рис. 68 показано окно финансового инструмента, в котором можно наблюдать график изменения цены Bid и двухстороннюю котировку - линию текущей цены Bid (чёрного цвета, 1.3005) и линию текущей цены Ask (красного цвета, 1.3007). Легко увидеть, что в данном случае брокер предлагает спред, равный 2 пунктам. На графике не отражена история цены по Ask, но она подразумевается и может быть легко посчитана для любого момента времени.

Типы и характеристики ордеров

Всего различаются шесть типов ордеров - два рыночных и четыре отложенных.

Buy - рыночный ордер, определяющий покупку активов по финансовому инструменту.

Sell - рыночный ордер, определяющий продажу активов по финансовому инструменту.

BuyLimit - отложенный ордер на покупку активов по финансовому инструменту по цене ниже текущей. Ордер исполнится (преобразуется в рыночный ордер Buy), если цена Ask достигнет или окажется ниже цены, заявленной в ордере.

SellLimit - отложенный ордер на продажу активов по финансовому инструменту по цене, превышающей текущую цену. Ордер исполнится (преобразуется в рыночный ордер Sell), если цена Bid достигнет или окажется выше цены, заявленной в ордере.

BuyStop - отложенный ордер на покупку активов по финансовому инструменту по цене, превышающей текущую цену. Ордер исполнится (преобразуется в рыночный ордер Buy), если цена Ask достигнет или окажется выше цены, заявленной в ордере.

SellStop - отложенный ордер на продажу активов по финансовому инструменту по цене ниже текущей. Ордер исполнится (преобразуется в рыночный ордер Sell), если цена Bid достигнет или окажется ниже цены, заявленной в ордере.

Lots - размер ордера, выраженный в количестве лотов.

StopLoss - стоп-приказ; заявленная цена, по которой рыночный ордер будет закрыт при движении цены финансового инструмента в сторону убытков по ордеру.

TakeProfit - стоп-приказ; заявленная цена, по которой рыночный ордер будет закрыт при движении цены финансового инструмента в сторону прибыли по ордеру.

Требования и ограничения при проведении торговых операций

Для правильного формирования торговых приказов в прикладных программах (экспертах и скриптах) необходимо принимать во внимание имеющиеся требования и ограничения. Рассмотрим их подробно.

Все торговые операции осуществляются по правильным ценам. Цена исполнения для каждой торговой операции вычисляется на основе правильной цены двухсторонней котировки.

Указанное правило является всеобщим для всех участников рынка и не может быть изменено по воле разработчиков торговой платформы или на основе договорённости между брокером и трейдером. Это значит, например, что открытие рыночного ордера осуществляется только по текущей рыночной цене и не может быть выполнено по любой другой цене. Порядок расчёта правильных цен для различных торговых операций рассматривается ниже.

При расчёте правильных цен необходимо учитывать также ограничения, накладываемые поставщиком услуг (дилинговым центром). К таким ограничениям относятся минимальная дистанция и дистанция заморозки. Сущность этих ограничений состоит в том, чтобы предоставить брокеру возможность подготовиться к исполнению новых торговых операций, будь то преобразование отложенного ордера в рыночный или закрытие ордера в результате исполнения стоп-приказа.

Дилинговые центры ограничивают значение минимально допустимой разницы между рыночной ценой и заявленной ценой каждого из стоп-приказов рыночного ордера, между рыночной ценой и заявленной ценой отложенного ордера, а также между заявленной ценой отложенного ордера и заявленными ценами его стоп-приказов. Это значит, например, что в торговом приказе на открытие рыночного ордера могут быть заявлены только такие значения цен стоп-приказов, которые удалены от текущей рыночной цены не менее, чем на минимальную дистанцию. Торговый приказ, в котором цены стоп-приказов заявлены ближе к рыночной цене, чем на минимальную дистанцию, расценивается клиентским терминалом как ошибочный. Разные дилинговые центры могут устанавливать различные, свойственные только им, ограничения минимальной дистанции. Как правило, размер минимальной дистанции колеблется от 1 до 15 пунктов. Для наиболее распространённых финансовых инструментов (EUR/USD, GBP/USD, EUR/CHF и пр.) эта дистанция у большинства дилинговых центров обычно составляет 3 - 5 пунктов. Разные финансовые инструменты также могут иметь разные значения минимальной дистанции, например, для золота это значение может составлять 50-100 пунктов. Значение минимальной дистанции для любого финансового инструмента может быть изменено брокером в любое время (обычно это происходит перед выходом важных экономических новостей). Аналогичных правил для ограничения максимальной дистанции не существует.

Дистанция заморозки ограничивает возможность модификации заявленных цен открытия отложенных ордеров, а также заявленных цен стоп-приказов рыночных ордеров, которые находятся в зоне заморозки. Это значит, например, что если рыночная цена =1.3800, имеется отложенный ордер заявленной ценой открытия 1.3807 и брокером установлено значение = 10, то отложенный ордер находится в зоне заморозки, т.е. его нельзя ни удалить, ни модифицировать. При спокойном рынке заморозка обычно не устанавливается, т.е. = 0. В период, предшествующий выходу важных новостей, а также при большой волатильности брокер может установить некоторое значение дистанции заморозки. При различных условиях и у разных брокеров это значение может составлять приблизительно от 1 до 30 пунктов по основным финансовым инструментам и принимать большие значения по другим инструментам. Брокер может изменить значение дистанции заморозки по своему усмотрению в любое время.

Предельно допустимые ценовые уровни, ограниченные значениями минимальной дистанции и дистанции заморозки, рассчитываются от правильных цен.

Открытие и закрытие рыночных ордеров

Открытие рыночного ордера предполагает покупку или продажу активов по финансовому инструменту по рыночным ценам, сложившимся на текущий момент (см. Требования и ограничения торговых операций). Для открытия рыночных ордеров используются функции OrderSend( ), а для закрытия - функция OrderClose( ).

Правильной ценой открытия рыночного ордера Buy является последняя известная рыночная цена Ask.
Правильной ценой открытия рыночного ордера Sell является последняя известная рыночная цена Bid.
Ограничение, связанное с положением стоп-приказов открываемого рыночного ордера, рассчитывается от правильной рыночной цены, применяемой для закрытия ордера.
StopLoss и TakeProfit ордера не могут быть установлены ближе к рыночной цене, чем на минимальную дистанцию.

Например, минимальная дистанция для EUR/USD составляет 5 пунктов. Рыночный ордер Sell открывается по цене Bid=1.2987. Соответствующей ценой двухсторонней котировки, применяемой для закрытия ордера Sell, является Ask=1.2989. Наиболее приближенными к текущей цене в момент открытия ордера будут следующие значения стоп-приказов (см. рис. 69 и Требования и ограничения торговых операций):

StopLoss = Ask + минимальная дистанция = 1.2989 + 0.0005 = 1.2994

TakeProfit = Ask - минимальная дистанция = 1.2989 - 0.0005 = 1.2984.

Рис. 69. Рыночный ордер Sell со стоп-приказами, максимально приближенными к рыночной цене.

Если при формировании торгового приказа для открытия рыночного ордера Sell по цене Bid=1.2987 будут использоваться значения стоп-приказов ближе указанных (SL=1.2994 и ТР=1.2984), то такой торговый приказ будет отклонён клиентским терминалом. Кроме того, необходимо учитывать, что при открытии ордеров возможно проскальзывание цены, в результате чего ордер может быть открыт по цене, отличающейся от заявленной на некоторую допустимую величину, указанную трейдером в торговом приказе. Если в этом же торговом приказе указаны значения стоп-приказов, максимально приближенные к заявленной цене открытия, то такой торговый приказ тоже будет отклонён клиентским терминалом, т.к. в этом случае не будет соблюдено требование минимально допустимой дистанции между ценой открытия ордера и заявленной ценой одного из стоп-приказов. Поэтому в торговых приказах для открытия рыночных ордеров не рекомендуется использовать значения стоп-приказов, максимально приближенные к заявленной цене открытия ордера. Напротив, рекомендуется иметь некоторый запас, т.е. указывать такие значения стоп-приказов, которые удалены от заявленной цены открытия ордера на 1-2 пункта дальше, чем на величину минимально допустимой дистанции.

Закрытие рыночных ордеров может происходить в результате исполнения торгового приказа, отданного трейдером или программой, а также при достижении ценой одной из цен, заявленных в стоп-приказах ордера.

Правильной ценой закрытия рыночного ордера Buy является последняя известная рыночная цена Bid.
Правильной ценой закрытия рыночного ордера Sell является последняя известная рыночная цена Ask.

Если ордер Sell (рис. 69) закрыть в текущий момент, то он будет закрыт по цене Ask=1.2989, т.е. с убытком 2 пункта. Если же этот ордер оставить на некоторое время открытым, при этом рыночная цена Ask опустится до значения 1.2984, ордер будет закрыт по этой цене с прибылью в 3 пункта. Если же рыночная цена поднимется и достигнет значения Ask = 1.2994, то ордер будет закрыт по этой цене с убытком 7 пунктов.

Если прикладная программа сформировала торговый приказ на открытие или закрытие рыночного ордера по цене, не соответствующей последней известной рыночной цене, то такой торговый приказ будет отклонён клиентским терминалом.

Ограничение, связанное с закрытием рыночных ордеров, рассчитывается от правильной рыночной цены, применяемой для закрытия ордера.
Ордер не может быть закрыт, если цена исполнения его StopLoss или TakeProfit находится в пределах дистанции заморозки от рыночной цены.

Например, ордер, представленный на рис. 69, может быть закрыт только в том случае, если установленное брокером значение дистанции заморозки на момент закрытия будет составлять 4 пункта или меньше. Цена открытия ордера в данном случае не имеет значения. Границы коридора заморозки для ордера рассчитываются от рыночной цены. Поэтому, если = 4, то цена верхней границы заморозки равна + = 1.2989 + 0.0004 = 1.2993, а цена нижней границы, соответственно, - = 1.2989 - 0.0004 = 1.2985. При этих условиях ни один из стоп-приказов ордера не находится в коридоре заморозки, поэтому ордер может быть закрыт, если трейдер (или программа) отправит на сервер корректный торговый приказ. В случае если на текущий момент брокером установлено значение = 5, то границы коридора заморозки будут соответственно 1.2994 и 1.2984. В этом случае каждый из стоп-приказов оказывается на границе заморозки, т.е. попадает под ограничение, установленное брокером, поэтому ордер не может быть закрыт по инициативе трейдера или по приказу торгующей программы. В данном примере одновременно оба стоп-приказа подпадают под ограничение. В общем случае рыночный ордер не может быть закрыт по инициативе со стороны клиентского терминала, если хотя бы один из стоп-приказов этого ордера находится в зоне заморозки.

Если по одному финансовому инструменту одновременно открыто два рыночных ордера, один из которых Buy, а другой Sell, то их можно закрыть одним из двух способов: последовательно, один за другим, закрыть ордера, используя OrderClose(), или выполнить встречное закрытие (один за счёт другого) с помощью OrderCloseBy(). С точки зрения экономической выгоды предпочтителен второй вариант - при встречном закрытии ордеров экономится один спред. Более подробно использование торговых функций рассматривается в последующем изложении.

Установка и удаление отложенных ордеров

Отложенный ордер предполагает наличие заявленной цены открытия ордера, не совпадающей с текущей рыночной ценой. Для установки отложенных ордеров используются функция OrderSend(), а для удаления - OrderDelete().

Отложенные ордера SellLimit и BuyStop устанавливаются выше текущей рыночной цены, а BuyLimit и SellStop - ниже текущей рыночной цены.

Ограничение, связанное с положением устанавливаемого отложенного ордера, рассчитывается от правильной рыночной цены преобразования отложенного ордера в рыночный.
Отложенные ордера BuyLimit, BuyStop, SellLimit и SellStop не могут быть установлены ближе к рыночной цене, чем на минимальную дистанцию.

Например, для того чтобы рассчитать предельно допустимую минимальную цену для ордера BuyStop, необходимо прибавить к последней известной цене Ask значение минимальной дистанции. Если StopLevel= 5, то предельно допустимая цена для установки отложенного ордера BuyStop составляет 1.3003+0.0005 = 1.3008 (см. рис. 70). Это значит, что ордер BuyStop может быть установлен в текущий момент по заявленной цене 1.3008 или большей цене. В данном примере BuyStop установлен по цене 1.3015, что вполне допустимо.

Рис. 70. Отложенные ордера устанавливаются ниже или выше текущей цены.

Заявленная цена отложенного ордера BuyStop равна 1.3015.

Заявленная цена отложенного ордера SellLimit равна 1.3012.

Заявленная цена отложенного ордера SellStop равна 1.2995.

Заявленная цена отложенного ордера BuyLimit равна 1.2993.

В данном примере все ордера были установлены на нулевом баре в момент, показанный на рис. 70, при этом минимальная дистанция для установки отложенного ордера составляла 5 пунктов. Наиболее близким к рыночному курсу является отложенный ордер SellStop. В данном случае Bid = 1.3001, а заявленная цена SellStop = 1.2995. Таким образом, дистанция между ордером и правильной ценой двухсторонней котировки (Bid) составляет 6 пунктов (1.3001 - 1.2995), т.е. больше минимально допустимой дистанции. Это значит, что при открытии ордера (также и всех других ордеров в этом примере) торговый приказ был одобрен клиентским терминалом и отправлен на сервер, где, в свою очередь, также была проведена необходимая проверка и принято решение об исполнении торгового приказа на установку отложенного ордера (см. Требования и ограничения торговых операций).

Положение стоп-приказов отложенных ордеров также ограничивается минимальной дистанцией:

Ограничение, связанное с положением стоп-приказов отложенного ордера, рассчитывается от заявленной цены открытия отложенного ордера и никак не связано с рыночными ценами.
StopLoss и TakeProfit любого отложенного ордера не могут быть установлены ближе к заявленной цене открытия, чем на минимальную дистанцию.
Положение StopLoss и TakeProfit отложенных ордеров дистанцией заморозки не ограничивается.

На рис. 71 показан отложенный ордер SellLimit, стоп-приказы которого максимально приближены к заявленной цене ордера. В данном случае: заявленная цена ордера = 1.2944, StopLoss=1.2949, TakeProfit=1.2939. При минимальной дистанции 5 пунктов это допустимые значения.

Рис. 71. Отложенный ордер со стоп-приказами, максимально приближенными к ордеру.

В данном примере отложенный ордер SellLimit был открыт в 18:07. На рис. 71 видно, что в дальнейшем рыночная цена достигла и пересекла один из его стоп-приказов и впоследствии снова понизилась. Это событие не оказало никакого влияния на ордер: стоп-приказ являет собой приказ на закрытие рыночного ордера, т.е. вступает в силу только с того момента, когда отложенный ордер преобразуется в рыночный. В данном случае ордер не был преобразован в рыночный (т.к. цена Bid не достигла заявленной цены открытия ордера), поэтому пересечение ценой стоп-приказа не привело ни к каким изменениям.

Ограничение, связанное с удалением отложенных ордеров, рассчитывается от правильной рыночной цены, применяемой для преобразования отложенного ордера в рыночный.
Отложенные ордера BuyLimit, BuyStop, SellLimit и SellStop не могут быть удалены, если заявленная цена открытия ордера находится в пределах дистанции заморозки от рыночной цены.

Ордер SellLimit может быть удалён в момент, представленный на рис. 71, по инициативе со стороны клиентского терминала только в случае, если установленное на этот момент значение = 8 или менее пунктов. В этом случае верхняя граница коридора заморозки (рассчитываемая для SellLimit) составляет: + = 1.2935 +0.0008 = 1.2943. Заявленная цена открытия ордера составляет 1.2944, т.е. ордер установлен за пределами коридора заморозки и может быть удалён. Если же брокер установит значение большее, чем 8 пунктов, то отложенный ордер SellLimit удалён быть не может, а клиентский терминал отклонит торговый приказ.

Преобразование отложенных ордеров в рыночные

Преобразование отложенных ордеров в рыночные происходит на сервере автоматически, поэтому никаких функций для исполнения этой торговой операции не предусмотрено (см. Требования и ограничения торговых операций).

Отложенные ордера BuyLimit и BuyStop преобразуются в рыночные, если последняя известная цена Ask достигнет заявленной цены отложенного ордера.
Отложенные ордера SellLimit и SellStop преобразуются в рыночные, если последняя известная цена Bid достигнет заявленной цены отложенного ордера.

О ранее установленных отложенных ордерах (рис. 70) можно сказать следующее.

Отложенный ордер BuyStop преобразуется в рыночный ордер Buy, если текущая цена Ask достигнет значения 1.3015.

Отложенный ордер SellLimit преобразуется в рыночный ордер Sell, если текущая цена Bid достигнет значения 1.3012.

Отложенный ордер SellStop преобразуется в рыночный ордер Sell, если текущая цена Bid достигнет значения 1.2995.

Отложенный ордер BuyLimit преобразуется в рыночный ордер Buy, если текущая цена Ask достигнет значения 1.2993.

Последующие события, касающиеся этих ордеров, отображены на рис. 72-74.

Рис. 72. Преобразование отложенных ордеров в рыночные.

В более поздней истории были преобразованы в рыночные и 2 других отложенных ордера.

Рис. 73. Преобразование отложенных ордеров в рыночные.

Рис. 74. Отражение преобразованных (теперь рыночных) ордеров в окне терминала.

Обратите внимание, на рис. 73 показано открытие ордера Buy 4210322 (бывшего отложенного ордера BuyStop). Легко заметить, что бар, образованный в 18:55, не касается цены 1.3015. Максимальное значение цены в этом баре достигает значения 1.3013. Вместе с тем, в окне терминала (рис. 74) показано, что время преобразования отложенного ордера в рыночный произошло именно на этом баре, т.е. в 18:55.

Здесь необходимо ещё раз подчеркнуть, что в окне финансового инструмента отображается только история рыночных курсов по меньшей цене двухсторонней котировки, а именно, история Bid. История Ask не отображается. По этой причине может сложиться впечатление, что преобразование отложенного ордера в рыночный произошло ошибочно. В действительности в данном случае ошибки нет. В тот момент, когда цена Bid была равна 1.3013, цена Ask составляла 1.3013 + 2 = 1.3015 (2 = спред 2 пункта). Таким образом, касание рыночной ценой заявленной цены ордера произошло, в результате чего отложенный ордер был автоматически преобразован в рыночный. Преобразование ордера было осуществлено на сервере. Сразу после этого сервер передал информацию клиентскому терминалу, а тот, в свою очередь, отобразил эту информацию графически в окне финансового инструмента и текстом в окне терминала.

Аналогичные наблюдения касаются и преобразования ордера BuyLimit 4210411. Несмотря на то, что графическое изображение цены в 16:37 - 16:39 и в 16:41 (рис. 72) касается или находится ниже заявленной цены отложенного ордера BuyLimit, открытие ордера не произошло. В данном случае причина та же: не произошло касания рыночной ценой Ask заявленной цены ордера. Но это касание произошло на следующем баре, в 16:42. В результате этого события отложенный ордер был преобразован в рыночный, в окне финансового инструмента вместо записи BuyLimit появилась запись Buy, а в окне терминала отобразился новый рыночный ордер.

В рассмотренном примере все ордера были установлены с нулевыми стоп-приказами (что означает их отсутствие). Однако, наличие содержательных (ненулевых значений) стоп-приказов никак не влияет на преобразование отложенных ордеров в рыночные, т.к. преобразование происходит только при касании или прохождении соответствующей ценой двухсторонней котировки заявленной цены отложенного ордера.

Преобразование отложенного ордера в рыночный никак не связано со значениями его стоп-приказов.

Отложенный ордер может быть открыт (преобразован в рыночный) и по цене, не совпадающей с заявленной ценой открытия отложенного ордера. Это может произойти при резком изменении рыночной цены, т.е. при условиях, когда последняя известная цена перед открытием ордера ещё не достигла цены, заявленной в ордере, а следующая цена (по которой и открывается ордер), не совпадает с ценой открытия ордера, а находится за её пределами (рис. 75).

а) разрыв цен произошёл между барами б) разрыв цен произошёл при формировании бара
Рис. 75. Преобразование отложенного ордера в рыночный при разрыве цен.

На рис. 75а представлен возможный вариант открытия отложенного ордера BuyStop (здесь показано два его положения - до и после открытия; при действительных событиях можно наблюдать только один ордер - либо BuyStop, либо Buy). Последняя известная цена до скачка цен составляла 1.9584. В 19:15 были обнародованы какие-то новости, в результате чего цена по финансовому инструменту скачкообразно изменилась. Первая известная цена после выхода новостей равна 1.9615. Скачкообразное изменение цены обычно происходит в результате выхода важных новостей. В подобных случаях у брокера нет возможности открыть ордер по заявленной цене, т.к. на рынке в этот момент нет соответствующих цен. В данном случае отложенный ордер BuyLimit был установлен по заявленной цене 1.9590, но открылся (преобразовался в рыночный) по цене 1.9615. Это произошло потому, что в диапазоне от 1.9584 до 1.9615 других цен не было.

В результате рассматриваемых событий рыночный ордер Buy был открыт по цене на 25 пунктов хуже в сравнении с ценой отложенного ордера BuyStop. Аналогичная ситуация (недополучение прибыли по ордеру) может сложиться и для ордера SellStop в случае, если цена скачкообразно понижается. Если же в разрыв цен попадает отложенный ордер BuyLimit или SellLimit, то соответствующий рыночный может быть открыт по цене лучшей, чем цена, заявленная в отложенном ордере.

Отдельно нужно заметить, что разрыв цен (разница между двумя ближайшими котировками более одного пункта) происходит довольно часто и может случиться в любой момент. Если разрыв цен происходит между барами, а именно сильно отличающаяся цена приходит на первом тике нового бара, то разрыв цен можно наблюдать на ценовом графике (рис. 75а). Если же разрыв цен происходит в пределах одного бара, то такой разрыв визуально определить нельзя (рис. 75б). В этом случае разрыв скрыт внутри бара (свечи). Однако по внешнему виду бара и его программно доступным характеристикам ничего нельзя сказать об истории котировок внутри бара (но разрыв можно выявить программным способом с помощью прикладной программы, вычисляющей разницу цен поступающих котировок).

Модификация рыночных ордеров

Торговая система MetaTrader позволяет формировать торговые приказы для модификации ценовых уровней рыночных и отложенных ордеров.

Для модификации любых типов ордеров, в том числе рыночных, используется функция OrderModify().

Модификация рыночного ордера предполагает изменение заявленных значений стоп-приказов. Изменение цены открытия рыночного ордера запрещено.

Цену открытия рыночного ордера изменить нельзя, т.к. открытие ордера - это уже свершившееся событие. Соответственно, не существует и программно реализуемого способа, с помощью которого можно было бы это выполнить. Единственное, что можно сделать с рыночным ордером, - это закрыть его. Рыночный ордер может быть закрыт в результате исполнения торгового приказа, сформированного трейдером или программой, или в результате достижения рыночной ценой заявленной цены одного из стоп-приказов ордера.

Ордера StopLoss и TakeProfit не могут быть установлены ближе к рыночной цене, чем на минимальную дистанцию.
Ордер не может быть модифицирован, если цена исполнения его StopLoss или TakeProfit находится в пределах дистанции заморозки от рыночной цены.

Обратите внимание, положение стоп-приказов рыночного ордера ограничено относительно текущей рыночной цены и никак не связано с ценой открытия ордера (см. Требования и ограничения торговых операций). Это значит, что в результате модификации стоп-приказы могут быть установлены ниже или выше цены открытия рыночного ордера.

Рассмотрим пример. Ранее был открыт рыночный ордер со стоп-приказами, максимально приближенными к рыночной цене (рис. 69). В дальнейшем рыночная цена изменилась (увеличилась на 1 пункт). В момент, показанный на рис. 76, стало возможным изменить значение TakeProfit. Ордер Sell закрывается по последней известной цене Ask. Дистанция между Ask=1.2990 и предыдущим значением TakeProfit=1.2984 составляла 6 пунктов, т.е. больше минимально допустимой дистанции. Трейдером или программой был сформирован торговый приказ изменить значение TakeProfit, а именно, увеличить это значение на 1 пункт. В результате была совершена торговая операция - изменение положения стоп-приказа рыночного ордера (предыдущее значение TakeProfit=1.2984, новое значение 1.2985).

Если бы торговый приказ содержал указание модифицировать ордер Sell так, чтобы новое значение любого из стоп-приказов было ближе к рыночному кусу Ask, чем на минимальную дистанцию, то такой торговый приказ был бы отклонён клиентским терминалом, и торговая операция не была бы исполнена.

Рис. 76. Модифицированный ордер со стоп-приказами, максимально приближенными к рыночной цене.

Правило модификации рыночных ордеров ограничивает приближение стоп-приказа к текущей цене, но не ограничивает дистанцию удаления стоп-приказа от цены. Поэтому стоп-приказы могут устанавливаться от текущей цены на любом расстоянии, большем ограничивающей дистанции (если на момент модификации ордера стоп-приказ находится за пределами коридора заморозки, определённого значением). На рис. 77 показан тот же ордер после ещё одной модификации: в данном случае стоп приказы находятся далеко за пределами ограничивающей минимальной дистанции.

Рис. 77. Модифицированный ордер, стоп-приказы которого установлены за пределами минимальной дистанции.

Модификация отложенных ордеров

Для модификации любых типов ордеров, в том числе отложенных, используется функция OrderModify().

Модификация отложенного ордера предполагает возможность изменения заявленных значений цен открытия отложенного ордера и его стоп-приказов.
Ограничение, связанное с положением модифицируемого отложенного ордера, рассчитывается от правильной рыночной цены преобразования отложенного ордера в рыночный.
Ограничение, связанное с положением стоп-приказов отложенного ордера, рассчитывается от заявленной цены открытия отложенного ордера и никак не связано с рыночными ценами.

Отложенные ордера BuyLimit и BuyStop не могут быть установлены ближе к рыночной цене Ask, чем на минимальную дистанцию StopLevel.
Отложенные ордера SellLimit и SellStop не могут быть установлены ближе к рыночной цене Bid, чем на минимальную дистанцию StopLevel.
StopLoss и TakeProfit любого отложенного ордера не могут быть установлены ближе к заявленной цене открытия ордера, чем на минимальную дистанцию StopLevel.
Отложенные ордера BuyLimit и BuyStop не могут быть модифицированы, если заявленная цена открытия ордера находится в пределах дистанции заморозки от рыночной цены Ask.
Отложенные ордера SellLimit и SellStop не могут быть модифицированы, если заявленная цена открытия ордера находится в пределах дистанции заморозки от рыночной цены Bid.
Положение StopLoss и TakeProfit отложенных ордеров дистанцией заморозки FreezeLevel не ограничивается.

Обратите внимание, заявленная цена отложенного ордера ограничена относительно рыночной цены, а стоп-приказы - относительно заявленной цены отложенного ордера (см. Требования и ограничения торговых операций).

Например, отложенный ордер BuyLimit установлен с параметрами: заявленная цена=1. 2969, StopLoss=1.2964, TakeProfit=1.2974. Текущее значение рыночной цены (применяемой для преобразования отложенного ордера в рыночный) Ask=1.2983. Таким образом, ордер установлен на расстоянии 14 пунктов (1.2983-1.2969) от рыночной цены, что значительно превышает минимально допустимую дистанцию. Стоп-приказы находятся на расстоянии 5 пунктов от заявленной цены, что не больше минимальной дистанции, т.е. допустимо.

Рис. 78. Отложенный ордер BuyLimit со стоп-приказами, максимально приближенными к ордеру.

Если у трейдера возникла необходимость изменить цену ордера BuyLimit, то в какую бы сторону не был сдвинут этот ордер, в данном случае необходимо также одновременно изменить и положение соответствующего стоп-приказа (или удалить его, т.е. установить нулевое значение), в противном случае дистанция между ордером и его стоп-приказом окажется меньше минимально допустимой. Трейдер принял решение модифицировать ордер таким образом, чтобы сохранить дистанцию между ордером и TakeProfit равной 5 пунктов, а значение StopLoss оставить без изменения (рис. 79).

Рис. 79. Модифицированный ордер BuyLimit (изменена заявленная цена и TakeProfit).

Если у трейдера возникла необходимость установить отложенный ордер BuyLimit как можно ближе к рыночному курсу, то в данном случае (рис. 80) предельно допустимое значение заявленной цены равно Ask-5пунктов = 1.2985-0.0005 = 1.2980. В этом примере стоп-приказы установлены за пределами ограничивающей минимальной дистанции.

Рис. 80. Модифицированный ордер BuyLimit максимально приближен к рыночной цене.

В приложении Требования и ограничения торговых операций представлена сводная таблица, в которой указаны соответствующие значения двухсторонней котировки, применяемые для открытия, закрытия или преобразования ордеров, а также другие расчётные значения, ограничивающие проведение торговых операций.

Общий порядок проведения торговых операцийОткрытие и установка ордеров


Открытие и установка ордеров - Торговые операции - Учебник по MQL4

Учебник по MQL4 [image] Торговые операции [image] Открытие и установка ордеров
MetaQuotes Sofware Corp.
  • Общий порядок проведения торговых операций
  • Характеристики ордеров и правила проведения торговых операций
  • Открытие и установка ордеров
  • Закрытие и удаление ордеров
  • Модификация ордеров
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Открытие и установка ордеров

Формирование торговых приказов для открытия рыночных и установки отложенных ордеров осуществляется с помощью функции OrderSend( ).

Функция OrderSend()

int OrderSend (string symbol, int cmd, double volume, double price, int slippage, double stoploss,
double takeprofit, string comment=NULL, int magic=0, datetime expiration=0, color arrow_color=CLR_NONE)

(обратите внимание, здесь и далее для справки представляется заголовок функции, а не пример использования вызова функции в программе).

Рассмотрим подробно, из чего состоит эта функция.

OrderSend - название функции. Функция возвращает номер тикета (ticket - уникальный порядковый номер ордера), который назначен ордеру торговым сервером или -1 в случае, если торговый приказ был отклонён севером или клиентским терминалом. Для получения информации о причине отклонения торгового приказа необходимо использовать функцию GetLastError() (в дальнейшем изложении мы рассмотрим несколько наиболее распространённых ошибок).

symbol - наименование финансового инструмента, с которым проводится торговая операция. Каждому финансовому инструменту поставлено в соответствие значение строковой переменной. Например, для валютной пары Eur/Usd это значение "EURUSD". Если открытие ордера проводится по заранее известному финансовому инструменту, то этот параметр можно указать в явном виде: "EURUSD", "EURGBP" и т.д. Если же предполагается использование советника в окне любого другого финансового инструмента, то можно использовать стандартную функцию Symbol(). Эта функция возвращает строковое значение, соответствующее названию того финансового инструмента, в окне которого исполняется советник или скрипт.

cmd - тип операции. Тип операций может быть указан в виде предопределённой константы или её значения и в соответствии с типом торговой операции.

volume - количество лотов. Для рыночных ордеров всегда проверяется достаточность свободных средств на счёте. Для отложенных ордеров количество лотов не ограничено.

price - цена открытия. Устанавливается в соответствии с требованиями и ограничениями, принятыми для проведения торговых операций (см. Характеристики ордеров). Если заявленной цены для открытия рыночных ордеров не было в ценовом потоке или она сильно устарела, то такой торговый приказ отклоняется; если же цена устарела, но присутствует в ценовом потоке и при этом отклонение от текущей цены находится в пределах значения slippage, то такой торговый приказ будет принят клиентским терминалом и отправлен на торговый сервер.

slippage - максимально допустимое отклонение заявленной цены открытия ордера от рыночной цены для рыночных ордеров (пунктов). В случае установки отложенного ордера параметр не обрабатывается.

stoploss - заявленная цена закрытия, определяющая предельный уровень убыточности. Устанавливается в соответствии с ограничениями, принятыми для проведения торговых операций (см. Характеристики ордеров, Требования и ограничения торговых операций).

takeprofit - заявленная цена закрытия, определяющая предельный уровень прибыльности. Устанавливается в соответствии с ограничениями, принятыми для проведения торговых операций (см. Характеристики ордеров, Требования и ограничения торговых операций).

comment - текст комментария ордера. Последняя часть комментария может быть изменена торговым сервером.

magic - магическое число ордера. Может использоваться как определяемый пользователем идентификатор ордера. В некоторых случаях это - единственная информация, по которой можно судить о принадлежности ордера к той или иной открывшей его программе. Параметр устанавливается пользователем, может совпадать или не совпадать со значением этого же параметра других ордеров.

expiration - срок истечения отложенного ордера. При наступлении этого срока отложенный ордер будет автоматически закрыт на торговом сервере. На некоторых торговых серверах может быть установлен запрет на применение срока истечения отложенных ордеров. В этом случае при попытке задать ненулевое значение параметра торговый приказ будет отклонён.

arrow_color - цвет открывающей стрелки на графике. Если параметр отсутствует или его значение равно CLR_NONE, то открывающая стрелка на графике не отображается.

На некоторых торговых серверах может быть установлен лимит на общее количество открытых и отложенных ордеров. При превышении этого лимита любой торговый приказ, предполагающий открытие рыночного или установку отложенного ордера, будет отклонён торговым сервером.

Открытие рыночных ордеров

На первый взгляд может показаться, что функция OrderSend() слишком сложна для понимания. В действительности, все рассматриваемые параметры достаточно просты, необходимы и полезно используются в торговле. Для того чтобы в этом убедиться, рассмотрим наиболее простой вариант использования торговой функции OrderSend() для открытия рыночного ордера.

Прежде всего обратим внимание, что функция OrderSend() имеет предопределённые параметры (см. Вызов функции и Тело функции и оператор return). Это значит, что допустимо использование этой функции в упрощённом варианте, с использованием только минимального набора обязательных параметров. Такими параметрами являются:

symbol - финансовый инструмент указать необходимо, иначе неизвестно, где открывать ордер. Пусть наш скрипт предполагает возможность открытия ордера в окне любого финансового инструмента. В этом случае в качестве параметра подставим стандартную функцию Symbol();

cmd - для примера будем открывать ордер Buy, поэтому необходимо указать параметр OP_BUY;

volume - можно указать любое допустимое значение; мы будем открывать ордер небольшого размера, пусть это значение будет 0.1;

price- цена открытия для ордера Buy - это цена Ask;

slippage - обычно это значение указывают в размере от 0 до 3 пунктов. Укажем значение 2;

stoploss - стоп-приказы могут быть выставлены не ближе минимальной дистанции, обычно 5 пунктов (см. Требования и ограничения торговых операций); выставим стоп-приказы на расстоянии 15 пунктов от цены закрытия, а именно Bid - 15*Point;

takeprofit - выставим стоп-приказы на расстоянии 15 пунктов от цены закрытия, а именно Bid + 15*Point;

Простейший скрипт simpleopen.mq4, предназначенный для открытия ордера Buy, выглядит так:

//--------------------------------------------------------------------
// simpleopen.mq4
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------------
int start()                                  // Спец. функция start()
  {                                          // Открытие BUY
   OrderSend(Symbol(),OP_BUY,0.1,Ask,3,Bid-15*Point,Bid+15*Point);
   return;                                   // Выход из start()
  }
//--------------------------------------------------------------------

Если запустить этот скрипт на исполнение, то в подавляющем большинстве случаев он будет работать. Скрипт состоит из одной специальной функции, содержащей функцию открытия ордера OrderSend() и оператор return. Опишем порядок исполнения программных строк и связанных с этим событий.

1. Пользователь прикрепил скрипт к окну финансового инструмента - перетянул название скрипта мышью из окна "Навигатор" клиентского терминала в окно финансового инструмента, по которому он хочет открыть рыночный ордер Buy стоимостью 0.1 лота со стоп-приказами, удалёнными от рыночного курса на 15 пунктов.

2. В момент прикрепления скрипта к окну финансового инструмента клиентский терминал передал управление (запустил на исполнение) специальной функции start() (кратко напомним, что start() скрипта запускается в момент присоединения к окну финансового инструмента, а start() эксперта - в момент поступления ближайшего тика по финансовому инструменту).

3. В рамках исполнения специальной функции start() управление передаётся в строку вызова функции открытия ордера:

   OrderSend(Symbol(),OP_BUY,0.1,Ask,3,Bid-15*Point,Bid+15*Point);

Перед исполнением этой функции программа вычисляет значения всех формальных параметров:

3.1. Мы прикрепили скрипт в окно финансового инструмента Eur/Usd. В этом случае стандартная функция Symbol() вернёт строковое значение EURUSD.

3.2. Пусть на момент обращения Ask =1.2852 и Bid =1.2850.

3.3. Значение StopLoss в этом случае будет равно 1.2850-15*0.0001 = 1.2835, а TakeProfit = 1.2865.

4. Исполнение функции OrderSend():

4.1. Функция сформировала торговый приказ на открытие ордера и передала этот приказ клиентскому терминалу.

4.2. Одновременно с торговым приказом функция передала клиентскому терминалу управление и, таким образом, исполнение программы приостановилось.

4.3. Клиентский терминал произвёл проверку полученного торгового приказа, не обнаружил некорректных параметров и отправил торговый приказ на сервер.

4.4. Сервер получил торговый приказ, произвёл его проверку, не обнаружил некорректных параметров и принял решение исполнить торговый приказ.

4.5. Сервер исполнил торговый приказ, произведя транзакцию в своей базе данных, и отправил сведения об исполненном приказе торговому терминалу.

4.6. Торговый терминал получил информацию о том, что последний торговый приказ исполнен, отразил это событие в окне терминала и в окне финансового инструмента и вернул управление программе.

4.7. Получив управление, программа продолжила свою работу с того места, откуда ранее управление передавалось в клиентский терминал (и куда впоследствии вернулось).

Обратите внимание, в период с п.4.2 по п.4.7 в программе не производилось никаких действий - программа находилась в режиме ожидания ответа сервера.

5. Управление в программе передаётся следующему оператору - return.

6. Исполнение оператора return приводит к выходу из функции start() и, как следствие, к окончанию исполнения программы (напомним, что скрипты после исполнения заканчивают работу) - управление возвращается клиентскому терминалу.

Таким образом, скрипт выполнил своё предназначение: открыт ордер Buy с заданными параметрами. Использование скриптов очень удобно, если необходимо выполнить небольшую разовую операцию; в данном случае использование скрипта вполне оправданно. В соответствии с п. 4.6. трейдер может наблюдать ордер на экране.

Рис. 81. Ордер выставлен скриптом simpleopen.mq4.

Рассмотренный выше порядок событий не всегда проходит так гладко. Возможны случаи, при которых исполнение торгового приказа будет отклонено клиентским терминалом или сервером. Попробуем немного поэкспериментировать, например, изменим название финансового инструмента: укажем явно "GBPUSD" (это вполне допустимо). Получится программа с ограниченной областью использования:

int start()                               // Спец. функция start
  {                                       // Открытие BUY
   OrderSend("GBPUSD",OP_BUY,0.1,Ask,3,Bid-15*Point,Bid+15*Point);
   return;                                // Выход из start()
  }

Запустим скрипт в том же окне финансового инструмента Eur/Usd. По замыслу, скрипт должен открыть ордер в окне Gbp/Usd. Однако после присоединения скрипта в окно Eur/Usd ожидаемого открытия ордера в окне Gbp/Usd не происходит.

Недостатком подобных программ является их функциональная ограниченность. В данном случае, после присоединения скрипта в окно финансового инструмента пользователь просто ждёт открытия ордера. Но открытия нет. Пользователь находится в неведении относительно причины сложившейся ситуации: то ли причина в том, что в коде программы имеется алгоритмическая ошибка, то ли торговый приказ "потерялся" на пути к серверу, то ли торговый приказ давно отклонён клиентским терминалом (а пользователь ждёт), то ли имеется другая причина.

Для того чтобы предоставить в распоряжение пользователя (и, что не менее важно, в распоряжение программы) информацию о событиях, связанных с исполнением торгового приказа, необходимо выполнить обработку ошибок.

Обработка ошибок

Очень важное свойство клиентского терминала состоит в том, что в случае, если во время выполнения прикладной программы возникает ошибка, то клиентский терминал не прекращает исполнение программы. Обычно ошибки возникают по причине несовершенства используемого в прикладной программе алгоритма, а в некоторых случаях - в результате внешних (по отношению к программе) причин. К внутренним причинам относятся любые нарушения требований языка MQL4 или правил торговли, например, использование неправильных цен, а к внешним - причины, не связанные с прикладной программой, например, проблемы со связью.

Если при исполнении программы возникает ошибка, то программа продолжает работу, а клиентский терминал генерирует значение кода ошибки, которое доступно программе при использовании функции GetLastError( ).

Функция GetLastError()

int GetLastError()

Функция возвращает код последней ошибки, после чего значение специальной переменной last_error, в которой хранится код последней ошибки, обнуляется. Последующий вызов GetLastError() вернет значение 0.

В дальнейшем все возникающие ошибки мы будем идентифицировать по этому коду. Во время исполнения программы может возникнуть несколько ошибок; функция GetLastError() позволяет получить значение кода только одной - последней ошибки, поэтому во всех случаях, когда может понадобиться такая информация, использовать функцию GetLastError() необходимо непосредственно после тех программных строк, в которых эта ошибка может возникнуть.

Ошибка 130. Неправильные стопы

Последний рассмотренный скрипт не производит анализ ошибок, поэтому пользователь остаётся в неведении относительно результатов исполнения функции открытия ордера. В простом варианте использования функции GetLastError() можно проанализировать ошибку и просто сообщить о ней пользователю. Если скрипт confined.mq4 запустить на исполнение в окне Eur/Usd, то возникнет ошибка.

//--------------------------------------------------------------------
// confined.mq4
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------------
int start()                                     // Спец. функция start
  {                                             // Открытие BUY
   OrderSend("GBPUSD",OP_BUY,0.1,Ask,3,Bid-15*Point,Bid+15*Point);
   Alert (GetLastError());                      // Сообщение об ошибке
   return;                                      // Выход из start()
  }
//--------------------------------------------------------------------

В этом скрипте добавлена всего одна, но очень содержательная строка:

   Alert (GetLastError());                      // Сообщение об ошибке

Функция GetLastError( ) возвращает код последней ошибки, а с помощью Alert() это значение выводится на экран. После присоединения скрипта confined.mq4 в окно финансового инструмента Eur/Usd скрипт исполнится, в результате чего пользователь увидит следующее сообщение:

Рис. 82. Код ошибки, полученный при исполнении скрипта confined.mq4 в окне Eur/Usd.

В приложении представлены Коды ошибок, которые могут возникать при исполнении программы. В данном случае возникла ошибка 130 - неправильные стопы. Это значит, что значения формальных параметров, используемых в функции OrderSend(), не удовлетворяют ограничениям, указанным в Требования и ограничения торговых операций. При внимательном рассмотрении становится очевидной и причина возникшей ошибки: текущие значения рыночной цены Bid и Ask берутся из того окна финансового инструмента, в которое присоединён скрипт, а именно, из окна Eur/Usd. А используются эти значения для формирования торгового приказа по финансовому инструменту Gbp/Usd. В результате, при текущей цене Gbp/Usd Ask = 1.9655, значение TakeProfit для вновь открываемого рыночного ордера оказывается равным (для Eur/Usd Bid =1.2930) 1.2930+15*0.0001=1. 2945, что значительно ниже предельно допустимого значения, т.е ошибочно.

В данном случае возникла алгоритмическая ошибка. Для того чтобы её исправить, необходимо использовать правильные значения цен по финансовому инструменту. Получить эти значения можно с помощью функции MarketInfo(). Скрипт improved.mq4 для открытия рыночного ордера по Gbp/Usd может быть запущен в окне любого финансового инструмента:

//--------------------------------------------------------------------
// improved.mq4
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------------
int start()                                     // Спец. функция start
  {
   double bid   =MarketInfo("GBPUSD",MODE_BID); // Запрос значения Bid
   double ask   =MarketInfo("GBPUSD",MODE_ASK); // Запрос значения Ask
   double point =MarketInfo("GBPUSD",MODE_POINT);//Запрос Point
   // Открытие BUY
   OrderSend("GBPUSD",OP_BUY,0.1,ask,3,bid-15*Point,bid+15*Point);
   Alert (GetLastError());                      // Сообщение об ошибке
   return;                                      // Выход из start()
  }
//--------------------------------------------------------------------

При исполнении этого скрипта рассматриваемая ошибка не возникает, поэтому в результате его исполнения будет выведено соответствующее сообщение: 0 (ноль). Это значит, что функция GetLastError() вернула значение 0, т.е. при исполнении торгового приказа клиентским терминалом ошибок не выявлено.

Рассмотрим и некоторые другие наиболее распространённые ошибки. Для этого вернёмся к идее открытия ордера с помощью скрипта в том окне, в которое присоединён скрипт.

Ошибка 129. Неправильная цена

В ряде случаев возникает банальная ошибка - в качестве цены открытия указывается не то значение двухсторонней котировки. Как известно (см. Требования и ограничения торговых операций), рыночные ордера Buy открываются ценой Ask. Вот что получится, если в скрипте mistaken.mq4 ошибочно указать Bid:

//--------------------------------------------------------------------
// mistaken.mq4
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------------
int start()                                     // Спец. функция start
  {                                             // Открытие BUY
   OrderSend(Symbol(),OP_BUY,0.1,Bid,3,Bid-15*Point,Bid+15*Point);
   Alert (GetLastError());                      // Сообщение об ошибке
   return;                                      // Выход из start()
  }
//--------------------------------------------------------------------

Перед отправкой торгового приказа на сервер клиентский терминал проанализирует, соответствуют ли заявленные значения цены и стоп-приказов допустимым значениям. Во время этой проверки обнаружится, что заявленная цена открытия ордера является ошибочной, поэтому торговый приказ не будет отправлен клиентским терминалом для исполнения на сервер, а функция GetLastError() вернёт значение 129 (см. Коды ошибок). В результате исполнения скрипта появится окно с соответствующим сообщением:

Рис. 83. Ошибка 129 (неправильная цена) при исполнении mistaken.mq4.

Ошибка 134. Недостаточно денег для совершения операции

Аналогичный результат (ошибка 134) будет получен и в случае, если свободных средств не хватает для открытия ордера. Размер свободных средств, необходимых для открытия 1 лота на покупку для каждого финансового инструмента можно узнать с помощью функции MarketInfo(Имя_инструмента, MODE_MARGINREQUIRED).

Размер стандартного лота в разных дилинговых центрах для одного финансового инструмента может отличаться.

Размер необходимых средств для открытия ордера в один лот обратно пропорционален размеру предоставляемого плеча. В то же время, стоимость 1 пункта в валюте депозита по финансовому инструменту не зависит от предоставленного плеча.

Таблица 3. Варианты соотношения стоимости лотов и 1 пункта (валюта депозита- доллар США).

 | Дилинговый центр 1 |  |  | Дилинговый центр 2 |  |  | Дилинговый центр 3
 | Buy | Sell | 1pt | Buy | Sell | 1pt | Buy | Sell | 1pt
EUR/USD | 1296.40 | 1296.20 | 10.00 | 1296.50 | 1296.20 | 10.00 | 1000.00 | 1000.00 | 10.00
GBP/USD | 1966.20 | 1966.00 | 10.00 | 1376.48 | 1376.20 | 7.50 | 1000.00 | 1000.00 | 10.00
AUD/USD | 784.40 | 784.20 | 10.00 | 1569.20 | 1568.40 | 20.00 | 1000.00 | 1000.00 | 10.00
USD/JPY | 1000.00 | 1000.00 | 8.29 | 1000.00 | 1000.00 | 8.29 | 1000.00 | 1000.00 | 8.29
USD/CHF | 1000.00 | 1000.00 | 8.02 | 1000.00 | 1000.00 | 8.02 | 1000.00 | 1000.00 | 8.02
EUR/CHF | 1296.40 | 1296.20 | 8.02 | 1296.35 | 1296. 35 | 8.02 | 1000.00 | 1000.00 | 8.02

Цены даны по состоянию на 16.12.2007г.

Кратко рассмотрим распространённые методы расчёта стоимости 1 лота и 1 пункта.

Дилинговый центр 1 (наиболее распространённый вариант)

Для тех валютных инструментов, у которых в знаменателе указан USD, стоимость 1 лота равна текущей цене соответствующей двухсторонней котировки, умноженной на 1000, стоимость 1 пункта равна $10.

Для тех валютных инструментов, у которых USD указан в числителе, стоимость 1 лота равна $1000.00, а стоимость 1 пункта обратно пропорциональна текущей котировке и равна 1/(Bid). Например, для USD/CHF при Bid= 1.2466 стоимость 1 пункта = 1/1. 2466 = 8.02.

Для кросс-курсов стоимость 1 лота оценивается так, как оценивается стоимость валюты, указанной в числителе, а стоимость 1 пункта так, как для валюты, указанной в знаменателе. Например, для EUR/CHF стоимость 1 лота = 129.40 (как для EUR/USD), а стоимость 1 лота = 8.02 (как для USD/CHF).

Дилинговый центр 2

В некоторых дилинговых центрах при соблюдении того же общего порядка стоимостные показатели для некоторых финансовых инструментов могут отличаться. Например, стоимость лота и стоимость 1 пункта может быть пропорционально увеличена или уменьшена. Например, для GBP/USD этот коэффициент составляет 0.75, а для AUD/USD составляет 2.0. Такое представление стоимостных показателей не приводит ни к каким экономическим последствиям; в таких случаях нужно просто учитывать эту особенность при расчёте стоимости ордера. Обратите внимание также на особенность стоимости лотов для покупки и продажи активов кросс-курсов - они совпадают.

Дилинговый центр 3

Существуют также такие дилинговые центры, которые устанавливают стоимость 1 лота для любого финансового инструмента равной $1000.00. В то же время стоимость 1 пункта остаётся пропорциональной текущим ценам. Этим подразумевается, что для каждого финансового инструмента устанавливается своё кредитное плечо.

Стоимость 1 пункта для всех финансовых инструментов, котируемых не по отношению к USD, постоянно изменяется пропорционально стоимости той валюты, которая указана в знаменателе.

В общем, возможны и другие принципы построения стоимостных показателей. Разумеется, прежде чем приступить к реальной торговле, необходимо определить метод расчёта, используемый в конкретном дилинговом центре, и при составлении программ его обязательно учитывать.

Свободные средства

При составлении программ очень важно также учитывать принцип формирования свободных средств. Cвободные средства - эта та сумма денежных средств, которая остаётся свободной для совершения торговых операций.

Рассмотрим пример. Пусть Баланс = 5000.00, в терминале нет открытых ордеров. Откроем ордер Buy стоимостью 1 лот в дилинговом центре 3. В дилинговом центре 3 установлено следующее правило:

Если по одному финансовому инструменту открыты разнонаправленные рыночные ордера, то меньшая суммарная стоимость однонаправленных ордеров высвобождается из торговли и увеличивает сумму свободных средств (правило выполняется не во всех дилинговых центрах).

В окне терминала отразится информация об открытом ордере. Обратите внимание, залог составляет 1000.00, прибыль по ордеру -30.00, таким образом, количество свободных средств составляет 5000-1000-30=3970.00:

Рис. 84. Ордер Buy в окне терминала.

После открытия ордера Sell той же стоимости количество свободных средств увеличится. Меньшая суммарная стоимость однонаправленных рыночных ордеров составляет 1000.00, поэтому свободные средства увеличиваются на 1000.00. На рис. 85 показана ситуация, при которой стоимость разнонаправленных ордеров совпадает, таким образом, вся сумма стоимости ордеров высвобождается для торговли.

Рис. 85. Ордер Buy и Sell в окне терминала.

После открытия ордера Sell меньшей стоимости количество свободных средств также увеличится. В данном случае меньшая суммарная стоимость однонаправленных рыночных ордеров составляет 700.00, поэтому свободные средства увеличиваются на 700.00, а залог составляет разницу между суммарными стоимостями разнонаправленных ордеров (рис. 86).

Рис. 86. Ордер Buy и Sell в окне терминала.

В случае если будет открыт ещё один ордер Sell на 0.1 лота (стоимостью 100.00), то меньшая суммарная стоимость однонаправленных ордеров составляет 700.00 + 100. 00 = 800.00. Таким образом, сумма залога (в сравнении с вариантом, когда открыт только один ордер Buy) уменьшается на 800.00. В сравнении с вариантом, представленным на рис. 86, залог уменьшается, а свободные средства увеличиваются на 100.00 (см. рис. 87).

Рис. 87. Ордер Buy и Sell в окне терминала.

Количество свободных средств, отображаемых на рис. 86 и 87, отличаются более чем на 100.00, т.к. при изменении текущего курса изменилось суммарное значение прибыли по открытым ордерам (разница составляет 8.00).

Если аналогичные манипуляции провести на другом дилинговом центре, то легко убедиться, что описанный выше порядок формирования значения свободных средств не соблюдается. Для некоторых дилинговых центров выполняется правило:

Открытие любых рыночных ордеров не высвобождает залоговые средства и не увеличивает сумму свободных средств. Открытие рыночных ордеров увеличивает залог на сумму, превышающую суммарную стоимость противоположных ордеров по финансовому инструменту (правило выполняется не во всех дилинговых центрах).

Например, если в дилинговом центре 2 по USD/JPY ранее был открыт ордер Buy стоимостью 4 лота, то при открытии ордера Sell стоимостью 4 лота сумма залога и сумма свободных средств не изменится.

Рис. 88. Наличие разнонаправленных ордеров не высвобождает залог.

Получить информацию о том, хватает ли текущих средств для открытия ордера можно расчётным путём. Можно также воспользоваться функцией AccountFreeMarginCheck(), возвращающей количество свободных средств, которые останутся после открытия рыночного ордера заданного количества лотов по указанному финансовому инструменту. Если возвращённое значение оказывается больше или равно 0, то средств хватает, если же меньше, то ордер такой стоимости по этому финансовому инструменту открыть не удастся - клиентский терминал вернёт ошибку 134.

Для того чтобы при первом знакомстве с условиями, предлагаемыми дилинговым центром, выяснить размер свободных средств, требуемых для открытия ордера объемом в 1 лот, можно воспользоваться нехитрым скриптом conditions.mq4:

//--------------------------------------------------------------------
// conditions.mq4
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------------
int start()                                      // Спец.функция start
  {
   Alert(Symbol(),"  Sell = ",AccountFreeMargin()// При продаже
         -AccountFreeMarginCheck(Symbol(),OP_SELL,1));
   Alert(Symbol(),"  Buy = ",AccountFreeMargin() // При покупке
         -AccountFreeMarginCheck(Symbol(),OP_BUY,1));
   return;                                       // Выход из start()
  }
//--------------------------------------------------------------------

Здесь выражение

AccountFreeMargin() - AccountFreeMarginCheck(Symbol(),OP_SELL,1)

позволяет вычислить разницу между имеющимися свободными средствами и свободными средствами, которые останутся после открытия ордера.

Если этот скрипт запустить на исполнение в условиях, когда в терминале нет рыночных ордеров, то можно получить текущий требуемый размер средств для открытия ордера объемом 1 лот на покупку и на продажу:

Рис. 89. Стоимость 1 лота для различных финансовых инструментов, полученная с помощью conditions.mq4.

Если скрипт conditions.mq4 запустить на исполнение в окне финансового инструмента, по которому открыты рыночные ордера, то можно получить и другие значения в зависимости от того, каким методом расчёта пользуется тот или иной дилинговый центр.

Другие ошибки и функция MarketInfo()

Существуют и другие ограничения, связанные с определением значений параметров функции открытия ордера OrderSend(). Это - максимальный и минимальный шаг изменения стоимости ордера, максимальный и минимальный размер стоимости ордера и пр. Использование функции MarketInfo() позволяет получить различную информацию по финансовым инструментам, которые отражены в окне "Обзор рынка" клиентского терминала.

Функция MarketInfo()

double MarketInfo(string symbol, int type)

Функция возвращает различную информацию о финансовых инструментах, перечисленных в окне "Обзор рынка". Часть информации о текущем финансовом инструменте хранится в предопределенных переменных.

Параметры:

symbol - символ инструмента;

type - идентификатор запроса, определяющий тип возвращаемой информации. Может быть любым из значений идентификаторов запроса (см. Идентификаторы функции MarketInfo).

Некоторые ошибки могут возникать по причинам, обусловленным сервером. Например, в условиях быстро изменяющихся цен брокер может увеличить минимальную дистанцию, ограничивающую положение отложенных ордеров и стоп-приказов. В дальнейшем, при спокойном рынке, брокер может снова уменьшить эту дистанцию. Таким образом, значения некоторых параметров могут быть изменены в любой момент.

Для того чтобы программа работала устойчиво, с минимальным количеством отклонённых торговых приказов, перед исполнением функции OrderSend() необходимо обновлять используемые программой параметры информационного окружения с помощью функций MarketInfo() и RefreshRates().

Пример простого скрипта, открывающего ордер Buy, стоимостью 35% от суммы свободных средств, с некоторыми заданными значениями стоп-приказов (openbuy.mq4).

//--------------------------------------------------------------------
// openbuy.mq4
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------- 1 --
int start()                                     // Спец.функция start
  {
   int Dist_SL =10;                             // Заданный SL (pt)
   int Dist_TP =3;                              // Заданный TP (pt)
   double Prots=0.35;                           // Процент своб. ср.
   string Symb=Symbol();                        // Финанс. инструмент
//--------------------------------------------------------------- 2 --
   while(true)                                  // Цикл открытия орд.
     {
      int Min_Dist=MarketInfo(Symb,MODE_STOPLEVEL);// Мин. дистанция
      double Min_Lot=MarketInfo(Symb,MODE_MINLOT);// Мин. размер лота
      double Step   =MarketInfo(Symb,MODE_LOTSTEP);//Шаг изменен лотов
      double Free   =AccountFreeMargin();       // Свободн средства
      double One_Lot=MarketInfo(Symb,MODE_MARGINREQUIRED);//Стоим.1 лота
      //--------------------------------------------------------- 3 --
      double Lot=MathFloor(Free*ProtsOne_LotStep)*Step;// Лоты
      if (Lot < Min_Lot)                        // Если меньше допуст
        {
         Alert(" Не хватает денег на ", Min_Lot," лотов");
         break;                                 // Выход из цикла
        }
      //--------------------------------------------------------- 4 --
      if (Dist_SL < Min_Dist)                   // Если меньше допуст.
        {
         Dist_SL=Min_Dist;                      // Установим допуст.
         Alert(" Увеличена дистанция SL = ",Dist_SL," pt");
        }
      double SL=Bid - Dist_SL*Point;            // Заявленная цена SL
      //--------------------------------------------------------- 5 --
      if (Dist_TP < Min_Dist)                   // Если меньше допуст.
        {
         Dist_TP=Min_Dist;                      // Установим допуст.
         Alert(" Увеличена дистанция TP = ",Dist_TP," pt");
        }
      double TP=Bid + Dist_TP*Point;            // Заявленная цена ТР
      //--------------------------------------------------------- 6 --
      Alert("Торговый приказ отправлен на сервер. Ожидание ответа..");
      int ticket=OrderSend(Symb, OP_BUY, Lot, Ask, 2, SL, TP);
      //--------------------------------------------------------- 7 --
      if (ticket>0)                             // Получилось :)
        {
         Alert ("Открыт ордер Buy ",ticket);
         break;                                 // Выход из цикла
        }
      //--------------------------------------------------------- 8 --
      int Error=GetLastError();                 // Не получилось :(
      switch(Error)                             // Преодолимые ошибки
        {
         case 135:Alert("Цена изменилась. Пробуем ещё раз..");
            RefreshRates();                     // Обновим данные
            continue;                           // На след. итерацию
         case 136:Alert("Нет цен. Ждём новый тик..");
            while(RefreshRates()==false)        // До нового тика
               Sleep(1);                        // Задержка в цикле
            continue;                           // На след. итерацию
         case 146:Alert("Подсистема торговли занята. Пробуем ещё..");
            Sleep(500);                         // Простое решение
            RefreshRates();                     // Обновим данные
            continue;                           // На след. итерацию
        }
      switch(Error)                             // Критические ошибки
        {
         case 2 : Alert("Общая ошибка.");
            break;                              // Выход из switch
         case 5 : Alert("Старая версия клиентского терминала.");
            break;                              // Выход из switch
         case 64: Alert("Счет заблокирован.");
            break;                              // Выход из switch
         case 133:Alert("Торговля запрещена");
            break;                              // Выход из switch
         default: Alert("Возникла ошибка ",Error);// Другие варианты
        }
      break;                                    // Выход из цикла
     }
//--------------------------------------------------------------- 9 --
   Alert ("Скрипт закончил работу -----------------------------");
   return;                                      // Выход из start()
  }
//-------------------------------------------------------------- 10 --

Скрипт состоит из одной специальной функции start() (блоки 1-10). В блоке 1-2 заданы значения, при которых должен быть открыт ордер. Блок 2-9 представляет цикл while (), в котором производятся необходимые вычисления. Наличие этого цикла предполагает возможность нескольких попыток открытия ордера. В блоке 2-3 обновляются переменные окружения. В блоках 3-4-5-6 вычисляются значение количества лотов и заявленные цены стоп-приказов. В блоке 7-8-9 выполняется обработка ошибок. В блоке 9-10 печатается сообщение о завершении работы скрипта.

Рассмотрим некоторые особенности программного кода. Легко заметить, что формирование торгового приказа осуществляется в блоке 6-7. В предшествующем блоке 3-4 вычисляется количество лотов. Учитывается вариант, при котором выделенных свободных средств не хватит для открытия ордера даже на минимальное количество лотов. Поэтому в блоке 3-4, после опубликования сообщения о нехватке денег, осуществляется выход из цикла 2-9 с помощью оператора break. Управление передаётся в блок 9-10, и скрипт заканчивает работу. Сообщение в блоке 9 не обязательно должно присутствовать. Здесь оно указано только для того, чтобы при опробовании скрипта на демо-счёте было легче сориентироваться - когда программа закончила работу, а когда возникла пауза, связанная с задержками в сети или на сервере.

Если для открытия ордера свободных средств хватает, то управление передаётся в блок 4-5 и далее в блок 5-6. В этих блоках не предусмотрен выход из цикла. Этим полагается, что для любой минимальной дистанции, установленной брокером, найдутся соответствующие значения стоп-приказов. В блоке 1-2 намеренно указано значение 3 пункта для TP. Подавляющее число брокеров устанавливают минимальную дистанцию 5 пунктов. В блоке 5-6 будет обнаружено, что заданное значение меньше допустимого, и установлено такое значение цены стоп-приказа, которое не противоречит ограничению.

Далее управление передаётся в блок 6-7 для открытия ордера. В первой строке этого блока публикуется сообщение и лишь во второй строке формируется торговый приказ. Возникает вопрос: почему мы заявляем о формировании торгового приказа ещё до того, как он сформирован? Ведь можно было бы сначала отдать приказ, а потом сообщить об этом пользователю. Ответ на этот вопрос непосредственно связан с технологией отправки приказа клиентскому терминалу и далее на сервер (см. рис. 66). В нашем случае торговый приказ формируется в функции OrderSend(), указанной в правой части оператора присваивания. Собственно торговый приказ создаётся и отправляется на сервер в самой функции, а исполнение операции присвоения в операторе присваивания будет выполнено уже после того, как сервер вернёт какой-либо ответ о судьбе данного торгового приказа. Таким образом, единственная возможность сообщить пользователю о начале событий, связанных с торговым приказом, - это указать сообщение перед оператором присваивания, в правой части которого указана торговая функция.

Рано или поздно клиентский терминал вернёт управление в программу, будет исполнен оператор присваивания в блоке 6-7, в результате чего переменная ticket получит какое-то значение, и управление будет передано далее - в блок анализа ошибок 7-8-9.

Если ордер открыт на сервере, то переменной ticket будет присвоен номер открытого ордера. В этом случае скрипт выполнил своё предназначение и далее работу программы необходимо прекратить. В блоке 7-8 используется оператор break для выхода из цикла while(). Управление передаётся в блок 9-10 (за пределы цикла) и программа заканчивает работу.

Если же попытка открыть ордер не увенчалась успехом, то управление передаётся в блок 8-9 для анализа ошибок. Здесь рассматривается 2 вида ошибок - те, которые позволяют ещё надеяться на успешное открытие и те, появление которых однозначно указывает на необходимость прекратить исполнение программы. Переменной Error присваивается код последней ошибки, в данном случае той ошибки, которая была возвращена сервером или клиентским терминалом при исполнении торговой функции OrderSend().

В первом операторе switch блока 8-9 рассматриваются преодолимые ошибки. Каждая из ошибок этой группы обрабатывается по-своему. Например, если изменилась цена (ошибка 135), то достаточно просто обновить параметры окружения с помощью RefreshRates() и повторить попытку открытия ордера. Если же возникла ошибка "нет цен" (ошибка 136), то нет смысла сразу снова отправлять торговый приказ на сервер. В этом случае необходимо дождаться нового тика (на сервере в этот период тоже нет цен) и только после этого произвести ещё одну попытку открытия ордера. Поэтому в блоке обработки ошибки 136 имеется цикл задержки, который будет прерван в результате поступления нового тика. Выход из оператора switch() осуществляется с помощью оператора continue, который прекращает текущую итерацию цикла while () и начинает новую.

Ошибки непреодолимой силы обрабатываются иначе. Если такая ошибка возникла, то программа просто сообщит о ней пользователю и прекратит работу. Для этой цели в программе используется оператор break (последний в блоке 8-9), прекращающий цикл while (), в результате чего программа заканчивает работу.

Отдельно нужно заметить, что в данном примере намеренно не рассматриваются все без исключения ошибки. В данном случае мы не ставим перед собой цель предоставить в распоряжение пользователя готовую программу. Очень важно, чтобы программист сам проанализировал другие варианты ошибок и самостоятельно принял решение о том, какие ещё ошибки и как необходимо обработать в программе. В то же время, некоторые ошибки не должны обрабатываться, потому что сама программа построена таким образом, что не предполагает возможности для возникновения некоторых ошибок, например, в данном случае - для ошибок 129 и 130.

В представленном примере имеется также небольшая алгоритмическая ошибка, которая не может быть обнаружена ни на этапе компиляции, ни в клиентском терминале, ни на сервере.

Относитесь критически к любым программным кодам, невзирая на авторитеты.

Обратите внимание на код в блоке 4-5:

//--------------------------------------------------------------- 4 --
      if (Dist_SL<Min_Dist)                     // Если меньше допуст.
        {
         Dist_SL=Min_Dist;                      // Установим допуст.
         Alert(" Увеличена дистанция SL = ",Dist_SL," pt");
        }
      double SL = Bid - Dist_SL*Point;          // Заявленная цена SL
//--------------------------------------------------------------- 5 --

В результате вычислений в теле оператора if () переменная Dist_SL может получить новое значение. Предположим, что обычно минимальная дистанция составляет 5 пунктов. Предположим, что при первом исполнении (на быстром рынке) это значение установлено на сервере равным 20 пунктов. Переменная Min_Dist получит значение 20.

      int Min_Dist=MarketInfo(Symb,MODE_STOPLEVEL);// Мин. дистанция

Предположим также, что сформированный торговый приказ был отклонён в результате ошибки 136. Программа будет отслеживать новый тик в блоке 8-9. За это время на сервере снова может быть изменено значение минимальной дистанции, на этот раз, например, уменьшено до 10 пунктов. С момента поступления нового тика управление будет передано на новый цикл, будет вычислено новое значение переменной Min_Dist, равное 10. Однако значение переменной Dist_SL останется неизменным, равным 20 (блок операторов 4-5 написан так, что значение Dist_SL может только увеличиваться). Чтобы исключить эту алгоритмическую ошибку, блок 4-5 необходимо составить таким образом, чтобы изменялось только то значение, которое зависит от ситуации, - в данном случае значение SL, а значение Dist_SL не изменялось, например, так:

//--------------------------------------------------------------- 4 --
      double SL = Bid - Dist_SL*Point;          // Заявленная цена SL
      if (Dist_SL<Min_Dist)                     // Если меньше допуст.
        {
         SL = Bid - Min_Dist*Point;             // Заявленная цена SL
         Alert(" Увеличена дистанция SL = ",Min_Dist," pt");
        }
//--------------------------------------------------------------- 5 --

Аналогичное изменение кода следует выполнить в блоке 5-6 и для другого стоп-приказа.

Выставление отложенных ордеров

Программирование выставления отложенных ордеров принципиально ничем не отличается от предназначенного для выставления рыночных.

Обратить внимание следует лишь на тот факт, что проверка достаточности средств (необходимых для преобразования отложенного ордера в рыночный) для отложенных ордеров не производится ни клиентским терминалом, ни сервером и никак не ограничена. Возможно выставить отложенный ордер, многократно превышающий по стоимости имеющиеся на счёте средства. Такой ордер может находиться в торговле неопределённо долгое время. В момент, когда рыночная цена достигнет уровня заявленной в отложенном ордере цены открытия, на сервере будет произведена проверка. Если в этот момент средств на счёте достаточно для открытия, то ордер будет преобразован в рыночный (открыт), если же нет - то он будет удалён.

Функция WindowPriceOnDropped()

В MQL4 есть одна очень важная возможность - программно определить в окне финансового инструмента координаты места, на которое был установлен эксперт или скрипт, если они присоединены с помощью мыши. Например, используя функцию WindowPriceOnDropped() можно получить значение прикрепления скрипта по оси ординат.

double WindowPriceOnDropped()

Функция возвращает значение цены в точке графика, на которой был брошен эксперт или скрипт. Значение будет верным только в случае, если эксперт или скрипт перемещены с помощью мыши (технология "drag and drop"). Для пользовательских индикаторов это значение не определено.

Пример простого скрипта, устанавливающего ордер BuyStop, стоимостью 35% от суммы свободных средств, с некоторыми заданными значениями стоп-приказов (openbuystop.mq4).

//--------------------------------------------------------------------
// openbuystop.mq4
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------- 1 --
int start()                                     // Спец.функция start
  {
   int Dist_SL =10;                             // Заданный SL (pt)
   int Dist_TP =3;                              // Заданный TP (pt)
   double Prots=0.35;                           // Процент своб. ср.
   string Symb=Symbol();                        // Финанс. инструмент
   double Win_Price=WindowPriceOnDropped();     // Здесь брошен скрипт
   Alert("Мышкой задана цена Price = ",Win_Price);// Задано мышей
//--------------------------------------------------------------- 2 --
   while(true)                                  // Цикл открытия орд.
     {
      int Min_Dist=MarketInfo(Symb,MODE_STOPLEVEL);// Мин. дистанция
      double Min_Lot=MarketInfo(Symb,MODE_MINLOT);// Мин. размер лота
      double Free   =AccountFreeMargin();       // Свободн средства
      double One_Lot=MarketInfo(Symb,MODE_MARGINREQUIRED);//Стоим.лота
      double Lot=MathFloor(Free*ProtsOne_LotMin_Lot)*Min_Lot;// Лоты
      //--------------------------------------------------------- 3 --
      double Price=Win_Price;                   // Цена задана мышей
      if (NormalizeDouble(Price,Digits)<        // Если меньше допуст.
         NormalizeDouble(Ask+Min_Dist*Point,Digits))
        {                                       // Только для BuyStop!
         Price=Ask+Min_Dist*Point;              // Ближе нельзя
         Alert("Изменена заявленная цена: Price = ",Price);
        }
      //--------------------------------------------------------- 4 --
      double SL=Price - Dist_SL*Point;          // Заявленная цена SL
      if (Dist_SL < Min_Dist)                   // Если меньше допуст.
        {
         SL=Price - Min_Dist*Point;             // Заявленная цена SL
         Alert(" Увеличена дистанция SL = ",Min_Dist," pt");
        }
      //--------------------------------------------------------- 5 --
      double TP=Price + Dist_TP*Point;          // Заявленная цена ТР
      if (Dist_TP < Min_Dist)                   // Если меньше допуст.
        {
         TP=Price + Min_Dist*Point;             // Заявленная цена TP
         Alert(" Увеличена дистанция TP = ",Min_Dist," pt");
        }
      //--------------------------------------------------------- 6 --
      Alert("Торговый приказ отправлен на сервер. Ожидание ответа..");
      int ticket=OrderSend(Symb, OP_BUYSTOP, Lot, Price, 0, SL, TP);
      //--------------------------------------------------------- 7 --
      if (ticket>0)                             // Получилось :)
        {
         Alert ("Установлен ордер BuyStop ",ticket);
         break;                                 // Выход из цикла
        }
      //--------------------------------------------------------- 8 --
      int Error=GetLastError();                 // Не получилось :(
      switch(Error)                             // Преодолимые ошибки
        {
         case 129:Alert("Неправильная цена. Пробуем ещё раз..");
            RefreshRates();                     // Обновим данные
            continue;                           // На след. итерацию
         case 135:Alert("Цена изменилась. Пробуем ещё раз..");
            RefreshRates();                     // Обновим данные
            continue;                           // На след. итерацию
         case 146:Alert("Подсистема торговли занята. Пробуем ещё..");
            Sleep(500);                         // Простое решение
            RefreshRates();                     // Обновим данные
            continue;                           // На след. итерацию
        }
      switch(Error)                             // Критические ошибки
        {
         case 2 : Alert("Общая ошибка.");
            break;                              // Выход из switch
         case 5 : Alert("Старая версия клиентского терминала.");
            break;                              // Выход из switch
         case 64: Alert("Счет заблокирован.");
            break;                              // Выход из switch
         case 133:Alert("Торговля запрещена");
            break;                              // Выход из switch
         default: Alert("Возникла ошибка ",Error);// Другие варианты
        }
      break;                                    // Выход из цикла
     }
//--------------------------------------------------------------- 9 --
   Alert ("Скрипт закончил работу -----------------------------");
   return;                                      // Выход из start()
  }
//-------------------------------------------------------------- 10 --

Структура скрипта openbuystop.mq4 построена так же, как в скрипте openbuy.mq4, поэтому нет необходимости описывать его подробно. Остановимся только на основных отличиях этих программ.

Цена, на уровне которой скрипт был прикреплён к окну финансового инструмента, определяется в строке:

   double Win_Price=WindowPriceOnDropped();     // Здесь брошен скрипт

В дальнейшем значение этой переменной сохраняется неизменным в течение всего времени работы программ. Это необходимо в случае, если скрипт несколько раз подряд потерпит неудачу при попытке установить ордер. При этом скрипт всякий раз будет вычислять заявленное значение цены, близкой к тому месту (тому уровню цены), где пользователь прикрепил скрипт.

Нетрудно увидеть, что в скрипте openbuystop.mq4 отсутствует проверка достаточности свободных средств для открытия ордера, но появилась проверка значения цены открытия ордера (блок 3-4). Если вычисленное значение переменной Price не удовлетворяет требованиям установки отложенного Stop ордера (см. Характеристики ордеров, Требования и ограничения торговых операций), то производится перерасчёт этого значения.

В блоке обработки ошибок также произошли небольшие изменения: некоторые ошибки не рассматриваются, но появилась обработка кодов других ошибок.

Разумные ограничения

В связи с использованием торговых функций необходимо обратить внимание на ограничения более общего характера. Например, ошибка 146 возникает только в том случае, если в окне одного финансового инструмента одновременно работают несколько программ, формирующих торговые приказы. По мнению автора, такая практика, хотя и допустима, но не оправданна.

Гораздо эффективнее - создать и использовать одну торгующую программу, которая учитывала бы все особенности торговли. Во время работы одной программы возможность формирования одновременно нескольких торговых приказов вообще не возникает. Кроме того, в такой программе можно более эффективно организовать весь алгоритм: учитывать вероятность успешных торгов по различным финансовым инструментам и в зависимости от этого правильно перераспределять денежные средства.

Для торговых операций более эффективно использовать полноценный эксперт, а скрипт лучше применять для разовых расчётов и сообщения на экран некоторой полезной информации. Вместе с тем, в случае если трейдер не использует эксперт для автоматической торговли, применение скриптов оказывается более эффективным, чем управление ордерами с помощью панели управления клиентского терминала.

Характеристики ордеров и правила проведения торговых операцийЗакрытие и удаление ордеров


Простой эксперт - Простые программы на MQL4 - Учебник по MQL4

Учебник по MQL4 [image] Простые программы на MQL4 [image] Простой эксперт
MetaQuotes Sofware Corp.
  • Использование технических индикаторов
  • Простой эксперт
  • Создание пользовательских индикаторов
  • Пользовательский индикатор скорости изменения цены (ROC)
  • Совместное использование программ
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Простой эксперт

В этом параграфе рассматриваются принципы построения простого торгующего эксперта.

Задача 29. Создать торгующий эксперт.

Предварительные рассуждения

Прежде, чем приступить к программированию торгующего эксперта, необходимо обозначить общие контуры будущей программы. Каких-либо жёстких правил составления программ не существует. Вместе с тем, однажды составив программу, программист обычно продолжает совершенствовать её в будущем. Чтобы в дальнейшем в программе можно было без труда разобраться, она должна быть составлена в соответствии с осмысленной и интуитивно понятной схемой (особенно важно это бывает в случаях, когда программа передаётся для доработки другому программисту). Наиболее удобно работать с программой, состоящей из функциональных блоков, каждый из которых отвечает за свою часть вычислений. Чтобы составить алгоритм торгующего эксперта, проанализируем, что вообще должна делать работающая программа.

Одним из наиболее важных показателей при формировании торговых приказов являются сведения о том, какие ордера в текущий момент уже имеются в терминале. Существуют торговые стратегии, допускающие наличие только одного однонаправленного ордера. В общем случае, если торговая стратегия это допускает, в терминале может быть открыто одновременно несколько ордеров, однако их количество должно быть разумно ограничено. При использовании любой стратегии торговые решения должны приниматься с учётом текущей ситуации. Прежде, чем в программе будет принято какое бы то ни было торговое решение, необходимо знать какие ордера уже открыты или установлены. Поэтому программа должна содержать блок учёта ордеров, исполняемый в программе одним из первых.

В процессе исполнения эксперта должны приниматься торговые решения, реализация которых приводит к осуществлению торговых операций. Часть кода, отвечающую за формирование торговых приказов, желательно выделить в отдельный блок. Эксперт может сформировать торговый приказ для открытия нового отложенного или рыночного ордера, закрытия или модификации какого-то из имеющихся ордеров или не осуществлять никаких действий. В эксперте также должна вычисляться стоимость ордеров в зависимости от пожеланий пользователя.

Торговые решения должны приниматься в программе на основе торговых критериев. От того, насколько правильно в программе определяются торговые критерии, зависит успешность всей программы. При вычислении торговых критериев программа может (и должна) принимать во внимание любые сведения, которые могут оказаться полезными. Например, эксперт может анализировать сочетание показателей технических индикаторов, время обнародования важных новостей, текущее время, значения некоторых ценовых уровней и т.д. Для удобства часть программы, отвечающую за вычисление торговых критериев, желательно выделить в отдельный блок.

Торгующий эксперт также обязательно должен содержать блок обработки ошибок. Анализ ошибок, иногда возникающих при осуществлении торговых операций, позволит, с одной стороны, повторить торговый приказ, а с другой стороны - уведомить пользователя о возможной конфликтной ситуации.

Структура простого эксперта

Ниже представлена структурная схема простого эксперта, построенная на основе нескольких функциональных блоков, в каждом из которых выполняется некоторая обособленная часть вычислений.

Рис. 109. Структурная схема простого эксперта.

На данной стадии разработки эксперта программного кода пока ещё нет. В то же время алгоритм будущей программы в значительной степени уже сложился. Как будет работать эксперт, построенный на основе представленной схемы, можно легко понять, просто глядя на схему и ориентируясь по названию блоков и стрелкам связей (передачи управления) между ними.

После запуска программы на исполнение управление поступает в блок предварительной обработки. В этом блоке можно проанализировать некоторые общие параметры. Например, если в окне недостаточно баров (необходимых для вычисления параметров технических индикаторов), то эксперт не сможет полноценно работать. В этом случае эксперт должен прекратить работу, предварительно известив об этом пользователя, а также сообщив причину отказа в работе. Если противопоказаний общего характера нет, то управление передаётся в блок учёта ордеров.

В блоке учёта ордеров вычисляется количество и качество ордеров, имеющихся в терминале по некоторому финансовому инструменту (в окно которого присоединён эксперт). В этом блоке должны быть отсеяны ордера по другим финансовым инструментам. Если программируемая торговая стратегия предполагает использование только рыночных ордеров (и не использует отложенные ордера), то должен быть обнаружен факт наличия отложенных ордеров. Если стратегия допускает только один рыночный ордер, а фактически их несколько, то этот факт также должен быть известен. Задача блока учёта ордеров (в этой схеме) состоит в том, чтобы определить соответствует ли текущая торговая ситуация ожидаемой, т. е такой, в которой эксперт может полноценно работать. И если соответствует, то управление должно быть передано следующему блоку для продолжения работы эксперта, а если нет, то необходимо прекратить работу эксперта и сообщить об этом пользователю.

Если в терминале нет ордеров или количество и качество имеющихся ордеров соответствует ожидаемому, то управление передаётся в блок определения торговых критериев. В этом блоке должны быть вычислены все критерии, необходимые для принятия торговых решений, а именно критерии для открытия, закрытия и модификации ордеров. Далее управление передаётся в блок закрытия ордеров.

Нетрудно понять, почему в представленной схеме блок закрытия ордеров исполняется раньше, чем блок открытия ордеров. Всегда разумнее сначала выполнить обработку имеющихся ордеров (закрыть или модифицировать) и лишь после этого открывать новые ордера. В целом правильно исходить из стремления иметь в терминале как можно меньше ордеров. В процессе исполнения этого блока должны быть закрыты все ордера, для которых сработал критерий закрытия.

После того, как необходимые ордера закрыты, управление передаётся в блок вычисления размера новых ордеров. Существует множество алгоритмов для вычисления объема ордера. Самый простой из них - постоянный, фиксированный лот. Этот алгоритм удобно включать в программу для тестирования стратегии. Более распространённый способ определения размера ордера состоит в том, что количество лотов ставится в зависимость от суммы свободных средств, например, может составлять 30-40%. Если средств на счёте недостаточно, то программа заканчивает работу, предварительно уведомив пользователя о причине.

После определения количества лотов для вновь открываемых ордеров управление передаётся в блок открытия ордеров. Если какой-либо из вычисленных ранее критериев указывают на необходимость открытия ордера определённого типа, то в этом блоке формируется торговый приказ на открытие ордера.

В эксперте предусмотрен также анализ ошибок. Если какая-либо торговая операция закончилась неудачей, то (только в этом случае) управление передаётся в блок обработки ошибок. Если ошибка, возвращённая сервером или клиентским терминалом, не является непреодолимой, то производится повторная попытка осуществить торговую операцию. Если же возвращена критическая ошибка (например, заблокирован счёт), то эксперт должен прекратить работу. Здесь необходимо напомнить, что в MQL4 не предусмотрено возможности программного завершения работы экспертов в окне финансового инструмента (в отличие от скриптов, см. Специальные функции). Всё, что программно можно сделать в эксперте - это завершить исполнение специальной функции start(). При новом запуске функции start() на новом тике можно проанализировать значение некоторой переменной - флага, запрещающего торговлю (в данном случае поднятого в результате появления критической ошибки) и передать управление на завершение исполнение специальной функции, не допуская, таким образом, формирование новых торговых приказов. В представленной схеме значение флага анализируется в блоке предварительной обработки.

Торговая стратегия

Рыночные цены находятся в постоянном движении. Состояние рынка в любой момент может быть условно охарактеризовано либо как тренд - сильное однонаправленное изменение (повышение или понижение) цены, либо как флэт - боковое движение цены со слабыми отклонениями от некоторой средней. Эти характеристики рынка являются условными, поскольку не существует чётких критериев, в соответствии с которыми тренд или флэт можно было бы идентифицировать. Например, бывают продолжительные боковые движения цен с сильными отклонениями, которые нельзя отнести ни к флэту ни к тренду. В целом принято считать, что в основном рынок находится в состоянии бокового движения, а тренды на рынке занимают около 15-20% времени.

Рис. 110. Флэт и тренд на рынке.

Все торговые стратегии также можно условно разделить на две основные группы. К первой группе относятся торговые стратегии, ориентированные на флэт. Основная идея таких стратегий заключается в том, что после заметного отклонения от некоторой средней цена должна вернуться назад, поэтому ордера открываются в сторону, противоположную последнему движению цены. Ко второй группе относятся трендовые стратегии, в которых ордера открываются в сторону последнего движения цены. Существуют также и более сложные (смешанные) стратегии. В таких стратегиях принимается во внимание множество различных факторов, характеризующих рынок, в результате чего становится возможным вести торговлю как на флэте, так и на тренде. Торговлю по той или иной стратегии технически реализовать несложно - в MQL4 для этой цели имеются все необходимые средства. Основная работа при создании собственной стратегии сводится к поиску торговых критериев.

Торговые критерии

В данном примере мы попробуем построить трендовый эксперт, т.е. такой, который будет открывать ордера в сторону движения цены. Для этого среди множества показателей различных технических индикаторов необходимо найти такие, которые свидетельствуют о начале тренда. Один из наиболее простых методов поиска торговых критериев основан на анализе сочетания средних МА с различным периодом усреднения. На Рис. 111 и Рис. 112 показано расположение двух различных МА (с периодами усреднения 11 и 31) на различных участках рынка. Средние с небольшим периодом усреднения (красного цвета) располагаются ближе ценовому графику, они более извилисты и подвижны. В то же время средние с большим периодом усреднения (синего цвета) более инертны, имеют большее запаздывание и располагаются дальше от рыночных цен. Обратим внимание на те места, в которых МА с разным периодом усреднения пересекаются, и попробуем решить: можно ли факт пересечения МА использовать в качестве торгового критерия.

Рис. 111. Пересечения МА(11) и МА(31) при изменении направления движения цены.

На Рис. 111 показан участок рынка, на котором открытие ордеров в сторону движения цены по факту пересечения МА оправдано. В точке А красная линия пересекает синюю линию снизу вверх, и вслед за этим событием рыночная цена некоторое время продолжает расти. Последующее обратное пересечение МА свидетельствует об изменении направления движения цены. Если в точке А открыть ордер Buy, а в точке В закрыть его, то в результате будет получена прибыль, пропорциональная разнице цен А и В.

Рис. 112. Пересечения МА(11) и МА(31) при изменении направления движения цены.

В то же время на рынке попадаются и другие участки, на которых МА также пересекаются, однако это не приводит к существенному последующему повышению или снижению цены (Рис. 112). Ордера, открытые по факту пересечения МА на таких участках оказываются убыточными. Если в точке А открыть Sell, а в точке В его закрыть, то результатом такой торговой операции окажется убыток. То же можно сказать и об ордере Buy, открытом в точке В закрытом в точке С.

Успешность всей стратегии, реализованной на основе факта пересечения МА, в конечном счёте зависит от количества участков, которые можно охарактеризовать как тренд и флэт. На флэте частое пересечение МА является закономерным явлением, которое сильно вредит любой трендовой стратегии. Множественные ложные сигналы, как правило, приводят к общему убытку. Поэтому данный признак - факт пересечения МА с различным периодом усреднения - можно использовать для построения трендовых стратегий только в сочетании с другими признаками, подтверждающими наличие тренда. В данном примере (для построения простого эксперта) мы вынуждены отказаться от использования этого признака.

Используем другой признак. Визуально анализируя характер изменения цен на рынке можно заметить, что длительное однонаправленное повышение или понижение цен часто возникает в результате непродолжительного сильного движения. Иными словами, если в течение краткосрочного периода случилось сильное движение цены, то в среднесрочной перспективе можно ожидать его продолжение.

Рис. 113. Сильное движение цены может привести к развитию тенденции.

На Рис. 113 показан участок рынка, на котором сильное движение цены привело к продолжению изменения цены в том же направлении. В качестве показателя "сильного движения" можно использовать разницу значений МА с различным периодом усреднения. Чем сильнее движение, тем большее отставание МА с большим периодом усреднения от МА с малым периодом усреднения. Показательно, что даже сильные скачкообразные изменения цен с последующим возвратом не приводят к большой разнице значений между различными МА, т.е. не возникает много нежелательных ложных сигналов. Например, скачкообразное изменение цены на 50 пунктов, сопровождаемое последующим откатом (в центре Рис. 113), привело к увеличению разницы между МА всего на 20 пунктов. В то же время, действительно сильное движение (которое обычно не сопровождается значительной коррекцией) в точке А повлекло за собой увеличение разницы между МА до 25 - 30 пунктов.

Если при достижении некоторого значения разницы между значениями различных МА, например, в точке А, открыть ордер Buy, то вполне вероятно, что в конечном итоге этот ордер окажется прибыльным, когда цена достигнет уровня заявленного значения его стоп-приказа. Используем этот показатель в качестве торгового критерия в нашем эксперте.

Количество ордеров

В этом примере рассматривается эксперт, допускающий наличие только одного рыночного ордера и не предусматривающий отложенных ордеров. Такой подход является оправданным не только в данном конкретном примере, а может быть взят за основу для построения любой стратегии.

Отложенные ордера обычно используются в тех случаях, когда в распоряжении разработчика имеется достаточно надёжный критерий, позволяющий прогнозировать изменение цены с большой вероятностью успеха. Если же такого критерия нет, то в применении отложенных ордеров нет необходимости.

Нельзя считать обоснованной также ситуацию, когда по одному финансовому инструменту открыто несколько встречных ордеров. Ранее уже упоминалось, что с экономической точки зрения встречные ордера представляют бессмыслицу, тем более, если стоимость этих ордеров одинаковая (см. Закрытие и удаление ордеров). В таком случае необходимо просто закрыть один ордер за счёт другого и ждать сигнала для открытия одного рыночного ордера в каком-либо направлении.

Отношение торговых критериев

С этой позиции становится понятным также, в каком соотношении между собой могут находиться торговые критерии. На Рис. 114 представлено три варианта соотношений торговых критериев, при которых каждый из критериев остаётся значимым (действующим, имеющим силу). Развитие событий (открытие и закрытие рыночных ордеров) на представленных рисунках происходит по часовой стрелке.

Рис. 114. Соотношение критериев открытия и закрытия ордеров (а и b - правильные критерии, с - неправильные).

Наиболее распространённым вариантом правильно сформированных торговых критериев является вариант а. После открытия рыночный ордер Buy удерживается открытым до момента, когда сработает критерий, предписывающий его закрытие. Вслед за этим возникает пауза, в течение которой не открываются никакие ордера. В последующих событиях может быть открыт рыночный ордер Sell, условия для закрытия которого (в соответствии с правильно составленными критериями) возникают раньше, чем могут созреть условия для открытия ордера Buy. Вместе с тем, конечно, не исключается возможность повторного открытия Buy, если на это указывает критерий открытия. Однако, согласно этому варианту не допускается открытие рыночного ордера, если имеется рыночный ордер, открытый в противоположном направлении.

Аналогичное соотношение торговых критериев заключено и в варианте b. Отличие состоит лишь в том, что критерий для открытия любого рыночного ордера одновременно является критерием для закрытия противоположного ордера. Этот вариант также, как и вариант а, не допускает наличия в терминале одновременно нескольких рыночных ордеров по одному финансовому инструменту.

Вариант соотношения торговых критериев с, является ошибочным. Согласно этому варианту допускается открытие рыночного ордера в условиях, когда ещё не закрыты противоположные ордера, что противоречит здравому смыслу. Возможны исключительные случаи, отчасти оправдывающие это вариант. Открытие встречного ордера иногда допускается для того, чтобы компенсировать убытки, возникающие при небольших коррекциях после сильных движений рыночных цен. В таких случаях встречный ордер может быть открыт на ту же или несколько меньшую сумму, чем уже имеющийся, а после окончания коррекции - закрыт. Такая тактика позволяет не затрагивать "основной" ордер, открытый в пользу тренда.

В общем случае допустимо также наличие нескольких однонаправленных ордеров. Это может быть оправдано в случаях, когда ранее открытый ордер уже защищён стоп-приказом и снова сработал критерий, указывающий на развитие движение цены в том же направлении. Вместе с тем, при создании подобной торговой стратегии разработчик должен отдавать себе отчёт в том, что в случае резкого изменения направления движения цены установленные стоп-приказы могут быть не исполнены некоторыми брокерами по первому касанию цены. При этом убыток будет пропорционален общей стоимости однонаправленных рыночных ордеров.

В нашем примере используется вариант b соотношения торговых критериев. Все открытые рыночные ордера закрываются либо по стоп-приказу, либо в результате срабатывания критерия открытия ордера в противоположном направлении (при этом критерий закрытия Buy совпадает с критерием открытия Sell и наоборот).

Размер открываемых ордеров

При любой торговой стратегии размеры ордеров должны быть разумно ограничены. В простом случае в эксперте предусматривается постоянный размер ордеров. Перед началом работы пользователь по своему усмотрению может установить любой объем будущих ордеров и в течение некоторого срока не изменять её. В дальнейшем, если сумма баланса изменится, пользователь может установить новое значение количества лотов открываемых ордеров.

Слишком маленький размер ордеров позволит получить больше уверенности в работе при непредсказуемом изменении рынка, но и сумма прибыли при успешной работе в этом случае окажется незначительной. При слишком большом размере ордеров можно получить и пропорционально большую прибыль, однако такой эксперт будет слишком рисковым. Обычно размер открываемых ордеров устанавливается таким образом, чтобы залоговые средства не превышали 2 - 35% от баланса или от суммы свободных средств (если стратегия допускает только один ордер, то значения баланса и свободных средств в момент, предшествующий открытию ордера, совпадают).

В данном примере реализованы оба варианта. Пользователь может по своему выбору либо прямо указать стоимость ордеров, либо установить для стоимости ордеров значение в процентах от суммы свободных средств.

Подробности программирования

Простой трендовый эксперт tradingexpert.mq4, построенный на основе предыдущих рассуждений, может выглядеть так:

//--------------------------------------------------------------------
// tradingexpert.mq4
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------------
#property copyright "Copyright © Book, 2007"
#property link      "http://AutoGraf.dp.ua"
//--------------------------------------------------------------- 1 --
                                   // Численные значения для М15
extern double StopLoss   =200;     // SL для открываемого ордера
extern double TakeProfit =39;      // ТР для открываемого ордера
extern int    Period_MA_1=11;      // Период МА 1
extern int    Period_MA_2=31;      // Период МА 2
extern double Rastvor    =28.0;    // Расстояние между МА
extern double Lots       =0.1;     // Жестко заданное колич. лотов
extern double Prots      =0.07;    // Процент свободных средств

bool Work=true;                    // Эксперт будет работать.
string Symb;                       // Название финанс. инструмента
//--------------------------------------------------------------- 2 --
int start()
  {
   int
   Total,                           // Количество ордеров в окне
   Tip=-1,                          // Тип выбран. ордера (B=0,S=1)
   Ticket;                          // Номер ордера
   double
   MA_1_t,                          // Значен. МА_1 текущее
   MA_2_t,                          // Значен. МА_2 текущее
   Lot,                             // Колич. лотов в выбран.ордере
   Lts,                             // Колич. лотов в открыв.ордере
   Min_Lot,                         // Минимальное количество лотов
   Step,                            // Шаг изменения размера лота
   Free,                            // Текущие свободные средства
   One_Lot,                         // Стоимость одного лота
   Price,                           // Цена выбранного ордера
   SL,                              // SL выбранного ордера
   TP;                              // TP выбранного ордера
   bool
   Ans  =false,                     // Ответ сервера после закрытия
   Cls_B=false,                     // Критерий для закрытия  Buy
   Cls_S=false,                     // Критерий для закрытия  Sell
   Opn_B=false,                     // Критерий для открытия  Buy
   Opn_S=false;                     // Критерий для открытия  Sell
//--------------------------------------------------------------- 3 --
   // Предварит.обработка
   if(Bars < Period_MA_2)                       // Недостаточно баров
     {
      Alert("Недостаточно баров в окне. Эксперт не работает.");
      return;                                   // Выход из start()
     }
   if(Work==false)                              // Критическая ошибка
     {
      Alert("Критическая ошибка. Эксперт не работает.");
      return;                                   // Выход из start()
     }
//--------------------------------------------------------------- 4 --
   // Учёт ордеров
   Symb=Symbol();                               // Название фин.инстр.
   Total=0;                                     // Количество ордеров
   for(int i=1; i<=OrdersTotal(); i++)          // Цикл перебора ордер
     {
      if (OrderSelect(i-1,SELECT_BY_POS)==true) // Если есть следующий
        {                                       // Анализ ордеров:
         if (OrderSymbol()!=Symb)continue;      // Не наш фин. инструм
         if (OrderType()>1)                     // Попался отложенный
           {
            Alert("Обнаружен отложенный ордер. Эксперт не работает.");
            return;                             // Выход из start()
           }
         Total++;                               // Счётчик рыночн. орд
         if (Total>1)                           // Не более одного орд
           {
            Alert("Несколько рыночных ордеров. Эксперт не работает.");
            return;                             // Выход из start()
           }
         Ticket=OrderTicket();                  // Номер выбранн. орд.
         Tip   =OrderType();                    // Тип выбранного орд.
         Price =OrderOpenPrice();               // Цена выбранн. орд.
         SL    =OrderStopLoss();                // SL выбранного орд.
         TP    =OrderTakeProfit();              // TP выбранного орд.
         Lot   =OrderLots();                    // Количество лотов
        }
     }
//--------------------------------------------------------------- 5 --
   // Торговые критерии
   MA_1_t=iMA(NULL,0,Period_MA_1,0,MODE_LWMA,PRICE_TYPICAL,0); // МА_1
   MA_2_t=iMA(NULL,0,Period_MA_2,0,MODE_LWMA,PRICE_TYPICAL,0); // МА_2

   if (MA_1_t > MA_2_t + Rastvor*Point)         // Если разница между
     {                                          // ..МА 1 и 2 большая
      Opn_B=true;                               // Критерий откр. Buy
      Cls_S=true;                               // Критерий закр. Sell
     }
   if (MA_1_t < MA_2_t - Rastvor*Point)         // Если разница между
     {                                          // ..МА 1 и 2 большая
      Opn_S=true;                               // Критерий откр. Sell
      Cls_B=true;                               // Критерий закр. Buy
     }
//--------------------------------------------------------------- 6 --
   // Закрытие ордеров
   while(true)                                  // Цикл закрытия орд.
     {
      if (Tip==0 && Cls_B==true)                // Открыт ордер Buy..
        {                                       //и есть критерий закр
         Alert("Попытка закрыть Buy ",Ticket,". Ожидание ответа..");
         RefreshRates();                        // Обновление данных
         Ans=OrderClose(Ticket,Lot,Bid,2);      // Закрытие Buy
         if (Ans==true)                         // Получилось :)
           {
            Alert ("Закрыт ордер Buy ",Ticket);
            break;                              // Выход из цикла закр
           }
         if (Fun_Error(GetLastError())==1)      // Обработка ошибок
            continue;                           // Повторная попытка
         return;                                // Выход из start()
        }

      if (Tip==1 && Cls_S==true)                // Открыт ордер Sell..
        {                                       // и есть критерий закр
         Alert("Попытка закрыть Sell ",Ticket,". Ожидание ответа..");
         RefreshRates();                        // Обновление данных
         Ans=OrderClose(Ticket,Lot,Ask,2);      // Закрытие Sell
         if (Ans==true)                         // Получилось :)
           {
            Alert ("Закрыт ордер Sell ",Ticket);
            break;                              // Выход из цикла закр
           }
         if (Fun_Error(GetLastError())==1)      // Обработка ошибок
            continue;                           // Повторная попытка
         return;                                // Выход из start()
        }
      break;                                    // Выход из while
     }
//--------------------------------------------------------------- 7 --
   // Стоимость ордеров
   RefreshRates();                              // Обновление данных
   Min_Lot=MarketInfo(Symb,MODE_MINLOT);        // Миним. колич. лотов
   Free   =AccountFreeMargin();                 // Свободн средства
   One_Lot=MarketInfo(Symb,MODE_MARGINREQUIRED);// Стоимость 1 лота
   Step   =MarketInfo(Symb,MODE_LOTSTEP);       // Шаг изменен размера

   if (Lots > 0)                                // Если заданы лоты,то
      Lts =Lots;                                // с ними и работаем
   else                                         // % свободных средств
      Lts=MathFloor(Free*Prots/One_Lot/Step)*Step;// Для открытия

   if(Lts < Min_Lot) Lts=Min_Lot;               // Не меньше минимальн
   if (Lts*One_Lot > Free)                      // Лот дороже свободн.
     {
      Alert(" Не хватает денег на ", Lts," лотов");
      return;                                   // Выход из start()
     }
//--------------------------------------------------------------- 8 --
   // Открытие ордеров
   while(true)                                  // Цикл закрытия орд.
     {
      if (Total==0 && Opn_B==true)              // Открытых орд. нет +
        {                                       // критерий откр. Buy
         RefreshRates();                        // Обновление данных
         SL=Bid - New_Stop(StopLoss)*Point;     // Вычисление SL откр.
         TP=Bid + New_Stop(TakeProfit)*Point;   // Вычисление TP откр.
         Alert("Попытка открыть Buy. Ожидание ответа..");
         Ticket=OrderSend(Symb,OP_BUY,Lts,Ask,2,SL,TP);//Открытие Buy
         if (Ticket > 0)                        // Получилось :)
           {
            Alert ("Открыт ордер Buy ",Ticket);
            return;                             // Выход из start()
           }
         if (Fun_Error(GetLastError())==1)      // Обработка ошибок
            continue;                           // Повторная попытка
         return;                                // Выход из start()
        }
      if (Total==0 && Opn_S==true)              // Открытых орд. нет +
        {                                       // критерий откр. Sell
         RefreshRates();                        // Обновление данных
         SL=Ask + New_Stop(StopLoss)*Point;     // Вычисление SL откр.
         TP=Ask - New_Stop(TakeProfit)*Point;   // Вычисление TP откр.
         Alert("Попытка открыть Sell. Ожидание ответа..");
         Ticket=OrderSend(Symb,OP_SELL,Lts,Bid,2,SL,TP);//Открытие Sel
         if (Ticket > 0)                        // Получилось :)
           {
            Alert ("Открыт ордер Sell ",Ticket);
            return;                             // Выход из start()
           }
         if (Fun_Error(GetLastError())==1)      // Обработка ошибок
            continue;                           // Повторная попытка
         return;                                // Выход из start()
        }
      break;                                    // Выход из while
     }
//--------------------------------------------------------------- 9 --
   return;                                      // Выход из start()
  }
//-------------------------------------------------------------- 10 --
int Fun_Error(int Error)                        // Ф-ия обработ ошибок
  {
   switch(Error)
     {                                          // Преодолимые ошибки
      case  4: Alert("Торговый сервер занят. Пробуем ещё раз..");
         Sleep(3000);                           // Простое решение
         return(1);                             // Выход из функции
      case 135:Alert("Цена изменилась. Пробуем ещё раз..");
         RefreshRates();                        // Обновим данные
         return(1);                             // Выход из функции
      case 136:Alert("Нет цен. Ждём новый тик..");
         while(RefreshRates()==false)           // До нового тика
            Sleep(1);                           // Задержка в цикле
         return(1);                             // Выход из функции
      case 137:Alert("Брокер занят. Пробуем ещё раз..");
         Sleep(3000);                           // Простое решение
         return(1);                             // Выход из функции
      case 146:Alert("Подсистема торговли занята. Пробуем ещё..");
         Sleep(500);                            // Простое решение
         return(1);                             // Выход из функции
         // Критические ошибки
      case  2: Alert("Общая ошибка.");
         return(0);                             // Выход из функции
      case  5: Alert("Старая версия терминала.");
         Work=false;                            // Больше не работать
         return(0);                             // Выход из функции
      case 64: Alert("Счет заблокирован.");
         Work=false;                            // Больше не работать
         return(0);                             // Выход из функции
      case 133:Alert("Торговля запрещена.");
         return(0);                             // Выход из функции
      case 134:Alert("Недостаточно денег для совершения операции.");
         return(0);                             // Выход из функции
      default: Alert("Возникла ошибка ",Error); // Другие варианты
         return(0);                             // Выход из функции
     }
  }
//-------------------------------------------------------------- 11 --
int New_Stop(int Parametr)                      // Проверка стоп-прик.
  {
   int Min_Dist=MarketInfo(Symb,MODE_STOPLEVEL);// Миним. дистанция
   if (Parametr < Min_Dist)                     // Если меньше допуст.
     {
      Parametr=Min_Dist;                        // Установим допуст.
      Alert("Увеличена дистанция стоп-приказа.");
     }
   return(Parametr);                            // Возврат значения
  }
//-------------------------------------------------------------- 12 --

Описание переменных

Немаловажным критерием при оценке программы является её читабельность. Правильно составленной программой следует считать такую, которая без труда воспринимается другим программистом, поэтому все основные части программы, а также основополагающие моменты, характеризующие стратегию, должны быть прокомментированы. По этой же причине желательно все переменные объявить и прокомментировать в начале программы.

В блоке 1-2 описаны внешние и глобальные переменные.

Согласно правилам внешние и глобальные переменные должны быть открыты до первого использования этих переменных (см. Виды переменных), поэтому все они объявлены в головной части программы. Все локальные переменные функции start() собраны и описаны в верхней части функции (блок 2-3), сразу после заголовка функции. Правила объявления локальных переменных этого не требует, однако и не запрещают. При чтении программы, если у программиста возникают затруднения с пониманием смысла какой-либо переменной, он легко может обратиться к верхней части программы и выяснить смысл и тип любой переменной. В практике программирования это очень удобно.

Блок предварительной обработки

В данном примере предварительная обработка ситуации состоит из двух частей (блок 3-4). Программа заканчивает работу в случае, если в окне финансового инструмента мало баров; в этом случае не представляется возможным правильно определить (в блоке 5-6) значения скользящих средних, необходимых для вычисления торговых критериев. Кроме того, здесь анализируется значение глобальной переменной Work. При нормальной работе эксперта значение этой переменной всегда равно true (устанавливается один раз при инициализации). Если же при выполнении программы возникла критическая (непреодолимая) ошибка, то эта переменная получает значение false, в результате чего специальная функция start() заканчивает работу. В дальнейшем это значение никогда не изменяется, поэтому и последующий код программы не исполняется. В этом случае необходимо остановить исполнение программы и установить причину возникновения критической ошибки (при необходимости связаться с дилинговым центром). После того, как ситуация будет разрешена, можно снова запустить программу в работу, присоединив эксперт к окну финансового инструмента.

Учёт ордеров

Рассматриваемый эксперт предполагает возможность работы только с одним рыночным ордером. Задачей блока учёта ордеров (блок 4-5) является определение характеристик открытого ордера, если такой ордер есть. В цикле перебора ордеров for опрашиваются все имеющиеся рыночные и отложенные ордера, а именно от первого (int i=1) до последнего (i<=OrdersTotal()). На каждой итерации этого цикла с помощью функции OrderSelect() выбирается очередной ордер. Выбор производится из источника открытых и отложенных ордеров (SELECT_BY_POS).

   if (OrderSelect(i-1,SELECT_BY_POS)==true) // Если есть следующий

Если этот выбор удалось выполнить успешно (т.е. если в терминале есть очередной ордер), то в дальнейшем и этот ордер и сложившуюся ситуацию необходимо исследовать: открыт ли выбранный ордер по финансовому инструменту, по которому работает эксперт, является ли ордер рыночным или отложенным, а также учесть его при подсчёте ордеров. В строке:

      if (OrderSymbol()!=Symb)continue;      // Не наш фин. инструм

отсеиваются все ордера, открытые по какому-либо другому финансовому инструменту. Оператор continue заканчивает текущую итерацию, в результате чего характеристики этого ордера не обрабатываются. Если же ордер открыт по тому финансовому инструменту, в окно которого присоединён эксперт, он подвергается следующей проверке.

Если функция OrderType() возвращает значение больше 1 (см. Типы торговых операций), то выбранный ордер - отложенный. Но в данном эксперте не предусмотрено управление отложенными ордерами. Это значит, что необходимо закончить исполнение специальной функции start(), т.к. сложилась конфликтная ситуация. В этом случае после сообщения об окончании работы исполнение функции start() заканчивается с помощью оператора return.

Если последняя проверка показала, что исследуемый ордер рыночный, то производится подсчёт и анализ общего количества ордеров, открытых по финансовому инструменту. Для первого из таких ордеров определяются все необходимые характеристики. Если же на очередной итерации счётчик ордеров (переменная Total ) зафиксирует второй рыночный ордер, то такая ситуация также расценивается как конфликтная, т.к. эксперт не предназначен для управления более, чем одним рыночным ордером. В этом случае исполнение специальной функции start() после уведомления пользователя заканчивается.

В результате исполнения блока учёта ордеров (если все проверки прошли успешно) переменная Total сохраняет своё значение нулевым, если рыночных ордеров нет, или получает значение 1, если по нашему финансовому инструменту имеется рыночный ордер. В последнем случае ряд переменных, поставленных в соответствие характеристикам ордера (номер, тип, цена открытия, значения стоп-приказов и стоимость ордера), тоже получают свои значения.

Вычисление торговых критериев

В рассматриваемом примере определение торговых критериев (блок 5-6) вычисляется на основе разницы значений скользящих средних с различными периодами усреднения. В соответствии с принятыми критериями ценовой график имеет бычье направление, если текущее значение МА малого периода усреднения больше, чем значение МА большего периода, и разница между значениями средних превышает некоторую величину. При медвежьем движении рынка МА малого периода находится ниже, чем МА большого периода, и разница между этими значениями также превышает некоторую критическую величину.

В начале блока вычисляются значения средних с периодами усреднения Period_MA_1 и Period_MA_2. Факт значимости какого-либо торгового критерия выражается через значение соответствующей переменной. Переменные Opn_B и Opn_S означают срабатывание критерия для открытия ордеров Buy и Sell, а переменные Cls_В и Cls_S - для закрытия. Например, если критерий для открытия ордера Buy не сработал, то значение переменной Opn_B остаётся равным false (установленным при инициализации переменной), а если критерий сработал, то переменная Opn_B получает значение true. В данном случае критерий закрытия ордера Sell совпадает с критерием открытия ордера Buy и критерий открытия Sell совпадает с критерием закрытия Buy.

Принятые в данном эксперте торговые критерии используются в учебных целях и не должны рассматриваться как руководство к действию при торговле на реальном счёте.

Закрытие ордеров

Ранее указывалось, что данный эксперт предназначен для работы только с одним рыночным ордером, открытым по финансовому инструменту, в окне которого работает эксперт. К моменту, когда управление в программе передаётся в блок закрытия ордеров, точно известно, что в текущий момент по финансовому инструменту либо вообще нет ордеров, либо имеется только один рыночный ордер. Поэтому в блоке закрытия ордеров код составлен таким образом, чтобы можно было успешно закрыть только один ордер.

Блок закрытия построен на основе бесконечного цикла while, тело которого состоит из двух аналогичных частей: первая часть предназначена для закрытия ордера Buy, а вторая - для закрытия Sell. Цикл while используется здесь для того, чтобы в случае неудачного завершения торговой операции её можно было повторить.

В заголовке первого оператора if вычисляется условие для закрытия ордера Buy ( закрытие рыночных ордеров Sell происходит по аналогичному алгоритму). Если тип ранее открытого ордера соответствует типу Buy (см. Типы торговых операций) и признак закрытия ордера Buy является значимым, то управление передаётся в тело оператора if, где формируется торговый приказ на закрытие. В качестве цены закрытия ордера в функции OrderClose() указывается значение двухсторонней котировки, соответствующее типу ордера (см. Требования и ограничения торговых операций). Если торговая операция выполнена успешно, то после сообщения о закрытии ордера текущая итерация цикла while прерывается, и, таким образом, исполнение блока закрытия ордеров заканчивается. Если же операция закрытия закончилась неудачей, то вызывается для исполнения пользовательская функция обработки ошибок Fun_Error() (блок 10-11).

Обработка ошибок

В качестве передаваемого параметра в функции Fun_Error() используется код последней ошибки, вычисленной с помощью GetLastError(). В зависимости от кода ошибки функция Fun_Error() возвращает 1 в случае, если ошибка преодолимая и торговую операцию можно повторить, и 0, если возникла критическая ошибка. Критические ошибки в свою очередь тоже делятся на два вида - те, после которых ещё можно продолжать исполнение программы (например, общая ошибка) и те, при появлении которых необходимо прекратить исполнение любых торговых операций (например, счёт заблокирован).

Если после неудачной торговой операции пользовательская функция вернула значение 1, то текущая итерация внешнего цикла while прерывается и на следующей итерации предпринимается следующая попытка осуществить торговую операцию - закрыть ордер. Если же функция обработки ошибок вернула 0, то прекращается текущее исполнение специальной функции start(). На ближайшем следующем тике функция start() будет снова запущена на исполнение клиентским терминалом и в случае, если условия для закрытия ордера сохраняются, будет предпринята очередная попытка закрыть ордер.

Если при обработке ошибок выяснится, что дальнейшее выполнение программы бессмысленно (например, если работа ведётся на устаревшей версии клиентского терминала), то при следующем запуске исполнение специальной функции start() будет прекращено в блоке предварительной обработки при анализе значения переменной Work.

Вычисление количества лотов для новых ордеров

Вычисление количества лотов может быть выполнено в соответствии с настройками пользователя по одному из двух вариантов. Первый вариант - некоторая постоянная величина, установленная пользователем. Согласно второму варианту количество лотов вычисляется на основе суммы, составляющей определённый процент (задаётся пользователем) от свободных средств на счету.

В начале блока определения количества лотов для новых ордеров (блок 7-8) вычисляются необходимые значения некоторых переменных - минимально допустимое количество лотов и шаг изменения лота, установленные брокером, количество свободных средств и стоимость одного лота для данного финансового инструмента.

В данном примере предусмотрено следующее. Если пользователь установил некоторое ненулевое значение для внешней переменной Lots, например, 0.5, то оно принимается как количество лотов Lts при формировании торгового приказа открытия ордера. Если же для внешней переменной Lots пользователь установил 0, то количество лотов Lts определяется на основании переменной Prots (процент), суммы свободных средств и условий, установленных брокером.

После вычисления значения Lts производится проверка. Если это значение оказывается меньше минимально допустимого, то принимается минимально допустимое, если при этом свободных средств не хватает, то после сообщения пользователю о недостатке средств исполнение специальной функции start() заканчивается.

Открытие ордеров

Блок открытия ордеров (блок 8-9) также, как и блок закрытия, представляет бесконечный цикл while. В заголовке первого оператора if вычисляются условия для открытия ордера Buy: если по финансовому инструменту нет ордеров (переменная Total равна 0) и признак для открытия ордера Buy является значимым ( Opn_B равно true ), то управление передаётся в тело оператора if для открытия ордера. В этом случае после обновления данных вычисляются заявленные цены для стоп-приказов.

Значения стоп-приказов изначально задаются пользователем во внешних переменных StopLoss и TakeProfit. В общем случае пользователь может установить значение для этих параметров меньшее, чем позволяет брокер. Кроме того, брокер в любой момент по своему усмотрению может изменить минимально допустимую дистанцию (это нередко случается при сильных движениях рынка, например, перед выходом важных новостей). Поэтому перед каждым открытием ордера значения стоп-приказов должны быть вычислены с учётом значений, установленных пользователем, а также минимально допустимого значения, установленного брокером.

Для вычисления значений стоп-приказов вызывается пользовательская функция New_Stop(); в качестве передаваемого параметра используется значение стоп-приказа, заданное пользователем. В функции New_Stop() сначала вычисляется текущее значение минимально допустимой дистанции. Если значение, заданное пользователем, удовлетворяет требованиям брокера, то возвращается это значение. Если же оно оказывается меньше допустимого, то новым значением стоп-приказа становится значение, допускаемое брокером. При этом значение цены стоп-приказа рассчитывается от соответствующей двухсторонней котировки (см. Требования и ограничения торговых операций).

Торговый приказ на открытие ордера формируется с помощью функции OrderSend(). Для расчёта цены открытия ордера и цен стоп-приказов используются те значения текущей двухсторонней котировки, которые соответствует типу открываемого ордера. Если торговая операция прошла успешно (а именно, сервер вернул номер открытого ордера), то после сообщения об успешном открытии исполнение специальной функции start() заканчивается. Если же ордер не был открыт, а клиентский терминал вернул ошибку, то производится обработка ошибок по ранее рассмотренному алгоритму.

Некоторые особенности кода

Рассматриваемый здесь код эксперта ориентирован на реализацию одной конкретной стратегии. Обратите внимание, некоторые программные строки содержат переменные и вычисления, которые при изменении стратегии пришлось бы переписывать.

Например, в соответствии с принятой стратегией, эксперт ориентирован на работу только с одним ордером. Это позволило использовать переменную Ticket как для идентификации номера закрываемого ордера (в блоке закрытия 6-7), так и для идентификации успешности исполнения торговой операции при открытии ордера (в блоке открытия 8-9). В данном случае такое решение вполне приемлемо. Вместе с тем, если рассматриваемый код взять за основу для реализации другой стратегии (например, позволять встречные ордера), то придётся дополнительно ввести ещё одну или несколько переменных, чтобы иметь возможность различать номера открытых ордеров и идентифицировать успешность торговых операций.

При последующем совершенствовании или изменении стратегии придётся изменить и некоторые программные строки, содержащие часть логики, заложенной в исходную стратегию. В частности, в блоке учёта ордеров не нужно будет прерывать исполнение программы в случаях, если по финансовому инструменту открыто несколько ордеров. Кроме того, изменятся и условия, при которых необходимо открывать и закрывать ордера, что неизбежно повлечёт за собой необходимость переписывания кода в блоках открытия и закрытия.

На основании этих рассуждений нетрудно прийти к выводу, что представленный простой эксперт не является совершенным. В общем случае для реализации учёта ордеров необходимо использовать универсальную функцию, основанную на использовании массивов данных, которая не несёт логики никакой конкретной стратегии. То же можно сказать и о блоках открытия и закрытия ордеров. Более совершенная программа должна содержать главную - аналитическую функцию, а все другие пользовательские функции должны быть ей подчинены. В этой аналитической функции необходимо собрать программный код, в котором анализируются все условия для реализации любой стратегии, а всем подчинённым функциям передать лишь очень ограниченный круг обязанностей. Функция учёта ордеров должна только учитывать ордера, функции открытия и закрытия ордеров должны только открывать и закрывать ордера, а аналитическая функция должна "думать" и всеми остальными управлять, т.е. при необходимости вызывать их для исполнения.

Использование технических индикаторовСоздание пользовательских индикаторов


Создание пользовательских индикаторов - Простые программы на MQL4 - Учебник по MQL4

Учебник по MQL4 [image] Простые программы на MQL4 [image] Создание пользовательских индикаторов
MetaQuotes Sofware Corp.
  • Использование технических индикаторов
  • Простой эксперт
  • Создание пользовательских индикаторов
  • Пользовательский индикатор скорости изменения цены (ROC)
  • Совместное использование программ
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Создание пользовательских индикаторов

При создании торговой стратегии у разработчика часто возникает необходимость графически отобразить в окне финансового инструмента некоторую зависимость, рассчитанную пользователем (программистом). Для этой цели в языке MQL4 предусмотрена возможность создания пользовательских индикаторов.

Пользовательский индикатор - это программа, составленная на языке MQL4, основным назначением которой является графическое отображение на экране рассчитанных зависимостей.

Устройство пользовательского индикатора

Необходимость буферов

Основным принципом, заложенным в основу пользовательских индикаторов, является передача значений индикаторных массивов клиентскому терминалу (для построения индикаторных линий) через буферы обмена.

Буфер - область памяти, содержащая численные значения индикаторного массива.

Стандартом языка MQL4 предусмотрена возможность построения с помощью одного пользовательского индикатора до восьми индикаторных линий. Каждой из индикаторных линий ставится в соответствие один индикаторный массив и один буфер. Каждый из буферов имеет свой индекс. Индекс первого буфера - 0, второго - 1, и т.д., а последнего - 7. На Рис. 115 показано как информация из пользовательского индикатора через буферы передаётся клиентскому терминалу для построения индикаторных линий.

Рис. 115. Передача значений индикаторных массивов через буфер клиентскому терминалу.

Общий порядок построения индикаторных линий состоит в следующем:

1. В пользовательском индикаторе выполняются вычисления, в результате чего элементы индикаторных массивов получают некоторые численные значения.

2. Значения элементов индикаторных массивов через буферы сообщаются клиентскому терминалу.

3. На основе массивов значений, полученных из буферов, клиентский терминал воспроизводит изображение индикаторных линий.

Из чего состоит пользовательский индикатор

Возьмём для примера простой пользовательский индикатор, с помощью которого отображаются две индикаторные линии - одна линия построена по максимальным значениям цен баров, а другая - по минимальным.

Пример простого пользовательского индикатора userindicator.mq4

//--------------------------------------------------------------------
// userindicator.mq4
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------------
#property indicator_chart_window    // Индик. рисуется в основном окне
#property indicator_buffers 2       // Количество буферов
#property indicator_color1 Blue     // Цвет первой линии
#property indicator_color2 Red      // Цвет второй линии

double Buf_0[],Buf_1[];             // Объявление массивов (под буферы индикатора)
//--------------------------------------------------------------------
int init()                          // Специальная функция init()
  {
   SetIndexBuffer(0,Buf_0);         // Назначение массива буферу
   SetIndexStyle (0,DRAW_LINE,STYLE_SOLID,2);// Стиль линии
   SetIndexBuffer(1,Buf_1);         // Назначение массива буферу
   SetIndexStyle (1,DRAW_LINE,STYLE_DOT,1);// Стиль линии
   return;                          // Выход из спец. ф-ии init()
  }
//--------------------------------------------------------------------
int start()                         // Специальная функция start()
  {
   int i,                           // Индекс бара
       Counted_bars;                // Количество просчитанных баров
//--------------------------------------------------------------------
   Counted_bars=IndicatorCounted(); // Количество просчитанных баров
   i=Bars-Counted_bars-1;           // Индекс первого непосчитанного
   while(i>=0)                      // Цикл по непосчитанным барам
     {
      Buf_0[i]=High[i];             // Значение 0 буфера на i-ом баре
      Buf_1[i]=Low[i];              // Значение 1 буфера на i-ом баре
      i--;                          // Расчёт индекса следующего бара
     }
//--------------------------------------------------------------------
   return;                          // Выход из спец. ф-ии start()
  }
//--------------------------------------------------------------------

Рассмотрим подробно из чего состоит этот индикатор. В любой прикладной программе, написанной на MQL4, можно указать настроечные параметры, которые позволяют клиентскому терминалу правильно обслуживать программу. В данном примере в головной части программы (см. Структура программы) имеется несколько строк, содержащих директивы #property.

Первая директива указывает клиентскому терминалу, в каком окне необходимо отображать индикаторные линии:

#property indicator_chart_window             // Индик. рисуется в основном окне

В MQL4 предусмотрено всего два варианта для отображения индикаторных линий: в основном окне финансового инструмента и в отдельном окне. Основное окно - это то окно, в котором отображается привычный график цены по финансовому инструменту. В данном примере параметр indicator_chart_window в директиве #property предписывает клиентскому терминалу отображать индикаторные линии в основном окне.

В следующей строке указано количество буферов, используемых в индикаторе:

#property indicator_buffers 2                // Количество буферов

В рассматриваемом примере предусматривается построение двух индикаторных линий. Каждой линии ставится в соответствие один буфер, поэтому общее количество буферов - два.

В следующих строках заданы цвета для каждой из индикаторных линий.

#property indicator_color1 Blue              // Цвет первой линии
#property indicator_color2 Red               // Цвет второй линии

Параметры indicator_color1 и indicator_color2 указывают на настройку цветов для соответствующего буфера - в данном случае для буферов с индексами 0 (Blue - синий цвет) и 1 (Red - красный цвет). Обратите внимание, литеры 1 и 2 в названиях параметров indicator_color1 и indicator_color2 - это не индексы буферов. Эти литеры являются составной частью названия констант, поставленных в соответствие буферам. Для каждой из этих констант может быть установлен свой цвет по усмотрению пользователя.

В следующей строке объявлены индикаторные массивы:

double Buf_0[],Buf_1[];                      // Объявление массивов(под буферы индикатора)

Индикатор предназначен для построения двух индикаторных линий, поэтому необходимо объявить два глобальных одномерных массива, по одному на каждую линию. Названия индикаторных массивов определяются пользователем по его выбору. В данном случае использованы названия массивов Buf_0[] и Buf_1[], в других случаях возможно использование других названий, например,Line_1[],Alfa[], Integral[] и пр. Необходимость объявления массивов на глобальном уровне вызвана тем, что значения элементов массивов должны сохраняться в период между вызовами на исполнение специальной функции start().

Рассматриваемый пользовательский индикатор построен на основе двух специальных функций -init() и start(). В функции init() собрана та часть кода, которая по смыслу используется в программе один раз (см. Специальные функции).

Очень важное действие выполняется в строке:

   SetIndexBuffer(0,Buf_0);                  // Назначение массива буферу

С помощью функции SetIndexBuffer() необходимый буфер (в данном случае с индексом 0) ставится в соответствие массиву (в данном случае Buf_0). Это значит, что для построения первой индикаторной линии клиентский терминал будет принимать данные, заключённые в массиве Buf_0, используя для этого нулевой буфер.

В следующей строке определяется стиль линии:

   SetIndexStyle (0,DRAW_LINE,STYLE_SOLID,2);// Стиль линии

Клиентскому терминалу предписывается для нулевого буфера (0) использовать следующие стили отображения: простая линия (DRAW_LINE), сполошная линия (STYLE_SOLID), толщина линии 2.

В последующих двух строках указаны настройки для второй индикаторной линии:

   SetIndexBuffer(1,Buf_1);                 // Назначение массива буферу
   SetIndexStyle (1,DRAW_LINE,STYLE_DOT,1); // Стиль линии

Таким образом, в соответствии с кодом специальной функции init(), обе индикаторные линии будут отображены клиентским терминалом в основном окне финансового инструмента. Первая из них будет сплошной синей линией толщиной 2, а вторая - красной пунктирной ( STYLE_DOT) линией обычной толщины. Индикаторные линии могут отображаться и другими стилями (см. Стили отображения индикаторных линий).

Вычисление значений элементов индикаторных массивов (здесь внимательно)

Вычисление значений элементов индикаторных массивов выполняется в специальной функции start(). Для того, чтобы правильно понять содержание программного кода функции start() пользовательского индикатора, необходимо обратить внимание на порядок индексирования баров. В разделе Массивы подробно рассматривался метод индексирования массивов-таймсерий. Согласно этому методу индексирование баров начинается с нуля. Нулевым баром считается текущий, ещё не сформировавшийся бар. Ближайший к нему бар имеет индекс 1, следующий - индекс 2 и т.д.

По мере того, как в окне финансового инструмента появляются новые бары, индексы уже сформированных (исторических) баров меняются. Новый (текущий, только что образовавшийся, самый правый) бар получает нулевой индекс, ближайший бар слева от него (только что полностью сформировавшийся) получает индекс 1 и значения индексов всех исторических баров также увеличиваются на единицу.

Указанный способ индексирования баров является единым для всей информационно-торговой системы MetaTrader, в том числе, учитывается и при построении индикаторных линий как с помощью технических, так и пользовательских индикаторов.

Ранее упоминалось, что индикаторные линии строятся на основе численной информации, содержащейся в индикаторных массивах. Индикаторный массив содержит информацию о координатах точек, по которым строится индикаторная линия. При этом координатой каждой точки по оси Y является значение элемента индикаторного массива, а координатой по оси Х - значение индекса элемента индикаторного массива. В рассматриваемом примере первая индикаторная линия строится по максимальным значениям баров. На Рис. 116 показана эта индикаторная линия (синего цвета) в окне финансового инструмента, построенная на основе индикаторного массива Buf_0.

Значение индекса индикаторного массива Buf_0 | Значение элемента индикаторного массива Buf_0
0 | 1.3123
1 | 1.3124
2 | 1.3121
3 | 1.3121
4 | 1.3123
5 | 1.3125
6 | 1.3127
... | ...

Рис. 116. Соответствие координат индикаторной линии значениям индикаторного массива.

Значение индекса индикаторного массива ставится клиентским терминалом в соответствие индексу бара - эти значения индексов совпадают. Необходимо также принять во внимание, что процесс построения индикаторных линий происходит в режиме реального времени, в условиях, при которых время от времени в окне финансового инструмента появляются новые бары. При этом все исторические бары сдвигаются влево. Чтобы индикаторная линия отображалась правильно (каждая точка линии над своим баром) её также нужно сдвинуть одновременно с барами. Поэтому возникает (чисто техническая) необходимость переиндексации индикаторного массива.

Основополагающее отличие индикаторного массива от обычного массива состоит в том, что:

В момент образования нового бара значения индексов элементов индикаторного массива автоматически изменяются клиентским терминалом, а именно - значение каждого индекса индикаторного массива увеличивается на единицу, а размер индикаторного массива увеличивается на один элемент (с нулевым индексом).

Например, нулевой бар на Рис. 116 (таймфреймH1) имеет время открытия 6:00. В 7:00 в окне финансового инструмента появится новый бар. Бар, открытый в 6:00, автоматически получит индекс 1. Для того, чтобы индикаторная линия на этом баре была отражена правильно, клиентский терминал изменит индекс элемента индикаторного массива, соответствующего бару со временем открытия 6:00. В таблице на Рис. 116 этот элемент записан в первой строке. Одновременно с этим индексы всех элементов индикаторного массива будут увеличены клиентским терминалом на единицу. В частности, индекс элемента массива, соответствующего бару со временем открытия 6:00, получит индекс 1 (ранее он был равен 0). Индикаторный массив будет увеличен на один элемент. Индекс нового, добавленного элемента индикаторного массива будет равен 0, а значением этого элемента должно быть новое значение, отражающее координату индикаторной линии на нулевом баре. Это значение и рассчитывается в специальной функции start() на каждом тике.

Расчёты в специальной функции start() должны быть построены таким образом, чтобы не выполнялись лишние действия. До того, как пользовательский индикатор прикреплён к окну финансового инструмента, в нём не отображено никаких индикаторных линий (т.к. не определены значения индикаторных массивов). Поэтому при самом первом запуске функции start() пользовательского индикатора необходимо выполнить расчёты значений индикаторного массива для всех баров, на которых должна быть построена индикаторная линия. В рассматриваемом примере это вообще все бары, имеющиеся в окне финансового инструмента (первоначальный расчёт можно производить не для всех имеющихся баров, а лишь для некоторой части последней истории; как это сделать рассматривается в последующих примерах). При всех следующих запусках специальной функции start() нет необходимости вновь рассчитывать значения индикаторного массива для всех баров. Эти значения уже рассчитаны и содержатся в индикаторном массиве. Необходимость рассчитывать текущее значение индикаторной линии возникает лишь на каждом новом тике нулевого бара.

Для реализации указанной технологии в языке MQL4 имеется очень полезная стандартная функция - IndicatorCounted().

Функция IndicatorCounted()

int IndicatorCounted()

Функция возвращает количество баров, не измененных после последнего вызова индикатора.

Если раньше индикатор никогда не присоединялся к окну финансового инструмента, то при первом исполнении функции start() значение переменной Counted_bars будет равно нулю:

   Counted_bars=IndicatorCounted();  // Количество просчитанных баров

Это означает, что индикаторный массив не содержит ни одного элемента с ранее определённым значением, поэтому есть необходимость рассчитать весь индикаторный массив от начала до конца. Расчёт индикаторного массива производится в направлении от самого старого бара к нулевому. Индекс самого старого бара, начиная с которого необходимо производить вычисления, рассчитывается так:

   i=Bars-Counted_bars-1;           // Индекс первого непосчитанного

Предположим, что в момент запуска в окне финансового инструмента имеется 300 баров. Эта величина является значением предопределённой переменной Bars. Ранее определённое значение Counted_bars равно 0. В результате получится, что индекс i первого не посчитанного бара (самого старого бара, начиная с которого необходимо начать расчёт) равен 299.

Вычисление значений элементов индикаторных массивов выполняется в цикле while():

   while(i>=0)                      // Цикл по непосчитанным барам
     {
      Buf_0[i] = High[i];           // Значение 0 буфера на i-ом баре
      Buf_1[i] = Low[i];            // Значение 1 буфера на i-ом баре
      i--;                          // Расчёт индекса следующего бара
     }

До тех пор, пока значение переменной i находится в пределах значений индексов первого непосчитанного (299) и текущего (0) баров включительно, выполняется расчёт значений элементов индикаторных массивов для обеих индикаторных линий. Обратите внимание, расчёт недостающих значений элементов индикаторных массивов производится в рамках одного (первого) запуска специальной функции start(). По ходу вычислений клиентский терминал запоминает, для каких элементов был произведен расчёт. Последняя итерация в цикле while() выполняется, когда значение переменной i равно нулю, т.е. рассчитываются значения индикаторных массивов для нулевого бара. По окончании цикла специальная функция start() заканчивает своё исполнение и передаёт управление клиентскому терминалу. Клиентский терминал, в свою очередь, отобразит все (в данном случае две) индикаторные линии в соответствии с рассчитанными значениями элементов индикаторных массивов.

На следующем тике специальная функция start() будет снова запущена клиентским терминалом на исполнение. Дальнейшие события будут развиваться в зависимости от ситуации (продолжим рассмотрение примера для 300 баров).

Вариант 1. Новый тик поступил во время развития текущего нулевого бара (наиболее распространённая ситуация).

Рис. 117. Обрабатываемый тик принадлежит текущему бару.

На Рис. 117 показано два тика, поступивших в клиентский терминал в момент времени t 1 и t 2. Рассматриваемая ситуация будет одинаковой для обоих этих тиков. Для примера проследим, как будет исполняться функция start(), запущенная в момент t 2. Во время выполнения функции start() будет исполнена строка:

   Counted_bars=IndicatorCounted(); // Количество просчитанных баров

Функция IndicatorCounted() вернёт значение 299, т.е. с момента последнего вызова функции start() не изменялись предыдущие 299 баров. В результате этого вычисленное значение индекса i будет равно 0 (300-299-1):

   i=Bars-Counted_bars-1;           // Индекс первого непосчитанного

Это значит, что в последующем цикле while() будут рассчитаны значения элементов индикаторных массивов, имеющие нулевой индекс. Иными словами, будет рассчитано новое положение индикаторной линии на нулевом баре. По окончании цикла функция start() закончит работу и передаст управление клиентскому терминалу.

Вариант 2. Новый тик является первым тиком нового нулевого бара (систематически встречающаяся ситуация).

Рис. 118. Обрабатываемый тик является первым тиком нового нулевого бара.

В данном случае большое значение имеет факт образования нового бара. До того, как управление будет передано специальной функции start() пользовательского индикатора, клиентский терминал перерисует все бары, имеющиеся в окне финансового инструмента, и произведёт переиндексацию всех объявленных индикаторных массивов (поставленных в соответствие буферам). Кроме того, клиентский терминал будет помнить, что в окне финансового инструмента имеется уже не 300 баров, а 301 бар.

На Рис. 118 показана ситуация, при которой на последнем тике предыдущего бара (в момент t 2 ) была запущена и благополучно исполнена функция start(). Поэтому, хотя теперь уже первый (с индексом 1) бар, закончившийся в момент t 2, был посчитан индикатором, функция IndicatorCounted() вернет значение, которое было на предыдущем баре, то есть 299:

   Counted_bars=IndicatorCounted(); // Количество просчитанных баров

В следующей строке будет вычислен индекс i, в данном случае для первого тика нового он окажется равным 1 (301-299-1):

   i=Bars-Counted_bars-1;           // Индекс первого непосчитанного

Это значит, что вычисление значений индикаторных массивов в цикле while() при появлении нового бара будет выполняться для последнего бара и для вновь образовавшегося нулевого бара. Несколько раньше, во время переиндексации индикаторных массивов, клиентский терминал также увеличил размеры этих массивов. Значения элементов массивов с нулевыми индексами перед вычислениями в цикле были не определены. Во время вычислений в цикле эти элементы получают некоторые значения. По окончании вычислений в функции start() управление возвращается клиентскому терминалу. После этого клиентский терминал отобразит индикаторные линии на нулевом баре на основе только что вычисленных значений элементов индикаторных массивов с нулевыми индексами.

Вариант 3. Новый тик является первым тиком нового нулевого бара, но при этом предпоследний тик не обработан (редкая ситуация).

Рис. 119. Не все тики на предыдущем баре были обработаны.

На Рис. 119 показана ситуация, когда специальная функция start() запущена на первом тике нового бара, в момент t 5. Предыдущий раз функция start() запускалась в момент t 2. Тик, поступивший в клиентский терминал в момент t 3 (красная стрелка) не был обработан индикатором. Это произошло потому, что период исполнения функции start() t 2 -t 4 оказался больше интервала времени между тиками t 2 -t 3. Этот факт будет отмечен клиентским терминалом - при исполнении функции start(), запущенной в момент t 5. При вычислении в строке:

   Counted_bars=IndicatorCounted(); // Количество просчитанных баров

функция IndicatorCounted() вернёт значение 299 (!). Это значение соответствует истине - с момента последнего вызова индикатора не было изменено 299 баров из (теперь уже) 301. Поэтому вычисленный индекс первого (самого левого) бара, с которого необходимо начать расчёт значения элементов индикаторных массивов, будет равен 1 (301-299-1):

   i=Bars-Counted_bars-1;           // Индекс первого непосчитанного

Это значит, что при исполнении оператора цикла while() будет выполнено две итерации. На первой из них будут посчитаны значения элементов индикаторных массивов с индексом i =1, а именно, Buf_0[1] и Buf_1[1]. Обратите внимание, к моменту начала вычислений бары и индикаторные массивы уже переиндексированы клиентским терминалом (по причине начала нового бара, в период между запусками на исполнение функции start()). Поэтому вычисления для элементов массивов с индексами 1 будут производиться на основе массивов-таймсерий (максимальных и минимальных значений цены бара) также с индексом 1:

   while(i>=0)                      // Цикл по непосчитанным барам
     {
      Buf_0[i] = High[i];           // Значение 0 буфера на i-ом баре
      Buf_1[i] = Low[i];            // Значение 1 буфера на i-ом баре
      i--;                          // Расчёт индекса следующего бара
     }

На второй итерации цикла while() вычисляются значения для элементов индикаторных массивов с нулевыми индексами, т.е. для нулевого бара, на основе последних известных значений массивов-таймсерий.

Использование указанной технологии для вычислений в пользовательских индикаторах позволяет, во-первых, гарантировать расчёт значений всех без исключения элементов индикаторных массивов независимо от специфики тиковой истории, и во-вторых, выполнять расчёты только для непосчитанных баров, т.е. экономно расходовать вычислительные ресурсы.

Обратите внимание, бар считается непосчитанным, если расчёт значений элементов индикаторного массива не выполнен хотя бы для одного последнего тика на этом баре.

Запустив на исполнение пользовательский индикатор userindicator.mq4, в окне финансового инструмента можно наблюдать две линии - жирную синюю линию, построенную по максимумам баров, и красную пунктирную линию, построенную по минимумам (Рис. 120).

Рис. 120. Две индикаторные линии в окне финансового инструмента, построенные индикатором userindicator.mq4.

Следует заметить, что можно построить пользовательский индикатор, индикаторные линии которого будут совпадать с линиями аналогичного технического индикатора. Это легко выполнить, если в качестве расчётных формул в пользовательском индикаторе будут использоваться те же формулы, что и в техническом. Чтобы это продемонстрировать несколько усовершенствуем программный код, рассмотренный в предыдущем примере. Пусть следующий пользовательский индикатор строит индикаторные линии по средним значениям максимумов и минимумов нескольких последних баров. Выполнить необходимые для этого вычисления очень просто: достаточно найти средние значения элементов массивов-таймсерий. Например, значение индикаторного массива с индексом 3 (т.е. координату индикаторной линии для третьего бара) на основе пяти последних максимумов, вычисляется так:

Buf_0[3] = ( High[3] + High[4] + High[5] + High[6] + High[7] ) / 5

Аналогичные вычисления можно выполнить и для индикаторной линии, которая строится по средним минимумам.

Пример простого пользовательского индикатора averagevalue.mq4. Индикаторные линии построены по средним максимальным и минимальным значениям N баров.
//--------------------------------------------------------------------
// averagevalue.mq4
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------------
#property indicator_chart_window    // Индик. рисуется в основном окне
#property indicator_buffers 2       // Количество буферов
#property indicator_color1 Blue     // Цвет первой линии
#property indicator_color2 Red      // Цвет второй линии

extern int Aver_Bars=5;             // Количество баров для расчёта

double Buf_0[],Buf_1[];             // Объявление индикаторных массивов
//--------------------------------------------------------------------
int init()                          // Специальная функция init()
  {
//--------------------------------------------------------------------
   SetIndexBuffer(0,Buf_0);         // Назначение массива буферу
   SetIndexStyle (0,DRAW_LINE,STYLE_SOLID,2);// Стиль линии
//--------------------------------------------------------------------
   SetIndexBuffer(1,Buf_1);         // Назначение массива буферу
   SetIndexStyle (1,DRAW_LINE,STYLE_DOT,1);// Стиль линии
//--------------------------------------------------------------------
   return;                          // Выход из спец. ф-ии init()
  }
//--------------------------------------------------------------------
int start()                         // Специальная функция start()
  {
   int i,                           // Индекс бара
       n,                           // Формальный параметр
       Counted_bars;                // Количество просчитанных баров
       double
       Sum_H,                       // Сумма значений High за переиод
       Sum_L;                       // Сумма значений Low  за переиод
//--------------------------------------------------------------------
   Counted_bars=IndicatorCounted(); // Количество просчитанных баров
   i=Bars-Counted_bars-1;           // Индекс первого непосчитанного
   while(i>=0)                      // Цикл по непосчитанным барам
     {
      Sum_H=0;                      // Обнуление в начале цикла
      Sum_L=0;                      // Обнуление в начале цикла
      for(n=i;n<=i+Aver_Bars-1;n++) // Цикл суммирования значений
        {
         Sum_H=Sum_H + High[n];     // Накопление суммы макс.значений
         Sum_L=Sum_L + Low[n];      // Накопление суммы мин. значений
        }
      Buf_0[i]=Sum_H/Aver_Bars;     // Значение 0 буфера на i-ом баре
      Buf_1[i]=Sum_L/Aver_Bars;     // Значение 1 буфера на i-ом баре

      i--;                          // Расчёт индекса следующего бара
     }
//--------------------------------------------------------------------
   return;                          // Выход из спец. ф-ии start()
  }
//--------------------------------------------------------------------

В представленном примере имеется внешняя переменная Aver_Bars. С помощью этой переменной пользователь может указать количество баров, для которых вычисляется среднее значение. В функции start() это значение используется для вычисления средних значений. В цикле for вычисляется сумма максимальных и минимальных значений для того количества баров, которое соответствует значению переменной Aver_Bars. В последующих двух строках программы рассчитываются значения элементов индикаторных массивов для индикаторных линий, соответствующих максимальным и минимальным значениям.

Используемый здесь метод усреднения применяется также для расчётов в техническом индикаторе Moving Average. Если к окну финансового инструмента прикрепить рассматриваемый пользовательский индикатор averagevalue.mq4 и технический индикатор Moving Average, то можно наблюдать три индикаторных линии. Если для обоих индикаторов установить одинаковый период усреднения, то индикаторная линия технического индикатора совпадёт с одной из линий пользовательского индикатора (для этого также необходимо в настройке технического индикатора указать параметры, представленные на Рис. 121.)

Рис. 121. Совпадение линий технического и пользовательского индикаторов (красная линия).

Таким образом, легко убедиться, с помощью технических индикаторов можно построить отображение любых закономерностей, которые необходимы пользователю для практической работы.

Возможности пользовательских индикаторов

Отображение индикаторных линий в разных окнах

MQL4 предоставляет большой сервис для построения пользовательских индикаторов, что делает их применение очень удобным. В частности, возможно отображение индикаторных линий в отдельном окне. Это бывает полезно в тех случаях, когда абсолютные значения амплитуды индикаторной линии существенно меньше (или больше) значений цены по финансовому инструменту. Например, если мы поинтересуемся разницей между средними значениями максимумов и минимумов баров на некотором историческом промежутке, то (в зависимости от таймфрейма) обнаружится, то эта величина составляет приблизительно 0 - 50 пунктов (например, для М15). Построить индикаторную линию по этим значениям несложно, но в окне финансового инструмента она будет отображена в диапазоне от 0 до 50 пунктов цены по финансовому инструменту, т.е. значительно ниже отображаемой на экране области графика цен, что очень не удобно.

Для отображения индикаторных линий в отдельном окне (которое располагается в нижней части окна финансового инструмента) в директиве #property (в начале программы) необходимо указать параметр indicator_separate_window:

#property indicator_separate_window // Индик. рисуется в основном окне

В момент прикрепления такого индикатора к окну финансового инструмента клиентский терминал образует в нижней части графика цен отдельное окно, в котором и будут отображены индикаторные линии, рассчитанные в индикаторе. В зависимости от настроек цвета и вида индикаторных линий они будут отображаться тем или иным стилем.

Ограничение расчётной истории

В большинстве случаев индикаторные линии несут полезную информацию только в последней истории. Та часть индикаторных линий, которая построена по старым барам (например, месячной давности на минутном таймфрейме) вряд ли может быть расценена как полезная для принятия торговых решений. Кроме того, если в окне финансового инструмента находится много баров, то время, затраченное на расчёт и отображение индикаторных линий, может занимать неоправданно большое время. Это бывает критично при отладке программы, когда часто производится компиляция с последующим запуском программы на исполнение. По этим причинам возникает необходимость выполнять расчёты не для всей, а только для ограниченной части последней баровой истории.

Для этой цели в следующей программе используется внешняя переменная History. Значение этой переменной учитывается при вычислении индекса первого (самого левого) бара, начиная с которого необходимо рассчитывать значения элементов индикаторных массивов.

   i=Bars-Counted_bars-1;           // Индекс первого непосчитанного
   if (i>History-1)                 // Если много баров то ..
      i=History-1;                  // ..рассчитывать заданное колич.

Дальнейшие вычисления в цикле while() будут выполняться для того количества баров последней истории, которое не больше указанного значения History. Обратите внимание, рассматриваемый способ ограничения расчётной истории касается только той части вычислений, которые выполняются в период первого запуска специальной функции start(). В дальнейшем, с появлением новых баров, в правой части индикаторных линий будут добавляться новые участки, в то время, как в левой части изображение будет сохраняться. Таким образом, длина индикаторной линии будет расти в течение всего времени работы пользовательского индикатора. Обычным для параметра History можно считать значение около 5000 баров.

Пример простого пользовательского индикатора separatewindow.mq4. Индикаторные линии отображаются в отдельном окне.
//--------------------------------------------------------------------
// separatewindow.mq4
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------------
#property indicator_separate_window // Отображение в отдельном окне
#property indicator_buffers 1       // Количество буферов
#property indicator_color1 Blue     // Цвет первой линии
#property indicator_color2 Red      // Цвет второй линии

extern int History  =50;            // Колич.баров в расчётной истории
extern int Aver_Bars=5;             // Количество баров для расчёта

double Buf_0[];                     // Объявление индикаторного массива
//--------------------------------------------------------------------
int init()                          // Специальная функция init()
  {
   SetIndexBuffer(0,Buf_0);         // Назначение массива буферу
   SetIndexStyle (0,DRAW_LINE,STYLE_SOLID,2);// Стиль линии
   return;                          // Выход из спец. ф-ии init()
  }
//--------------------------------------------------------------------
int start()                         // Специальная функция start()
  {
   int i,                           // Индекс бара
   n,                               // Формальный параметр
   Counted_bars;                    // Количество просчитанных баров
   double
   Sum_H,                           // Сумма значений High за переиод
   Sum_L;                           // Сумма значений Low  за переиод
//--------------------------------------------------------------------
   Counted_bars=IndicatorCounted(); // Количество просчитанных баров
   i=Bars-Counted_bars-1;           // Индекс первого непосчитанного
   if (i>History-1)                 // Если много баров то ..
      i=History-1;                  // ..рассчитывать заданное колич.
   while(i>=0)                      // Цикл по непосчитанным барам
     {
      Sum_H=0;                      // Обнуление в начале цикла
      Sum_L=0;                      // Обнуление в начале цикла
      for(n=i;n<=i+Aver_Bars-1;n++) // Цикл суммирования значений
        {
         Sum_H=Sum_H + High[n];     // Накопление суммы макс.значений
         Sum_L=Sum_L + Low[n];      // Накопление суммы мин. значений
        }
      Buf_0[i]=(Sum_H-Sum_L)/Aver_Bars;// Знач. 0 буфера на i-ом баре
      i--;                          // Расчёт индекса следующего бара
     }
//--------------------------------------------------------------------
   return;                          // Выход из спец. ф-ии start()
  }
//--------------------------------------------------------------------

Аналогичный расчёт индикаторной линии выполняется и в техническом индикаторе AverageTrue Range. На Рис. 122 можно наблюдать индикаторную линию, построенную пользовательским индикатором separatewindow.mq4 в одном отдельном окне и индикаторную линию, построенную техническим индикатором ATR в другом окне. В данном случае наблюдается полное совпадение линий благодаря тому, что для обоих индикаторов выбран один и тот же период усреднения, равный 5. Если в каком-нибудь индикаторе изменить этот параметр, то рисунок соответствующей индикаторной линии изменится.

Рис. 122. Отображение линии пользовательского индикатора в отдельном окне.
Совпадение рисунков линий технического (ATR) и пользовательского (separatewindow.mq4) индикаторов.

Легко заметить также, что линия пользовательского индикатора построена не на всю ширину экрана, а лишь по 50 последним барам, согласно установленному значению внешней переменной History. В случае если трейдеру понадобится использовать больший исторический интервал, он может легко изменить значение внешней переменной через окно настроек пользовательского индикатора.

На Рис. 123 показано окно финансового инструмента, в котором индикаторная линия отражается другим стилем - в виде гистограммы. Для получения такого результата в программном коде separatewindow.mq4 была изменена одна строка - указаны иные значения стиля линии:

   SetIndexStyle (0,DRAW_HISTOGRAM);// Стиль линии

Весь остальной код программы оставлен без изменения.

Рис. 123. Отображение линии пользовательского индикатора в отдельном окне (гистограмма).
Совпадение рисунков линий технического (ATR) и пользовательского (separatewindow.mq4) индикаторов.

Cмещение индикаторных линий по вертикали и горизонтали

В ряде случаев возникает необходимость сместить индикаторную линию по графику цен в каком-либо направлении. Это легко выполняется средствами MQL4. Рассмотрим пример, в котором вычисляется положение индикаторных линий в окне финансового инструмента согласно значениям, задаваемым пользователем.

Пример простого пользовательского индикатора displacement.mq4. Смещение индикаторных линий по горизонтали и вертикали.
//--------------------------------------------------------------------
// displacement.mq4
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------------
#property indicator_chart_window       // Индик. рисуется в основном окне
#property indicator_buffers 3          // Количество буферов
#property indicator_color1 Red         // Цвет первой линии
#property indicator_color2 Blue        // Цвет второй линии
#property indicator_color3 Green       // Цвет второй линии

extern int History  =500;              // Колич.баров в расчётной истории
extern int Aver_Bars=5;                // Количество баров для расчёта
extern int Left_Right= 5;              // Смещение по горизонтали (баров)
extern int Up_Down  =25;               // Смещение по вертикали (пунктов)

double Line_0[],Line_1[],Line_2[];     // Объявление массивов данных
//--------------------------------------------------------------------
int init()                             // Специальная функция init()
  {
//--------------------------------------------------------------------
   SetIndexBuffer(0,Line_0);           // Назначение массива буферу 0
   SetIndexStyle (0,DRAW_LINE,STYLE_SOLID,2);// Стиль линии
//--------------------------------------------------------------------
   SetIndexBuffer(1,Line_1);           // Назначение массива буферу 1
   SetIndexStyle (1,DRAW_LINE,STYLE_DOT,1);// Стиль линии
//--------------------------------------------------------------------
   SetIndexBuffer(2,Line_2);           // Назначение массива буферу 2
   SetIndexStyle (2,DRAW_LINE,STYLE_DOT,1);// Стиль линии
//--------------------------------------------------------------------
   return;                             // Выход из спец. ф-ии init()
  }
//--------------------------------------------------------------------
int start()                            // Специальная функция start()
  {
   int i,                              // Индекс бара
       n,                              // Формальный параметр (индекс)
       k,                              // Индекс элемента индик. массива
       Counted_bars;                   // Количество просчитанных баров
       double
       Sum;                            // Сумма Low и High за переиод
//--------------------------------------------------------------------
   Counted_bars=IndicatorCounted();    // Количество просчитанных баров
   i=Bars-Counted_bars-1;              // Индекс первого непосчитанного
   if (i>History-1)                    // Если много баров то ..
      i=History-1;                     // ..рассчитывать заданное колич.

   while(i>=0)                         // Цикл по непосчитанным барам
     {
      Sum=0;                           // Обнуление в начале цикла
      for(n=i;n<=i+Aver_Bars-1;n++)    // Цикл суммирования значений
         Sum=Sum + High[n]+Low[n];     // Накопление суммы макс.значений
      k=i+Left_Right;                  // Вычисление расчётного индекса
      Line_0[k]= Sum/2/Aver_Bars;      // Значение 0 буфера на k-ом баре
      Line_1[k]= Line_0[k]+Up_Down*Point;// Значение 1 буфера
      Line_2[k]= Line_0[k]-Up_Down*Point;// Значение 2 буфера

      i--;                             // Расчёт индекса следующего бара
     }
//--------------------------------------------------------------------
   return;                             // Выход из спец. ф-ии start()
  }
//--------------------------------------------------------------------

Для того, чтобы пользователь мог настроить смещение линий по графику цен в индикаторе предусмотрены две внешние переменные - Left_Right для смещения всех индикаторных линий по горизонтали, а также Up_Down для смещения двух (пунктирных) линий по вертикали.

extern int Left_Right= 5;              // Смещение по горизонтали (баров)
extern int Up_Down   = 25;             // Смещение по вертикали (пунктов)

Алгоритм, используемый для вычисления значений соответствующих элементов индикаторных массивов, основан на простых положениях:

  • для смещения линии по горизонтали необходимо присвоить вычисленное значение элементу массива, индекс которого на величину Left_Right больше (для сдвига влево и меньше для сдвига вправо), чем индекс бара, для которого выполнены вычисления;
  • для смещения линии по вертикали необходимо прибавить (для смещения вверх или вычесть для смещения вниз) значение Up_Down*Point к каждому значению индикаторного массива, характеризующего исходное положение линии;

В рассматриваемом примере вычисление индексов выполняются в строке:

      k = i+Left_Right;                // Вычисление расчётного индекса

Здесь i - индекс бара, для которого выполняются вычисления, а k - индекс элемента индикаторного массива. Красная индикаторная линия, отображаемая клиентским терминалом на основе индикаторного массива Line_0[], сдвинута влево на 5 баров (в соответствии с настройками пользователя, см. Рис. 124) относительно того места точек, по которым была бы построена исходная линия. Исходная линия в данном случае представляет среднюю МА с периодом усреднения 5, рассчитанную по формуле (High[i]+Low[i])/2.

      Line_0[k]= Sum2 Aver_Bars;       // Значение 0 буфера на k-ом баре

В данном примере положение красной индикаторной линии является основой для расчёта значений индикаторных массивов двух других индикаторных линий, т.е. их положения на графике цен. Пунктирные линии рассчитываются так:

      Line_1[k]= Line_0[k]+Up_Down*Point;// Значение 1 буфера
      Line_2[k]= Line_0[k]-Up_Down*Point;// Значение 2 буфера

Использование здесь индекса k для элементов всех индикаторных массивов позволило выполнить расчёт для элементов массивов Line_1[], Line_2[] на том же баре, для которого имеется соответствующее значение опорного массива Line_0[]. В результате пунктирные линии оказались сдвинутыми относительно красной линии на то значение, которое указано пользователем в окне настроек индикатора, в данном случае, на 30 пунктов (Рис. 124).

Рис. 124. Красная индикаторная линия сдвинута влево на 5 баров.
Пунктирные индикаторные линии отстоят от красной линии на 30 пунктов.

Ограничения пользовательских индикаторов

В MQL4 имеются ограничения, которые необходимо учитывать при программировании пользовательских индикаторов.

Существует группа функций, которые можно использовать только в пользовательских
индикаторах, и запрещено использовать в экспертах и скриптах: IndicatorBuffers(),
IndicatorCounted (), IndicatorDigits(), IndicatorShortName(), SetIndexArrow(),
SetIndexBuffer(), SetIndexDrawBegin(), SetIndexEmptyValue(), SetIndexLabel(), SetIndexShift(),
SetIndexStyle(), SetLevelStyle(), SetLevelValue().

С другой стороны, в индикаторах запрещено использование торговых функций: OrderSend(), OrderClose(), OrderCloseBy(), OrderDelete() и OrderModify(). Это связано с тем, что индикаторы работают в интерфейсном потоке (в отличие от экспертов и скриптов, работающих в собственном потоке).

По этой же причине в пользовательских индикаторах недопустимо применение алгоритмов, основанных на зацикливании. Запуск на исполнение пользовательского индикатора, в котором содержится бесконечный цикл (по времени фактического исполнения) может привести к зависанию клиентского терминала с необходимостью последующей перезагрузки компьютера.

Общая сравнительная характеристика экспертов, скриптов и индикаторов приведена в Таблице 2.

Простой экспертПользовательский индикатор скорости изменения цены (ROC)


Простые программы на MQL4 - Учебник по MQL4

Учебник по MQL4 [image] Простые программы на MQL4
  • Использование технических индикаторов
  • Простой эксперт
  • Создание пользовательских индикаторов
  • Пользовательский индикатор скорости изменения цены (ROC)
  • Совместное использование программ
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Простые программы на MQL4

В разделе представлено несколько простых программ, готовых для практического использования. Рассматриваются общие принципы построения простого эксперта и простого пользовательского индикатора, а также порядок совместного использования эксперта и различных индикаторов.

Торговые критерии, используемые в программах, применяются в учебных целях и не должны рассматриваться как руководство к действию при торговле на реальном счёте.

  • Использование технических индикаторов.
    В терминале MetaTrader 4 есть несколько десятков встроенных индикаторов, которые называются техническими. Название технический происходит из разделения двух видов анализа рынка: фундаментальный анализ (ФА) - анализ макроэкономических показателей в контексте торгуемого инструмента, рынка, страны и так далее; и технический анализ (ТА) - анализ непосредственно цены с помощью ценовых графиков и разнообразных преобразований цены. Язык MQL4 позволяет получать значения технических индикаторов через соответствующие функции. При вызове функции технического индикатора необходимо указать требуемые параметры.
  • Простой эксперт.
    При написании эксперта (торгового робота) необходимо провести предварительные работы: определить торговую стратегию, задать критерии, и на основе этого построить структуру. Торговые критерии обычно задаются в одной или нескольких функциях, которые являются блоками выдачи торговых сигналов. Размер открываемой торговой позиции зачастую является отдельной задачей, и также может быть оформлен в отдельной функции. Приказы на открытие, закрытие и модификацию ордеров могут приводить к появлению ошибок, которые необходимо обрабатывать. Эти операции обычно также выносят в соответствующие пользовательские функции.
  • Программирование пользовательских индикаторов.
    Создание пользовательского индикатора не является сложным, если знать устройство последнего. Каждый пользовательский индикатор может содержать от 1 до 8 индикаторных буферов, с помощью которых терминал отображает информацию на графиках инструментов. Необходимые буферы объявляются в виде массивов типа double на глобальном уровне программы, и затем в функции init() происходит уточнение/установка параметра каждого буфера: стиль отображения, цвет и толщина линии, и так далее. Так как запуск функции start() происходит в индикаторе с приходом каждого тика, то организация экономных вычислений выходит на первый план. Для создания оптимального алгоритма индикатора служит функция IndicatorCounted(), которая содержит данные о количестве баров, которые не изменились с последнего вызова функции start().
  • Пользовательский индикатор скорости изменения цены.
    Создание пользовательского индикатора лучше всего освоить на примере с подробными объяснениями. Детальные комментарии в тексте индикатора будут полезны вам самим и в дальнейшем, когда вы захотите изменить ранее написанное. Хорошие программы - это хорошо документированные программы.
  • Совместное использование программ.
    Чтобы использовать значение пользовательского индикатора в других индикаторах, скриптах или экспертах, достаточно включить в код программы вызов пользовательского индикатора с помощью функции iCustom(). При этом не производится проверка физического наличия вызываемого пользовательского индикатора в соответствующем каталоге при компиляции. Поэтому параметры вызова пользовательского индикатора должны быть заданы корректно, в противном случае вычисленные значения могут отличаться от ожидаемых. Возможность вызова пользовательского индикатора позволяет существенно разгрузить код эксперта.
Модификация ордеровИспользование технических индикаторов


Использование технических индикаторов - Простые программы на MQL4 - Учебник по MQL4

Учебник по MQL4 [image] Простые программы на MQL4 [image] Использование технических индикаторов
MetaQuotes Sofware Corp.
  • Использование технических индикаторов
  • Простой эксперт
  • Создание пользовательских индикаторов
  • Пользовательский индикатор скорости изменения цены (ROC)
  • Совместное использование программ
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Использование технических индикаторов

По признаку принадлежности к информационно-торговой системе MetaTrader в MQL4 различают два вида индикаторов - технические и пользовательские.

Технический индикатор - это составная часть информационно-торговой системы MetaTrader, встроенная функция, позволяющая графически отображать на экране определённую зависимость.

Свойства технических индикаторов

Отображение в окне финансового инструмента

Каждый технический индикатор рассчитывает некоторую предопределённую зависимость. Чтобы отобразить эту зависимость графически на экране, необходимо присоединить технический индикатор к окну финансового инструмента. Это можно выполнить, обратившись к системному меню Вставка >> Индикаторы или к окну Навигатора клиентского терминала. Для присоединения технических индикаторов к окну финансового инструмента из Навигатора используется очень простой способ - достаточно перетянуть название нужного технического индикатора из Навигатора в окно финансового инструмента. В результате этого события в окне появятся одна или несколько цветных линий, рассчитанных в этом индикаторе.

Рис. 104. Присоединение к технического индикатора к окну финансового инструмента.

Индикаторные линии технического индикатора могут отражаться как в основном окне ценового графика, так и в отдельном окне в нижней части окна финансового инструмента. На Рис. 104 показано, что технический индикатор Alligator отображается в окне ценового графика.

Неизменность кода

Все технические индикаторы являются встроенными, их код недоступен пользователю для внесения изменений. Таким образом, пользователь гарантирован от ошибочного изменения кода встроенных технических индикаторов. Вместе с тем, исходный код, по которому рассчитан каждый технический индикатор, доступен на сайте производителя ПО (MetaQuotes Software Corp.) в разделе Технические индикаторы. В случае необходимости программист может использовать полностью или частично эти коды для создания пользовательских индикаторов (см. Создание пользовательских индикаторов).

Вызов функции технического индикатора

Графическое изображение, видимое пользователем, воспроизводится на экране клиентским терминалом. В дальнейшем, для простоты изложения, мы будем называть эти изображения индикаторными линиями.

Индикаторная линия - графическое отображение на экране некоторой зависимости, построенной на основе численных значений, содержащихся в индикаторном массиве.

Вид индикаторной линии настраивается пользователем. Индикаторная линия может быть отображена в виде сплошной или прерывистой линии указанного пользователем цвета, а также в виде последовательности значков (точек, квадратов, кружков и пр.). Во время исполнения индикатора в нём вычисляются наборы численных значений, в соответствии с которыми на экране должны быть построены индикаторные линии. Эти наборы значений хранятся в индикаторных массивах.

Индикаторный массив - одномерный массив, содержащий численные значения, в соответствии с которыми строятся индикаторные линии. Численные значения элементов индикаторного массива - это координаты точек, по которым строится индикаторная линия. При этом координатой каждой точки по оси Y является значение элемента индикаторного массива, а координатой по оси Х - значение индекса элемента индикаторного массива.

Технология хранения данных в индикаторных массивах положена в основу построения технических и пользовательских индикаторов. Значения элементов индикаторных массивов технических индикаторов доступны из всех прикладных программ, в том числе, экспертов, скриптов и пользовательских индикаторов. Для получения значения элемента индикаторного массива с каким-либо индексом в прикладной программе необходимо вызвать для исполнения встроенную функцию, название которой поставлено в соответствие названию технического индикатора.

Для исполнения функции технического индикатора не требуется, чтобы соответствующий технический индикатор был прикреплён к окну какого-либо финансового инструмента. Также и вызов функции технического индикатора из какой-либо прикладной программы не приводит к присоединению соответствующего индикатора к какому-либо окну финансового инструмента. Присоединение технического индикатора к окну финансового инструмента тоже не приводит к вызову функции технического индикатора в какой-либо прикладной программе.

В составе клиентского терминала информационно-торговой системы MetaTrader имеется ряд Технических индикаторов. Рассмотрим некоторые из них.

Скользящее Среднее (Moving Average, MA).

Технический Индикатор Скользящее Среднее (Moving Average, MA) показывает среднее значение цены инструмента за некоторый период времени. Индикатор отражает общую тенденцию рынка - может расти, убывать или показывать незначительные колебания возле некоторой цены.

Для получения значения индикаторной линии МА в какой-либо момент времени необходимо воспользоваться стандартной функцией:

double iMA(string symbol, int timeframe, int period, int ma_shift, int ma_method, int applied_price, int shift)

Параметры:

symbol - символьное имя инструмента, на данных которого будет вычисляться индикатор. NULL означает текущий символ.

timeframe - период. Может быть одним из периодов графика. 0 означает период текущего графика.

period - период усреднения для вычисления скользящего среднего.

ma_shift - сдвиг индикатора относительно ценового графика.

ma_method - метод усреднения. Может быть одним из значений методов скользящего среднего (Moving Average).

applied_price - используемая цена. Может быть любой из ценовых констант.

shift - индекс значения, получаемого из индикаторного массива (сдвиг относительно текущего бара на указанное количество баров назад).

Ниже приведен пример вызова функции технического индикатора из эксперта callindicator.mq4 :

//--------------------------------------------------------------------
// callindicator.mq4
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------------
extern int Period_MA = 21;            // Период расчётной МА
bool Fact_Up = true;                  // Факт сообщения, что цена..
bool Fact_Dn = true;                  //..находится выше или ниже МА
//--------------------------------------------------------------------
int start()                           // Спец. функция start
  {
   double MA;                         // Значение МА на 0 баре
//--------------------------------------------------------------------
                                      // Обращение к функции техн.инд.
   MA=iMA(NULL,0,Period_MA,0,MODE_SMA,PRICE_CLOSE,0);
//--------------------------------------------------------------------
   if (Bid > MA && Fact_Up == true)   // Проверка прохода вверх
     {
      Fact_Dn = true;                 // Сообщать о цене выше МА
      Fact_Up = false;                // Не сообщать о цене ниже МА
      Alert("Цена находится выше MA(",Period_MA,").");// Сообщение
     }
//--------------------------------------------------------------------
   if (Bid < MA && Fact_Dn == true)   // Проверка прохода вниз
     {
      Fact_Up = true;                 // Сообщать о цене ниже МА
      Fact_Dn = false;                // Не сообщать о цене выше МА
      Alert("Цена находится ниже MA(",Period_MA,").");// Сообщение
     }
//--------------------------------------------------------------------
   return;                            // Выход из start()
  }
//--------------------------------------------------------------------

В эксперте callindicator.mq4 используется вызов функции iMA() технического индикатора Скользящее Среднее. Рассмотрим эту часть кода более подробно:

   MA=iMA(NULL,0,Period_MA,0,MODE_SMMA,PRICE_CLOSE,0);

NULL означает, что расчёт скользящей средней производится для того финансового инструмента, в окно которого присоединён эксперт (в данном случае - эксперт, в общем случае - любая прикладная программа);

0 - расчёт производится для таймфрейма, установленного в окне финансового инструмента, к которому присоединён эксперт;

Period_MA - значение периода усреднения задано во внешней переменной; если после присоединения к окну финансового инструмента пользователь не изменил это значение на панели настроек внешних переменных эксперта, то это значение равно 5;

0 - сдвиг индикаторного массива относительно ценового графика не производился, т. е значения элементов индикаторного массива содержат те значения МА, которые рассчитаны для баров, на которых отображается индикаторная линия;

MODE_SMA - для расчёта выбран метод простого скользящего среднего;

PRICE_CLOSE - для расчёта принята цена закрытия бара;

0 - индекс элемента индикаторного массива, для которого получено значение - в данном случае, для нулевого элемента.

Учитывая, что сдвиг индикаторного массива относительно ценового графика не производился, значение скользящей средней получено для нулевого бара. Функция iMA() возвращает некоторое значение, которое присваивается переменной MA. В дальнейших строках программы это значение сравнивается с текущей ценой Bid. Если текущая цена оказывается выше или ниже полученного значения МА (т.е. выше линии), то выдаётся сообщение пользователю. Использование в программе переменных Fact_Up и Fact_Dn позволяет выводить сообщения только в случаях, если происходит первое проникновение цены через линию МА (обратите внимание, голубая индикаторная линия в окне финансового инструмента отражена не потому, что функция технического индикатора была вызвана из программы, а потому, что пользователь прикрепил индикатор в окно, Рис. 104).

Рис. 105. Результат работы эксперта callindicator.mq4.

Здесь необходимо напомнить, что по мере появления новых баров индексы исторических баров увеличиваются, а текущий, развивающийся бар всегда имеет индекс 0. В эксперте callindicator.mq4 функция технического индикатора iMA() возвращает значение, рассчитанное для нулевого бара. Несмотря на то, что во время исполнения данного эксперта значение этого индекса никогда не меняется (т.е. расчёт всегда производится для нулевого бара), значение, возвращаемое функцией iMA(), всегда будет соответствовать последнему расчётному, а именно, рассчитанному для текущего нулевого бара.

Если для каких-либо расчётов в программе необходимо получить значение функции технического индикатора не для нулевого, а для какого-либо исторического бара, то в вызове функции необходимо указать значение индекса того элемента индикаторного массива, который нужен. Рассмотрим пример эксперта historybars.mq4, в котором вычисляется значение Скользящей Средней на четвёртом баре:

//--------------------------------------------------------------------
// historybars.mq4
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------------
extern int Period_MA = 5;             // Период расчётной МА
//--------------------------------------------------------------------
int start()                           // Спец. функция start
  {
   double MA_c,                       // Значение МА на 0 баре
          MA_p,                       // Значение МА на 4 баре
          Delta;                      // Разница МА на 0 и 4 баре
//--------------------------------------------------------------------
                                      // Обращение к функции техн.инд.
   MA_c  = iMA(NULL,0,Period_MA,0,MODE_SMA,PRICE_CLOSE,0);
   MA_p  = iMA(NULL,0,Period_MA,0,MODE_SMA,PRICE_CLOSE,4);
   Delta = (MA_c - MA_p)Point;       // Разница МА на 0 и 4 баре
//--------------------------------------------------------------------
   if (Delta > 0 )                    // Текущая цена больше старой
      Alert("На 4 барах МА выросла на ",Delta,"pt");  // Сообщение
   if (Delta < 0 )                    // Текущая цена меньше старой
      Alert("На 4 барах МА снизилась на ",-Delta,"pt");// Сообщение
//--------------------------------------------------------------------
   return;                            // Выход из start()
  }
//--------------------------------------------------------------------

В эксперте historybars.mq4 рассчитываются значения МА для текущего бара (с индексом 0) и для четвёртого бара (с индексом 4). Указанные значения индексов 0 и 4 в процессе работы (этой, конкретной) программы не изменяются, в то же время программа может работать бесконечно долгое время, всякий раз выполняя необходимые вычисления значений МА для нулевого и четвёртого бара. Здесь важно ещё раз отметить: несмотря на то, что вычисления ведутся для МА на барах с одними и теми же индексами, сами значения МА будут меняться, а именно соответствовать текущим значениям МА на текущем нулевом и текущем четвёртом баре.

Рис. 106. Результат работы эксперта historybars.mq4.

На Рис. 106 хорошо видно, что по мере роста цены на последних барах МА поднимается вверх. Разница между значениями МА на нулевом и четвёртом барах также растёт, что находит своё отражение в сообщениях функции Alert().

Технические индикаторы могут отображать не только одну, а две или более индикаторных линий.

Стохастический Осциллятор (Stochastic Oscillator).

Технический Индикатор Стохастический Осциллятор (Stochastic Oscillator) сопоставляет текущую цену закрытия с диапазоном цен за выбранный период времени. Индикатор представлен двумя индикаторными линиями. Главная линия называется %K. Вторая линия %D, сигнальная, это - скользящее среднее линии %K . Обычно %K изображается сплошной линией, а %D - пунктирной. Согласно одному из вариантов трактовки показаний индикатора следует покупать, если линия %K поднимается выше линии %D и продавать, если линия %K опускается ниже линии %D. Наиболее благоприятным моментом для совершения торговой операции считается момент пересечения линий.

double iStochastic(string symbol, int timeframe, int %Kperiod, int %Dperiod, int slowing, int method,
     int price_field, int mode, int shift)

Параметры:

symbol - символьное имя инструмента, на данных которого будет вычисляться индикатор. NULL означает текущий символ.

timeframe - период. Может быть одним из периодов графика. 0 означает период текущего графика.

%Kperiod - период(количество баров) для вычисления линии %K.

%Dperiod - период усреднения для вычисления линии %D.

slowing - значение замедления.

method - метод усреднения. Может быть любым из значений методов скользящего среднего (Moving Average).

price_field - Параметр выбора цен для расчета. Может быть одной из следующих величин: 0 - Low/High или 1 - Close/Close.

mode - индекс линии индикатора. Может принимать одно из значений: MODE_MAIN или MODE_SIGNAL.

shift - индекс получаемого значения из индикаторного буфера (сдвиг относительно текущего бара на указанное количество периодов назад).

Использование осциллятора Stochastic Oscillator предполагает необходимость анализа относительного положения линий. Для того, чтобы вычислить какое торговое решение необходимо осуществлять, следует принять во внимание значения каждой линии на текущем и на предыдущем барах (см. Рис. 107). При пересечении линий в точке А (зелёная линия пересекает красную снизу вверх) необходимо закрыть рыночный ордер Sell и открыть Buy. На всём протяжении участка А - В (нет пересечения линий, зелёная выше красной) необходимо удерживать открытым рыночный ордер Buy. В точке В (зелёная линия пересекает красную сверху вниз) необходимо закрыть Buy и открыть Sell. Далее - удерживать открытым ордер Sell до следующего пересечения линий (нет пересечений, зелёная остаётся ниже красной).

Рис. 107. Пересечение главной и сигнальной линий осциллятора Stochastic Oscillator.

В следующем примере реализован простой алгоритм, демонстрирующий как можно получить необходимые значения каждой из линий и сформировать торговые критерии. Для этого в эксперте callstohastic.mq4 используются значения функции технического индикатора iStochastic():

//--------------------------------------------------------------------
// callstohastic.mq4
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------------
int start()                       // Спец. функция start
  {
   double M_0, M_1,               // Значение MAIN на 0 и 1 барах
          S_0, S_1;               // Значение SIGNAL на 0 и 1барах
//--------------------------------------------------------------------
                                  // Обращение к функции техн.индикат.
   M_0 = iStochastic(NULL,0,5,3,3,MODE_SMA,0,MODE_MAIN,  0);// 0 бар
   M_1 = iStochastic(NULL,0,5,3,3,MODE_SMA,0,MODE_MAIN,  1);// 1 бар
   S_0 = iStochastic(NULL,0,5,3,3,MODE_SMA,0,MODE_SIGNAL,0);// 0 бар
   S_1 = iStochastic(NULL,0,5,3,3,MODE_SMA,0,MODE_SIGNAL,1);// 1 бар
//--------------------------------------------------------------------
                                  // Анализ ситуации
   if( M_1 < S_1 && M_0 >= S_0 )  // Зеленая пересекает красную снизу
      Alert("Пересечение снизу вверх. ПОКУПКА."); // Сообщение
   if( M_1 > S_1 && M_0 <= S_0 )  // Зеленая пересекает красную свеху
      Alert("Пересечение сверху вниз. ПРОДАЖА."); // Сообщение

   if( M_1 > S_1 && M_0 > S_0 )   // Зелёная выше красной
      Alert("Продолжаем держать покупку.");       // Сообщение
   if( M_1 < S_1 && M_0 < S_0 )   // Зелёная ниже красной
      Alert("Продолжаем держать продажу.");       // Сообщение
//--------------------------------------------------------------------
   return;                            // Выход из start()
  }
//--------------------------------------------------------------------

Для получения значения линии %K (сплошная зелёная) на нулевом баре используется следующая строка вычислений:

      M_0 = iStochastic(NULL,0,5,3,3,MODE_SMA,0,MODE_MAIN,  0);// 0 бар

Здесь параметр MODE_MAIN указывает линию, значение которой запрашивается, а последний параметр 0 - индекс бара, для которого необходимо вычислить значение указанной линии. В последующих трёх строках программы аналогично вычисляются другие значения - для линии %D (красная пунктирная, параметр MODE_SIGNAL) для нулевого и первого баров.

В следующем блоке выполняется анализ соотношения полученных значений, и эксперт сообщает пользователю о текущем состоянии на каждом тике. Например, в строках:

     if( M_1 < S_1 && M_0 >= S_0 )  // Зеленая пересекает красную снизу
      Alert("Пересечение снизу вверх. ПОКУПКА."); // Сообщение

вычисляется факт пересечения красной линии зелёной сигнальной линией сверху вниз. Если на предыдущем баре зелёная линия была ниже красной (т.е. истинным является выражение M_1 < S_1), а на текущем баре зелёная линия поднялась выше красной или их значения совпадают (т.е. истинным является выражение M_0 >= S_0), то это значит, что в период с момента образования предыдущего бара по настоящий момент зелёная линия пересекла красную снизу вверх. Таким образом, вычисленное условие в операторе if является истинным, поэтому управление передаётся в тело оператора if, в результате чего исполняется функция Alert() для вывода соответствующего сообщения пользователю.

В эксперте, предназначенном для торговли, в теле оператора if следует указать торговую функцию для открытия ордера Buy. В этом случае рассмотренный вариант пересечения индикаторных линий будет приводить к формированию торгового приказа и, в конечном счёте, - к осуществлению торговой операции. Для варианта, когда зелёная линия пересекает красную сверху вниз, в теле оператора if необходимо указать торговую функцию для открытия ордера на продажу.

На Рис. 108 показан результат работы эксперта callstohastic.mq4.

Рис. 108. Результат работы эксперта callstohastic.mq4.

Применение функций технических индикаторов для создания торгующих экспертов или скриптов очень удобно. Количество функций технических индикаторов, используемых в одном эксперте, не ограничено. По усмотрению разработчика торговой стратегии могут быть определены любые торговые критерии, основанные на некотором сочетании показаний тех или иных технических индикаторов. Пример простого торгующего эксперта, торговые критерии которого построены на основе технических индикаторов, рассматривается в разделе Простой эксперт.

Простые программы на MQL4Простой эксперт


Пользовательский индикатор скорости изменения цены (ROC) - Простые программы на MQL4 - Учебник по MQL4

Учебник по MQL4 [image] Простые программы на MQL4 [image] Пользовательский индикатор скорости изменения цены (ROC)
MetaQuotes Sofware Corp.
  • Использование технических индикаторов
  • Простой эксперт
  • Создание пользовательских индикаторов
  • Пользовательский индикатор скорости изменения цены (ROC)
  • Совместное использование программ
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Пользовательский индикатор скорости изменения цены (ROC)

Все индикаторы, как известно, имеют сугубо прикладное значение - помочь трейдеру сориентироваться в текущем движении цены и хотя бы отчасти спрогнозировать будущее движение цен. При достаточном опыте можно вести торговлю ориентируясь по характеру изменения скользящей средней, например, просто следовать за её направлением. Однако, скользящая средняя отражает динамику изменения цен на рынке лишь "в общем", т.к. имеет существенный недостаток - запаздывание. Представленный здесь пользовательский индикатор скорости изменения цены обладает некоторыми преимуществами по сравнению с простой МА - он имеет меньшее запаздывание и большую наглядность.

Посмотрим, как характеризуют движение цены скользящие средние МА с различным периодом усреднения. На Рис. 125 показано две таких индикаторных линии: красная - МА с периодом усреднения 21 бар и голубая МА с периодом усреднения 5 баров. Легко увидеть, что МА с малым периодом усреднения ближе прилегает к свечному графику и имеет малое запаздывание. Однако, использование этой линии для характеристики рынка затруднительно, т.к. она чрезмерно извилиста, т.е. часто изменяет своё направление, давая при этом множество ложных сигналов. МА с большим периодом усреднения не так извилиста, т. е. не будет давать столько много ложных сигналов, как МА с малым периодом, но имеет другой недостаток - большее запаздывание.

Рис. 125. Индикаторные линии: МА(21) - красная, МА(5) - голубая и скорости V - оранжевая.

Третья линия, представленная на Рис. 125, - индикаторная линия скорости изменения тренда (оранжевая). Эта линия обладает неоспоримыми достоинствами по сравнению с любой из МА: она имеет сравнительно небольшое запаздывание и хорошую сглаженность. Рассмотрим подробней, что представляет эта линия.

В основе построения этой индикаторной линии лежит скорость изменения МА(21). На участке А-В скорость изменения значений МА растёт. Это значит, что каждая точка МА на указанном участке не просто выше предыдущей, а выше на такое значение, которое больше, чем аналогичное значение для предыдущей точки. Например, если на баре с индексом 271 значение МА(21) было 1.3274, на баре с индексом 272 - 1.3280, а на баре 273 - 1.3288, то между барами с индексами 271 и 272 МА выросла на 6 пунктов, а между барами 272 и 273 на 8 пунктов. Таким образом, МА не просто растёт, а ускоряется, т.е. характеризуется всё время увеличивающейся скоростью роста. На участке ускорения роста (А-В) МА прогибается вверх, при этом любой небольшой фрагмент этого участка может быть описан как часть окружности с некоторым радиусом r1.

По мере того, как МА приближается к точке перегиба В, радиус окружности, описывающей последний участок, растёт, а в самой точке В равен бесконечности. Т.е. в точке В МА вырождается в прямую линию, характеризующуюся постоянной скоростью роста, поэтому оранжевая линия изменения скорости перестаёт расти. На участке В-С МА замедляет свой рост, но рост продолжается. Несмотря на то, что МА продолжает расти с некоторой положительной скоростью, скорость роста МА уменьшается, поэтому и кривая скорости V снижается. Любой небольшой фрагмент на этом участке МА как бы описывает окружность некоторого радиуса r2, находящуюся ниже МА.

В точке С МА перестаёт расти, т.е. скорость её равна нулю. В данном примере для построения оранжевой линии скорости в качестве опорной линии отсчёта принята сама МА. Здесь необходимо уточнить, что такое опорная МА. При обычном построении какого-нибудь графика на плоскости, как правило, используется Декартова система координат, при этом в качестве лини начала отсчёта для построения используется ось Х. В нашем случае в качестве такой линии используется не прямая ось, а МА с некоторым периодом усреднения (в данном случае сама МА(21), красная), она и называется опорной МА. Скорость изменения МА пропорциональна значению разницы между красной МА и оранжевой V. Т.е. если оранжевая линия находится выше МА, то скорость МА положительная, если ниже, то отрицательная, а в точке пересечения линии V с линией МА скорость роста МА равна нулю. Участок C-D может быть описан в тех же терминах, что и участок А-В, но с той разницей, что скорость роста МА имеет отрицательное значение.

Определяющий момент заключается в том, что МА растёт на всём промежутке E-C, в то время, как кривая скорости V имеет характерный, ярко выраженный экстремум в точке К. Визуальный анализ графика цен позволяет легко убедиться, что индикаторная линия скорости изменения цены гораздо лучше характеризует вершины и впадины ценового графика, чем любая из МА.

При программировании индикатора для вычисления скорости изменения роста МА принята простая технология. Собственно скорость, как известно, - это показатель, имеющий в числителе значение изменяемого параметра, а в знаменателе - время, в течение которого этот параметр изменяется. Применительно к скорости изменения цены (см. Рис. 126) это разница значений МА_с (текущее значение МА) и МА_p (предыдущее значение) на промежутке в несколько баров Bars_V. Имея в виду, что вычисление скорости на всей истории развития цены выполняется на одном и том же промежутке времени (количестве баров), знаменатель можно опустить, т.е. судить о скорости изменения цены по разнице МА_с - МА_p на текущем и предыдущих барах.

Рис. 126. Параметры для построения индикаторной линии скорости.

Рассматриваемый пользовательский индикатор рассчитывает в общей сложности 6 индикаторных линий. Индикаторный массив Line_0[] несёт значения опорной МА, относительно которой строятся все остальные индикаторные линии. Следующие три индикаторных массива (Line_1[], Line_2[] и Line_3[]) содержат значения скоростей изменения цены, основанные на МА с различным периодом усреднения. Индикаторный массив Line_4[] предназначен для построения средней линии скорости (как среднего арифметического Line_1[],Line_2[] и Line_3[]), а Line_5[] - для построения той же средней линии скорости, но сглаженной.

При принятии торговых решений трейдером, как правило, учитывается характер развития графика цены не только на текущем, но и на ближайших таймфреймах. Для того, чтобы получше разобраться как построены три индикаторные линии скорости, обратим внимание на следующую подробность. МА с некоторым периодом усреднения, построенная на некотором таймфрейме, отображается на ближайшем большем таймфрейме с помощью МА с периодом усреднения во столько раз меньшим, во сколько раз больше таймфрейм. Например, если в окне финансового инструмента М30 отражена МА с периодом усреднения 400, то она так же (с тем же рисунком и близкими абсолютными значениями) будет отражаться в окне H1 с периодом усреднения 200, в окне H4 с периодом усреднения 50 и т.д. При этом, строго говоря, будет наблюдаться некоторая погрешность, связанная с большим количеством данных, учитываемых на более мелких таймфреймах. Однако в большинстве случаев эта погрешность пренебрежимо мала и здесь не учитывается.

Оранжевая линия, построенная на основе индикаторного массива Line_1[], отражает изменение скорости на текущем таймфрейме. Зелёная линия, построенная на основе Line_2[], отображается (в этом же, текущем таймфрейме) так, как в ближайшем большем таймфрейме отражалась бы оранжевая линия. Коричневая линия отражается в текущем таймфрейме так, как оранжевая отображалась бы в следующем большем таймфрейме. Таким образом, с помощью представленного индикатора скорости можно наблюдать в одном окне одновременно три индикаторных линии, отражающих, соответственно, скорость развития цены на текущем, ближайшем большем и следующем большем таймфреймах.

Пользовательский индикатор roc.mq4 скорости изменения цены на текущем, ближайшем большем и следующем большем таймфреймах.

//--------------------------------------------------------------------
// roc.mq4 (Priliv)
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------------
//--------------------------------------------------------------- 1 --
#property copyright "Copyright © SK, 2007"
#property link      "http://AutoGraf.dp.ua"
//--------------------------------------------------------------------
#property indicator_chart_window    // Индик. рисуется в основном окне
#property indicator_buffers 6       // Количество буферов
#property indicator_color1 Black    // Цвет линии 0 буфера
#property indicator_color2 DarkOrange//Цвет линии 1 буфера
#property indicator_color3 Green    // Цвет линии 2 буфера
#property indicator_color4 Brown    // Цвет линии 3 буфера
#property indicator_color5 Blue     // Цвет линии 4 буфера
#property indicator_color6 Red      // Цвет линии 5 буфера
//--------------------------------------------------------------- 2 --
extern int History    =5000;        // Колич.баров в расчётной истории
extern int Period_MA_0=13;          // Период опорной МА для текущ. ТФ
extern int Period_MA_1=21;          // Период расчётной МА
extern int Bars_V     =13;             // Колич.баров для расчёта скорост
extern int Aver_Bars  =5;           // Колич. баров для сглаживания
extern double K       =2;           // Коэффициент усиления
//--------------------------------------------------------------- 3 --
int
   Period_MA_2,  Period_MA_3,       // Расчётные периоды МА для др. ТФ
   Period_MA_02, Period_MA_03,      // Расчётные периоды опорных МА
   K2, K3;                          // Коэффициенты соотношения ТФ
double
   Line_0[],                        // Инидикаторн. массив опорной MA
   Line_1[], Line_2[], Line_3[],    // Инд. массивы линий скорости
   Line_4[],                        // Инидикаторн. массив суммарный
   Line_5[],                        // Инд.массив суммарный сглаженный
   Sh_1, Sh_2, Sh_3;                // Колич.баров для расч. скоростей
//--------------------------------------------------------------- 4 --
int init()                          // Специальная функция init()
  {
   SetIndexBuffer(0,Line_0);        // Назначение массива буферу
   SetIndexBuffer(1,Line_1);        // Назначение массива буферу
   SetIndexBuffer(2,Line_2);        // Назначение массива буферу
   SetIndexBuffer(3,Line_3);        // Назначение массива буферу
   SetIndexBuffer(4,Line_4);        // Назначение массива буферу
   SetIndexBuffer(5,Line_5);        // Назначение массива буферу
   SetIndexStyle (5,DRAW_LINE,STYLE_SOLID,3);// Стиль линии
//--------------------------------------------------------------- 5 --
   switch(Period())                 // Расчёт коэффициентов для..
     {                              // .. различных ТФ
      case     1: K2=5;K3=15; break;// Таймфрейм М1
      case     5: K2=3;K3= 6; break;// Таймфрейм М5
      case    15: K2=2;K3= 4; break;// Таймфрейм М15
      case    30: K2=2;K3= 8; break;// Таймфрейм М30
      case    60: K2=4;K3=24; break;// Таймфрейм H1
      case   240: K2=6;K3=42; break;// Таймфрейм H4
      case  1440: K2=7;K3=30; break;// Таймфрейм D1
      case 10080: K2=4;K3=12; break;// Таймфрейм W1
      case 43200: K2=3;K3=12; break;// Таймфрейм МN
     }
//--------------------------------------------------------------- 6 --
   Sh_1=Bars_V;                     // Период измерен скорости (баров)
   Sh_2=K2*Sh_1;                    // Период измерен. для ближ. ТФ
   Sh_3=K3*Sh_1;                    // Период измерен. для след. ТФ
   Period_MA_2 =K2*Period_MA_1;     // Расчётн.период МА для ближ. ТФ
   Period_MA_3 =K3*Period_MA_1;     // Расчётн.период МА для след. ТФ
   Period_MA_02=K2*Period_MA_0;     // Период опорной МА для ближ. ТФ
   Period_MA_03=K3*Period_MA_0;     // Период опорной МА для след. ТФ
//--------------------------------------------------------------- 7 --
   return;                          // Выход из спец. функции init()
  }
//--------------------------------------------------------------- 8 --
int start()                         // Специальная функция start()
  {
//--------------------------------------------------------------- 9 --
   double
   MA_0, MA_02, MA_03,              // Опорные МА для разных ТФ
   MA_c, MA_p,                      // Текущее и предыдущ. знач. МА
   Sum;                             // Техн.параметр для накопл. суммы
   int
   i,                                  // Индекс бара
   n,                                  // Формальн. параметр(индекс бара)
   Counted_bars;                       // Количество просчитанных баров
//-------------------------------------------------------------- 10 --
   Counted_bars=IndicatorCounted(); // Количество просчитанных баров
   i=Bars-Counted_bars-1;           // Индекс первого непосчитанного
   if (i>History-1)                 // Если много баров то ..
      i=History-1;                  // ..рассчитывать заданное колич.
//-------------------------------------------------------------- 11 --
   while(i>=0)                      // Цикл по непосчитанным барам
     {
      //-------------------------------------------------------- 12 --
      MA_0=iMA(NULL,0,Period_MA_0,0,MODE_LWMA,PRICE_TYPICAL,i);
      Line_0[i]=MA_0;               // Значение опорной МА
      //-------------------------------------------------------- 13 --
      MA_c=iMA(NULL,0,Period_MA_1,0,MODE_LWMA,PRICE_TYPICAL,i);
      MA_p=iMA(NULL,0,Period_MA_1,0,MODE_LWMA,PRICE_TYPICAL,i+Sh_1);
      Line_1[i]= MA_0+K*(MA_c-MA_p);// Значение 1 линии скорости
      //-------------------------------------------------------- 14 --
      MA_c=iMA(NULL,0,Period_MA_2,0,MODE_LWMA,PRICE_TYPICAL,i);
      MA_p=iMA(NULL,0,Period_MA_2,0,MODE_LWMA,PRICE_TYPICAL,i+Sh_2);
      MA_02= iMA(NULL,0,Period_MA_02,0,MODE_LWMA,PRICE_TYPICAL,i);
      Line_2[i]=MA_02+K*(MA_c-MA_p);// Значение 2 линии скорости
      //-------------------------------------------------------- 15 --
      MA_c=iMA(NULL,0,Period_MA_3,0,MODE_LWMA,PRICE_TYPICAL,i);
      MA_p=iMA(NULL,0,Period_MA_3,0,MODE_LWMA,PRICE_TYPICAL,i+Sh_3);
      MA_03= iMA(NULL,0,Period_MA_03,0,MODE_LWMA,PRICE_TYPICAL,i);
      Line_3[i]=MA_03+K*(MA_c-MA_p);// Значение 3 линии скорости
      //-------------------------------------------------------- 16 --
      Line_4[i]=(Line_1[i]+Line_2[i]+Line_3[i])3;// Суммарный массив
      //-------------------------------------------------------- 17 --
      if (Aver_Bars<0)              // Если неверно задано сглаживание
         Aver_Bars=0;               // .. то не меньше нуля
      Sum=0;                        // Технический приём
      for(n=i; n<=i+Aver_Bars; n++) // Суммироваение последних значен.
         Sum=Sum + Line_4[n];       // Накопление суммы последн. знач.
      Line_5[i]= Sum(Aver_Bars+1); // Индик. массив сглаженной линии
      //-------------------------------------------------------- 18 --
      i--;                          // Расчёт индекса следующего бара
      //-------------------------------------------------------- 19 --
     }
   return;                          // Выход из спец. ф-ии start()
  }
//-------------------------------------------------------------- 20 --

Для расчётов индикаторных массивов трёх линий скорости используются МА с различными периодами усреднения. Период усреднения МА для текущего таймфрейма задаётся пользователем во внешней переменной Period_MA_1, а период усреднения опорной МА - во внешней переменной Period_MA_0.

Периоды усреднения МА, для которых рассчитывается скорость, периоды усреднения опорных МА, а также период, на котором измеряется скорость, вычисляются для старших таймфреймов в блоке 6-7. Значения соответствующих коэффициентов для расчётов этих значений определяются в блоке 5-6. Например, если индикатор присоединён в окно М30, то коэффициенты К2 и К3 будут соответственно равны 2 и 8, т.к ближайший больший таймфрейм Н1 в 2 раза больше, чем М30, а следующий больший Н4 - в 8 раз больше М30.

Вычисления в функции start() очень просты. В блоке 12-13 вычисляются значения опорной МА для текущего таймфрейма (чёрная индикаторная линия). В блоке 13-14 определяются значения индикаторного массива Line_1[] для построения линии скорости изменения цен на текущем таймфрейме (оранжевая линия). Собственно скорость определяется как разница значений рассматриваемой МА на текущем баре и баре, индекс которого на Sh_1 больше текущего, а именно (MA_c-MA_p). Значение индикаторного массива Line_1[] на текущем баре складывается из значения опорной МА и показателя, характеризующего скорость (здесь К - масштабный коэффициент, задаваемый во внешней переменной):

      Line_1[i]= MA_0+K*(MA_c-MA_p);// Значение 1 линии скорости

Аналогичные вычисления выполняются и для построения линий скорости изменения цены для двух других таймфреймов (блоки 14-16). Опорные МА для этих массивов индикатором не отображаются. В блоке 16-17 определяются значения индикаторного массива Line_4[] для построения средней линии скорости (синяя линия), являющейся их простым средним арифметическим.

В блоке 17-18 выполняются вычисления для ещё одной средней линии скорости - сглаженной (красная жирная линия, индикаторный массив Line_5[]). Сглаживание выполняется путём простого усреднения: значение элемента индикаторного массива Line_5[] на текущем баре является средним арифметическим значений нескольких последних элементов индикаторного массива Line_4[]. В результате применения такого метода сглаживания красная индикаторная линия становится менее извилистой, но в то же время обладает некоторым запаздыванием. Количество баров для сглаживания задаётся во внешней переменной Aver_Bars.

Запустив индикатор на исполнение, в окне финансового инструмента можно наблюдать 6 индикаторных линий:

  • чёрная линия - опорная МА для построения линии скорости цены на текущем таймфрейме;
  • оранжевая линия - скорость изменения цены на текущем таймфрейме;
  • зелёная линия - скорость изменения цены на ближайшем большем таймфрейме;
  • коричневая линия - скорость изменения цены на следующем большем таймфрейме;
  • синяя линия - средняя линия скорости изменения цены;
  • красная линия - сглаженная средняя линия скорости изменения цены.

Рис. 127. Пользовательский индикатор roc.mq4 позволяет наблюдать на одном экране график изменения скорости на текущем, ближайшем большем и следующем большем таймфрейме, а также их среднюю.

Индикатор roc.mq4 можно прикрепить к окну любого финансового инструмента с любым таймфреймом. Для каждого таймфрейма будет справедливо одно и то же правило: оранжевая линия отражает скорость изменения цены на текущем таймфрейме, зелёная - на ближайшем большем таймфрейме, а коричневая - на следующем большем таймфрейме. В этом легко убедиться, прикрепив индикатор в окно финансового инструмента и наблюдая рисунок линий в текущем и соседних таймфреймах (см. Рис. 128 и Рис. 129).

Рис. 128. Рисунок 3-й (коричневой) линии на текущем (М15) таймфрейме совпадает с рисунком 2-й (зелёной) линии на
старшем таймфрейме (M30, Рис. 129) и рисунком 1-й (оранжевой) лини на следующем старшем таймфрейме (H1, Рис. 129).

Рис. 129. Рисунок 2-й (зелёной) линии на текущем (М30) таймфрейме совпадает с рисунком 3-й (коричневой) линии
на младшем таймфрейме (М15, Рис. 128) и с рисунком 1-й (оранжевой) линии на старшем таймфрейме (H1).

В представленном индикаторе roc.mq4 имеется одна особенность: каждая линия скорости несёт в себе не только значение скорости изменения цены, но также зависит и от характера изменения опорной МА. С одной стороны, такая технология позволяет отображать линии изменения скоростей непосредственно на ценовом графике, что очень удобно. С другой стороны, при малых величинах скорости изменения цены определяющим (при построении линии скорости) становится значение опорной МА, что нежелательно, т.к. любая МА обладает некоторым запаздыванием.

Следующий пользовательский индикатор является полным аналогом индикатора roc.mq4, но отображается в отдельном окне. Это позволило рассчитать значения линий скоростей для разных таймфреймов не относительно опорной МА, а относительно горизонтальной нулевой линии. В связи с этим несколько изменился программный код: отпала необходимость в расчёте опорных МА и в масштабном коэффициенте.

Пользовательский индикатор rocseparate.mq4 скорости изменения цены на текущем, ближайшем большем и следующем большем таймфреймах отображается в отдельном окне.

//--------------------------------------------------------------------
// rocseparate.mq4 (Priliv_s)
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------- 1 --
#property copyright "Copyright © SK, 2007"
#property link      "http://AutoGraf.dp.ua"
//--------------------------------------------------------------------
#property indicator_separate_window // Индик.рисуется в отдельном окне
#property indicator_buffers 6       // Количество буферов
#property indicator_color1 Black    // Цвет линии 0 буфера
#property indicator_color2 DarkOrange//Цвет линии 1 буфера
#property indicator_color3 Green    // Цвет линии 2 буфера
#property indicator_color4 Brown    // Цвет линии 3 буфера
#property indicator_color5 Blue     // Цвет линии 4 буфера
#property indicator_color6 Red      // Цвет линии 5 буфера
//--------------------------------------------------------------- 2 --
extern int History    =5000;        // Колич.баров в расчётной истории
extern int Period_MA_1=21;          // Период расчётной МА
extern int Bars_V     =13;          // Колич.баров для расчёта скорост
extern int Aver_Bars  =5;           // Колич. баров для сглаживания
//--------------------------------------------------------------- 3 --
int
   Period_MA_2,  Period_MA_3,       // Расчётные периоды МА для др. ТФ
   K2, K3;                          // Коэффициенты соотношения ТФ
double
   Line_0[],                        // Инидикаторн. массив опорной MA
   Line_1[], Line_2[], Line_3[],    // Инд. массивы линий скорости
   Line_4[],                        // Инидикаторн. массив суммарный
   Line_5[],                        // Инд.массив суммарный сглаженный
   Sh_1, Sh_2, Sh_3;                // Колич.баров для расч. скоростей
//--------------------------------------------------------------- 4 --
int init()                          // Специальная функция init()
  {
   SetIndexBuffer(0,Line_0);        // Назначение массива буферу
   SetIndexBuffer(1,Line_1);        // Назначение массива буферу
   SetIndexBuffer(2,Line_2);        // Назначение массива буферу
   SetIndexBuffer(3,Line_3);        // Назначение массива буферу
   SetIndexBuffer(4,Line_4);        // Назначение массива буферу
   SetIndexBuffer(5,Line_5);        // Назначение массива буферу
   SetIndexStyle (5,DRAW_LINE,STYLE_SOLID,3);// Стиль линии
//--------------------------------------------------------------- 5 --
   switch(Period())                 // Расчёт коэффициентов для..
     {                              // .. различных ТФ
      case     1: K2=5;K3=15; break;// Таймфрейм М1
      case     5: K2=3;K3= 6; break;// Таймфрейм М5
      case    15: K2=2;K3= 4; break;// Таймфрейм М15
      case    30: K2=2;K3= 8; break;// Таймфрейм М30
      case    60: K2=4;K3=24; break;// Таймфрейм H1
      case   240: K2=6;K3=42; break;// Таймфрейм H4
      case  1440: K2=7;K3=30; break;// Таймфрейм D1
      case 10080: K2=4;K3=12; break;// Таймфрейм W1
      case 43200: K2=3;K3=12; break;// Таймфрейм МN
     }
//--------------------------------------------------------------- 6 --
   Sh_1=Bars_V;                     // Период измерен скорости (баров)
   Sh_2=K2*Sh_1;                    // Период измерен. для ближ. ТФ
   Sh_3=K3*Sh_1;                    // Период измерен. для след. ТФ
   Period_MA_2 =K2*Period_MA_1;     // Расчётн.период МА для ближ. ТФ
   Period_MA_3 =K3*Period_MA_1;     // Расчётн.период МА для след. ТФ
//--------------------------------------------------------------- 7 --
   return;                          // Выход из спец. функции init()
  }
//--------------------------------------------------------------- 8 --
int start()                         // Специальная функция start()
  {
//--------------------------------------------------------------- 9 --
   double
   MA_c, MA_p,                      // Текущее и предыдущ. знач. МА
   Sum;                             // Техн.параметр для накопл. суммы
   int
   i,                               // Индекс бара
   n,                               // Формальн. параметр(индекс бара)
   Counted_bars;                    // Количество просчитанных баров
//-------------------------------------------------------------- 10 --
   Counted_bars=IndicatorCounted(); // Количество просчитанных баров
   i=Bars-Counted_bars-1;           // Индекс первого непосчитанного
   if (i>History-1)                 // Если много баров то ..
      i=History-1;                  // ..рассчитывать заданное колич.
//-------------------------------------------------------------- 11 --
   while(i>=0)                      // Цикл по непосчитанным барам
     {
      //-------------------------------------------------------- 12 --
      Line_0[i]=0;                  // Горизонтальная линия отсчёта
      //-------------------------------------------------------- 13 --
      MA_c=iMA(NULL,0,Period_MA_1,0,MODE_LWMA,PRICE_TYPICAL,i);
      MA_p=iMA(NULL,0,Period_MA_1,0,MODE_LWMA,PRICE_TYPICAL,i+Sh_1);
      Line_1[i]= MA_c-MA_p;         // Значение 1 линии скорости
      //-------------------------------------------------------- 14 --
      MA_c=iMA(NULL,0,Period_MA_2,0,MODE_LWMA,PRICE_TYPICAL,i);
      MA_p=iMA(NULL,0,Period_MA_2,0,MODE_LWMA,PRICE_TYPICAL,i+Sh_2);
      Line_2[i]= MA_c-MA_p;         // Значение 2 линии скорости
      //-------------------------------------------------------- 15 --
      MA_c=iMA(NULL,0,Period_MA_3,0,MODE_LWMA,PRICE_TYPICAL,i);
      MA_p=iMA(NULL,0,Period_MA_3,0,MODE_LWMA,PRICE_TYPICAL,i+Sh_3);
      Line_3[i]= MA_c-MA_p;         // Значение 3 линии скорости
      //-------------------------------------------------------- 16 --
      Line_4[i]=(Line_1[i]+Line_2[i]+Line_3[i])3;// Суммарный массив
      //-------------------------------------------------------- 17 --
      if (Aver_Bars<0)              // Если неверно задано сглаживание
         Aver_Bars=0;               // .. то не меньше нуля
      Sum=0;                        // Технический приём
      for(n=i; n<=i+Aver_Bars; n++) // Суммироваение последних значен.
         Sum=Sum + Line_4[n];       // Накопление суммы последн. знач.
      Line_5[i]= Sum(Aver_Bars+1); // Индик. массив сглаженной линии
      //-------------------------------------------------------- 18 --
      i--;                          // Расчёт индекса следующего бара
      //-------------------------------------------------------- 19 --
     }
   return;                          // Выход из спец. ф-ии start()
  }
//-------------------------------------------------------------- 20 --

При внимательном рассмотрении рисунков индикаторных линий, отображаемых в отдельном окне и на ценовом графике, можно заметить некоторые отличия, которые продиктованы использованием при расчётах разных методов. Для расчётов индикаторных линий, отображаемых в основном окне, используются опорные МА, а при расчётах для отдельного окна опорные МА отсутствуют. По этой же причине наблюдается строгое совпадение по времени точек пересечения линии скорости с опорной МА в индикаторе roc.mq4 и точек пересечения линии скорости с нулевой линией в индикаторе rocseparate.mq4.

Рис. 130. Пользовательский индикатор rocseparate.mq4 позволяет наблюдать в отдельном окне график
изменения скорости на текущем, ближайшем большем и следующем большем таймфрейме, а также их среднюю.

Создание пользовательских индикаторовСовместное использование программ


Совместное использование программ - Простые программы на MQL4 - Учебник по MQL4

Учебник по MQL4 [image] Простые программы на MQL4 [image] Совместное использование программ
MetaQuotes Sofware Corp.
  • Использование технических индикаторов
  • Простой эксперт
  • Создание пользовательских индикаторов
  • Пользовательский индикатор скорости изменения цены (ROC)
  • Совместное использование программ
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Совместное использование программ

Ранее упоминалось, что, в соответствии с правилами MQL4, применение торговых функций в пользовательских индикаторах не допускается, поэтому для автоматической торговли необходимо использовать эксперт или скрипт. Однако, ресурсосберегающая технология, принятая для расчётов в индикаторах (см. Создание пользовательских индикаторов), оказывается востребованной при создании торгующих программ. В значительной части случаев в пользовательских индикаторах можно эффективно рассчитать значения элементов индикаторных массивов, необходимые для формирования в эксперте торговых критериев и принятия торговых решений.

Расчёты, выполняемые в пользовательских индикаторах, технически возможно выполнять и в экспертах, однако это может привести к дублированию расчётов в разных прикладных программах и неоправданному расходованию ресурсов, а в некоторых случаях (при выполнении длительных энергоёмких вычислений) - к запаздыванию торговых решений. В тех случаях, когда в эксперте или скрипте возникает потребность в использовании результатов вычислений, выполненных в пользовательском индикаторе, можно использовать функцию iCustom().

Функция iCustom()

double iCustom(string symbol, int timeframe, string name, ..., int mode, int shift)

Расчет указанного пользовательского индикатора. Пользовательский индикатор должен быть скомпилирован (файл с расширением EX4) и находиться в директории Каталог_терминала\experts\indicators.

Параметры:

symbol - символьное имя инструмента, на данных которого будет вычисляться индикатор. NULL означает текущий символ.

timeframe - период. Может быть одним из периодов графика. 0 означает период текущего графика.

name - имя пользовательского индикатора.

... - Список параметров (при необходимости). Передаваемые параметры должны соответствовать порядку объявления и типу внешних (extern) переменных пользовательского индикатора.

mode - Индекс линии индикатора. Может быть от 0 до 7 и должен соответствовать индексу, используемому одной из функций SetIndexBuffer.

shift - Индекс получаемого значения из индикаторного буфера (сдвиг относительно текущего бара на указанное количество периодов назад).

Рассмотрим, как практически может быть использована функция iCustom(), для этого решим следующую задачу:

Задача 30. Торговая стратегия построена на данных пользовательского индикатора rocseparate.mq4. Если линия скорости изменения цены на текущем таймфрейме (оранжевая) пересекает сглаженную среднюю линию скорости (красная жирная) ниже некоторого заданного уровня снизу вверх, то считать значимым торговый критерий на покупку (открыть Buy и закрыть Sell). При зеркальных условиях считать значимым критерий на продажу. Представить код эксперта, реализующего эту стратегию.

Принцип построения пользовательского индикатора rocseparate.mq4 подробно рассмотрен в разделе Пользовательский индикатор ROC. На Рис. 131 показаны две точки, в которых линия скорости изменения цены на текущем таймфрейме (М15) пересекается со средней сглаженной линией скорости изменения цены. В точке А оранжевая линия пересекает красную снизу вверх, причём место пересечения линий находится ниже уровня -0.001. В точке В оранжевая пересекает красную сверху вниз, причём точка пересечения находится выше уровня 0.001. Факт пересечения указанных линий должен быть вычислен в эксперте и расцениваться как сигнал на покупку (точка А - закрыть Sell и открыть Buy) или продажу (точка В - закрыть Buy и открыть Sell).

Рис. 131. Пересечения линий пользовательского индикатора рассматривается как торговый критерий.

При решении подобных задач можно использовать готовый эксперт, изменив в нём порядок расчёта торговых критериев. В данном случае можно взять за основу эксперт tradingexpert.mq4, представленный в разделе Простой эксперт. Эксперт shared.mq4, вычисляющий торговые критерии на основе пользовательского индикатора, будет выглядеть так:

//--------------------------------------------------------------------
// shared.mq4
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------------
#property copyright "Copyright © Book, 2007"
#property link      "http://AutoGraf.dp.ua"
//--------------------------------------------------------------- 1 --
                      // М15
extern double StopLoss  =100;          // SL для открываемого ордера
extern double TakeProfit=35;           // ТР для открываемого ордера
extern double Lots      =0.1;          // Жестко заданное колич. лотов
extern double Prots     =0.07;         // Процент свободных средств
//-------------------------------------------------------------- 1a --
extern int Period_MA_1  =56;           // Период расчётной МА
extern int Bars_V       =34;           // Колич.баров для расчёта скор
extern int Aver_Bars    =0;            // Колич. баров для сглаживания
extern double Level     =0.001;
//-------------------------------------------------------------- 1b --
bool   Work=true;                      // Эксперт будет работать.
string Symb;                           // Название финанс. инструмента
//--------------------------------------------------------------- 2 --
int start()
  {
   int
   Total,                              // Количество ордеров в окне
   Tip=-1,                             // Тип выбран. ордера (B=0,S=1)
   Ticket;                             // Номер ордера
   double
   MA_1_t,                             // Значен. МА_1 текущее
   MA_2_t,                             // Значен. МА_2 текущее
   Lot,                                // Колич. лотов в выбран.ордере
   Lts,                                // Колич. лотов в открыв.ордере
   Min_Lot,                            // Минимальное количество лотов
   Step,                               // Шаг изменения размера лота
   Free,                               // Текущие свободные средства
   One_Lot,                            // Стоимость одного лота
   Price,                              // Цена выбранного ордера
   SL,                                 // SL выбранного ордера
   TP;                                 // TP выбранного ордера
   bool
   Ans  =false,                        // Ответ сервера после закрытия
   Cls_B=false,                        // Критерий для закрытия  Buy
   Cls_S=false,                        // Критерий для закрытия  Sell
   Opn_B=false,                        // Критерий для открытия  Buy
   Opn_S=false;                        // Критерий для открытия  Sell
//--------------------------------------------------------------- 3 --
   // Предварит.обработка
   if(Bars < Period_MA_1)                       // Недостаточно баров
     {
      Alert("Недостаточно баров в окне. Эксперт не работает.");
      return;                                   // Выход из start()
     }
   if(Work==false)                              // Критическая ошибка
     {
      Alert("Критическая ошибка. Эксперт не работает.");
      return;                                   // Выход из start()
     }
//--------------------------------------------------------------- 4 --
   // Учёт ордеров
   Symb=Symbol();                               // Название фин.инстр.
   Total=0;                                     // Количество ордеров
   for(int i=1; i<=OrdersTotal(); i++)          // Цикл перебора ордер
     {
      if (OrderSelect(i-1,SELECT_BY_POS)==true) // Если есть следующий
        {                                       // Анализ ордеров:
         if (OrderSymbol()!=Symb)continue;      // Не наш фин. инструм
         if (OrderType()>1)                     // Попался отложенный
           {
            Alert("Обнаружен отложенный ордер. Эксперт не работает.");
            return;                             // Выход из start()
           }
         Total++;                               // Счётчик рыночн. орд
         if (Total>1)                           // Не более одного орд
           {
            Alert("Несколько рыночных ордеров. Эксперт не работает.");
            return;                             // Выход из start()
           }
         Ticket=OrderTicket();                  // Номер выбранн. орд.
         Tip   =OrderType();                    // Тип выбранного орд.
         Price =OrderOpenPrice();               // Цена выбранн. орд.
         SL    =OrderStopLoss();                // SL выбранного орд.
         TP    =OrderTakeProfit();              // TP выбранного орд.
         Lot   =OrderLots();                    // Количество лотов
        }
     }
//--------------------------------------------------------------- 5 --
   // Торговые критерии
   int H= 1000;                   // Колич.баров в расчётной истории
   int P= Period_MA_1;            // Период расчётной МА
   int B= Bars_V;                 // Колич.баров для расчёта скорост
   int A= Aver_Bars;              // Колич. баров для сглаживания
//-------------------------------------------------------------- 5a --
   double L_1=iCustom(NULL,0,"rocseparate",H,P,B,A,1,0);
   double L_5=iCustom(NULL,0,"rocseparate",H,P,B,A,5,0);
//-------------------------------------------------------------- 5b --
   if (L_5<=-Level && L_1>L_5)
     {
      Opn_B=true;                               // Критерий откр. Buy
      Cls_S=true;                               // Критерий закр. Sell
     }
   if (L_5>=Level && L_1<L_5)
     {
      Opn_S=true;                               // Критерий откр. Sell
      Cls_B=true;                               // Критерий закр. Buy
     }
//--------------------------------------------------------------- 6 --
   // Закрытие ордеров
   while(true)                                  // Цикл закрытия орд.
     {
      if (Tip==0 && Cls_B==true)                // Открыт ордер Buy..
        {                                       //и есть критерий закр
         Alert("Попытка закрыть Buy ",Ticket,". Ожидание ответа..");
         RefreshRates();                        // Обновление данных
         Ans=OrderClose(Ticket,Lot,Bid,2);      // Закрытие Buy
         if (Ans==true)                         // Получилось :)
           {
            Alert ("Закрыт ордер Buy ",Ticket);
            break;                              // Выход из цикла закр
           }
         if (Fun_Error(GetLastError())==1)      // Обработка ошибок
            continue;                           // Повторная попытка
         return;                                // Выход из start()
        }

      if (Tip==1 && Cls_S==true)                // Открыт ордер Sell..
        {                                       // и есть критерий закр
         Alert("Попытка закрыть Sell ",Ticket,". Ожидание ответа..");
         RefreshRates();                        // Обновление данных
         Ans=OrderClose(Ticket,Lot,Ask,2);      // Закрытие Sell
         if (Ans==true)                         // Получилось :)
           {
            Alert ("Закрыт ордер Sell ",Ticket);
            break;                              // Выход из цикла закр
           }
         if (Fun_Error(GetLastError())==1)      // Обработка ошибок
            continue;                           // Повторная попытка
         return;                                // Выход из start()
        }
      break;                                    // Выход из while
     }
//--------------------------------------------------------------- 7 --
   // Стоимость ордеров
   RefreshRates();                              // Обновление данных
   Min_Lot=MarketInfo(Symb,MODE_MINLOT);        // Миним. колич. лотов
   Free   =AccountFreeMargin();                 // Свободн средства
   One_Lot=MarketInfo(Symb,MODE_MARGINREQUIRED);// Стоимость 1 лота
   Step   =MarketInfo(Symb,MODE_LOTSTEP);       // Шаг изменен размера

   if (Lots > 0)                                // Если заданы лоты,то
      Lts =Lots;                                // с ними и работаем
   else                                         // % свободных средств
      Lts=MathFloor(Free*ProtsOne_LotStep)*Step;// Для открытия

   if(Lts < Min_Lot) Lts=Min_Lot;               // Не меньше минимальн
   if (Lts*One_Lot > Free)                      // Лот дороже свободн.
     {
      Alert(" Не хватает денег на ", Lts," лотов");
      return;                                   // Выход из start()
     }
//--------------------------------------------------------------- 8 --
   // Открытие ордеров
   while(true)                                  // Цикл закрытия орд.
     {
      if (Total==0 && Opn_B==true)              // Открытых орд. нет +
        {                                       // критерий откр. Buy
         RefreshRates();                        // Обновление данных
         SL=Bid - New_Stop(StopLoss)*Point;     // Вычисление SL откр.
         TP=Bid + New_Stop(TakeProfit)*Point;   // Вычисление TP откр.
         Alert("Попытка открыть Buy. Ожидание ответа..");
         Ticket=OrderSend(Symb,OP_BUY,Lts,Ask,2,SL,TP);//Открытие Buy
         if (Ticket > 0)                        // Получилось :)
           {
            Alert ("Открыт ордер Buy ",Ticket);
            return;                             // Выход из start()
           }
         if (Fun_Error(GetLastError())==1)      // Обработка ошибок
            continue;                           // Повторная попытка
         return;                                // Выход из start()
        }
      if (Total==0 && Opn_S==true)              // Открытых орд. нет +
        {                                       // критерий откр. Sell
         RefreshRates();                        // Обновление данных
         SL=Ask + New_Stop(StopLoss)*Point;     // Вычисление SL откр.
         TP=Ask - New_Stop(TakeProfit)*Point;   // Вычисление TP откр.
         Alert("Попытка открыть Sell. Ожидание ответа..");
         Ticket=OrderSend(Symb,OP_SELL,Lts,Bid,2,SL,TP);//Открытие Sel
         if (Ticket > 0)                        // Получилось :)
           {
            Alert ("Открыт ордер Sell ",Ticket);
            return;                             // Выход из start()
           }
         if (Fun_Error(GetLastError())==1)      // Обработка ошибок
            continue;                           // Повторная попытка
         return;                                // Выход из start()
        }
      break;                                    // Выход из while
     }
//--------------------------------------------------------------- 9 --
   return;                                      // Выход из start()
  }
//-------------------------------------------------------------- 10 --
int Fun_Error(int Error)                        // Ф-ия обработ ошибок
  {
   switch(Error)
     {                                          // Преодолимые ошибки
      case  4: Alert("Торговый сервер занят. Пробуем ещё раз..");
         Sleep(3000);                           // Простое решение
         return(1);                             // Выход из функции
      case 135:Alert("Цена изменилась. Пробуем ещё раз..");
         RefreshRates();                        // Обновим данные
         return(1);                             // Выход из функции
      case 136:Alert("Нет цен. Ждём новый тик..");
         while(RefreshRates()==false)           // До нового тика
            Sleep(1);                           // Задержка в цикле
         return(1);                             // Выход из функции
      case 137:Alert("Брокер занят. Пробуем ещё раз..");
         Sleep(3000);                           // Простое решение
         return(1);                             // Выход из функции
      case 146:Alert("Подсистема торговли занята. Пробуем ещё..");
         Sleep(500);                            // Простое решение
         return(1);                             // Выход из функции
         // Критические ошибки
      case  2: Alert("Общая ошибка.");
         return(0);                             // Выход из функции
      case  5: Alert("Старая версия терминала.");
         Work=false;                            // Больше не работать
         return(0);                             // Выход из функции
      case 64: Alert("Счет заблокирован.");
         Work=false;                            // Больше не работать
         return(0);                             // Выход из функции
      case 133:Alert("Торговля запрещена.");
         return(0);                             // Выход из функции
      case 134:Alert("Недостаточно денег для совершения операции.");
         return(0);                             // Выход из функции
      default: Alert("Возникла ошибка ",Error); // Другие варианты
         return(0);                             // Выход из функции
     }
  }
//-------------------------------------------------------------- 11 --
int New_Stop(int Parametr)                      // Проверка стоп-прик.
  {
   int Min_Dist=MarketInfo(Symb,MODE_STOPLEVEL);// Миним. дистанция
   if (Parametr<Min_Dist)                       // Если меньше допуст.
     {
      Parametr=Min_Dist;                        // Установим допуст.
      Alert("Увеличена дистанция стоп-приказа.");
     }
   return(Parametr);                            // Возврат значения
  }
//-------------------------------------------------------------- 12 --

Рассмотрим, какие преобразования внесены в исходный код (tradingexpert.mq4). Значительная часть кода эксперта, взятого за основу, не изменилась. Изменения внесены в два блока - блок 1-2 и блок 5-6.

В блоке 5-6 рассчитываются торговые критерии. В представленном эксперте торговая стратегия построена на основе всего двух торговых критериев - критерия открытия Buy и критерия открытия Sell. Принятая в эксперте стратегия предусматривает возможность одновременного присутствия в торговле только одного рыночного ордера, отложенные ордера не допускаются. Стратегия предполагает также закрытие противоположного ордера при срабатывании критерия открытия; например, если значимым является критерий для открытия Buy, то это также означает, что необходимо закрыть Sell.

Для того, чтобы в эксперте shared.mq4 использовать результаты вычислений, выполненных в пользовательском индикаторе rocseparate.mq4, необходимо исполнить функцию iCustom():

   double L_1 = iCustom(NULL,0,"rocseparate",H,P,B,A,1,0);
   double L_5 = iCustom(NULL,0,"rocseparate",H,P,B,A,5,0);

В данном случае формальные параметры, указанные в вызове функции iCustom(), означают следующее:

NULL - расчёты в индикаторе осуществляются на основе данных по текущему финансовому инструменту; в данном случае эксперт прикреплён в оно EURUSD, значит, будут использованы данные по EURUSD (см. Рис. 131);

0 - при расчётах используются данные, соответствующие текущему таймфрейму; в данном случае текущий таймфрейм М15, значит, будут использованы данные, соответствующие М15;

"rocseparate" - название пользовательского индикатора, в котором будут выполнены расчёты.

H,P,B и A - список настраиваемых параметров. В данном случае пользовательский индикатор rocseparate.mq4 имеет настраиваемые параметры (блок 2-3 в коде rocseparate.mq4). Для того чтобы предоставить пользователю возможность настраивать значения этих параметров из эксперта, они указаны в списке передаваемых параметров функции iCustom(). В эксперте могут быть определены значения этих параметров, не совпадающие по значению с теми, что указаны в индикаторе, и при выполнении расчётов в индикаторе будут использоваться именно эти переданные значения. Эти параметры означают следующее:

H - количество баров в расчётной истории;

P - период расчётной МА;

B - количество баров для расчёта скорости;

A - количество баров для сглаживания.

(подробное объяснение сущности указанных параметров см. в разделе Пользовательский индикатор ROC).

1 (5) - индекс линии индикатора. В пользовательском индикаторе rocseparate.mq4 используется 6 индикаторных массивов. Линия скорости изменения цены на текущем таймфрейме (оранжевая) строится на основе значений индикаторного массива Line_1[], для которого используется буфер с индексом 1. Средняя сглаженная линия скорости строится на основе значений элементов массива Line_5[], индекс используемого буфера 5.

0 - индекс получаемого значения из индикаторного буфера (сдвиг относительно текущего бара на указанное количество периодов назад). В данном случае используются значения индикаторных линий на нулевом баре, поэтому указан индекс 0.

Для того, чтобы предоставить пользователю возможность вручную в эксперте изменять настраиваемые параметры индикатора, в блоке 1а-1b (эксперта) указаны внешние переменные. В блоке 5-5а значения этих настраиваемых параметров переприсвоены другим переменным с более короткими именами - это сделано для удобства представления кода в блоке 5а-5b. Таким образом, пользователь может по своему усмотрению указать в эксперте shared.mq4 параметры, при которых будут производиться расчёты в пользовательском индикаторе rocseparate.mq4. После исполнения функция iCustom() вернёт значение, соответствующее значению заданного элемента индикаторного массива, вычисленного в заданном индикаторе при заданных значениях настраиваемых параметров.

Во время практической работы удобно наблюдать в окне финансового инструмента линии индикатора, значения индикаторных массивов которого используются в эксперте (см. Рис. 131). Вместе с тем, исполнение функции iCustom() никак не связано с наличием в окне финансового инструмента вызываемого индикатора, а также со значениями его настраиваемых параметров.

Для исполнения функции iCustom() не требуется, чтобы соответствующий технический индикатор был прикреплён к окну финансового инструмента. Также и вызов функции iCustom() из какой-либо прикладной программы не приводит к присоединению соответствующего индикатора к окну финансового инструмента. Присоединение технического индикатора к окну финансового инструмента тоже не приводит к вызову функции iCustom() в какой-либо прикладной программе.

Торговые критерии в эксперте (блок 5-6) вычисляются на основе значений элементов массивов, полученных с помощью функции Custom(). Например, критерий для открытия Buy и закрытия Sell вычисляется так:

    if (L_5<=-Level && L_1>L_5)
     {
      Opn_B = true;                             // Критерий откр. Buy
      Cls_S = true;                             // Критерий закр. Sell
     }

Если последнее известное значение средней сглаженной линии скорости изменения цены (L_5) меньше заданного уровня (значение настраиваемого параметра Level = 0.001) и при этом последнее известное значение линии скорости изменения цены в текущем таймфрейме (L_1) больше средней сглаженной линии скорости цены (L_5), то значимыми являются критерий для открытия ордера Buy и критерий закрытия ордера Sell. Для подтверждения значимости противоположных критериев используются зеркальные условия.

Принятые в данном эксперте торговые критерии используются в учебных целях и не должны рассматриваться как руководство к действию при торговле на реальном счёте.

Пользовательский индикатор скорости изменения цены (ROC)Стандартные функции


Операции с графиками - Стандартные функции - Учебник по MQL4

Учебник по MQL4 [image] Стандартные функции [image] Операции с графиками
MetaQuotes Sofware Corp.
  • Общие функции
  • Графические объекты
  • Операции с графиками
  • Строковые функции
  • Дата и время
  • Файловые операции
  • Массивы и таймсерии
  • Математические функции
  • Глобальные переменные GlobalVariables
  • Пользовательские индикаторы
  • Информация о счёте
  • Торговые функции
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Операции с графиками

Обычно во время практической работы трейдер открывает в окне финансового инструмента несколько подокон, в которых отображаются индикаторы. Порядок вывода индикаторов не лимитирован - они могут располагаться в любой последовательности. Количество подокон в окне финансового инструмента не ограничено. Все подокна имеют свой номер. Основное окно, в котором отображается ценовой график, имеется всегда, его номер 0. Каждое из подокон индикаторов также имеют номер. Соблюдается простой порядок нумерации подокон - в порядке представления в окне финансового инструмента в направлении сверху вниз: подокно индикатора, ближайшее к основному, имеет номер 1, следующее нижнее имеет номер 2, следующее - номер 3 и т.д.

Рис. 140. Расположение подокон в окне финансового инструмента.

Количество подокон можно легко вычислить с помощью функции:

int WindowsTotal()

Функция возвращает количество подокон индикаторов на графике, включая главное окно графика. Максимальный номер (самого нижнего) окна всегда на 1 меньше, чем общее количество подокон (включая основное, с номером 0) в окне финансового инструмента. Если в ситуации, изображённой на рис. 140, из любой прикладной программы вызвать для исполнения функцию WindowsTotal(), то возвращённое ею значение будет равно 3, в то время как максимальный номер (самого нижнего) подокна равен 2.

Указанный порядок нумерации окон сохраняется в случаях, если добавляется новое подокно индикатора или удаляется любое из имеющихся. В случае добавления нового окна, оно отображается ниже всех других подокон и получает соответствующий номер, на 1 больше, чем номер вышестоящего окна. Если же какое-либо из подокон удаляется из окна финансового инструмента, то все подокна, находящиеся ниже него, автоматически перенумеруются - номер каждого из них уменьшается на 1.

В MQL4 предусмотрена возможность создавать графические объекты (и изменять их свойства) в любом из имеющихся подокон. Для этого в функции ObjectCreate() предусмотрен параметр window, согласно которому объект создаётся в указанном подокне окна финансового инструмента. Текущий номер подокна можно вычислить с помощью функции:

int WindowFind(string name)

Функция возвращает номер подокна графика, содержащего индикатор с указанным именем name, если он найден, иначе возвращается -1. Функция также возвращает -1, если пользовательский индикатор ищет сам себя в процессе инициализации init().

Параметры:

name - короткое имя индикатора.

Количество подокон в окне финансового инструмента может измениться в любой момент в результате удаления пользователем какого-либо из индикаторов. Поэтому алгоритм прикладной программы, поддерживающей управление графическими объектами, должен предусматривать постоянное отслеживание номеров окон, в которых отображаются индикаторы.

Задача 34. Используя графические объекты, отобразить сообщения о показаниях двух индикаторов. Если в окне финансового инструмента установлен соответствующий индикатор, то графический объект выводить в окно индикатора, в противном случае - в основное окно.

Для решения задачи выберем индикаторы RSI и Momentum. Общий алгоритм построения эксперта сводится к следующему. В функции init() можно задать тексты, которые будут выводиться на экран в зависимости от показаний индикаторов, т.е. выполнить те вычисления, которые выполняются в программе один раз. В функции start() необходимо вычислить показания индикаторов, определить наличие необходимых подокон и их номера, а затем, в зависимости от ситуации, выдать то или иное сообщение в то или иное подокно. При исполнении функции deinit() необходимо удалить все графические объекты, созданные в процессе работы программы. Ниже представлен эксперт charts.mq4, управляющий графическими объектами в подокнах окна финансового инструмента.

//--------------------------------------------------------------------
// charts.mq4
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------- 1 --
int   Win_Mom_old=0,                   // Старый номер подокна Moment.
      Win_RSI_old=0;                   // Старый номер подокна RSI
color Color[5];                        // Объявление массива цветов
string Text[5];                        // Объявление строков. массива
//--------------------------------------------------------------- 2 --
int init()                             // Спец. функция init()
  {
   Win_RSI_old=0;                      // Технический момент
   Win_Mom_old=0;                      // Технический момент

   Text[0]= "RSI(14) ниже 30. Buy";    // Тексты для ситуаций RSI
   Text[1]= "RSI(14) выше 70. Sell";   // Тексты для ситуаций RSI
   Text[2]= "RSI(14) между 30 и 70";   // Тексты для ситуаций RSI
   Text[3]= "Моментум(14) повышается"; // Тексты для ситуаций Моментум
   Text[4]= "Моментум(14) снижается";  // Тексты для ситуаций Моментум
   Color[0]= DeepSkyBlue;              // Цвет объектов для ..
   Color[1]= LightPink;                // .. различных ситуаций ..
   Color[2]= Orange;                   // .. индикатора RSI
   Color[3]= Color[0];                 // Те же цвета для Моментум
   Color[4]= Color[1];                 // Те же цвета для Моментум

   Create_RSI(0);                      // Создание первого объекта
   Create_Mom(0);                      // Создание второго объекта
   Main();                             // Вызов пользовательской ф-ии
   return;                             // Выход из init()
  }
//--------------------------------------------------------------- 3 --
int start()                            // Спец. функция start
  {
   Main();                             // Вызов пользовательской ф-ии
   return;                             // Выход из start()
  }
//--------------------------------------------------------------- 4 --
int deinit()                           // Спец. функция deinit()
  {
   ObjectDelete("Obj_RSI");            // Удаление объекта
   ObjectDelete("Obj_Mom");            // Удаление объекта
   return;                             // Выход из deinit()
  }
//--------------------------------------------------------------- 5 --
int Main()                             // Пользовательская функция
  {
   int                                 // Целые переменные
   Win_RSI_new=0,                      // Новый  номер подокна RSI
   Win_Mom_new=0,                      // Новый  номер подокна Moment.
   Ind_RSI, Ind_Mom;                   // Индексы для ситуаций
   double                              // Действительные переменные
   RSI,                                // Значение RSI на 0 баре
   Mom_0, Mom_1;                       // Значение Mom на 0 и 1 барах
//--------------------------------------------------------------- 6 --
   RSI=iRSI(NULL,0,14,PRICE_CLOSE,0);  // RSI(14) на нулевом баре
   Ind_RSI=2;                          // RSI между уровнями 30 и 70
   if(RSI < 30)Ind_RSI=0;              // RSI внизу.  Нужно покупать
   if(RSI > 70)Ind_RSI=1;              // RSI вверху. Нужно продавать
//--------------------------------------------------------------- 7 --
   Win_RSI_new=WindowFind("RSI(14)");  // Номер окна индикатора RSI
   if(Win_RSI_new==-1) Win_RSI_new=0;  // Если нет индик, то осн. окно
   if(Win_RSI_new!=Win_RSI_old)        // Удалено или установлено ..
     {                                 // .. окно индикатора RSI
      ObjectDelete("Obj_RSI");         // Удаление объекта
      Create_RSI(Win_RSI_new);         // Создаём объект в нужном окне
      Win_RSI_old=Win_RSI_new;         // Запомним это окно
     }                                 // Изменяем текстовое описание:
   ObjectSetText("Obj_RSI",Text[Ind_RSI],10,"Arial",Color[Ind_RSI]);
//--------------------------------------------------------------- 8 --
   Mom_0=iMomentum(NULL,0,14,PRICE_CLOSE,0);// Значен. на нулевом баре
   Mom_1=iMomentum(NULL,0,14,PRICE_CLOSE,1);// Знач. на предыдущ. баре
   if(Mom_0 >=Mom_1)Ind_Mom=3;         // Индик. линия поднимается
   if(Mom_0 < Mom_1)Ind_Mom=4;         // Индик. линия опускается
//--------------------------------------------------------------- 9 --
   Win_Mom_new=WindowFind("Momentum(14)");// Номер окна индик. Momen
   if(Win_Mom_new==-1) Win_Mom_new=0;  // Если нет индик, то осн. окно
   if(Win_Mom_new!=Win_Mom_old)        // Удалено или установлено ..
     {                                 // .. окно индикатора Momentum
      ObjectDelete("Obj_Mom");         // Удаление объекта
      Create_Mom(Win_Mom_new);         // Создаём объект в нужном окне
      Win_Mom_old=Win_Mom_new;         // Запомним это окно
     }                                 // Изменяем текстовое описание:
   ObjectSetText("Obj_Mom",Text[Ind_Mom],10,"Arial",Color[Ind_Mom]);
//-------------------------------------------------------------- 10 --
   WindowRedraw();                     // Перерисовка изображения
   return;                             // Выход из пользоват. функции
  }
//-------------------------------------------------------------- 11 --
int Create_RSI(int Win)                         // Пользовательс ф-ия
  {                                             // ..создания объекта
   ObjectCreate("Obj_RSI",OBJ_LABEL, Win, 0,0); // Создание объекта
   ObjectSet("Obj_RSI", OBJPROP_CORNER, 0);     // Привязка к углу
   ObjectSet("Obj_RSI", OBJPROP_XDISTANCE, 3);  // Координата Х
   if (Win==0)
      ObjectSet("Obj_RSI",OBJPROP_YDISTANCE,20);// Координата Y
   else
      ObjectSet("Obj_RSI",OBJPROP_YDISTANCE,15);// Координата Y
   return;                                      // Выход из польз.ф-ии
  }
//-------------------------------------------------------------- 12 --
int Create_Mom(int Win)                         // Пользовательс ф-ия
  {                                             // ..создания объекта
   ObjectCreate("Obj_Mom",OBJ_LABEL, Win, 0,0); // Создание объекта
   ObjectSet("Obj_Mom", OBJPROP_CORNER, 0);     // Привязка к углу
   ObjectSet("Obj_Mom", OBJPROP_XDISTANCE, 3);  // Координата Х
   if (Win==0)
      ObjectSet("Obj_Mom",OBJPROP_YDISTANCE, 5);// Координата Y
   else
      ObjectSet("Obj_Mom",OBJPROP_YDISTANCE,15);// Координата Y
   return;                                      // Выход из польз.ф-ии
  }
//-------------------------------------------------------------- 13 --

Прежде чем рассматривать представленный код, необходимо указать на специфику работы программы. Предполагается, что однажды созданный графический объект (в данном случае отображающий текст) будет присутствовать на экране постоянно (непрерывно), и его текстовое описание будет характеризовать ситуацию. Изменять содержание текстового описания необходимо при исполнении функции start(), на каждом тике. В то же время, при переключении таймфреймов для окна, к которому прикреплён эксперт, программа проходит стадии deinit(), init(), (ожидание тика) и start(). Если первый раз объект создаётся в процессе исполнения start(), то всякий раз при переключении таймфрейма до появления объекта будет проходить некоторое время, равное времени ожидания очередного тика. Это очень неудобно, в особенности, если происходит частое переключение таймфреймов.

В правильно построенной программе необходимые сообщения выводятся на экран в момент присоединения программы к окну финансового инструмента или в момент переключения таймфрейма (т.е. ещё до поступления нового тика). Для этого на этапе исполнения специальной функции init(), как правило, необходимо выполнить все действия, которые будут выполняться на каждом тике при запуске специальной функции start(). Чтобы не повторять в разных специальных функциях один и тот же программный код, его можно организовать в виде отдельной функции. Для этой цели в эксперте создана пользовательская функция Main(). Она вызывается для исполнения один раз на этапе инициализации (блок 2-3) и на каждом тике в процессе последующей работы эксперта (блок 3-4).

В программе (блок 11-13) имеются ещё две пользовательские функции - Create_RSI() и Create_Mom(), предназначенные для создания и изменения свойств объектов. При исполнении функции init() с помощью этих функций создаются необходимые объекты, а вызов на исполнение функции Main() приводит к наделению объектов необходимыми свойствами (отражение в нужном окне объектов с нужным текстовым описанием нужного цвета).

Рассмотрим функцию Main() (блок 5-11) подробно. В блоке 6-7 вычисляются показания индикатора RSI. В зависимости от того, находится ли конец индикаторной линии выше 70, ниже 30 или в промежутке между ними, переменной Ind_RSI присваивается то или иное значение. В дальнейшем это значение используется в качестве индекса массивов Color[] и Text[] (в блоке 7-8) для изменения свойств графического объекта с именем "Obj_RSI".

Блок 7-8. Номер окна индикатора RSI вычисляется в строке:

   Win_RSI_new = WindowFind("RSI(14)");// Номер окна индикатора RSI

В качестве передаваемого параметра используется строковое значение "RSI(14)". Это - короткое имя индикатора, номер которого определяется. В данном случае вся последовательность литер в указанной строке, включая скобки и цифры, является названием. Нужно заметить, что в общем случае в окне финансового инструмента могут находиться несколько однотипных индикаторов, например, RSI(14), RSI(21) и RSI(34). Каждое из подокон, в которых отражаются эти индикаторы, имеет свой номер. Поэтому технические индикаторы разработаны таким образом, что каждый из них формирует своё короткое имя согласно установленным значениям настраиваемых параметров. Короткое имя каждого технического индикатора совпадает с тем, которое отображается в верхнем левом углу его подокна (короткое имя пользовательского индикатора устанавливается программистом по своему усмотрению с помощью функции IndicatorShortName()).

Если в окне финансового инструмента не установлен искомый индикатор, то переменная Win_RSI_new (номер подокна, в котором этот объект должен быть отображён на текущий момент) получит значение -1, т.е. в несуществующее окно. В этом случае в программе предусмотрено выводить графический объект в основное окно графика, номер которого всегда 0:

   if(Win_RSI_new == -1) Win_RSI_new=0;// Если нет индик, то осн. окно

В процессе работы пользователь может установить недостающий индикатор или удалить имеющийся. Для того чтобы определить, какие действия нужно выполнить, в программе используются глобальные переменные Win_RSI_old и Win_Mom_old. Значение каждой из этих переменных - это номер подокна, в котором ранее был создан объект. Если значения переменных Win_RSI_new и Win_RSI_old не совпадают, то это означает, что окно индикатора либо добавлено (а раньше его не было), либо удалено (а на предыдущем тике ещё было). И в том, и в другом случае необходимо удалить ранее созданный графический объект и создать новый в нужном окне:

      ObjectDelete("Obj_RSI");         // Удаление объекта
      Create_RSI(Win_RSI_new);         // Создаём объект в нужном окне

После создания объекта в окне с номером Win_RSI_new переменной Win_RSI_old присваивается значение, равное номеру этого окна, т.е. программа запоминает номер окна, в котором создан графический объект:

      Win_RSI_old = Win_RSI_new;       // Запомним это окно

Если значения переменных Win_RSI_new и Win_RSI_old совпадают, значит достаточно сообщить объекту (уже сейчас расположенному в нужном окне) новое текстовое описание. Это также необходимо сделать в случае создания нового объекта:

      ObjectSetText("Obj_RSI",Text[Ind_RSI],10,"Arial",Color[Ind_RSI]);

Аналогичные вычисления выполняются и для другого подокна - индикатора Momentum (блоки 8 - 10). В конце функции Main() все имеющиеся графические объекты перерисовываются в результате исполнения WindowRedraw().

Легко заметить, что программное управление графическими объектами в подокнах предполагает использование глобальных переменных (можно также использовать static). В подобных случаях при составлении программ необходимо внимательно следить за тем, какие значения могут принимать глобальные переменные в различных случаях и какие последствия это может повлечь. В рассматриваемой программе в функции init() глобальные переменные обнуляются:

   Win_RSI_old = 0;                    // Технический момент
   Win_Mom_old = 0;                    // Технический момент

Необходимость включения в программу этих строк вызвана тем, что глобальные переменные теряют свои значения, только если пользователь прекратил исполнение прикладной программы в окне финансового инструмента. Если же пользователь выполнил настройку внешних переменных или переключил таймфрейм, то программа проходит деинициализацию и последующую инициализацию, однако значения глобальных переменных при этом сохраняются.

Рассмотрим, как будет работать программа, в которой указанные строки отсутствуют. Предположим, что на момент, когда пользователь переключил таймфрейм, в окне финансового инструмента были установлены оба индикатора, с номерами подокон, соответственно, 1 и 2. В рассматриваемом примере при деинициализации программы происходит удаление графических объектов. При исполнении специальной функции init() объекты создаются в нулевом окне. В дальнейшем, при исполнении функции Main(), в блоках 7-8 и 9-10 выполняется сравнение найденного номера окна, в котором должны быть установлены объекты, и номера окна, в котором объекты находились на предыдущем тике. Фактически объекты установлены в нулевом окне, но значения глобальных переменных будут свидетельствовать о другом: их номера будут 1 и 2. В результате графические объекты будут оставаться в основном окне до тех пор, пока пользователь не удалит и вновь не установит соответствующие индикаторы. Для того чтобы предотвратить нежелательное развитие событий, в программе и предусмотрено обнуление глобальных переменных при исполнении функции init(). Таким образом, значения этих переменных поставлены в соответствие ситуации.

В результате исполнения эксперта charts.mq4 можно наблюдать такие варианты сочетания окон и отображения графических объектов:

Рис. 141. Отображение графических объектов в подокнах окна финансового инструмента.

Если в окне финансового инструмента имеются оба индикатора, то соответствующие графические объекты будут отображены в их подокнах. Если ни один из этих индикаторов не установлен, то оба объекта будут созданы программой в основном окне. Добавление или удаление любого из индикаторов, имена которых обрабатываются в программе, приведёт к перемещению соответствующего графического объекта в нужное окно. Добавление или удаление из окна финансового инструмента других индикаторов не повлечёт никаких последствий.

Отдельно нужно заметить, что в данной программе не рассматривается вариант удаления графического объекта пользователем. Практически используемая программа должна содержать анализ такой ситуации с последующим восстановлением объекта (см. решение Задачи 33).

Функции, используемые для работы с графиками

Функция | Краткое описание
HideTestIndicators | Функция выставляет флаг скрытия индикаторов, вызываемых экспертом. При открытии графика после тестирования индикаторы, помеченные флагом скрытия, не будут выведены на график тестирования. Перед каждым вызовом индикатор помечается текущим установленным флагом скрытия (на график тестирования могут быть выведены только те индикаторы, которые непосредственно вызываются из тестируемого эксперта).
Period | Возвращает значение числа минут периода для текущего графика.
RefreshRates | Обновление данных в предопределенных переменных и массивах-таймсериях. Эта функция используется, когда эксперт или скрипт производит вычисления в течение долгого времени и нуждается в обновленных данных. Возвращается TRUE, если данные обновлены, иначе FALSE. Данные могут не обновиться только по той причине, что они соответствуют текущему состоянию клиентского терминала.
Symbol | Возвращает текстовую строку с именем текущего финансового инструмента.
WindowBarsPerChart | Функция возвращает количество баров, помещающихся в окно текущего графика.
WindowExpertName | Возвращает имя выполняющегося эксперта, скрипта, пользовательского индикатора или библиотеки, в зависимости от того, из какой MQL4-программы вызвана данная функция.
WindowFind | Возвращает номер подокна графика, содержащего индикатор с указанным именем name, если он найден, иначе возвращается -1. WindowFind() возвращает -1, если пользовательский индикатор ищет сам себя в процессе инициализации init().
WindowFirstVisibleBar | Функция возвращает номер первого видимого бара в окне текущего графика. Необходимо иметь в виду, что ценовые бары нумеруются задом наперед, от последнего к первому. Текущий бар, самый последний в ценовом массиве, имеет индекс 0. Самый старый бар имеет индекс Bars-1. Если номер первого видимого бара меньше, чем количество видимых баров на графике на 2 и более, это значит, что окно графика заполнено не до конца и имеется поле справа.
WindowHandle | Возвращает системный дескриптор окна (window handle), содержащего указанный график. Если график с symbol и timeframe на момент вызова функции не открыт, то возвращается 0.
WindowIsVisible | Возвращает TRUE, если подокно графика видимо, иначе возвращает FALSE. Подокно графика может быть скрыто из-за свойств видимости помещенного в него индикатора.
WindowOnDropped | Возвращает индекс окна, в которое был брошен эксперт, пользовательский индикатор или скрипт. Это значение будет верным только в том случае, если эксперты, пользовательские индикаторы и скрипты прикреплены с помощью мыши (технология "drag and drop"). Для пользовательских индикаторов, находящихся в процессе инициализации (вызов из функции init()) этот индекс не определен. Возвращаемый индекс является номером окна (0-главное окно графика, подокна индикаторов нумеруются с 1), в котором работает пользовательский индикатор. В процессе инициализации пользовательский индикатор может создать свое собственное новое подокно, и его номер будет отличаться от номера окна, на которое действительно был брошен индикатор.
WindowPriceMax | Возвращает максимальное значение вертикальной шкалы указанного подокна текущего графика (0-главное окно графика, подокна индикаторов нумеруются с 1). Если индекс подокна не указан, то возвращается максимальное значение ценовой шкалы главного окна графика.
WindowPriceMin | Возвращает минимальное значение вертикальной шкалы указанного подокна текущего графика (0-главное окно графика, подокна индикаторов нумеруются с 1). Если индекс подокна не указан, то возвращается минимальное значение ценовой шкалы главного окна графика.
WindowPriceOnDropped | Возвращает значение цены в точке графика, на которой был брошен эксперт или скрипт. Значение будет верным только в случае, если эксперт или скрипт перемещены с помощью мыши (технология "drag and drop"). Для пользовательских индикаторов это значение не определено.
WindowRedraw | Принудительно перерисовывает текущий график. Обычно применяется после изменения свойств объектов.
WindowScreenShot | Сохраняет изображение текущего графика в файле формата GIF. В случае неудачи возвращает FALSE.
WindowTimeOnDropped | Возвращает значение времени в точке графика, на которой был брошен эксперт или скрипт. Значение будет верным только в случае, если эксперт или скрипт перемещены с помощью мыши (технология "drag and drop"). Для пользовательских индикаторов это значение не определено.
WindowsTotal | Возвращает количество окон индикаторов на графике, включая главное окно графика.
WindowXOnDropped | Возвращает значение координаты по оси X в пикселах точки клиентской области окна графика, на которой был брошен эксперт или скрипт. Значение будет верным только в случае, если эксперт или скрипт перемещены с помощью мыши (технология "drag and drop").
WindowYOnDropped | Возвращает значение координаты по оси Y в пикселах точки клиентской области окна графика, на которой был брошен эксперт или скрипт. Значение будет верным только в случае, если эксперт или скрипт перемещены с помощью мыши (технология "drag and drop").

Для получения подробного описания этих и других функций необходимо обратиться к справочной документации на MQL4.community, сайте MetaQuotes Software Corp. или к разделу "Справка" в редакторе MetaEditor.

Графические объектыСтроковые функции


Общие функции - Стандартные функции - Учебник по MQL4

Учебник по MQL4 [image] Стандартные функции [image] Общие функции
MetaQuotes Sofware Corp.
  • Общие функции
  • Графические объекты
  • Операции с графиками
  • Строковые функции
  • Дата и время
  • Файловые операции
  • Массивы и таймсерии
  • Математические функции
  • Глобальные переменные GlobalVariables
  • Пользовательские индикаторы
  • Информация о счёте
  • Торговые функции
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Общие функции

Одной из самых простых и наиболее распространённых функций является функция Comment().

Функция Comment()

void Comment(...)

Функция выводит комментарий, определенный пользователем, в левый верхний угол окна финансового инструмента. Параметры могут иметь любой тип. Количество параметров не может превышать 64. Массивы нельзя передавать в функцию Comment(). Массивы должны печататься поэлементно. Данные типа double выводятся с 4 десятичными цифрами после точки. Для вывода чисел с большей точностью необходимо использовать функцию DoubleToStr(). Типы bool, datetime и color будут напечатаны как числа. Чтобы вывести данные типа datetime в виде строки необходимо использовать функцию TimeToStr().

Параметры:
... - любые значения, разделенные запятыми.

Примером использования этой функции может служить простой эксперт comment.mq4, отражающий информацию о количестве ордеров.

//--------------------------------------------------------------------
// comment.mq4
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------------
int start()                            // Спец. функция start
  {
   int Orders=OrdersTotal();           // Количество ордеров
   if (Orders==0)                      // Если кол.орд равно 0
      Comment("Ордеров нет");          // Комментарий в угол окна
   else                                // Если есть ордера
      Comment("В торговле имеется ",Orders," ордеров." );// Коммент.
   return;                             // Выход
  }
//--------------------------------------------------------------------

В начале программы с помощью функции OrdersTotal() вычисляется общее количество ордеров. В случае, если переменная Orders (количество ордеров) равна 0, то исполняется функция Comment() с параметром "Ордеров нет". Если же в торговле присутствует хотя бы один ордер, то выполняется функция Comment() со списком параметров, перечисленных через запятую. В данном случае используется 3 параметра, первый из которых - строковое значение "В торговле имеется ", второй - целое число Orders и третий - строковое значение " ордеров.". В результате исполнения эксперта при каждом запуске на исполнение функции start() в левом верхнем углу окна финансового инструмента будет отображаться одна из надписей. На Рис. 132 показано окно финансового инструмента в ситуации, когда в торговле одновременно присутствует один ордер.

Рис. 132. Отображение текста в левом верхнем углу окна финансового инструмента в результате исполнения Comment().

Для воспроизведения звуковых файлов используется функция PlaySound().

Функция PlaySound()

void PlaySound(string filename)

Функция воспроизводит звуковой файл. Файл должен быть расположен в каталоге каталог_терминала\sounds или его подкаталоге.

Параметры:
filename - путь к звуковому файлу.

Набор рекомендуемых звуковых файлов приведен в приложении Звуковые файлы.

В некоторых случаях программа может быть составлена так, чтобы поддерживать диалог с пользователем. Для этой цели используется Функция MessageBox().

Функция MessageBox()

int MessageBox(string text=NULL, string caption=NULL, int flags=EMPTY)

Функция MessageBox создает и отображает диалоговое окно сообщений, а также управляет им. Диалоговое окно сообщений содержит определенные в программе сообщение и заголовок, любую комбинацию предопределенных значков и командных кнопок. Если функция успешно выполняется, возвращаемое значение - одно из значений кодов возврата MessageBox(). Функцию нельзя вызывать из пользовательских индикаторов, так как индикаторы выполняются в интерфейсном потоке и не должны его тормозить.

Параметры:
text - текст, содержащий сообщение для отображения;
caption - необязательный текст для отображения в заголовке окна сообщения. Если этот параметр пустой, в заголовке окна будет отображено название эксперта;
flags - необязательные флаги, определяющие вид и поведение диалогового окна. Флаги могут быть комбинацией флагов из следующих групп флагов (см. Коды возврата функции MessageBox).

Рассмотрим пример использования функции MessageBox().

Задача 31. Представить код эксперта, который за 5 минут до выхода важных новостей открывает диалоговое окно, содержащее вопрос о закрытии всех ордеров. Если пользователь нажимает кнопку Yes, то закрыть все ордера, если No, то не выполнять никаких действий.

Эксперт, поддерживающий диалог с пользователем (dialogue.mq4), может быть, например, таким:

//--------------------------------------------------------------------
// dialogue.mq4
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------- 1 --
#include <WinUser32.mqh>               // Нужно для MessageBox
extern double Time_News=15.30;         // Время важных новостей
bool Question=false;                   // Флажок (вопрос ещё не задан)
//--------------------------------------------------------------- 2 --
int start()                            // Спец. функция start
  {
   PlaySound("tick.wav");              // На каждом тике
   double Time_cur=Hour()+ Minute()/100.0;// Текущее время (double)
   if (OrdersTotal()>0 && Question==false && Time_cur>=Time_News-0.05)
     {                                 // При некоторых условиях
      PlaySound("news.wav");           // На каждом тике
      Question=true;                   // Флажок (вопрос уже задан)
      int ret=MessageBox("Время важных новостей. Закрыть все ордера?",
      "Вопрос", MB_YESNO|MB_ICONQUESTION|MB_TOPMOST); // Диалог. окно
      //--------------------------------------------------------- 3 --
      if(ret==IDYES)                   // Если получен ответ ДА
         Close_Orders();               // То закрываем все ордера
     }
   return;                             // Выход
  }
//--------------------------------------------------------------- 4 --
void Close_Orders()                    // Польз. ф-ия закрытия ордеров
  {
   Alert("Работает функция закрытия всех ордеров.");// Для иллюстрации
   return;                             // Выход
  }
//--------------------------------------------------------------- 5 --

В блоке 1-2 в программу включён файл WinUser32.mqh, в котором определены коды возврата функции MessageBox(). В этом блоке также задана внешняя переменная Time_News - время выхода важных новостей. В течение всего периода исполнения эксперта вопрос о закрытии ордеров должен быть задан пользователю всего один раз. Для того, чтобы учитывать в эксперте был ли задан вопрос, объявлена переменная Question.

При каждом запуске на исполнение функции start() (блок 2-3) исполняется функция PlaySound(). Воспроизводимый при этом звук tick.wav напоминает слабый щелчок, наилучшим образом отражающий факт нового тика. Решение об использовании звуков в программе программист принимает по своему выбору. В ряде случаев применение звуков оказывается полезным. Например, по звуку тиков можно судить о факте исполнения эксперта. Другие звуки могут соответствовать иным событиям, например, срабатыванию торгового критерия, закрытию ордера и т.д.

Значение действительной переменной Time_cur соответствует текущему серверному времени. В эксперте анализируются условия, при которых необходимо вывести диалоговое окно. Если в торговле имеется один или более ордеров, диалоговое окно ранее не выводилось и при этом серверное время отличается от времени важных новостей менее, чем на 5 минут, то в программе выполняются определённые действия. Прежде всего исполняется функция PlaySound(), воспроизводимый звук привлекает пользователя обратить внимание на экран. Флаг Question получает значение true (в следующий раз диалог не выводить). В следующей строке исполняется MessageBox():

      int ret=MessageBox("Время важных новостей. Закрыть все ордера?",
      "Вопрос", MB_YESNO|MB_ICONQUESTION|MB_TOPMOST); // Диалог. окно

В данном случае на диалоговой панели будет отображено значение строковой константы "Время важных новостей. Закрыть все ордера?", а значение "Вопрос" будет отображено в верхней строке панели. Флаг MB_YESNO определяет наличие кнопок - в данном случае кнопки ДА и кнопки НЕТ (см. Коды возврата функции MessageBox). Флаг MB_ICONQUESTION определяет иконку, отображаемую в левой части диалогового окна (каждая операционная среда имеет свой набор иконок, на Рис. 133 показана иконка из набора Widows XP). Флаг MB_TOPMOST наделяет диалоговое окно свойством "всегда сверху", т.е. окно всегда будет находиться в области видимости, независимо от того, какие программы исполняются в текущий момент на компьютере пользователя. В результате исполнения функции MessageBox() с указанными параметрами на экран выводится диалоговое окно:

Рис. 133. Диалоговое окно, выводимое в результате исполнения функции MessageBox().

В момент, когда диалоговое окно выведено на экран, исполнение программы приостанавливается до того момента, пока пользователь нажмёт одну из клавиш в диалоговом окне. Как только это произойдёт, управление будет передано в строку, следующую за вызовом функции MessageBox(), в данном случае, в блок 3-4. Это свойство диалогового окна удерживать управление является очень важным и его обязательно необходимо учитывать при составлении программ. Например, если пользователь отлучился от компьютера, и в этот период было выведено диалоговое окно, то в течение всего времени отсутствия пользователя (пока не нажата одна из кнопок на диалоговом окне) программа будет находиться в режиме ожидания ответа, и никакой другой код в этот период исполняться не будет.

Обратите внимание, до вывода диалогового окна исполнение программы сопровождается звуком тиков. В момент вывода диалогового окна воспроизводится другой звук. А в период, пока диалоговое окно открыто и ожидается ответ пользователя, звуки не воспроизводятся, что наглядно иллюстрирует факт удержания управления при открытом диалоговом окне. После нажатия одной из кнопок исполнение программы продолжится, и звук тиков возобновится.

Если пользователь нажал кнопку ДА, то в блоке 3-4 будет вызвана функция Close_Orders(), предназначенная для закрытия всех ордеров. В данном примере содержание этой функции не рассматривается, а для обозначения факта исполнения этой функции исполняется Alert ("Работает функция закрытия всех ордеров."). Если пользователь ответил НЕТ, то функция закрытия ордеров не вызывается. В текущем сеансе исполнения эксперта диалоговое окно больше выводиться не будет.

Общие функции

Функция | Краткое описание
Alert | Отображает диалоговое окно, содержащие пользовательские данные. Параметры могут быть любого типа. Количество параметров не может превышать 64.
Comment | Функция выводит комментарий, определенный пользователем, в левый верхний угол графика. Параметры могут иметь любой тип. Количество параметров не может превышать 64.
GetTickCount | Функция GetTickCount() возвращает количество миллисекунд, прошедших с момента старта системы. Счетчик ограничен разрешающей способностью системного таймера. Так как время хранится как беззнаковое целое, то он переполняется каждые 49.7 дней.
MarketInfo | Возвращает различную информацию о финансовых инструментах, перечисленных в окне "Обзор рынка". Часть информации о текущем финансовом инструменте хранится в предопределенных переменных (см. Идентификаторы функции MarketInfo()).
MessageBox | Функция MessageBox создает и отображает окно сообщений, а также управляет им. Окно сообщений содержит определенные приложением сообщение и заголовок, любую комбинацию предопределенных значков и командных кнопок. Если функция успешно выполняется, возвращаемое значение - одно из значений кодов возврата MessageBox(). Функцию нельзя вызывать из пользовательских индикаторов, так как индикаторы выполняются в интерфейсном потоке и не должны его тормозить
PlaySound | Функция воспроизводит звуковой файл. Файл должен быть расположен в каталоге каталог_терминала\sounds или его подкаталоге.
Print | Печатает некоторое сообщение в журнал экспертов. Параметры могут иметь любой тип. Количество параметров не может превышать 64.
SendFTP | Посылает файл по адресу, указанному в окне настроек на закладке "Публикация". В случае неудачи возвращает FALSE. Функция не работает в режиме тестирования. Из пользовательских индикаторов также нельзя вызывать эту функцию. Отсылаемый файл должен находиться в папке каталог_терминала\experts\files или ее подпапках. Отсылка не производится, если в настройках не указан адрес FTP и/или пароль доступа.
SendMail | Посылает электронное письмо по адресу, указанному в окне настроек на закладке "Почта". Отсылка может быть запрещена в настройках, также может быть не указан адрес электронной почты.
Sleep | Функция задерживает выполнение текущего эксперта или скрипта на определенный интервал. Функцию Sleep() нельзя вызывать из пользовательских индикаторов, так как индикаторы выполняются в интерфейсном потоке и не должны его тормозить. В функцию встроена проверка состояния флага остановки эксперта каждую 0.1 секунды.

Для получения подробного описания этих и других функций необходимо обратиться к справочной документации на MQL4.community, сайте MetaQuotes Software Corp. или к разделу "Справка" в редакторе MetaEditor.

Стандартные функцииГрафические объекты


Дата и время - Стандартные функции - Учебник по MQL4

Учебник по MQL4 [image] Стандартные функции [image] Дата и время
MetaQuotes Sofware Corp.
  • Общие функции
  • Графические объекты
  • Операции с графиками
  • Строковые функции
  • Дата и время
  • Файловые операции
  • Массивы и таймсерии
  • Математические функции
  • Глобальные переменные GlobalVariables
  • Пользовательские индикаторы
  • Информация о счёте
  • Торговые функции
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Дата и время

Информационно-торговая система MetaTrader использует показания двух источников времени - локальное (компьютерное) время и серверное время.

Локальное время - это время, установленное на локальном компьютере.

Серверное время - это время, установленное на сервере.

Функция TimeLocal()

datetime TimeLocal()

Функция возвращает локальное компьютерное время в виде количества секунд, прошедших после 00:00 1 января 1970 года. Замечание: при тестировании локальное время моделируется и совпадает с моделированным последним известным временем сервера.

Подавляющее большинство событий, происходящих в клиентском терминале, учитываются в соответствии с серверным временем. По серверному времени отмечается приход тика, начало нового бара, открытие и закрытие ордеров. Для получения значения серверного времени, соответствующего текущему моменту, необходимо исполнить функцию TimeCurrent():

Функция TimeCurrent()

datetime TimeCurrent()

Функция возвращает последнее известное время сервера (время прихода последней котировки) в виде количества секунд, прошедших после 00:00 1 января 1970 года. Перед запуском на исполнение специальных функций клиентский терминал обновляет время прихода последней котировки (наряду с другими переменными окружения). Каждый тик характеризуется своим значением серверного времени, которое можно получить с помощью TimeCurrent(). В процессе выполнения программы это значение может быть изменено только в результате вызова функции RefreshRates() и только в том случае, если с момента последнего исполнения RefreshRates() данные были фактически обновлены, т.е с сервера поступили новые значения каких-либо переменных окружения.

Время открытия бара Time[i], как правило, не совпадает со временем поступления тика. Время открытия бара для любого таймфрейма всегда кратно таймфрейму. Любой первый тик, возникший в пределах таймфрейма, является барообразующим; если же в пределах таймфрейма не поступило ни одного тика, то и бар в пределах этого таймфрейма не образуется.

Например, тик, поступивший в терминал в момент (серверного) времени t 0, приводит к образованию бара со временем открытия Time[i+2] (Рис. 143). Момент, отмеченный началом таймфрейма, не совпадает с моментом t 0, а в общем случае может совпадать случайно. Последующие тики, поступающие в терминал в пределах того же таймфрейма (в моменты t 1 и t 2), могут изменить характеристики бара, например, максимальную цену или цену закрытия, но уже не влияют на время открытия бара. Время закрытия бара в информационно-торговой системе MetaTrader не учитывается (формально временем закрытия бара можно считать время поступления последнего тика в пределах таймфрейма, как показано на Рис. 143, или время начала следующего таймфрейма).

Рис. 143. Порядок формирования баров в информационно-торговой системе MetaTrader.

На Рис. 143. показано, что на некоторых временных интервалах, равных таймфрейму, бары могут не образовываться. Так, в промежуток между временем поступления тика t 5 и временем поступления очередного тика t 6 укладывается полный таймфрейм, поэтому в данном временном промежутке новый бар не образовался. Таким образом, время открытия бара может отличаться от времени открытия соседнего бара более, чем на один таймфрейм, но всегда кратно таймфрейму. Для наглядного представления порядка формирования баров можно исполнить эксперт timebars.mq4, который выводит время поступления тика и время открытия бара:

//--------------------------------------------------------------------
// timebars.mq4
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------------
int start()                            // Спец. функция start
  {
   Alert("TimeCurrent=",TimeToStr(TimeCurrent(),TIME_SECONDS),
         " Time[0]=",TimeToStr(Time[0],TIME_SECONDS));
   return;                             // Выход из start()
  }
//--------------------------------------------------------------------

На Рис. 144 представлены результаты работы эксперта timebars.mq4. Очевидно, что первый тик на очередном временном промежутке, длительностью 1 минуту, поступил в 14:29:12, при этом образовался новый бар, время открытия которого 14:29:00. Обратите внимание, в правом столбце окна сообщений отображается серверное время, а в левом столбце - локальное.

Рис. 144. Порядок формирования баров в информационно-торговой системе MetaTrader.

В случае, если тики поступают редко (например, в период между окончанием европейской и началом азиатской сессии), то при исполнении эксперта timebars.mq4 можно наблюдать и другое явление - время открытия соседних баров может отличаться более, чем на 1 минуту (для минутного таймфрейма), при этом индексация баров сохраняется подряд, без пропусков.

Серверное время в разных серверах, установленных в разных дилинговых центрах, может отличаться. Время начала и окончания торгов также устанавливается на каждом сервере персонально и может не совпадать со временем начала или окончания очередного дня. В некоторых дилинговых центрах, например, выполнены такие настройки, при которых открытие торгов происходит в воскресенье, в 23:00 по серверному времени. Это приводит к образованию "неполноценных" дневных баров, фактическая продолжительность которых равна одному часу (Рис. 145).

Рис. 145. Различная баровая история в разных дилинговых центрах.

Использование функций даты и времени в MQL4 достаточно просто. Некоторые из них преобразуют серверное или локальное время, выраженное в количестве секунд, прошедших после 00:00 1 января 1970 года, в целое число, соответствующее часу, дню и пр. Другие функции возвращают целое значение, соответствующее текущему часу, минуте, дню и пр.

Функции TimeSeconds (), TimeMinute(), TimeHour(), TimeDay(), TimeMonth(), TimeYear(), TimeDayOfWeek () и TimeDayOfYear()

Это - группа подобных функций, возвращающих соответственно количество секунд, прошедших с начала минуты, минуту, час, день, месяц, год, день недели и день в году для указанного времени. Например:

int TimeMinute(datetime time)

Функция возвращает минуты для указанного времени.

Параметры:

time - дата, представленная в виде количества секунд, прошедших после 00:00 1 января 1970 года.

int TimeDayOfWeek(datetime time)

Возвращает день недели (0-Воскресенье,1,2,3,4,5,6) для указанной даты.

Параметры:

time - дата, представленная в виде количества секунд, прошедших после 00:00 1 января 1970 года.

Указанные функции можно использовать, например, для анализа времени открытия любого бара. Ниже представлен эксперт bigbars.mq4 для поиска бара не менее заданного размера.

//--------------------------------------------------------------------
// bigbars.mq4
// The program is intended to be used as an example in MQL4 Tutorial.
//--------------------------------------------------------------- 1 --
extern int Quant_Pt=20;                // Number of points
//--------------------------------------------------------------- 2 --
int start()                            // Spec. start function
  {
   int H_L=0;                          // Height of the bar
   for(int i=0; H_L<Quant_Pt; i++)     // Cycle for bars
     {
      H_L=MathAbs(High[i]-Low[i])/Point;//Height of the bar
      if (H_L>=Quant_Pt)               // if the high bar is not found
        {
         int YY=TimeYear(  Time[i]);   // Year
         int MN=TimeMonth( Time[i]);   // Month
         int DD=TimeDay(   Time[i]);   // Day
         int HH=TimeHour(  Time[i]);   // Hour
         int MM=TimeMinute(Time[i]);   // Minute
         Comment("The last price movement more than ",Quant_Pt,//Message
         " pt happened ", DD,".",MN,".",YY," ",HH,":",MM);//output
        }
     }
   return;                             // Exit from start()
  }
//--------------------------------------------------------------- 3 --

Эксперт bigbars.mq4 ищет ближайший бар, высота которого (разница между максимумом и минимумом) больше или равна значению, указанному пользователем во внешней переменной Quant_Pt. Дата и время найденного бара выводятся в окно финансового инструмента с помощью функции Comment().

Функции Seconds (), Minute(), Hour(), Day(), TimeMonth(), TimeYear(), DayOfWeek () и DayOfYear()

Это - группа подобных функций, возвращающих текущую секунду, минуту, час, день, месяц, год, день недели и день в году для последнего известного серверного времени. Последним известным серверным временем считается серверное время, соответствующее моменту старта программы (запуска на исполнение какой-либо специальной функции клиентским терминалом). В процессе исполнения специальной функции значение серверного времени не изменяется.

int Hour()

Возвращает текущий час (0,1,2,..23) последнего известного серверного времени. Замечание: при тестировании последнее известное время сервера моделируется.

int DayOfYear()

Возвращает текущий день года (1-1 января,..,365(6) - 31 декабря), т.е. день года последнего известного серверного времени. Замечание: при тестировании последнее известное время сервера моделируется.

Примером использования указанных функций может служить эксперт timeevents.mq4, выполняющий некоторые действия при наступлении заданного времени.

//--------------------------------------------------------------------
// timeevents.mq4
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------- 1 --
extern double Time_Cls=16.10;          // Время закрытия ордеров
bool Flag_Time=false;                  // Флаг, сообщения ещё не было
//--------------------------------------------------------------- 2 --
int start()                            // Спец. функция start
  {
   int    Cur_Hour=Hour();             // Серверное время в часах
   double Cur_Min =Minute();           // Серверное время в минутах
   double Cur_time=Cur_Hour + Cur_Min100; // Текущее время
   Alert(Cur_time);
   if (Cur_time>=Time_Cls)             // Если наступило время события
      Executor();                      //.. то выполняем задуманное
   return;                             // Выход из start()
  }
//--------------------------------------------------------------- 3 --
int Executor()                         // Пользовательская функция
  {
   if (Flag_Time==false)               // Если ещё не было сообщения..
     {                                 // .. то сообщаем (1 раз)
      Alert("Время важных новостей. Закройте ордера.");
      Flag_Time=true;                  // Теперь сообщение уже было
     }
   return;                             // Выход из польз. функции
  }
//--------------------------------------------------------------- 4 --

При исполнении специальной функции start() (блок 2-3) вычисляется серверное время в часах и минутах. В строке:

   double Cur_time = Cur_Hour + Cur_Min100; // Текущее время

текущее серверное время представлено в виде действительной переменной Cur_time. Действительные переменные удобно использовать в операциях сравнения:

   if (Cur_time >= Time_Cls)           // Если наступило время события

Если текущее время оказывается больше или равным времени, указанному пользователем во внешней переменной Time_Cls, то вызывается для исполнения пользовательская функция Executor(). В данном примере пользовательская функция выводит сообщение с рекомендациями по ведению торгов. В общем случае эта функция может содержать любой код, например, осуществлять торговые операции, отправлять электронные письма, создавать графические объекты и пр.

Функции даты и времени

Функция | Краткое описание
Day | Возвращает текущий день месяца, т.е день месяца последнего известного времени сервера.
DayOfWeek | Возвращает порядковый номер дня недели (воскресенье-0,1,2,3,4,5,6) последнего известного времени сервера.
DayOfYear | Возвращает текущий день года (1-1 января,..,365(6) - 31 декабря), т.е день года последнего известного времени сервера.
Hour | Возвращает текущий час (0,1,2,..23) последнего известного серверного времени на момент старта программы (в процессе выполнения программы это значение не меняется).
Minute | Возвращает текущую минуту (0,1,2,..59) последнего известного серверного времени на момент старта программы (в процессе выполнения программы это значение не меняется).
Month | Возвращает номер текущего месяца (1-Январь,2,3,4,5,6,7,8,9,10,11,12), т.е. номер месяца последнего известного времени сервера.
Seconds | Возвращает количество секунд, прошедших с начала текущей минуты последнего известного серверного времени на момент старта программы (в процессе выполнения программы это значение не меняется).
TimeCurrent | Возвращает последнее известное время сервера (время прихода последней котировки) в виде количества секунд, прошедших после 00:00 1 января 1970 года.
TimeDay | Возвращает день месяца (1 - 31) для указанной даты.
TimeDayOfWeek | Возвращает день недели (0-Воскресенье,1,2,3,4,5,6) для указанной даты.
TimeDayOfYear | Возвращает день (1 - 1 января,..,365(6) - 31 декабря) года для указанной даты.
TimeHour | Возвращает час для указанного времени.
TimeLocal | Возвращает локальное компьютерное время в виде количества секунд, прошедших после 00:00 1 января 1970 года.
TimeMinute | Возвращает минуты для указанного времени.
TimeMonth | Возвращает номер месяца для указанного времени (1-Январь,2,3,4,5,6,7,8,9,10,11,12).
TimeSeconds | Возвращает количество секунд, прошедших с начала минуты для указанного времени.
TimeYear | Возвращает год для указанной даты. Возвращаемая величина может быть в диапазоне 1970-2037.
Year | Возвращает текущий год, т.е. год последнего известного времени сервера.

Для получения подробного описания этих и других функций необходимо обратиться к справочной документации на MQL4.community, сайте MetaQuotes Software Corp. или к разделу "Справка" в редакторе MetaEditor.

Строковые функцииФайловые операции


Файловые операции - Стандартные функции - Учебник по MQL4

Учебник по MQL4 [image] Стандартные функции [image] Файловые операции
MetaQuotes Sofware Corp.
  • Общие функции
  • Графические объекты
  • Операции с графиками
  • Строковые функции
  • Дата и время
  • Файловые операции
  • Массивы и таймсерии
  • Математические функции
  • Глобальные переменные GlobalVariables
  • Пользовательские индикаторы
  • Информация о счёте
  • Торговые функции
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Файловые операции

В MQL4 предусмотрена возможность работы с файлами, содержащими некоторый набор информации. Необходимость записи информации в файл, а также считывания информации из файла может возникнуть по нескольким причинам.

Файл может применяться как средство передачи данных в другую программу. В этом случае файл может быть создан прикладной программой и использоваться ею как приёмник информации. Например, при исполнении прикладной программы в файл может быть записана торговая история по счёту. В дальнейшем этот файл может быть прочитан другой программой, например, Excel, для построения диаграммы изменения баланса.

В других случаях требуется сообщить некоторую информацию прикладной программе, например, расписание важных новостей. Исполняемая прикладная программа (например, эксперт) может считать эту информацию из заранее подготовленного файла и учитывать её в процессе вычислений для графического отображения на экране, сообщений пользователю или при формировании торговых решений.

Имена и каталоги файлов

Название рабочего файла должно быть составлено в соответствии с правилами операционной системы. Название любого файла, используемого в MQL4, состоит из двух частей - имени файла и его расширения, разделённых точкой, например, News.txt. Технически название файла никак не связано с содержащейся в нём информацией, поэтому и имя файла и его расширение могут быть заданы программистом произвольно. Имя файла обычно выбирается таким, чтобы оно отражало суть содержащихся в нём данных.

Большинство программ автоматически запускаются на исполнение в компьютере пользователя в случае, если по названию файла дважды кликнуть мышкой. В зависимости от того, какое расширение имеется у файла, операционная среда подгрузит ту или иную программу, в которой будет отражено содержание файла. Поэтому, выбирая расширение рабочего файла, следует ориентироваться на то, какая программа (в случае необходимости) обычно будет использоваться для просмотра файлов.

Наиболее распространёнными типами файлов (тип определяется расширением) являются следующие:

- .txt - текстовый файл, для просмотра используется блокнот, Word, FrontPage и др. редакторы;

- .csv - файл для построения таблиц в Excel;

- .htm - файл для просмотра в браузере, например, Internet Explorer, Netscape Navigator и др.

Существует три каталога (с подкаталогами), в которых могут располагаться рабочие файлы:

- Каталог_терминала\Experts \History\<текущий брокер>\ - для файлов истории;

- Каталог_терминала\Experts \Files\ - для общего случая;

- Каталог_терминала\Tester\ Files\ - для файлов, используемых при тестировании.

Рабочий файл может быть сохранён в одном из приведенных каталогов или их подкаталогов. В случае, если в момент сохранения файла указанный подкаталог не существует, то он будет создан клиентским терминалом автоматически. Работа с файлами, содержащимися в других каталогах, не предусмотрена.

Режимы работы файлов

Технология взаимодействия прикладной программы с рабочим файлом предусматривает несколько возможных режимов. В общем случае один файл может быть открыт одновременно несколькими программами (в пределах одного компьютера или в нескольких компьютерах, соединённых в сеть). При этом операционная среда обеспечивает лишь для одной из таких программ полный доступ к файлу, а именно, возможность чтения и записи в файл, а для всех остальных программ - доступ только для чтения. Например, если файл My_text. doc уже открыт какой-то программой для чтения и записи, то все другие программы перед открытием файла получат уведомление:

Рис. 146. Диалоговое окно, возникающее при попытке доступа к файлу, открытому другой программой.

Использование указанной технологии гарантирует, что один файл не будет изменяться одновременно двумя различными программами. Для того, чтобы исполняемая прикладная программа могла взаимодействовать с рабочим файлом, его прежде всего необходимо открыть. Режим открытия файла указывается в функции FileOpen().

Одна прикладная программа может открыть несколько рабочих файлов. Для того чтобы в программе была возможность различать файлы между собой, каждому открытому файлу ставится в соответствие файловый описатель.

Файловый описатель – уникальный номер файла, открытого исполняемой программой в текущий момент.

При успешном открытии файла функция FileOpen () возвращает некоторое целое значение (обычно это значение присваивается переменной handle), которое и является файловым описателем. Большинство функций, предназначенных для работы с файлами, предполагают использование значения файлового описателя в качестве одного из формальных параметров.

Функция FileOpen()

 int FileOpen(string filename, int mode, int delimiter=';')

Функция открывает файл для ввода и/или вывода. Функция возвращает файловый описатель открытого файла или -1 в случае неудачи. Файлы могут открываться только в каталоге Каталог_терминала\Experts \Files\ или в каталоге Каталог_терминала\Tester\Files\ (в случае тестирования эксперта) или в их подкаталогах.

Параметры:

filename - название файла;

mode - способ открытия файла; принимает значения (или их комбинацию): FILE_BIN, FILE_CSV, FILE_READ, FILE_WRITE;

delimiter - знак разделителя для csv-файлов. По умолчанию применяется символ ';'.

Режим открытия файла FILE_READ предусматривает, что файл будет использоваться программой только для чтения. Попытка открытия файла в этом режиме заканчивается неудачей, если файла с указанным именем не существует.

Режим открытия файла FILE_WRITE предусматривает, что файл будет использоваться программой только для записи. Попытка открытия файла в этом режиме приводит к открытию файла нулевой длины. Даже если до открытия в файле были данные, то они будут уничтожены. Открытие файла в этом режиме может закончиться неудачей, если файл ранее был открыт другой программой (в режиме записи).

Допускается открытие файла в режиме FILE_READ|FILE_WRITE. Этот режим предусматривает возможность чтения из файла и записи в файл. Режим используется при необходимости дописать данные в файл, уже содержащий какие-то данные. Функция предусматривает обязательное использование одного из режимов FILE_READ или FILE_WRITE или их комбинацию.

Режим открытия FILE_BIN определяет работу с рабочим файлом, как с бинарным. Режим открытия файла FILE_CSV определяет работу с рабочим файлом, как с текстовым. Функция предусматривает обязательное использование одного из режимов FILE_BIN или FILE_CSV. Одновременное использование режимов FILE_BIN и FILE_CSV не допускается.

Функция предусматривает обязательное комбинирование режимов FILE_READ, FILE_WRITE или FILE_READ|FILE_WRITE с режимами FILE_BIN или FILE_CSV. Например, для чтения текстового файла необходимо использовать комбинацию режимов FILE_CSV|FILE_READ, а для того, чтобы добавить запись в бинарный файл, нужно использовать комбинацию FILE_BIN|FILE_READ|FILE_WRITE.

В пределах одного исполняемого модуля (прикладной программы, например, эксперта) одновременно может быть открыто не более 32 файлов. Описатели файлов, открытых в одном модуле, нельзя передавать в другие модули (библиотеки).

Содержание записей в файлах

При любой комбинации режимов записи данных заносятся в файл без промежутков. При формировании файлов в режиме FILE_BIN записи данных заносятся подряд. В зависимости от типа данных, записываемых в файл (и используемых для этого функций записи), между группами записей может прописываться комбинация символов конца строки ("\r\n"). При формировании файлов в режиме FILE_CSV записи данных отделяются файловым разделителем (обычно ';'), а группы записей (составляющих строки) разделяются с помощью комбинации символов конца строки ("\r\n").

Файловый разделитель - специальный символ; запись, которая заносится в файл для разделения записей данных.

Файловый разделитель используется для разделения записей данных только в csv-файлах.

Общий принцип построения записей в любых файлах состоит в том, что записи заносятся в фай в определённой последовательности, без промежутков. Собственно вся запись представляет собой сплошную последовательность символов. Любой файл может быть прочитан какой-либо программой, и (в зависимости от правил, реализованных в этой программе) отображён на экране в том или ином виде. Например, пусть имеется файл File_1.csv со следующим содержанием:

int FileOpen(string filename, int mode, int delimiter=';')

Файл File_1.csv будет по-разному отображён в различных текстовых редакторах:

Рис. 147. Отображение файла File_1 разными программами (File_1.csv).

В данном случае комбинация символов "\r\n" была воспринята каждой из программ (Excel и Блокнот) как указание на порядок форматирования: последовательность данных после комбинации "\r\n" отображается в новой строке, а само сочетание символов "\r\n" в окне редактирования не отображается. В то же время, Excel - табличный редактор, поэтому символ ";" был воспринят этой программой, как разделитель данных на столбцы. Обратите внимание, символ ";" в окне Excel не отображается. Блокнот - текстовый редактор. Правила, реализованные в этой программе, не предполагают деление на столбцы, поэтому символ ";" был воспринят не как файловый разделитель, а как составная часть данных, и поэтому отображён на экране.

Указанные символы (";" и "\r\n") используются для разделения записей в MQL4.

Рис. 148. Разновидности записей в рабочих файлах.

На Рис. 148 представлена структура записей данных в нескольких файлах. В верхней строке показано содержание csv-файла, а в трёх нижних - структуры бинарных файлов. Все эти файлы составлены в соответствии с правилами, соответствующими той или иной функции записи в файл.

Запись в csv-файле - это последовательность строковых значений (типа string), между которыми указываются либо файловый разделитель, либо признак конца строки. И то и другое воспринимается при чтении данных (стандартной функцией MQL4 для чтения файлов) как признак окончания содержательной части считываемого значения. Строковое значение может быть разной длины, и заранее неизвестно, сколько именно символов необходимо прочесть, поэтому считывание выполняется до момента обнаружения программой одного из разделителей.

Записи в двух видах бинарных файлов представляют последовательность данных без каких-либо разделителей. Такой порядок записи определяется фиксированной длиной для данных разного типа: 4 байта для данных типа int, bool, datetime и color и 8 байт (или 4 байта, в зависимости от параметров функции записи) для данных типа double. В этом случае нет необходимости в разделителях, т.к. считывание выполняется с помощью стандартной функции для чтения данных определённого типа фиксированной длины. Последний (нижний на Рис. 148) бинарный файл содержит данные типа string, разделённые признаком конца строки.

Файловый указатель - место в файле, с которого начинается чтение следующего значения.

Понятие "файловый указатель" является аналогом понятия "курсор". Файловый указатель характеризуется позицией в файле. По мере прочтения данных файловый указатель смещается вправо на одну или несколько позиций.

Задача 36. Прочесть из текстового файла данные о важных новостях и отобразить на ценовом графике графические объекты (вертикальные линии) в соответствии со временем публикации новостей.

Пусть в каталоге Каталог_терминала\Experts \Files\ имеется рабочий файл News.csv со следующей записью:

Рис. 149. Содержание рабочего файла News.csv.

В данном случае в файле содержится информация о пяти событиях, которые должны произойти в разных странах в разное время. Каждая строка содержит две записи. Первая запись - строковое значение, несущее информацию о дате и времени события. Вторая запись - текстовое описание события. Первые три символа во второй записи содержат название валюты (страны), которой касается будущее событие.

Решение задачи состоит из двух частей. Сначала необходимо прочесть данные из рабочего файла, а затем полученные значения использовать в качестве координат графических объектов. Чтение данных из текстового файла осуществляется с помощью функции FileReadString().

Функция FileReadString()

 string FileReadString(int handle, int length=0)

Функция читает строку с текущей позиции файла. Применяется как к CSV, так и к двоичным файлам. Для текстовых файлов строка будет прочитана до разделителя. Для бинарных файлов в строке будет прочитано указанное количество символов. Чтобы получить информацию об ошибке, необходимо вызвать функцию GetLastError().

Параметры:

handle - файловый описатель, возвращаемый функцией FileOpen();

length - количество символов для чтения.

Необходимость обработки данных о новостях обычно возникает один раз в начале торгов, поэтому в данном случае, для решения Задачи 36, можно использовать скрипт. Скрипт timetablenews.mq4 предназначен для считывания данных из файла и отображения графических объектов в окне финансового инструмента.

//--------------------------------------------------------------------
// timetablenews.mq4
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------- 1 --
int start()                            // Спец. функция start
  {
//--------------------------------------------------------------- 2 --
   int Handle,                         // Файловый описатель
       Stl;                            // Стиль вертикальной линии
   string File_Name="News.csv",        // Имя файла
          Obj_Name,                    // Имя объекта
          Instr,                       // Название валюты
          One,Two,                     // 1я и 2я чать названия инстр.
          Text,                        // Текст описания события
          Str_DtTm;                    // Дата и время события(строка)
   datetime Dat_DtTm;                  // Дата и время события(дата)
   color Col;                          // Цвет вертикальной линии
//--------------------------------------------------------------- 3 --
   Handle=FileOpen(File_Name,FILE_CSV|FILE_READ,";");// Открытие файла
   if(Handle<0)                        // Неудача при открытии файла
     {
      if(GetLastError()==4103)         // Если файла не существует,..
         Alert("Нет файла с именем ",File_Name);//.. извещаем трейдера
      else                             // При любой другой ошибке..
         Alert("Ошибка при открытии файла ",File_Name);//..такое сообщ
      PlaySound("Bzrrr.wav");          // Звуковое сопровождение
      return;                          // Выход из start()
     }
//--------------------------------------------------------------- 4 --
   while(FileIsEnding(Handle)==false)  // До тех пор, пока файловый ..
     {                                 // ..указатель не в конце файла
      //--------------------------------------------------------- 5 --
      Str_DtTm =FileReadString(Handle);// Дата и время события(дата)
      Text     =FileReadString(Handle);// Текст описания события
      if(FileIsEnding(Handle)==true)   // Файловый указатель в конце
         break;                        // Выход из чтения и рисования
      //--------------------------------------------------------- 6 --
      Dat_DtTm =StrToTime(Str_DtTm);   // Преобразование типа данных
      Instr    =StringSubstr(Text,0,3);// Извлекаем первые 3 символа
      One=StringSubstr(Symbol(),0,3);// Извлекаем первые 3 символа
      Two=StringSubstr(Symbol(),3,3);// Извлекаем вторые 3 символа
      Stl=STYLE_DOT;                   // Для всех - стиль пунктир
      Col=DarkOrange;                  // Для всех - цвет такой
      if(Instr==One || Instr==Two)     // А для событий по нашему ..
        {                              // .. финансовому инструменту..
         Stl=STYLE_SOLID;              // .. такой стиль..
         Col=Red;                      // .. и такой цвет верт. линии
        }
      //--------------------------------------------------------- 7 --
      Obj_Name="News_Line  "+Str_DtTm;              // Имя объекта
      ObjectCreate(Obj_Name,OBJ_VLINE,0,Dat_DtTm,0);//Создаем объект..
      ObjectSet(Obj_Name,OBJPROP_COLOR, Col);       // ..и его цвет,..
      ObjectSet(Obj_Name,OBJPROP_STYLE, Stl);       // ..стиль..
      ObjectSetText(Obj_Name,Text,10);              // ..и описание
     }
//--------------------------------------------------------------- 8 --
   FileClose( Handle );                // Закрываем файл
   PlaySound("bulk.wav");              // Звуковое сопровождение
   WindowRedraw();                     // Перерисовываем объекты
   return;                             // Выход из start()
  }
//--------------------------------------------------------------- 9 --

В блоке 2-3 эксперта открыты и описаны используемые переменные. В блоке 3-4 осуществляется попытка открытия файла и производится анализ результатов этой операции. Для открытия файла используется функция FileOpen():

   Handle=FileOpen(File_Name,FILE_CSV|FILE_READ,";");// Открытие файла

Попытка открытия файла не всегда заканчивается успехом. Неудача может быть в том случае, если файла с указанным именем не существует. При неудачной попытке открыть файл (файловый описатель - отрицательное число) выводится необходимое сообщение пользователю и исполнение функции start() заканчивается.

В случае успешного открытия файла управление передаётся оператору цикла while (блоки 4-8). На каждой итерации этого цикла выполняется чтение данных из файла (блок 5-6), преобразование и анализ этих данных (блок 6-7) и создание графического объекта с координатами и свойствами, соответствующими последним прочитанным данным (блок 7-8).

Выполнение цикла while происходит до тех пор, пока файловый указатель не переместится в конец файла, т.е. когда справа от файлового указателя уже не останется каких-либо данных. Для анализа положения файлового указателя используется функция FileIsEnding().

Функция FileIsEnding()

bool FileIsEnding(int handle)

Функция возвращает TRUE, если файловый указатель находится в конце файла, иначе возвращает FALSE. Чтобы получить информацию об ошибке, необходимо вызвать функцию GetLastError(). В случае достижения конца файла в процессе чтения функция GetLastError() вернет ошибку ERR_END_OF_FILE (4099).

Параметры:

handle - файловый описатель, возвращаемый функцией FileOpen().

Представленное решение (timetablenews.mq4) предусматривает, что в рабочем файле News.csv может быть записано неопределённое количество новостей. В приведенном примере (Рис. 149) файл News.csv содержит пять строк, соответствующих пяти событиям (новостям). В общем случае количество строк может составлять от 0 до 20-30 в зависимости от количества реальных событий, которые должны произойти в этот день.

Чтение записей из файла (идентифицируемого по значению переменной Handle) осуществляется в блоке 5-6:

      Str_DtTm =FileReadString(Handle);// Дата и время события(дата)
      Text     =FileReadString(Handle);// Текст описания события
      if(FileIsEnding(Handle)==true)   // Файловый указатель в конце
         break;                        // Выход из чтения и рисования

В первой и второй строках блока 5-6 производится чтение данных из файла до ближайшего разделителя. В третьей и четвёртой строках выполняется проверка: не находится ли файловый указатель в конце файла. Если нет, то далее в цикле на основе двух прочитанных значений создаются графические объекты. Если бы изначально было точно известно количество записей, то анализ, выполняемый в третьей и четвёртой строках был бы не нужен. В этом случае можно было бы жёстко задать количество итераций в цикле (например, 5) и не выполнять лишнюю проверку.

Однако, в данном случае общее количество записей неизвестно. Вместе с тем, в данном примере каждое событие описывается двумя значениями, составляющими одну строку вида: значение, файловый разделитель, значение, признак окончания строки. В данном случае полагается, что если есть одна запись (первое значение в строке), то есть и другая запись; но если нет первой записи, то нет и второй, а значит нет и события, поэтому создавать графический объект не нужно. Если обеих записей или какой-либо одной из них не существует, то при попытке чтения записи файловый указатель переместится в конец файла, т.е. такое место, где справа от указателя нет никаких данных. Проверка в строках 3 и 4 позволяет выявить этот факт. Если указанную проверку (две последние строки в блоке 5-6) удалить, то в процессе исполнения программы будет создан лишний графический объект. И лишь после этого сработает условие окончания цикла while и управление будет передано в блок 8-9. В общем случае при составлении алгоритмов чтения файлов необходимо учитывать логику представления данных в файле, порядок следования записей и разделителей, количество строк и пр. Для каждого конкретного случая должен быть определён конкретный алгоритм.

Данные, прочитанные из файла, имеют строковый тип. Для того, чтобы воспользоваться полученными значениями для создания графических объектов, необходимо преобразовать данные в нужный тип. В блоке 6-7 первое (прочитанное в очередной строке) значение преобразуется в значение типа datetime и в дальнейшем используется в качестве координаты графического объекта, поставленного в соответствие событию. Первые три символа из второго прочитанного строкового значения сравниваются с первой и второй тройкой символов в названии финансового инструмента. Если есть совпадение, то графический объект получает соответствующие свойства: стиль линии - сплошная и цвет - красный (блок 7-8). В других случаях объекты отображаются оранжевым пунктиром. В результате исполнения скрипта в окне финансового инструмента можно наблюдать линии новостей:

Рис. 150. Графические объекты в окне финансового инструмента после исполнения timetablenews.mq4.

Таким образом, скрипт может быть исполнен в окне любого валютного инструмента, при этом в каждом окне сплошная красная вертикальная линия будет отражать события, касающиеся этого инструмента, а пунктирные линии - события по другим инструментам. Для отображения текстового описания объекта необходимо включить галочку опции "Показывать описания объектов" в окне Свойства финансового инструмента (F8) > Общие.

В блоке 8-9, после того, как задача решена, а именно все необходимые объекты созданы, ранее открытый файл закрывается. Файл необходимо закрывать для того, чтобы, во-первых, не расходовать лишние ресурсы компьютера, а во-вторых, для того, чтобы обеспечить другим программам доступ к файлу в режиме записи. Нормальной следует считать практику закрытия файла сразу после того, как все данные из него прочитаны (или записаны в файл) и в использовании файла больше нет необходимости. Закрытие файла выполняется с помощью функции FileClose().

Функция FileClose()

 void FileClose(int handle)

Функция выполняет закрытие файла, ранее открытого функцией FileOpen().

Параметры:

handle - файловый описатель, возвращаемый функцией FileOpen().

Для того, чтобы у трейдера была возможность практически использовать скрипт timetablenews. mq4, в его распоряжении должен быть способ создания файла, содержащего расписание новостей на некоторый период. Такой файл может быть создан с помощью любого текстового редактора, однако в этом случае остаётся возможность ошибки (иногда можно ошибочно не указать разделитель). Рассмотрим вариант создания рабочего файла средствами MQL4.

Задача 37. Представить код эксперта для создания файла расписания новостей.

В общем случае эксперт может быть предназначен для создания файла, содержащего любое количество новостей. Рассматриваемый здесь эксперт createfile.mq4 создаёт рабочий файл, содержащий сведения не более, чем о пяти событиях.

//--------------------------------------------------------------------
// createfile.mq4
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------- 1 --
extern string Date_1="";   // 2007.05.11 10:30
extern string Text_1="";   // CHF Разрешения на строительство
extern string Date_2="";   // 2007.05.11 12:00
extern string Text_2="";   // GBP Ставка рефинансирования,2%,2.5%
extern string Date_3="";   // 2007.05.11 13:15
extern string Text_3="";   // EUR Встреча управляющих банков G10
extern string Date_4="";   // 2007.05.11 15:30
extern string Text_4="";   // USD Количество безработных в США
extern string Date_5="";   // 2007.05.11 18:30
extern string Text_5="";   // JPY Промышленное производство
//--------------------------------------------------------------- 2 --
int start()                            // Спец. функция start
  {
//--------------------------------------------------------------- 3 --
   int Handle,                         // Файловый описатель
   Qnt_Symb;                           // Количество записанных симв.
   string File_Name="News.csv";        // Имя файла
   string Erray[5,2];                  // Массив на 5 новостей
//--------------------------------------------------------------- 4 --
   Erray[0,0]=Date_1;                  // Заполняем массив значениями
   Erray[0,1]=Text_1;
   Erray[1,0]=Date_2;
   Erray[1,1]=Text_2;
   Erray[2,0]=Date_3;
   Erray[2,1]=Text_3;
   Erray[3,0]=Date_4;
   Erray[3,1]=Text_4;
   Erray[4,0]=Date_5;
   Erray[4,1]=Text_5;
//--------------------------------------------------------------- 5 --
   Handle=FileOpen(File_Name,FILE_CSV|FILE_WRITE,";");//Открытие файла
   if(Handle==-1)                      // Неудача при открытии файла
     {
      Alert("Ошибка при открытии файла. ",// Сообщение об ошибке
              "Возможно, файл занят другим приложением");
      PlaySound("Bzrrr.wav");          // Звуковое сопровождение
      return;                          // Выход из start()
     }
//--------------------------------------------------------------- 6 --
   for(int i=0; i<=4; i++)             // Цикл по всему массиву
     {
      if(StringLen(Erray[i,0])== 0  || // Если значение первой или ..
         StringLen(Erray[i,1])== 0)    // ..второй перемен. не введено
         break;                        // .. то выход из цикла
      Qnt_Symb=FileWrite(Handle,Erray[i,0],Erray[i,1]);//Запись в файл
      if(Qnt_Symb < 0)                 // Если не получилось
        {
         Alert("Ошибка записи в файл ",GetLastError());// Сообщение
         PlaySound("Bzrrr.wav");       // Звуковое сопровождение
         FileClose( Handle );          // Закрываем файл
         return;                       // Выход из start()
        }
     }
//--------------------------------------------------------------- 7 --
   FileClose( Handle );                // Закрываем файл
   Alert("Файл ",File_Name," создан.");// Сообщение
   PlaySound("Bulk.wav");              // Звуковое сопровождение
   return;                             // Выход из start()
  }
//--------------------------------------------------------------- 8 --

Исходные данные вводятся в программу с помощью внешних переменных типа string (блок 1-2). В блоке 3-4 открыты и описаны переменные. Для удобства обработки в программе введенные данные записываются (блок 4-5) в строковый массив Erray[][]. Каждое событие (сведения, характеризующие новость) представлено в двух элементах массива по второму измерению. Размер первого измерения (количество строк в массиве) определяется количеством новостей, в данном случае 5. Для того, чтобы при опробовании эксперта на демо-счёте не вводить вручную все значения, можно загрузить файл настроек эксперта example_news.set; файл настроек эксперта должен находиться в каталоге Каталог_терминала\presets \.

В блоке 5-6 выполняется открытие файла. Если операция закончилась неудачей, то после сообщения пользователю функция start() заканчивает работу. Если файл открыт удачно, то управление передаётся оператору цикла for, в блок 6-7. Количество итераций в цикле ограничивается количеством новостей, а именно, числом 5. В общем случае количество вводимых значений, размер массива Erray и количество итераций можно увеличить до желаемого.

На каждой итерации цикла выполняется проверка: не является ли какое либо из введенных значений пустым. Для этого вычисляется длина строковых значений элементов массива Erray. Если какое-то из них имеет нулевую длину, то это расценивается как отсутствие текущего и следующих сообщений, поэтому текущая итерация прерывается. До тех пор, пока не нашлось пустое значение элемента массива, выполняется запись значений двух элементов массива в файл. Для записей значений в csv-файл используется функция FileWrite():

Функция FileWrite()

 int FileWrite(int handle, ...)

Функция предназначена для записи данных в файл CSV, разделитель между данными включается автоматически. После записи в файл добавляется признак конца строки "\r\n". При выводе числовые данные преобразуются в текстовый формат (см. функцию Print()). Функция возвращает количество записанных символов или отрицательное значение, если происходит ошибка.

Параметры:

handle - файловый описатель, возвращаемый функцией FileOpen();

... - данные, разделенные запятыми. Может быть не больше 63 параметров.

Данные типов double, int автоматически преобразовываются в строку (данные типов color, datetime и bool воспринимаются как целые числа тип int, и тоже преобразовываются в строку), данные типа string выводятся как есть, без преобразования. В качестве параметра нельзя передать массивы; массивы должны выводиться поэлементно.

В рассматриваемом примере данные записываются в файл в строке:

      Qnt_Symb=FileWrite(Handle,Erray[i,0],Erray[i,1]);//Запись в файл

При записи в файл после значения Erray[i,0] будет записан разделитель (символ, используемый как разделитель, указывается в функции открытия файла FileOpen(), в данном случае ';'). После окончания исполнения функции FileWrite(), т.е. в конце записи, будет автоматически записан признак конца строки "\r\n". На всех последующих итерациях цикла for будет сделана очередная запись такого же вида. Каждая новая запись начинается с того места, где остался файловый указатель после последней записи. При этом в файл будут записаны значения следующих элементов массива Erray (индексы элементов на каждой итерации увеличиваются на 1).

Если текущая запись в файл выполнена успешно, то управление передаётся на следующую итерацию. Если же запись в файл закончилась неудачей, то после сообщения пользователю файл закрывается с помощью функции FileClose() и функция start() заканчивает работу. Если все записи в файл выполнены успешно, то после окончания исполнения цикла for управление передаётся функции закрытия файла FileClose() в блок 7-8. В этом случае выводится сообщение об успешном создании файла, после чего исполнение функции start() заканчивается. По окончании исполнения эксперта будет создан файл News.csv, представленный на Рис. 149.

Функции, применяемые для осуществления файловых операций

Функция | Краткое описание
FileClose | Закрытие файла, ранее открытого функцией FileOpen().
FileDelete | Удаление указанного файла. Файлы могут быть удалены только в том случае, если они расположены в папке каталог_терминала\experts\files (каталог_терминала\tester\files в случае тестирования эксперта) или ее подпапках.
FileFlush | Сброс на диск всех данных, оставшихся в файловом буфере ввода-вывода.
FileIsEnding | Возвращает TRUE, если файловый указатель находится в конце файла, иначе возвращает FALSE. В случае достижения конца файла в процессе чтения функция GetLastError() вернет ошибку ERR_END_OF_FILE (4099)
FileIsLineEnding | Возвращает TRUE, если файловый указатель находится в конце строки файла формата CSV, иначе возвращает FALSE.
FileOpen | Открывает Файл для ввода и/или вывода. Возвращает файловый описатель открытого файла или -1 в случае неудачи.
FileOpenHistory | Открывает файл в текущей папке истории (каталог_терминала\history\server_name) или ее подпапках. Возвращает описатель файла или -1 в случае неудачи.
FileReadArray | Функция читает указанное число элементов из двоичного файла в массив. Перед чтением данных массив должен быть достаточного размера. Функция возвращает количество фактически прочитанных элементов.
FileReadDouble | Функция читает число двойной точности с плавающей точкой (double) из текущей позиции бинарного файла. Размер числа может быть 8 байтов (double) или 4 байта (float).
FileReadInteger | Функция читает целое число из текущей позиции бинарного файла. Размер целого числа может быть 1, 2 или 4 байта. Если размер числа не указан, система пытается прочитать как 4-байтовое целое число.
FileReadNumber | Чтение числа с текущей позиции файла CSV до разделителя. Применяется только для файлов CSV.
FileReadString | Функция читает строку с текущей позиции файла. Применяется как к CSV, так и к двоичным файлам. Для текстовых файлов строка будет прочитана до разделителя. Для бинарных файлов в строку будет прочитано указанное количество символов.
FileSeek | Функция перемещает файловый указатель на новую позицию, которая является смещением в байтах от начала, конца или текущей позиции файла. Следующее чтение или запись происходят с новой позиции. Если перемещение файлового указателя прошло успешно, функция возвращает TRUE, иначе возвращает FALSE.
FileSize | Функция возвращает размер файла в байтах.
FileTell | Функция возвращает смещение текущей позицию файлового указателя от начала файла.
FileWrite | Функция предназначена для записи данных в файл CSV, разделитель между данными включается автоматически. После записи в файл добавляется признак конца строки "\r\n". При выводе числовые данные преобразуются в текстовый формат. Возвращает количество записанных символов или отрицательное значение, если происходит ошибка.
FileWriteArray | Функция записывает массив в бинарный файл.
FileWriteDouble | Функция записывает число с плавающей запятой в двоичный файл.
FileWriteInteger | Функция записывает значение целого числа в двоичный файл.
FileWriteString | Функция записывает строку в двоичный файл с текущей позиции. Возвращает число фактически записанных байтов или отрицательное значение в случае ошибки.

Для получения подробного описания этих и других функций необходимо обратиться к справочной документации на MQL4.community, сайте MetaQuotes Software Corp. или к разделу "Справка" в редакторе MetaEditor.

Дата и времяМассивы и таймсерии


Глобальные переменные GlobalVariables - Стандартные функции - Учебник по MQL4

Учебник по MQL4 [image] Стандартные функции [image] Глобальные переменные GlobalVariables
MetaQuotes Sofware Corp.
  • Общие функции
  • Графические объекты
  • Операции с графиками
  • Строковые функции
  • Дата и время
  • Файловые операции
  • Массивы и таймсерии
  • Математические функции
  • Глобальные переменные GlobalVariables
  • Пользовательские индикаторы
  • Информация о счёте
  • Торговые функции
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Глобальные переменные GlobalVariables

Значительная часть функций, предназначенных для работы с глобальными переменными клиентского терминала, рассмотрена в разделе Переменные GlobalVariables. В предыдущем изложении указывалось, что при завершении работы правильно составленная программа должна удалить глобальные переменные, которые были ею созданы. После завершения всех программ в клиентском терминале не должно оставаться GV-переменных.

При отладке, использующих глобальные переменные клиентского терминала, в терминале могут оставаться одна или несколько GV-переменных. В этом случае, перед очередным запуском на исполнение отлаживаемой программы программисту приходится вручную удалять GV-переменные, оставшиеся после предыдущего исполнения программы. Для механизации этого процесса можно создать скрипт, удаляющий все глобальные переменные клиентского терминала.

Функция GlobalVariablesDeleteAll()

 int GlobalVariablesDeleteAll(string prefix_name=NULL)

Удаляет глобальные переменные. Если префикс для имени не задан, то удаляются все глобальные переменные. В противном случае удаляются только те переменные, имена которых начинаются на указанный префикс. Функция возвращает количество удаленных переменных.

Параметры:

prefix_name - префикс имени удаляемых глобальных переменных.

Пример простого скрипта deleteall.mq4, удаляющего все без исключения глобальные переменные клиентского терминала.

//--------------------------------------------------------------------
// deleteall.mq4
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------------
int start()                             // Специальная функция start()
  {
   GlobalVariablesDeleteAll();          // Удаление всех GV-переменных
   PlaySound("W2.wav");                 // Брыньк
   return;                              // И уходим
  }
//--------------------------------------------------------------------

Скрипт можно применять только в том случае, если в клиентском терминале нет ни одной исполняющейся программы, использующей GV-переменные. В противном случае исполнение скрипта может нарушить логику вычислений в других программах, что может привести к неконтролируемым действиям. После исполнения скрипта окно глобальных переменных клиентского терминала (F3) будет пустым:

Рис. 153. Вид окна глобальных переменных клиентского терминала после исполнения скрипта deleteall.mq4.

Функции для работы с глобальными переменными

Функция | Краткое описание
GlobalVariableCheck | Возвращает значение TRUE, если GV-переменная существует, иначе возвращает FALSE
GlobalVariableDel | Удаляет глобальную переменную. При успешном удалении функция возвращает TRUE, иначе FALSE.
GlobalVariableGet | Возвращает значение существующей глобальной переменной или 0 в случае ошибки.
GlobalVariableName | Функция возвращает имя глобальной переменной по порядковому номеру в списке глобальных переменных.
GlobalVariableSet | Устанавливает новое значение глобальной переменной. Если переменная не существует, то система создает новую глобальную переменную. При успешном выполнении функция возвращает время последнего доступа, иначе 0.
GlobalVariableSetOnCondition | Устанавливает новое значение существующей глобальной переменной, если текущее значение переменной равно значению третьего параметра check_value. Если переменной не существует, функция сгенерирует ошибку ERR_GLOBAL_VARIABLE_NOT_FOUND (4058) и вернет FALSE. При успешном выполнении функция возвращает TRUE, иначе FALSE.
GlobalVariablesDeleteAll | Удаляет глобальные переменные. Если префикс для имени не задан, то удаляются все глобальные переменные. В противном случае удаляются только те переменные, имена которых начинаются на указанный префикс. Функция возвращает количество удаленных переменных.
GlobalVariablesTotal | Функция возвращает общее количество глобальных переменных.

Для получения подробного описания этих и других функций необходимо обратиться к справочной документации на MQL4.community, сайте MetaQuotes Software Corp. или к разделу "Справка" в редакторе MetaEditor.

Математические функцииПользовательские индикаторы


Пользовательские индикаторы - Стандартные функции - Учебник по MQL4

Учебник по MQL4 [image] Стандартные функции [image] Пользовательские индикаторы
MetaQuotes Sofware Corp.
  • Общие функции
  • Графические объекты
  • Операции с графиками
  • Строковые функции
  • Дата и время
  • Файловые операции
  • Массивы и таймсерии
  • Математические функции
  • Глобальные переменные GlobalVariables
  • Пользовательские индикаторы
  • Информация о счёте
  • Торговые функции
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Пользовательские индикаторы

Функции пользовательских индикаторов позволяют выполнить необходимые настройки, чтобы представить индикатор в удобном оформлении. Рассмотрим некоторые из них (см. также Создание пользовательских индикаторов).

Функция SetIndexBuffer()

 bool SetIndexBuffer(int index, double array[])

Функция связывает переменную-массив, объявленный на глобальном уровне, с предопределенным буфером пользовательского индикатора. Количество буферов, необходимых для расчета индикатора, задается с помощью функции IndicatorBuffers() и не может быть больше 8. В случае успешного связывания возвращается TRUE, иначе FALSE. Чтобы получить расширенные сведения об ошибке, следует вызвать функцию GetLastError().

Параметры:

index - порядковый номер линии (допускаются значения от 0 до 7);

array[] - имя массива, связанного с расчетным буфером.

Функция SetIndexStyle()

 void SetIndexStyle(int index, int type, int style=EMPTY, int width=EMPTY, color clr=CLR_NONE)

Функция устанавливает новый тип, стиль, ширину и цвет для указанной линии индикатора.

Параметры:

index - порядковый номер линии (допускаются значения от 0 до 7);

type - стиль отрисовки линии индикатора. Может быть одним из перечисленных стилей отрисовки линии (см. Стили отображения индикаторных линий);

style - стиль линии. Используется для линий толщиной в 1 пиксель. Может быть одним из стилей линии, указанных в приложении Стили отображения индикаторных линий. Пустое значение (EMPTY) указывает, что стиль не будет изменен;

width - ширина линии; допустимые значения - 1,2,3,4,5; пустое значение (EMPTY) указывает, что ширина не будет изменена;

clr - цвет линии. Пустое значение CLR_NONE указывает, что цвет не будет изменен.

Функция SetIndexLabel()

void SetIndexLabel(int index, string text)

Функция позволяет устанавливать имя линии индикатора для отображения информации в окне DataWindow и всплывающей подсказке.

Параметры:

index - порядковый номер линии (допускаются значения от 0 до 7);

text - Текст описания линии индикатора. NULL означает, что значение этой линии не показывается в DataWindow.

Пример простого индикатора, отображающего линию High (indicatorstyle.mq4), использующий указанные выше функции:

//--------------------------------------------------------------------
// indicatorstyle.mq4
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------- 1 --
#property indicator_chart_window    // Индик. рисуется в основном окне
#property indicator_buffers 1       // Количество буферов
#property indicator_color1 Blue     // Цвет первой линии

double Buf_0[];                     // Открытие индикаторного массива
//--------------------------------------------------------------- 2 --
int init()                          // Специальная функция init()
  {
   SetIndexBuffer(0,Buf_0);         // Назначение массива буферу
   SetIndexStyle (0,DRAW_LINE,STYLE_SOLID,2);// Стиль линии
   SetIndexLabel (0,"Линия High");
   return;                          // Выход из спец. ф-ии init()
  }
//--------------------------------------------------------------- 3 --
int start()                         // Специальная функция start()
  {
   int i,                           // Индекс бара
   Counted_bars;                    // Количество просчитанных баров
   Counted_bars=IndicatorCounted(); // Количество просчитанных баров
   i=Bars-Counted_bars-1;           // Индекс первого непосчитанного
   while(i>=0)                      // Цикл по непосчитанным барам
     {
      Buf_0[i]=High[i];             // Значение 0 буфера на i-ом баре
      i--;                          // Расчёт индекса следующего бара
     }
   return;                          // Выход из спец. ф-ии start()
  }
//--------------------------------------------------------------- 4 --

В блоке 1-2 индикатора выполнены общие настройки. С помощью директивы #property указано, что индикатор должен отображаться в основном окне, индикатор использует один буфер, цвет индикаторной линии - синий. В блоке 1-2 также открыт один буферный массив.

В блоке 2-3 используются указанные выше функции. В строке:

   SetIndexBuffer(0,Buf_0);         // Назначение массива буферу

буферу с индексом 0 ставится в соответствие массив с именем Buf_0. В строке:

   SetIndexStyle (0,DRAW_LINE,STYLE_SOLID,2);// Стиль линии

определяется стиль индикаторной линии, имеющей индекс 0. Константа DRAW_LINE означает, что отображаемая линия - простая, указание константы STYLE_SOLID означает, что линия сплошная, а 2 определяет толщину линии. В строке:

   SetIndexLabel (0,"Линия High");

индикаторной линии с индексом 0 присваивается имя. Указанное имя можно видеть в окне данных и во всплывающей подсказке в окне финансового инструмента (см. Рис. 810_3). Именование линий удобно использовать в случаях, когда в окне одновременно отражено несколько индикаторных линий; иногда это единственный способ отличить одну линию от другой. В блоке 3-4 выполняется простой расчёт значений элементов индикаторного массива для линии, отображающей максимальные значения баров (порядок расчёта индикаторных массивов подробно рассмотрен в разделе Программирование пользовательских индикаторов.).

Если индикатор отображается в отдельном подокне, то в этом окне можно отобразить горизонтальные уровни.

Функция SetLevelValue()

 void SetLevelValue(int level, double value)

Устанавливает значение для указанного горизонтального уровня индикатора, выводимого в отдельное окно.

Параметры:

level - номер уровня (0-31).

value - значение для указанного уровня.

Использование горизонтальных уровней бывает очень удобно в тех случаях, когда необходимо зрительно определить находится ли индикаторная линия выше или ниже некоторых заданных значений. Представленный ниже простой индикатор рассчитывает разницу между максимальной и минимальной ценами бара. События на рынке представляют интерес для пользователя (условно, в данном примере), если индикаторная линия находится выше уровня 0.001 или ниже уровня -0.001. Пример индикатора, отображающего разницу High и Low (linelevel.mq4).

//--------------------------------------------------------------------
// linelevel.mq4
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------- 1 --
#property indicator_separate_window // Индик. рисуется в отдельн. окне
#property indicator_buffers 1       // Количество буферов
#property indicator_color1 Red      // Цвет линии

double Buf_0[];                     // Открытие индикаторного массива
//--------------------------------------------------------------- 2 --
int init()                          // Специальная функция init()
  {
   SetIndexBuffer(0,Buf_0);         // Назначение массива буферу
   SetIndexStyle (0,DRAW_LINE,STYLE_SOLID,2);// Стиль линии
   SetIndexLabel (0,"Разница High и Low");
   SetLevelValue (0, 0.0010);       // Задан уровень горизонт. линии
   SetLevelValue (1,-0.0010);       // Задан ещё один уровень
   return;                          // Выход из спец. ф-ии init()
  }
//--------------------------------------------------------------- 3 --
int start()                         // Специальная функция start()
  {
   int i,                           // Индекс бара
       Counted_bars;                // Количество просчитанных баров

   Counted_bars=IndicatorCounted(); // Количество просчитанных баров
   i=Bars-Counted_bars-1;           // Индекс первого непосчитанного

   while(i>=0)                      // Цикл по непосчитанным барам
     {
      Buf_0[i]=High[i]-Low[i];      // Значение 0 буфера на i-ом баре
      if(Open[i]>Close[i])          // Если свеча чёрная..
         Buf_0[i]=-Buf_0[i];        // .. то реверс значения
      i--;                          // Расчёт индекса следующего бара
     }
   return;                          // Выход из спец. ф-ии start()
  }
//--------------------------------------------------------------- 4 --

Рассматриваемая функция используется в индикаторе в блоке 2-3. В данном случае задано два горизонтальных уровня. Первое значение в списке параметров - номер горизонтального уровня, а второе - заданное значение уровня:

   SetLevelValue (0, 0.0010);       // Задан уровень горизонт. линии
   SetLevelValue (1,-0.0010);       // Задан ещё один уровень

Параметры настроенных таким образом индикаторов indicatorstyle.mq4 и linelevel.mq4 отражаются в окне финансового инструмента и в окне данных.

Рис. 154. Отображение настроек индикаторов в различных окнах клиентского терминала.

На Рис. 154 представлено два окна - окно данных и окно финансового инструмента. В окне данных можно наблюдать строку, содержащую текст "Линия High" и значение 1.3641. Такие же надписи отображаются в нижней строке всплывающей подсказки. В окне данных указанная строка присутствует в течение всего времени исполнения индикатора, название линии при этом не изменяется, а значение в правой части строки зависит от места положения курсора в окне финансового инструмента. Название линии, отображаемое во всплывающей подсказке, соответствует той индикаторной линии, к которой подведен курсор.

В подокне индикатора linelevel.mq4 отображены горизонтальные линии, установленные в соответствии со значениями, заданными пользователем. Если подвести стрелку курсора к красной индикаторной линии, то во всплывающей подсказке можно видеть название этой линии, в данном случае "Разница High и Low", и чуть правее - значение линии в точке курсора.

Функции для настройки пользовательских индикаторов

Функция | Краткое описание
IndicatorBuffers | Распределяет память для буферов, используемых для вычислений пользовательского индикатора. Количество буферов не может превышать 8 и быть менее значения, указанного в директиве #property indicator_buffers. Если пользовательский индикатор требует дополнительных буферов для счета, следует использовать эту функцию для указания общего числа буферов.
IndicatorCounted | Функция возвращает количество баров, не измененных после последнего вызова индикатора. Большинство подсчитанных баров не нуждается в пересчете.
IndicatorDigits | Установка формата точности (количество знаков после десятичной точки) для визуализации значений индикатора.
IndicatorShortName | Установка "короткого" имени пользовательского индикатора для отображения в подокне индикатора и в окне DataWindow.
SetIndexArrow | Назначение значка для линии индикаторов, имеющей стиль DRAW_ARROW.
SetIndexBuffer | Связывает переменную-массив, объявленный на глобальном уровне, с предопределенным буфером пользовательского индикатора.
SetIndexDrawBegin | Установка порядкового номера бара от начала данных, с которого должна начинаться отрисовка указанной линии индикатора.
SetIndexEmptyValue | Устанавливает значение пустой величины для линии индикатора. Пустые значения не рисуются и не показываются в DataWindow.
SetIndexLabel | Установка имени линии индикатора для отображения информации в окне DataWindow и всплывающей подсказке.
SetIndexShift | Установка смещения линии индикатора относительно начала графика. При положительном значении изображение линии смещается вправо, при отрицательном - влево. Т.е. значение, рассчитанное на текущем баре, рисуется с указанным смещением относительно текущего бара.
SetIndexStyle | Устанавливает новый тип, стиль, ширину и цвет для указанной линии индикатора (см. Стили отображения индикаторных линий).
SetLevelStyle | Устанавливает новый стиль, ширину и цвет для горизонтальных уровней индикатора, выводимого в отдельное окно (см. Стили отображения индикаторных линий).
SetLevelValue | Устанавливает значение для указанного горизонтального уровня индикатора, выводимого в отдельное окно.

Для получения подробного описания этих и других функций необходимо обратиться к справочной документации на MQL4.community, сайте MetaQuotes Software Corp. или к разделу "Справка" в редакторе MetaEditor.

Глобальные переменные GlobalVariablesИнформация о счёте


Стандартные функции - Учебник по MQL4

Учебник по MQL4 [image] Стандартные функции
  • Общие функции
  • Графические объекты
  • Операции с графиками
  • Строковые функции
  • Дата и время
  • Файловые операции
  • Массивы и таймсерии
  • Математические функции
  • Глобальные переменные GlobalVariables
  • Пользовательские индикаторы
  • Информация о счёте
  • Торговые функции
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Стандартные функции

Всего в языке MQL4 насчитывается более 220 стандартных функций, не считая функций технических индикаторов. Представить в учебнике описание и пример использования для каждой из них не представляется возможным ввиду их большого количества. Некоторые функции, требующие подробных пояснений, рассмотрены в предыдущих разделах. В данном разделе рассматриваются другие наиболее употребляемые функции. В конце каждого параграфа приводится полный список функций определённой категории и их краткое описание.

  • Общие функции.
    В этой группе функции, которые не вошли ни в одну из специализированных групп. Это функции Print(), Alert(), Comment(), MarketInfo(), Sleep() и т.д.

  • Графические объекты.
    Терминал MetaTrader 4 позволяет прикреплять к ценовым графикам множество графических объектов. В этой группе собраны функции, которые позволяют создавать такие объекты программно, а также изменять их свойства, перемещать и удалять.
  • Операции с графиками.
    Группа функций, которые позволяют получить различную информацию об окне текущего графика, к которому прикреплена программа на MQL4 (скрипт, индикатор или эксперт).
  • Строковые функции и функции преобразование данных.
    Строковые функции предназначены для обработки переменных типа string: поиск значения, объединение (конкатенация) строк, извлечение подстроки и так далее. Функции преобразования позволяют производить преобразования переменной одного типа в переменную другого типа. Функция NormalizeDouble() производит округления числа типа double до указанной точности.
  • Дата и время.
    Данная группа функций позволяет получить время в том или ином представлении: LocalTime() сообщает локальное время компьютера, TimeCurrent() сообщает серверное время последней поступившей котировки. Кроме того, можно получить для указанного значения времени такие параметры как день недели, день месяца, час, минута и так далее.
  • Файловые операции.
    Эта группа функций необходима при операциях чтения/записи на жесткий диск.
  • Операции с массивами и доступ к таймсериям.
    Обеспечивают доступ к ценовым данным любого доступного символа/периода.
  • Математические функции.
    Стандартный набор математических и тригонометрических функций.
  • Глобальные переменные GlobalVariable.
    Функции для работы с глобальными переменными клиентского терминала.
  • Пользовательские индикаторы.
    Эти функции можно использовать только при написании пользовательских индикаторов.
  • Клиентский терминал, проверка состояния и информация о счёте.
    Функции сообщают информацию о клиентском терминале, состоянии счета и проверяют текущее состояние клиентского терминала (в том числе состояние окружения выполняемой MQL4-программы).
  • Торговые функции.
    Функции для проведения торговых операций.

Для получения подробного описания любой стандартной функции необходимо обратиться к справочной документации на MQL4.community, сайте MetaQuotes Software Corp. или к разделу "Справка" в редакторе MetaEditor.

Совместное использование программОбщие функции


Математические функции - Стандартные функции - Учебник по MQL4

Учебник по MQL4 [image] Стандартные функции [image] Математические функции
MetaQuotes Sofware Corp.
  • Общие функции
  • Графические объекты
  • Операции с графиками
  • Строковые функции
  • Дата и время
  • Файловые операции
  • Массивы и таймсерии
  • Математические функции
  • Глобальные переменные GlobalVariables
  • Пользовательские индикаторы
  • Информация о счёте
  • Торговые функции
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Математические функции

В составе MQL4 имеются математические и тригонометрические функции. Использование большинства из них не вызывает никаких затруднений. Например, функция MathMax() возвращает максимальное из двух числовых значений, указанных в списке параметров вызова функции. Использование других функций требует определённой внимательности и вдумчивости. Рассмотрим одну из таких функций.

Функция MathFloor()

 double MathFloor(double x)

Функция возвращает числовое значение, представляющее наибольшее целое число, которое меньше или равно x.

Параметры:

x - числовое значение.

Обратите внимание, значение, возвращаемое функцией, является действительным числом (типа double), в то же время в назначении функции указано, что функция возвращает целое число. Это нужно понимать так, что функция возвращает действительное число, у которого во всех разрядах после разделительной точки указаны нули. Например, функция MathFloor() может вернуть 37.0 (положительное число типа double) или -4.0 (отрицательное число типа double).

В описании также указано, что функция возвращает максимальное из возможных чисел, которое меньше заданного. Например, если значение передаваемого параметра х равно 13.5, то максимальное действительное число, имеющее после разделительной только нули, равно 13.0. Если же в вызове функции указано отрицательное число -13.5, то максимальное меньшее целое число равно -14.0. Таким образом, изменение знака передаваемого параметра приводит к разным результатам, а именно, получаемые значения не равны по модулю.

В некоторых случаях использование подобных функций оказывается очень удобным. Для примера рассмотрим фрагмент расчёта количества лотов для новых ордеров:

int Percent   =30;                                  // % свободных средств
double Free   =AccountFreeMargin();                 // Свободные средства
double One_Lot=MarketInfo(Symb,MODE_MARGINREQUIRED);//Стоим. 1 лота
double Step   =MarketInfo(Symb,MODE_LOTSTEP);       // Шаг изменен размера

double Lots_New=MathFloor(Free*Percent100One_LotStep)*Step;

Значение переменной Percent задаётся пользователем. В данном случае пользователь выделил для новых ордеров 30% свободных средств. В соответствии с правилами, установленными дилинговым центром, правильно вычисленное количество лотов должно быть кратно минимальному шагу изменения размера лотов (Step). Для расчёта необходимы также значения свободных средств на счёте (Free) и стоимости одного лота (One_Lot).

Рассмотрим логику рассуждений программиста, составившего формулу для расчёта искомого количества лотов Lots_New для новых ордеров. Используем для наглядности численные значения переменных. Пусть Free = 5000.0, One_Lot = 1360.0 (в большинстве ДЦ стоимость 1 лота для валютной пары, в знаменателе которой USD, пропорциональна цене по валютному инструменту), Step = 0.1. В этом случае программную строку для вычисления Lots_New можно переписать так:

Lots_New = MathFloor(5000.0*30/100/1360.0/0.1)*0.1;

Значением выражения 5000.0*30/100 является количество средств, выделенных пользователем для открытия нового ордера. В данном случае стоимость нового ордера может достигать 1500.0. Потратив все эти средства можно открыть один ордер, количество лотов у которого равно 1500.0 / 1360.0 = 1.102941. Однако дилинговый центр не примет заявку на такое количество лотов, т.к. минимальный шаг (в большинстве дилинговых центров) Step = 0.1. Для вычисления искомого количества лотов необходимо отбросить "лишние" цифры в дробной части и заменить их нулями.

Для этого можно воспользоваться рассматриваемой математической функцией:

Lots_New = MathFloor(1.102941/0.1)*0.1;

Результатом вычисления MathFloor(1.102941/0.1) будет число 11.0, а вычисленным значением переменной Lots_New - число 1.1 лота. Это значение соответствует правилам, установленным дилинговым центром, поэтому его можно использовать как заявляемое количество лотов для новых ордеров.

Математические функции

Функция | Краткое описание
MathAbs | Функция возвращает абсолютное значение (значение по модулю) переданного ей числа.
MathArccos | Функция возвращает значение арккосинуса x в диапазоне 0 к π в радианах. Если x меньше -1 или больше 1, функция возвращает NaN (неопределенное значение)
MathArcsin | Функция возвращает арксинус x в диапазоне от -π/2 до π/2 радианов. Если x-, меньше -1 или больше 1, функция возвращает NaN (неопределенное значение).
MathArctan | Функция возвращает арктангенс x. Если x равен 0, функция возвращает 0. MathArctan возвращает значение в диапазоне от -π/2 до π/2 радианов.
MathCeil | Функция возвращает числовое значение, представляющую наименьшее целое число, которое больше или равно x.
MathCos | Функция возвращает косинус угла.
MathExp | Функция возвращает значение числа e в степени d. При переполнении функция возвращает INF (бесконечность), в случае потери порядка MathExp возвращает 0.
MathFloor | Функция возвращает числовое значение, представляющее наибольшее целое число, которое меньше или равно x.
MathLog | Функции возвращают натуральный логарифм x в случае успеха. Если x отрицателен, функция возвращает NaN (неопределенное значение). Если x равен 0, функция возвращает INF (бесконечность).
MathMax | Функция возвращает максимальное из двух числовых значений.
MathMin | Функция возвращает минимальное из двух числовых значений.
MathMod | Функция возвращает вещественный остаток от деления двух чисел. Функция MathMod рассчитывает вещественный остаток f от x / y таким образом, что x = i * y + f , где i является целым числом, f имеет тот же знак, что и x, и абсолютное значение f меньше, чем абсолютное значение y.
MathPow | Функция возвращает значение основания, возведенного в указанную степень.
MathRand | Функция возвращает псевдослучайное целое число в дипазоне от 0 до 32767. Перед первым вызовом функции необходимо использовать функцию MathSrand, чтобы перевести генератор псевдослучайных чисел в начальное состояние
MathRound | Функция возвращает значение, округленное до ближайшего целого числа указанного числового значения.
MathSin | Функция возвращает синус указанного угла.
MathSqrt | Функция возвращает квадратный корень x. Если x отрицателен, MathSqrt возвращает NaN (неопределенное значение).
MathSrand | Функция устанавливает начальное состояние для генерации ряда псевдослучайных целых чисел.
MathTan | Функция возвращает тангенс x. Если x больше или равен 263 или меньше или равен -263, то происходит потеря значения и функция возвращает неопределенное число.

Для получения подробного описания этих и других функций необходимо обратиться к справочной документации на MQL4.community, сайте MetaQuotes Software Corp. или к разделу "Справка" в редакторе MetaEditor.

Массивы и таймсерииГлобальные переменные GlobalVariables


Графические объекты - Стандартные функции - Учебник по MQL4

Учебник по MQL4 [image] Стандартные функции [image] Графические объекты
MetaQuotes Sofware Corp.
  • Общие функции
  • Графические объекты
  • Операции с графиками
  • Строковые функции
  • Дата и время
  • Файловые операции
  • Массивы и таймсерии
  • Математические функции
  • Глобальные переменные GlobalVariables
  • Пользовательские индикаторы
  • Информация о счёте
  • Торговые функции
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Графические объекты

Графический объект - это изображение в окне финансового инструмента, которое можно выделить, переместить, изменить или удалить.

К графическим объектам относятся, например, горизонтальные и вертикальные линии, канал линейной регрессии, уровни Фибоначчи, прямоугольник, текстовая метка и пр. Такие изображения, как индикаторные линии, уровни индикатора, изображения свечей, надписи, выводимые функцией Comment(), и др. выделить и удалить невозможно, поэтому они не являются графическими объектами.

Графические объекты отображаются клиентским терминалом в окне финансового инструмента в соответствии с заданными координатами. Каждый графический объект, в зависимости от своего типа, имеет одну, две или три координаты и другие настраиваемые параметры. Любой графический объект можно установить в окно финансового инструмента вручную (с панели инструментов и из системного меню), а также в результате исполнения прикладной программы, запущенной в этом окне финансового инструмента, в том числе, эксперта, скрипта или пользовательского индикатора. Преобразование вида и места положения графического объекта может осуществляться вручную или программно, путём сообщения графическому объекту новых значений координат и других параметров.

Способы позиционирования графических объектов

В MQL4 принято два способа позиционирования объектов: относительно ценового графика и относительно окна финансового инструмента. Чтобы наглядно продемонстрировать разницу между этими способами, установим вручную в окне финансового инструмента два различных графических объекта: текст (OBJ_TEXT) и текстовую метку (OBJ_LABEL). Для этого можно воспользоваться кнопками А и Т на панели графических инструментов клиентского терминала. Установим размер окна таким образом, чтобы оно занимало приблизительно половину площади экрана (Рис. 134). Проследим, как будут реагировать эти графические объекты на изменение размеров окна (а также на горизонтальное и вертикальное масштабирование ценового графика).

Рис. 134. Графические объекты с различными способами позиционирования в окне финансового инструмента.

Позиционирование относительно окна финансового инструмента

Графический объект OBJ_LABEL будет оставаться неподвижным, если размер окна изменять путём перемещения его правой или нижней границы. Если же размер окна менять перемещая верхнюю или левую границу, то объект будет смещаться, при этом положение объекта относительно каждой их этих границ будет оставаться неизменным. Это происходит потому, что позиционирование графического объекта OBJ_LABEL осуществляется относительно границ окна финансового инструмента. В данном случае точкой привязки графического объекта к окну финансового инструмента является левый верхний угол окна финансового инструмента. Координаты объекта относительно указанной точки привязки задаются в пикселях - 193 и 48 на Рис. 135.

Рис. 135. Настройки графического объекта OBJ_LABEL.

Точкой отсчёта координат самого объекта (в данном случае) является верхний левый угол курсорной рамки, видимой при выделении объекта мышью. В левом верхнем углу курсорной рамки можно видеть небольшую точку, свидетельствующую о настройках данного графического объекта. В случае, если указана иная точка привязки, то и на курсорной рамке точка будет указана в другом углу.

При появлении в окне финансового инструмента новых баров объект типа OBJ_LABEL будет оставаться неподвижным относительно окна финансового инструмента. Использование этого объекта удобно в том случае, если необходимо вывести на экран текстовую информацию общего характера, например, о прекращении торгов, изменении брокером значения ограничивающей дистанции для ордеров и пр.

Позиционирование относительно ценового графика

При любом способе изменения размеров окна, а также при масштабировании ценового графика объект типа OBJ_TEXT не меняет своего положения относительно ценового графика. Точкой отсчёта координат для этого объекта является середина верхней линии курсорной рамки, координатой по оси Х - время, а по оси Y - цена по финансовому инструменту (Рис. 136).

Рис. 136. Настройки графического объекта OBJ_TEXT.

По мере появления в окне финансового инструмента новых баров место положения графического объекта OBJ_TEXT относительно ценового графика не изменяется, т.е. с появлением новых баров объект будет смещаться влево вместе с ценовым графиком, а когда новых баров накопится достаточное количество, то объект переместится за пределы левой границы окна финансового инструмента.

Тот или иной способ позиционирования является собственным свойством графического объекта определённого типа и не может быть изменён пользователем, в том числе программно. Большинство графических объектов позиционируются относительно ценового графика, т.е. в координатах цены и времени.

Создание графических объектов и изменение их свойств

Создать графический объект - это значит установить в окне финансового инструмента один из объектов предопределённого типа (см. Типы и свойства графических объектов). Для создания объекта используется функция:

Функция ObjectCreate()

bool ObjectCreate(string name, int type, int window, datetime time1, double price1,
        datetime time2=0, double price2=0, datetime time3=0, double price3=0)

Функция создаёт объект указанного типа с заданным именем и начальными координатами в указанном подокне графика. Число координат, связываемых с объектом, может быть от 1 до 3 в зависимости от его типа. При успешном создании объекта функция возвращает TRUE, иначе FALSE. Чтобы получить дополнительную информацию об ошибке, необходимо вызвать функцию GetLastError().

Координаты должны передаваться парами - время и цена. Например, объекту OBJ_VLINE требуется только время, но также нужно передать и цену (любое значение). Графический объект типа OBJ_LABEL игнорирует координаты, указанные в функции; для установки свойств OBJPROP_XDISTANCE и OBJPROP_YDISTANCE этого объекта необходимо использовать функцию ObjectSet().

Параметры:

  • name - имя объекта;
  • type - тип объекта (может быть одним из предопределённых типов объектов);
  • window - номер окна, в которое будет добавлен объект. Нумерация подокон графика (если на графике есть подокна с индикаторами) начинается с 1, главное окно графика есть всегда и имеет номер 0; указываемый номер окна должен быть большим или равным 0 и меньшим, чем значение, возвращаемое функцией WindowsTotal();
  • time1 - время первой координаты;
  • price1 - цена первой координаты;
  • time2 - время второй координаты;
  • price2 - цена второй координаты;
  • time3 - время третьей координаты;
  • price3 - цена третьей координаты.

Каждый графический объект имеет некоторые (свойственные ему) настраиваемые параметры. Например, кроме задаваемых координат объекту можно установить цвет, текст сообщения (для одних объектов), стиль линий (для других объектов) и т.д. Для изменения свойств объектов используется функция:

Функция ObjectSet()

bool ObjectSet(string name, int prop_id, double value)

Функция изменяет значение указанного свойства объекта. В случае успеха функция возвращает TRUE, иначе FALSE. Для получения информации об ошибке необходимо вызвать функцию GetLastError().

Параметры:

  • name - имя объекта;
  • prop_id - идентификатор свойства объекта (указывается одно из свойств объекта);
  • value - новое значение указанного свойства.

Все графические объекты могут иметь также текстовое описание. Текстовое описание каждого объекта доступно пользователю и может быть изменено на панели свойств объекта или программным способом. Для объектов OBJ_TEXT и OBJ_LABEL это описание составляет их основное содержание и всегда отображается в виде текстовой строки. Текстовые описания других объектов отображаются в непосредственной близости от изображения самого объекта в том случае, если включена опция "Показывать описания объектов" на панели свойств окна финансового инструмента (F8). Для изменения текстового описания объекта используется функция:

Функция ObjectSetText()

bool ObjectSetText(string name, string text, int font_size,
         string font_name=NULL, color text_color=CLR_NONE)

Функция изменения описания объекта. В случае успеха функция возвращает значение TRUE, иначе FALSE. Для получения дополнительной информации об ошибке необходимо вызвать функцию функцию GetLastError().Параметры font_size, font_name и text_color используются только для объектов OBJ_TEXT и OBJ_LABEL. Для объектов других типов эти параметры игнорируются.

Параметры:

  • name - имя объекта;
  • text - текст описания обьекта;
  • font_size - размер шрифта в пунктах;
  • font_name - наименование шрифта;
  • text_color - цвет текста.

Рассмотрим пример эксперта, в котором полезно используются функции управления графическими объектами.

Задача 32.Используя графический объект сообщить пользователю о торговых критериях, определённых на основе показаний индикатора MACD.

Как известно, индикатор MACD часто используется трейдерами для формирования торговых критериев. Индикатор представлен двумя линиями - главной и сигнальной. Считается, что торговый критерий срабатывает в момент пересечения указанных линий. Если главная линия индикатора (обычно серая гистограмма) пересекает сверху вниз сигнальную линию (обычно красную пунктирную), то нужно продавать, а если снизу вверх, - то покупать. В промежутках между пересечениями линий индикатора необходимо удерживать рыночные ордера, а в момент срабатывания противоположного критерия зарывать их и одновременно открывать новые в противоположном направлении. Таким образом, необходимо подготовить 4 вида сообщения: открытие Buy, открытие Sell, удержание Buy и удержание Sell.

В данной задаче все сообщения являются взаимоисключающими, т.е. невозможна ситуация, при которой возникает необходимость вывести на экран одновременно два или более сообщений. Поэтому в данном случае можно использовать всего один графический объект, постоянно присутствующий на экране, и по мере необходимости изменять выводимый текст. Отобразим объект в правом верхнем углу окна финансового инструмента, в котором будет работать эксперт. Поскольку положение объекта по ходу торгов менять не предполагается, то удобно использовать объект типа OBJ_LABEL, т.к. он позиционируется относительно окна финансового инструмента.

В качестве решения Задачи 32 рассмотрим эксперт grafobjects.mq4, использующий графический объект OBJ_LABEL:

//--------------------------------------------------------------------
// grafobjects.mq4
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------------
int start()                            // Спец. функция start
  {
//--------------------------------------------------------------- 1 --
   int Sit;
   double MACD_M_0,MACD_M_1,           // Главная линия, 0 и 1 бар
   MACD_S_0,MACD_S_1;                  // Сигнальная линия, 0 и 1 бар
   string Text[4];                     // Объявление строков. массива
   color  Color[4];                    // Объявление массива цветов

   Text[0]= "Открытие Buy";            // Текст для различных ситуаций
   Text[1]= "Открытие Sell";
   Text[2]= "Удерживаем Buy";
   Text[3]= "Удерживаем Sell";

   Color[0]= DeepSkyBlue;              // Цвет объекта ..
   Color[1]= LightPink;                // .. для различных ситуаций
   Color[2]= Yellow;
   Color[3]= Yellow;
//--------------------------------------------------------------- 2 --
   ObjectCreate("Label_Obj_MACD", OBJ_LABEL, 0, 0, 0);// Создание объ.
   ObjectSet("Label_Obj_MACD", OBJPROP_CORNER, 1);    // Привязка угол
   ObjectSet("Label_Obj_MACD", OBJPROP_XDISTANCE, 10);// Координата Х
   ObjectSet("Label_Obj_MACD", OBJPROP_YDISTANCE, 15);// Координата Y
//--------------------------------------------------------------- 3 --
   MACD_M_0 =iMACD(NULL,0,12,26,9,PRICE_CLOSE,MODE_MAIN,0);  // 0 бар
   MACD_S_0 =iMACD(NULL,0,12,26,9,PRICE_CLOSE,MODE_SIGNAL,0);// 0 бар
   MACD_M_1 =iMACD(NULL,0,12,26,9,PRICE_CLOSE,MODE_MAIN,1);  // 1 бар
   MACD_S_1 =iMACD(NULL,0,12,26,9,PRICE_CLOSE,MODE_SIGNAL,1);// 1 бар
//--------------------------------------------------------------- 4 --
   // Анализ ситуации
   if(MACD_M_1=MACD_S_0)                      // Персеч. снизу вверх
      Sit=0;
   if(MACD_M_1>MACD_S_1 && MACD_M_0<=MACD_S_0)// Персеч. сверху вниз
      Sit=1;
   if(MACD_M_1>MACD_S_1 && MACD_M_0>MACD_S_0) // Главная выше сигн.
      Sit=2;
   if(MACD_M_1

В блоке 1-2 эксперта определены переменные, в частности, заданы значения элементов массивов Text[] и Color[], которые в дальнейшем используются для изменения свойств объекта. В блоке 2-3 создаётся объект, и устанавливаются значения некоторых его свойств. Разберём это блок подробно. Согласно этой строки кода эксперта в окне финансового инструмента, в котором исполняется эксперт, создаётся графический объект:

   ObjectCreate("Label_Obj_MACD", OBJ_LABEL, 0, 0, 0);// Создание объ.

Значение "Label_Obj_MACD" указывает, что объекту назначено такое имя (имя создаваемому объекту присваивает программист по своему усмотрению). OBJ_LABEL - идентификатор типа объекта, указывает, что создаваемый объект будет иметь такой тип (выбирается из списка возможных типов). Первый из трёх последующих нолей указывает, что объект создаётся в основном окне (основное окно, где отображается ценовой график, всегда имеет индекс 0).

Следующие два ноля устанавливают для создаваемого объекта координаты, в соответствии с которыми объект должен быть отображён в указанном окне. В данном конкретном случае создаётся объект OBJ_LABEL, который не использует координаты цены и времени. Обратите внимание, в описании функции ObjectCreate() указываются только координаты цены и времени. Причём, для второй и третьей пары координат имеются умолчательные значения, в то время как для первой пары координат умолчательных значений нет. Это значит, что несмотря на то что для объекта OBJ_LABEL вообще не требуются координаты цены и времени, в вызове функции ObjectCreate() должны быть указаны какие-то значения. В данном случае указаны нули, можно было бы указать другие значения, но и в том и в другом случае они всё равно игнорируются при установлении свойств объекта OBJ_LABEL.

В последующих трёх строках программы (ранее созданному) объекту с именем Label_Obj_MACD устанавливаются значения для некоторых его свойств:

   ObjectSet("Label_Obj_MACD", OBJPROP_CORNER, 1);    // Привязка угол
   ObjectSet("Label_Obj_MACD", OBJPROP_XDISTANCE, 10);// Координата Х
   ObjectSet("Label_Obj_MACD", OBJPROP_YDISTANCE, 15);// Координата Y

Для угла привязки (OBJPROP_CORNER) устанавливается значение 1, что означает привязку к правому верхнему углу (ранее определённого основного) окна финансового инструмента. В следующих двух строках устанавливаются значения дистанции в пикселях от объекта до угла привязки: по горизонтали (OBJPROP_XDISTANCE) 10 пикселей и по вертикали (OBJPROP_YDISTANCE) 15 пикселей. На этой стадии исполнения программы объект создан, имеет уникальное имя и определены его основные свойства.

Для того чтобы объект отобразил нужный текст, сначала необходимо вычислить каким этот текст должен быть. Для этого сначала в блоке 3-4 определяется взаимное положение индикаторных линий индикатора MACD на текущем и предыдущем барах, а затем в блоке 4-5 вычисляется значение Sit, соответствующее текущей ситуации (см. также Рис. 107 и callstohastic.mq4)

В следующей строке определяются свойства объекта в зависимости от сложившейся ситуации:

                                       // Изменение свойств объекта
   ObjectSetText("Label_Obj_MACD",Text[Sit],10,"Arial",Color[Sit]);

В результате исполнения функции ObjectSetText() объекту с именем Label_Obj_MACD назначается текстовое описание, а именно значение строковой переменной Text[Sit]. Это значение для разных ситуаций будет различным в зависимости от значения переменной Sit. Например, если главная линия пересекла сигнальную сверху вниз, то в блоке 4-5 переменная Sit получит значение 1, в результате чего графическому объекту будет назначено текстовое описание, содержащееся в элементе массива Text[1], а именно "Открытие Sell". Следующие параметры: 10, "Arial" и Color[Sit] указывают размер, название и цвет шрифта для текстового описания.

В результате исполнения эксперта в окне финансового инструмента EURUSD можно наблюдать следующее:

Рис. 137. Результат работы эксперта grafobjects.mq4 в момент срабатывание критерия на продажу.

На Рис. 137 видно, что в окне финансового инструмента имеется также подокно индикатора MACD. Нужно заметить, что для полноценной работы эксперта наличие этого индикатора в окне финансового инструмента не требуется, т.к. вычисление торговых критериев в эксперте происходит в результате исполнения функции технического индикатора, не связанной с выводом индикатора на экран. Здесь индикатор показан только для того, чтобы можно было визуально определить момент срабатывания торгового критерия и вывод необходимого для этого случая текстового описания графического объекта. Эксперт будет работать аналогично и при всех других сочетаниях взаимного положения индикаторных линий, всякий раз отображая описание, соответствующее ситуации.

Удаление графических объектов

Рассмотренный выше эксперт grafobjects.mq4 имеет небольшой недостаток. По окончании работы эксперта в окне финансового инструмента останется графический объект (при этом его свойства будут такими, какими они были на момент последнего изменения). Графические объекты самопроизвольно не удаляются. По мере развития торгов, начиная с некоторого момента, надпись Открытие Sell уже не будет соответствовать действительности. Чтобы не вводить пользователя в заблуждение, графический объект нужно удалить.

Для удаления любого графического объекта (независимо от способа его создания - вручную или программно) достаточно выделить его и нажать клавишу Delete. Однако, говоря о программировании, следует подчеркнуть, что правильно составленная программа обязательно должна "почистить" после себя окно финансового инструмента. Иными словами, в программе должен быть предусмотрен блок, в котором удаляются все созданные программой графические объекты.

Функция ObjectDelete()

bool ObjectDelete(string name)

Удаление объекта с указанным именем. При успешном удалении функция возвращает TRUE, иначе FALSE. Чтобы получить дополнительную информацию об ошибке, необходимо вызвать функцию GetLastError().

Параметры:

  • name - имя удаляемого объекта.

Использование функции ObjectDelete() крайне просто: достаточно указать имя удаляемого объекта.

Для того чтобы устранить недоработку, допущенную в предыдущем примере, достаточно дополнить эксперт grafobjects.mq4 специальной функцией deinit(), в которой и указать функцию удаления объекта:

//--------------------------------------------------------------- 7 --
int deinit()                           // Спец. функция deinit
  {
   ObjectDelete("Label_Obj_MACD");     // Удаление объекта
   return;                             // Выход из deinit()
  }
//--------------------------------------------------------------- 8 --

При исполнении эксперта, дополненного функцией deinit() с таким кодом, объект с именем Label_Obj_MACD будет удалён. В общем случае программа может создавать множество объектов. Каждый из них может быть удалён программно в соответствии с алгоритмом.

Модификация графических объектов

В ряде случаев требуется программно изменить положение объекта в окне финансового инструмента. Чаще всего такая необходимость возникает по причине появления новых баров. Например, торговые критерии в эксперте могут формироваться на основе канала линейной регрессии, построенного на баровой истории определённой длительности (например, по последним 50 барам). Если графический объект "канал линейной регрессии" просто отобразить в окне финансового инструмента и в дальнейшем не предпринимать никаких мер, то он всё время будет оставаться в том месте ценового графика, где был установлен, и с появлением новых баров будет смещаться влево вместе с историческими барами. Для того, чтобы этот графический объект не "съезжал", его необходимо перерисовывать на каждом новом баре. Для этой цели необходимо вычислить и сообщить объекту новые координаты, в соответствии с которыми объект должен быть отображён в окне финансового инструмента.

Для того, чтобы узнать какие свойства имеются у графического объекта на текущий момент, необходимо использовать функцию:

Функция ObjectGet()

double ObjectGet(string name, int prop_id)

Функция возвращает значение указанного свойства объекта. Для получения информации об ошибке необходимо вызвать функцию GetLastError().

Параметры:

  • name - имя объекта;
  • prop_id - идентификатор свойства объекта. Может быть любым из значений списка свойств объекта.

Сообщение новых координат объекту осуществляется с помощью функции ObjectMove().

Функция ObjectMove()

bool ObjectMove(string name, int point, datetime time1, double price1)

Изменение одной из координат объекта на графике. Функция возвращает TRUE в случае успеха, иначе FALSE. Для получения дополнительной информации об ошибке необходимо вызвать функцию GetLastError(). Нумерация координат объекта начинается с 0.

Параметры:

  • name - имя объекта;
  • point - индекс координаты (0-2);
  • time1 - новое значение времени;
  • price1 - новое значение цены.

Задача 33.Составить программу (эксперт), поддерживающую отображение канала линейной регрессии для последних 50 баров.

Графический объект "канал линейной регрессии" использует две координаты времени. Координаты цены (если они были назначены в программе) при построении этого объекта клиентским терминалом игнорируются. Канал линейной регрессии вычисляется клиентским терминалом на основе исторических цен и по своей сути не может быть отображён в стороне от ценового графика. Поэтому отсутствие привязки этого объекта по цене (игнорирование координат цены терминалом) является собственным неизменным свойством этого объекта. Эксперт (moveobjects.mq4), управляющий положением графического объекта может быть составлен так:

//--------------------------------------------------------------------
// moveobjects.mq4
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------------
extern int   Len_Cn=50;                // Длина канала (баров)
extern color Col_Cn=Orange;            // Цвет канала
//--------------------------------------------------------------- 1 --
int init()                             // Спец. функция init()
  {
   Create();                           // Вызов пользов. ф-ии создания
   return;                             // Выход из init()
  }
//--------------------------------------------------------------- 2 --
int start()                            // Спец. функция start()
  {
   datetime T2;                        // Вторая координата времени
   int Error;                          // Код ошибки
//--------------------------------------------------------------- 3 --
   T2=ObjectGet("Obj_Reg_Ch",OBJPROP_TIME2);// Запрос коорд. t2
   Error=GetLastError();               // Получение кода ошибки
   if (Error==4202)                    // Если объекта нет :(
     {
      Alert("Канал регрессии находится под управлением",
            "\n Book_expert_82_2. Удалять нельзя.");
      Create();                        // Вызов пользов. ф-ии создания
      T2=Time[0];                      // Текущее значение коорд. t2
     }
//--------------------------------------------------------------- 4 --
   if (T2!=Time[0])                    // Если объект не на месте
     {
      ObjectMove("Obj_Reg_Ch", 0, Time[Len_Cn-1],0); //Новая коорд. t1
      ObjectMove("Obj_Reg_Ch", 1, Time[0],       0); //Новая коорд. t2
      WindowRedraw();                  // Перерисовка изображения
     }
   return;                             // Выход из start()
  }
//--------------------------------------------------------------- 5 --
int deinit()                           // Спец. функция deinit()
  {
   ObjectDelete("Obj_Reg_Ch");         // Удаление объекта
   return;                             // Выход из deinit()
  }
//--------------------------------------------------------------- 6 --
int Create()                           // Пользовательская функция..
  {                                    // ..создания объекта
   datetime T1=Time[Len_Cn-1];         // Определение 1 коорд времени
   datetime T2=Time[0];                // Определение 2 коорд времени
   ObjectCreate("Obj_Reg_Ch",OBJ_REGRESSION,0,T1,0,T2,0);// Создание
   ObjectSet(   "Obj_Reg_Ch", OBJPROP_COLOR, Col_Cn);    // Цвет
   ObjectSet(   "Obj_Reg_Ch", OBJPROP_RAY,   false);     // Луч
   ObjectSet(   "Obj_Reg_Ch", OBJPROP_STYLE, STYLE_DASH);// Стиль
   ObjectSetText("Obj_Reg_Ch","Создан экспертом moveobjects",10);
   WindowRedraw();                     // Перерисовка изображения
  }
//--------------------------------------------------------------- 7 --

Алгоритм эксперта moveobjects.mq4 предполагает, что однажды выставленный графический объект будет оставаться на экране в течение всего времени исполнения программы. В подобных случаях имеет смысл использовать в программе пользовательскую функцию (здесь это функция Create(), блок 6-7) для создания объекта и обращаться к ней из программы по мере необходимости. Для отображения объекта необходимы две координаты времени (Т1 - координата левой границы объекта и Т2 - координата правой границы):

   datetime T1 = Time[Len_Cn-1];       // Определение 1 коорд времени
   datetime T2 = Time[0];              // Определение 2 коорд времени

В данном примере правая граница графического объекта должна всегда находиться на нулевом баре, поэтому значение второй координаты совпадает со временем открытия нулевого бара. Левая координата вычисляется в зависимости от заданного пользователем количества баров (внешняя переменная Len_Cn) и определяется как время открытия бара с соответствующим индексом. Например, если длина канала составляет 50 баров, то левая координата объекта будет равна времени открытия бара с индексом 49.

В следующих строках пользовательской функции Create() с помощью ObjectCreate() создаётся объект OBJ_REGRESSION, и с помощью ObjectSet() созданный объект наделяется необходимыми свойствами (заданный пользователем во внешней переменной цвет, запрещено рисовать объект как луч, стиль линии - пунктирная). В строке:

   ObjectSetText("Obj_Reg_Ch","Создан экспертом moveobjects",10);

объекту сообщается текстовое описание. В отличие от ранее рассмотренного объекта OBJ_LABEL, текстовое описание объекта OBJ_REGRESSION не выводится на экран. Текстовое описание графических объектов можно увидеть на панели свойств объектов. Это очень удобно использовать во время практической работы для того, чтобы отличить объекты, созданные программой, от объектов, выставленных пользователем вручную:

Рис. 138. Общие свойства графического объекта "канал линейной регрессии", созданного экспертом moveobjects.mq4.

В программе используется ещё одна функция, с помощью которой перерисовывается текущий график:

   WindowRedraw();                     // Перерисовка изображения

Функция WindowRedraw()

void WindowRedraw()

Функция принудительно перерисовывает текущий график. Обычно применяется после изменения свойств объектов.

Обычный порядок отображения графических объектов клиентским терминалом предусматривает фактическое изменение изображения в момент поступления нового тика. Поэтому, если не использовать WindowRedraw(), то изменения свойств объекта становятся видимы пользователю на следующем тике, т.е. процесс отображения постоянно запаздывает на один тик. Использование WindowRedraw() позволяет принудительно перерисовать все объекты в нужный момент, например, сразу после изменения свойств объектов. В общем случае, если в программе изменяются свойства нескольких объектов, то функцию WindowRedraw() достаточно использовать один раз, после изменения свойств последнего из объектов.

Первое обращение к пользовательской функции осуществляется из специальной функции init(). В момент прикрепления эксперта к окну финансового инструмента начнётся исполнение init(), в результате чего графический объект "канал линейной регрессии" отобразится в окне финансового инструмента.

В функции start() рассматривается две возможных ситуации: когда объект случайно удалён пользователем (блок 3-4) и когда объект необходимо переместить вправо при образовании нового нулевого бара (блок 4-5). Для того чтобы определить, существует ли вообще графический объект на текущий момент, достаточно запросить значение одной из его координат. Если объект существует, то функция ObjectGet() вернёт некоторое значение, соответствующее запрошенной координате, а функция GetLastError() вернёт нулевое значение (т.е. при запросе координаты ошибка не возникла). Если же объекта с заданным именем в окне финансового инструмента нет, то функция GetLastError() вернёт код ошибки 4202, т.е. объект не существует:

   T2=ObjectGet("Obj_Reg_Ch",OBJPROP_TIME2);     // Запрос коорд. t2
   Error=GetLastError();                         // Получение кода ошибки

Если анализ ошибки показал, что объекта нет, значит его надо вновь создать, уведомив пользователя о недопустимых действиях (программа не удаляет объект в процессе работы, значит объект удалён пользователем). Поэтому после вывода сообщения в программе выполняется обращение к ранее рассмотренной пользовательской функции Create(), в результате чего объект снова создаётся в окне финансового инструмента.

К моменту, когда исполняется следующий блок (4-5), графический объект обязательно присутствует. Чтобы решить, надо ли его двигать, следует знать, каково положение объекта на текущий момент. Для этого достаточно проанализировать (ранее полученное) значение первой координаты объекта, и если это значение не совпадает со временем открытия нулевого бара, то сообщить объекту новые координаты.

Изменение координат объекта осуществляется с помощью функции ObjectMove():

   ObjectMove("Obj_Reg_Ch", 0, Time[Len_Cn-1],0); //Новая коорд. t1
   ObjectMove("Obj_Reg_Ch", 1, Time[0],       0); //Новая коорд. t2

Здесь объекту с именем Obj_Reg_Ch для первой координаты (координата 0) устанавливается значение Time[Len_Cn-1], а для второй координаты (координата 1) -Time[0]. Последним среди передаваемых в функцию ObjectMove() параметров указан 0. Это - координата цены, которую в соответствии с описанием функции передавать необходимо, но которое в данном случае будет проигнорировано клиентским терминалом. В результате исполнения этих строк свойства указанного графического объекта будут изменены, а в результате последующего исполнения функции WindowRedraw() графический объект будет принудительно перерисован клиентским терминалом - теперь уже соответственно новым значениям координат.

Таким образом, при исполнении функции start() графический объект "канал линейной регрессии" будет перерисовываться клиентским терминалом всякий раз при образовании нового бара, на первом же его тике (см. рис. 139). По окончании выполнения эксперта в окне финансового инструмента, в момент исполнения специальной функции deinit(), указанный объект будет удалён (т.е. программа "подметёт" после работы своё рабочее место).

Рис. 139. Отображение канала линейной регрессии при исполнении эксперта moveobjects.mq4.

В общем случае можно создавать и удалять графические объекты в зависимости от некоторых вычисленных в программе условий. Можно отображать линии поддержки и сопротивления (OBJ_TREND), вертикальными линиями (OBJ_VLINE) отмечать время приближающихся значительных событий, текстовыми объектами (OBJ_LABEL и OBJ_TEXT) указывать пересечения различных линий, прогнозируемое направление движения цены и т.д.

Отдельно нужно заметить, что в ряде случаев использование графических объектов не требуется. Например, если есть необходимость вывести на экран множество простых однотипных изображений (например, стрелки), то для этого можно воспользоваться индикаторными линиями, соответствующим образом настроив стиль линий. Такой подход избавит от необходимости отслеживать в программе множество координат объектов и предотвратит возможность случайного удаления изображения (значки, отображающие индикаторные линии, невозможно ни выделить, ни удалить).

Функции для работы с графическими объектами

Функция | Краткое описание
ObjectCreate | Создание объекта с указанным именем, тип и начальные координаты в указанном подокне графика. Число координат, связываемых с объектом, может быть от 1 до 3 в зависимости от типа. При успешном создании объекта функция возвращает TRUE, иначе FALSE.
ObjectDelete | Удаление объекта с указанным именем. При успешном удалении функция возвращает TRUE, иначе FALSE
ObjectDescription | Функция возвращает описание объекта. Для объектов типа OBJ_TEXT и OBJ_LABEL возвращается текст, отображаемый этими объектами.
ObjectFind | Поиск объекта с указанным именем. Функция возвращает индекс окна, которому принадлежит искомый объект. В случае неудачи функция вернет -1.
ObjectGet | Функция возвращает значение указанного свойства объекта.
ObjectGetFiboDescription | Функция возвращает описание уровня объекта Фибоначчи. Количество уровней зависит от типа объекта, принадлежащего к группе объектов Фибоначчи. Максимальное количество уровней - 32.
ObjectGetShiftByValue | Функция вычисляет и возвращает номер бара (смещение относительно текущего бара) для указанной цены. Номер бара вычисляется при помощи линейного уравнения по первой и второй координатам. Применяется для трендовых линий и аналогичных объектов.
ObjectGetValueByShift | Функция вычисляет и возвращает значение цены для указанного бара (смещение относительно текущего бара). Значение цены вычисляется при помощи линейного уравнения по первой и второй координатам. Применяется для трендовых линий и аналогичных объектов.
ObjectMove | Изменение одной из координат объекта на графике. Объекты могут иметь от одной до трех точек привязки в зависимости от типа объекта. Функция возвращает TRUE в случае успеха, иначе FALSE.
ObjectName | Функция возвращает имя объекта по порядковому номеру в списке объектов.
ObjectsDeleteAll | Удаление всех объектов с указанным типом и в указанном подокне графика. Функция возвращает число удаленных объектов.
ObjectSet | Изменение значения указанного свойства объекта. В случае успеха функция возвращает TRUE, иначе FALSE
ObjectSetFiboDescription | Функция присваивает новое описание уровню объекта Фибоначчи. Количество уровней зависит от типа объекта Фибоначчи. Максимальное количество уровней - 32.
ObjectSetText | Изменение описания объекта. Для объектов OBJ_TEXT и OBJ_LABEL это описание отображается на графике в виде текстовой строки. В случае успеха функция возвращает значение TRUE, иначе FALSE.
ObjectsTotal | Возвращает общее число объектов указанного типа на графике.
ObjectType | Функция возвращает тип указанного объекта.

Для получения подробного описания этих и других функций необходимо обратиться к справочной документации на MQL4.community, сайте MetaQuotes Software Corp. или к разделу "Справка" в редакторе MetaEditor.

Общие функцииОперации с графиками


Строковые функции - Стандартные функции - Учебник по MQL4

Учебник по MQL4 [image] Стандартные функции [image] Строковые функции
MetaQuotes Sofware Corp.
  • Общие функции
  • Графические объекты
  • Операции с графиками
  • Строковые функции
  • Дата и время
  • Файловые операции
  • Массивы и таймсерии
  • Математические функции
  • Глобальные переменные GlobalVariables
  • Пользовательские индикаторы
  • Информация о счёте
  • Торговые функции
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Строковые функции

Наиболее часто встречающаяся операция для строковых значений - сложение (конкатенация) - рассматривалась в Операции и выражения (Задача 3). В некоторых случаях возникает необходимость выполнить другие вычисления, связанные со строковыми значениями. Для работы со значениями типа string в MQL4 имеется ряд строковых функций. Рассмотрим, как могут быть использованы некоторые из них на примере.

Задача 35. Раскрасить 100 последних баров свечного графика: чёрные свечи - красным цветом, а белые - синим.

Раскраска свечи может быть выполнена двумя линиями: тонкая линия должна накладываться на свечу так, чтобы полностью накрыть тени, а широкая линия должна заполнить тело свечи. Применить для решения задачи линии пользовательского индикатора в данном случае не представляется возможным, потому что отображаемые линии должны быть вертикальными, т.е. построенными по двум координатам цены (при совпадающих координатах времени), а индикаторные массивы позволяют хранить только одно значение, поставленное в соответствие каждому бару. Поэтому решение задачи сводится к отображению на ценовом графике серии однотипных графических объектов - OBJ_TREND, отличающихся координатами, стилем и цветом линий (см. Графические объекты).

В данном случае в качестве прикладной программы используется эксперт, хотя в общем случае алгоритм может быть реализован и в пользовательском индикаторе. В целом алгоритм программы понятен. При присоединении эксперта к окну финансового инструмента (при исполнении init()) график должен быть раскрашен первый раз. На каждом тике (при исполнении start()) программа должна отслеживать возможные изменения в положении каждого из созданных ею графических объектов (пользователь может случайно удалить или переместить любой из них) и при необходимости восстановить его. А в период завершения программы (deinit()) все созданные программой графические объекты должны быть удалены.

В период практической работы с экспертом пользователь может вручную создать в окне финансового инструмента и другие объекты, например, установить канал стандартных отклонений, уровни Фибоначчи, линии поддержки и пр. Поэтому в программе должен быть реализован алгоритм, позволяющий отличать объекты, созданные программой, от объектов, установленных пользователем. Это особенно важно при завершении программы: необходимо удалить только "свои" объекты, а "пользовательские" оставить без изменения. Каждый графический объект обладает определёнными свойствами, которые, в общем случае, могут совпадать. Единственным отличительным признаком любого объекта является его уникальное имя (одинаковые имена не допускаются).

При составлении имени каждого из создаваемых объектов желательно ввести в имя объекта полезную информацию, по которой можно было бы судить о местоположении и свойствах объекта. Например, имя объекта может содержать префикс, отличающий объект, созданный этой программой, от всех других. В нашем случае это строковое значение "Paint_". Кроме того, необходимо отличать и "свои" объекты между собой. При этом простая нумерация (Paint_1, Paint_2 и т.д.) не может быть использована. Используя такой способ именования имён объектов, невозможно понять: на каком баре должен быть отображён, например, объект Paint_73. Тот бар, который имел индекс 73, с появлением нового бара получит индекс 74, при следующем новом баре 75 и т.д. При таком решении пришлось бы удалять и вновь создавать все объекты на каждом новом баре. Понятно, что это решение (хотя и осуществимо), является очень грубым и затратным.

Каждый из создаваемых объектов должен иметь координаты времени, совпадающие со временем открытия бара. Кроме того, на каждом баре необходимо отображать 2 линии - тонкую и широкую. Наиболее удобно представить имена создаваемых программой объектов в таком виде:

Имя объекта = Paint_2_2007.03.22 16:40, здесь:

Paint_ - префикс, отличающий объекты, созданные программой;

2_ - номер одного из двух объектов, отображаемых на баре (возможные значения 1 и 2);

2007.03.22 16:40 - координата времени, однозначно характеризующая бар, на котором отображается объект.

Paint_ и 2_ - это значения переменных Prefix и Nom_Lin. Координату времени для каждого бара можно получить путём преобразования значения типа datetime в значение типа string с помощью функции преобразования данных:

Функция TimeToStr()

string TimeToStr(datetime value, int mode=TIME_DATE|TIME_MINUTES)

Функция преобразовывает значение, содержащее время в секундах, прошедших с 01.01. 1970 (значение типа datetime), в строку заданного формата (значение типа string).

Параметры:

value - время в секундах от 00:00 1 января 1970;

mode - дополнительный режим вывода данных. Может быть одним или комбинированным флагом:

TIME_DATE получает результат в форме "yyyy.mm.dd";

TIME_MINUTES получает результат в форме "hh:mi";

TIME_SECONDS получает результат в форме "hh:mi:ss".

Рассмотрим эксперт strings.mq4, управляющий графическими объектами для раскраски свечей, и проследим как функция TimeToStr() используется в этой программе:

//--------------------------------------------------------------------
// strings.mq4
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------- 1 --
extern int Quant_Bars=100;             // Количество баров
datetime   Time_On;
string     Prefix    ="Paint_";
//--------------------------------------------------------------- 2 --
int init()                             // Спец. функция init()
  {
   int Ind_Bar;                        // Индекс бара
   Time_On=Time [Quant_Bars];          // Время первого раскрашенного
   for(Ind_Bar=Quant_Bars-1; Ind_Bar>=0; Ind_Bar--)// Цикл по барам
     {
      Create(Ind_Bar,1);               // Нарисуем тонкую линию
      Create(Ind_Bar,2);               // Нарисуем толстую линию
     }
   WindowRedraw();                     // Перерисовка изображения
   return;                             // Выход из init()
  }
//--------------------------------------------------------------- 3 --
int start()                            // Спец. функция start
  {
   datetime T1, T2;                    // 1 и 2 координаты времени
   int Error,Ind_Bar;                  // Код ошибки и индекс бара
   double P1, P2;                      // 1 и 2 координата цены
   color Col;                          // Цвет созданного объекта
//--------------------------------------------------------------- 4 --
   for(int Line=1; Line<=2; Line++)    // Цикл по видам линий
     {
      string Nom_Lin =Line + "_";      // Строка с номером линии
      //    string Nom_Lin  = DoubleToStr(Line,0)+"_";// Можно и так
      for(Ind_Bar=0; ;Ind_Bar++)       // Цикл по барам
        {
//--------------------------------------------------------------- 5 --
         datetime T_Bar= Time[Ind_Bar];// Время открытия бара
         if (T_Bar < Time_On) break;   // Заграничные не раскрашиваем
         string Str_Time=TimeToStr(T_Bar);       // Строка со временем
         string His_Name=Prefix+Nom_Lin+Str_Time;// Имя объекта
//--------------------------------------------------------------- 6 --
         T1=ObjectGet(His_Name,OBJPROP_TIME1);// Запрос коорд. t1
         Error=GetLastError();         // Получение кода ошибки
         if (Error==4202)              // Если объекта нет :(
           {
            Create(Ind_Bar,Line);      // Вызов ф-ии создания объекта
            continue;                  // На следующую итерацию
           }
//--------------------------------------------------------------- 7 --
         T2 =ObjectGet(His_Name,OBJPROP_TIME2); // Запрос коорд. t2
         P1 =ObjectGet(His_Name,OBJPROP_PRICE1);// Запрос коорд. p1
         P2 =ObjectGet(His_Name,OBJPROP_PRICE2);// Запрос коорд. p1
         Col=ObjectGet(His_Name,OBJPROP_COLOR); // Запрос цвета
         if(T1!=T_Bar || T2!=T_Bar || // Не те координаты или цвет:
            (Line==1 && (P1!=High[Ind_Bar] || P2!=  Low[Ind_Bar])) ||
            (Line==2 && (P1!=Open[Ind_Bar] || P2!=Close[Ind_Bar])) ||
            (Open[Ind_Bar] Close[Ind_Bar] && Col!=Red)  ||
            (Open[Ind_Bar]==Close[Ind_Bar] && Col!=Green)  )
           {
            ObjectDelete(His_Name);    // Удаляем объект
            Create(Ind_Bar,Line);      // Создаём правильный объект
           }
//--------------------------------------------------------------- 8 --
        }
     }
   WindowRedraw();                     // Перерисовка изображения
   return;                             // Выход из start()
  }
//--------------------------------------------------------------- 9 --
int deinit()                           // Спец. функция deinit()
  {
   string Name_Del[1];                 // Объявление массива
   int Quant_Del=0;                    // Количество удаляемых объектов
   int Quant_Objects=ObjectsTotal();   // Cтолько всего ВСЕХ объектов
   ArrayResize(Name_Del,Quant_Objects);// Необходимый размер массива
   for(int k=0; k<=Quant_Del; i++)     // Удаляем объекты с именами,..
      ObjectDelete(Name_Del[i]);       // .. имеющимися в массиве
   return;                             // Выход из deinit()
  }
//-------------------------------------------------------------- 10 --
int Create(int Ind_Bar, int Line)      // Пользовательская функция..
  {                                    // ..создания объекта
   color Color;                        // Цвет объекта
   datetime T_Bar=Time [Ind_Bar];      // Время открытия бара
   double   O_Bar=Open [Ind_Bar];      // Цена открытия бара
   double   C_Bar=Close[Ind_Bar];      // Цена закрытия бара
   double   H_Bar=High [Ind_Bar];      // Максимальная цена бара
   double   L_Bar=Low  [Ind_Bar];      // Минимальная цена бара

   string Nom_Lin =Line + "_";         // Строка - номер линии
   // string Nom_Lin  = DoubleToStr(Line,0)+"_";// Можно и так
   string Str_Time=TimeToStr(T_Bar);   // Строка - время откр.
   string His_Name=Prefix+Nom_Lin+Str_Time;// Имя созаваемого объект
   if (O_Bar < C_Bar) Color=Blue;      // Выбор цвета в зависимости..
   if (O_Bar >C_Bar) Color=Red;        // .. от характеристик бара
   if (O_Bar ==C_Bar) Color=Green;

   switch(Line)                        // Тонкая или толстая линия
     {
      case 1:                          // Тонкая линия
         ObjectCreate(His_Name,OBJ_TREND,0,T_Bar,H_Bar,T_Bar,L_Bar);
         break;                        // Выход из switch
      case 2:                          // Толстая линия
         ObjectCreate(His_Name,OBJ_TREND,0,T_Bar,O_Bar,T_Bar,C_Bar);
         ObjectSet(   His_Name, OBJPROP_WIDTH, 3);// Стиль
     }
   ObjectSet(    His_Name, OBJPROP_COLOR, Color); // Цвет
   ObjectSet(    His_Name, OBJPROP_RAY,   false); // Луч
   ObjectSetText(His_Name,"Объект создан экспертом",10);// Описание
   return;                             // Выход из польз. ф-ии
  }
//-------------------------------------------------------------- 11 --

Для создания графических объектов в программе имеется пользовательская функция Create() (блок 10-11). В качестве передаваемых параметров в этой функции используются переменная Ind_Bar, указывающая индекс бара, на котором необходимо создать объект, и Line - номер объекта (1я или 2я линия).

При формировании имени создаваемого объекта His_Name используются три составляющих:

   string His_Name = Prefix+Nom_Lin+Str_Time;// Имя создаваемого объект

Значение переменной Prefix задано программистом в головной части программы и при выполнении программы не изменяется:

string     Prefix     = "Paint_";

Значение переменной Nom_Lin получено в результате вычислений:

   string Nom_Lin  = Line + "_";       // Строка - номер линии
// string Nom_Lin  = DoubleToStr(Line,0)+"_";// Можно и так

Здесь значение целой переменной (при вычислении выражения в правой части выражения) преобразуется к типу, имеющему более высокий приоритет, а именно, к типу string. В результате, в зависимости от значения переменной Line, переменная Nom_Lin получает значение "1_"или "2_".

Для вычисления значения переменной Str_Time используется функция преобразования данных TimeToStr():

   string Str_Time = TimeToStr(T_Bar); // Строка - время откр.

Обратите внимание, функция TimeToStr() имеет умолчательные значения. В данном случае именно такие значения параметра mode и требуются: "yyyy.mm.dd hh:mi"; использовать дополнительно секунды нет необходимости, потому что минимальный таймфрейм равен 1 минуте.

Для использования в имени объекта можно было бы применить и такой способ вычисления Str_Time:

   string Str_Time = T_Bar;

В этом случае переменная Str_Time получила бы значение, равное количеству секунд, прошедших с 01.01.1970. Чтобы увидеть разницу, можно выполнить программу, содержащую такой код:

int init()
  {
   string String_Time = TimeToStr(Time[0]); // Время в формате.
   string String_Sec  = Time[0];            // Количество секунд
   Alert("String_Time = ",String_Time,"  String_Sec = ",String_Sec);
   return;
  }

В результате исполнения этой программы (в зависимости от времени открытия нулевого бара) на экран будет выведено сообщение:

String_Time = 2007.03.22 19:10 String_Sec = 1174590600

Первый вариант, реализованный в эксперте strings.mq4, несколько более информативен, поэтому в данном случае предпочтение отдано ему (с точки зрения алгоритма, реализованного в программе, эти варианты равнозначны).

В последующих строках пользовательской функции Create() создаётся объект с вычисленным именем His_Name, содержащим сведения о времени открытия бара, и со свойствами, соответствующими номеру линии Line, а также с цветом в зависимости от характеристик бара. Для каждого объекта указывается также значение текстового описания: "Объект создан экспертом".

Вызов функции Create() осуществляется в программе в двух местах - из специальной функции init() для первоначального создания объектов, и из специальной функции start(), в случае необходимости ещё раз создать объект, случайно удалённый или изменённый пользователем. Имена объектов в функции start() (блоки 4-5-6) формируются так же, как и в других местах программы.

В блоке 6-7 определяется первая координата исследуемого объекта. Если при этом объект не найден, то он создаётся с помощью Create(). А если объект существует, то определяются другие его координаты и вычисляется, соответствуют ли его свойства характеристикам бара (блок 7-8). При обнаружении любого несоответствия объект удаляется и создаётся вновь (с тем же именем), но уже с правильными свойствами.

При исполнении функции deinit() решается ещё одна задача: из всей совокупности объектов, имеющихся в окне финансового инструмента, необходимо удалить только те, которые созданы экспертом. Это делается в два этапа: на первом этапе в массив Name_Del[] запоминаются имена всех объектов, которые необходимо удалить, а затем, в отдельном цикле, все эти объекты удаляются. Общее количество всех объектов в окне (в том числе, созданных программой и установленных пользователем вручную) вычисляется с помощью функции ObjectsTotal():

   int Quant_Objects=ObjectsTotal();   // Cтолько всего ВСЕХ объектов

Количество раскрашиваемых баров устанавливается пользователем во внешней переменной, т.е. заранее неизвестно, сколько графических объектов придётся удалять. Поэтому строковый массив, несущий имена удаляемых объектов, объявляется с количеством элементов равным 1, а затем размер массива программно изменяется - количество его элементов увеличивается до общего количества объектов.

   ArrayResize(Name_Del,Quant_Objects);// Необходимый размер массива

Для того, чтобы отобрать объекты, созданные экспертом, в функции deinit() имеется цикл for, в котором производится анализ имени каждого объекта.

      string Obj_Name = ObjectName(k); // Запрашиваем имя объекта

Признаком, отличающим "наши" объекты от всех других, является префикс "Paint_", с которого начинается имя каждого созданного программой объекта. Для анализа названия объекта необходимо извлечь из строковой переменной, являющейся уникальным именем объекта, начальную часть (в данном случае 6 символов), а затем сравнить полученное значение со значением переменной Prefix. Если обнаружится совпадение, то исследуемый объект подлежит удалению, если же нет, то объект удалять не нужно.

Функция StringSubstr()

string StringSubstr(string text, int start, int length=0)
Функция извлекает подстроку из текстовой строки, начинающейся c указанной позиции. Функция возвращает копию извлеченной подстроки, если возможно, иначе возвращается пустая строка.

Параметры:

text - строка, из которой должна быть извлечена подстрока;

start - начальная позиция подстроки. Может быть от 0 до StringLen(text)-1;

length - длина извлекаемой подстроки. Если значение параметра меньше или равно 0 либо параметр не задан, то будет извлекаться подстрока, начиная с указанной позиции и до конца строки.

В рассматриваемом примере извлечение подстроки из имени объекта выполняется так:

      string Head=StringSubstr(Obj_Name,0,6);// Извлекаем первые 6 сим

В данном случае из строковой переменной Obj_Name извлекаются первые 6 символов, начиная с нулевого. Обратите внимание, счёт любых индексов в MQL4 (баров, массивов), строк в списке ордеров, а также номер позиции в строке, начинается с 0, в то же время количественный счёт начинается с 1.

Извлечённая подстрока (значение типа string) присваивается строковой переменной Head. Если имя объекта (и сам объект) было создано рассматриваемым экспертом, то значение извлечённой подстроки будет таким: "Paint_". Если же анализируется другое имя, то искомое значение будет другим. Например, для имени объекта "StdDev Channel 23109" значение извлечённой подстроки будет таким: "StdDev", а для объекта с именем "Fibo 22800" - таким: "Fibo 2".

В последующих строках значение переменной Head сравнивается со значением переменной Prefix:

      if (Head == Prefix)              // Найден объект, ..
         {                             // .. начинающийся с Paint_

И если эти значения равны, то анализируемое имя объекта заносится в массив Name_Del[] имён объектов, назначенных к удалению. В следующем цикле for удаляются все объекты, имена которых содержатся в этом массиве (отдельно нужно заметить, что в первом цикле for удалять объекты нельзя, т.к. в этом случае после каждого удаления изменится общее количество объектов и их нумерация, в результате чего некоторые имена объектов будут пропущены).

Во время исполнения эксперта strings.mq4 ценовой график будет выглядеть так:

Рис. 142. Ценовой график раскрашен с помощью графических объектов (strings.mq4).

На Рис. 142 кроме группы объектов, покрывающих ценовой график, показаны два других объекта, установленные пользователем вручную, - канал регрессии и уровни Фибоначчи. После прекращения работы эксперта созданные им объекты будут удалены, а объекты, установленные пользователем, останутся в окне финансового инструмента. Указанный результат получен благодаря использованию в программе строковых функций, позволяющих создавать и анализировать строковые значения, в том числе, имена графических объектов.

Строковые функции

Функция | Краткое описание
StringConcatenate | Формирует строку из переданных параметров и возвращает её. Параметры могут иметь любой тип. Количество параметров не может превышать 64.
StringFind | Поиск подстроки. Возвращает номер позиции в строке, с которой начинается искомая подстрока, либо -1, если подстрока не найдена.
StringGetChar | Возвращает значение символа, расположенного в указанной позиции строки.
StringLen | Возвращает число символов в строке.
StringSetChar | Возвращает копию строки с измененным значением символа в указанной позиции.
StringSubstr | Извлекает подстроку из текстовой строки, начинающейся c указанной позиции. Функция возвращает копию извлеченной подстроки, если возможно, иначе возвращается пустая строка.
StringTrimLeft | Функция урезает символы перевода каретки, пробелы и символы табуляции в левой части строки. Функция возвращает копию преобразованной строки, если это возможно, в противном случае возвращается пустая строка.
StringTrimRight | Функция урезает символы перевода каретки, пробелы и символы табуляции в правой части строки. Функция возвращает копию преобразованной строки, если это возможно, в противном случае возвращается пустая строка.

Функции преобразования данных

Функция | Краткое описание
CharToStr | Преобразование кода символа в односимвольную строку.
DoubleToStr | Преобразование числового значения в текстовую строку, содержащую символьное представление числа в указанном формате точности.
NormalizeDouble | Округление числа с плавающей запятой до указанной точности. Рассчитываемые значения StopLoss, TakeProfit, а также значения цены открытия отложенных ордеров должны быть нормализованы с точностью, значение которой хранится в предопределенной переменной Digits.
StrToDouble | Преобразование строки, содержащей символьное представление числа, в число типа double (формат двойной точности с плавающей точкой).
StrToInteger | Преобразование строки, содержащей символьное представление числа, в число типа int (целое).
StrToTime | Преобразование строки, содержащей время и/или дату в формате "yyyy.mm.dd [hh:mi]", в число типа datetime (количество секунд, прошедших с 01.01.1970).
TimeToStr | Преобразование значения, содержащего время в секундах, прошедшее с 01.01.1970, в строку формата "yyyy.mm.dd hh:mi".

Для получения подробного описания этих и других функций необходимо обратиться к справочной документации на MQL4.community, сайте MetaQuotes Software Corp. или к разделу "Справка" в редакторе MetaEditor.

Операции с графикамиДата и время


Информация о счёте - Стандартные функции - Учебник по MQL4

Учебник по MQL4 [image] Стандартные функции [image] Информация о счёте
MetaQuotes Sofware Corp.
  • Общие функции
  • Графические объекты
  • Операции с графиками
  • Строковые функции
  • Дата и время
  • Файловые операции
  • Массивы и таймсерии
  • Математические функции
  • Глобальные переменные GlobalVariables
  • Пользовательские индикаторы
  • Информация о счёте
  • Торговые функции
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Информация о счёте

Функции клиентского терминала и проверки состояния удобно применять, например, для ограничения использования программ при коммерческом распространении. Рассмотрим, как может быть решена такая задача:

Задача 39. Представить защитный код программы, распространяемой на коммерческой основе, удовлетворяющий следующим требованиям:
  • для исполнения программы на реальных счетах индивидуальных клиентов требуется ввести пароль;
  • для исполнения программы на реальных счетах корпоративных клиентов пароль не требуется;
  • ограничения при исполнении программы на демо-счёте не предусмотрены.

В этом примере правильно сформулирована постановка задачи. Для успешного коммерческого распространения в распоряжение потенциальных потребителей необходимо предоставить программу, которая в полной мере может быть опробована на демо-счёте. При этом пользователь может оценить все достоинства программы и принять решение о её приобретении.

Применять один общий пароль для всех клиентов неправильно - в этом случае появляется риск несанкционированного распространения программы. Поэтому для индивидуальных клиентов пароль должен быть поставлен в зависимость от номера реального счёта. Для корпоративных клиентов (если дилинговый центр приобрёл лицензию для всех своих трейдеров) использовать пароль нет необходимости - программа должна сама определить, к какому серверу подключён клиентский терминал. И если это сервер корпоративного клиента, то необходимо предоставить любому пользователю возможность беспрепятственной работы.

Решение Задачи 39 для ограничения прав использования программ может быть таким (эксперт сheck.mq4):

//--------------------------------------------------------------------
// сheck.mq4
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------- 1 --
extern int Parol=12345;
//--------------------------------------------------------------- 2 --
int start()                            // Спец. функция start
  {
   if(Check()==false)                  // Если условия использования..
      return;                          // ..не выполняются, то выход

   // Здесь должен быть указан основной код программы
   Alert("Исполнение программы");      // Алерт для примера

   return;                             // Выход из start()
  }
//--------------------------------------------------------------- 3 --
bool Check()                           // Пользов. функция проверки ..
  {                                    // .. условий использования
   if (IsDemo()==true)                 // Если это демо-счёт, то..
      return(true);                    // .. других ограничений нет
   if (AccountCompany()=="SuperBank")  // Для корпоративных клиентов..
      return(true);                    // ..пароль не нужен
   int Key=AccountNumber()*2+1000001;  // Вычисляем ключ
   if (Parol==Key)                     // Если пароль верный, то..
      return(true);                    // ..разрешаем работу на реале
   Alert("Неправильный пароль. Эксперт не работает.");
   return(false);                      // Выход из пользов. функции
  }
//--------------------------------------------------------------- 4 --

В данном примере необходимая проверка выполняется в первых строках специальной функции start (блок 2-3):

   if(Check()==false)                  // Если условия использования..

Если в результате выполнения проверки пользовательская функция Check() (блок 3-4) вернула false, то управление передаётся на оператор return и специальная функция start() заканчивает работу. Основной код программы располагается непосредственно после указанной проверки. В результате успешной проверки функция Check() вернёт true, в этом случае основной код программы будет исполнен.

В пользовательской функции Check() выполняется проверка по трём критериям:
- является ли счёт демонстрационным;
- принадлежит ли сервер корпоративному клиенту;
- подходит ли пароль к реальному счёту.

Для проверки по первому критерию используется функция IsDemo().

Функция IsDemo()

bool IsDemo()

Функция возвращает TRUE, если программа работает на демонстрационном счете, в противном случае возвращает FALSE.

Если функция IsDemo() возвращает true, то пользователь работает на демо-счёте. Это значит, что выполнять другие проверки нет необходимости (т.к. опробование программы на демо-счёте позволено для всех желающих). В этом случае функция Check() прекращает работу, и возвращает значение true:

   if (IsDemo() == true)               // Если это демо-счёт, то..
      return(true);                    // .. других ограничений нет

Если же в функция IsDemo() вернёт значение false, значит, пользователь работает на реальном счёте. В этом случае необходимо выяснить, достаточно ли у пользователя прав. В данном примере сначала выполняется проверка корпоративных клиентов, для этого используется функция AccountCompany().

Функция AccountCompany()

 string AccountCompany()

Функция возвращает название брокерской компании, в которой зарегистрирован текущий счет.

Если в результате выполнения проверки:

   if (AccountCompany() == "SuperBank")// Для корпоративных клиентов..
      return(true);                    // ..пароль не нужен

установлено, что название компании совпадает с тем, что указано в программе, то функция Check() закончит работу и вернёт true - проверка закончена успешно. Если же оказывается, что клиент подключен к другой компании (не являющейся корпоративным клиентом), то необходимо выяснить имеет ли он индивидуальную лицензию.

В строке:

   int Key = AccountNumber()*2+1000001;// Вычисляем ключ

в программу заложен алгоритм вычисления ключа для любого номера счёта. В данном примере это простой способ. Программист по своему усмотрению может ввести в программу другой, более сложный способ вычисления ключа. В любом случае алгоритм вычисления ключа должен учитывать номер счёта, который доступен программе через функцию AccountNumber().

Функция AccountNumber()

 int AccountNumber()

Функция возвращает номер текущего счета.

Ранее вычисленный по тому же алгоритму пароль передаётся пользователю. Если в результате проверки оказывается, что пароль и ключ совпадают, то функция Check() прекращает работу и возвращает значение true:

   if (Parol == Key)                   // Если пароль верный, то..
      return(true);                    // ..разрешаем работу на реале

Если ни одна из проверок не закончилась успешно, это означает, что пользователь не имеет права применения данной программы на реальном счёте. В этом случае, после соответствующего уведомления, функция Check() прекращает работу и возвращает значение false. Таким образом пресекается попытка несанкционированного использования программы.

Функции, возвращающие информацию о клиентском терминале

Функция | Краткое описание
TerminalCompany | Возвращает наименование компании-владельца клиентского терминала.
TerminalName | Возвращает имя клиентского терминала.
TerminalPath | Возвращает директорий, из которого запущен клиентский терминал.

Функции, позволяющие определить текущее состояние клиентского терминала, в том числе состояние окружения выполняемой MQL4-программы

Функция | Краткое описание
GetLastError | Функция возвращает код последней ошибки, после чего значение специальной переменной last_error, в которой хранится код последней ошибки, обнуляется. Так что последующий вызов GetLastError() вернет значение 0.
IsConnected | Возвращает состояние главного соединения клиентского терминала с сервером, по которому производится подкачка данных. TRUE - связь с сервером установлена, FALSE - связь с сервером отсутствует или прервана.
IsDemo | Возвращается TRUE, если программа работает на демонстрационном счете, в противном случае возвращает FALSE.
IsDllsAllowed | Возвращает TRUE, если DLL вызов функции разрешены для эксперта, иначе возвращает FALSE.
IsExpertEnabled | Возвращает TRUE, если в клиентском терминале разрешен запуск экспертов, иначе возвращает FALSE.
IsLibrariesAllowed | Возвращает TRUE, если эксперт может назвать библиотечную функцию, иначе возвращает FALSE.
IsOptimization | Возвращается TRUE, если эксперт работает в режиме оптимизации тестирования, иначе возвращает FALSE.
IsStopped | Возвращается TRUE, если программа (эксперт или скрипт) получила команду на завершение своей работы, иначе возвращает FALSE.
IsTesting | Возвращается TRUE, если эксперт работает в режиме тестирования, иначе возвращает FALSE.
IsTradeAllowed | Возвращается TRUE, если эксперту разрешено торговать и поток для выполнения торговых операций свободен, иначе возвращает FALSE.
IsTradeContextBusy | Возвращается TRUE, если поток для выполнения торговых операций занят, иначе возвращает FALSE.
IsVisualMode | Возвращается TRUE, если эксперт тестируется в режиме визуализации, иначе возвращает FALSE.
UninitializeReason | Возвращает код причины завершения экспертов, пользовательских индикаторов и скриптов. Возвращаемые значения могут быть одним из кодов деинициализации. Эту функцию можно также вызывать в функции init() для анализа причин деинициализации предыдущего запуска.

Функции для доступа к информации об активном счете

Функция | Краткое описание
AccountBalance | Возвращает значение баланса активного счета (сумма денежных средств на счете).
AccountCredit | Возвращает значение кредита для активного счета.
AccountCompany | Возвращает название брокерской компании, в которой зарегистрирован текущий счет.
AccountCurrency | Возвращает наименование валюты для текущего счета.
AccountEquity | Возвращает сумму собственных средств для текущего счета. Расчет equity зависит от настроек торгового сервера.
AccountFreeMargin | Возвращает значение свободных средств, разрешенных для открытия позиций на текущем счете.
AccountFreeMarginCheck | Возвращает размер свободных средств, которые останутся после открытия указанной позиции по текущей цене на текущем счете.
AccountFreeMarginMode | Режим расчета свободных средств, разрешенных для открытия позиций на текущем счете.
AccountLeverage | Возвращает значение плеча для текущего счета.
AccountMargin | Возвращает сумму залоговых средств, используемых для поддержания открытых позиций на текущем счете.
AccountName | Возвращает имя пользователя текущего счета.
AccountNumber | Возвращает номер текущего счета.
AccountProfit | Возвращает значение прибыли для текущего счета в базовой валюте.
AccountServer | Возвращает имя активного сервера.
AccountStopoutLevel | Возвращает значение уровня, по которому определяется состояние Stop Out.
AccountStopoutMode | Возвращает режим расчета уровня Stop Out.

Для получения подробного описания этих и других функций необходимо обратиться к справочной документации на MQL4.community, сайте MetaQuotes Software Corp. или к разделу "Справка" в редакторе MetaEditor.

Пользовательские индикаторыТорговые функции


Массивы и таймсерии - Стандартные функции - Учебник по MQL4

Учебник по MQL4 [image] Стандартные функции [image] Массивы и таймсерии
MetaQuotes Sofware Corp.
  • Общие функции
  • Графические объекты
  • Операции с графиками
  • Строковые функции
  • Дата и время
  • Файловые операции
  • Массивы и таймсерии
  • Математические функции
  • Глобальные переменные GlobalVariables
  • Пользовательские индикаторы
  • Информация о счёте
  • Торговые функции
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Массивы и таймсерии

При работе с массивами очень важно помнить, что в MQL4 нумерация любой последовательности однотипных элементов начинается с нуля.

Ранее указывалось, что не следует путать максимальное значение индекса элемента массива с количеством элементов этого массива (см. Массивы). Например, если объявлен массив:

  int Erray_OHL[3];         // Объявление массива

то это значит, что одномерный массив (имеющий одно измерение) с именем Erray_OHL состоит из трёх элементов. Индексация элементов массива начинается с нуля, т.е. первый из трёх элементов имеет индекс 0 (Erray_OHL[0]), второй элемент - индекс 1 (Erray_OHL[1 ]), а третий элемент - индекс 2 (Erray_OHL[2 ]). Таким образом, максимальное значение индекса элемента массива на единицу меньше, чем количество элементов в этом измерении. В данном случае массив является одномерным, т.е можно говорить о количестве элементов в первом измерении: поскольку количество элементов в массиве равно 3, значит максимальное значение индекса равно 2.

То же можно сказать и о нумерации измерений массива. Например, если объявлен массив:

  int Erray_OHL[3][8];      // Объявление массива

то это значит, что массив имеет два измерения. Первое измерение этого массива определяет количество строк (в данном примере 3), а второе измерение - количество элементов в строке (или, что то же самое, количество столбцов, в данном примере 8). Сами измерения также нумеруется. Первое измерение имеет номер 0, а второе измерение - номер 1. Номера измерений используются, например, в функции ArrayRange().

Функция ArrayRange()

 int ArrayRange(object array[], int range_index)

Функция возвращает число элементов в указанном измерении массива.

Использование функции ArrayRange() можно продемонстрировать при решении следующей задачи:

Задача 38. Значения элементов матрицы 3х5 содержатся в массиве Mas_1. Получить значения массива Mas_2, значения элементов в котором равны значениям транспонированной матрицы. Использовать произвольные значения элементов.

Зададимся некоторыми значениями элементов и представим исходную и искомую матрицы, содержащиеся, соответственно, в массивах Mas_1 и Mas_2:

Индексы | 0 | 1 | 2 | 3 | 4
0 | 1 | 2 | 3 | 4 | 5
1 | 11 | 12 | 13 | 14 | 15
2 | 21 | 22 | 23 | 24 | 25

Индексы | 0 | 1 | 2
0 | 1 | 11 | 21
1 | 2 | 12 | 22
2 | 3 | 13 | 23
3 | 4 | 14 | 24
4 | 5 | 15 | 25
Исходная матрица, массив Mas_1. Транспонированная матрица, массив Mas_2.

Рис. 151. Исходная и транспонированная матрицы.

В данном случае вся задача сводится к тому, чтобы переписать значения одного массива в другой, соблюдая при этом правила транспонирования матрицы, а именно, значения элементов, содержащихся в столбцах исходного массива, переписать в строки искомого массива. Решение задачи транспонирование матрицы реализовано в эксперте matrix.mq4:

//--------------------------------------------------------------------
// matrix.mq4
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------- 1 --
int start()                            // Спец. функция start
  {
   int Mas_1[3][5]={1,2,3,4,5,  11,12,13,14,15,  21,22,23,24,25};
   int Mas_2[5][3];
   int R0= ArrayRange( Mas_1, 0);      // Число элементов в первом изм
   int R1= ArrayRange( Mas_1, 1);      // Число элементов в втором изм

   for(int i=0; i

В функции start() эксперта открыты два массива. Массив Mas_1 имеет 3 строки по 5 элементов в каждой строке, а массив Mas_2 - 5 строк по 3 элемента в строке. Собственно перезапись значений элементов из одного массива в другой выполняется в строке:

         Mas_2[[j][i] = Mas_1[i][j];    // Транспонирование матрицы

Для того чтобы определить условия выполнения (количество итераций) двух вложенных операторов цикла, необходимо знать значения элементов в каждом из массивов. В данном примере можно было бы использовать значения констант 3 и 5. Однако такой способ составления программ является некорректным. В общем случае программа может содержать объёмный код, во многих местах которого выполняется обращение к одним и тем же значениям. Программа должна быть составлена так, чтобы при необходимости внесения изменений исправления можно было бы сделать в одном месте, а во всех других местах все необходимые значения вычислялись. В данном случае, если необходимо будет изменить размеры массивов, то исправления нужно внести только в строки, в которых эти массивы открываются и инициализируются, и не придётся править код нигде в других местах.

Для определения количества элементов в первом и втором измерении массива Mas_1 выполняются вычисления:

   int R0 =  ArrayRange( Mas_1, 0);    // Число элементов в первом изм
   int R1 =  ArrayRange( Mas_1, 1);    // Число элементов в втором изм

Обратите внимание, для первого измерения используется значение 0, а для второго 1. Вычисленные значения переменных R0 и R1 используются для определения количества итераций в циклах for.

Полученные значения элементов массива Mas_2 выводятся на экран с помощью функции Comment().

Рис. 152. Результат работы эксперта matrix.mq4.

Функции для работы с массивами

Функция | Краткое описание
ArrayBsearch | Возвращает индекс первого найденного элемента в первом измерении массива. Если элемент с указанным значением в массиве отсутствует, функция вернет индекс ближайшего элемента (по значению).
ArrayCopy | Копирует один массив в другой. Массивы должны иметь одинаковый тип. Массивы типа double[], int[], datetime[], color[], и bool[], можно копировать как массивы одного типа. Возвращает количество скопированных элементов.
ArrayCopyRates | Копирует в двухмерный массив, вида RateInfo[][6], данные баров текущего графика и возвращает количество скопированных баров, либо -1 в случае неудачи.
ArrayCopySeries | Копирует массив-таймсерию в пользовательский массив и возвращает количество скопированных элементов.
ArrayDimension | Возвращает ранг многомерного массива.
ArrayGetAsSeries | Возвращается TRUE, если массив организован как таймсерия (элементы массива индексируются от последнего к первому), иначе возвращается FALSE.
ArrayInitialize | Устанавливает все элементы числового массива в одну величину. Возвращает количество инициализированных элементов.
ArrayIsSeries | Возвращается TRUE, если проверяемый массив является массивом-таймсерией (Time[], Open[],Close[],High[],Low[] или Volume[]), иначе возвращается FALSE.
ArrayMaximum | Поиск элемента с максимальным значением. Функция возвращает позицию максимального элемента в массиве.
ArrayMinimum | Поиск элемента с минимальным значением. Функция возвращает позицию минимального элемента в массиве.
ArrayRange | Возвращает число элементов в указанном измерении массива. Поскольку индексы начинаются с нуля, размер измерения на 1 больше, чем самый большой индекс.
ArrayResize | Устанавливает новый размер в первом измерении массива. При успешном выполнении функция возвращает количество всех элементов, содержащихся в массиве после изменения размера, в противном случае возвращает -1, и массив не меняет размеры.
ArraySetAsSeries | Устанавливает направление индексирования в массиве.
ArraySize | Возвращает количество элементов массива.
ArraySort | Сортировка числовых массивов по первому измерению. Массивы-таймсерии не могут быть отсортированы.

Функции доступа к таймсериям

Функция | Краткое описание
iBars | Возвращает количество баров на определенном графике.
iBarShift | Поиск бара по времени. Функция возвращает смещение бара, которому принадлежит указанное время. Если для указанного времени бар отсутствует ("дыра" в истории), то функция возвращает, в зависимости от параметра exact, -1 или смещение ближайшего бара.
iClose | Возвращает значение цены закрытия указанного параметром shift бара с соответствующего графика (symbol, timeframe). В случае ошибки функция возвращает 0.
iHigh | Возвращает значение максимальной цены указанного параметром shift бара с соответствующего графика (symbol, timeframe). В случае ошибки функция возвращает 0.
iHighest | Возвращает индекс найденного наибольшего значения (смещение относительно текущего бара).
iLow | Возвращает значение минимальной цены указанного параметром shift бара с соответствующего графика (symbol, timeframe). В случае ошибки функция возвращает 0.
iLowest | Возвращает индекс найденного наименьшего значения (смещение относительно текущего бара).
iOpen | Возвращает значение цены открытия указанного параметром shift бара с соответствующего графика (symbol, timeframe). В случае ошибки функция возвращает 0.
iTime | Возвращает значение времени открытия указанного параметром shift бара с соответствующего графика (symbol, timeframe). В случае ошибки функция возвращает 0.
iVolume | Возвращает значение тикового объема указанного параметром shift бара с соответствующего графика (symbol, timeframe). В случае ошибки функция возвращает 0.

Для получения подробного описания этих и других функций необходимо обратиться к справочной документации на MQL4.community, сайте MetaQuotes Software Corp. или к разделу "Справка" в редакторе MetaEditor.

Файловые операцииМатематические функции


Торговые функции - Стандартные функции - Учебник по MQL4

Учебник по MQL4 [image] Стандартные функции [image] Торговые функции
MetaQuotes Sofware Corp.
  • Общие функции
  • Графические объекты
  • Операции с графиками
  • Строковые функции
  • Дата и время
  • Файловые операции
  • Массивы и таймсерии
  • Математические функции
  • Глобальные переменные GlobalVariables
  • Пользовательские индикаторы
  • Информация о счёте
  • Торговые функции
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Торговые функции

Все торговые функции можно разделить на две группы - функции, формирующие торговые приказы, и функции, возвращающие некоторое значение, характеризующее ордер. В MQL4 имеются всего пять функций, которые формируют и отправляют на сервер торговые приказы:

  • OrderSend() - открытие рыночного ордера и установка отложенного ордера;
  • OrderClose() - закрытие рыночного ордера;
  • OrderCloseBy() - встречное закрытие двух разнонаправленных рыночных ордеров;
  • OrderDelete() - удаление отложенного ордера;
  • OrderModify() - модификация ордеров всех видов.

Порядок использования указанных функций подробно рассматривался в главе Программирование торговых операций. Все другие функции не формируют торговых приказов, но их применение очень часто бывает востребованным. Например, в ряде случаев ордера требуется закрыть в порядке некоторого приоритета. Для этого в программе необходимо проанализировать характеристики каждого из ордеров, а именно, - тип ордера, количество лотов, положение стоп-приказов и т.д. Рассмотрим некоторые функции, позволяющие получить информацию об ордере.

Функция OrderTotal()

int OrdersTotal()

Функция возвращает общее количество открытых и отложенных ордеров.

Функция OrderTakeProfit()

double OrderTakeProfit()

Функция возвращает значение заявленной цены закрытия позиции при достижении уровня прибыльности (take profit) для текущего выбранного ордера. Ордер должен быть предварительно выбран с помощью функции OrderSelect().

Функция OrderProfit()

double OrderProfit()

Возвращает значение чистой прибыли (без учёта свопов и комиссий) для выбранного ордера. Для открытых позиций это - текущая нереализованная прибыль. Для закрытых ордеров - зафиксированная прибыль. Ордер должен быть предварительно выбран с помощью функции OrderSelect().

Функция OrderLots()

double OrderLots()

Возвращает количество лотов для выбранного ордера. Ордер должен быть предварительно выбран с помощью функции OrderSelect().

Ниже представлен фрагмент программы, в котором вычисляются заявленная цена закрытия TakeProfit, прибыль по ордеру и количество лотов:

for (int i=0; i<OrdersTotal(); i++)         // По всем ордерам
  {
   if((OrderSelect(i,SELECT_BY_POS)==true)  // Если есть следующ.
     {
      double ТР =    OrderTakeProfit();     // TakeProfit ордера
      double Profit= OrderProfit();         // Прибыль по ордеру
      double Lots  = OrderLots();           // Количество лотов
      //......Использование значений ТР и Profit в программе.....
     }
  }                                         // Конец тела цикла

Легко заметить, что каждая из рассматриваемых функций (OrderTakeProfit (), OrderProfit() и OrderLots() не имеет настраиваемых параметров, т.е. не предусматривает указание, например, номера ордера, чтобы возвращаемое функцией значение соответствовало характеристике конкретного ордера.

Чтобы вычислить искомые характеристики какого-то одного ордера (в данном случае - заявленную цену одного из стоп-приказов, прибыль по ордеру и количество лотов), сначала необходимо выделить этот ордер, сообщив таким способом программе, для какого именно из ордеров будут производиться вычисления. Для этого перед вычислениями характеристик ордера, нужно исполнить функцию OrderSelect() (см. Закрытие и удаление ордеров). Торговые функции, исполненные после этого, будут возвращать значения, соответствующие характеристикам выбранного ордера.

Немаловажное значение имеет правильная оценка программистом той или иной характеристики ордера. Например, при решении задачи о порядке закрытия ордеров, необходимо задаться какими-то критериями, чтобы вычислить, какой из ордеров необходимо закрыть раньше, а какой после. Рассмотрим небольшую задачу.

Задача 40. В торговле имеются два ордера Buy, открытых по одному финансовому инструменту. Первый ордер открыт по цене 1.2000, на 0.5 лота, второй ордер открыт по цене 1. 3000 на 1 лот. Текущая цена 1.3008. Сработал торговый критерий закрытия ордеров типа Buy. Требуется принять правильное решение, а именно, решить какой из ордеров нужно закрыть первым, а какой - вторым.

Очевидно, что прибыль по первому ордеру составляет 108 пунктов, а по второму 8. Несмотря на то, что первый ордер открыт на меньшее количество лотов, прибыль у него больше, чем у второго, а именно, у первого $540, а у второго $80. На первый взгляд может показаться, что сначала нужно закрыть первый ордер, т.к. у него больше прибыли. Однако это решение является ошибочным. Для принятия правильного решения необходимо рассмотреть возможный сценарий развития событий.

Если бы заранее было точно известно, что в течение периода закрытия ордеров цена не изменится, то порядок закрытия ордеров не имел бы значения. Однако за то время, пока исполняется торговый приказ на закрытие одного из ордеров, цена может измениться. Поэтому, закрыть следует тот ордер, который при неблагоприятном развитии событий принесёт больше вреда. При изменении цены на 1 пункт прибыль по первому ордеру уменьшится на $5, а по второму - на $10. Очевидно, что вреда будет больше от второго ордера, т.е. его и следует закрыть первым. Таким образом, в вопросе о порядке закрытия ордеров определяющее значение имеет количество лотов. Благоприятное развитие событий в данном случае рассматривать нельзя, т.к. торговля в правильно составленной программе ведётся в соответствии с торговыми критериями, и в данном случае сработал критерий закрытия ордеров типа Buy.

Если необходимо сделать выбор между двумя ордерами, открытыми на одинаковое количество лотов, то следует принять во внимание другие характеристики ордеров. Например, можно учитывать дистанцию между текущей ценой и заявленным значением StopLoss каждого из ордеров. При этом необходимо проанализировать, какой из ордеров принесёт больше вреда при сильном движении цены. Ответ также очевиден - больше вреда будет от того ордера (из двух ордеров, открытых на одинаковое количество лотов), StopLoss которого находится дальше от текущей цены.

Подобным образом можно проанализировать важность и всех других характеристик ордера и составить приоритетный список критериев, которые должны приниматься во внимание при решении задачи закрытия ордеров. Нетрудно также определить и критерии, которые не должны рассматриваться. Таким критерием является, например, цена открытия ордера (и зависимая от неё прибыль по ордеру). Количество денежных средств, имеющихся у трейдера на текущий момент, отражается в клиентском терминале в графе Средства. При этом не важно, каким образом было получено это значение - то ли в результате убытка по одному или нескольким рыночным ордерам, то ли в результате прибыли.

Все необходимые характеристики ордера можно получить, исполнив соответствующие торговые функции:

Торговые функции

Функция | Краткое описание
Ошибки исполнения | Любая торговая операция (функции OrderSend, OrderClose, OrderCloseBy, OrderDelete или OrderModify) по ряду причин может завершиться неудачей и вернуть либо отрицательный номер тикета, либо FALSE. Причину неудачи можно выяснить, вызвав функцию GetLastError. Каждая ошибка должна быть обработана по-своему. Ниже в таблице приведены общие рекомендации.
OrderClose | Закрытие позиции. Возвращает TRUE при успешном завершении функции. Возвращает FALSE при неудачном завершении функции.
OrderCloseBy | Закрытие одной открытой позиции другой позицией, открытой по тому же самому инструменту, но в противоположном направлении. Возвращает TRUE при успешном завершении функции. Возвращает FALSE при неудачном завершении функции.
OrderClosePrice | Возвращает цену закрытия выбранного ордера.
OrderCloseTime | Возвращает время закрытия для выбранного ордера.
OrderComment | Возвращает комментарий для выбранного ордера.
OrderCommission | Возвращает значение рассчитанной комиссии для выбранного ордера.
OrderDelete | Удаляет ранее установленный отложенный ордер. Возвращает TRUE при успешном завершении функции. Возвращает FALSE при неудачном завершении функции.
OrderExpiration | Возвращает дату истечения для выбранного отложенного ордера.
OrderLots | Возвращает количество лотов для выбранного ордера.
OrderMagicNumber | Возвращает идентификационное ("магическое") число для выбранного ордера.
OrderModify | Изменяет параметры ранее открытых позиций или отложенных ордеров. Возвращает TRUE при успешном завершении функции. Возвращает FALSE при неудачном завершении функции.
OrderOpenPrice | Возвращает цену открытия для выбранного ордера.
OrderOpenTime | Возвращает время открытия выбранного ордера.
OrderPrint | Выводит данные ордера в журнал.
OrderProfit | Возвращает значение чистой прибыли (без учёта свопов и комиссий) для выбранного ордера. Для открытых позиций это - текущая нереализованная прибыль. Для закрытых ордеров - зафиксированная прибыль.
OrderSelect | Функция выбирает ордер для дальнейшей работы с ним. Возвращает TRUE при успешном завершении функции. Возвращает FALSE при неудачном завершении функции.
OrderSend | Основная функция, используемая для открытия позиции или установки отложенного ордера. Возвращает номер тикета, который назначен ордеру торговым сервером или -1 в случае неудачи.
OrdersHistoryTotal | Возвращает количество закрытых позиций и удаленных ордеров в истории текущего счета, загруженной в клиентском терминале.
OrderStopLoss | Возвращает значение цены закрытия позиции при достижении уровня убыточности (stop loss) для текущего выбранного ордера.
OrdersTotal | Возвращает общее количество открытых и отложенных ордеров.
OrderSwap | Возвращает значение свопа для текущего выбранного ордера.
OrderSymbol | Возвращает наименование финансового инструмента для текущего выбранного ордера.
OrderTakeProfit | Возвращает значение цены закрытия позиции при достижении уровня прибыльности (take profit) для текущего выбранного ордера.
OrderTicket | Возвращает номер тикета для текущего выбранного ордера.
OrderType | Возвращает тип операции текущего выбранного ордера.

Для получения подробного описания этих и других функций необходимо обратиться к справочной документации на MQL4.community, сайте MetaQuotes Software Corp. или к разделу "Справка" в редакторе MetaEditor.

Информация о счётеСоздание обычной программы


Функция определения торговых критериев - Создание обычной программы - Учебник по MQL4

Учебник по MQL4 [image] Создание обычной программы [image] Функция определения торговых критериев
MetaQuotes Sofware Corp.
  • Структура обычной программы
  • Учёт ордеров
  • Информационная функция
  • Функция слежения за событиями
  • Функция определения количества лотов
  • Функция определения торговых критериев
  • Торговые функции
  • Функция обработки ошибок
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Функция определения торговых критериев

Успешность любой торговой стратегии главным образом зависит от порядка вычисления торговых критериев. Функция определения торговых критериев является наиболее важной частью программы и должна использоваться обязательно. В зависимости от содержания торговой стратегии функция может возвращать значения, соответствующие тем или иным торговым критериям.

В общем случае могут быть определены следующие критерии:

  • критерий для открытия рыночного ордера;
  • критерий для закрытия рыночного ордера;
  • критерий для частичного закрытия рыночного ордера;
  • критерий для встречного закрытия рыночных ордеров;
  • критерий для модификации заявленных цен стоп-приказов рыночного ордера;
  • критерий для установки отложенного ордера;
  • критерий для удаления отложенного ордера;
  • критерий для модификации заявленной цены открытия отложенного ордера;
  • критерий для модификации заявленных цен стоп-приказов отложенного ордера.

В большинстве случаев срабатывание одних торговых критериев является взаимоисключающим по отношению к другим критериям. Например, если в некоторый момент значимым является критерий для открытия ордера Buy, то это означает, что в этот же момент критерии для закрытия Buy и открытия Sell значимыми быть не могут (см. Отношение торговых критериев). В то же время, в соответствии с правилами торговой стратегии, некоторые критерии могут срабатывать одновременно. Например, одновременно могут оказаться значимыми критерии для закрытия рыночного ордера Sell и модификации отложенного ордера BuyStop.

Торговая стратегия накладывает требования к содержанию и технологии использования функции определения торговых критериев. Любая функция может возвращать только одно значение. Поэтому, если в эксперте реализована стратегия, предполагающая использование только взаимоисключающих торговых критериев, то возвращаемое функцией значение может быть поставлено в соответствие одному из критериев. Если же стратегия допускает срабатывание одновременно нескольких критериев, то их значения необходимо передавать для обработки другим функциям, используя для этого глобальные переменные.

Торговая стратегия, реализованная в рассматриваемом эксперте, предполагает использование только взаимоисключающих критериев. Поэтому в представленной здесь функции Criterion() для передачи вычисленных критериев другим функциям используется значение, возвращаемое функцией.

Пользовательская функция Criterion()

int Criterion()

Функция вычисляет торговые критерии. Функция возвращает следующие значения:
10 - сработал торговый критерий для открытия рыночного ордера Buy;
20 - сработал торговый критерий для открытия рыночного ордера Sell;
11 - сработал торговый критерий для закрытия рыночного ордера Buy;
21 - сработал торговый критерий для закрытия рыночного ордера Sell;
0 - значимых критериев нет;
-1 - используемый финансовый инструмент не является EURUSD.

Функция использует значения следующих внешних переменных:
St_min - нижний уровень индикатора Stochastic Oscillator;
St_max - верхний уровень индикатора Stochastic Oscillator;
Open_Level - уровень индикатора MACD (для открытия ордеров);
Close_Level - уровень индикатора MACD (для закрытия ордеров).

Для вывода сообщений функция предполагает использование информационной функции Inform(). В случае, если функция Inform() не включена в эксперт, сообщения не выводятся.

Функция определения торговых критериев Criterion() оформлена в виде включаемого файла Criterion.mqh:

//--------------------------------------------------------------------
// Criterion.mqh
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------- 1 --
// Функция вычисления торговых критериев.
// Возвращаемые значения:
// 10 - открытие Buy
// 20 - открытие Sell
// 11 - закрытие Buy
// 21 - закрытие Sell
// 0  - значимых критериев нет
// -1 - используется другой финансовый инструмент
//--------------------------------------------------------------- 2 --
// Внешние переменные:
extern int St_min=30;                  // Миним.  уровень стохастика
extern int St_max=70;                  // Максим. уровень стохастика
extern double Open_Level =5;           // Уровень MACD для откр.(+/-)
extern double Close_Level=4;           // Уровень MACD для закр.(+/-)
//--------------------------------------------------------------- 3 --
int Criterion()                        // Пользовательская функция
  {
   string Sym="EURUSD";
   if (Sym!=Symbol())                  // Если не наш фин. инструмент
     {
      Inform(16);                      // Сообщение..
      return(-1);                      // .. и выход
     }
   double
   M_0, M_1,                           // Значение MAIN на 0 и 1 барах
   S_0, S_1,                           // Значение SIGNAL на 0 и 1 бар
   St_M_0, St_M_1,                     // Значение MAIN на 0 и 1 барах
   St_S_0, St_S_1;                     // Значение SIGNAL на 0 и 1 бар
   double Opn=Open_Level*Point;        // Уровень откр. MACD (пунктов)
   double Cls=Close_Level*Point;       // Уровень закр. MACD (пунктов)
//--------------------------------------------------------------- 4 --
   // Параметры технич. индикат:
   M_0=iMACD(Sym,PERIOD_H1,12,26,9,PRICE_CLOSE,MODE_MAIN,0); // 0 бар
   M_1=iMACD(Sym,PERIOD_H1,12,26,9,PRICE_CLOSE,MODE_MAIN,1); // 1 бар
   S_0=iMACD(Sym,PERIOD_H1,12,26,9,PRICE_CLOSE,MODE_SIGNAL,0);//0 бар
   S_1=iMACD(Sym,PERIOD_H1,12,26,9,PRICE_CLOSE,MODE_SIGNAL,1);//1 бар

   St_M_0=iStochastic(Sym,PERIOD_M15,5,3,3,MODE_SMA,0,MODE_MAIN,  0);
   St_M_1=iStochastic(Sym,PERIOD_M15,5,3,3,MODE_SMA,0,MODE_MAIN,  1);
   St_S_0=iStochastic(Sym,PERIOD_M15,5,3,3,MODE_SMA,0,MODE_SIGNAL,0);
   St_S_1=iStochastic(Sym,PERIOD_M15,5,3,3,MODE_SMA,0,MODE_SIGNAL,1);
//--------------------------------------------------------------- 5 --
   // Вычисление торговых критериев
   if(M_0>S_0 && -M_0>Opn && St_M_0>St_S_0 && St_S_0<St_min)
      return(10);                      // Открытие Buy
   if(M_0<S_0 &&  M_0>Opn && St_M_0<St_S_0 && St_S_0>St_max)
      return(20);                      // Открытие Sell
   if(M_0<S_0 &&  M_0>Cls && St_M_0<St_S_0 && St_S_0>St_max)
      return(11);                      // Закрытие Buy
   if(M_0>S_0 && -M_0>Cls && St_M_0>St_S_0 && St_S_0<St_min)
      return(21);                      // Закрытие Sell
//--------------------------------------------------------------- 6 --
   return(0);                          // Выход из пользов. функции
  }
//--------------------------------------------------------------- 7 --

В блоке 1-2 описаны значения, возвращаемые функцией. В блоке 2-3 объявлены некоторые внешние переменные. Включаемый файл Criterion.mqh - единственный файл, используемый в рассматриваемом эксперте, в котором объявлены глобальные (в данном случае - внешние) переменные. В разделе Структура обычной программы приведены причины, указывающие на необходимость объявления всех без исключения глобальных переменных в отдельном файле Variables.mqh. В данном случае внешние переменные объявлены в файле Criterion.mqh по двум причинам: во-первых, для того, чтобы продемонстрировать техническую возможность (такая возможность бывает не всегда), во-вторых, для того, чтобы показать, как можно использовать внешние переменные в период отладки и тестирования программы.

Техническая возможность объявления внешних переменных в файле Criterion.mqh существует потому, что эти переменные ни в каких других функциях программы не используются. Значения внешних переменных, объявленных в блоке 2-3, определяют уровни для индикаторов Stochastic Oscillator и MACD и используются только в рассматриваемой функции Criterion(). Объявление внешних переменных в файле, содержащем функцию определения торговых критериев, может быть оправданно в случае, если файл с таким содержанием используется временно, а именно, в течение периода отладки программы и вычисления оптимальных значений этих внешних переменных. Для этой цели можно ввести и другие внешние переменные, например, для оптимизации параметров индикаторов (в данном случае константами заданы значения 12,26,9 для MACD и 5,3,3 для Stochastic Oscillator). По окончании работы над программой указанные внешние переменные могут быть удалены из программы, а вместо них в программе должны использоваться константы со значениями, вычисленными во время оптимизации.

В блоке 3-4 открыты и описаны локальные переменные. Эксперт предназначен для использования на финансовом инструменте EURUSD, поэтому в блоке 3-4 выполняется необходимая проверка. Если эксперт запущен в окне другого финансового инструмента, то функция заканчивает работу и возвращает значение -1 (не тот инструмент).

В программе используются значения двух индикаторов, вычисленные на текущем и предыдущем барах (блок 4-5). При обычном применении индикаторов Stochastic Oscillator и MACD сигналы на покупку и продажу образуются в момент пересечения двух индикаторных линий. В данном случае для определения торговых критериев используются одновременно два индикатора. Вероятность того, что в некоторый момент времени произойдёт пересечение индикаторных линий одновременно в двух индикаторах, очень невелика. Более вероятно, что пересечения могут произойти последовательно одно за другим - сначала в одном индикаторе, а несколько позднее - в другом. В случае, если пересечения индикаторных линий происходят через небольшой промежуток времени, можно считать, что вместе два индикатора сформировали торговый критерий.

Например, критерий на покупку вычисляется так (блок 5-6):

if(M_0>S_0 && -M_0>Opn && St_M_0>St_S_0 && St_S_0<St_min)

В соответствии с этой записью, критерий на покупку является значимым, если соблюдаются условия:

  • в индикаторе MACD индикаторная линия MAIN (гистограмма) находится выше индикаторной линии SIGNAL и при этом находится ниже нижнего уровня Open_Level (рис. 157);
  • в индикаторе Stochastic Oscillator индикаторная линия MAIN находится выше индикаторной линии SIGNAL и при этом находится ниже минимального уровня St_min (рис. 158).

Рис. 157. Необходимое условие положения индикаторных линий MACD для подтверждения факта значимости торговых критериев для открытия и закрытия ордеров.

В левой части рис. 157 показано положение индикаторных линий MACD, при котором срабатывают два критерия - открытие Buy и закрытие Sell. Индикаторная линия MAIN находится ниже уровня 0.0005 в период времени T1 = t 1 - t 0. Если в этот период сложатся необходимые показания индикатора Stochastic Oscillator, то сработает критерий для открытия Buy. В течение времени T2 = t 2 - t 0 линия MAIN находится также ниже уровня 0.0004. Если в это время произойдёт подтверждение индикатора Stochastic Oscillator, то сработает критерий для закрытия Sell.

Обратите внимание, формально в течение периода T1 (при подтверждении Stochastic Oscillator) срабатывают оба указанные критерия. Ранее указывалось, что рассматриваемая функция Criterion() возвращает только одно значение, а именно значение, поставленное в соответствие одному сработавшему критерию. В этот период возникает необходимость сделать выбор в пользу одного из критериев. Этот вопрос решается заранее, в процессе программирования согласно приоритету критериев, который предписывается торговой стратегией.

В данном случае (согласно рассматриваемой торговой стратегии) приоритет у критерия открытия Buy выше, чем у критерия закрытия Sell. Поэтому в блоке 5-6 программная строка, в которой вычисляется критерий для открытия ордера Buy находится выше по тексту. Если в период T1 (рис. 157) получено подтверждение индикатора Stochastic Oscillator, то функция возвращает значение 10, поставленное в соответствие этому критерию. В период времени с момента t 1 до момента t 2 функция вернёт значение 21, поставленное в соответствие критерию закрытия Sell.

Одновременно с этим, при исполнении торговых функций будут сформированы необходимые торговые приказы. При срабатывании критерия открытия Buy прежде всего будут сформированы торговые приказы для закрытия всех имеющихся ордеров Sell, и когда не останется ни одного из них, будет отдан торговый приказ на открытие одного ордера Buy. Соответственно, при срабатывании критерия на закрытие Sell будет сформирована последовательность торговых приказов только на закрытие всех ордеров Sell (см. Торговые функции).

Условия, при которых срабатывает подтверждение индикатора Stochastic Oscillator, показаны на рис. 158.

Рис. 158. Необходимое условие положения индикаторных линий Stochastic Oscillator для подтверждения факта значимости торговых критериев для открытия и закрытия ордеров.

Согласно программному коду, указанному в блоке 5-6, критерии для открытия Buy и закрытия Sell могут оказаться значимыми при условии, если в индикаторе Stochastic Oscillator индикаторная линия MAIN окажется выше сигнальной линии SIGNAL, причём линия MAIN будет находиться ниже минимального уровня St_min. На рис. 158 такие условия складываются в течение периода времени Ts. Зеркальные условия подтверждают срабатывание критериев для открытия ордера Sell и закрытия ордеров Buy (в правой части рис. 158). Если ни один из критериев не сработал, то функция возвращает 0. При этих условиях могут выполняться другие торговые операции, например, корректировка заявленных значений стоп-приказов.

Отдельно нужно заметить, что рассматриваемая торговая стратегия предполагает использование показаний индикатора MACD, рассчитанного на часовом таймфрейме, а Stochastic Oscillator - на 15-минутном. В период тестирования с целью оптимизации таймфрейм может быть изменён. Однако по окончании тестирования в окончательном коде функции Criterion() обязательно необходимо указать константные значения для всех вычисленных параметров, в том числе, для таймфреймов. Эксперт должен использоваться только в тех условиях, для которых он создавался. В представленном варианте (с явно указанными в индикаторах значениями PERIOD_H1 и PERIOD_M15) эксперт будет учитывать только необходимые параметры независимо от текущего таймфрейма, установленного в окне финансового инструмента, где запущен эксперт.

Принятые в данном эксперте торговые критерии используются в учебных целях и не должны рассматриваться как руководство к действию при торговле на реальном счёте.

Функция определения количества лотовТорговые функции


Функция обработки ошибок - Создание обычной программы - Учебник по MQL4

Учебник по MQL4 [image] Создание обычной программы [image] Функция обработки ошибок
MetaQuotes Sofware Corp.
  • Структура обычной программы
  • Учёт ордеров
  • Информационная функция
  • Функция слежения за событиями
  • Функция определения количества лотов
  • Функция определения торговых критериев
  • Торговые функции
  • Функция обработки ошибок
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Функция обработки ошибок

Ошибки, возникающие при исполнении торговых приказов можно разделить на две группы - преодолимые и критические. К преодолимым ошибкам относятся все ошибки, сопровождающие отказ сервера, после которых можно продолжать торговлю. Например, торговый приказ может быть отклонён брокером в случае, если на текущий момент в его распоряжении нет информации о текущих ценах. Такая ситуация может возникнуть в случае очень медленного рынка, т.е. в условиях, когда тики поступают редко. Или напротив, в условиях быстро меняющегося рынка, когда поступающих котировок слишком много, брокер не всегда может удовлетворить множество торговых заявок от трейдеров, и тогда возникает пауза перед исполнением приказа, а иногда - отказ. В подобных случаях эксперт, после исполнения некоторого кода, поставленного в соответствие коду ошибки, может продолжать работу, например, после некоторой паузы повторить торговый приказ.

К критическим относятся все ошибки, возникновение которых свидетельствует о каких-либо серьёзных нарушениях. Например, если счёт заблокирован, то отправлять торговые приказы на сервер нет никакого смысла. В этом случае эксперт должен вывести необходимое сообщение, и не выполнять повторение торгового приказа. В составе обычного эксперта функция обработки ошибок должна использоваться обязательно.

Пользовательская функция обработки ошибок Errors()

bool Errors( int Error )

Функция возвращает TRUE, если ошибка преодолимая и FALSE, если ошибка является критической или отсутствует.
Параметр Error может принимать любое значение и соответствовать коду ошибки, возникшей при попытке осуществить торговую операцию.

Пользовательская функция обработки ошибок Errors() оформлена в виде включаемого файла Errors.mqh:

//--------------------------------------------------------------------
// Errors.mqh
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------- 1 --
// Функция обработки ошибок.
// Возвращаемые значения:
// true  - если ошибка преодолимая (т.е. можно продолжать работу)
// false - если ошибка критическая (т.е. торговать нельзя)
//--------------------------------------------------------------- 2 --
bool Errors(int Error)                    // Пользовательская функция
  {
   // Error             // Номер ошибки
   if(Error==0)
      return(false);                      // Нет ошибки
   Inform(15,Error);                      // Сообщение
//--------------------------------------------------------------- 3 --
   switch(Error)
     {   // Преодолимые ошибки:
      case 129:         // Неправильная цена
      case 135:         // Цена изменилась
         RefreshRates();                  // Обновим данные
         return(true);                    // Ошибка преодолимая
      case 136:         // Нет цен. Ждём новый тик.
         while(RefreshRates()==false)     // До нового тика
            Sleep(1);                     // Задержка в цикле
         return(true);                    // Ошибка преодолимая
      case 146:         // Подсистема торговли занята
         Sleep(500);                      // Простое решение
         RefreshRates();                  // Обновим данные
         return(true);                    // Ошибка преодолимая
         // Критические ошибки:
      case 2 :          // Общая ошибка
      case 5 :          // Старая версия клиентского терминала
      case 64:          // Счет заблокирован
      case 133:         // Торговля запрещена
      default:          // Другие варианты
         return(false);                   // Критическая ошибка
     }
//--------------------------------------------------------------- 4 --
  }
//--------------------------------------------------------------------

Одним из вопросов, возникающих при составлении алгоритма функции обработки ошибок Errors(), является вопрос о том, что должна вернуть функция, если значение передаваемого параметра равно 0 (т.е. ошибки нет). В правильно написанном эксперте такая ситуация вообще не возникает. Однако при совершенствовании программы код может быть несколько изменён, при этом в каких-то случаях может передаваться и нулевое значение ошибки. Поэтому уже на этапе первоначальной разработки имеет смысл ввести в функцию несколько строк кода для случая, если значение Error равно 0 (блок 2-3).

Какой должна быть реакция функции Errors() на нулевое значение переменной Error, зависит от того, какой алгоритм используется для обработки значения, возвращаемого функцией. В рассматриваемом эксперте значение, возвращаемое функцией, принимается во внимание в исполнительных торговых функциях. Если функция Errors() возвращает значение true (ошибка преодолимая), то предпринимается повторная попытка осуществить торговую операцию. Если же возвращено значение false, то исполнение торговой функции прекращается и управление последовательно возвращается в вызывающую функцию, затем в функцию start() и клиентскому терминалу. Если выбирать между двумя этими вариантами, то случай, когда ошибки нет (Error = 0) соответствует второму варианту, а именно возвращаемому значению false. Этим гарантируется, что однажды исполненный приказ не будет повторён.

После вывода с помощью функции Inform() сообщения об ошибке управление передаётся в блок 3-4, оператору switch. Для каждого из рассматриваемых кодов ошибок в функции предусмотрен свой вариант case. Например, если возникла ошибка 136, то это значит, что на текущий момент у брокера нет цен, на основании которых он может принять правильное решение. Это значит также, что в период до ближайшего тика ситуация не изменится, т.е. нет необходимости многократно повторять один и тот же торговый приказ, он всё равно не будет исполнен. Правильным решением в этом случае является пауза - отсутствие какой-либо инициативы со стороны эксперта. Для этой цели используется простой способ определения нового тика - анализ значения, возвращаемого функцией RefreshRates(). Как только новый тик появляется, управление возвращается в вызвавшую функцию, в которой торговый приказ (при необходимости, после соответствующего анализа) повторяется.

При возникновении любой ошибки, которая, по мнению программиста, является критической, функция возвращает значение false. В этом случае в торговых функциях не будет осуществляться повтор торгового приказа, поэтому нет смысла и предпринимать какие-либо действия в функции Errors(). Все ошибки, рассмотрение которых не предусмотрено, также расцениваются как критические (вариант default). В общем случае список обрабатываемых кодов ошибок может быть расширен (см. Коды ошибок).

Торговые функцииО сложных программах


Функция слежения за событиями - Создание обычной программы - Учебник по MQL4

Учебник по MQL4 [image] Создание обычной программы [image] Функция слежения за событиями
MetaQuotes Sofware Corp.
  • Структура обычной программы
  • Учёт ордеров
  • Информационная функция
  • Функция слежения за событиями
  • Функция определения количества лотов
  • Функция определения торговых критериев
  • Торговые функции
  • Функция обработки ошибок
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Функция слежения за событиями

В период проведения торгов происходит множество различных событий. Некоторые из них трейдер может наблюдать непосредственно в окне финансового инструмента, например, динамику изменения рыночных цен или пересечение индикаторных линий. Другие события, хотя и представляют интерес для трейдера, но в явном виде нигде не отображаются. Значительная часть этих событий может быть вычислена и обработана средствами языка MQL4.

Например, незадолго до выхода важных новостей или при сильном движении цен дилинговый центр может изменить условия торговли. В подобных случаях может быть увеличен спред или минимально допустимая дистанция для установки ордеров и заявленных цен стоп-приказов. В случае, если это происходит, необходимо, во-первых, обнаружить и принять во внимание новые условия торговли, и во-вторых, поставить в известность трейдера о возникших изменениях.

Для решения этих задач в эксперте используется функция слежения за событиями.

Пользовательская функция Events()

int Events()

Функция вычисляет изменение минимальной дистанции для установки ордеров и их стоп-приказов, а также изменения в составе рыночных и отложенных ордеров. Для исполнения функции требуется применение в программе функции учёта ордеров Terminal(). Используются значения глобальных массивов:

  • Mas_Ord_New - массив характеристик ордеров на момент последнего исполнения функции Terminal();
  • Mas_Ord_Old - массив характеристик ордеров на момент предыдущего исполнения функции Terminal().

Используются значения глобальных переменных:
- Level_new - текущее значение минимальной дистанции;
- Level_old - предыдущее значение минимальной дистанции.

Для вывода сообщений функция предполагает использование информационной функции Inform(). В случае, если функция Inform() не включена в эксперт, сообщения не выводятся.

Функция слежения за событиями Events() оформлена в виде включаемого файла Events.mqh:

//--------------------------------------------------------------------
// Events.mqh
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------- 1 --
// Функция слежения за событиями.
// Глобальные переменные:
// Level_new            Новое значение минимальной дистанции
// Level_old            Предыдущее значение минимальной дистанции
// Mas_Ord_New[31][9]   Массив ордеров последний известный
// Mas_Ord_Old[31][9]   Массив ордеров предыдущий (старый)
//--------------------------------------------------------------- 2 --
int Events()                              // Пользовательская функция
  {
   bool Conc_Nom_Ord;                     // Совпадение ордеров в ..
   //.. старом и новом массивах
//--------------------------------------------------------------- 3 --
   Level_new=MarketInfo(Symbol(),MODE_STOPLEVEL );// Последн.известное
   if (Level_old!=Level_new)              // Новое не равно старому..
     {                                    // значит изменились условия
      Level_old=Level_new;                // Новое "старое значение"
      Inform(10,Level_new);               // Сообщение: новая дистанц.
     }
//--------------------------------------------------------------- 4 --
   // Поиск пропавших, поменявших тип, частично закрытых и переоткрытых
   for(int old=1;old<=Mas_Ord_Old[0][0];old++)// По массиву старых
     {                                    // Исходим из того, что..
      Conc_Nom_Ord=false;                 // ..ордера не совпадают
      //--------------------------------------------------------- 5 --
      for(int new=1;new<=Mas_Ord_New[0][0];new++)//Цикл по массиву ..
        {                                 //..новых ордеров
         //------------------------------------------------------ 6 --
         if (Mas_Ord_Old[old][4]==Mas_Ord_New[new][4])// Совпал номер
           {                              // Тип ордера стал ..
            if (Mas_Ord_New[new][6]!=Mas_Ord_Old[old][6])//.. другим
               Inform(7,Mas_Ord_New[new][4]);// Сообщение: преобраз.:)
            Conc_Nom_Ord=true;            // Ордер найден, ..
            break;                        // ..значит выходим из ..
           }                              // .. внутреннего цикла
         //------------------------------------------------------ 7 --
                                          // Не совпал номер ордера
         if (Mas_Ord_Old[old][7]>0 &&     // MagicNumber есть, совпал
            Mas_Ord_Old[old][7]==Mas_Ord_New[new][7])//.. со старым
           {               //значит он переоткрыт или частично закрыт
                                             // Если лоты совпадают,..
            if (Mas_Ord_Old[old][5]==Mas_Ord_New[new][5])
               Inform(8,Mas_Ord_Old[old][4]);// ..то переоткрытие
            else                             // А иначе это было..
               Inform(9,Mas_Ord_Old[old][4]);// ..частичное закрытие
            Conc_Nom_Ord=true;               // Ордер найден, ..
            break;                           // ..значит выходим из ..
           }                                 // .. внутреннего цикла
        }
      //--------------------------------------------------------- 8 --
      if (Conc_Nom_Ord==false)               // Если мы сюда дошли,..
        {                                    // ..то ордера нет:(
         if (Mas_Ord_Old[old][6]==0)
            Inform(1, Mas_Ord_Old[old][4]);  // Ордер Buy закрыт
         if (Mas_Ord_Old[old][6]==1)
            Inform(2, Mas_Ord_Old[old][4]);  // Ордер Sell закрыт
         if (Mas_Ord_Old[old][6]> 1)
            Inform(3, Mas_Ord_Old[old][4]);  // Отложен. ордер удалён
        }
     }
//--------------------------------------------------------------- 9 --
   // Поиск новых ордеров
   for(new=1; new<=Mas_Ord_New[0][0]; new++)// По массиву новых орд.
     {
      if (Mas_Ord_New[new][8]>0)            //Это не новый,а переоткр
         continue;                          //..или частично закрытый
      Conc_Nom_Ord=false;                   // Пока совпадения нет
      for(old=1; old<=Mas_Ord_Old[0][0]; old++)// Поищем этот ордерок
        {                                   // ..в массиве старых
         if (Mas_Ord_New[new][4]==Mas_Ord_Old[old][4])//Совпал номер..
           {                                          //.. ордера
            Conc_Nom_Ord=true;              // Ордер найден, ..
            break;                          // ..значит выходим из ..
           }                                // .. внутреннего цикла
        }
      if (Conc_Nom_Ord==false)              // Если совпадения нет,..
        {                                   // ..то ордер новый :)
         if (Mas_Ord_New[new][6]==0)
            Inform(4, Mas_Ord_New[new][4]); // Ордер Buy открыт
         if (Mas_Ord_New[new][6]==1)
            Inform(5, Mas_Ord_New[new][4]); // Ордер Sell открыт
         if (Mas_Ord_New[new][6]> 1)
            Inform(6, Mas_Ord_New[new][4]); // Установлен отлож.ордер
        }
     }
//-------------------------------------------------------------- 10 --
   return;
  }
//-------------------------------------------------------------- 11 --

В блоке 1-2 описаны глобальные массивы и переменные, необходимые для исполнения функции. В блоке 2-3 открыта переменная Conc_Nom_Ord, используемая в дальнейшем коде для анализа состава ордеров.

Функция отслеживает изменение минимальной дистанции для установки ордеров и стоп-приказов. Для этого при каждом исполнении функции (блок 3-4) сначала вычисляется текущее значение минимальной дистанции Level_new, а затем оно сравнивается с предыдущим значением минимальной дистанции Level_old (полученным в период предыдущего исполнения функции). Если значения этих переменных не равны, значит незадолго до последнего исполнения функции минимальная дистанция была изменена дилинговым центром. В этом случае переменной Level_old присваивается текущее значение минимальной дистанции (чтобы учесть при последующих исполнениях функции) и исполняется функция Inform() с целью вывести необходимое сообщение.

В общем случае аналогичным способом возможно выявить и другие события, например, изменение спреда, разрешение торгов по указанному инструменту (идентификатор MODE_TRADEALLOWED в функции MarketInfo()), факт образования нового бара (см. Задачу 27), факт пересечения индикаторных линий (см. Рис. 107), факт достижения некоторого заданного времени и пр. Некоторые события можно отслеживать с целью использования полученных значений в эксперте, другие - для того, чтобы информировать пользователя.

В блоках 4-10 выполняется анализ состояния рыночных и отложенных ордеров. Информация о большинстве событий, связанных с изменениями ордеров, доводится до сведения пользователя. Анализ выполняется в два этапа. На первом этапе выявляются изменения, касающиеся пропавших (закрытых или удалённых), поменявших тип, частично закрытых и переоткрытых ордеров (блок 4-9). На втором этапе (блок 9-10) осуществляется поиск новых ордеров.

В блоке 4-9 производится анализ ордеров, учтённых в массиве Mas_Ord_Old. Количество итераций во внешнем цикл for устанавливается в соответствии с общим количеством ордеров в этом массиве (элемент массива Mas_Ord_Old[0][0]). Для того чтобы определить, сохранился ли ордер на текущий момент, необходимо найти аналогичный ордер в массиве ордеров Mas_Ord_New. Этот поиск выполняется во внутреннем цикле for (блок 6-8), количество итераций которого равно количеству ордеров в массиве (элемент массива Mas_Ord_New[0][0]). В дальнейшем изложении массив Mas_Ord_Old именуется старым массивом, а Mas_Ord_New - новым.

В блоках 6-8 выполняется поиск только тех ордеров, характеристики которых отличаются. Например, в блоке 6-7 производится проверка ордера по его номеру (см. соответствие индексов массивов характеристикам ордеров в Таблице 4). Если исследуемый ордер из старого массива совпал по номеру с одним из ордеров нового массива, то этот ордер, по крайней мере не закрыт (или удалён). При этом необходимо выяснить также, не поменялся ли тип ордера. И если тип ордера изменился, значит отложенный ордер преобразовался в рыночный. В этом случае с помощью функции Inform() выводится необходимое сообщение. Независимо от факта изменения (или сохранения) типа ордера дальнейшие исследования этого ордера прекращаются: осуществляется выход из внутреннего цикла и, в конечном счёте, начало новой итерации внешнего цикла.

Если при исполнении блока 6-7 обнаружено, что исследуемый ордер из старого массива не совпал по номеру ни с одним из ордеров нового массива, то управление передаётся в блок 7-8. Здесь выясняется, есть ли у текущего ордера из нового массива ненулевой MagicNumber (все ордера, открываемые и устанавливаемые экспертом, имеют ненулевой MagicNumber). Если MagicNumber есть и он совпадает с MagicNumber исследуемого ордера из старого массива, значит исследуемый ордер присутствует в торговле, но претерпел какие-то преобразования. Преобразования, связанные с изменением номера ордера, возникают в двух случаях.

Случай 1. Если ордер частично закрыт. Частичное закрытие рыночного ордера (для отложенных ордеров не предусмотрено) в соответствии с технологией, принятой в среде МТ4, выполняется в два этапа. На первом этапе полностью закрывается исходный ордер в полном объёме. В этот же момент открывается новый рыночный ордер в объёме остаточной стоимости, с тем же курсом открытия и заявленными ценами стоп-приказов, что и у исходного. Этот новый ордер получает свой уникальный номер ордера, не совпадающий с номером исходного частично закрываемого ордера.

Случай 2. Если ордер переоткрыт дилинговым центром. Некоторые банки (в связи со специфическим порядком внутреннего учёта) в конце каждого рабочего дня принудительно закрывают все рыночные ордера и в тот же момент открывают рыночные ордера того же типа на то же количество лотов, но уже по текущему курсу за вычетом свопа. Это событие не оказывает никакого влияния на экономический результат по игровому счёту. Каждый из вновь открытых ордеров также получает свой уникальный номер, не совпадающий с номерами закрытых ордеров.

Разница между рассмотренными случаями заключается в новом количестве лотов для новых ордеров - в первом случае количество лотов уменьшается, во втором случае не изменяется. Это различие используется в блоке 7-8 для того, чтобы отличать причину преобразования ордера. В том и другом случае выводится соответствующее сообщение (ордер частично закрыт или ордер переоткрыт).

Если к моменту полного окончания внутреннего цикла не удалось выявить признаки совпадения (блок 6-7) или наследования (блок 7-8) ордера в новом массиве, значит исследуемый ордер из старого массива ордеров закрыт или удалён. В этом случае управление передаётся в блок 8-9, где в зависимости от типа ордера выводится то или иное сообщение. В данном примере реализовано три варианта сообщений - для ордера Buy, ордера Sell и отложенных ордеров независимо от их типа. В общем случае этот порядок может быть несколько изменён (дополнен) - возможно создание группы соответствующих сообщений для каждого из типов отложенных ордеров.

На втором этапе принимаются к рассмотрению ордера из нового массива ордеров (блок 9-10). Это делается для того, чтобы выявить вновь открытые и установленные ордера. Во внешнем цикле for выполняется перебор всех ордеров, сведения о которых содержатся в массиве новых ордеров. Для идентификации переоткрытых или частично закрытых ордеров используется простой признак - наличие комментария. При частичном закрытии или переоткрытии в комментарий ордера сервером автоматически заносится запись, в которой указывается номер исходного ордера. Рассматриваемый эксперт не использует комментарий, поэтому наличие комментария свидетельствует о том, что рассматриваемый ордер не новый.

Если ордер не содержит комментарий, то выполняется поиск ордера с таким же номером в массиве старых ордеров. В случае, если во внутреннем цикле for среди старых ордеров обнаружен ордер с таким номером, значит он не новый, а был открыт ранее. Если же номер исследуемого ордера из нового массива не совпадает ни с одним из номеров ордеров в старом массиве, значит этот ордер - открытый рыночный или установленный отложенный. В нижней части блока 9-10, в зависимости от типа ордера, выполняется обращение к функции Inform() для вывода необходимого сообщения.

Использование рассматриваемой функции Events() на практике оказывается очень полезным. Однажды применив функцию в советнике, программист обычно использует её и в дальнейшем. Отдельно нужно заметить, что функции Events() и Terminal() тесно связаны между собой. Если предполагается вносить изменения в одну из этих функций (например, использовать другие названия глобальных массивов), то соответствующие изменения необходимы и в другой функции. Если для реализации торговой стратегии используются комментарии в ордерах, то следует иначе обрабатывать признак наследования ордера (блок 9-10), а именно, с помощью строковых функций проанализировать текст комментария к ордеру.

Количество событий, рассматриваемых в функции Events(), может быть существенно увеличено. Например, для того чтобы избыточно полно отразить все события, связанные с ордерами, необходимо добавить анализ характеристик ордеров - изменение заявленных цен стоп-приказов и заявленных цен открытия отложенных ордеров, а также метод закрытия ордеров (закрыты ли ордера встречно или каждый в отдельности) и причину закрытия или удаления ордеров (при достижении ценой уровня заявленной цены стоп-приказа, по инициативе трейдера и т.д.).

Информационная функцияФункция определения количества лотов


Создание обычной программы - Учебник по MQL4

Учебник по MQL4 [image] Создание обычной программы
  • Структура обычной программы
  • Учёт ордеров
  • Информационная функция
  • Функция слежения за событиями
  • Функция определения количества лотов
  • Функция определения торговых критериев
  • Торговые функции
  • Функция обработки ошибок
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Построение обычных программ

Как правило, после самостоятельного программирования нескольких простых прикладных программ на MQL4, программист переходит к более сложному проекту - созданию удобной программы для практического использования. Простые программы в ряде случаев не удовлетворяют потребностям трейдера-программиста по крайней мере по двум причинам:

1. Функциональная ограниченность простых программ не позволяет в полной мере обеспечить трейдера необходимой информацией и средствами управления торговлей, что делает их применение недостаточно эффективным.

2. Несовершенство кода простых программ затрудняет возможность дальнейшего их наращивания с целью получения большего сервиса.

В данном разделе представлен один из возможных вариантов реализации торгующего эксперта, который может рассматриваться как основа для создания собственного проекта.

  • Структура обычной программы
    Наличие множества пользовательских функций в программе позволяет создавать мощные и гибкие алгоритмы обработки информации. Директива компилятору #include позволяет однажды написанную и отлаженную функцию использовать и в других программах. Таким образом можно создавать свои собственные библиотеки или пользоваться открытыми разработками других программистов.
  • Учёт ордеров
    Рассматривается пример пользовательской функции Terminal(), которая реализована в отдельном включаемом файле с расширением mqh. Такие файлы подключаются к коду программы на этапе компиляции с помощью директивы #include.
  • Информационная функция
    Пример еще одной пользовательской функции, которая помогает организовать вывод текстовой информации о текущей работе эксперта. Эта функция позволяет отказаться от функции Comment() для вывода текста в главное окно графика, и реализована как индикатор в отдельном подокне ценового графика.
  • Функция слежения за событиями
    Не всегда трейдер может заметить все события самостоятельно. Программа на MQL4 позволит обнаруживать изменения любых торговых условий или ситуаций. Пользовательская функция Events() подключается к эксперту с помощью директивы #include, и использует вызовы другой подключаемой функции Inform().
  • Функция определения количества лотов
    Расчет объема открываемой позиции является одной из задач управления капиталом и рисками. Пользовательская функция Lot() является небольшим примером для этих целей.
  • Функция определения торговых критериев
    Самая важная часть любой торговой стратегии - определение моментов входа в позицию и выхода из нее. Создание торговых правил или критериев является ядром любого экперта. Пользовательская функция Criterion() подключается с помощью директивы #include. В ней показано, как на основании значений индикаторов эксперт может принимать решение о соответствии текущей ситуации тому или иному критерию.
  • Торговые функции
    Текущая ситуация проанализирована функцией Criterion(), и теперь необходимо произвести торговые операции: открытие, закрытие, модификацию или удаление отложенного ордера. Все эти операции можно вынести в отдельные пользовательские функции Trade(), Close_All() и Open_Ord(). Подтягивание защитных стопов производится еще одной пользовательской функцией Tral_Stop().
  • Функция обработки ошибок
    Контроль ошибок является неотъемлемой частью любого эксперта. Вы сами определяете, каким образом обрабатывается сообщение о занятом торговом потоке, отсутствии цен по запрашиваемому инструменту и так далее. В одних случаях достаточно вывести сообщение о полученной ошибке, в других стоит попытаться повторить торговый приказ через некоторое время. Необходимо определить, как будет обрабатываться та или иная ошибка. В пользовательской функции Errors() показана обработка ошибок с помощью оператора выбора switch().
Торговые функцииСтруктура обычной программы


Информационная функция - Создание обычной программы - Учебник по MQL4

Учебник по MQL4 [image] Создание обычной программы [image] Информационная функция
MetaQuotes Sofware Corp.
  • Структура обычной программы
  • Учёт ордеров
  • Информационная функция
  • Функция слежения за событиями
  • Функция определения количества лотов
  • Функция определения торговых критериев
  • Торговые функции
  • Функция обработки ошибок
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Информационная функция

Обычный эксперт, используемый в практической работе, выгодно отличается от своих простых аналогов тем, что предоставляет трейдеру качественное информационное сопровождение.

Во время торгов ситуация всё время меняется, происходят различные события. Для того чтобы принимать правильные торговые решения, трейдеру необходимо быть в полной мере информированным. С этой целью в экспертах используются различные функции, назначение которых - довести до сведения пользователя некоторый набор информации.

В простых экспертах, как правило, такую роль выполняет стандартная функция Comment(), которая выводит заданный текст в левый верхний угол окна финансового инструмента. Такой метод вывода информации не очень удобен, т.к. текст зачастую накладывается на ценовой график, поэтому может использоваться лишь в ограниченной части случаев для вывода небольших сообщений.

Здесь рассматривается принципиально иной метод вывода информации - все сообщения выводятся в отдельное окно, а для формирования текстов сообщений используются графические объекты. Применение графических объектов даёт ощутимое преимущество, т.к. объекты (в отличие от текстов, выводимых с помощью Comment()) можно перемещать, создавая, таким образом, историю сообщений.

Отдельное подокно для вывода информации создаётся с помощью пользовательского индикатора с соответствующей настройкой. Единственным назначением этого индикатора является создание подокна, поэтому в индикаторе не выполняются никакие вычисления, не ставится также цель построения индикаторных линий. Код индикатора Inform.mq4 может выглядеть так:

//--------------------------------------------------------------------
// Inform.mq4
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------------
#property indicator_separate_window // Отдельное окно индикатора
//--------------------------------------------------------------------
int start()                         // Специальная функция start()
  {
  }
//--------------------------------------------------------------------

В общем случае программист по своему усмотрению может добавить в индикатор необходимый код, наделив его, таким образом, дополнительными свойствами. Например, в некоторой части подокна индикатора можно выводить индикаторные линии. В данном примере предлагается простой код индикатора, в окне которого будут отображаться графические объекты.

Пользовательская функция Inform()

int Inform(int Mess_Number,int Number=0,double Value=0.0)

Функция выводит сообщения, созданные с помощью графических объектов, в подокно индикатора Inform.mq4. Функция управляет положением графических объектов в подокне индикатора: каждое новое сообщение выводится в нижнюю часть окна (нижнюю строку) и окрашивается нужным цветом, при этом ранее выведенные сообщения перемещаются в верхнюю часть окна (на одну строку выше). Если в течение 15 секунд не было выведено новых сообщений, то при обращении к функции все ранее выведенные сообщения окрашиваются в серый цвет (чтобы не отвлекать внимание пользователя).

Параметры:

Mess_Number - номер сообщения, может принимать следующие значения:

  • (ноль) 0 - сообщение не выводится, режим используется для сброса счётчика времени;
  • (минус единица) -1 - все графические объекты, созданные функцией, удаляются;
  • (единица и более) - номер сообщения, которое необходимо вывести в подокно индикатора;

Number - целое число, используемое в некоторых сообщениях;

Value - действительное число, используемое в некоторых сообщениях.

Функция Inform(), создающая графические объекты, как и другие функции в обычном эксперте, оформлена в виде включаемого файла Inform.mqh :

//--------------------------------------------------------------------
// Inform.mqh
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------- 1 --
// Функция вывода на экран графических сообщений.
//--------------------------------------------------------------- 2 --
int Inform(int Mess_Number, int Number=0, double Value=0.0)
  {
   // int    Mess_Number               // Номер сообщения
   // int    Number                    // Передаваемое целое значение
   // double Value                     // Передаваемое действит. знач.
   int    Win_ind;                     // Номер окна индикатора
   string Graf_Text;                   // Строка сообщения
   color  Color_GT;                    // Цвет строки сообщения
   static int    Time_Mess;            // Время последней публикации сообщ.
   static int    Nom_Mess_Graf;        // Счётчик графических сообщений
   static string Name_Grf_Txt[30];     // Массив имён графич. сообщений
//--------------------------------------------------------------- 3 --
   Win_ind= WindowFind("inform");      // Ищем номер окна индикатора
   if (Win_ind<0)return;               // Если такого окна нет, уходим
//--------------------------------------------------------------- 4 --
   if (Mess_Number==0)                 // Это происходит в каждом тике
     {
      if (Time_Mess==0) return;        // Если уже крашено серым
      if (GetTickCount()-Time_Mess>15000)// За 15 сек цвет устарел
        {
         for(int i=0;i<=29; i++)       // Красим cтроки серым
            ObjectSet( Name_Grf_Txt[i], OBJPROP_COLOR, Gray);
         Time_Mess=0;                  // Флажок: все строки серые
         WindowRedraw();               // Перерисовываем объекты
        }
      return;                          // Выход из функции
     }
//--------------------------------------------------------------- 5 --
   if (Mess_Number==-1)                // Это происходит при deinit()
     {
      for(i=0; i<=29; i++)             // По индексам объектов
         ObjectDelete(Name_Grf_Txt[i]);// Удаление объекта
      return;                          // Выход из функции
     }
//--------------------------------------------------------------- 6 --
   Nom_Mess_Graf++;                    // Счётчик графических сообщ.
   Time_Mess=GetTickCount();           // Время последней публикации
   Color_GT=Lime;
//--------------------------------------------------------------- 7 --
   switch(Mess_Number)                 // Переход на сообщение
     {
      case 1:
         Graf_Text="Закрыт ордер Buy "+ Number;
         PlaySound("Close_order.wav");                         break;
      case 2:
         Graf_Text="Закрыт ордер Sell "+ Number;
         PlaySound("Close_order.wav");                         break;
      case 3:
         Graf_Text="Удалён отложенный ордер "+ Number;
         PlaySound("Close_order.wav");                         break;
      case 4:
         Graf_Text="Открыт ордер Buy "+ Number;
         PlaySound("Ok.wav");                                  break;
      case 5:
         Graf_Text="Открыт ордер Sell "+ Number;
         PlaySound("Ok.wav");                                  break;
      case 6:
         Graf_Text="Установлен отложенный ордер "+ Number;
         PlaySound("Ok.wav");                                  break;
      case 7:
         Graf_Text="Ордер "+Number+" преобразовался в рыночный";
         PlaySound("Transform.wav");                           break;
      case 8:
         Graf_Text="Переоткрыт ордер "+ Number;                break;
         PlaySound("Bulk.wav");
      case 9:
         Graf_Text="Частично закрыт ордер "+ Number;
         PlaySound("Close_order.wav");                         break;
      case 10:
         Graf_Text="Новая минимальная дистанция: "+ Number;
         PlaySound("Inform.wav");                              break;
      case 11:
         Graf_Text=" Не хватает денег на "+
         DoubleToStr(Value,2) + " лотов";
         Color_GT=Red;
         PlaySound("Oops.wav");                                break;
      case 12:
         Graf_Text="Попытка закрыть ордер "+ Number;
         PlaySound("expert.wav");                              break;
      case 13:
         if (Number>0)
            Graf_Text="Попытка открыть ордер Sell..";
         else
            Graf_Text="Попытка открыть ордер Buy..";
         PlaySound("expert.wav");                              break;
      case 14:
         Graf_Text="Неправильный пароль. Эксперт не работает.";
         Color_GT=Red;
         PlaySound("Oops.wav");                                break;
      case 15:
         switch(Number)                 // Переход на номер ошибки
           {
            case 2:   Graf_Text="Общая ошибка.";             break;
            case 129: Graf_Text="Неправильная цена. ";       break;
            case 135: Graf_Text="Цена изменилась. ";         break;
            case 136: Graf_Text="Нет цен. Ждём новый тик.."; break;
            case 146: Graf_Text="Подсистема торговли занята";break;
            case 5 :  Graf_Text="Старая версия терминала.";  break;
            case 64:  Graf_Text="Счет заблокирован.";        break;
            case 133: Graf_Text="Торговля запрещена";        break;
            default:  Graf_Text="Возникла ошибка " + Number;//Другие
           }
         Color_GT=Red;
         PlaySound("Error.wav");                               break;
      case 16:
         Graf_Text="Эксперт работает только на EURUSD";
         Color_GT=Red;
         PlaySound("Oops.wav");                                break;
      default:
         Graf_Text="default "+ Mess_Number;
         Color_GT=Red;
         PlaySound("Bzrrr.wav");
     }
//--------------------------------------------------------------- 8 --
   ObjectDelete(Name_Grf_Txt[29]);      // 29й(верхний) объект удаляем
   for(i=29; i>=1; i--)                 // Цикл по индексам массива ..
     {                                 // .. графических объектов
      Name_Grf_Txt[i]=Name_Grf_Txt[i-1];// Поднимаем объекты:
      ObjectSet( Name_Grf_Txt[i], OBJPROP_YDISTANCE, 2+15*i);
     }
   Name_Grf_Txt[0]="Inform_"+Nom_Mess_Graf+"_"+Symbol(); // Имя объект
   ObjectCreate (Name_Grf_Txt[0],OBJ_LABEL, Win_ind,0,0);// Создаём
   ObjectSet    (Name_Grf_Txt[0],OBJPROP_CORNER, 3   );  // Угол
   ObjectSet    (Name_Grf_Txt[0],OBJPROP_XDISTANCE, 450);// Коорд. Х
   ObjectSet    (Name_Grf_Txt[0],OBJPROP_YDISTANCE, 2);  // Коорд. Y
   // Текстовое описание объекта
   ObjectSetText(Name_Grf_Txt[0],Graf_Text,10,"Courier New",Color_GT);
   WindowRedraw();                      // Перерисовываем все объекты
   return;
  }
//--------------------------------------------------------------- 9 --

В блоке 2-3 описаны используемые в функции переменные. Для хранения имён графических объектов используется массив Name_Grf_Txt. Согласно принятому в функции методу для вывода каждого нового сообщения создаётся новый графический объект. Общее количество объектов - 30, каждый объект представляет текстовую надпись, располагаемую в одной строке. В случае большого разрешения экрана количество выводимых строк сообщений можно увеличить путём увеличения количества создаваемых объектов.

В блоке 3-4 вычисляется номер подокна индикатора "Inform", в которое выводятся сообщения. Если индикатор не установлен, то функция прекращает работу. Отсутствие окна не позволяет выводить сообщения, однако это не влияет на работоспособность эксперта - все другие функции будут работать в обычном режиме, в том числе будут осуществляться торговые операции.

В блоке 4-5 осуществляется анализ расцветки сообщений. Обращение к функции с параметром Mess_Number=0 выполняется в эксперте на каждом тике (см. функцию start() в эксперте usualexpert.mq4). Если в предыдущей истории все объекты уже обесцвечены (т.е. все объекты серого цвета), то функция заканчивает работу. Если же значение переменной Time_Mess не нулевое, то изменяются свойства всех объектов, а именно всем объектам сообщается серый цвет.

В случае (блок 5-6), если при вызове функции указан параметр Mess_Number=-1, то все объекты, ранее созданные при исполнении функции, удаляются. Такая необходимость возникает при отключении эксперта из окна финансового инструмента. В этом случае, в соответствии с общим правилом, каждая прикладная программа должна удалить все объекты, созданные ею в период исполнения (см. функцию deinit() в эксперте usualexpert.mq4).

Если управление в программе передаётся в блок 6-7, значит, необходимо создать новый графический объект с нужными свойствами и расположить его в нижней части подокна индикатора (в нижней строке; здесь термин "строка" - условный, в действительности положение графических объектов определяется заданными координатами). Каждый вновь создаваемый объект имеет уникальное имя. Для формирования имён объектов используется исторический порядковый номер сообщения, поэтому в блоке 6-7 установлен счётчик сообщений (в дальнейшем значение переменной Nom_Mess_Graf используется для формирования уникального имени, блок 8-9). Здесь же учитывается время последней публикации и устанавливается основной цвет для новых сообщений (зелёный).

Блок 7-8 состоит из оператора switch, управление внутри которого передаётся согласно заданному при вызове функции значению параметра Mess_Number. В каждом из вариантов case этого оператора переменной Graf_Text присваивается новое значение, которое и является содержанием выводимого сообщения. Для некоторых сообщений устанавливается собственный цвет, например, в случае вывода важного предупреждения цвет может быть красным. Все сообщения сопровождаются звуком - исполнением стандартной функции PlaySound() (см. Звуковые файлы).

Создание нового графического объекта и перемещение уже имеющихся объектов осуществляется в блоке 8-9. Количество объектов ограничено, поэтому при публикации каждого нового сообщения один их графических объектов (самый старый) удаляется. Все другие, уже имеющиеся, объекты перемещаются на одну строку выше. Перемещение объектов выполняется путём изменения их свойств - координат по вертикали. Координаты объектов по горизонтали остаются неизменными.

После того как выполнены необходимые подготовительные действия (все объекты подняты на одну строку вверх), создаётся новый объект с новым уникальным именем и со свойствами, частично определёнными в блоке 7-8. Тип графического объекта - текстовая метка. Объекты этого типа позиционируются относительно окна финансового инструмента, что позволяет пользователю произвольно перемещать ценовой график, не затрагивая этим действием положение надписей сообщений.

Вызов функции Inform() может осуществляться из любого места программы, где по смыслу необходимо вывести очередное сообщение. В результате длительного использования в окне накапливаются сообщения. Пользователь может посмотреть историю сообщений, изменив размер подокна индикатора (например, подняв его верхнюю границу). По желанию пользователя, можно также установить высоту окна таким образом, чтобы видимого пространства хватало для отображения необходимого количества строк сообщений (рекомендуется три - четыре строки).

Рис. 156. Окно финансового инструмента. Сообщения в подокне индикатора.

Легко заметить, что разнообразие сообщений, выводимых функцией, может быть увеличено. В случае если предполагается расширять программу, достаточно добавить новый вариант case в операторе switch (блок 7-8).

Учёт ордеровФункция слежения за событиями


Функция определения количества лотов - Создание обычной программы - Учебник по MQL4

Учебник по MQL4 [image] Создание обычной программы [image] Функция определения количества лотов
MetaQuotes Sofware Corp.
  • Структура обычной программы
  • Учёт ордеров
  • Информационная функция
  • Функция слежения за событиями
  • Функция определения количества лотов
  • Функция определения торговых критериев
  • Торговые функции
  • Функция обработки ошибок
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Функция определения количества лотов

Для практической работы трейдеру необходимо иметь возможность регулировать количество лотов для новых ордеров. Создать для этой цели универсальную функцию затруднительно, т.к. каждая торговая стратегия предусматривает свой собственный порядок управления размерами ордеров. Например, некоторые стратегии предполагают возможность работы только с одним рыночным ордером, другие стратегии позволяют открывать новые рыночные ордера в условиях, когда какие-то рыночные ордера уже имеются. Известны также стратегии, основанные на управлении различными отложенными ордерами, в том числе, в некоторых случаях допускается присутствие в торговле одновременно нескольких отложенных и рыночных ордеров.

Одним из наиболее распространённых методов расчёта размера открываемых ордеров (для группы стратегий, допускающих одновременно только один рыночный ордер) является метод прогрессивного вложения средств. Согласно этому методу залоговая стоимость каждого нового ордера пропорциональна сумме свободных средств, имеющихся на момент совершения торговой операции. В случае, если очередной рыночный ордер закрывается с прибылью, то количество лотов для нового ордера увеличивается, а если с убытком, то уменьшается.

В представленном примере рассматривается пользовательская функция Lot(), позволяющая устанавливать количество лотов для новых ордеров по одному из двух вариантов:

Вариант 1. Количество лотов для новых ордеров задаётся пользователем вручную.

Вариант 2. Количество лотов вычисляется в зависимости от количества выделенных пользователем средств. Количество выделенных средств задаётся в виде процента от суммы свободных средств.

Пользовательская функция Lot()

bool Lot()

Функция рассчитывает количество лотов для новых ордеров. В результате исполнения функции изменяется значение глобальной переменной Lots_New - количество лотов. Функция возвращает TRUE, если свободных средств хватает для открытия ордера на минимальное количество лотов (для финансового инструмента, в окно которого присоединён эксперт), в противном случае возвращает FALSE.

Функция использует значения глобальных переменных:

  • Lots - количество лотов, заданное пользователем;
  • Percent - процент от свободных средств, заданный пользователем.

Для вывода сообщений функция предполагает использование информационной функции Inform(). В случае, если функция Inform() не включена в эксперт, сообщения не выводятся.

Функция определения количества лотов Lot() оформлена в виде включаемого файла Lot.mqh:

//--------------------------------------------------------------------
// Lot.mqh
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------- 1 --
// Функция вычисления количества лотов.
// Глобальные переменные:
// double Lots_New - количество лотов для новых ордеров (вычисляется)
// double Lots     - желаемое количество лотов, заданное пользовател.
// int Percent     - процент средств, заданный пользователем
// Возвращаемые значения:
// true  - если средств хватает на минимальный лот
// false - если средств не хватает на минимальный лот
//--------------------------------------------------------------- 2 --
bool Lot()                                     // Позовательская ф-ия
  {
   string Symb   =Symbol();                    // Финансовый инструм.
   double One_Lot=MarketInfo(Symb,MODE_MARGINREQUIRED);//Стоим. 1 лота
   double Min_Lot=MarketInfo(Symb,MODE_MINLOT);// Мин. размер. лотов
   double Step   =MarketInfo(Symb,MODE_LOTSTEP);//Шаг изменен размера
   double Free   =AccountFreeMargin();         // Свободные средства
//--------------------------------------------------------------- 3 --
   if (Lots>0)                                 // Лоты заданы явно..
     {                                         // ..проверим это
      double Money=Lots*One_Lot;               // Стоимость ордера
      if(Money<=AccountFreeMargin())           // Средств хватает..
         Lots_New=Lots;                        // ..принимаем заданное
      else                                     // Если не хватает..
         Lots_New=MathFloor(Free/One_Lot/Step)*Step;// Расчёт лотов
     }
//--------------------------------------------------------------- 4 --
   else                                        // Если лоты не заданы
     {                                         // ..то берём процент
      if (Percent > 100)                       // Задано ошибочно ..
         Percent=100;                          // .. то не более 100
      if (Percent==0)                          // Если установлен 0 ..
         Lots_New=Min_Lot;                     // ..то минимальный лот
      else                                     // Желаем. колич.лотов:
         Lots_New=MathFloor(Free*Percent/100/One_Lot/Step)*Step;//Расч
     }
//--------------------------------------------------------------- 5 --
   if (Lots_New < Min_Lot)                     // Если меньше допуст..
      Lots_New=Min_Lot;                        // .. то миниамальный
   if (Lots_New*One_Lot > AccountFreeMargin()) // Не хватает даже..
     {                                         // ..на минимальн. лот:(
      Inform(11,0,Min_Lot);                    // Сообщение..
      return(false);                           // ..и выход
     }
   return(true);                               // Выход из польз. ф-ии
  }
//--------------------------------------------------------------- 6 --

Функция имеет простой код. В блоке 1-2 описаны глобальные переменные и возвращаемые значения. В блоке 2-3 вычислены значения некоторых переменных. Для расчёта принят следующий приоритет устанавливаемых значений: если пользователь задал ненулевое количество лотов, то значение процента от свободных средств не принимается во внимание. Внешние переменные Lots и Percent объявлены во включаемом файле Variables.mqh.

В блоке 3-4 выполняется расчёт для варианта, когда пользователем задано ненулевое значение количества лотов во внешней переменной Lots. В этом случае производится проверка. Если свободных средств хватает для того, чтобы открыть рыночный ордер с указанным количеством лотов, то установленное пользователем значение присваивается глобальной переменной Lots_New и используется в дальнейших расчётах. Если свободных средств не хватает, то высчитывается максимально достижимое количество лотов, которое и используется в дальнейшем (см. Математические функции).

Управление передаётся в блок 4-5 в случае, если пользователь установил нулевое количество лотов. При этом принимается во внимание процент свободных средств, указанный пользователем во внешней переменной Percent. Выполняется проверка: если указанное значение больше ста (процентов), то в расчётах используется значение 100. Если пользователь указал нулевое значение переменной Percent, то количество лотов приравнивается минимально возможному значению, установленному в дилинговом центре. Для всех промежуточных величин высчитывается количество лотов, соответствующее количеству выделенных пользователем средств.

В блоке 5-6 выполняется необходимая проверка. Если вычисленное количество лотов оказывается меньше, чем минимально допустимое (например, нулевое значение может быть получено в блоке 4-5, если пользователь указал малое значение переменной Percent), то переменной Lots_New присваивается минимальное значение. Далее проверяется, достаточно ли свободных средств для открытия ордера в объёме ранее вычисленного количества лотов (на счёте может быть недостаточно средств). Если имеющихся средств не хватает, то после сообщения пользователю о недостатке средств осуществляется выход из функции, при этом функция возвращает значение false. Если же проверка прошла успешно, то возвращается значение true.

Функция слежения за событиямиФункция определения торговых критериев


Учёт ордеров - Создание обычной программы - Учебник по MQL4

Учебник по MQL4 [image] Создание обычной программы [image] Учёт ордеров
MetaQuotes Sofware Corp.
  • Структура обычной программы
  • Учёт ордеров
  • Информационная функция
  • Функция слежения за событиями
  • Функция определения количества лотов
  • Функция определения торговых критериев
  • Торговые функции
  • Функция обработки ошибок
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Учёт ордеров

Ранее упоминалось, что каких-либо жёстких правил для составления алгоритмов программ не существует. Вместе с тем, подавляющее большинство алгоритмов предполагает принятие торговых решений в зависимости от текущего состояния ордеров. В одних случаях, например, для открытия рыночного ордера требуется, чтобы на момент осуществления торговой операции других рыночных ордеров не было. В других случаях, для установки отложенного ордера необходимым условием может являться отсутствие стоп-приказов на рыночном ордере. Известны также алгоритмы, предполагающие установку одновременно двух разнонаправленных отложенных ордеров.

Чтобы удовлетворить требования той или иной тактики или стратегии к моменту принятия торгового решения, необходимо знать текущее состояние: какие рыночные и отложенные ордера имеются и какие у них характеристики. Для этого можно использовать один из двух вариантов решения.

В соответствии с первым вариантом необходимый фрагмент программного кода (в котором выполняется анализ ордеров) прописывается непосредственно в том месте программы, где нужно выяснить текущий набор ордеров и их характеристики. Такое решение технически осуществимо, но оказывается неэффективным, когда необходимо внести изменения в алгоритм. В этом случае программист вынужден анализировать все места программы, где анализируется состояние ордеров, и вносить изменения в каждом месте. Второй, более эффективный вариант решения, заключается в том, чтобы один раз создать универсальную функцию учёта ордеров и использовать её всякий раз, когда требуется обновить информацию о текущем состоянии ордеров. Такое решение, с одной стороны, позволяет значительно сократить код программы, а с другой стороны, предоставляет программисту возможность использовать готовую функцию при составлении других программ.

Для того чтобы правильно составить функцию учёта ордеров, необходимо решить, какие параметры нужно учитывать. В большинстве случаев для принятия торговых решений требуются значения следующих параметров:

  • общее количество ордеров;
  • количество ордеров каждого типа (например, сколько имеется ордеров Buy, сколько SellStop, BuyLimit и т.д.);
  • все характеристики каждого из ордеров (номер ордера, StopLoss и TakeProfit ордера, количество лотов и т.д.).

Указанная информация должна быть доступна другим функциям, а именно тем, в которых эта информация обрабатывается. По этой причине все параметры, характеризующие состояние ордеров, являются значениями глобальных массивов. Всего для учёта ордеров предусмотрено три массива:

  • массив текущих ордеров Mas_Ord_New, содержащий сведения обо всех характеристиках всех рыночных и отложенных ордеров, имеющихся на текущий момент, а именно, в период последнего исполнения функции;
  • массив старых ордеров Mas_Ord_Old, содержащий сведения обо всех характеристиках всех рыночных и отложенных ордеров, имеющихся на момент предыдущего исполнения функции;
  • массив Mas_Tip, значениями которого являются количества ордеров различных типов (на текущий момент).

Массивы Mas_Ord_New и Mas_Ord_Old подобны и имеют одинаковую размерность; разница между ними заключается лишь в том, что первый из них отражает текущее состояние ордеров, а второй - предшествующее. Рассмотрим детально, какие значения содержатся в элементах этих массивов.

Таблица 4. Соответствие элементов массивов Mas_Ord_New и Mas_Ord_Old характеристикам ордеров.

 | Не опред. | Курс открытия | StopLoss | TakeProfit | Номер ордера | Колич. лотов | Тип ордера | Magic Number | Коммент.
Индексы | 0 | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8
0 | 2.0 | 0.0 | 0.0 | 0.0 | 0.0 | 0.0 | 0.0 | 0.0 | 0.0
1 | 0.0 | 1.2583 | 1.2600 | 1.2550 | 123456.0 | 1.4 | 1.0 | 1177102416.0 | 1.0
2 | 0.0 | 1.2450 | 1.2580 | 1.2415 | 123458.0 | 2.5 | 2.0 | 1177103358.0 | 0.0
3 | 0.0 | 0.0 | 0.0 | 0.0 | 0.0 | 0.0 | 0.0 | 0.0 | 0.0
. . . | 0.0 | 0.0 | 0.0 | 0.0 | 0.0 | 0.0 | 0.0 | 0.0 | 0.0
30 | 0.0 | 0.0 | 0.0 | 0.0 | 0.0 | 0.0 | 0.0 | 0.0 | 0.0

Первый индекс массива (строки) определяет порядковый номер ордера в массиве. Характеристики первого обнаруженного ордера (среди открытых рыночных и установленных отложенных ордеров) заносятся в первую строку массива, второго ордера - во вторую строку и т.д. Размер массива по первому индексу равен 31, таким образом, массив предназначен для хранения информации максимум о тридцати ордерах, одновременно присутствующих в торговле по одному торговому счёту. В случае, если торговая стратегия допускает наличие одновременно более тридцати ордеров, то при объявлении массива необходимо указать соответствующее значение для первого индекса. (В подавляющем большинстве случаев значение 30 значительно превышает действительную потребность, которая может составлять от 2 до 10-15. Здесь для примера используется значение 30, принятое с большим запасом, в предположении, что функция может использоваться и в случае реализации своеобразной торговой стратегии).

Второй индекс массива (столбцы) соответствует характеристикам ордеров. Каждый элемент массива со вторым индексом, равным 1, содержит значение курса открытия ордера, с индексом 2 - значение StopLoss ордера, 3 - TakeProfit ордера и т.д. (см. Таблицу 4). Элемент массива с индексом [0][0] имеет значение, равное общему количеству ордеров, содержащихся в массиве. Все элементы массива с первым или вторым индексом, равным 0, не используются (кроме элемента с индексом [0][0]).

В таблице 4 показано состояние массива, содержащего информацию о двух ордерах, в некоторый момент времени одновременно присутствующих в торговле. Элемент массива Mas_Ord_New[0][0] имеет значение 2.0 - общее количество ордеров - два. Элементы первой строки массива содержат значения характеристик рыночного ордера Sell (Mas_Ord_New[1][6] = 1.0, см. Типы торговых операций), открытого на 1.4 лота (Mas_Ord_New[1][5] =1.4), имеющего номер 123456 (Mas_Ord_New[1][4] =123456.0). Значение элемента Mas_Ord_New[1][8] =1.0 означает, что этот ордер имеет непустой комментарий. Во второй строке массива содержатся значения, характеризующие второй ордер. В частности, элемент массива Mas_Ord_New[2][6] имеет значение 2.0, - значит, это ордер BuyLimit.

Массив Mas_Tip отражает количество ордеров каждого типа. Значения индексов этого массива поставлены в соответствие типам торговых операций (см. Типы торговых операций). Это означает, что элемент массива Mas_Tip с индексом 0 содержит количество одновременно присутствующих в торговле рыночных ордеров типа Buy, с индексом 1 - ордеров типа Sell, с индексом 2 - типа BuyLimit и т.д. Для ситуации, отражённой в таблице 4, элементы массива Mas_Tip будут иметь следующие значения:

Таблица 5. Соответствие элементов массива Mas_Tip количеству ордеров различных типов.

 | Buy | Sell | BuyLimit | SellLimit | BuyStop | SellStop
Индекс | 0 | 1 | 2 | 3 | 4 | 5
Значение | 0 | 1 | 1 | 0 | 0 | 0

В данном случае значения элементов массива Mas_Tip означают следующее: Mas_Tip[1] равно 1, значит, в торговле имеется один ордер Sell; Mas_Tip[2] также равно 1, значит, в торговле есть один отложенный ордер BuyLimit. Остальные элементы массива имеют нулевые значения, значит ордеров этого типа в торговле нет. В случае если в торговле присутствуют одновременно несколько ордеров одного типа, то соответствующий элемент массива будет иметь значение, равное количеству таких ордеров. Например, если в торговле имеется три ордера BuyStop, то элемент Mas_Tip[4] будет иметь значение 3.

Предлагаемая здесь функция учёта ордеров Terminal() оформлена в виде включаемого файла Terminal.mqh.

Пользовательская функция Terminal()

int Terminal()

Функция выполняет учёт рыночных и отложенных ордеров. В результате исполнения функции изменяются значения следующих глобальных массивов:

  • Mas_Ord_New - массив характеристик ордеров, имеющихся на момент исполнения функции;
  • Mas_Ord_Old - массив характеристик ордеров, имеющихся на момент предыдущего исполнения функции;
  • Mas_Tip - массив количества ордеров всех типов.

Включаемый файл Terminal.mqh, содержащий описание функции учёта ордеров Terminal():

//--------------------------------------------------------------------
// Terminal.mqh
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------- 1 --
// Функция учёта ордеров
// Глобальные переменные:
// Mas_Ord_New[31][9]   // Массив ордеров последний известный
// Mas_Ord_Old[31][9]   // Массив ордеров предыдущий (старый)
                        // 1й индекс = порядковый номер ордера
                        // [][0] не определяется
                        // [][1] курс откр. ордера (абс.знач.курса)
                        // [][2] StopLoss ордера   (абс.знач.курса)
                        // [][3] TakeProfit ордера (абс.знач.курса)
                        // [][4] номер ордера
                        // [][5] колич. лотов орд. (абс.знач.курса)
                        // [][6] тип орд. 0=B,1=S,2=BL,3=SL,4=BS,5=SS
                        // [][7] магическое число ордера
                        // [][8] 0/1 факт наличия комментария
// Mas_Tip[6]           // Массив колич. ордеров всех типов
                        // [] тип орд: 0=B,1=S,2=BL,3=SL,4=BS,5=SS
//--------------------------------------------------------------- 2 --
int Terminal()
  {
   int Qnt=0;                          // Счётчик количества ордеров

//--------------------------------------------------------------- 3 --
   ArrayCopy(Mas_Ord_Old, Mas_Ord_New);// Сохраняем предыдущую историю
   Qnt=0;                              // Обнуление счётчика ордеров
   ArrayInitialize(Mas_Ord_New,0);     // Обнуление массива
   ArrayInitialize(Mas_Tip,    0);     // Обнуление массива
//--------------------------------------------------------------- 4 --
   for(int i=0; i<OrdersTotal(); i++) // По рыночн. и отлож. ордерам
     {
      if((OrderSelect(i,SELECT_BY_POS)==true)     //Если есть следующ.
      && (OrderSymbol()==Symbol()))               //.. и наша вал.пара
        {
         //------------------------------------------------------ 5 --
         Qnt++;                                   // Колич. ордеров
         Mas_Ord_New[Qnt][1]=OrderOpenPrice();    // Курс открытия орд
         Mas_Ord_New[Qnt][2]=OrderStopLoss();     // Курс SL
         Mas_Ord_New[Qnt][3]=OrderTakeProfit();   // Курс ТР
         Mas_Ord_New[Qnt][4]=OrderTicket();       // Номер ордера
         Mas_Ord_New[Qnt][5]=OrderLots();         // Количество лотов
         Mas_Tip[OrderType()]++;                  // Кол. ордеров типа
         Mas_Ord_New[Qnt][6]=OrderType();         // Тип ордера
         Mas_Ord_New[Qnt][7]=OrderMagicNumber();  // Магическое число
         if (OrderComment()=="")
            Mas_Ord_New[Qnt][8]=0;                // Если нет коммент
         else
            Mas_Ord_New[Qnt][8]=1;                // Если есть коммент
         //------------------------------------------------------ 6 --
        }
     }
   Mas_Ord_New[0][0]=Qnt;                         // Колич. ордеров
//--------------------------------------------------------------- 7 --
   return;
  }
//--------------------------------------------------------------- 8 --

В блоке 1-2 приводится комментарий описания глобальных массивов, используемых в функции. Глобальные массивы объявлены во включаемом файле Variables.mqh. В блоке 3-4 содержание массива Mas_Ord_New копируется в массив Mas_Ord_Old. Таким образом, ранее известное состояние ордеров запоминается и в дальнейшем может использоваться в программе. Далее значения элементов массивов Mas_Ord_New и Mas_Tip, отражающих новое состояние ордеров, обнуляется перед обновлением данных в блоке 4-7.

Блок 4-7 содержит цикл for, в котором последовательно опрашиваются все рыночные и отложенные ордера по финансовому инструменту, в окно которого прикреплён эксперт. Отбор ордеров производится с помощью функции OrderSelect() в соответствии с параметром MODE_TRADES, заданным по умолчанию. В блоке 5-6 вычисляются все необходимые характеристики для отобранных ордеров, и полученные значения заносятся в массив новых ордеров Mas_Ord_New. Одновременно производится подсчёт количества ордеров всех типов, и полученные значения присваиваются соответствующим элементам массива Mas_Tip. По окончании цикла общее количество ордеров по финансовому инструменту присваивается элементу Mas_Ord_New[0][0].

Отдельно нужно заметить, что анализ закрытых рыночных и удалённых отложенных ордеров (исполнение функции OrderSelect() с параметром MODE_HISTORY) не выполняется. Как правило, сведения о закрытых и удалённых ордерах в торгующих экспертах не используются. Сведения о закрытых и отложенных ордерах представляют историю по торговому счёту. Эти сведения могут быть использованы, например, для построения диаграмм, отражающих динамику вложения средств и фактических результатов торгов, однако не могут принести какую бы то ни было пользу для принятия новых торговых решений. Технически учёт этой части ордеров может быть выполнен аналогичным способом, однако, это - отдельная задача, которая не имеет отношения к торговле.

Анализ событий, связанных с ордерами, в программе выполняется на основе сравнения данных, имеющихся в рассмотренных массивах. Например, если массив Mas_Ord_Old содержит сведения о некотором отложенном ордере, номер которого 246810, а массив Mas_Ord_New содержит сведения о том же ордере 246810, но при этом ордер имеет уже другой тип, значит отложенный ордер был преобразован в рыночный. Анализ ордеров необходим также при осуществлении торговых операций (рассматривается в последующем изложении).

Перед самым первым исполнением функции Terminal() массивы Mas_Ord_Old и Mas_Ord_New пустые, т.е. каждый элемент обоих массивов имеет нулевое значение. Это значит, что после первого исполнения функции массив Mas_Ord_Old в строке

   ArrayCopy(Mas_Ord_Old, Mas_Ord_New);// Сохраняем предыдущую историю

наследует от массива Mas_Ord_New "нулевое" состояние, в результате чего при исполнении функции обработки событий могут появиться ложные сигналы о событиях. Для того чтобы этого не происходило, самое первое исполнение функции Terminal() осуществляется на этапе инициализации, и обработка событий после этого исполнения функции не производится (см. функцию init() в эксперте usualexpert.mq4).

Структура обычной программыИнформационная функция


Структура обычной программы - Создание обычной программы - Учебник по MQL4

Учебник по MQL4 [image] Создание обычной программы [image] Структура обычной программы
MetaQuotes Sofware Corp.
  • Структура обычной программы
  • Учёт ордеров
  • Информационная функция
  • Функция слежения за событиями
  • Функция определения количества лотов
  • Функция определения торговых критериев
  • Торговые функции
  • Функция обработки ошибок
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Структура обычной программы

Основной отличительной особенностью обычной программы является её структура, позволяющая легко применять те или иные пользовательские функции. Обычно для удобства пользовательские функции оформляются в виде включаемых файлов (.mqh), которые хранятся в каталоге Каталог_терминала\experts\include.

Как правило, обычная программа содержит все три специальные функции, которые вызывают для исполнения необходимые пользовательские функции. Пользовательские функции, в свою очередь, могут вызывать для исполнения другие пользовательские функции, при этом каждая из них имеет своё функционально ограниченное назначение.

В составе эксперта могут применяться пользовательские функции с самыми разнообразными свойствами. Одни функции, например, предназначены для отслеживания событий и удобного вывода информации, другие - для формирования торговых приказов, третьи - для различных вычислений, например, определения торговых критериев, вычисления стоимости ордеров и т.д. Решение о том, какие функции использовать в программе, зависит от назначения эксперта и от того, какой сервис программа должна предоставлять пользователю. На рис. 155 приведена структурная схема обычного торгующего эксперта, построенного на небольшом наборе пользовательских функций.

Рис. 155. Структурная схема обычной программы (эксперт).

Стрелками на структурной схеме показаны связи между различными функциями. Например, функция учёта ордеров вызывается в эксперте из специальной функции init(), специальной функции start(), а также может быть вызвана из любого другого места программы. В правой части схемы показаны стрелки связей, символизирующие возможность вызова одной пользовательской функции из другой. Например, функция определения торговых критериев не вызывается ни из одной специальной функции, но может быть вызвана для исполнения торговой функцией. Информационная функция вызывается из специальной функции deinit(), а также при необходимости вызывается другими функциями, например, функцией обработки ошибок, торговыми функциями, функцией слежения за событиями. Включаемый файл объявления переменных не вызывается ни из одной функции, потому что имеющийся в нём код не является описанием функции, которая может быть вызвана и исполнена. Этот файл содержит строки объявления глобальных переменных, поэтому просто является составной частью эксперта. Для того чтобы понять, каким образом различные части эксперта взаимодействуют между собой, рассмотрим порядок создания и использования включаемых файлов.

Использование включаемых файлов

Если прикладная программа содержит множество программных строк, то её отладка бывает затруднительной - программисту приходится многократно прокручивать текст программы, чтобы внести изменения в код в том или ином месте. В подобных случаях для удобства программа может быть разделена на несколько фрагментов, каждый из которых оформляется в виде отдельного включаемого файла. Включаемые файлы могут содержать любой фрагмент кода, который предполагается использовать в программе. Обычно каждая используемая в программе функция оформляется в виде включаемого файла. Если несколько функций логически связаны между собой, то содержанием одного включаемого файла может быть описание нескольких пользовательских функций.

В разделе Информация о счёте рассматривался пример защитного кода, предотвращающего несанкционированное использование коммерческих программ. В эксперте check.mq4 соответствующая часть программного кода представлена в виде пользовательской функции Check(), описание которой содержится непосредственно в исходном тексте эксперта. В эксперте usualexpert.mq4 (см. рис. 91.3) также используется эта функция, но в этом случае функция оформлена в виде включаемого файла Check.mqh.

Пользовательская функция Check()

bool Check()

Функция возвращает TRUE, если соблюдены условия использования прикладной программы, возвращает FALSE, если условия не соблюдены.

Условия использования программы считаются выполненными, если:

  • программа используется на демо-счёте;
  • счёт открыт в компании SuperBank;
  • при работе на реальном счёте пользователь установил правильное значение внешней переменной Parol.

Включаемый файл Check.mqh, содержащий описание пользовательской функции Check():

//--------------------------------------------------------------------
// Check.mqh
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------- 1 --
// Функция проверки легальности использования программы
// Входные параметры:
// - глобальная переменная Parol
// - локальная константа "SuperBank"
// Возвращаемые значения:
// true  - если условия использования соблюдены
// false - если условия использования нарушены
//--------------------------------------------------------------- 2 --
extern int Parol=12345; // Пароль для работы на реальном счёте
//--------------------------------------------------------------- 3 --
bool Check()                           // Пользовательская функция
  {
   if (IsDemo()==true)                 // Если это демо-счёт, то..
      return(true);                    // .. других ограничений нет
   if (AccountCompany()=="SuperBank")  // Для корпоративных клиентов..
      return(true);                    // ..пароль не нужен
   int Key=AccountNumber()*2+1000001;  // Вычисляем ключ
   if (Parol==Key)                     // Если пароль верный, то..
      return(true);                    // ..разрешаем работу на реале
   Inform(14);                         // Сообщение о несанкц. работе
   return(false);                      // Выход из пользов. функции
  }
//--------------------------------------------------------------- 4 --

Легко заметить, что название включаемого файла совпадает с названием содержащейся в нём функции. Правилами языка MQL4 такое требование не предусмотрено. В общем случае название включаемого файла не обязательно должно совпадать с названием функции, которая в нём содержится. Тем более это понятно, если учесть, что один файл может нести описание нескольких функций или какого-либо фрагмента программы, вообще не являющегося функцией. Однако практика присваивать включаемому файлу имя, совпадающее с именем описанной в нём функции, оправданна. При этом значительно облегчается труд программиста: он легко может понять, какие функции имеются в каталоге Каталог_терминала\experts\include, ориентируясь по именам файлов. Для того чтобы фрагмент программы, содержащийся в файле, включить в программу, используется директива #include.

Директива #include

#include <Имя файла>
#include "Имя файла"

Директива #include может быть указана в любом месте программы, но обычно все включения размешаются в начале файла исходного текста. Препроцессор заменяет строку #include <имя_файла> (или строку #include "имя_файла") содержимым файла с указанным именем.

Угловые скобки обозначают, что файл будет взят из стандартного каталога Каталог_терминала\experts\include (текущий каталог не просматривается). Если имя файла заключено в кавычки, то поиск производится в текущем каталоге, а именно в том, в котором содержится основной файл исходного текста (стандартный каталог не просматривается).

Ниже представлен обычный эксперт usualexpert.mq4. Все включаемые файлы размещены в головной части программы.

//--------------------------------------------------------------------
// usualexpert.mq4
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------- 1 --
#property copyright "Copyright © Book, 2007"
#property link      "http://AutoGraf.dp.ua"
//--------------------------------------------------------------- 2 --
#include <stdlib.mqh>
#include <stderror.mqh>
#include <WinUser32.mqh>
//--------------------------------------------------------------- 3 --
#include <Variables.mqh>   // Описание переменных
#include <Check.mqh>       // Проверка легальности использов. программ
#include <Terminal.mqh>    // Учёт ордеров
#include <Events.mqh>      // Функция слежения за событиями, обновлен.
#include <Inform.mqh>      // Информационная функция
#include <Trade.mqh>       // Торговая функция
#include <Open_Ord.mqh>    // Открытие одного ордера заданного типа
#include <Close_All.mqh>   // Закрытие  всех ордеров заданного типа
#include <Tral_Stop.mqh>   // Модификация StopLoss всех ордеров типа
#include <Lot.mqh>         // Вычисление количества лотов
#include <Criterion.mqh>   // Торговые критерии
#include <Errors.mqh>      // Функция обработки ошибок.
//--------------------------------------------------------------- 4 --
int init()                             // Спец. функция init
  {
   Level_old=MarketInfo(Symbol(),MODE_STOPLEVEL );//Миним. дистаниция
   Terminal();                         // Функция учёта ордеров
   return;                             // Выход из init()
  }
//--------------------------------------------------------------- 5 --
int start()                            // Спец. функция start
  {
   if(Check()==false)                  // Если условия использования..
      return;                          // ..не выполняются, то выход
   PlaySound("tick.wav");              // На каждом тике
   Terminal();                         // Функция учёта ордеров
   Events();                           // Информация о событиях
   Trade(Criterion());                 // Торговая функция
   Inform(0);                          // Для перекрашивания объектов
   return;                             // Выход из start()
  }
//--------------------------------------------------------------- 6 --
int deinit()                           // Спец. функция deinit()
  {
   Inform(-1);                         // Для удаления объектов
   return;                             // Выход из deinit()
  }
//--------------------------------------------------------------- 7 --

В блоке 2-3 с помощью директивы #include в программу включены стандартные файлы stdlib.mqh, stderror.mqh и WinUser32.mqh. Использование этих файлов в программе бывает необходимо не всегда. Например, файл stderror.mqh содержит определение стандартных констант, используемых при обработке ошибок. Если в программе не предусмотрен анализ ошибок (указанные константы не используются), то включать этот фал в исходный текст нет необходимости. Вместе с тем, в обычной программе, как правило, требуется использование указанных файлов.

В блоке 3-4 в программу включены несколько файлов, содержащих описание пользовательских функций. В том числе, с помощью директивы #include, в строке:

#include <Check.mqh>       // Проверка легальности использов. программ

в исходный текст программы включается пользовательская функция Check(). Программист видит исходный текст эксперта (в данном случае - usualexpert.mq4) таким, каким он представлен выше. Однако при компиляции исходный текст программы преобразуется, а именно: вместо каждой строки, содержащей директиву #include, в программу вставляется текст, содержащийся в файле с указанным именем. Таким образом, исполняемый файл .ex4 создаётся на основе полного кода эксперта, в котором вместо каждой строки #include<Имя файла> (или #include "Имя файла") содержится соответствующий фрагмент кода.

Примером включаемого файла, в котором содержится некоторый фрагмент программы, не являющийся описанием функции, может служить файл Variables.mqh. Этот файл включается в текст программы в строке:

#include <Variables.mqh>   // Описание переменных

и содержит описание глобальных переменных, которые используются различными пользовательскими функциями.

//--------------------------------------------------------------------
// Variables.mqh
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------- 1 --
// Описание глобальных переменных
extern double Lots    = 0.0;// Количество лотов
extern int Percent    = 0;  // Процент выделенных средств
extern int StopLoss   =100; // StopLoss для новых ордеров (пунктов)
extern int TakeProfit =40;  // TakeProfit для новых ордеров (пунктов)
extern int TralingStop=100; // TralingStop для рыночных ордеров (пунк)
//--------------------------------------------------------------- 2 --
int
   Level_new,           // Новое значение минимальной дистанции
   Level_old,           // Предыдущее значение минимальной дистанции
   Mas_Tip[6];          // Массив типов ордеров
                        // [] тип орд: 0=B,1=S,2=BL,3=SL,4=BS,5=SS
//--------------------------------------------------------------- 3 --
double
   Lots_New,            // Количество лотов для новых ордеров
   Mas_Ord_New[31][9],  // Массив ордеров текущий ..
   Mas_Ord_Old[31][9];  // .. и старый
                        // 1й индекс = порядковый номер ордера
                        // [][0] не определяется
                        // [][1] курс откр. ордера (абс.знач.курса)
                        // [][2] StopLoss ордера   (абс.знач.курса)
                        // [][3] TakeProfit ордера (абс.знач.курса)
                        // [][4] номер ордера
                        // [][5] колич. лотов орд. (абс.знач.курса)
                        // [][6] тип орд. 0=B,1=S,2=BL,3=SL,4=BS,5=SS
                        // [][7] магическое число ордера
                        // [][8] 0/1 факт наличия комментария
//--------------------------------------------------------------- 4 --

В соответствии с правилами MQL4 объявление любой, в том числе и глобальной, переменной должно осуществляться до первого обращения к этой переменной. По этой причине файл Variables.mqh включён в программу раньше (выше по тексту), чем файлы функций, использующих значения указанных в этом файле переменных. По этой же причине в этот файл вынесены все глобальные переменные.

В некоторых (редких) случаях имеется техническая возможность объявить глобальную переменную во включаемом файле, описывающем функцию, в которой впервые в программе используется значение этой переменной. В таких случаях необходимо следить за порядком включения файлов. Т.е. требуется, чтобы программная строка с директивой #include, включающей файл (с объявлением глобальной переменной) в программу, находилась выше по тексту, чем строки, включающие другие файлы, где используется значение этой глобальной переменной.

В других случаях нет даже указанной технической возможности. Например, если имеется два включаемых файла, каждый из которых использует две глобальные переменные, одна из которых объявлена в одном файле, а другая в другом, то при компиляции такой программы будет получена ошибка, т.к. независимо от порядка включения файлов одна из переменных используется раньше, чем она объявлена в программе. Поэтому, обычная практика объявления глобальных переменных в обычной программе предполагает объявление всех без исключения глобальных переменных в одном файле, который включается в программу раньше других файлов, содержащих описание пользовательских функций.

В блоке 1-2 включаемого файла Variables.mqh указаны внешние переменные, значения которых определяют количество лотов для новых ордеров, процент свободных средств, выделенный для новых ордеров, заявленные цены для стоп-приказов открываемых рыночных ордеров, а также дистанцию TralingStop для модификации StopLoss ордера. В блоках 2-4 указаны другие глобальные переменные, смысл которых будет понятен при рассмотрении соответствующих пользовательских функций. В следующих разделах главы представлены включаемые файлы, каждый из которых содержит описание одноимённой пользовательской функции.

Создание обычной программыУчёт ордеров


Торговые функции - Создание обычной программы - Учебник по MQL4

Учебник по MQL4 [image] Создание обычной программы [image] Торговые функции
MetaQuotes Sofware Corp.
  • Структура обычной программы
  • Учёт ордеров
  • Информационная функция
  • Функция слежения за событиями
  • Функция определения количества лотов
  • Функция определения торговых критериев
  • Торговые функции
  • Функция обработки ошибок
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Торговые функции

Как правило, обычный эксперт содержит несколько торговых функций. Их можно разделить на две категории - управляющие и исполнительные. В большинстве случаев в эксперте используется всего одна управляющая функция и несколько исполнительных.

Торговая стратегия в обычном эксперте реализуется на основе двух функций - функции определения торговых критериев и управляющей торговой функции. Нигде в других местах программы не должно быть каких-либо указаний на торговую стратегию. Управляющая торговая функция и функция определения критериев должны быть согласованы между собой по значениям передаваемых параметров.

Каждая из исполнительных торговых функций имеет свой обособленный круг задач. В зависимости от требований торговой стратегии в эксперте могут применяться исполнительные торговые функции, имеющие следующее назначение:

  • открытие рыночного ордера заданного типа;
  • закрытие одного рыночного ордера заданного типа;
  • частичное закрытие одного рыночного ордера заданного типа;
  • закрытие всех рыночных ордеров заданного типа;
  • встречное закрытие двух рыночных ордеров в заданном объёме;
  • закрытие всех рыночных ордеров;
  • модификация стоп-приказов рыночного ордера заданного типа;
  • установка отложенного ордера заданного типа;
  • удаление одного отложенного ордера заданного типа;
  • удаление всех отложенных ордеров заданного типа;
  • удаление всех отложенных ордеров;
  • модификация отложенного ордера заданного типа.

Общий порядок осуществления торговли в обычном эксперте заключается в следующем: на основе вычисленных (в соответствии со стратегией) торговых критериев управляющая торговая функция (также реализуя стратегию) вызывает те или иные исполнительные торговые функции, которые, в свою очередь, формируют необходимые торговые приказы.

Пользовательская управляющая торговая функция Trade()

int Trade( int Trad_Oper )

Основная функция, реализующая стратегию.

Параметр Trad_Oper может принимать следующие значения, соответствующие торговым критериям:
10 - сработал торговый критерий для открытия рыночного ордера Buy;
20 - сработал торговый критерий для открытия рыночного ордера Sell;
11 - сработал торговый критерий для закрытия рыночного ордера Buy;
21 - сработал торговый критерий для закрытия рыночного ордера Sell;
0 - значимых критериев нет;
-1 - используемый финансовый инструмент не является EURUSD.

Для исполнения функции требуются следующие торговые функции:

  • Close_All() - функция закрытия всех рыночных ордеров заданного типа;
  • Open_Ord() - функция открытия одного рыночного ордера заданного типа;
  • Tral_Stop() - функция модификации StopLoss рыночного ордера заданного типа;
  • Lot() - функция определения количества лотов для новых ордеров.

Управляющая торговая функция Trade() оформлена в виде включаемого файла Trade.mqh:

//--------------------------------------------------------------------
// Trade.mqh
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------------
// Торговая функция.
//--------------------------------------------------------------- 1 --
int Trade(int Trad_Oper)              // Пользовательская функция
  {
   // Trad_Oper - тип торговой операции:
   // 10 - открытие Buy
   // 20 - открытие Sell
   // 11 - закрытие Buy
   // 21 - закрытие Sell
   //  0 - значимых критериев нет
   // -1 - используется другой финансовый инструмент
   switch(Trad_Oper)
     {
      //--------------------------------------------------------- 2 --
      case 10:                         // Торговый критерий = Buy
         Close_All(1);                 // Закрыть все Sell
         if (Lot()==false)             // Средств не хватает на миним.
            return;                    // Выход из пользов. функции
         Open_Ord(0);                  // Открыть Buy
         return;                       // Поторговали - уходим
         //------------------------------------------------------ 3 --
      case 11:                         // Торг. крит. = закрытие Buy
         Close_All(0);                 // Закрыть все Buy
         return;                       // Поторговали - уходим
         //------------------------------------------------------ 4 --
      case 20:                         // Торговый критерий = Sell
         Close_All(0);                 // Закрыть все Buy
         if (Lot()==false)
            return;                    // Выход из пользов. функции
         Open_Ord(1);                  // Открыть Sell
         return;                       // Поторговали - уходим
         //------------------------------------------------------ 5 --
      case 21:                         // Торг. крит. = закрытие Sell
         Close_All(1);                 // Закрыть все Sell
         return;                       // Поторговали - уходим
         //------------------------------------------------------ 6 --
      case 0:                          // Удержание открытых позиций
         Tral_Stop(0);                 // Трейлинг стоп Buy
         Tral_Stop(1);                 // Трейлинг стоп Sell
         return;                       // Поторговали - уходим
         //------------------------------------------------------ 7 --
     }
  }
//--------------------------------------------------------------- 8 --

Вызов управляющей торговой функции Trade() осуществляется из специальной функции start() эксперта usualexpert.mq4. В качестве передаваемого параметра в функции Trade() указано значение, возвращаемое функцией определения торговых критериев Criterion().

В блоке 1-2 функции Trade() описаны торговые критерии, принимаемые во внимание реализованной торговой стратегией. В функции используется оператор switch() (блоки 2-7), позволяющий активизировать необходимую группу функций для осуществления торговли согласно торговому критерию. В соответствии с принятой в эксперте торговой стратегией эксперт открывает и закрывает только рыночные ордера, использование отложенных ордеров в этой стратегии не предусмотрено.

В разделе Функция определения торговых критериев указывалось, что по некоторым торговым критериям может быть сформировано несколько различных торговых приказов. Так, в случае, если значимым является торговый критерий на покупку (значение переменной Trad_Oper равно 10), то при исполнении оператора switch() управление передаётся на метку case 10 (блок 2-3). В этом случае сначала вызывается торговая функция Close_All(1). Исполнение этой функции приводит к закрытию всех рыночных ордеров Sell, открытых по финансовому инструменту EURUSD. После того как все ордера Sell закрыты, выполняется проверка достаточности средств для совершения следующей торговой операции. Для этого вызывается пользовательская функция Lot() (см. раздел Функция определения количества лотов). Если эта функция возвращает false, значит имеющихся средств недостаточно даже для открытия ордера Buy на минимально допустимое количество лотов. В этом случае функция Trade() заканчивает свою работу. Если же средств достаточно, то вызывается торговая функция Open_Ord(0) для открытия одного рыночного ордера Buy на такое количество лотов, которое вычислено при исполнении функции Lot(). Указанная совокупность действий являет реакцию эксперта на сложившуюся ситуацию на рынке (в соответствии с данным торговым критерием).

Если значимым является критерий, указывающий на необходимость закрытия рыночных ордеров Buy, то управление передаётся на метку case 11, в блок 3-4. В этом случае вызывается для исполнения всего одна функция Close_All(0) для закрытия всех имеющихся рыночных ордеров типа Buy. Блоки 4-6 составлены аналогично блокам 2-4, управление вариантам case 20 и case 21 передаётся в случаях, если значимыми являются критерии на продажу или закрытие рыночных ордеров Sell.

Обратите внимание, все исполнительные торговые функции, формирующие торговые приказы, вызываются из функции Trade(), которая в свою очередь вызывается при исполнении специальной функции start() эксперта, запускаемой клиентским терминалом в результате прихода очередного тика. Код функции Trade() составлен таким образом, что управление не возвращается в функцию start() (и в конечном счёте клиентскому терминалу) до тех пор, пока не будут исполнены все необходимые исполнительные торговые функции. Поэтому все торговые операции, предусмотренные для каждого из торговых критериев, осуществляются экспертом подряд, без пауз. Исключение составляют случаи, когда при исполнении торговых операций возникают критические ошибки (см. раздел Функция обработки ошибок).

Если при исполнении функции Criterion() определено, что ни один из торговых критериев не является значимым (переменная Trad_Oper равна 0), то управление передаётся на метку case 0, в результате чего дважды вызывается для исполнения функция Tral_Stop() для модификации заявленных значений рыночных ордеров разных типов. Реализованная в эксперте торговая стратегия допускает наличие только одного рыночного ордера, поэтому порядок следования вызовов функций Tral_Stop(0) и Tral_Stop(1) не имеет значения. В данном случае сделан случайный выбор.

В случае, если функция Criterion() вернула значение -1, то это означает, что эксперт прикреплён в окно финансового инструмента, не являющегося EURUSD. В этом случае функция Trade() не осуществляет вызов каких-либо исполнительных торговых функций и возвращает управление вызвавшей её специальной функции start().

Пользовательская исполнительная торговая функция Close_All()

int Close_All( int Tip)

Функция закрывает все рыночные ордера указанного типа.

Параметр Tip может принимать следующие значения, соответствующие типу закрываемых ордеров:
0 - тип закрываемых ордеров Buy;
1 - тип закрываемых ордеров Sell.

Для исполнения функции требуется применение в программе функции учёта ордеров Terminal(), функции слежения за событиями Events() и функции обработки ошибок Errors(). Для вывода сообщений функция предполагает использование информационной функции Inform(). В случае, если функция Inform() не включена в эксперт, сообщения не выводятся.

Используются значения глобальных массивов:

  • Mas_Ord_New - массив характеристик ордеров на момент последнего исполнения функции Terminal();
  • Mas_Tip - массив количества ордеров всех типов на момент последнего исполнения функции Terminal().

Исполнительная торговая функция Close_All() оформлена в виде включаемого файла Close_All.mqh:

//--------------------------------------------------------------------
// Close_All.mqh
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------- 1 --
// Функция закрытия всех рыночных ордеров указанного типа
// Глобальные переменные:
// Mas_Ord_New   Массив ордеров последний известный
// Mas_Tip       Массив типов ордеров
//--------------------------------------------------------------- 2 --
int Close_All(int Tip)                    // Пользовательская функция
  {
   // int Tip                             // Тип ордера
   int Ticket=0;                          // Номер ордера
   double Lot=0;                          // Количество закр. лотов
   double Price_Cls;                      // Цена закрытия ордера
//--------------------------------------------------------------- 3 --
   while(Mas_Tip[Tip]>0)                 // До тех пор, пока есть ..
     {                                   //.. ордера заданного типа
      for(int i=1; i<=Mas_Ord_New[0][0]; i++)// Цикл по живым ордерам
        {
         if(Mas_Ord_New[i][6]==Tip &&     // Среди ордеров нашего типа
            Mas_Ord_New[i][5]>Lot)        // .. выбираем самый дорогой
           {                              // Этот больше ранее найден.
            Lot=Mas_Ord_New[i][5];        // Наибольший найденный лот
            Ticket=Mas_Ord_New[i][4];     // Номер его ордера такой
           }
        }
      if (Tip==0) Price_Cls=Bid;          // Для ордеров Buy
      if (Tip==1) Price_Cls=Ask;          // Для ордеров Sell
      Inform(12,Ticket);                  // Сообщение о попытке закр.
      bool Ans=OrderClose(Ticket,Lot,Price_Cls,2);// Закрыть ордер !:)
      //--------------------------------------------------------- 4 --
      if (Ans==false)                     // Не получилось :(
        {                                // Поинтересуемся ошибками:
         if(Errors(GetLastError())==false)// Если ошибка непреодолимая
            return;                       // .. то уходим.
        }
      //--------------------------------------------------------- 5 --
      Terminal();                         // Функция учёта ордеров
      Events();                           // Отслеживание событий
     }
   return;                                // Выход из пользов. функции
  }
//--------------------------------------------------------------- 6 --

В блоке 1-2 описаны используемые глобальные переменные, в блоке 2-3 открыты и описаны локальные переменные. Условие Mas_Tip[Tip]>0 в заголовке оператора цикла while (блоки 3-6) предполагает, что функция будет удерживать управление до тех пор, пока не выполнит своё предназначение, а именно, пока не будут закрыты все ордера заданного типа. Элемент глобального массива Mas_Tip[Tip] содержит значение, равное количеству ордеров заданного типа Tip. Например, если функция Close_All() вызвана с передаваемым параметром, равным 1, то это означает, что ей предписывается закрыть все рыночные ордера Sell (см. Типы торговых операций). В этом случае значение элемента массива Mas_Tip[1] будет равно количеству имеющихся ордеров Sell (последнему известному на момент исполнения функции Terminal()). Таким образом, оператор цикла while будет исполнен столько раз, сколько имеется ордеров Sell.

Если трейдер не вмешивается в работу эксперта (т.е. не выставляет ордера вручную), то в торговле может присутствовать только один рыночный ордер того или иного типа. Если же трейдер по своей инициативе установил дополнительно один или несколько рыночных ордеров, то при исполнении функции Close_All() должен быть соблюдён некоторый порядок закрытия ордеров. Предпочтительным является порядок закрытия ордеров от большего к меньшему. Например, если на момент начала исполнения функции Close_All() имеется три ордера Sell, причём один из них открыт на 5 лотов, другой на 1 лот, а третий - на 4 лота, то в соответствии с указанным порядком ордера будут закрыты в такой последовательности: сначала ордер в объёме 5 лотов, потом 4 лота и последним - ордер объёмом 1 лот.

Обратите внимание, количество лотов - единственный критерий, принятый для определения порядка закрытия ордеров. Прибыль/убыток по ордеру, курс открытия ордера, а также другие параметры, характеризующие ордер (заявленные цены стоп-приказов, время и причина открытия и пр.), не рассматриваются.

Все рыночные ордера определённого типа должны быть закрыты в случае, если критерий закрытия ордеров этого типа является значимым, в порядке от большего к меньшему.

Для соблюдения указанного порядка закрытия ордеров в блоке 3-4 используется цикл for, в котором среди всех ордеров заданного типа выбирается один ордер, имеющий наибольшее количество лотов. Поиск этого ордера выполняется на основе анализа значений элементов глобального массива Mas_Ord_New, содержащего информацию обо всех ордерах, присутствующих в торговле. После того как номер этого ордера определён, в зависимости от типа ордера вычисляется заявленная цена закрытия, равная соответствующему значению последней известной двухсторонней котировки. Если тип закрываемых ордеров Buy, то следует заявлять цену закрытия в соответствии со значением Bid, а если Sell, - то Ask.

Непосредственно перед формированием торгового приказа выводится информация о попытке закрыть ордер, для этого используется вызов функции Inform(). Торговый приказ на закрытие ордера формируется в строке:

      bool Ans=OrderClose(Ticket,Lot,Price_Cls,2);// Закрыть ордер !:)

В качестве параметров используются вычисленные значения: Ticket - номер ордера, Lot - количество лотов, Price_Cls - заявленная цена закрытия, 2 - проскальзывание.

В блоке 4-5 выполняется анализ результатов выполнения торговой операции. Если функция OrderClose() вернула значение true, то это означает, что торговая операция успешно завершена, т.е. ордер закрыт. В этом случае управление передаётся в блок 5-6, где обновляется информация об ордерах, имеющихся на текущий момент. После исполнения функций Terminal() и Events() текущая итерация цикла while заканчивается (за время, пока исполняется функция, в том числе, выполняются торговые операции, количество ордеров может измениться, поэтому исполнение функции учёта ордеров на каждой итерации цикла while обязательно). В случае если в торговле ещё присутствуют ордера заданного типа, то на следующей итерации цикла while они будут закрыты, при этом для определения параметров очередного закрываемого ордера используются новые значения элементов массивов Mas_Ord_New и Mas_Tip, полученные при исполнении функции Terminal().

Если в результате исполнения торгового приказа функция OrderClose() вернула значение false, то это значит, что ордер не закрыт. Чтобы выяснить причину неудачи выполняется анализ последней ошибки, возникшей при попытке осуществления торговой операции. Для этого вызывается функция Errors() (см. раздел Функция обработки ошибок). Если при исполнении этой функции обнаруживается, что ошибка является непреодолимой (например, торговля запрещена), то функция Close_All() заканчивает работу и возвращает управление в управляющую торговую функцию Trade(), что в конечном счёте приводит к завершению исполнения специальной функции start() эксперта. На следующем тике торговый терминал снова запустит на исполнение функцию start(), и если критерий закрытия на тот момент будет ещё актуален, то это снова приведёт к вызову на исполнение функции закрытия всех ордеров Close_All().

Пользовательская исполнительная торговая функция Open_Ord()

int Open_Ord ( int Tip)

Функция открывает один рыночный ордер указанного типа.

Параметр Tip может принимать следующие значения, соответствующие типу закрываемых ордеров:
0 - тип закрываемых ордеров Buy;
1 - тип закрываемых ордеров Sell.

Для исполнения функции требуется применение в программе функции учёта ордеров Terminal(), функции слежения за событиями Events() и функции обработки ошибок Errors(). Для вывода сообщений функция предполагает использование информационной функции Inform(). В случае, если функция Inform() не включена в эксперт, сообщения не выводятся.

Используются значения глобальных переменных:

  • Mas_Tip - массив количества ордеров всех типов на момент последнего исполнения функции Terminal();
  • StopLoss - значение StopLoss (количество пунктов);
  • TakeProfit - значение TakeProfit (количество пунктов).

Исполнительная торговая функция Open_Ord() оформлена в виде включаемого файла Open_Ord.mqh:

//--------------------------------------------------------------------
// Open_Ord.mqh
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------- 1 --
// Функция открытия одного рыночного ордера указанного типа
// Глобальные переменные:
// int Mas_Tip                Массив типов ордеров
// int StopLoss               Значение StopLoss   (количество пунктов)
// int TakeProfit             Значение TakeProfit (количество пунктов)
//--------------------------------------------------------------- 2 --
int Open_Ord(int Tip)
  {
   int    Ticket,                        // Номер ордера
          MN;                            // MagicNumber
   double SL,                            // StopLoss (относит.знач.цены)
          TP;                            // TakeProf (относит.знач.цены)
//--------------------------------------------------------------- 3 --
   while(Mas_Tip[Tip]==0)                // До тех пор, пока  ..
     {                                   //.. не достигнут успех
      if (StopLoss<Level_new)            // Если меньше допустимого..
         StopLoss=Level_new;             // .. то допустимый
      if (TakeProfit<Level_new)          // Если меньше допустимого..
         TakeProfit=Level_new;           // ..то допустимый
      MN=TimeCurrent();                  // Простой MagicNumber
      Inform(13,Tip);                    // Сообщение о попытке откр
      if (Tip==0)                        // Будем открывать Buy
        {
         SL=Bid - StopLoss*  Point;      // StopLoss   (цена)
         TP=Bid + TakeProfit*Point;      // TakeProfit (цена)
         Ticket=OrderSend(Symbol(),0,Lots_New,Ask,2,SL,TP,"",MN);
        }
      if (Tip==1)                        // Будем открывать Sell
        {
         SL=Ask + StopLoss*  Point;      // StopLoss   (цена)
         TP=Ask - TakeProfit*Point;      // TakeProfit (цена)
         Ticket=OrderSend(Symbol(),1,Lots_New,Bid,2,SL,TP,"",MN);
        }
      //--------------------------------------------------------- 4 --
      if (Ticket<0)                       // Не получилось :(
        {                                 // Поинтересуемся ошибками:
         if(Errors(GetLastError())==false)// Если ошибка непреодолимая
            return;                       // .. то уходим.
        }
      Terminal();                         // Функция учёта ордеров
      Events();                           // Отслеживание событий
     }
//--------------------------------------------------------------- 5 --
   return;                                // Выход из пользов. функции
  }
//--------------------------------------------------------------- 6 --

В блоках 1-3 функции Open_Ord() описаны глобальные переменные, значения которых используются при исполнении функции, а также открыты и описаны локальные переменные. Основной код функции сосредоточен в операторе цикла while (блоки 3-5), который исполняется до тех пор, пока в торговле нет ни одного ордера заданного типа Tip.

Торговая стратегия предполагает открытие ордеров, имеющих ненулевые стоп-приказы. В общем случае трейдер может установить такие значения стоп-приказов, которые не удовлетворяют требованиям дилингового центра, а именно меньше ограничивающей минимальной дистанции. Поэтому перед открытием ордера выполняется необходимая проверка: если последняя известная минимальная дистанция (Level_new) превышает значение внешней переменной StopLoss или TakeProfit, то значение этой переменной увеличивается и устанавливается равным Level_new.

Каждый открываемый ордер имеет свой уникальный MagicNumber, равный текущему серверному времени. В результате исполнения одного эксперта по финансовому инструменту может быть одновременно открыт только один рыночный ордер (или установлен отложенный). Таким образом гарантируется, что все рыночные ордера будут иметь уникальный MagicNumber. Перед открытием ордера исполняется функция Inform(), в результате чего выводится сообщение о попытке совершить торговую операцию.

В зависимости от типа ордера выполняется тело одного из операторов if. Например, если значение передаваемого параметра Tip равно 0, то это значит, что необходимо открыть ордер Buy. В этом случае вычисляются значения StopLoss и TakeProfit, соответствующие типу ордера Buy, и после этого управление передаётся в строку

         Ticket=OrderSend(Symbol(),0,Lots_New,Ask,2,SL,TP,"",MN);

для формирования торгового приказа на открытие рыночного ордера Buy. Аналогичные вычисления производятся в случае, если значение параметра Tip равно 1, т.е необходимо открыть ордер Sell.

Обработка ошибок во всех пользовательских исполнительных торговых функциях выполняется подобным образом. Если торговая операция завершилась успехом, то функция заканчивает работу (потому, что не будет выполняться очередная итерация цикла while, т.к. после исполнения функции Terminal() значение элемента массива Mas_Tip[Tip] будет равно 1). Если же торговый приказ не был исполнен, то выполняется анализ ошибок (блок 4-5). В этом случае вызывается для исполнения функция обработки ошибок Errors(). Если она возвращает false (ошибка является критической), то исполнение функции Open_Ord() заканчивается, управление последовательно возвращается в управляющую торговую функцию Trade(), специальную функцию start() и далее клиентскому терминалу. Если же ошибка является преодолимой, то после обновления массивов ордеров в функции Terminal() управление передаётся на очередную итерацию цикла while, в результате чего выполняется ещё одна попытка открыть ордер.

Таким образом, функция Open_Ord() удерживает управление до тех пор, пока не будет открыт ордер, либо при исполнении торгового приказа будет получена критическая ошибка.

Пользовательская исполнительная торговая функция Tral_Stop()

int Tral_Stop ( int Tip)

Функция модификации всех рыночных ордеров указанного типа.

Параметр Tip может принимать следующие значения, соответствующие типу закрываемых ордеров:
0 - тип закрываемых ордеров Buy;
1 - тип закрываемых ордеров Sell.

Для исполнения функции требуется применение в программе функции учёта ордеров Terminal(), функции слежения за событиями Events() и функции обработки ошибок Errors(). Для вывода сообщений функция предполагает использование информационной функции Inform(). В случае, если функция Inform() не включена в эксперт, сообщения не выводятся.

Используются значения глобальных переменных:

  • Mas_Ord_New - массив характеристик ордеров на момент последнего исполнения функции Terminal();
  • TralingStop - дистанция между рыночной ценой и желаемым значением заявленной цены StopLoss (количество пунктов).

Исполнительная торговая функция Tral_Stop() оформлена в виде включаемого файла Tral_Stop.mqh:

//--------------------------------------------------------------------
// Tral_Stop.mqh
// Предназначен для использования в качестве примера в учебнике MQL4.
//--------------------------------------------------------------- 1 --
// Функция модификации StopLoss всех ордеров указанного типа
// Глобальные переменные:
// Mas_Ord_New             Массив ордеров последний известный
// int TralingStop         Значение TralingStop(количество пунктов)
//--------------------------------------------------------------- 2 --
int Tral_Stop(int Tip)
  {
   int Ticket;                      // Номер ордера
   double
   Price,                           // Цена открытия рыночного ордера
   TS,                              // TralingStop (относит.знач.цены)
   SL,                              // Значение StopLoss ордера
   TP;                              // Значение TakeProfit ордера
   bool Modify;                     // Признак необходимости модифи.
//--------------------------------------------------------------- 3 --
   for(int i=1;i<=Mas_Ord_New[0][0];i++)  // Цикл по всем ордерам
     {                                    // Ищем ордера задан. типа
      if (Mas_Ord_New[i][6]!=Tip)         // Если это не наш тип..
         continue;                        //.. то переступим ордер
      Modify=false;                       // Пока не назначен к модифи
      Price =Mas_Ord_New[i][1];           // Цена открытия ордера
      SL    =Mas_Ord_New[i][2];           // Значение StopLoss ордера
      TP    =Mas_Ord_New[i][3];           // Значение TakeProft ордера
      Ticket=Mas_Ord_New[i][4];           // Номер ордера
      if (TralingStop<Level_new)          // Если меньше допустимого..
         TralingStop=Level_new;           // .. то допустимый
      TS=TralingStop*Point;               // То же в относит.знач.цены
      //--------------------------------------------------------- 4 --
      switch(Tip)                         // Переход на тип ордера
        {
         case 0 :                         // Ордер Buy
            if (NormalizeDouble(SL,Digits)<// Если ниже желаемого..
               NormalizeDouble(Bid-TS,Digits))
              {                           // ..то модифицируем его:
               SL=Bid-TS;                 // Новый его StopLoss
               Modify=true;               // Назначен к модифи.
              }
            break;                        // Выход из switch
         case 1 :                         // Ордер Sell
            if (NormalizeDouble(SL,Digits)>// Если выше желаемого..
               NormalizeDouble(Ask+TS,Digits)||
               NormalizeDouble(SL,Digits)==0)//.. или нулевой(!)
              {                           // ..то модифицируем его
               SL=Ask+TS;                 // Новый его StopLoss
               Modify=true;               // Назначен к модифи.
              }
        }                                 // Конец switch
      if (Modify==false)                  // Если его не надо модифи..
         continue;                        // ..то идём по циклу дальше
      bool Ans=OrderModify(Ticket,Price,SL,TP,0);//Модифицируем его!
      //--------------------------------------------------------- 5 --
      if (Ans==false)                     // Не получилось :(
        {                                 // Поинтересуемся ошибками:
         if(Errors(GetLastError())==false)// Если ошибка непреодолимая
            return;                       // .. то уходим.
         i--;                             // Понижение счётчика
        }
      Terminal();                         // Функция учёта ордеров
      Events();                           // Отслеживание событий
     }
   return;                                // Выход из пользов. функции
  }
//--------------------------------------------------------------- 6 --

В блоках 1-3 описаны глобальные переменные, используемые в функции, а также открыты и описаны локальные переменные. В цикле for (блоки 3-6) выполняется отбор ордеров заданного типа, и если StopLoss какого-либо из этих ордеров находится дальше от текущей цены, чем задано пользователем, этот ордер модифицируется.

Для облегчения восприятия кода значения некоторых элементов массива ордеров Mas_Ord_New присваиваются простым переменным (блок 3-4). Далее для переменной TralingStop выполняется необходимая проверка: если значение этой переменной меньше минимально допустимой дистанции, установленной дилинговым центром, то оно увеличивается до минимально допустимой величины.

В блоке 4-5, в зависимости от типа ордера, выполняются необходимые вычисления. Например, если значение передаваемого параметра Tip равно 1 (необходимо модифицировать ордер Sell), то управление передаётся на метку case 1 оператора switch. Здесь выполняется проверка необходимости модификации StopLoss ордера (в соответствии с правилами, применяемыми для ордера этого типа, см. Требования и ограничения торговых операций). Если StopLoss вообще не установлен или находится дальше от текущего курса, чем на величину дистанции TralingStop, то вычисляется желаемое новое значение StopLoss. Торговый приказ для модификации ордера формируется в строке:

      bool Ans = OrderModify(Ticket,Price,SL,TP,0);//Модифицируем его!

Ранее отмечалось, что рассматриваемая здесь торговая стратегия предполагает наличие только одного рыночного ордера. Тем не менее, функция Tral_Stop() предусматривает возможность модификации нескольких рыночных ордеров одного типа. Если трейдер не вмешивается в торговлю во время работы эксперта, то необходимость модифицировать несколько ордеров не возникает. Однако для случая, когда трейдер допускает открытие рыночного ордера вручную (в дополнение к уже имеющемуся), возникает вопрос о порядке модификации ордеров, а именно, какой из них необходимо модифицировать раньше других и почему.

При рассмотрении порядка закрытия нескольких ордеров было указано, что критерием, определяющим приоритет закрытия ордеров, является количество лотов. Такое решение очевидно - чем больше лотов (из суммарного количества) будет закрыто, тем быстрее будет реакция эксперта на срабатывание признака закрытия. Вопрос о порядке модификации ордеров не имеет однозначного решения. Во всех случаях критерий для определения порядка модификации ордеров диктуется сущностью торговой стратегии. Таким критерием может быть не только количество лотов, но и факт отсутствия StopLoss на каком-либо из ордеров, размер дистанции от StopLoss до текущей цены. В ряде случаев критерием может выступать обобщённый показатель - размер убытка, который может быть получен при резком изменении цены, т.е. при условии одномоментного автоматического закрытия всех рыночных ордеров по StopLoss.

В рассматриваемом примере функции Tral_Stop() реализован случайный порядок модификации ордеров - ордера модифицируются в той последовательности, в которой они встречаются в списке открытых рыночных и установленных отложенных ордеров. В каждом конкретном случае функцию необходимо доработать - запрограммировать порядок модификации ордеров в соответствии с правилами конкретной стратегии.

Особое внимание нужно обратить на тот факт, что все торговые операции совершаются в режиме реального времени. Если ордеров слишком много, то эксперт будет генерировать множество торговых приказов. За время, пока эти приказы будут исполнены, рынок может развернуться. Однако функция не возвращает управление в вызывающую её функцию Trade() до тех пор, пока не будут модифицированы все ордера, подлежащие модификации. Это значит, что возникает опасность пропустить торговый приказ на закрытие или открытие ордеров. По этой причине любая стратегия должна составляться таким образом, чтобы по возможности не допускать значительного количества рыночных ордеров.

В блоке 5-6 выполняется анализ ошибок, полученных при исполнении торговых приказов. Если ошибка является критической, то функция заканчивает работу. Если же получена преодолимая ошибка, то значение счётчика i понижается на 1. Это делается для того, чтобы на очередной итерации цикла for была предпринята ещё одна попытка модифицировать тот же ордер.

В большинстве случаев представленный код будет удовлетворять потребности модификации нескольких ордеров. Вместе с тем, если в период нескольких неудачных попыток модификации в составе ордеров произойдут изменения (например, какой-то из ордеров будет закрыт при достижения рыночной ценой одного из стоп-приказов), то порядок ордеров в массиве Mas_Ord_New может измениться. Это приведёт к тому, что какой-то ордер может быть пропущен и не модифицирован в период последнего запуска специальной функции start(). Ситуация может быть исправлена на следующем тике, при очередном запуске функции start().

Функция определения торговых критериевФункция обработки ошибок


О сложных программах - Учебник по MQL4

Учебник по MQL4 [image] О сложных программах
  • Предисловие
  • Содержание
  • Введение в MQL4
  • Основы языка
  • Редактор MetaEditor
  • Программа на MQL4
  • Операторы
  • Переменные
  • Программирование на MQL4
  • Торговые операции
  • Простые программы на MQL4
  • Стандартные функции
  • Создание обычной программы
  • О сложных программах
  • Приложения
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Общая характеристика сложных программ

Какого-либо одного формального признака, отличающего обычную программу от сложной, не существует. В целом, сложные программы выгодно отличаются разнообразием предоставляемого сервиса и количеством обрабатываемой информации. Возможно обозначить лишь некоторые качественные характеристики, свойственные сложной программе.

Порядок исполнения программы

Как правило, в обычной программе основной код сосредоточен в специальной функции start(), запускаемой на исполнение клиентским терминалом. В подавляющем большинстве случаев время исполнения функции start() значительно меньше периода между тиками. Это значит, что большую часть времени программа "простаивает" в ожидании тика. Подобные процессы характеризуются скважностью. Скважность - это отношение периода повторяющегося процесса к длительности самого процесса. Время исполнения специальной функции start() Т1 составляет приблизительно от 10 до 100 миллисекунд, а время Т2 между тиками в среднем равно 5 секундам. Таким образом, работа эксперта характеризуется скважностью, достигающей Т2/Т1=1000 и более (см. Рис. 159). Иными словами, обычный работающий эксперт выполняет полезную работу в течение 0,1% всего времени, а всё остальное время простаивает.

Иногда в эксперте могут выполняться сложные расчёты, в результате чего время исполнения функции start() может быть большим, достигать десятков секунд. В таких случаях start() запускается на исполнение не на каждом тике, а лишь на тех тиках, которые приходят в момент, когда start() находится в режиме ожидания тика. На Рис. 159 показано, что тик, пришедший в период исполнения start(), а именно в момент t 4, не приводит к новому запуску специальной функции, и в следующий раз start() запускается в момент t 5. При этих условиях также возникает пауза между окончанием текущего исполнения и началом следующего исполнения функции start().

Рис. 159 Различная скважность при исполнении функции start(),
запускаемой клиентским терминалом, и зацикленной функции start().

Существует способ существенно увеличить время полезной работы программы, понизив, таким образом, скважность процесса управления торговлей. Для этого в программе необходимо реализовать алгоритм, согласно которому основной код многократно (бесконечно) повторяется при исполнении специальной функции start() (допустимо только в экспертах и скриптах). Ниже представлен пример зацикленной специальной функции start():

//--------------------------------------------------------------------
start()                    // Специальная функция start()
   {
   while(!IsStopped())     // До тех пор, пока пользователь..
      {                    // ..не прекратит исполнение программы
      RefreshRates();      // Обновление данных
      //......................Здесь указывается основной код программы
      Sleep(5);            // Небольшая пауза
      }
   return;                 // Управление возвращается терминалу
   }
//--------------------------------------------------------------------

Весь основной код указывается в теле оператора цикла while, а единственным условием выхода из цикла является получение от клиентского терминала команды на завершение программы. Если функцию start(), построенную на указанном принципе, запустить на исполнение, то она будет исполняться бесконечно долго и вернёт управление клиентскому терминалу только в тот момент, когда пользователь вручную отсоединит программу из окна финансового инструмента или при некоторых других условиях (см. Свойства специальных функций).

Исполнение зацикленной функции start() выполняется непрерывно, поэтому не существует и периода, в течение которого программа находится в режиме ожидания нового тика (см. Рис. 159), поэтому скважность процесса исполнения зацикленной программы равна 1. Функция start(), основанная на указанном принципе, запускается клиентским терминалом на исполнение всего один раз. Это значит, что обновление данных (например, рыночных котировок) необходимо выполнять принудительно, используя функцию RefreshRates(). Для того, чтобы процесс вычислений не потреблял много ресурсов, в конце тела цикла можно указать небольшую паузу.

Проектирование зацикленной программы требует повышенного внимания при составлении алгоритма. Например, реакцией обычной программы на получение критической ошибки является прекращение исполнения функции start() и возврат управления клиентскому терминалу. Зацикленная программа в процессе работы постоянно удерживает управление, поэтому должна предусматривать другую реакцию, например, запрет на формирование торговых приказов в течение некоторого периода. Однако, временный запрет на торговлю не должен препятствовать исполнению программы. В течение всего времени исполнения программа должна обрабатывать все доступные сведения о событиях, в том числе, и управляющие воздействия пользователя. В целом, такая программа обладает несоизмеримо большей мощностью, чем обычная программа.

Предоставляемый сервис

Применение зацикленных программ имеет смысл только в том случае, если непрерывность исполнения программы полезно используется. Например, такая программа может обрабатывать управляющие действия трейдера. В качестве таких воздействий может использоваться изменение координат графических объектов или факт присоединения пользователем в окно финансового инструмента других программ - скриптов и индикаторов.

Если обычная программа может отреагировать на какие-либо события (в том числе, инициируемые пользователем), как правило, при очередном запуске функции start() на ближайшем тике, то зацикленная программа может обрабатывать все события моментально (!). В этом случае задержка может случиться лишь на непродолжительное время, не большее, чем время исполнения одного цикла функции start() (приблизительно не более 10 - 100 мс).

Сложная программа может использовать графические объекты для отображения характеристик ордера или правил его модификации. Например, обычно ордера всех типов отображаются в окне финансового инструмента линиями зелёного цвета, а стоп-приказы - красного цвета. При этом, если на экране одновременно отображается несколько ордеров, то определить зрительно какому ордеру принадлежит та или иная линия бывает затруднительно. Если же на каждую ордерную линию наложить графический объект "горизонтальная линия" нужного цвета и стиля, то отличать ордера и их стоп-приказы станет значительно удобнее.

Кроме того, факт изменения координат таких объектов может восприниматься программой, как руководство к действию. Например, если пользователь переместил горизонтальную линию, покрывающую отложенный ордер, на несколько пунктов вверх, то в результате этого события программа может сформировать и отправить на сервер торговый приказ, согласно которому ордер должен быть модифицирован, а именно, заявленная цена открытия увеличена на несколько пунктов (для моментального исполнения использование зацикленной программы обязательно). Таким образом, сложная программа может предоставлять возможность управления торговлей с помощью мыши.

В сложной программе могут также использоваться функции, предназначенные для модификации отдельно взятого стоп-приказа или заявленной цены открытия ордера. В случае, если подобная функция используется применительно к одной из ордерных линий, то вблизи ордерной линии может отображаться, например, графический объект "стрелка", свидетельствующий о факте активности функции.

Используя графические объекты возможно "настраивать" сценарий торгов. Например, установив на некотором удалении от текущего курса значок "Разворот" можно сообщить программе, что при достижении указанной цены необходимо закрыть рыночный ордер и открыть в противоположном направлении. Аналогичным способом можно указать программе предельные уровни модификации, цену закрытия ордера и пр. Использование графических объектов, отображающих настройки программы, значительно повышает информированность трейдера о происходящих и планируемых событиях.

В сложной программе используются также звуковые сигналы, поставленные в соответствие событиям. Использование в программе звуков позволяет трейдеру отлучаться от компьютера и ориентироваться в происходящих событиях по характеру звуковых сигналов (мелодии, озвученного текста и пр.).

Результативность торгов зачастую зависит от того, учитывалась ли в момент принятия торговых решений информация о времени опубликования важных экономических и политических новостей. Подавляющее большинство дилинговых центров еженедельно предоставляют трейдерам перечень новостей, планируемых на ближайшую неделю, с указанием их времени опубликования и важности. Информация о предстоящих событиях заносится в файл. Во время работы программа считывает информацию из файла и, в зависимости от степени важности предстоящих событий, принимает к исполнению тот или иной сценарий торгов. Например, программа может удалить отложенные ордера, модифицировать стоп-приказы рыночных ордеров и т.д. Незадолго до выхода очень важных новостей программа может полностью прекратить торговлю - закрыть все ордера, предварительно уведомив трейдера.

Автоматический и ручной режимы работы программы

Сложная программа характеризуется также более сложным алгоритмом обработки событий. В частности, такая программа, предполагает некоторую реакцию на вмешательство трейдера в торговлю. Например, если торговая стратегия допускает только один рыночный ордер, а трейдер вручную открыл ещё один, то сложная программа, во-первых, отслеживает подобные события, а во-вторых, начинает исполнять предусмотренную для этого случая часть алгоритма. Сначала программа может предупредить трейдера о несанкционированном вмешательстве в автоматическую торговлю и предложить самостоятельно удалить лишний ордер. Если этого не происходит, то программа (в зависимости от настроек) может либо удалить лишний ордер, либо выйти из режима автоматической торговли, предварительно уведомив трейдера.

В случае если программа запущена на исполнение в условиях, когда в торговле есть одновременно множество ордеров, то, в зависимости от настроек, принимаются нужные решения. Например, программа может закрыть все встречные ордера без согласования с трейдером. Если торговая стратегия не предусматривает отложенных ордеров, то они тоже удаляются в приоритетном порядке - сначала те, которые ближе к рыночному курсу, потом те, которые дороже и т.д.

После того, как трейдер в ручном режиме установил допускаемое торговой стратегией количество и качество ордеров, программа (в течение всего этого времени не переставая работать, отслеживая все изменения) может предложить трейдеру активизировать автоматический режим работы, и в случае, если трейдер соглашается, обозначить с помощью графических объектов разворачиваемый сценарий торгов.

Каждый трейдер имеет свой набор предпочтений при работе с программой. Одни трейдеры предполагают исполнение программы только в автоматическом режиме, другие - в полуавтоматическом режиме, а третьи предпочитают ручной режим. Правильно составленная программа должна удовлетворять все потребности, т.е. иметь ряд настроек, которые позволяют использовать программу в разных режимах. Например, в режиме ручной работы программа может выполнять роль консультанта - выводить текст, содержащий прямые рекомендации, а также графические объекты, отражающие направление тренда, прогнозируемые точки разворота и пр. При работе в полуавтоматическом режиме, программа может запрашивать у трейдера разрешение на открытие ордера, допускать вмешательство трейдера в управление ордерами (например, ручную модификацию стоп-приказов). Если же программа работает в автоматическом режиме, то любое вмешательство трейдера в торговлю может расцениваться как указание на переход в ручной или полуавтоматический режим работы.

Все указанные свойства программы можно реализовать на основе языка программирования MQL4, специально предназначенного для этой цели. Правильно составленная сложная программа обладает рядом неоспоримых достоинств, к которым трейдер легко привыкает и стремится использовать в торговле.

Функция обработки ошибокПриложения


Коды ошибок - Приложения - Учебник по MQL4

Учебник по MQL4 [image] Приложения [image] Коды ошибок
  • Словарь терминов
  • Типы торговых операций
  • Требования и ограничения при проведении торговых операций
  • Коды ошибок
  • Стили отображения индикаторных линий
  • Типы и свойства графических объектов
  • Звуковые файлы
  • Коды возврата функции MessageBox()
  • Идентификаторы функции MarketInfo()
  • Список программ
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Коды ошибок

GetLastError() - функция, возвращающая коды ошибок. Кодовые константы ошибок определены в файле stderror.mqh. Для вывода текстовых сообщений следует использовать функцию ErrorDescription(), определенную в файле stdlib.mqh.

Коды ошибок, возвращаемые торговым сервером или клиентским терминалом:

Константа | Значение | Описание
ERR_NO_ERROR | 0 | Нет ошибки
ERR_NO_RESULT | 1 | Нет ошибки, но результат неизвестен
ERR_COMMON_ERROR | 2 | Общая ошибка
ERR_INVALID_TRADE_PARAMETERS | 3 | Неправильные параметры
ERR_SERVER_BUSY | 4 | Торговый сервер занят
ERR_OLD_VERSION | 5 | Старая версия клиентского терминала
ERR_NO_CONNECTION | 6 | Нет связи с торговым сервером
ERR_NOT_ENOUGH_RIGHTS | 7 | Недостаточно прав
ERR_TOO_FREQUENT_REQUESTS | 8 | Слишком частые запросы
ERR_MALFUNCTIONAL_TRADE | 9 | Недопустимая операция нарушающая функционирование сервера
ERR_ACCOUNT_DISABLED | 64 | Счет заблокирован
ERR_INVALID_ACCOUNT | 65 | Неправильный номер счета
ERR_TRADE_TIMEOUT | 128 | Истек срок ожидания совершения сделки
ERR_INVALID_PRICE | 129 | Неправильная цена
ERR_INVALID_STOPS | 130 | Неправильные стопы
ERR_INVALID_TRADE_VOLUME | 131 | Неправильный объем
ERR_MARKET_CLOSED | 132 | Рынок закрыт
ERR_TRADE_DISABLED | 133 | Торговля запрещена
ERR_NOT_ENOUGH_MONEY | 134 | Недостаточно денег для совершения операции
ERR_PRICE_CHANGED | 135 | Цена изменилась
ERR_OFF_QUOTES | 136 | Нет цен
ERR_BROKER_BUSY | 137 | Брокер занят
ERR_REQUOTE | 138 | Новые цены
ERR_ORDER_LOCKED | 139 | Ордер заблокирован и уже обрабатывается
ERR_LONG_POSITIONS_ONLY_ALLOWED | 140 | Разрешена только покупка
ERR_TOO_MANY_REQUESTS | 141 | Слишком много запросов
ERR_TRADE_MODIFY_DENIED | 145 | Модификация запрещена, так как ордер слишком близок к рынку
ERR_TRADE_CONTEXT_BUSY | 146 | Подсистема торговли занята
ERR_TRADE_EXPIRATION_DENIED | 147 | Использование даты истечения ордера запрещено брокером
ERR_TRADE_TOO_MANY_ORDERS | 148 | Количество открытых и отложенных ордеров достигло предела, установленного брокером.

Коды ошибок выполнения MQL4 программы:

Константа | Значение | Описание
ERR_NO_MQLERROR | 4000 | Нет ошибки
ERR_WRONG_FUNCTION_POINTER | 4001 | Неправильный указатель функции
ERR_ARRAY_INDEX_OUT_OF_RANGE | 4002 | Индекс массива - вне диапазона
ERR_NO_MEMORY_FOR_FUNCTION_CALL_STACK | 4003 | Нет памяти для стека функций
ERR_RECURSIVE_STACK_OVERFLOW | 4004 | Переполнение стека после рекурсивного вызова
ERR_NOT_ENOUGH_STACK_FOR_PARAMETER | 4005 | На стеке нет памяти для передачи параметров
ERR_NO_MEMORY_FOR_PARAMETER_STRING | 4006 | Нет памяти для строкового параметра
ERR_NO_MEMORY_FOR_TEMP_STRING | 4007 | Нет памяти для временной строки
ERR_NOT_INITIALIZED_STRING | 4008 | Неинициализированная строка
ERR_NOT_INITIALIZED_ARRAYSTRING | 4009 | Неинициализированная строка в массиве
ERR_NO_MEMORY_FOR_ARRAYSTRING | 4010 | Нет памяти для строкового массива
ERR_TOO_LONG_STRING | 4011 | Слишком длинная строка
ERR_REMAINDER_FROM_ZERO_DIVIDE | 4012 | Остаток от деления на ноль
ERR_ZERO_DIVIDE | 4013 | Деление на ноль
ERR_UNKNOWN_COMMAND | 4014 | Неизвестная команда
ERR_WRONG_JUMP | 4015 | Неправильный переход
ERR_NOT_INITIALIZED_ARRAY | 4016 | Неинициализированный массив
ERR_DLL_CALLS_NOT_ALLOWED | 4017 | Вызовы DLL не разрешены
ERR_CANNOT_LOAD_LIBRARY | 4018 | Невозможно загрузить библиотеку
ERR_CANNOT_CALL_FUNCTION | 4019 | Невозможно вызвать функцию
ERR_EXTERNAL_EXPERT_CALLS_NOT_ALLOWED | 4020 | Вызовы внешних библиотечных функций не разрешены
ERR_NOT_ENOUGH_MEMORY_FOR_RETURNED_STRING | 4021 | Недостаточно памяти для строки, возвращаемой из функции
ERR_SYSTEM_BUSY | 4022 | Система занята
ERR_INVALID_FUNCTION_PARAMETERS_COUNT | 4050 | Неправильное количество параметров функции
ERR_INVALID_FUNCTION_PARAMETER_VALUE | 4051 | Недопустимое значение параметра функции
ERR_STRING_FUNCTION_INTERNAL_ERROR | 4052 | Внутренняя ошибка строковой функции
ERR_SOME_ARRAY_ERROR | 4053 | Ошибка массива
ERR_INCORRECT_SERIES_ARRAY_USING | 4054 | Неправильное использование массива-таймсерии
ERR_CUSTOM_INDICATOR_ERROR | 4055 | Ошибка пользовательского индикатора
ERR_INCOMPATIBLE_ARRAYS | 4056 | Массивы несовместимы
ERR_GLOBAL_VARIABLES_PROCESSING_ERROR | 4057 | Ошибка обработки глобальныех переменных
ERR_GLOBAL_VARIABLE_NOT_FOUND | 4058 | Глобальная переменная не обнаружена
ERR_FUNCTION_NOT_ALLOWED_IN_TESTING_MODE | 4059 | Функция не разрешена в тестовом режиме
ERR_FUNCTION_NOT_CONFIRMED | 4060 | Функция не подтверждена
ERR_SEND_MAIL_ERROR | 4061 | Ошибка отправки почты
ERR_STRING_PARAMETER_EXPECTED | 4062 | Ожидается параметр типа string
ERR_INTEGER_PARAMETER_EXPECTED | 4063 | Ожидается параметр типа integer
ERR_DOUBLE_PARAMETER_EXPECTED | 4064 | Ожидается параметр типа double
ERR_ARRAY_AS_PARAMETER_EXPECTED | 4065 | В качестве параметра ожидается массив
ERR_HISTORY_WILL_UPDATED | 4066 | Запрошенные исторические данные в состоянии обновления
ERR_TRADE_ERROR | 4067 | Ошибка при выполнении торговой операции
ERR_END_OF_FILE | 4099 | Конец файла
ERR_SOME_FILE_ERROR | 4100 | Ошибка при работе с файлом
ERR_WRONG_FILE_NAME | 4101 | Неправильное имя файла
ERR_TOO_MANY_OPENED_FILES | 4102 | Слишком много открытых файлов
ERR_CANNOT_OPEN_FILE | 4103 | Невозможно открыть файл
ERR_INCOMPATIBLE_ACCESS_TO_FILE | 4104 | Несовместимый режим доступа к файлу
ERR_NO_ORDER_SELECTED | 4105 | Ни один ордер не выбран
ERR_UNKNOWN_SYMBOL | 4106 | Неизвестный символ
ERR_INVALID_PRICE_PARAM | 4107 | Неправильный параметр цены для торговой функции
ERR_INVALID_TICKET | 4108 | Неверный номер тикета
ERR_TRADE_NOT_ALLOWED | 4109 | Торговля не разрешена
ERR_LONGS_NOT_ALLOWED | 4110 | Длинные позиции не разрешены
ERR_SHORTS_NOT_ALLOWED | 4111 | Короткие позиции не разрешены
ERR_OBJECT_ALREADY_EXISTS | 4200 | Объект уже существует
ERR_UNKNOWN_OBJECT_PROPERTY | 4201 | Запрошено неизвестное свойство объекта
ERR_OBJECT_DOES_NOT_EXIST | 4202 | Объект не существует
ERR_UNKNOWN_OBJECT_TYPE | 4203 | Неизвестный тип объекта
ERR_NO_OBJECT_NAME | 4204 | Нет имени объекта
ERR_OBJECT_COORDINATES_ERROR | 4205 | Ошибка координат объекта
ERR_NO_SPECIFIED_SUBWINDOW | 4206 | Не найдено указанное подокно
ERR_SOME_OBJECT_ERROR | 4207 | Ошибка при работе с объектом

Требования и ограничения при проведении торговых операцийСтили отображения индикаторных линий


Список программ - Приложения - Учебник по MQL4

Учебник по MQL4 [image] Приложения [image] Список программ
  • Словарь терминов
  • Типы торговых операций
  • Требования и ограничения при проведении торговых операций
  • Коды ошибок
  • Стили отображения индикаторных линий
  • Типы и свойства графических объектов
  • Звуковые файлы
  • Коды возврата функции MessageBox()
  • Идентификаторы функции MarketInfo()
  • Список программ
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Список программ

Эксперты:

Название | Описание со ссылкой на раздел
create.mq4 | Пример комментированного программного кода
simple.mq4 | Пример простого эксперта, исполнение специальных функций
possible.mq4 | Пример правильной структуры программы
incorrect.mq4 | Пример неправильной структуры программы
userfunction.mq4 | Простой пример применения пользовательской функции
onelevel.mq4 | Пример применения оператора if-else
twolevel.mq4 | Пример применения оператора if-else
twoleveloptim.mq4 | Пример применения оператора if-else
compoundcondition.mq4 | Пример применения оператора if-else
pricealert.mq4 | Пример применения оператора switch
predefined.mq4 | Обновление значения предопределённой переменной
countticks.mq4 | Пример применения глобальной переменной (счётчик тиков)
staticvar.mq4 | Пример применения статической переменной (счётчик тиков)
externvar.mq4 | Пример применения внешних переменных
globalvar.mq4 | Пример применения глобальных переменных клиентского терминала
stringarray.mq4 | Пример применения строкового массива данных
extremumprice.mq4 | Использование значений элементов массивов-таймсерий
newbar.mq4 | Вычисление факта образования нового бара (массив-таймсерия)
modifystoploss.mq4 | Модификация StopLoss рыночных ордеров
callindicator.mq4 | Вызов из эксперта функции технического индикатора
historybars.mq4 | Вызов из эксперта функции технического индикатора iMA()
callstohastic.mq4 | Вызов из эксперта функции технического индикатора iStochastic()
tradingexpert.mq4 | Простой эксперт. Структура, стратегия, алгоритм
shared.mq4 | Эксперт, вычисляющий торговые критерии на основе пользовательского индикатора
comment.mq4 | Вывод текста в верхний левый угол окна финансового инструмента
dialogue.mq4 | Эксперт, поддерживающий диалог с пользователем
grafobjects.mq4 | Эксперт, использующий графический объект OBJ_LABEL
moveobjects.mq4 | Эксперт, управляющий положением графического объекта
charts.mq4 | Эксперт, управляющий графическими объектами в подокнах окна финансового инструмента
strings.mq4 | Эксперт, управляющий графическими объектами для раскраски свечей
timebars.mq4 | Эксперт, выводящий время поступления тика и время открытия бара
bigbars.mq4 | Эксперт для поиска бара не менее заданной высоты
timeevents.mq4 | Эксперт, выполняющий некоторые действия при наступлении заданного времени
createfile.mq4 | Эксперт для создания файла расписания новостей
matrix.mq4 | Эксперт для транспонирование матрицы
сheck.mq4 | Ограничения прав при использовании программ, распространяемых на коммерческой основе
usualexpert.mq4 | Обычный эксперт, использующий включаемые файлы

Скрипты:

Название | Описание со ссылкой на раздел
pifagor.mq4 | Пример программы без пользовательской функции
gipo.mq4 | Пример применения пользовательской функции
fibonacci.mq4 | Пример применения оператора цикла while
sumtotal.mq4 | Пример применения оператора цикла for
rectangle.mq4 | Пример применения оператора break
area.mq4 | Пример применения оператора break
sheep.mq4 | Пример применения оператора continue
othersheep.mq4 | Пример применения оператора continue
barnumber.mq4 | Пример применения оператора switch
callfunction.mq4 | Пример применения пользовательской функции
countiter.mq4 | Счётчик циклов между тиками
arrayalert.mq4 | Пример инициализации массивов
simpleopen.mq4 | Простейший скрипт для открытия ордера
confined.mq4 | Скрипт с простейшим анализом ошибки
improved.mq4 | Скрипт может работать в окне любого финансового инструмента
mistaken.mq4 | Скрипт с ошибочной ценой открытия
conditions.mq4 | Скрипт для определения стоимости ордеров
openbuy.mq4 | Скрипт для открытия рыночного ордера Buy
openbuystop.mq4 | Скрипт для установки отложенного ордера BuyStop
closeorder.mq4 | Скрипт для закрытия одного из рыночных ордеров
deleteorder.mq4 | Скрипт для удаления одного из отложенных ордеров
closeby.mq4 | Скрипт для встречного закрытия ордеров
modifyorderprice.mq4 | Скрипт для модификации отложенного ордера
timetablenews.mq4 | Скрипт для считывания данных из файла и отображения графических объектов
deleteall.mq4 | Скрипт, удаляющий все глобальные переменные клиентского терминала

Индикаторы:

Название | Описание со ссылкой на раздел
userindicator.mq4 | Простой пользовательский индикатор (линии High и Low)
averagevalue.mq4 | Простой пользовательский индикатор (усреднение High и Low)
separatewindow.mq4 | Пользовательский индикатор в отдельном окне
displacement.mq4 | Смещение линий пользовательского индикатора по вертикали и горизонтали
roc.mq4 | Пользовательский индикатор скорости изменения цены
rocseparate.mq4 | Пользовательский индикатор скорости изменения цены в отдельном окне
indicatorstyle.mq4 | Индикатор, отображающий линию High
linelevel.mq4 | Индикатор, отображающий разницу High и Low
Inform.mq4 | Индикатор, создающий пустое подокно в окне финансового инструмента

Включаемые файлы:

Название | Описание со ссылкой на раздел
Variables.mqh | Включаемый файл, содержащий объявление глобальных переменных
Check.mqh | Функция ограничения прав использования программы
Terminal.mqh | Функция учёта ордеров
Inform.mqh | Функция для вывода сообщений в подокно, создаваемое индикатором Inform.mq4
Events.mqh | Функция слежения за событиями
Lot.mqh | Функция определения количества лотов
Criterion.mqh | Функция определения торговых критериев
Trade.mqh | Управляющая торговая функция
Close_All.mqh | Функция закрытия всех рыночных ордеров указанного типа
Open_Ord.mqh | Функция открытия одного рыночного ордера указанного типа
Tral_Stop.mqh | Функция модификации всех рыночных ордеров указанного типа
Errors.mqh | Функция обработки ошибок

Идентификаторы функции MarketInfo()


Словарь терминов - Приложения - Учебник по MQL4

Учебник по MQL4 [image] Приложения [image] Словарь терминов
  • Словарь терминов
  • Типы торговых операций
  • Требования и ограничения при проведении торговых операций
  • Коды ошибок
  • Стили отображения индикаторных линий
  • Типы и свойства графических объектов
  • Звуковые файлы
  • Коды возврата функции MessageBox()
  • Идентификаторы функции MarketInfo()
  • Список программ
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Словарь терминов

  • Алгоритм - точное предписание выполнить заранее определённую последовательность действий; управление в исполняемой программе передаётся в соответствии с алгоритмом.

  • Бар - графическая форма представления графика развития цены. Бар характеризуется: ценой открытия (Open), ценой закрытия (Close), максимальной ценой (High), минимальной ценой (Low), объёмом (Volume) и временем открытия (Time) (см. также Свеча).

  • Буфер - область памяти, содержащая численные значения индикаторного массива.

  • Валютный инструмент - валютная пара, например, EUR/USD, GBP/CHF; частный случай финансового инструмента.

  • Внешняя переменная - переменная, значение которой доступно из окна свойств программы; обладает свойствами глобальной переменной.

  • Встречный ордер - рыночный ордер, открытый в противоположном направлении по отношению к другому рыночному ордеру по тому же финансовому инструменту.
  • Встроенная функция - то же, что стандартная функция.

  • Вызов функции (то же, что обращение к функции) - запись, исполнение которой приводит к исполнению функции (см. также Описание функции).

  • Выражение - последовательность операндов и операций; запись в программе, вычисленное значение которой характеризуется типом данных.

  • Глобальная переменная - переменная, объявленная за пределами всех функций. Областью видимости глобальных переменных является вся программа.

  • Глобальная переменная клиентского терминала - переменная, значение которой доступно из всех прикладных программ, запущенных на клиентском терминале (сокращённо - GV-переменная).

  • Графический объект - изображение в окне финансового инструмента, которое можно выделить, переместить, изменить или удалить.

  • Двухсторонняя котировка - связанная пара рыночных цен, предлагаемых брокером для осуществления покупки и продажи активов по финансовому инструменту в текущий момент.

  • Заголовок функции - составная часть описания функции; состоит из указания типа возвращаемого значения, названия функции и списка формальных параметров. Список формальных параметров заключается в круглые скобки и располагается после названия.

  • Зацикливание - бесконечное повторяющееся выполнение операторов, составляющих тело цикла; критическая ситуация, возникающая в результате реализации ошибочного алгоритма.

  • Знак операции - предопределённый символ или группа символов, предписывающих выполнить некоторую операцию.

  • Идентификатор переменной - набор символов, состоящий из букв, цифр и знака подчеркивания, начинающийся с буквы, длиной не более 31 символа. То же, что Имя переменной и Название переменной.

  • Имя переменной - то же, что идентификатор переменной.

  • Индикатор - встроенная функция клиентского терминала или программа, составленная на языке MQL4; основным назначением индикаторов является отображение на экране индикаторных линий; у индикаторов отсутствует возможность осуществления торговых операций; различают пользовательские и технические индикаторы (см. также эксперт, советник и скрипт).

  • Индикаторная линия - графическое отображение на экране некоторой зависимости, построенной на основе численных значений, содержащихся в индикаторном массиве.

  • Индикаторный массив - одномерный массив, содержащий численные значения, в соответствии с которыми строится индикаторная линия.

  • Инициализация переменной - присвоение переменной значения, соответствующего её типу, при объявлении переменной.

  • Итерация - повторное выполнение некоторых вычислений; используется для обозначения факта исполнения программных строк, составляющих тело оператора цикла (см. Оператор цикла while и Оператор цикла for).

  • Комментарий - необязательная и неисполняемая часть программы.

  • Константа - составная часть программы; объект, имеющий значение.

  • Константное выражение - выражение, состоящее из констант и операций, например: 2+3*7 . Константное выражение вычисляется на этапе компиляции программы.

  • Локальная переменная - переменная, объявленная внутри какой-либо функции. Областью видимости локальных переменных является тело функции, в которой эта переменная объявлена.

  • Локальное время - время, установленное на локальном компьютере (см. также серверное время).

  • Массив - упорядоченный набор значений однотипных переменных, имеющих общее название. Различают одномерный и многомерный массивы. Максимально допустимое количество измерений в массиве - четыре. Допускаются массивы любых типов данных.

  • Название переменной - то же, что идентификатор переменной.

  • Нулевой бар - текущий бар, который ещё полностью не сформировался. В окне финансового инструмента нулевой бар отражается в крайней правой позиции.

  • Нормализованная цена - цена, округлённая с точностью до размера одного пункта по финансовому инструменту.

  • Нормальный выход из цикла - передача управления за пределы оператора цикла в результате исполнения условия, содержащегося в заголовке оператора цикла (см. также специальный выход из цикла).

  • Область видимости переменной - место в программе, в котором доступно значение переменной. Каждая переменная имеет свою область видимости (см. также локальная переменная и глобальная переменная).

  • Обращение к функции - то же, что Вызов функции.

  • Объявление переменной - первое упоминание переменной в программе. При объявлении переменной указывается её тип.

  • Операнд - константа, переменная, элемент массива или значение, возвращаемое функцией константа, переменная, элемент массива или значение, возвращаемое функцией (см. Вызов функции).

  • Оператор - составная часть программы; фраза алгоритмического языка, предписывающая определённый порядок преобразования информации. Различают простые и составные операторы.

  • Операция - действие, производимое над операндами (см. также знак операции).

  • Описание функции - именованная, обособленная часть программы, предназначенная для исполнения; состоит из двух основных частей - заголовка функции и тела функции; используется применительно к специальным и пользовательским функциям (см. Функции, Описание функции и оператор return и Специальные функции).

  • Отложенный ордер - торговый приказ на покупку или продажу активов по финансовому инструменту при достижении заданного значения цены. Отложенный ордер отражается в окне финансового инструмента и в окне "Терминал" до тех пор, пока он не преобразуется в рыночный ордер либо будет удалён (см. также рыночный ордер)

  • Переменная - составная часть программы; объект, имеющий название и значение.

  • Пользовательская функция - функция, созданная программистом (см. Функция).

  • Пользовательский индикатор - прикладная программа, составленная на языке MQL4, основным назначением которой является графическое отображение на экране рассчитанных зависимостей. Значения элементов индикаторных массивов пользовательского индикатора доступны другим прикладным программам через функцию iCustom() (см. также технический индикатор).

  • Предопределённая переменная - переменная с предопределённым названием, значение которой определяется клиентским терминалом и не может быть изменено программным способом (см. Предопределённые переменные).

  • Приведение типов - изменение (преобразование) типа значения операнда или выражения. Перед выполнением операций (кроме операций присваивания) происходит преобразование в тип, имеющий наибольший приоритет, а перед операциями присваивания - в целевой тип.

  • Прикладная программа - программа, написанная на языке MQL4, используемая в клиентском терминале MetaTrader 4; эксперт, скрипт или индикатор.

  • Пункт - единица измерения цены по финансовому инструменту (минимально возможное изменение цены, последняя значащая цифра в значении цены).

  • Рыночный ордер - исполненный приказ на покупку или продажу активов по финансовому инструменту. Рыночный ордер отображается в окне финансового инструмента и в окне "Терминал" до тех пор, пока не выполнен приказ на закрытие ордера (см. также отложенный ордер).

  • Свеча - графическая форма представления графика развития цены. Свеча характеризуется: ценой открытия (Open), ценой закрытия (Close), максимальной ценой (High), минимальной ценой (Low), объёмом (Volume) и временем открытия (Time). Различают чёрные и белые свечи (см. также бар).

  • Серверное время - время, установленное на сервере (см. также локальное время).

  • Скрипт - программа, составленная на языке MQL4; отличается свойствами специальной функции start(), вызываемой клиентским терминалом для исполнения один раз; назначением скриптов является выполнение любых операций, которые по их смыслу требуется выполнить один раз (см. также эксперт, советник и индикатор).

  • Советник - то же, что эксперт (см. также скрипт и индикатор).

  • Специальная функция - функция, имеющая одно из предопределённых имён (init(), start() и deinit()), вызываемая для исполнения клиентским терминалом и обладающая специальными собственными свойствами (см. специальные функции).

  • Специальный выход из цикла - передача управления за пределы оператора цикла в результате исполнения оператора break, содержащегося в теле оператора цикла (см. также нормальный выход из цикла).

  • Спред - разница между большей и меньшей ценой в двухсторонней котировке по финансовому инструменту, выраженная в пунктах.

  • Стандартная функция - то же, что Встроенная функция; функция, созданная разработчиками языка MQL4, имеющая предопределённое имя и свойства; описание стандартных функций в программе не указывается; свойства стандартных функций подробно описаны в справочной документации (см. Функции и Стандартные функции ).

  • Массив-таймсерия - массив с предопределённым названием (Open, Close, High, Low, Volume или Time), элементы которого содержат значения соответствующих характеристик исторических баров.

  • Таймфрейм - период времени, в течение которого формируется один ценовой бар; различают стандартные таймфреймы: М1, М5, М15, М30, Н1, Н4, D1, W1 и MN (1 мин, 5 мин, 15 мин, 30 мин, 1 час, 4 часа, 1 день, 1 неделя и 1 месяц, соответственно)

  • Тело функции - один или несколько операторов, являющих исполняемую часть описания функции.

  • Тело цикла - один или несколько операторов, обрамлённых фигурными скобками; располагается непосредственно после заголовка оператора цикла (см. Оператор цикла while и Оператор цикл а for).

  • Технический индикатор - составная часть информационно-торговой системы MetaTrader 4, встроенная функция, позволяющая графически отображать на экране определённую зависимость (см. также пользовательский индикатор).

  • Тик - событие, характеризующееся новой ценой по финансовому инструменту в некоторый момент времени.

  • Торговая операция - открытие, закрытие или модификации рыночных и отложенных ордеров.

  • Торговый приказ - приказ, сформированный программой или трейдером с целью осуществления торговой операции. Торговый приказ может быть исполнен на сервере и отклонён сервером или клиентским терминалом.

  • Трейдер - человек, который занимается торговлей на финансовых рынках с целью получения прибыли.

  • Управление - процесс выполнения действий, предопределённых алгоритмом программы и свойствами клиентского терминала. Управление может передаваться внутри программы от одной программной строки к другой, а также между программой и клиентским терминалом (см. Некоторые основные понятия).

  • Файловый описатель – уникальный номер файла, открытого исполняемой программой в текущий момент.

  • Файловый разделитель - специальный символ; запись, которая заносится в файл для разделения записей данных.

  • Файловый указатель - место в файле, с которого начинается чтение следующего значения. По мере прочтения данных файловый указатель смещается вправо на одну или несколько позиций.

  • Финансовый инструмент - название котируемого объекта.

  • Флаг - переменная, значение которой ставится в соответствие каким-либо событиям или фактам.

  • Формальные параметры - список переменных, указанных в заголовке описания функции (см. Функции и Описание функции и оператор return).

  • Формат оператора - набор правил форматирования, присущих виду оператора. Каждый вид оператора имеет свой формат (см. Операторы).

  • Функция - именованная, обособленная часть программы, описывающая порядок преобразования информации. Использование функции в программе предполагает наличие описания функции и вызова функции. Различают специальные, стандартные (встроенные) и пользовательские функции (см. Функции и Специальные функции ).

  • Эксперт - программа, составленная на языке MQL4; отличается свойствами специальной функции start(), вызываемой клиентским терминалом для исполнения на каждом тике; основным назначением экспертов является программное управление торговыми операциями (см. также советник, скрипт и индикатор).

  • Элемент массива - составная часть массива; индексированная переменная с одноимённым названием, имеющая некоторое значение.

  • Ask - большая из цен в двухсторонней котировке по финансовому инструменту, предлагаемая брокером.

  • Bid - меньшая из цен в двухсторонней котировке по финансовому инструменту, предлагаемая брокером.

  • Buy - рыночный ордер, определяющий покупку активов по финансовому инструменту.

  • BuyLimit - отложенный ордер на покупку активов по финансовому инструменту по цене ниже текущей. Ордер исполнится (преобразуется в рыночный ордер Buy), если цена Ask достигнет или окажется ниже цены, заявленной в ордере.

  • BuyStop - отложенный ордер на покупку активов по финансовому инструменту по цене, превышающей текущую цену. Ордер исполнится (преобразуется в рыночный ордер Buy), если цена Ask достигнет или окажется выше цены, заявленной в ордере.

  • GV-переменная - то же, что глобальная переменная клиентского терминала.

  • Sell - рыночный ордер, определяющий продажу активов по финансовому инструменту.

  • SellLimit - отложенный ордер на продажу активов по финансовому инструменту по цене, превышающей текущую цену. Ордер исполнится (преобразуется в рыночный ордер Sell), если цена Bid достигнет или окажется выше цены, заявленной в ордере.

  • SellStop - отложенный ордер на продажу активов по финансовому инструменту по цене ниже текущей. Ордер исполнится (преобразуется в рыночный ордер Sell), если цена Bid достигнет или окажется ниже цены, заявленной в ордере.

  • StopLoss - стоп-приказ; заявленная цена, по которой рыночный ордер будет закрыт при движении цены финансового инструмента в сторону убытков по ордеру.

  • TakeProfit - стоп-приказ; заявленная цена, по которой рыночный ордер будет закрыт при движении цены финансового инструмента в сторону прибыли по ордеру.
ПриложенияТипы торговых операций


Приложения - Учебник по MQL4

Учебник по MQL4 [image] Приложения
  • Словарь терминов
  • Типы торговых операций
  • Требования и ограничения при проведении торговых операций
  • Коды ошибок
  • Стили отображения индикаторных линий
  • Типы и свойства графических объектов
  • Звуковые файлы
  • Коды возврата функции MessageBox()
  • Идентификаторы функции MarketInfo()
  • Список программ
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Приложения

  • Словарь терминов.
    Используемые понятия и выражения.
  • Типы торговых операций.
    Типы ордеров, которые могут быть использованы в клиентском терминале MetaTrader 4.
  • Требования и ограничения при проведении торговых операций.
    Некоторые ограничения на открытие, закрытие, изменение и удаление ордеров.
  • Коды ошибок.
    При работе программы возможно появление той или иной ошибки. Необходимо заранее предусмотреть правильную обработку наиболее важных ошибок. Получить код ошибки можно с помощью функции GetLastError().
  • Стили отображения индикаторных линий.
    Пользовательские индикаторы позволяют выводить графическую информацию при помощи разных стилей. Стиль DRAW_LINE может рисовать линии заданной толщины и стиля отрисовки. Для стиля DRAW_ARROW требуется задавать код отображаемой стрелки в кодировке Wingdings. Стиль DRAW_SECTION использует один индикаторный буфер, в то время как стиль DRAW_ZIGZAG требует два индикаторных буфера: четный и нечетный. Знание стилей рисований позволяет в одном индикаторе комбинировать различные методы отображения информации.
  • Типы и свойства графических объектов.
    Всего существует 24 встроенных графических объекта, которые можно создать программно. Такая возможность позволяет придавать индикаторам и советникам дополнительные богатые средства визуализации. Для каждого объекта можно задать как общие свойства, например, точки привязки и цвет объекта, так и свойства, которые характерны только для данного графического объекта. После изменения свойств объект можно незамедлительно (в принудительном порядке) перерисовать с помощью функции WindowsRedraw().
  • Звуковые файлы.
    Вы можете переопределить набор звуковых файлов, используемых в терминале MetaTrader 4. Для этого откройте окно "Сервис"-"Настройки", и в закладке "События" укажите нужные звуковые файлы. Прилагаемые файлы вы также можете проигрывать в своих программах с помощью функции PlaySound().
  • Коды возврата функции MessageBox.
    Функция MessageBox() позволяет организовать взаимодействие программы и пользователя непосредственно в процессе исполнения. Обработка кодов возврата окна MessageBox() позволяет направить работу программы в зависимости от нажатой пользователем кнопки, и таким образом, позволяет придать большую гибкость.
  • Идентификаторы запроса, используемые в функции MarketInfo().
    Функция MarketInfo() позволяет получать различную информацию о торговом счете, свойствах инструмента и настройках торгового сервера.
  • Список программ.
    Все программы, которые использовались в книге.
О сложных программахСловарь терминов


Требования и ограничения при проведении торговых операций - Приложения - Учебник по MQL4

Учебник по MQL4 [image] Приложения [image] Требования и ограничения при проведении торговых операций
MetaQuotes Sofware Corp.
  • Словарь терминов
  • Типы торговых операций
  • Требования и ограничения при проведении торговых операций
  • Коды ошибок
  • Стили отображения индикаторных линий
  • Типы и свойства графических объектов
  • Звуковые файлы
  • Коды возврата функции MessageBox()
  • Идентификаторы функции MarketInfo()
  • Список программ
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Требования и ограничения при проведении торговых операций

В таблицах указаны расчётные значения, ограничивающие проведение торговых операций при открытии, закрытии, установке, удалении и модификации ордеров.

Для получения значения минимальной дистанции StopLevel и дистанции заморозки FreezeLevel необходимо вызвать функцию MarketInfo().

Требования.

Правильные цены, используемые при осуществлении торговых операций.
Тип ордера | Цена открытия | Цена закрытия | Цена открытия для отложенного ордера | Преобразование отложенного ордера в рыночный
Buy | Ask | Bid |  |
Sell | Bid | Ask |  |
BuyLimit |  |  | Ниже текущей цены Ask | Ask достигает цены открытия
SellLimit |  |  | Выше текущей цены Bid | Bid достигает цены открытия
BuyStop |  |  | Выше текущей цены Ask | Ask достигает цены открытия
SellStop |  |  | Ниже текущей цены Bid | Bid достигает цены открытия

Возможность удаления отложенного ордера регламентируется параметром FreezeLevel.

Ограничение по минимальной дистанции StopLevel.

Торговая операция не осуществляется, если нарушено любое из указанных требований.

Тип ордера | Цена открытия ордера (OpenPrice) | StopLoss (SL) | TakeProfit (TP)
Buy | Модификация запрещена | Bid-SL ≥ StopLevel | TP-Bid ≥ StopLevel
Sell | Модификация запрещена | SL-Ask ≥ StopLevel | Ask-TP ≥ StopLevel
BuyLimit | Ask-OpenPrice ≥ StopLevel | OpenPrice-SL ≥ StopLevel | TP-OpenPrice ≥ StopLevel
SellLimit | Bid-OpenPrice ≥ StopLevel | SL-OpenPrice ≥StopLevel | OpenPrice-TP ≥ StopLevel
BuyStop | OpenPrice-Ask ≥ StopLevel | OpenPrice-SL ≥ StopLevel | TP-OpenPrice ≥ StopLevel
SellStop | Bid-OpenPrice ≥ StopLevel | SL-OpenPrice ≥ StopLevel | OpenPrice-TP ≥ StopLevel

Ограничение по дистанции заморозки FreezeLevel.

Закрытие рыночных ордеров не осуществляется, если значения StopLoss или TakeProfit нарушают требования по параметру FreezeLevel.
Модификация StopLoss или TakeProfit рыночных ордеров не осуществляется, если значения StopLoss или TakeProfit нарушают требования по параметру StopLevel.
Удаление и модификация отложенных ордеров не осуществляется, если заявленная цена открытия ордера нарушает требования по параметру Freezelevel.

Тип ордера | Цена открытия ордера(OpenPrice) | StopLoss (SL) | TakeProfit (TP)
Buy | Модификация запрещена | Bid-SL > FreezeLevel | TP-Bid > FreezeLevel
Sell | Модификация запрещена | SL-Ask > FreezeLevel | Ask-TP > FreezeLevel
BuyLimit | Ask-OpenPrice > FreezeLevel | Регламентируется параметром StopLevel | Регламентируется параметром StopLevel
SellLimit | OpenPrice-Bid > FreezeLevel | Регламентируется параметром StopLevel | Регламентируется параметром StopLevel
BuyStop | OpenPrice-Ask > FreezeLevel | Регламентируется параметром StopLevel | Регламентируется параметром StopLevel
SellStop | Bid-OpenPrice > FreezeLevel | Регламентируется параметром StopLevel | Регламентируется параметром StopLevel

Типы торговых операцийКоды ошибок


Идентификаторы функции MarketInfo() - Приложения - Учебник по MQL4

Учебник по MQL4 [image] Приложения [image] Идентификаторы функции MarketInfo()
MetaQuotes Sofware Corp.
  • Словарь терминов
  • Типы торговых операций
  • Требования и ограничения при проведении торговых операций
  • Коды ошибок
  • Стили отображения индикаторных линий
  • Типы и свойства графических объектов
  • Звуковые файлы
  • Коды возврата функции MessageBox()
  • Идентификаторы функции MarketInfo()
  • Список программ
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Идентификаторы функции MarketInfo()

Идентификаторы запроса, используемые в функции MarketInfo(), могут принимать следующие значения:

Константа | Значение | Описание
MODE_LOW | 1 | Минимальная дневная цена
MODE_HIGH | 2 | Максимальная дневная цена
MODE_TIME | 5 | Время поступления последней котировки
MODE_BID | 9 | Последняя поступившая цена предложения. Для текущего инструмента хранится в предопределенной переменной Bid
MODE_ASK | 10 | Последняя поступившая цена продажи. Для текущего инструмента хранится в предопределенной переменной Ask
MODE_POINT | 11 | Размер пункта в валюте котировки. Для текущего инструмента хранится в предопределенной переменной Point
MODE_DIGITS | 12 | Количество цифр после десятичного точки в цене инструмента. Для текущего инструмента хранится в предопределенной переменной Digits
MODE_SPREAD | 13 | Спрэд в пунктах
MODE_STOPLEVEL | 14 | Минимально допустимый уровень стоп-лосса/тейк-профита в пунктах
MODE_LOTSIZE | 15 | Размер контракта в базовой валюте инструмента
MODE_TICKVALUE | 16 | Размер минимального изменения цены инструмента в валюте депозита
MODE_TICKSIZE | 17 | Минимальный шаг изменения цены инструмента в пунктах
MODE_SWAPLONG | 18 | Размер свопа для длинных позиций
MODE_SWAPSHORT | 19 | Размер свопа для коротких позиций
MODE_STARTING | 20 | Календарная дата начала торгов (обычно используется для фьючерсов)
MODE_EXPIRATION | 21 | Календарная дата конца торгов (обычно используется для фьючерсов)
MODE_TRADEALLOWED | 22 | Разрешение торгов по указанному инструменту
MODE_MINLOT | 23 | Минимальный размер лота
MODE_LOTSTEP | 24 | Шаг изменения размера лота
MODE_MAXLOT | 25 | Максимальный размер лота
MODE_SWAPTYPE | 26 | Метод вычисления свопов. 0 - в пунктах; 1 - в базовой валюте инструмента; 2 - в процентах; 3 - в валюте залоговых средств.
MODE_PROFITCALCMODE | 27 | Способ расчета прибыли. 0 - Forex; 1 - CFD; 2 - Futures
MODE_MARGINCALCMODE | 28 | Способ расчета залоговых средств. 0 - Forex; 1 - CFD; 2 - Futures; 3 - CFD на индексы
MODE_MARGININIT | 29 | Начальные залоговые требования для 1 лота
MODE_MARGINMAINTENANCE | 30 | Размер залоговых средств для поддержки открытых позиций в расчете на 1 лот
MODE_MARGINHEDGED | 31 | Маржа, взимаемая с перекрытых позиций в расчете на 1 лот
MODE_MARGINREQUIRED | 32 | Размер свободных средств, необходимых для открытия 1 лота на покупку
MODE_FREEZELEVEL | 33 | Уровень заморозки ордеров в пунктах. Если цена исполнения находится в пределах, определяемых уровнем заморозки, то ордер не может быть модифицирован, отменен или закрыт.

Коды возврата функции MessageBox()Список программ


Коды возврата функции MessageBox() - Приложения - Учебник по MQL4

Учебник по MQL4 [image] Приложения [image] Коды возврата функции MessageBox()
MetaQuotes Sofware Corp.
  • Словарь терминов
  • Типы торговых операций
  • Требования и ограничения при проведении торговых операций
  • Коды ошибок
  • Стили отображения индикаторных линий
  • Типы и свойства графических объектов
  • Звуковые файлы
  • Коды возврата функции MessageBox()
  • Идентификаторы функции MarketInfo()
  • Список программ
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Коды возврата функции MessageBox()

Если окно сообщения имеет кнопку Отмена (Cancel), то функция возвращает значение IDCANCEL при нажатой клавише ESC или кнопке Отмена (Cancel). Если окно сообщения не имеет кнопки Отмена (Cancel), нажатие ESC не приводит ни к какому результату.

Константа | Значение | Описание
IDOK | 1 | Выбрана кнопка OK
IDCANCEL | 2 | Выбрана кнопка Отмена(Cancel)
IDABORT | 3 | Выбрана кнопка Прервать (Abort)
IDRETRY | 4 | Выбрана кнопка Повтор (Retry)
IDIGNORE | 5 | Выбрана кнопка Пропустить (Ignore)
IDYES | 6 | Выбрана кнопка Да (Yes)
IDNO | 7 | Выбрана кнопка Нет (No)
IDTRYAGAIN | 10 | Выбрана кнопка Повторить (Try Again)
IDCONTINUE | 11 | Выбрана кнопка Продолжить (Continue)

Эти коды возврата определены в файле WinUser32.mqh, поэтому необходимо включать этот заголовочный файл в программы через #include <WinUser32.mqh>.

Основные флаги функции MessageBox() определяют содержание и поведение диалогового окна. Это значение может быть комбинацией флагов из следующих групп флагов:

Константа | Значение | Описание
MB_OK | 0x00000000 | Окно сообщения содержит одну кнопку: OK. По умолчанию
MB_OKCANCEL | 0x00000001 | Окно сообщения содержит две кнопки: OK и Cancel
MB_ABORTRETRYIGNORE | 0x00000002 | Окно сообщения содержит три кнопки: Abort, Retry и Ignore
MB_YESNOCANCEL | 0x00000003 | Окно сообщения содержит три кнопки: Yes, No и Cancel
MB_YESNO | 0x00000004 | Окно сообщения содержит две кнопки: Yes и No
MB_RETRYCANCEL | 0x00000005 | Окно сообщения содержит две кнопки: Retry и Cancel
MB_CANCELTRYCONTINUE | 0x00000006 | Окно сообщения содержит три кнопки: Cancel, Try Again, Continue

Для отображения иконки в окне сообщения необходимо определить дополнительные флаги:

Константа | Значение | Описание
MB_ICONSTOP MB_ICONERROR MB_ICONHAND | 0x00000010 | Изображение знака STOP
MB_ICONQUESTION | 0x00000020 | Изображение вопросительного знака
MB_ICONEXCLAMATION MB_ICONWARNING | 0x00000030 | Изображение восклицательного знака
MB_ICONINFORMATION MB_ICONASTERISK | 0x00000040 | Изображение, состоящее из строчного знака i в круге

Кнопки по умолчанию задаются следующими флагами:

Константа | Значение | Описание
MB_DEFBUTTON1 | 0x00000000 | Первая кнопка MB_DEFBUTTON1 - кнопка выбрана по умолчанию, если MB_DEFBUTTON2, MB_DEFBUTTON3, или MB_DEFBUTTON4 не определены
MB_DEFBUTTON2 | 0x00000100 | Вторая кнопка - кнопка по умолчанию
MB_DEFBUTTON3 | 0x00000200 | Третья кнопка - кнопка по умолчанию
MB_DEFBUTTON4 | 0x00000300 | Четвертая кнопка - кнопка по умолчанию

Флаги поведения функции MessageBox() определены в файле WinUser32.mqh, поэтому необходимо включать этот заголовочный файл в программы через #include <WinUser32.mqh>. Здесь перечислены не все возможные флаги. Более подробную информацию можно получить в описании Win32 API.

Звуковые файлыИдентификаторы функции MarketInfo()


Типы и свойства графических объектов - Приложения - Учебник по MQL4

Учебник по MQL4 [image] Приложения [image] Типы и свойства графических объектов
MetaQuotes Sofware Corp.
  • Словарь терминов
  • Типы торговых операций
  • Требования и ограничения при проведении торговых операций
  • Коды ошибок
  • Стили отображения индикаторных линий
  • Типы и свойства графических объектов
  • Звуковые файлы
  • Коды возврата функции MessageBox()
  • Идентификаторы функции MarketInfo()
  • Список программ
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Типы и свойства графических объектов

Идентификаторы типов графических объектов используются в функциях ObjectCreate(), ObjectsDeleteAll() и ObjectType() и могут принимать следующие значения:

Тип объекта | Значение | Описание
OBJ_VLINE | 0 | Вертикальная линия. Использует время в качестве первой координаты, цена игнорируется.
OBJ_HLINE | 1 | Горизонтальная линия. Использует цену в качестве первой координаты, время игнорируется.
OBJ_TREND | 2 | Трендовая линия. Использует 2 координаты.
OBJ_TRENDBYANGLE | 3 | Трендовая линия по углу. Использует 2 координаты, либо первую координату и угол. Для установки угла линии (свойство OBJPROP_ANGLE) используется функция ObjectSet().
OBJ_REGRESSION | 4 | Канал линейной регрессии. Использует временные составляющие 2 координат, ценовые составляющие игнорируются.
OBJ_CHANNEL | 5 | Равноудаленный канал. Использует 3 координаты.
OBJ_STDDEVCHANNEL | 6 | Канал стандартных отклонений. Использует временные составляющие 2 координат, ценовые составляющие игнорируются.
OBJ_GANNLINE | 7 | Линия Ганна. Использует 2 координаты, но ценовая составляющая второй координаты игнорируется. Для установки соотношения между временной и ценовой шкалами (свойство OBJPROP_SCALE) используется функция ObjectSet().
OBJ_GANNFAN | 8 | Веер Ганна. Использует 2 координаты, но ценовая составляющая второй координаты игнорируется. Для установки соотношения между временной и ценовой шкалами (свойство OBJPROP_SCALE) используется функция ObjectSet().
OBJ_GANNGRID | 9 | Сетка Ганна. Использует 2 координаты, но ценовая составляющая второй координаты игнорируется. Для установки соотношения между временной и ценовой шкалами (свойство OBJPROP_SCALE) используется функция ObjectSet().
OBJ_FIBO | 10 | Уровни Фибоначчи. Использует 2 координаты. Для установки количества уровней (свойство OBJPROP_FIBOLEVELS) и значения уровней (свойство OBJPROP_FIRSTLEVEL+n) используется функция ObjectSet().
OBJ_FIBOTIMES | 11 | Временные зоны Фибоначчи. Использует 2 координаты. Для установки количества уровней (свойство OBJPROP_FIBOLEVELS) и значения уровней (свойство OBJPROP_FIRSTLEVEL+n) используется функция ObjectSet().
OBJ_FIBOFAN | 12 | Веер Фибоначчи. Использует 2 координаты. Для установки количества уровней (свойство OBJPROP_FIBOLEVELS) и значения уровней (свойство OBJPROP_FIRSTLEVEL+n) используется функция ObjectSet().
OBJ_FIBOARC | 13 | Дуги Фибоначчи. Использует 2 координаты. Для установки количества уровней (свойство OBJPROP_FIBOLEVELS) и значения уровней (свойство OBJPROP_FIRSTLEVEL+n) используется функция ObjectSet().
OBJ_EXPANSION | 14 | Расширение Фибоначчи. Использует 3 координаты. Для установки количества уровней (свойство OBJPROP_FIBOLEVELS) и значения уровней (свойство OBJPROP_FIRSTLEVEL+n) используется функция ObjectSet().
OBJ_FIBOCHANNEL | 15 | Канал Фибоначчи. Использует 3 координаты. Для установки количества уровней (свойство OBJPROP_FIBOLEVELS) и значения уровней (свойство OBJPROP_FIRSTLEVEL+n) используется функция ObjectSet().
OBJ_RECTANGLE | 16 | Прямоугольник. Использует 2 координаты.
OBJ_TRIANGLE | 17 | Треугольник. Использует 3 координаты.
OBJ_ELLIPSE | 18 | Эллипс. Использует 2 координаты. Для установки соотношения между временной и ценовой шкалами (свойство OBJPROP_SCALE) используется функция ObjectSet().
OBJ_PITCHFORK | 19 | Вилы Эндрюса. Использует 3 координаты.
OBJ_CYCLES | 20 | Временные ряды (циклические линии). Использует 2 координаты.
OBJ_TEXT | 21 | Текст. Использует 1 координату. Для установки угла выводимого текста (свойство OBJPROP_ANGLE) используется функция ObjectSet(). Для изменения текста используется функция ObjectSetText().
OBJ_ARROW | 22 | Стрелки (символы). Использует 1 координату. Для установки кода символа (свойство OBJPROP_ARROWCODE) используется функция ObjectSet().
OBJ_LABEL | 23 | Текстовая метка. Для установки координат, задаваемых в пикселях относительно угла привязки (свойства OBJPROP_CORNER, OBJPROP_XDISTANCE, OBJPROP_YDISTANCE), используется функция ObjectSet(). Для изменения текста используется функция ObjectSetText().

Идентификаторы свойств графических объектов используются в функциях ObjectGet() и ObjectSet(), могут принимать следующие значения:

Cвойства объекта | Значение | Тип | Описание
OBJPROP_TIME1 | 0 | datetime | Получает/устанавливает первую координату времени.
OBJPROP_PRICE1 | 1 | double | Получает/устанавливает первую координату цены.
OBJPROP_TIME2 | 2 | datetime | Получает/устанавливает вторую координату времени.
OBJPROP_PRICE2 | 3 | double | Получает/устанавливает вторую координату цены.
OBJPROP_TIME3 | 4 | datetime | Получает/устанавливает третью координату времени.
OBJPROP_PRICE3 | 5 | double | Получает/устанавливает третью координату цены.
OBJPROP_COLOR | 6 | color | Получает/устанавливает цвет объекта.
OBJPROP_STYLE | 7 | int | Получает/устанавливает стиль линии объекта.
OBJPROP_WIDTH | 8 | int | Получает/устанавливает ширину линии объекта.
OBJPROP_BACK | 9 | bool | Получает/устанавливает флаг фонового отображения объекта.
OBJPROP_RAY | 10 | bool | Получает/устанавливает флаг свойства луч для объектов типа OBJ_TREND и ему подобных.
OBJPROP_ELLIPSE | 11 | bool | Получает/устанавливает флаг отображения полного эллипса для объекта OBJ_FIBOARC.
OBJPROP_SCALE | 12 | double | Получает/устанавливает значение масштаба объекта.
OBJPROP_ANGLE | 13 | double | Получает/устанавливает значение угла в градусах объекта OBJ_TRENDBYANGLE.
OBJPROP_ARROWCODE | 14 | int | Получает/устанавливает код стрелки объекта OBJ_ARROW. Может быть одним из символов wingdings или один из предопределенных кодов стрелок.
OBJPROP_TIMEFRAMES | 15 | int | Получает/устанавливает свойство отображения объекта на различных периодах. Может быть одним или комбинацией нескольких из констант видимости объекта.
OBJPROP_DEVIATION | 16 | double | Получает/устанавливает размер отклонения для объекта OBJ_STDDEVCHANNEL.
OBJPROP_FONTSIZE | 100 | int | Получает/устанавливает размер шрифта для объектов OBJ_TEXT и OBJ_LABEL.
OBJPROP_CORNER | 101 | int | Получает/устанавливает номер угла привязки для объекта OBJ_LABEL. Принимает значения 0-3.
OBJPROP_XDISTANCE | 102 | int | Получает/устанавливает расстояние X-координаты в пикселях относительно угла привязки для объекта OBJ_LABEL.
OBJPROP_YDISTANCE | 103 | int | Получает/устанавливает расстояние Y-координаты в пикселях относительно угла привязки для объекта OBJ_LABEL.
OBJPROP_FIBOLEVELS | 200 | int | Получает/устанавливает число уровней объекта Fibonacci. Может быть от 1 до 32.
OBJPROP_LEVELCOLOR | 201 | color | Получает/устанавливает цвет линии уровня объекта
OBJPROP_LEVELSTYLE | 202 | int | Получает/устанавливает стиль линии уровня объекта.
OBJPROP_LEVELWIDTH | 203 | int | Получает/устанавливает ширину линии уровня объекта.
OBJPROP_FIRSTLEVEL+n | 210+n | int | Получает/устанавливает номер уровня объекта, где n - индекс устанавливаемого/получаемого уровня. Может быть от 0 до 31.

Стили отображения индикаторных линийЗвуковые файлы


Звуковые файлы - Приложения - Учебник по MQL4

Учебник по MQL4 [image] Приложения [image] Звуковые файлы
  • Словарь терминов
  • Типы торговых операций
  • Требования и ограничения при проведении торговых операций
  • Коды ошибок
  • Стили отображения индикаторных линий
  • Типы и свойства графических объектов
  • Звуковые файлы
  • Коды возврата функции MessageBox()
  • Идентификаторы функции MarketInfo()
  • Список программ
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Звуковые файлы

Набор звуковых файлов, рекомендуемых для использования в практической работе в экспертах, скриптах и индикаторах:

Название файла | Рекомендуемое условие использования
Close_order.wav | Закрытие рыночного ордера
Ok.wav | Удачное завершение торговой операции
Transform.wav | Преобразование отложенного ордера в рыночный
Bulk.wav | Незначительные события
Inform.wav | Различная информация (изменение условий торговли и пр.)
Oops.wav | Критическая информация (не хватает средств и пр.) или недопустимое действие
Expert.wav | Отдан торговый приказ
Error.wav | Неудачное завершение торговой операции
Bzrrr.wav | Другие ошибки
Wait.wav | Пауза
Work.wav | Установлены необходимые программы и файлы
Tick.wav | Новый тик
W1.wav | Другие условия
W2.wav | Другие условия
W3.wav | Другие условия

Резкие, контрастные звуки, а также звуки большой длительности использовать не рекомендуется.

Типы и свойства графических объектовКоды возврата функции MessageBox()


Стили отображения индикаторных линий - Приложения - Учебник по MQL4

Учебник по MQL4 [image] Приложения [image] Стили отображения индикаторных линий
MetaQuotes Sofware Corp.
  • Словарь терминов
  • Типы торговых операций
  • Требования и ограничения при проведении торговых операций
  • Коды ошибок
  • Стили отображения индикаторных линий
  • Типы и свойства графических объектов
  • Звуковые файлы
  • Коды возврата функции MessageBox()
  • Идентификаторы функции MarketInfo()
  • Список программ
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Стили отображения индикаторных линий

Стили рисования индикаторных линий для функций SetIndexStyle() и SetLevelStyle():

Константа | Значение | Описание
DRAW_LINE | 0 | Простая линия
DRAW_SECTION | 1 | Отрезки между непустыми значениями линии
DRAW_HISTOGRAM | 2 | Гистограмма
DRAW_ARROW | 3 | Стрелки (символы)
DRAW_ZIGZAG | 4 | Отрезки между непустыми значениями чётной и нечётной линий (зигзаг)
DRAW_NONE | 12 | Отсутствие какого-либо рисования

Стиль линии. Используется только при толщине линии 0 или 1:

Константа | Значение | Описание
STYLE_SOLID | 0 | Сплошная линия
STYLE_DASH | 1 | Штриховая линия
STYLE_DOT | 2 | Пунктирная линия
STYLE_DASHDOT | 3 | Штрих-пунктирная линия
STYLE_DASHDOTDOT | 4 | Штрих-пунктирная линия с двойными точками

Коды ошибокТипы и свойства графических объектов


Типы торговых операций - Приложения - Учебник по MQL4

Учебник по MQL4 [image] Приложения [image] Типы торговых операций
MetaQuotes Sofware Corp.
  • Словарь терминов
  • Типы торговых операций
  • Требования и ограничения при проведении торговых операций
  • Коды ошибок
  • Стили отображения индикаторных линий
  • Типы и свойства графических объектов
  • Звуковые файлы
  • Коды возврата функции MessageBox()
  • Идентификаторы функции MarketInfo()
  • Список программ
MetaTrader 4 download
Скачайте клиентский терминал MetaTrader 4 (размер 3.5 Mb)

Типы торговых операций

Тип операции в функции OrderSend() может быть указан в виде предопределённой константы или её значения и в соответствии с типом торговой операции:

Константа | Значение | Торговая операция
OP_BUY | 0 | Покупка
OP_SELL | 1 | Продажа
OP_BUYLIMIT | 2 | Отложенный ордер BUY LIMIT
OP_SELLLIMIT | 3 | Отложенный ордер SELL LIMIT
OP_BUYSTOP | 4 | Отложенный ордер BUY STOP
OP_SELLSTOP | 5 | Отложенный ордер SELL STOP

Словарь терминовТребования и ограничения при проведении торговых операций